Ubuntu

Some free applications looks like paid applications with price 0.00 and with buy button

Reported by Nicholas Shatokhin on 2012-03-30
320
This bug affects 63 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
High
Unassigned
Ubuntu Software Center
Undecided
Unassigned
unity-lens-applications
Medium
Unassigned
software-center (Ubuntu)
High
Unassigned
unity-lens-applications (Ubuntu)
High
Unassigned

Bug Description

Just watch an attachment screenshot. Pages of some free applications looks like as pages of paid applications, but with zero price.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: software-center 5.1.13.2
ProcVersionSignature: Ubuntu 3.2.0-17.27-generic-pae 3.2.6
Uname: Linux 3.2.0-17-generic-pae i686
ApportVersion: 1.95-0ubuntu1
Architecture: i386
Date: Fri Mar 30 11:19:48 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta i386 (20120301)
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=uk_UA.UTF-8
 SHELL=/bin/bash
SourcePackage: software-center
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

lp:~mvo/software-center/lp968974
On hold for merging into lp:software-center
Matthew Paul Thomas: Needs Fixing (design) on 2012-04-13
Natalia Bidart: Approve on 2012-04-12
Nicholas Shatokhin (robotex) wrote :
Michael Vogt (mvo) on 2012-04-03
Changed in software-center (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
milestone: none → ubuntu-12.04
Changed in software-center (Ubuntu Precise):
status: Confirmed → Triaged
Matthew Paul Thomas (mpt) wrote :

Specification updated. <https://wiki.ubuntu.com/SoftwareCenter?action=diff&rev2=623&rev1=622> "If the item is not installed nor queued for installation, the price of the item (e.g. 'Free') at the leading end, and a button at the trailing end: 'Buy…' if installation requires sign-in and payment, 'Install…' if it requires sign-in only, or 'Install' if it requires neither."

I don't think varying "Install" to "Install…" is worth breaking string freeze for Pangolin.

Michael Vogt (mvo) on 2012-04-12
Changed in software-center (Ubuntu Precise):
status: Triaged → In Progress
Michael Vogt (mvo) wrote :

Unfortunately the changes in lp:~mvo/software-center/lp968974 are not sufficient and this needs more work, see
the code review comments from kiwinote for the additional issues that needs fixing before this can land.

Changed in software-center (Ubuntu Precise):
milestone: ubuntu-12.04 → none
status: In Progress → Confirmed
tags: added: rls-q-incoming
Changed in software-center (Ubuntu Precise):
milestone: none → ubuntu-12.04.1
Changed in software-center (Ubuntu Quantal):
milestone: none → quantal-alpha-3
Stéphane Graber (stgraber) wrote :

Is this work still on schedule to land in 12.04.1? Who's working on it? (please assign the bug to whoever is supposed to work on it).

Changed in software-center (Ubuntu Quantal):
status: Confirmed → Triaged
Changed in software-center (Ubuntu Precise):
status: Confirmed → Triaged
Changed in software-center (Ubuntu Precise):
milestone: ubuntu-12.04.1 → ubuntu-12.04.2
anthony (ant-jens) on 2012-09-23
Changed in software-center (Ubuntu Precise):
status: Triaged → Fix Released
Colin Watson (cjwatson) on 2012-10-02
Changed in software-center (Ubuntu Quantal):
milestone: quantal-alpha-3 → ubuntu-12.10
Michal Hruby (mhr3) on 2012-10-12
Changed in unity-lens-applications:
status: New → Confirmed
Pawel Stolowski (stolowski) wrote :

This also affects application lens, as some apps display 'Buy Free' button in the preview in the dash, because software-center-dbus GetAppDetails() call returns price = "Free" and raw_price = "0.00". For consistency with other commercial apps, price in the app details data should say "US$ 0.00" (i.e. should be a formatted price) for those apps.

Cassidy James (cassidyjames) wrote :

Pawel, I disagree. I think it makes more sense to have the free apps simply be listed as "Free" then as $0. This is pretty standard convention in other app distribution models. However, they shouldn't say, "Buy Free" because that just doesn't make sense.

Chris Wilson (notgary) on 2012-11-15
Changed in hundredpapercuts:
milestone: none → raring-round-4
John Pugh (jpugh) on 2012-11-28
Changed in software-center (Ubuntu):
importance: Medium → High
Changed in software-center (Ubuntu Precise):
importance: Medium → High
John Pugh (jpugh) wrote :

@cassidyjames you and @stolowski have valid points. I think there needs to be delineation of "free to access" apps vs "go thru buy process" apps. For instance, apps in the "paid applications/commercial" status do require one to go through the buy process to validate a subscription whereas other apps that are not "commercial" do not. So technically "commercial" apps are not "free", but they are $0.00 requiring one to go through the purchase process which is simply a login to the pay system for validation.

Radko Dinev (radko-dinev) wrote :

The "Nitro" app shows "Free" and there's a "Buy..." button that takes me to sign in the payment service. So I kinda did a $0.00 purchase. Why was that and is that expected behavior? IMHO not the best UX and quite confusing even for a power user.

uwe (maabdulhaq) wrote :

Well, in non-english, there is yet another related issue, the ambiguity free/gratis does not nessessrly exist, the current situation probably enforces this ambiguity on other languages! I think a 0.00$ is ok; or Gratis.

John Pugh (jpugh) wrote :

@radko-dinev that is expected behavior. Nitro is a $0 app that is a proprietary license. It requires a $0 subscription hence the need to authenticate the access to the app.

Radko Dinev (radko-dinev) wrote :

@jpugh My point is you don't buy free things so the "Buy..." caption is misleading in conjunction with "Free".

tags: added: ca-escalated
Chris Wilson (notgary) wrote :

The Software Centre should be context-sensitive, so when you're looking at an app where price == 0.00, the option is to 'Install' with the price text shown as 'Free', and if price > 0.00, the option is to 'Buy', with the price text will be shown as the price.

Changed in hundredpapercuts:
status: New → Confirmed
importance: Undecided → High

This bug has a lot of duplicates, so the effect of this bug is fairly noticeable to several users. Still present in 13.04

@jpugh Login to verify "subscription" on a free "commercial" app does not make sense. It is also poorly aligned with the general F/OSS policy. If this behaviour is something forced on Canonical by the commercial companies behind these applications, then this should be clarified to the user, as to not appear as a forced recruitment for Ubuntu One.

I don't expect to have to accept additional terms of services, and create and login to an account to install FREE/GRATIS software on a F/OSS operating system. I hope the bug here is just the misplacing of the buy-button and the forced login that comes with it. If not, then we are done, Ubuntu. Then we are done.

Leonardo Donelli (learts92) wrote :

I think the whole software center should make more clear the distinction between Free Software (as in free speech), Free software (as in free beer, freeware) and commercial software with a price.
And when installing freeware software that requires sign on, it should alert that is just for "subscription" need, you're not paying anything. I remember, when installing Steam, I was kind of scared: I had to press a Buy button, even if the price was 0, and then sign in to my launchpad account without a help/explanation/apparent motive.

no longer affects: software-center (Ubuntu Precise)
no longer affects: software-center (Ubuntu Quantal)
Changed in unity-lens-applications (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Dave Morley (davmor2) on 2013-05-28
tags: added: u1-notrack
Changed in unity-lens-applications (Ubuntu):
status: Confirmed → Triaged
Changed in hundredpapercuts:
status: Confirmed → Triaged
Changed in software-center:
status: New → Confirmed
Changed in hundredpapercuts:
assignee: nobody → Paper Cuts Ninja (papercuts-ninja)
Norbert (nrbrtx) wrote :

This is not fixed in Ubuntu 12.04 and Gigalomania (as original bug-reporter said).
The source code of this game is freely available - so it's Free (as in freedom, not money) Software, licensed under GPL v2.

I can confirm all the content of Gigalomania is under a libre license, as said in http://homepage.ntlworld.com/mark.harman/comp_gigalomania.html.

tags: added: scopes-s
Changed in unity-lens-applications:
importance: Undecided → Medium

still present while downloading free game 'wakfu' through software center in 13.10 - asked to 'buy' and log into ubuntu one

all my comments are repeats of and agreements to the above; 'purchase' or 'buy' as a button never ever makes sense gramatically in English for obtaining a free product- there should be an 'install' button which is consistent with the rest of the software catalog. if the software catalog is having issues with free as in beer vs free as in speech, that's a shame, because it should be a bastion and showcase for apps that are free in both regards, as well as showing how free as in beer but closed source apps play well with their FOSS friends and alternatives. instead it seems the software center isn't even designed to showcase free, closed-source apps that should be a simple automated install :(

as usual, ubuntu doesn't have enough developers to keep up with 18 month old UX bugs, and the debian core remains usable while the ubuntu user experience looks well intentioned but unmaintained :/ not complaining, just lamenting- I have neither the time nor the experience to contribute more to ubuntu, and I don't expect others to pick up the slack. just making an observation that ubuntu's most polished features tend to appear as if they are perpetual alpha-builds.

Paddy Landau (paddy-landau) wrote :

@overprescribed: "… the software catalog … should be a bastion and showcase for apps that are free in both regards…"

Um…

There is no "should" in this regard. Remember that the target user for Ubuntu (which includes myself) doesn't give a hoot about libre vs. licensed. We only care that the products are cheap and that they work without malware.

If Ubuntu starts making a noise about libre vs. licensed, it will simply put off many LInux converts.

Changed in hundredpapercuts:
assignee: Papercuts Ninjas (papercuts-ninja) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions