No sound with intel-hda without "alsa force-reload"

Bug #449762 reported by Bernhard Gehl on 2009-10-12
64
This bug affects 10 people
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)
Undecided
Unassigned
sl-modem (Ubuntu)
Medium
Rolf Leggewie

Bug Description

Binary package hint: pulseaudio

This bug is probably a duplicate of #430711 or #411574 but I'll report it anyways for my specific hardware.

Since my upgrade to Karmic Beta, sound has not been working. Pulseaudio is convinced that there is no sound card to use and sets up a dummy device. After running "sudo alsa force-reload" (as described in #411574) sound works fine.

PCI IDs:
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
 Subsystem: LG Electronics, Inc. Device 0067
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0, Cache Line Size: 64 bytes
 Interrupt: pin A routed to IRQ 22
 Region 0: Memory at f8400000 (64-bit, non-prefetchable) [size=16K]
 Capabilities: <access denied>
 Kernel driver in use: HDA Intel
 Kernel modules: snd-hda-intel

The problem persists with the packages from the ubuntu audio ppa.

Anything else I should post?

ProblemType: Bug
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: bernhard 1957 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf8400000 irq 22'
   Mixer name : 'Realtek ALC880'
   Components : 'HDA:10ec0880,00001854,00100800 HDA:11c13026,11c13026,00100700'
   Controls : 36
   Simple ctrls : 21
Date: Mon Oct 12 20:32:10 2009
DistroRelease: Ubuntu 9.10
Package: pulseaudio 1:0.9.19-0ubuntu1
ProcEnviron:
 PATH=(custom, user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-13.44-generic
SourcePackage: pulseaudio
Uname: Linux 2.6.31-13-generic x86_64
mtime.conffile..etc.init.d.pulseaudio: 2009-10-12T16:41:21.379883

Mathijs Dumon (zandmathijsje) wrote :

Can you post the output of:
sudo fuser -v /dev/dsp* /dev/snd/*

I had this problem, and noticed the lirc daemon had hooked itself to the /dev/snd/ device, resulting in pulseaudio being unable to load my soundcard. After doing:

sudo update-rc.d -f lirc remove

Than I got sound after rebooting. Now I only need to get to start lirc after pulseaudio starts, but that's another problem

Mathijs Dumon (zandmathijsje) wrote :

I found another workaround for this problem: start pulseaudio system-wide instead of per-user. There is a good explenation of the steps involved here: http://www.alanbriolat.co.uk/2009/03/mpd-pulseaudio-ubuntu-intrepid-810/

Devices in /dev/snd are grabbed by slmodemd and cannot be used by pulseaudio until after "alsa force-reload".

affects: pulseaudio (Ubuntu) → sl-modem (Ubuntu)

Wow, that seems to be the right direction (and I'm learning about
linux):

After a (clean) boot (resulting in a "dummy device" sound output) fuser
gives the following:

$ sudo fuser -v /dev/dsp /dev/snd/*
                     USER PID ACCESS COMMAND
/dev/snd/controlC0: Slmodemd 1213 F.... slmodemd
/dev/snd/pcmC0D6c: Slmodemd 1213 F.... slmodemd
/dev/snd/pcmC0D6p: Slmodemd 1213 F.... slmodemd

Following a "alsa force-reload" the output changes to:

$ sudo fuser -v /dev/dsp /dev/snd/*
                     USER PID ACCESS COMMAND
/dev/snd/controlC0: bernhard 3827 F.... pulseaudio
/dev/snd/pcmC0D0c: bernhard 3827 F...m pulseaudio
/dev/snd/pcmC0D0p: bernhard 3827 F...m pulseaudio

Yupp I realize that I made a typo missing an asterisk behind dsp, but I
think the point is quite clear. At boot time, the smartlink modem daemon
grabs all of the audiodevices. So it seems this bug is not really the
fault of pulseaudio but of slmodemd!

AirIntake (bradkimak) wrote :

I have the exact same issue. My chip is a 82801H. There is no sound device listed when the issue happens. An alsa force-reload always works to get sound back. Sometimes the sound will even keep working for a reboot or two, but eventually it loses my sound device again and I have to do another alsa force-reload. This issue did NOT occur with 9.10, 9.04, and 8.10 on my system. It has occurred on my system after an upgrade from 9.04, and from a fresh install from the 9.10 beta cd.

AirIntake (bradkimak) wrote :

I meant to say it didn't happen with 9.04, 8.10, and 8.04 on my system.

Karunadheera (karunadheera) wrote :

The solution I found is to add the following entry to /etc/rc.local

/sbin/alsa force-reload

Tom (tompollak) wrote :

I also have same issue since upgrade of 9.10 beta from 9.04. My audio device is:

$ lspci
00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 04)

No sound device listed after boot:
$ sudo fuser -v /dev/dsp* /dev/snd/*
                     USER PID ACCESS COMMAND
/dev/snd/controlC0: Slmodemd 1108 F.... slmodemd
/dev/snd/pcmC0D6c: Slmodemd 1108 F...m slmodemd
/dev/snd/pcmC0D6p: Slmodemd 1108 F...m slmodemd

Then after $ sudo alsa force-reload sound is ok:
$ sudo fuser -v /dev/dsp* /dev/snd/*
                     USER PID ACCESS COMMAND
/dev/snd/controlC0: tom 7437 F.... pulseaudio

AirIntake (bradkimak) wrote :

@Karunadheera
Yeah, I'll probably do that until a real fix comes along.

AirIntake (bradkimak) wrote :

The issue just went away with one of the last updates. Nevermind.

I think this pulseaudio (1:0.9.19-0ubuntu3) upload fixed it, as I see this in its changelog:

 * debian/patches/0056-ignore-sound-class-modem.patch:
    + Apply patch from Whoopie to fix initialization of devices with
      modem subdevices (LP: #394500, #450222)

Changed in sl-modem (Ubuntu):
status: New → Invalid
AirIntake (bradkimak) wrote :

Nevermind again. The issue came back after working through 8 reboots. This problem is strange.

Assign the bug to pulseaudio again, since it is probably related to this issue.

Changed in sl-modem (Ubuntu):
status: Invalid → Confirmed

Bug is still there with pulseaudio 0.9.19-0ubuntu4, linux-backports-modules-alsa-karmic-generic 2.6.31.14.27. (Not nagging, just trying to help.)

When this symptom occurs, what is the output from the following
command _before_ you issue an "alsa force-reload"? sudo fuser -v
/dev/dsp* /dev/snd/* /dev/audio* /dev/mixer* /dev/seq*

AirIntake (bradkimak) wrote :

My output before an alsa force-reload is:

                     USER PID ACCESS COMMAND
/dev/snd/controlC0: Slmodemd 1393 F.... slmodemd
/dev/snd/pcmC0D6c: Slmodemd 1393 F.... slmodemd
/dev/snd/pcmC0D6p: Slmodemd 1393 F.... slmodemd

AirIntake (bradkimak) wrote :

My output after an alsa force-reload is:

                     USER PID ACCESS COMMAND
/dev/snd/controlC0: brad 2700 F.... pulseaudio
/dev/snd/pcmC0D0p: brad 2700 F...m pulseaudio

AirIntake (bradkimak) wrote :

My output when the sound still works after a reboot is:

                     USER PID ACCESS COMMAND
/dev/snd/controlC0: brad 1984 F.... pulseaudio

Daniel T Chen (crimsun) wrote :

Right, so your symptom is the same as others with the modem driver on the
same hw:X device. You have a number of options:

1) deinstall sl-modem-daemon;
2) use module-udev instead of module-udev-detect in
/etc/pulse/default.pa(or ~/.pulse/
default.pa);
3) continue to use alsa force-reload.

On Oct 26, 2009 8:20 PM, "AirIntake" <email address hidden> wrote:

My output after an alsa force-reload is:

                    USER PID ACCESS COMMAND
/dev/snd/controlC0: brad 2700 F.... pulseaudio
/dev/snd/pcmC0D0p: brad 2700 F...m pulseaudio

-- No sound with intel-hda without "alsa force-reload"
https://bugs.launchpad.net/bugs/449762 You ...

Status in “sl-modem” package in Ubuntu: Confirmed

Bug description: Binary package hint: pulseaudio This bug is probably a
duplicate of #430711 or #41...

Benjamim Gois (benjamim-gois) wrote :

Hey Daniel, Thanks for the tip. It fix my problem with Intel ICH8 sound. I just remove the Proprietary driver of my Dial-up Modem and everythink went back to normal. It doesn't need to reboot !

Next workaround: Set DONTSTART to "1" in /etc/default/slmodemd

What's the drawback of using module-udev?

Daniel T Chen (crimsun) wrote :

On Tue, Oct 27, 2009 at 4:31 PM, Bernhard Gehl <email address hidden> wrote:
> What's the drawback of using module-udev?

You lose hotplugging.

pixolex (pixolex) wrote :

Just to confirm that disabling the proprietary modem crap I have my sound back!

Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: rodger 1833 F.... pulseaudio
 /dev/snd/pcmC0D0p: rodger 1833 F...m pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf1200000 irq 22'
   Mixer name : 'Realtek ALC883'
   Components : 'HDA:10ec0883,15580721,00100002 HDA:10573055,10573055,00100700'
   Controls : 29
   Simple ctrls : 18
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
Package: sl-modem
PackageArchitecture: i386
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_GB.UTF-8
 LANGUAGE=en_GB.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-16.53-generic
Uname: Linux 2.6.31-16-generic i686
UserGroups: adm admin cdrom dialout lpadmin netdev plugdev sambashare
mtime.conffile..etc.pulse.daemon.conf: 2009-11-17T20:48:00

tags: added: apport-collected

Either use the PPA version of PA or deinstall your softmodem.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 1:0.9.22~0.9.21+341-g62bf-0ubuntu1

---------------
pulseaudio (1:0.9.22~0.9.21+341-g62bf-0ubuntu1) lucid; urgency=low

  * New snapshot based on stable-queue git branch (testing requested
    specifically by upstream)
    - LP: #164745, #173212, #201391, #204536, #207796, #210016, #221038,
    - LP: #226342, #230408, #236423, #237443, #250059, #269585, #274304,
    - LP: #274577, #275474, #277532, #277566, #277932, #278025, #280534,
    - LP: #283049, #286816, #287036, #292732, #298011, #298301, #300290,
    - LP: #302038, #311497, #311853, #324062, #339448, #344057, #348979,
    - LP: #350829, #356206, #367379, #367544, #369822, #371897, #374846,
    - LP: #375570, #381801, #399515, #402950, #403786, #408169, #409322,
    - LP: #409723, #410326, #410446, #417695, #417976, #419271, #421072,
    - LP: #422774, #423979, #424655, #425028, #427016, #431072, #432660,
    - LP: #437640, #437996, #442191, #443306, #443389, #446719, #449762,
    - LP: #455417, #461532, #464652, #483191, #497537, #503780
  * debian/patches/:
    + add: 0099-change-configure-git-version-tag.patch: Match released
           upstream 0.9.21 for shlibs and LIBPULSE_VERSION_INFO
    - drop: 0004-set-tsched0.patch (no longer relevant)
            0050-revert-pacmd-poll-argv.patch (no longer relevant)
            0056-dont-bail-on-sound-class-modem.patch (merged)
            0056-ignore-sound-class-modem.patch (merged)
            0058-Backport-4c793.patch (merged)
            0059-Backport-978d3.patch (merged)
            0060-fix-implicit-func-decl-cpu-arm.patch (merged)
            0061-Backport-c5fdb.patch (merged)
            0070-dont-bail-on-sound-class-modem-devs.patch (merged)
    + refresh: 0001-change-resample-and-buffering.patch
               0090-disable-flat-volumes.patch
               0091-dont-load-cork-music-on-phone.patch
               0057-load-module-x11-bell.patch
 -- Daniel T Chen <email address hidden> Thu, 14 Jan 2010 20:33:05 -0500

Changed in pulseaudio (Ubuntu):
status: New → Fix Released
Rolf Leggewie (r0lf) wrote :

Is there still anything left that needs to be done for sl-modem?

Changed in sl-modem (Ubuntu):
assignee: nobody → Rolf Leggewie (r0lf)
importance: Undecided → Medium
status: Confirmed → Incomplete
Daniel T Chen (crimsun) wrote :

No, it was a PulseAudio bug (already fixed in Lucid).

Changed in sl-modem (Ubuntu):
status: Incomplete → Invalid
Rolf Leggewie (r0lf) wrote :

Thanks, Daniel.

ex-oficio (wilkinson-luke) wrote :

i would just like to extend my sincere thanks to everone here. this bug has been DRIVING ME UP THE WALL for months since i upgraded to karmic.

i never thought it would be the modem, but disabling it has fixed the problem.

based on post #41 can i assume that in lucid it will work even with the modem driver enabled?

big thanks to all.

Daniel T Chen (crimsun) wrote :

Yes, it will.

UlfZibis (ulf-zibis) wrote :

Hi,
I experience this bug again with Ubuntu 14.10.
I need to do:
sudo alsa force-reload

To make it work permanently, I need to edit /etc/pulse/default.pa :
load-module module-alsa-sink device=hw:0
load-module module-alsa-source device=hw:0

Felix (apoapo) wrote :

Hi,
I experience this bug again with Ubuntu 18.10.
I need to do:
sudo alsa force-reload

Daniel van Vugt (vanvugt) wrote :

This bug is closed. If you have any problems at all then please open a new bug.

To post a comment you must log in.