[Maverick] Samba process gets hung on maverick update - waiting on cups to start

Bug #639768 reported by johny on 2010-09-15
218
This bug affects 39 people
Affects Status Importance Assigned to Milestone
cups (Ubuntu)
High
Unassigned
Maverick
High
Unassigned
samba (Ubuntu)
High
Mathias Gug
Maverick
High
Mathias Gug

Bug Description

LATEST AFFECTED VERSION: 2:3.5.4~dfsg-1ubuntu6

-----------------------------------------

Binary package hint: samba

On the last maverick update at the moment of configuring samba, the update-manager freezes.
The progress bar stops going forward and the terminal output gets stuck on the "Setting up samba" step. (please see the screenshot)

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: samba 2:3.5.4~dfsg-1ubuntu5
ProcVersionSignature: Ubuntu 2.6.35-20.29-generic 2.6.35.4
Uname: Linux 2.6.35-20-generic i686
Architecture: i386
Date: Wed Sep 15 19:06:19 2010
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SambaServerRegression: Yes
SourcePackage: samba

johny (johny454) wrote :
johny (johny454) wrote :

Update:

To solve the problem you need to stop samba service manually with "sudo service smbd stop", then to get back to the terminal, stop the command by pressing ctrl+c.

Serge Hallyn (serge-hallyn) wrote :

Thanks, Johny, and sorry you had trouble - do I understand that you've solved this problem?

Changed in samba (Ubuntu):
status: New → Incomplete
Michael (mstrelan) wrote :

I too had encountered this bug. I went to update manager and hit apply updates. It got stuck on setting up samba for half an hour until I followed johny's advice and type "sudo service smbd stop" in terminal. The updates then continued on their own after that.

johny (johny454) wrote :

Serge. Yes I did solve the problem, but the bug is still there.

johny (johny454) wrote :

what further info do we need to confirm this?

Michael (mstrelan) wrote :

I tried to copy and paste from the terminal output but it didn't work at the time. I started typing it out but the update finished while I was typing. In hindsight I should have taken a screenshot.

johny (johny454) wrote :

On attached screenshot you can see the terminal output, so you don't need this. I just wonder why it was labeled as "incomplete"

Michael (mstrelan) wrote :

I can confirm this was the exact output my terminal showed as well

Changed in samba (Ubuntu):
status: Incomplete → Confirmed
Micah Gersten (micahg) wrote :

This happened again on tonight's upgrade of Samba. Marking High since this has the potential to affect a lot of people upgrading to/upgrading Maverick.

Changed in samba (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
description: updated

This affected me also on two computers (64-bit). When manually stopping the smbd service the installation continued and Samba is now working. Now though Nautilus crashes each time I set shares straight from nautilus with extra permissions like let others write in the folder or guest access.

dino99 (9d9) wrote :

have had to remove a corrupted file (known when running sudo dpkg --configure -a) only fulfilled (around 500 lines) by #paddling

sudo rm /var/lib/dpkg/updates/0086

this 0086 file was the latest created into this folder. Then my system was unlocked but upgrading samba is still a problem (2:3.5.4~dfsg-1ubuntu6(maverick)

Jon Ebbesen (jon-ebbesen) wrote :

I´m unable to run sudo, since Ubuntu won´t boot in regular or recoverymode. The Ubuntu screen pops up followed shortly thereafter by a cursor and nothing happens..

Andrew Aylett (andrew-aylett) wrote :

I managed to progress my upgrade by killing the 'start' proces executed by samba.postinst. Opened a terminal, used `ps --ppid` to find the children of the upgrade process (and their children, and so on; would have used pstree but it didn't seem to like me) and discovered that it was the process holding things up.

The install hasn't finished yet, so I can't tell you whether everything's working, but it looks fine.

Thierry Carrez (ttx) on 2010-09-16
tags: added: server-mrs
Changed in samba (Ubuntu Maverick):
milestone: none → ubuntu-10.10
Thierry Carrez (ttx) on 2010-09-16
Changed in samba (Ubuntu Maverick):
assignee: nobody → Mathias Gug (mathiaz)
Sebastian (sebastinr) wrote :

I also stop the service with the "sudo service smbd stop" command and the installation process continue by itself without my intervention.

Mathias Gug (mathiaz) on 2010-09-16
summary: - Samba process gets hung on maverick update
+ [Maverick] Samba process gets hung on maverick update
Robbie Williamson (robbiew) wrote :

Attaching my log.smbd file that contains a lot of cups related errors.

Seems to be related to cups:

< cjwatson> there was that recent change to cups
< cjwatson> which made it 'start on starting smbd' or similar, I believe
< soren> Ah, so it's cups, maybe?
< cjwatson> misuse of 'and' in a way that's known to break upstart
< cjwatson> ++start on ((starting smbd or filesystem)
< cjwatson> ++ and started dbus
< cjwatson> ++ and stopped udevtrigger)
< robbiew> has CUPS related errors
< cjwatson> that means that when 'starting smbd' arrived, it will wait
            for dbus to start and udevtrigger to stop (since those edge
            events have long since come and gone at system boot)

Changed in cups (Ubuntu Maverick):
importance: Undecided → High
status: New → Triaged
milestone: none → ubuntu-10.10
summary: - [Maverick] Samba process gets hung on maverick update
+ [Maverick] Samba process gets hung on maverick update - waiting on cups
+ to start
Martin Pitt (pitti) on 2010-09-16
Changed in cups (Ubuntu Maverick):
assignee: nobody → Martin Pitt (pitti)
status: Triaged → In Progress
Changed in samba (Ubuntu Maverick):
milestone: ubuntu-10.10 → none
status: Triaged → Invalid
assignee: Mathias Gug (mathiaz) → nobody
Thierry Carrez (ttx) on 2010-09-16
tags: added: server-mro
removed: server-mrs
Martin Pitt (pitti) wrote :

cups (1.4.4-4ubuntu1) maverick; urgency=low

  * ubuntu-upstart.dpatch: Drop the dependency "on starting smbd", it causes
    samba to hang on package upgrades or manual restarts. There doesn't seem
    to be a good way to express this dependency right now. (LP: #639768)

 -- Martin Pitt <email address hidden> Thu, 16 Sep 2010 17:48:42 +0200

Changed in cups (Ubuntu Maverick):
assignee: Martin Pitt (pitti) → nobody
status: In Progress → Fix Released
Mathias Gug (mathiaz) on 2010-09-16
Changed in samba (Ubuntu Maverick):
status: Invalid → In Progress
assignee: nobody → Mathias Gug (mathiaz)
milestone: none → ubuntu-10.10
Mathias Gug (mathiaz) wrote :

samba (2:3.5.4~dfsg-1ubuntu7) maverick; urgency=low

  * debian/control: Add cups breaks to push the package manager to also
    upgrade cups (LP: #639768).

 -- Mathias Gug <email address hidden> Thu, 16 Sep 2010 12:19:11 -0400

Changed in samba (Ubuntu Maverick):
status: In Progress → Fix Released
Rick McBride (rmcbride) wrote :

I'm still seeing this hang with samba "samba_2%3a3.5.4~dfsg-1ubuntu7_amd64.deb"

This is after updating, purging the broken samba install and re-installing it.

Rick McBride (rmcbride) wrote :

Actually it seems to be hanging during 'samba.postinst configure' which is a different thing apparently.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers