rhythmbox crashed with SIGSEGV in _nss_wins_gethostbyname_r()

Bug #529714 reported by nloewen on 2010-02-28
682
This bug affects 110 people
Affects Status Importance Assigned to Milestone
samba
Confirmed
Medium
banshee (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Unassigned
Oneiric
Undecided
Unassigned
Precise
Undecided
Unassigned
eglibc (Ubuntu)
Low
Unassigned
Natty
Undecided
Unassigned
Oneiric
Undecided
Canonical Foundations Team
Precise
Undecided
Unassigned
samba (Ubuntu)
Critical
Chuck Short
Natty
Critical
Unassigned
Oneiric
Critical
Chuck Short
Precise
Undecided
Unassigned

Bug Description

Binary package hint: rhythmbox

rhythmbox crashes when trying to access the Ubuntu One music store.

ProblemType: Crash
Architecture: i386
Date: Sun Feb 28 16:05:20 2010
DistroRelease: Ubuntu 10.04
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/rhythmbox
Package: rhythmbox 0.12.6git20100223-0ubuntu1
ProcCmdline: rhythmbox
ProcEnviron:
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-14.20-generic
SegvAnalysis:
 Segfault happened at: 0x223f682 <_nss_wins_gethostbyname_r+914>: movl $0x0,(%eax)
 PC (0x0223f682) ok
 source "$0x0" ok
 destination "(%eax)" (0x00000000) not located in a known VMA region (needed writable region)!
SegvReason: writing NULL VMA
Signal: 11
SourcePackage: rhythmbox
StacktraceTop:
 _nss_wins_gethostbyname_r () from /lib/libnss_wins.so.2
 _nss_wins_gethostbyname2_r () from /lib/libnss_wins.so.2
 ?? () from /lib/tls/i686/cmov/libc.so.6
 getaddrinfo () from /lib/tls/i686/cmov/libc.so.6
 ?? () from /usr/lib/libgio-2.0.so.0
Title: rhythmbox crashed with SIGSEGV in _nss_wins_gethostbyname_r()
Uname: Linux 2.6.32-14-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

nloewen (nloewen) wrote :
visibility: private → public

StacktraceTop:
 _nss_wins_gethostbyname_r (
 _nss_wins_gethostbyname2_r (
 gaih_inet (name=<value optimized out>,
 *__GI_getaddrinfo (name=0x9a000a8 "one.ubuntu.com",
 ?? () from /usr/lib/libgio-2.0.so.0

Changed in rhythmbox (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Pedro Villavicencio (pedro) wrote :

i don't see any function related to rhythmbox, if it's only occurs while browsing the ubuntu one store let's reassign it to there for now so the developers can have a look into this. thanks.

affects: rhythmbox (Ubuntu) → rhythmbox-ubuntuone-music-store (Ubuntu)
Stuart Langridge (sil) on 2010-04-08
Changed in rhythmbox-ubuntuone-music-store (Ubuntu):
assignee: nobody → Rodrigo Moya (rodrigo-moya)
nloewen (nloewen) wrote :

I think its fixed with the latest updates.

bugs still exists here :-|

Matthew Gall (matthewgall) wrote :

Just updated as well, still affecting me on Lucid 10.04 RC

Rodrigo Moya (rodrigo-moya) wrote :

This seems to me a bug in libnss_wins rather than in the music store, but not sure. So, are people getting this crash really using WINS for name resolution?

Michael (null-pointer-us) wrote :

Rodrigo, I have a similar bug (possible duplicate):
https://bugs.launchpad.net/ubuntu/+source/libubuntuone/+bug/570648

When I remove wins from nsswitch.conf, this crash disappears. Add it back in, and the crash returns.

Is it the same for the other people experiencing this bug? If so, I bet we have the same issue.

Matthew Gall (matthewgall) wrote :

I just removed wins from the hosts line of my /etc/nsswitch.conf and the SISEGV fault disappears and Rhythmbox operates properly again.

Looks like we have a duplicate of your bug Michael

Rodrigo Moya (rodrigo-moya) wrote :

This is a bug in winbind, so assigning to samba package

affects: rhythmbox-ubuntuone-music-store (Ubuntu) → samba (Ubuntu)
Michael (null-pointer-us) wrote :

Yes, I found a couple of older, unresolved bugs with the same workaround:

Moving wins to end of line in /etc/nsswitch.conf "fixed" problem:
https://bugs.launchpad.net/ubuntu/+source/liferea/+bug/369274

However, moving wins after dns just disables wins, which then breaks samba.

Removing wins "fixed" the problem here, too:
https://bugs.launchpad.net/ubuntu/+source/tk8.5/+bug/200397

Again, removing wins just breaks samba. The bug remains, either way.

razor7 (ghiamar) wrote :

Hi...in my case I use OpenDNS, so winbind is a must have to run samba local file shares...

I too have the same problem. One way I got around with keeping wins and able to continue using rhythmbox is remove wins from nsswitch.conf (restart samba/winbind). Start rhythmbox. Goto plugins and uncheck Magnatude, Last.FM, Ubuntuone and Jamendo. I then quit rhythmbox and added wins back to nsswitch.conf (restart samba and winbind). I am now able to use rhythmbox and wins for name resolution.

razor7 (ghiamar) wrote :

i think this bug is critical, because the brand new UbuntuONE music store, conflicts with wins samba local shares.

Please pay more attention on solve this.

Best regards!

Darren Couch (dcouch) wrote :

Same problem here as well. Removing WINS is not an acecptable solution- neither is disabling all of the stores.

It affects me at home (direct access to internet) when i run rhythmbox and only if i forget to disable the proxy settings i use at work.

xx@xx:~$ rhythmbox
** (rhythmbox:4514): DEBUG: Loading the real store page
** (rhythmbox:4514): DEBUG: navigation requested to https://one.ubuntu.com/music/store-no-token
Erreur de segmentation (core dumped)

"wins" is added at the end of the line host in /etc/nsswitch.conf

Yuki Izumi (kivikakk) wrote :

I get the same issue without wins in nsswitch.conf at all - but stranger results yet depending on whether or not an iPhone is currently connected to the computer.

With an iPhone connected, I get an invalid pointer crash with backtrace ending in libusb, then libc shortly thereafter. (log attached)

Without the iPhone, it just says "Segmentation fault". Boom!

Yuki Izumi (kivikakk) wrote :

As always, if any more information is helpful, let me know; it's been ages since I followed up on a bug report ...

David A. Rountree (darountree) wrote :

I get the same issue on a 64-bit lucid lynx installation. In my case, temporarily removing wins from /etc/nsswitch.conf, rebooting, then starting Rhythmbox and unchecking the Ubuntu One Store and Lastfm plugins, then adding wins back in to /etc/nsswitch.conf and rebooting was enough to allow Rhythmbox to work without crashing. If I only unchecked the Ubuntu One Store plugin but kept the Lastfm pluging, I could run Rhythmbox but it would crash if I clicked the Lastfm icon in Rhythmbox.

I really miss having the Lastfm plugin - hope this is fixed soon. If anyone needs me to post some error messages or diagnostic tools results, please advise.

william redland (wredland) wrote :

Ya, I have had this issue for a while now. I use wins for easy local name resolution.

I normally have the nsswitch file as:
hosts: files wins mdns4_minimal [NOTFOUND=return] dns mdns4

I found moving "wins":
hosts: files mdns4_minimal [NOTFOUND=return] dns wins mdns4

I can load the plugin's but when I go to use them, they crash.

Ubuntu, 10.04 x64.
I'll add my backtrace for giggles.

william redland (wredland) wrote :

This appears to be the same problem I raised as question #119397 on Canonical SSO provider. The only difference was that this time an error box popped up.

Changed in samba (Ubuntu):
assignee: Rodrigo Moya (rodrigo-moya) → Samba Team (samba-team)
Munchkinguy (10068660) wrote :

Bug is still present in Ubuntu 10.10

Changed in samba (Ubuntu):
status: New → Confirmed
C Pirnat (histoplasmosis) wrote :

removing the rhythmbox-ubuntuone-music-store package will also work. No need to remove wins.

nloewen (nloewen) wrote :

The bug is no longer present for me in Ubuntu 10.10. Others still experiencing the problem should probably file there own bug reports.

Changed in samba (Ubuntu):
status: Confirmed → Invalid
David Maidment (talkingpie) wrote :

This bug is still very much present for me in Ubuntu 10.10. All packages are up-to-date.

Munchkinguy (10068660) wrote :

I am also still experiencing the bug - and everything is up to date. Therefore, I am changing the status back to Confirmed.

Changed in samba (Ubuntu):
status: Invalid → Confirmed
Changed in samba (Ubuntu):
assignee: Samba Team (samba-team) → nobody
Munchkinguy (10068660) wrote :

Could you please explain why this is not the Samba Team's responsibility?

+1

Message in the messages log reports:
[321569.420797] rhythmbox[20381]: segfault at 0 ip 031947e2 sp b1abead8 error 6 in libnss_wins.so.2[3153000+253000]
on Ubuntu 10.04

Note that this seems to also affect a lot of the Banshee addins too. I did a search on the Samba bugzilla (https://bugzilla.samba.org) and wasn't able to find any relevant (open) bug reports. I'd highly recommend promoting this upstream, unless it's already fixed in Samba 3.5.6, which isn't in any PPA I can find.

Jelmer Vernooij (jelmer) wrote :

@munchkinguy The Samba-Team are the upstream developers of Samba, they don't maintain Samba in Ubuntu. The Assigned field is usually used to set the person that's actually actively working on an issue.

Jelmer Vernooij (jelmer) wrote :

Does anybody have a backtrace with the debugging symbols for libnss_wins.so.2 installed? Having the relevant line numbers would be very helpful in resolving this issue.

Mike Ferreira (mafoelffen) wrote :

My bug (#7027730) has been ID'ed as a diplicate of this bug... even though it effects a lot more on mine than just what I see in this bug-> Ubuntu One Music Store puggin cannot be loaded at all or Rhythembox will not start; Ubuntu's Last.fm, Jamendo and Magnatude pluggins crash Rhythembox if I try to play anything from them; No playback of any Audio CD and ripping Audio CD's... Yes that's right, if I insert an Audio CD into my CD/DVD drive Rhtyboxbox Crashes and cannot startup until the CD is taken out of the drive.

MY sys is 10.10 and as a test they had me load Ubuntu's newest release of Rhytmbox (yet even though it was an Ubuntu build, it is not yet supported by them formally) and that didn't change any of it at all.

As a work-around in comment #26, that person said that it will stop if you remove the Ubuntu One Music Store pluggin... not wholly true, at least not for mine. Mine will not even start up with that pluggin installed, but my other problems still are present when that pluggin is uninstalled. My other problems seem to be additional to these bugs- but do "also" disappear if I remove "wins" from the hosts line of /etc/nsswitche.conf... so it seems they "are" related to a problem in Samba. One other problem was that apport wasn't catching any of my crashes, so I had to do manual traces.

If anyone taking care of this bug needs traces, see the files attached to bug #7020030. They seem to be related and may help.

Mike Ferreira (mafoelffen) wrote :

Sorry the bug at end of comment #35 should have been bug #7027730 (no edit function here).

Sebastien Bacher (seb128) wrote :

Could someone on the server team try to work on this issue? that's a frequent crasher for the music store it seems

Changed in samba (Ubuntu):
assignee: nobody → Canonical Server Team (canonical-server)
Mike Ferreira (mafoelffen) wrote :

Okay-- Ubuntu updates tonight that include samba_3.5.4... to include changes in "winbind." I don't know yet if any of these new updates will affect these bugs (my fingers fingers are crossed), but will check on mine once they finish downloading and installing. Will report back soon.

Mike Ferreira (mafoelffen) wrote :

Changes in the updates for samba 2.3.5.4 had no affect on my problems (these bugs) // They were the same and still present. I took wins back out of nsswitch.conf and they were all gone again. I was optimistic, but my hopes were soon crushed...

Brendan Peterffy (s33plusplus) wrote :

Okay, this is odd. I've gotten the source for samba using "apt-get source winbind", built it without optimizations, then used LD_PRELOAD to override the system's copy of libnss_wins.so with my fresh copy, then launched rhythmbox (which segfaulted whenever it tried to resolve a hostname.) and it isn't crashing! I'll do some investigating to see if it was gcc's optimizations that mucked it up or some other cause, but at least this is progress!
It's 5 AM here, so I ought to get to bed, but I'll dig deeper tomorrow!

Brendan Peterffy (s33plusplus) wrote :

Why would LD_PRELOAD'ing libnss_wins.so fix the problem? If I get rhythmbox to load my freshly built libnss_wins.so instead of the one in /lib (using LD_LIBRARY_PATH) I can actually get some useful debugging info. Unless I'm going something totally wrong, rhythmbox is actually segfaulting on nsswitch/wins.c:95
I'll attach a full backtrace from gdb.

@Brendan Peterfly,

When you get some time can you list the steps you took so I can duplicate it on my test machine. Its not urgent however... At least for me it isn't.
-----Original Message-----
From: Brendan Peterffy <email address hidden>
Sender: <email address hidden>
Date: Mon, 07 Feb 2011 09:48:23
To: <email address hidden>
Reply-To: Bug 529714 <email address hidden>
Subject: [Bug 529714] Re: rhythmbox crashed with SIGSEGV in
 _nss_wins_gethostbyname_r()

Okay, this is odd. I've gotten the source for samba using "apt-get source winbind", built it without optimizations, then used LD_PRELOAD to override the system's copy of libnss_wins.so with my fresh copy, then launched rhythmbox (which segfaulted whenever it tried to resolve a hostname.) and it isn't crashing! I'll do some investigating to see if it was gcc's optimizations that mucked it up or some other cause, but at least this is progress!
It's 5 AM here, so I ought to get to bed, but I'll dig deeper tomorrow!

--
You received this bug notification because you are a direct subscriber
of a duplicate bug (550048).
https://bugs.launchpad.net/bugs/529714

Title:
  rhythmbox crashed with SIGSEGV in_nss_wins_gethostbyname_r()

Status in “samba” package in Ubuntu:
  Confirmed

Bug description:
  Binary package hint: rhythmbox

  rhythmbox crashes when trying to access the Ubuntu One music store.

  ProblemType: Crash
  Architecture: i386
  Date: Sun Feb 28 16:05:20 2010
  DistroRelease: Ubuntu 10.04
  EcryptfsInUse: Yes
  ExecutablePath: /usr/bin/rhythmbox
  Package: rhythmbox 0.12.6git20100223-0ubuntu1
  ProcCmdline: rhythmbox
  ProcEnviron:
   LANG=en_CA.UTF-8
   SHELL=/bin/bash
  ProcVersionSignature: Ubuntu 2.6.32-14.20-generic
  SegvAnalysis:
   Segfault happened at: 0x223f682 <_nss_wins_gethostbyname_r+914>: movl $0x0,(%eax)
   PC (0x0223f682) ok
   source "$0x0" ok
   destination "(%eax)" (0x00000000) not located in a known VMA region (needed writable region)!
  SegvReason: writing NULL VMA
  Signal: 11
  SourcePackage: rhythmbox
  StacktraceTop:
_nss_wins_gethostbyname_r () from /lib/libnss_wins.so.2
_nss_wins_gethostbyname2_r () from /lib/libnss_wins.so.2
   ?? () from /lib/tls/i686/cmov/libc.so.6
   getaddrinfo () from /lib/tls/i686/cmov/libc.so.6
   ?? () from /usr/lib/libgio-2.0.so.0
  Title: rhythmbox crashed with SIGSEGV in_nss_wins_gethostbyname_r()
  Uname: Linux 2.6.32-14-generic i686
  UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

To unsubscribe from this bug, go to:
https://bugs.launchpad.net/ubuntu/+source/samba/+bug/529714/+subscribe

Marian (mnion) wrote :

The bug dissapears if I start the winbind daemon or if I only have in my /etc/nsswitch.conf file
hosts : files dns

Chuck Short (zulcss) wrote :

Again if you are having problems can you install the samba-dbg package and reproduce it again and attach the information to this bug report so we can narrow it down?

Thanks
chuck

We've seen at least 3 people with mystery crashers in Banshee this past week which were all tracked down to this problem. Could someone please look at it, it is starting to present a serious burden for upstream Banshee.

As an example:
https://bugzilla.gnome.org//show_bug.cgi?id=644030

Mathew (sal-vager) wrote :

I have this problem in 10.10, i recently added "wins" to my nsswitch.conf to get name resolution to work on a windows network.

hosts: files mdns4_minimal [NOTFOUND=return] wins dns mdns4

This broke both aMSN and Rythmbox which now both crash when accessing the network, they will work correctly when "wins" is removed or moved behind dns or mdns4.

Unfortunately network name resolution will not work for me unless "wins" is where you see it in that line.

After a lot of googling I have found that this was fixed by Nicolas Gama in this thread https://bugs.launchpad.net/ubuntu/+source/samba/+bug/39990

However the .deb he made is no longer available and most likely wouldn't work on maverick anyway.

There is info here that points to a compilation mistake with the ubuntu winbind package https://bugs.launchpad.net/ubuntu/+source/samba/+bug/529714

So rather than being a samba bug, it is an ubuntu bug and a working version of winbind should be compiled and put in the repositories to fix this across the board.

Just a thought, can ubuntu find windows network shares out of the box? it's never worked for me and even after installing samba I still have to edit a .conf by hand, why isn't wins already there?

Timothy Furmston (timfur) wrote :

@ Chuck Short,

I've installed the samba-dbg package and recreated the problem but I'm not sure where to get the debug symbol output from.

Cheers,
Tim

Mathew (sal-vager) wrote :

Ok I have been messing around with 10.04 in virtualbox, ubuntu sees windows shares easily without winbind even being installed and without adding wins to nsswitch.conf, and once samba is installed my windows box can see ubuntu without any problems, also rhythmbox is working fine.

so it seems something is breaking the way samba looks at the network, if winbind isn't even needed there's no point trying to fix that.

I'd try putting samba back to how it was on first install but I don't know how and I don't want to cabbage my laptop, If anyone knows how to do it safely I might give it a go though, I thought I could just delete a bunch of files in /home/username/ but there's no .samba or anything that looks like a home for samba config files.

Mike Ferreira (mafoelffen) wrote :

Update/Observation -- I know you all have bounced this around pointing fingers here and there (Samba group, server group, Rhythmbox group... etc) I think as last (as I remember) you had changed it from samba to server...

Well here's a wrench to throw at that logic --> I just set uo one of my spares here with Ubuntu 10.10 Server Edition with LAMP, Samba, SSH, Tomcat, EUC frontend, etc, ... Comfigured all including smb shares. Installed 3 GUI shells (ubuntu-desktop, kubuntu-desktop, xubuntu-desktop) as well as editing grub2 to easily come into it's native text console... I configured Rythymbox on it the get its music from a mounted Windows share (on another server) AND GUESS WHAT???
Differences in desktup and server kerne
Rhythembox and all the extansion (including the Ubuntu Music Store runs perfectly!!! The machine I am having problems on is running LAMP and Samba services. The only obvios differnce on the machine that works from the one that I am having the problems on is the machine machine that is working is running the "server kernel"...

From the server guide, the differences betweeen the server and desktop kernel are:
 - :The Server Edition uses the Deadline I/O scheduler instead of the CFQ scheduler used by the Desktop Edition.
 - Preemption is turned off in the Server Edition.
 - The timer interrupt is 100 Hz in the Server Edition and 250 Hz in the Desktop Edition.:

I don't know, but it's working on this machine and not my other that is running server services on the desktop kernel. SO... might some of the config options that are different between /boot/config-2.35.xx-general and /boot/config-2.35.xx-server be doing this? If so, seems that it might not be a server issue, but rather how the desktop kernel is configured. (Just an mystery tio me.)

Chuck Short (zulcss) wrote :

Please as said before can you install samba-dbg package and get a proper backtrace?

Thanks
chuck

Changed in samba (Ubuntu):
assignee: Canonical Server Team (canonical-server) → Ubuntu Server Team (ubuntu-server)
Chow Loong Jin (hyperair) wrote :

Some quick googling has revealed that this bug has been fixed, I think, and here are the patches:-
https://attachments.samba.org/attachment.cgi?id=5511
https://attachments.samba.org/attachment.cgi?id=5522

Incidentally, this is the upstream bug report: https://bugzilla.samba.org/show_bug.cgi?id=7202

Chow Loong Jin (hyperair) wrote :

Hmm, the patches look like they have been applied already in Natty's package. Are there any Natty users experiencing this bug?

Changed in samba (Ubuntu):
status: Confirmed → Incomplete
Chow Loong Jin (hyperair) wrote :

https://launchpadlibrarian.net/69547170/Stacktrace.txt looks like a complete stack trace for Natty. And since there are so many duplicates of this bug, I'm bumping the importance.

Changed in samba (Ubuntu):
importance: Medium → Critical
status: Incomplete → Triaged
Chow Loong Jin (hyperair) wrote :

Okay, I think I've found the issue, based on a crash with liferea:-

At wins.c:95, we have
DEBUGLEVEL = 0;

Somewhere in source3/include/debug.h, we have
#define DEBUGLEVEL *debug_level
extern int DEBUGLEVEL;

In source3/lib/debug.c, we have:
int DEBUGLEVEL = &debug_all_class_hack;

Based on this, all seems well and good, except that due to a problematic build system, libnss_wins.so dynamically resolves this debug_level variable when loaded by libc. In the case of liferea, it uses a global int debug_level somewhere around its source code. I reckon the other applications that are affected by this bug also use something similar.

Given that Natty is really near, and I reckon it's too late to be trying something grand like controlling what symbols do and do not get exported/dynamically resolved during load, I have come up with a patch that renames debug_level to smb_debug_level in source3/include/debug.h. This should solve the issue for the time being.

I'm now test-building the patched package, and will post a follow-up comment.

On Tue, 2011-04-26 at 13:28 +0000, Chow Loong Jin wrote:
> Okay, I think I've found the issue, based on a crash with liferea:-
>
> At wins.c:95, we have
> DEBUGLEVEL = 0;
>
> Somewhere in source3/include/debug.h, we have
> #define DEBUGLEVEL *debug_level
> extern int DEBUGLEVEL;
>
> In source3/lib/debug.c, we have:
> int DEBUGLEVEL = &debug_all_class_hack;
>
>
> Based on this, all seems well and good, except that due to a problematic build system, libnss_wins.so dynamically resolves this debug_level variable when loaded by libc. In the case of liferea, it uses a global int debug_level somewhere around its source code. I reckon the other applications that are affected by this bug also use something similar.
>
> Given that Natty is really near, and I reckon it's too late to be trying
> something grand like controlling what symbols do and do not get
> exported/dynamically resolved during load, I have come up with a patch
> that renames debug_level to smb_debug_level in source3/include/debug.h.
> This should solve the issue for the time being.
I'm surprised nss modules aren't loaded with RTLD_DEEPBIND specified.
This is a flag for dlopen() that allows you to indicate that module
local symbols should preferred to global ones.

From the manpage:

RTLD_DEEPBIND (since glibc 2.3.4)
     Place the lookup scope of the symbols in this library ahead of
     the global scope. This means that a self-contained library
     will use its own symbols in preference to global symbols with
     the same name contained in libraries that have already been
     loaded. This flag is not specified in POSIX.1-2001.

Cheers,

Jelmer

Chow Loong Jin (hyperair) wrote :

Okay, here's an updated patch which actually compiles, and I'm not getting the bug on my machine any more.

Chow Loong Jin (hyperair) wrote :

I don't feel up to trekking through glibc's source code, so I've just added a glibc target to this bug for the time being.

Changed in samba (Ubuntu Natty):
assignee: Ubuntu Server Team (ubuntu-server) → nobody
Brian Murray (brian-murray) wrote :

Assigning to the foundations team to look at the eglibc bug task.

Changed in eglibc (Ubuntu):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Martin Pitt (pitti) wrote :

Sponsored, waiting in queue for review now.

Accepted samba into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in samba (Ubuntu Natty):
status: Triaged → Fix Committed
tags: added: verification-needed
Paul White (paulw2u) wrote :

I can confirm this has fixed the bug that I reported #769545 relating to banshee.
Thanks to all those involved in fixing this long outstanding bug.

Martin Pitt (pitti) on 2011-05-10
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package samba - 2:3.5.8~dfsg-1ubuntu2.2

---------------
samba (2:3.5.8~dfsg-1ubuntu2.2) natty-proposed; urgency=low

  * debian/patches/fix-debuglevel-name-conflict.patch:
    + Fix issue with the "debug_level" variable name in libnss_wins.so
      conflicting with the "debug_level" global variable that some applications
      use (LP: #529714)
 -- Chow Loong Jin <email address hidden> Mon, 02 May 2011 21:30:54 +0800

Changed in samba (Ubuntu Natty):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Copied natty-proposed to oneiric as well.

Changed in samba (Ubuntu):
status: Triaged → Fix Released
Changed in eglibc (Ubuntu Natty):
status: New → Confirmed
Changed in eglibc (Ubuntu):
status: New → Confirmed
bruce (bth73) wrote :

Banshee still crashing after proposed updates, removal of banshee /home/USER/.cache/.banshee-1 and /home/USER/.config/banshee-1 files, and reinstall banshee. Loaded all my media and played a few mp3 files, then apropo it crashed after Waren Zevon's song about dieing " My Shits Fucked Up".

razor7 (ghiamar) wrote :

Hi, started on 28/02/2010 and today, this bug persists...how can ubuntu success with this ugly kind of bug?

I need to have winbind installed because I use openDNS services, how can the ubuntu one service plugin in banshee crash the whole app because of this? I mean, is the defaul shinny audio application in the OS!

Devs note: Yes, I have erased the cache folder of banshee, and guess what, the error continues!

Please, we love Ubuntu and GNU/Linux very mouch, but this kind of bugs, still unresolved, are really annoying

razor7 (ghiamar) wrote :

Devs note. Yes, uninstalling banshee-extension-ubuntuonemusicstore fixes the problem...but of course, not ubuntuone music store available for banshee...

Please, for the good of Ubuntu, solve this...

razor7 (ghiamar) wrote :

Hi, Ubuntu 11.04 beta 2, guess what?, No ubuntu one winbind bug fixed at all!

PeterPall (peterpall) wrote :

Is a pity, that: Rather liked this store - and was excellently integrated into the operating system.
At least I did get tomboy to sync notes with ubuntu one again and the chalk(beta) app on my android phone, too, so Ubuntu one at least does do something for me again.

Steve Langasek (vorlon) wrote :

Confirmed, the debug_level symbol is back in winbind 2:3.5.9~dfsg-1ubuntu1 and later. The rationale for dropping it was:

      - debian/patches/fix-debuglevel-name-conflict.patch: Fixed upstream.

Chuck, how did you determine that this has been fixed upstream? The contents of the patch are definitely not present in the upstream source.

Changed in samba (Ubuntu):
assignee: nobody → Chuck Short (zulcss)
status: Fix Released → Triaged

Did contact the ubuntu one support because in my synaptic the
rhythmbox-ubuntuone-music-store package had disappeared. Seems like the
current plan for oneiric ozelot is to replace rhythmbox with banshee.
Will try to install banshee this evening. Looking at the extensions
available for this package it might be a powerful rhythmbox replacement.

tags: added: regression-release
Steve Langasek (vorlon) on 2011-09-28
Changed in samba (Ubuntu Oneiric):
milestone: none → oneiric-updates
PeterPall (peterpall) wrote :

Banshee crashes for me after an artist is selected in the u1 music store. Does anybody know enough of stack traces to be able to see if Bug #861146 a duplicate of this bug?

dobey (dobey) wrote :

Peter, that is not a duplicate of this bug, but is a duplicate of another, which I have marked it as.

tags: added: rls-mgr-o-tracking
Steve Langasek (vorlon) on 2011-09-30
Changed in eglibc (Ubuntu Oneiric):
status: Confirmed → Won't Fix
Changed in eglibc (Ubuntu Natty):
status: Confirmed → Won't Fix
Dave Walker (davewalker) wrote :

As per comment #63 & #64, this is Fix Released in Oneiric.

Thanks.

Dave Walker (davewalker) wrote :

(For the samba task.)

Changed in samba (Ubuntu Oneiric):
assignee: Chuck Short (zulcss) → nobody
status: Triaged → Fix Released
Steve Langasek (vorlon) wrote :

Daviey, did you read the comments AFTER comment #64, which explain why I reopened this bug?

Changed in samba (Ubuntu Oneiric):
status: Fix Released → Triaged
assignee: nobody → Chuck Short (zulcss)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package samba - 2:3.5.11~dfsg-1ubuntu2

---------------
samba (2:3.5.11~dfsg-1ubuntu2) oneiric; urgency=low

  * debian/patches/fix-debuglevel-name-conflict.patch:
    Re-add patch that was mistakenly dropped. (LP: #529714)
 -- Chuck Short <email address hidden> Fri, 30 Sep 2011 13:08:34 -0400

Changed in samba (Ubuntu Oneiric):
status: Triaged → Fix Released
Changed in eglibc (Ubuntu Precise):
status: New → Confirmed
tags: removed: rls-mgr-o-tracking
Steve Langasek (vorlon) on 2011-10-07
Changed in samba (Ubuntu Precise):
status: New → Invalid
Changed in banshee (Ubuntu Natty):
status: New → Invalid
Changed in banshee (Ubuntu Oneiric):
status: New → Invalid
Changed in banshee (Ubuntu Precise):
status: New → Invalid
Steve Langasek (vorlon) wrote :

The remaining task here is about suggesting use of RTLD_DEEPBIND when opening nss modules from eglibc. This is IMHO a reasonable suggestion to implement upstream, but not something that's critical to include a fix for in precise given that nss_wins has now addressed its own symbol issues.

Changed in eglibc (Ubuntu Precise):
status: Confirmed → Won't Fix
Changed in eglibc (Ubuntu):
assignee: Canonical Foundations Team (canonical-foundations) → nobody
importance: Undecided → Low
status: Confirmed → Triaged
mojo risin (lamfried-morr) wrote :

Not sure if related
http://pastebin.com/qENT0yiK

Started when I was trying to purchase something via paypal.
(using lubuntu 11.10)

Chow Loong Jin (hyperair) wrote :

On 11/04/2012 05:09, mojo risin wrote:
> Not sure if related
> http://pastebin.com/qENT0yiK
>
> Started when I was trying to purchase something via paypal.
> (using lubuntu 11.10)

No, this is unrelated, Please file a new bug.

--
Kind regards,
Loong Jin

Changed in samba:
importance: Unknown → Medium
status: Unknown → Confirmed
dino99 (9d9) wrote :

This is no more a supported version now

Changed in eglibc (Ubuntu):
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.