Transferring AAC files to iPod is broken

Bug #164265 reported by Caleb on 2007-11-21
26
Affects Status Importance Assigned to Milestone
Rhythmbox
Fix Released
Medium
rhythmbox (Ubuntu)
Low
Ubuntu Desktop Bugs
Hardy
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: rhythmbox

When I attach my iPod and drag an AAC song to it on Rhythmbox, it transfers very slowly and with high CPU usage, as if it were transcoding the file. I confirmed that the file transferred to the iPod was different from the original stored in my music library folder using md5 sums, and also listened to the song on my computer from the iPod's drive. The song sounded pretty bad. When the iPod was ejected and disconnected, the songs wouldn't play at all... the total time indicator showed the correct time for a moment, but it would instantly go to the next song without playing at all.

Related branches

Joss Winn (josswinn) wrote :

I've noticed this. Rhythmbox transcodes my m4a files to mp3 when moving it to an ipod. I'd really like to just *copy* my m4a files to my ipod. They don't need to be transcoded to mp3.

Pedro Villavicencio (pedro) wrote :

Thanks for your report, May you run rhythmbox from the command line as: GST_DEBUG_NO_COLOR=1 GST_DEBUG=3 rhythmbox &>rhythmbox-log.txt and attach that log to the report? thanks!.

Changed in rhythmbox:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
Joss Winn (josswinn) wrote :

Here it is. While running the app, I added files to my iPod (which were auto-transcoded to mp3!)

Thanks.

Caleb (caleb-marcus) wrote :

Hmm, I don't think it transcoded mine to mp3... the file on the iPod seemed to be an m4a. I could decode it with faad, for instance, although it sounded pretty bad. Also, it was the exact same size as the original. However, the iPod wouldn't play it... The thing is, it doesn't really matter what the output format is. The problem here seems to be that Rhythmbox either doesn't think that the iPod can handle AAC files, or it's reencoding the AAC file, both of which are bad things.

Joss Winn (josswinn) wrote :

I can see mine are mp3 just by looking at the properties of one of the files I've transferred to the ipod in the rythmnbox ipod window. Also, when I delete those files from the ipod and look in my Trash, they are all .mp3 files - the original library tracks are .m4a files, encoded using iTunes.

That's VERY strange... I just tested it with an m4a file, and the
resulting m4a file on the iPod looks like an AAC file in properties, but
doesn't play in anything I can try... however, faad decodes it, but the
results sound HIGHLY distorted.
On Thu, 2007-11-22 at 09:05 +0000, joss wrote:

> I can see mine are mp3 just by looking at the properties of one of the
> files I've transferred to the ipod in the rythmnbox ipod window. Also,
> when I delete those files from the ipod and look in my Trash, they are
> all .mp3 files - the original library tracks are .m4a files, encoded
> using iTunes.
>
> ** Attachment added: "Screenshot of Rythmnbox iPod properties tab, showing transcoded mp3 file"
> http://launchpadlibrarian.net/10509267/Screenshot.png
>

Caleb (caleb-marcus) wrote :

I took a screenshot of the same window, as well as the file properties
window...

Matt Hanyok (matthew-hanyok) wrote :

I'm also having this problem. Oddly it seemed to transcode my AAC files... to AAC format. The files were previously ripped with iTunes. They play without issue but if I use Rhythmbox to put music on the iPod (a 4th gen greyscale 20gb, firmware 3.1.1) and then try accessing the files on the iPod they're unplayable (a 3 minute song would keep the same filesize but report as 15 minutes in VLC, banshee or even on the actual ipod; nothing could make it play properly).

I think this issue is related to bug 95326:

https://bugs.launchpad.net/ubuntu/+source/gstreamer0.10/+bug/95326

I don't have much programming chops but I think sound juicer is using the same gstreamer component for ripping as rhythmbox uses for this transcoding.

Basilio Kublik (sourcercito) wrote :

Hi there
Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with the development branch of Ubuntu, Hardy Heron?

Thanks in advance.

Caleb (caleb-marcus) wrote :

I'm currently running Hardy in a VM, so I can't connect my iPod to it. I'm not really willing to install Hardy as my main OS right now, so I'm afraid I won't be able to test it in Hardy.

Joss Winn (josswinn) wrote :

I'm running Hardy with the latest updates. Rhythmbox is still modifying
these files. A 3.9MB file shows as 1.9MB on the iPod.

Joss

On Thu, Mar 13, 2008 at 12:35 PM, Basilio Kublik <email address hidden>
wrote:

> Hi there
> Thank you for taking the time to report this bug and helping to make
> Ubuntu better. You reported this bug a while ago and there hasn't been any
> activity in it recently. We were wondering is this still an issue for you?
> Can you try with the development branch of Ubuntu, Hardy Heron?
>
> Thanks in advance.
>
> --
> Transferring AAC files to iPod is broken
> https://bugs.launchpad.net/bugs/164265
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Joss Winn (josswinn) wrote :

In addition to my last mail, the original file shows the iTunes version in
the comment field, the transferred file shows 'Lavf1d.51.10.0'.

Here's some command output for the transferred file:

joss@laptop:~$ ffmpeg -i /home/joss/Desktop/01\ Love\ Me\ Do.m4a
FFmpeg version SVN-rUNKNOWN, Copyright (c) 2000-2007 Fabrice Bellard, et al.
  configuration: --enable-gpl --enable-pp --enable-swscaler
--enable-pthreads --enable-libvorbis --enable-libtheora --enable-libogg
--enable-libgsm --enable-dc1394 --disable-debug --enable-shared
--prefix=/usr
  libavutil version: 1d.49.3.0
  libavcodec version: 1d.51.38.0
  libavformat version: 1d.51.10.0
  built on Mar 12 2008 14:31:53, gcc: 4.2.3 (Ubuntu 4.2.3-2ubuntu4)
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from '/home/joss/Desktop/01 Love Me
Do.m4a':
  Duration: 00:02:21.1, start: 0.000000, bitrate: 114 kb/s
  Stream #0.0(und): Audio: mp4a / 0x6134706D, 44100 Hz, stereo

and the same output for the original file:

joss@laptop:~$ ffmpeg -i /home/joss/Desktop/01\ Love\ Me\ Do.m4a
FFmpeg version SVN-rUNKNOWN, Copyright (c) 2000-2007 Fabrice Bellard, et al.
  configuration: --enable-gpl --enable-pp --enable-swscaler
--enable-pthreads --enable-libvorbis --enable-libtheora --enable-libogg
--enable-libgsm --enable-dc1394 --disable-debug --enable-shared
--prefix=/usr
  libavutil version: 1d.49.3.0
  libavcodec version: 1d.51.38.0
  libavformat version: 1d.51.10.0
  built on Mar 12 2008 14:31:53, gcc: 4.2.3 (Ubuntu 4.2.3-2ubuntu4)
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from '/home/joss/Desktop/01 Love Me
Do.m4a':
  Duration: 00:02:20.7, start: 0.000000, bitrate: 193 kb/s
  Stream #0.0(und): Audio: mp4a / 0x6134706D, 44100 Hz, stereo

As you can see, the bitrate is lower on the transferred file.

Hope that helps someone!

Joss

On Thu, Mar 13, 2008 at 12:35 PM, Basilio Kublik <email address hidden>
wrote:

> Hi there
> Thank you for taking the time to report this bug and helping to make
> Ubuntu better. You reported this bug a while ago and there hasn't been any
> activity in it recently. We were wondering is this still an issue for you?
> Can you try with the development branch of Ubuntu, Hardy Heron?
>
> Thanks in advance.
>
> --
> Transferring AAC files to iPod is broken
> https://bugs.launchpad.net/bugs/164265
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Sebastien Bacher (seb128) wrote :
Changed in rhythmbox:
status: Incomplete → Triaged
Matt Hanyok (matthew-hanyok) wrote :

I had some time where I was doing a reinstall where I tried an Alpha release just to see if this problem was fixed... I think it was Alpha 4. I still had the problem then, but I haven't tried any of the later versions.

I think this can be tested by trying to rip a file to AAC format; as mentioned in the bug I linked in November the problem appears to be with gstreamer's AAC encoder (used in Rhythmbox's transcoding of files to an iPod for whatever reason) and not specifically with Rhythmbox; ripping files in that format also resulted in corrupt audio.

Changed in rhythmbox:
status: Unknown → New
Shogun (shogun713) wrote :

Hi guys!

I posted a patch on upstream bug posted above which fixes the problem.
Hope this helps!
   Shogun

Mark Duncan (eattheapple) wrote :

Up to date hardy and this bug still exists. Hopefully someone can get around to applying that patch mentioned above to the package.

Changed in rhythmbox:
status: New → Fix Released
Sebastien Bacher (seb128) wrote :

the bug has been fixed upstream now

Changed in rhythmbox:
status: Triaged → Fix Committed
Changed in rhythmbox:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rhythmbox - 0.11.5-5ubuntu2

---------------
rhythmbox (0.11.5-5ubuntu2) intrepid; urgency=low

  * debian/patches/70_from_svn_fix_incorrect_shuffle_detection.patch:
    - change from svn, correctly detect the new ipod shuffle devices
  * debian/patches/71_from_svn_fix_ipod_aac_copies.patch:
    - change from svn, don't convert aac when they are copied to an ipod
      (lp: #164265)
  * debian/patches/72_from_svn_ipod_correct_set_year_tag.patch:
    - change from svn, correctly set the year when copying a song to an ipod
      (lp: #144273)

 -- Sebastien Bacher <email address hidden> Thu, 12 Jun 2008 10:44:02 +0200

Changed in rhythmbox:
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here

Changed in rhythmbox:
status: Confirmed → Fix Committed
Henrik Nilsen Omma (henrik) wrote :

Caleb, Joss, Matt: could one of you please test the version in -proposed? I would but I don't have an iPod :)

You can find instructions for enabling -proposed here: https://wiki.ubuntu.com/Testing/EnableProposed

Joss Winn (josswinn) wrote :

Sorry, but my supported iPod shuffle is broken and my iPod Touch is unsupported.

Hello,

One or two month ago, I have reported the following bug :

When you try to send (drag and drop on rhythmbox ubuntu 0.11.5) an *OGG* file to an IPOD, the file is not converted and then (inevitably) can not be read on the ipod.
My bug report has been marked as a duplicated bug with this one (#164265). I have never understood what was the link but I was confident.

Now this bug has been fixed and the problem still there (for OGG files), I wonder if my bug report has been judged to rapidly as a duplicate...

Should I report my bug once again ?

Thanks

Arnaud

Sebastien Bacher (seb128) wrote :

the ogg bug is an another issue, the conversion works fine but you need codecs which are not installed by default due to patents issues and rhythmbox doesn't display a dialog about the issue, http://bugzilla.gnome.org/show_bug.cgi?id=520209 is the upstream corresponding bug, I think there is a bug on launchpad too but I don't know the number

Matt Hanyok (matthew-hanyok) wrote :

Henrik (and all),

I can confirm that this no longer attempts to transcode AAC files when transfering to an iPod.

Tested on my 4th-gen greyscale 20gb, Ubuntu Hardy 64 bit, Rhythmbox package 0.11.5-0ubuntu8.

Matt

Martin Pitt (pitti) wrote :

Copied to hardy-updates.

Changed in rhythmbox:
status: Fix Committed → Fix Released
CoffeeBurrito (coffeeburrito) wrote :

I have a problem with this 'fix'. My new iPod Shuffle 2G does not support m4a, and I WANT it to transcode the song to mp3 for me instead of copying it.

Martin Pitt (pitti) wrote :

Reopening then.

Changed in rhythmbox:
status: Fix Released → Confirmed
Caleb (caleb-marcus) wrote :

The iPod Shuffle 2G supports AAC. The only iTunes format it doesn't support is Apple Lossless. Is that what you're talking about?

Sebastien Bacher (seb128) wrote :

is that still an issue in intrepid?

Changed in rhythmbox:
status: Confirmed → Incomplete
Sebastien Bacher (seb128) wrote :

We are closing this bug report as it lacks the information, described in the previous comments, we need to investigate the problem further. However, please reopen it if you can give us the missing information and don't hesitate to submit bug reports in the future.

Changed in rhythmbox:
status: Incomplete → Invalid
Changed in rhythmbox:
importance: Unknown → Medium
Chris Jenkins (christj) wrote :

This bug is active again in rhythmbox 13.3 . It looks like it was fixed here:

https://bugzilla.gnome.org/show_bug.cgi?id=508537

by adding:

  } else if (strcmp (entry_mime, "audio/x-m4a") == 0) {
   entry_mime = "audio/aac";

to sources/rb-removable-media-source.c

I think the code for determining the entry mime has moved to backends/gstreamer/rb-encoder-gst.c and entry_mime is now entry_media_type . I'm no programming expert but I've created a patch which should do what the old one did.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.