Ubuntu

rdesktop crashes when logging in to windows 2000 (or pressing cancel)

Reported by Rocci on 2007-04-08
132
Affects Status Importance Assigned to Milestone
rdesktop (Debian)
Fix Released
Unknown
rdesktop (Ubuntu)
Undecided
Reinhard Tartler
Dapper
High
Kees Cook
Edgy
High
Kees Cook
Feisty
Undecided
Reinhard Tartler
Gutsy
Undecided
Whoopie

Bug Description

Binary package hint: rdesktop

Rdesktop version 1.5
When logging in to Windows 2000 server or when selecting cancel at point of ctl-alt-del login prompt.

Thanks for taking the time to report this bug and helping to make Ubuntu
better. However, your crash report is missing. Could you please add
the crash report that you received? You should be able to find it in
'/var/crash/'. This will allow us to better troubleshoot your bug.
Thanks in advance.

 status needsinfo
 assignee <email address hidden>

Changed in rdesktop:
assignee: nobody → brian-murray
status: Unconfirmed → Needs Info

On Mon, 9 Apr 2007 11:30:07 pm Brian Murray wrote:
Hi Brian,
I've uploaded the crash report to the bug report.
Would it help if I am able to provide any debugging info etc.. ??
Sorry, I'm new to reporting bugs in Ubuntu but will do my best to provide you
guys with whatever info is needed.

Thanks,
Rocci.

> Thanks for taking the time to report this bug and helping to make Ubuntu
> better. However, your crash report is missing. Could you please add
> the crash report that you received? You should be able to find it in
> '/var/crash/'. This will allow us to better troubleshoot your bug.
> Thanks in advance.
>
> status needsinfo
> assignee <email address hidden>
>
>
> ** Changed in: rdesktop (Ubuntu)
> Assignee: (unassigned) => Brian Murray
> Status: Unconfirmed => Needs Info

Rocci (rocci) wrote :
Rocci (rocci) wrote :
Changed in rdesktop:
assignee: brian-murray → nobody
status: Needs Info → Confirmed
mheily (mark-heily) wrote :

(This is a CC of the message I sent to the Debian BTS and to upstream)

Here is a patch that prevents rdesktop from crashing due to increased Xlib sanity checking
of arguments passed to XCreateImage(3). Thanks to Julien Cristau for his helpful explanation
of the problem on the Debian bug tracking system.

Thanks,

Mark Heily
<email address hidden>

References:

[1] http://<email address hidden>/msg326793.html
[2] https://bugs.launchpad.net/ubuntu/+source/rdesktop/+bug/104332

Patch:

--- ../rdesktop/xwin.c 2007-01-17 02:39:31.000000000 -0500
+++ xwin.c 2007-04-11 11:13:51.000000000 -0400
@@ -3218,7 +3218,7 @@
                return;

        image = XCreateImage(g_display, g_visual, g_depth, ZPixmap, 0,
- (char *) data, cx, cy, BitmapPad(g_display), cx * g_bpp / 8);
+ (char *) data, cx, cy, BitmapPad(g_display), 0);

        if (g_ownbackstore)
        {

Here is a corrected patch that fixes the segfault and correctly redraws the desktop image. This has
been tested with a Windows 2000 Server at 8bpp and a Windows 2003 server at 16bpp.

Thanks to Mat G for his suggestion on how to fix my original patch.

-Mark

--- ../rdesktop/xwin.c 2007-01-17 02:39:31.000000000 -0500
+++ xwin.c 2007-04-12 09:51:46.000000000 -0400
@@ -3218,7 +3218,7 @@
   return;

  image = XCreateImage(g_display, g_visual, g_depth, ZPixmap, 0,
- (char *) data, cx, cy, BitmapPad(g_display), cx * g_bpp / 8);
+ (char *) data, cx, cy, g_bpp, 0);

  if (g_ownbackstore)
  {

See attached patch (Launchpad stripped it from the previous message).

mheily (mark-heily) wrote :

Upstream (Michael Gernoth <email address hidden>) has committed the patch and posted the following message to their mailing list:

On Thu, Apr 12, 2007 at 10:03:16AM -0400, Mark Heily wrote:
> Here is a corrected patch that fixes the segfault and correctly
> redraws the desktop image. This has been tested with a Windows 2000
> Server at 8bpp and a Windows 2003 server at 16bpp.

Thank you for your patch. I have just committed it to the rdesktop CVS
repository (xwin.c revision 1.223).

Regards,
  Michael

Eddie Hung (eddieh) wrote :

I'm seeing a problem here too, under latest Feisty. I crash consistently when I try to create various windows: Start -> Run, Start -> Logoff, starting Wordpad, etc. I gather you've found out what the problem is - and you say you've committed the patch "upstream" - but does that mean we'll get to see the version in the Feisty repos (which I guess is unlikely, given how close we are to release) - and if not, does it mean I have to build from source to get this fix? Thanks.

Changed in rdesktop:
status: Unknown → Unconfirmed
Reinhard Tartler (siretart) wrote :

michael gernoth is sitting next to me, I'm handling this bug

Changed in rdesktop:
assignee: nobody → siretart
status: Confirmed → In Progress
Reinhard Tartler (siretart) wrote :

uploaded to feisty

Changed in rdesktop:
status: In Progress → Fix Committed
Reinhard Tartler (siretart) wrote :

13:43:21 < siretart> Mithrandir: I just uploaded a fix for rdesktop bug #104332 - upstream is sitting next to me and it really seems a very good idea to have that patch in for feisty
13:44:10 < Mithrandir> siretart: -updates;
13:44:29 < siretart> oh. ok. please reject my upload then
13:44:38 < siretart> I reupload in a sek
13:45:00 < Mithrandir> -updates isn't open yet, and you need to follow the normal SRU procedure.
13:45:19 < siretart> oh. I see

Changed in rdesktop:
status: Fix Committed → In Progress
Changed in rdesktop:
status: In Progress → Fix Committed
Timo Aaltonen (tjaalton) on 2007-04-20
Changed in rdesktop:
importance: Undecided → High
status: Unconfirmed → Confirmed
Supermike (reachmike) wrote :

Will this replacement rdesktop be uploaded soon for release on Dapper? I depend on rdesktop a great deal and I imagine right now so do many other users.

Reinhard Tartler (siretart) wrote :

Proposed upload:

--- rdesktop-1.5.0/debian/changelog
+++ rdesktop-1.5.0/debian/changelog
@@ -1,3 +1,11 @@
+rdesktop (1.5.0-1ubuntu1~prop1) feisty-proposed; urgency=low
+
+ * apply patch from upstream cvs:
+ http://rdesktop.cvs.sourceforge.net/rdesktop/rdesktop/xwin.c?r1=1.222&r2=1.223&view=patch
+ Recommended upload, thanks to upstream Michael Gernoth, LP #104332
+
+ -- Reinhard Tartler <email address hidden> Wed, 18 Apr 2007 07:22:57 -0400
+
 rdesktop (1.5.0-1build1) feisty; urgency=low

   * Rebuild for changes in the amd64 toolchain.
only in patch2:
unchanged:
--- rdesktop-1.5.0.orig/xwin.c
+++ rdesktop-1.5.0/xwin.c
@@ -3219,7 +3219,7 @@
                return;

        image = XCreateImage(g_display, g_visual, g_depth, ZPixmap, 0,
- (char *) data, cx, cy, BitmapPad(g_display), cx * g_bpp / 8);
+ (char *) data, cx, cy, g_bpp, 0);

        if (g_ownbackstore)
        {

Reinhard Tartler (siretart) wrote :

uploaded to feisty-proposed

Changed in rdesktop:
status: Fix Committed → In Progress
Martin Pitt (pitti) wrote :

Accepted into feisty-proposed.

Changed in rdesktop:
status: In Progress → Fix Committed
Andres Mujica (andres.mujica) wrote :

i'm having this issue too. i'm using dapper

Andres Mujica (andres.mujica) wrote :

ok, i'm confirming this bug on edgy and dapper.

on edgy when you upgrade from

 libx11-6 1.0.3-0ubuntu4

to

 libx11-6 1.0.3-0ubuntu4.1

you'll have the rdesktop segfault

in dapper the problem comes with

libx11-6 1.0.0-0ubuntu9.1

The workaround for both dapper and edgy is to downgrade libx11-6 to

libx11-6 1.0.0-0ubuntu9 (dapper)

 libx11-6 1.0.3-0ubuntu4 (edgy)

Andres Mujica (andres.mujica) wrote :

confirmed with libx11-6 1.0.3-0ubuntu4.1

Changed in rdesktop:
status: Unconfirmed → Confirmed
Michael Vogt (mvo) wrote :

I verified that it installs, I can do no further verification as I do not have a working terminal server. Given the small change and the scope of the change I will mark it verification-done

Michael Vogt (mvo) wrote :

verficiation-done for feisty-proposed, this can be uploaded into updates at Fri 27.04

John Florian (j100) wrote :

Michael,

I have access to a variety of terminal servers and would be happy to run some verification tests if you can point me to where I might snag a copy of the proposed version.

mheily (mark-heily) wrote :

I have verified that rdesktop 1.5.0-1ubuntu1~prop1 works correctly with a Windows 2000 terminal server at 8bpp and a Windows 2003 terminal server at 16bpp.

John Florian <email address hidden> writes:
> I have access to a variety of terminal servers and would be happy to run
> some verification tests if you can point me to where I might snag a copy
> of the proposed version.

You can find the packages in this directory:
http://archive.ubuntu.com/ubuntu/pool/main/r/rdesktop/

For e.g. i386, please try this .deb:
http://archive.ubuntu.com/ubuntu/pool/main/r/rdesktop/rdesktop_1.5.0-1ubuntu1~prop1_i386.deb

--
Gruesse/greetings,
Reinhard Tartler, KeyID 945348A4

I have Dapper and tried Reinhard's deb:

http://archive.ubuntu.com/ubuntu/pool/main/r/rdesktop/rdesktop_1.5.0-1ubuntu1~prop1_i386.deb

...after I had done 'apt-get --purge remove rdesktop' and the result from my 'dpkg -i' attempt was:

Selecting previously deselected package rdesktop.
(Reading database ... 151221 files and directories currently installed.)
Unpacking rdesktop (from rdesktop_1.5.0-1ubuntu1~prop1_i386.deb) ...
dpkg: dependency problems prevent configuration of rdesktop:
 rdesktop depends on libc6 (>= 2.5-0ubuntu1); however:
  Version of libc6 on system is 2.3.6-0ubuntu20.4.
 rdesktop depends on libssl0.9.8 (>= 0.9.8c-1); however:
  Version of libssl0.9.8 on system is 0.9.8a-7ubuntu0.3.
dpkg: error processing rdesktop (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 rdesktop

So it looks like I can't install this early. Unfortunately this is very critical for me. I boot up on Ubuntu in my office and depend on rdesktop heavily to do LAN management in an office of 400 computers and 100 servers, mixed with Linux and Windows. Any hope of a release for Dapper or is this an indicator that Canonical would rather I upgrade to Feisty? It's just that I am conservative in judgment and stick with LTS versions when I can.

John Florian (j100) wrote :

rdesktop 1.5.0-1ubuntu1~prop1 is working perfectly for me.

Supermike (reachmike) wrote :

John Florian -- with Dapper, Edgy, or Feisty? I have Dapper LTS because I want to be on something as stable as possible. I'm about two minutes from calling Canonical to pay for support so that I can learn how to roll back last Wednesday or Thursday's Xorg patch so that my rdesktop goes back to working again. I depend on rdesktop very heavily still in my day job, unfortunately, because Evolution has not worked well for me, as I describe in this thread:

http://ubuntuforums.org/showthread.php?p=2516247#post2516247

I also have to connect to Windows servers as part of my day job for LAN management.

Kees Cook (kees) wrote :

Supermike, I'll have a Dapper .deb up for you to try shortly.

Supermike (reachmike) wrote :

OMG thank you Kees Cook. You are like making my day! :)

Kees Cook (kees) wrote :

Supermike, please try [1] and let me know if it fixes the problems.

[1] http://people.ubuntu.com/~kees/debs/rdesktop_1.4.1-1.1ubuntu0.6.06_i386.deb

For edgy, or amd64 versions, see the parent directory.

On Mon, 2007-04-23 at 15:42 +0000, Supermike wrote:
> John Florian -- with Dapper, Edgy, or Feisty? I have Dapper LTS because
> I want to be on something as stable as possible. I'm about two minutes
> from calling Canonical to pay for support so that I can learn how to
> roll back last Wednesday or Thursday's Xorg patch so that my rdesktop
> goes back to working again. I depend on rdesktop very heavily still in
> my day job, unfortunately, because Evolution has not worked well for me,
> as I describe in this thread:
>
> http://ubuntuforums.org/showthread.php?p=2516247#post2516247
>
> I also have to connect to Windows servers as part of my day job for LAN
> management.
>

In synaptic search for libx11-6 and select it, then click on the package
menu and select force version, you should then be able to roll back to
the version before the security patched edition that broke things. you
can then lock the version if needed, again via the package menu.

If that doesn't work you can easily re-apply the security patch.

Regards
Alistair Crust
System Administrator
Skegness Grammar School
Vernon Road
Skegness
Lincs
UK
01754610000 ext 852

Kees - trying patch now. Alistair - thanks for letting me know this.

Kees Cook (kees) wrote :

Supermike, you're making mine! I don't have an easy way to test these fixes, so I'm glad you're online. :)

Supermike (reachmike) wrote :

Kees - You must be some kind of genius. That fixed me on Dapper connecting to XP, W2K3 Server, and W2K Advanced Server. Thanks so much!

Kees Cook (kees) wrote :

Supermike, I just compiled it. :) Thanks go to Michael Gernoth, and Reinhard Tartler. :)

I will get these fixes published shortly to the security archives. Thanks again for testing it!

Changed in rdesktop:
assignee: nobody → keescook
importance: Undecided → High
status: Confirmed → Fix Committed
assignee: nobody → keescook
status: Confirmed → Fix Committed
Tim Wieneke (tim-spen) wrote :

thanks a lot from germany. My feisty is now also again talking to the windows2000 server ;*) (8bit color)
I was nearly starting to install windows on the xen machine ;o)

Kees Cook wrote:
> Supermike, I'll have a Dapper .deb up for you to try shortly.
>

Kees, I've seen your name a lot around here, so I assume that means
you're a Good Guy (tm) and a great person to ask a lingering, albeit
tangent question. I've recently starting building debs out of some of
my own cruft, hoping to someday spiff it up enough for the rest of the
world to laugh at. :)

Anyway, I mostly write python and as I'm sure you're aware, it's rather
portable, if done right. Can you point me to a good source of info on
building debs for Ubuntu/Debian the right way. I already use svn and
can clearly see from what I've learned so far that Debian and by
extension Ubuntu too benefit from lots of automation. I hope to make
packages that work on a wide range of Ubuntu releases, yet work mostly
at the source level. I don't want to fiddle with the stuff in between
each time each change, except to set up the automation.

I've already read the Debian New Maint Guide insofar as much as was
needed to build my first few.

--
JohnF_

Hi John,

Getting involved in MotU[1] is the best way to go. There are a number of great resources[2] in the wiki. Additionally, looking at other people's packages, learning pbuilder or sbuild, and generally trying stuff is the best way to go.

[1] https://wiki.ubuntu.com/MOTU
[2] https://wiki.ubuntu.com/UbuntuDevelopment

Hi Jhon what i've done to downgrade to libx11-6 was to use aptitude to remove
this library, but this could be risky.

You may want to try to download the previous version of libx11-6
1.0.0-0ubuntu9 (dapper) and install it with dpkg -i

hope this helps...

El Lunes, 23 de Abril de 2007 10:42, Supermike escribió:
> John Florian -- with Dapper, Edgy, or Feisty? I have Dapper LTS because
> I want to be on something as stable as possible. I'm about two minutes
> from calling Canonical to pay for support so that I can learn how to
> roll back last Wednesday or Thursday's Xorg patch so that my rdesktop
> goes back to working again. I depend on rdesktop very heavily still in
> my day job, unfortunately, because Evolution has not worked well for me,
> as I describe in this thread:
>
> http://ubuntuforums.org/showthread.php?p=2516247#post2516247
>
> I also have to connect to Windows servers as part of my day job for LAN
> management.

John Florian (j100) wrote :

Kees Cook wrote:
> Hi John,
>
> Getting involved in MotU[1] is the best way to go. There are a number
> of great resources[2] in the wiki. Additionally, looking at other
> people's packages, learning pbuilder or sbuild, and generally trying
> stuff is the best way to go.
>
> [1] https://wiki.ubuntu.com/MOTU
> [2] https://wiki.ubuntu.com/UbuntuDevelopment
>

Many thanks Kees! That's just what I was hoping for. Hadn't heard the
terms pbuilder/sbuild before (not sure how when I live/breath Linux) --
I now I have the right threads to start following. Those wiki starting
points look perfect for what I needed.

Keep up the great work!

--
JohnF_

Reinhard Tartler (siretart) wrote :

Supermike <email address hidden> writes:

> I have Dapper and tried Reinhard's deb:
>
> http://archive.ubuntu.com/ubuntu/pool/main/r/rdesktop/rdesktop_1.5.0-1ubuntu1~prop1_i386.deb

Sorry, the package is for feisty only. I'm not aware that this bug also
affects dapper. If it does, can you set the dapper task to 'confirm'?
I'll upload version for dapper to proposed then.

--
Gruesse/greetings,
Reinhard Tartler, KeyID 945348A4

Supermike (reachmike) wrote :

Reinhard, I don't know yet what I'm doing in this app, but I tried to follow your suggestion and switched this bug to confirmed. Kees Cook's patch worked for me on Dapper.

Also, not that you asked, but I don't have Edgy, nor know anyone who has it, so I cannot confirm the bug for Edgy.

Changed in rdesktop:
status: Fix Committed → Confirmed
Kees Cook (kees) on 2007-04-25
Changed in rdesktop:
status: Confirmed → Fix Committed
Bert Jan Wezeman (bertjan) wrote :

Hi,

I just tried http://archive.ubuntu.com/ubuntu/pool/main/r/rdesktop/rdesktop_1.5.0-1ubuntu1~prop1_i386.deb on feisty and the problem seems to be solved.

$ sudo dpkg -l |grep rdesktop
ii rdesktop 1.5.0-1ubuntu1~prop1 RDP client for Windows NT/2000 Terminal Serv

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 7.04
Release: 7.04
Codename: feisty

Regards,
Bert Jan

Steve Kowalik (stevenk) wrote :

I also just tried the updated rdesktop package in feisty-proposed, and it works fine for me.

knine (jalbretsen) wrote :

Just tried it, feisty-proposed worked great for me. Thanks!

Martin Pitt (pitti) wrote :
Changed in rdesktop:
status: Fix Committed → Fix Released
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Accepted into feisty-updates.

Changed in rdesktop:
status: Fix Committed → Fix Released
Changed in rdesktop:
status: Unconfirmed → Fix Released
Changed in rdesktop:
status: Fix Committed → Fix Released
Johan Dahlin (jdahlin) wrote :

I can confirm that this is also an issue on edgy, I'd like to see a version pushed to edgy too, if possible

Johan Dahlin (jdahlin) wrote :

An Edgy deb with this patch applied is available at http://www.async.com.br/~jdahlin/misc/rdesktop_1.4.1-1.2_i386.deb

Reinhard Tartler (siretart) wrote :

there should be an updated rdesktop package in edgy-security

Changed in rdesktop:
assignee: nobody → whoopie79
Whoopie (whoopie79) wrote :

patch is in gutsy's rdesktop package. Sorry for the inconvenience.

Changed in rdesktop:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.