Ubuntu

Highpitched rattling like sound with 5.1 surround configuration

Reported by Chris O on 2009-10-07
460
This bug affects 94 people
Affects Status Importance Assigned to Milestone
PulseAudio
Invalid
Undecided
Unassigned
pulseaudio (Ubuntu)
Medium
David Henningsson
Lucid
Undecided
Unassigned
Maverick
Undecided
Luke Yelavich

Bug Description

SRU justification:
Pulseaudio contains volume scaling code optimized for the MMX and SSE instruction sets on X86, and optimized volume scaling code for some ARM CPU variants. This code initially did not deal with unusual numbers of channels, 3, 5, 6 and 7 on x86 using the SSE instruction set, and 3 on X86 using the MMX instruction set, and ARM. This resulted in various odd sounds, such as indicated in the original bug report below, and other comments in this report. This SRU fixes the code to correctly deal with the above number of channels, 6 channels being common for 5.1 audio output. Thanks to David Henningsson for the patch.

Regression potential:
There is a very low chance of this regressing other parts of PulseAudio. The patch in question only touches the optimized code source files in the source tree, so the chance of this affecting other users detrimentally is extremely unlikely.

This fix is in the above linked pulseaudio natty branch, ready for upload once natty is open for general development.

Original bug report follows:

Binary package hint: pulseaudio

I'm hearing a high pitched rattling sound when I have pulseaudio set to 5.1 surround
I set PulseAudio to 5.1 surround via the PulseAudio Volume Manager under the Configuration Tab
I'm running the Karmic Koala beta with all the newest Updates
I have a 82801JI (ICH10 Family) HD Audio Controller

I've tried other settings under the Configuration Tab, Analog Stereo seems to work perfectly but I have a 5.1 Surround Speaker Setup.

This problem seems to get worse as I increase the volume through pulseaudio, if I change the volume of a individual channel it gets almost impossible to listen to anything, all I can hear is a high pitched rattling like sound. However if I set the volume of channels individually through 'alsamixer' it doesn't screw up at all.

ProblemType: Bug
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: chris 2096 F.... pulseaudio
 /dev/snd/pcmC0D0c: chris 2096 F...m pulseaudio
 /dev/snd/pcmC0D0p: chris 2096 F...m pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf9ff8000 irq 22'
   Mixer name : 'Realtek ALC1200'
   Components : 'HDA:10ec0888,104382fe,00100101'
   Controls : 40
   Simple ctrls : 22
Date: Wed Oct 7 18:01:59 2009
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia
Package: pulseaudio 1:0.9.18-0ubuntu3
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: pulseaudio
Uname: Linux 2.6.31-pae i686

Chris O (megacrash57) wrote :

Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: chukysoria 2088 F.... pulseaudio
 /dev/snd/controlC1: chukysoria 2088 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xefffc000 irq 21'
   Mixer name : 'SigmaTel STAC9200'
   Components : 'HDA:83847690,102801cd,00102201 HDA:14f12bfa,14f100c3,00090000'
   Controls : 13
   Simple ctrls : 7
Card1.Amixer.info:
 Card hw:1 'PSC805'/'Philips Electronics Philips PSC805 at usb-0000:00:1d.2-1, full speed'
   Mixer name : 'USB Mixer'
   Components : 'USB0471:0155'
   Controls : 4
   Simple ctrls : 1
DistroRelease: Ubuntu 9.10
Package: pulseaudio 1:0.9.19-0ubuntu2
PackageArchitecture: i386
ProcEnviron:
 SHELL=/bin/bash
 LANG=es_ES.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-14.47-generic
Uname: Linux 2.6.31-14-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare vboxusers

tags: added: apport-collected

Also affects me.

Previously with Jaunty audio was working perfectly. After update to Karmic (in Alpha 5) I haven't been able to use the USB external sound card which is 5.1 surround. A really loud noise makes it unusable, however you can hear in some way the correct sound is playing.

I have attached the apport data if useful.

This must be a regression issue.

tags: added: regression-potential
Changed in pulseaudio (Ubuntu):
status: New → Confirmed
Changed in pulseaudio (Ubuntu):
importance: Undecided → High
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)

Luke, I know there is a team to assign sound bugs to, but I forget what the team is ... please reassign as appropriate.

Changed in pulseaudio (Ubuntu):
assignee: Canonical Desktop Team (canonical-desktop-team) → Luke Yelavich (themuso)
amano (jyaku) wrote :

Hmm. I seem to have this issue, too. But I have a Soundblaster Live 5.1 card. And it seems to have regressed. If I don't remember wrong, Karmic Beta was totally fine. Thus it must have regressed with some of the recent upgrades...

It seems to be getting worse for me. At first it was only slight but now
it's utterly unlistenable.
2009/10/17 amano <email address hidden>

> Hmm. I seem to have this issue, too. But I have a Soundblaster Live 5.1
> card. And it seems to have regressed. If I don't remember wrong, Karmic
> Beta was totally fine. Thus it must have regressed with some of the
> recent upgrades...
>
> --
> Highpitched Rattling like Sound with 5.1 Surround Configuration on Karmic
> Koala
> https://bugs.launchpad.net/bugs/445849
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

I also get this. I have a Creative X-Fi card. Stereo works fine, 7.1 works fine, but 5.1 (which is what I would like to use) has this sound. It gets worse as you move the sliders for panning and fading.

Mike Williams (drdred5) wrote :

I have the same problem, Soundblaster live 5.1 Using 5.1 analog outputs.

I've done a bit of experimentation to see if I would be able to narrow down or fix the issue.

As suggested in the thread http://ubuntuforums.org/showthread.php?t=1276999 i changed the following.

Quote:

"Check in /etc/pulse/daemon.conf and try uncommenting the line
enable-remixing=yes

You can also try changing the default sample rate from 44100 to 48000, some cards are only capable of 48000.

You can also try changing the default-fragments and increasing the default-fragment-size but that is usally necessary only if the sound is suttering.

You can read about these settings by typing in a terminal"

I also removed Pulseaudio the sound quality seemed to improve greatly, but only 2.0. I also attempted to build the latest Pulseaudio from source, but ran into dependency problems and have since abandoned the attempt.

I also have this problem. Im using Karmic amd64 with an OnBoard HDA Nvidia Soundcard. I tried what Mike supposed, but nothing helped.

Chris O (megacrash57) wrote :

I've tried editing /etc/pulse/daemon.conf, nothing I did seemed to work, but I found out I can set it to 4.0 surround without the sound screwing up, but as soon as I go to 4.1, 5.0, or 5.1 the sound becomes corrupt

Would you please attach separately the outputs from 'amixer' in a
Terminal after you set the profile to 4.0 surround and again after you
set the profile to each of 4.1, 5.0, and 5.1 surround?

Chris O (megacrash57) wrote :
Chris O (megacrash57) wrote :
Chris O (megacrash57) wrote :

While doing this I noticed 5.0 sounds worse than 5.1

yann (yann-strozecki) wrote :

I also have this problem.
In fact I had it with karmic alpha 5 (amd64 ) and it was fixed by maybe beta 1 but it returns a few days ago.
I have the high pitched sound for 5.1 but also bad sound for 4.0 and even 2.0 give me some crackling sounds
and when numerous sound are played the become awful. I try playing warzone 2100 and when all my units were firing
the sound was crazy and eventually crashed.
My card is a sound blaster audigy 4 recognized as a Creative Labs SB0400 Audigy2 Value.
I tried some change to the daemon conf without any result.

Mastermolch (molchx) wrote :

I reported a similar bug about my Creative Audigy 2 ZS Notebook. So maybe my report is a duplicate of this one. Members from the Gnome channel on freenode told me to make a bug report. Here is it:

https://bugs.launchpad.net/ubuntu/+source/alsa-lib/+bug/462283

But the "AnalogMix" problem seems to be another problem.

mdgill (michaelgill1969) wrote :

I am using a MacBook 4,1 (aka MacBook Early 2008?). The daemon.conf suggestions don't have any effect. Also, there is only the Master slider in alsamixer output. The "speaker-test -c6" gives six channels, with front and rear, left and right, and center checking out OK (using the left and right speakers in different combos and volumes). However, it does not activate the LFE speaker under the keyboard (or so I have heard that's where it is).

However, gamix fixes the problem if the LFE button is toggled off and on. This seems to work fine, at least for a while. At some point, the audio becomes unstable, which may have been a problem with messing around with daemon.conf. Now that it is set to default, I can report later if instability arises again. For now, gamix appears to fix the LFE. I don't know why.

@mdgill Is this using "speaker-test -Dplug:surround51 -c6"? (Please
note that the -Dplug:surround51 is *vital* for debugging.)

Using "speaker-test -Dplug:surround51 -c6", only the front-left and front-right produces a sound. There are only 3 speakers on a MacBook 4,1, so this looks like a much better test. So, the LFE does seem to work using gamix, but definitely does not with "speaker-test -Dplug:surround51 -c6".

Looks like a codec routing issue, then, because plug:surround51
definitely should do the right thing...

Updating my first post, the audio still becomes unstable after 20-30 minutes, at least when using Banshee with the LFE turned on using gamix. The bass end becomes very distorted in the LFE, and also in what bass comes through the left/right-front speakers.

Tibbey (a-tibbey) wrote :

I have this problem too. I normally listen to my music from Spotify, and I can't hear a thing because there is so much rattling! It worked fine in Jaunty, and I use the intergrated sound card.

Hi,

I have just installed the following package:

linux-backports-modules-alsa-karmic-generic

After installing and rebooting the problem has dissapeared and now worked flawlessly.

Nate Wiebe (natew) wrote :

Installing linux-backports-modules-alsa-karmic-generic did not solve the problem for me.

Installing linux-backports-modules-alsa-karmic-generic fixed the high pitched problem. But If I set the Profile to 5.1 there is no sound coming from either centre channel or boss.
Didn't have any problem like this with jaunty.
I am sorry, what the f**k is going on in there? does anyone even test this OS before releasing it? every time I install new ubuntu version there is something wrong with it. See https://bugs.launchpad.net/bugs/351186
I will try opensuse as soon as it comes out but I don't think it would be any better.

Ubuntu 9.10 using default kernel
Asus P5QL Pro with Onboard realtek
ATI 3650 HD using fglrx driver
Creative surround 5.1 speakers

anttin (anttin-gmail) wrote :

Installing linux-backports-modules-2.6.31-14-generic-pae, restarting alsa-utils and killing pulseaudio fixed the 5.1 problem for me. I got the center channel working by unmuting it from alsamixer.

Kernel: 2.6.31-14-generic-pae #48-Ubuntu SMP
Sound card: Creative X-Fi

Sebastian Breier (tomcat42) wrote :

Also affects me. The funny thing is: It never did for a week until now. I changed nothing big in configuration, and now I have that noise every time.

tags: added: regression-release
removed: regression-potential
Daniel T Chen (crimsun) on 2010-03-25
Changed in pulseaudio (Ubuntu):
status: Confirmed → Triaged
Daniel T Chen (crimsun) on 2010-04-12
Changed in pulseaudio (Ubuntu):
importance: High → Medium
tags: added: patch
papukaija (papukaija) on 2010-07-26
tags: added: karmic
summary: - Highpitched Rattling like Sound with 5.1 Surround Configuration on
- Karmic Koala
+ Highpitched rattling like sound with 5.1 surround configuration
Changed in pulseaudio (Ubuntu):
assignee: Luke Yelavich (themuso) → David Henningsson (diwic)
status: Triaged → In Progress
Luke Yelavich (themuso) on 2010-10-14
Changed in pulseaudio (Ubuntu Maverick):
assignee: nobody → Luke Yelavich (themuso)
status: New → In Progress
Luke Yelavich (themuso) on 2010-10-14
description: updated
description: updated
Martin Pitt (pitti) on 2010-10-14
Changed in pulseaudio (Ubuntu Maverick):
status: In Progress → Fix Committed
tags: added: verification-needed
tags: added: verification-done
removed: verification-needed
Changed in pulseaudio (Ubuntu Maverick):
status: Fix Committed → Fix Released
Martin Pitt (pitti) on 2010-10-20
Changed in pulseaudio (Ubuntu):
status: In Progress → Fix Released
178 comments hidden view all 258 comments
cccccccc (cccccccc) wrote :

has anybody from the "problematic group" tried plafuro's solution with diwic repository? I am pretty reluctant to test a new repository, which are not default in system.

Jmadero (jmadero) wrote :

Diwic is a developer so his repo is clean and safe. As for adding it, I believe it's been committed to the regular repository now so there should be no need to add the repo. Someone correct me if I'm wrong

David Henningsson (diwic) wrote :

@Jmadero, c x 8, plafuro:

* The actual fix for this issue has been released through maverick-updates already, but if many people experience that 0.9.22 fixes their problems whereas the maverick-updates version does not, perhaps we need to look into this more closely.

* For my personal ppa, do not assume that things there are stable unless told so for a specific package. E g, the pulseaudio version there, is for testing a new module I wrote last week.

* Pulseaudio 0.9.22 for Maverick has just been made available through the ubuntu-audio-dev ppa, so please use that instead if you want to test 0.9.22: https://launchpad.net/~ubuntu-audio-dev/+archive/ppa

cccccccc (cccccccc) wrote :

guys, i just tried this stuff and 5.1 works (from normal ubuntu repo)!!!!!!!!!!!!!! after almost 2 years!!! I can now use my surround system! many thanks! im going to enjoy all the movies now!

Simon Allen (garfunkel) wrote :

It's still dodgy for me. Both with a Xonar DX and with the inbuilt Realtec
chip on my Asus P8P67 Pro. Every time I open a window or something the sound
either turns off or It suddenly goes all deep and creepy (It sounds like
those movies where the kidnapper talks to the parents to give a random note
ant their voice is modulated by a box to hide their identity. It's a bit
creepy sounding actually). I've pretty much given up on pulseaudio. It's
beyond me that it is this difficult to get 5.1 surround working in the year
2011. Windows 98 surround sound worked out of the damn box. At least
Archlinux doesn't force this crap on me. I don't get why they are focusing
on Unity which isn't needed at the moment, and IMHO won't nearly be ready
for 11.04 and not on getting the basics actually... working.

On 5 February 2011 07:28, cccccccc <email address hidden> wrote:

> guys, i just tried this stuff and 5.1 works (from normal ubuntu
> repo)!!!!!!!!!!!!!! after almost 2 years!!! I can now use my surround
> system! many thanks! im going to enjoy all the movies now!
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (440921).
> https://bugs.launchpad.net/bugs/445849
>
> Title:
> Highpitched rattling like sound with 5.1 surround configuration
>

cccccccc (cccccccc) wrote :

Simon,

is your problem similar to my "latest" problem - pls see https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/714879? First I wrote, surround is working but suddenly, this new bug visits my computer at random.

Simon Allen (garfunkel) wrote :

maybe. My audio slows down and goes freaky just like what he's saying. But
I'm not experiencing video slowdown or anything. (I'm running a sandy bridge
build now with a 2600k though so maybe there is just so much horsepower that
i'm just not seeing it slow down). But yeah, I'm thinking it might be the
same bug, I'm sorry I didn't report it a few weeks ago but I got really
annoyed and had one of those pulsecrap 'I give up' moments.

On 11 February 2011 12:13, cccccccc <email address hidden> wrote:

> Simon,
>
> is your problem similar to my "latest" problem - pls see
> https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/714879? First
> I wrote, surround is working but suddenly, this new bug visits my
> computer at random.
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (440921).
> https://bugs.launchpad.net/bugs/445849
>
> Title:
> Highpitched rattling like sound with 5.1 surround configuration
>

cccccccc (cccccccc) wrote :

I'm happy I am not alone with this slowdown on sound (video sometimes is slowed, sometimes not) and interference. Please, do join me in my bug with more comments (now it looks like I am alone in the dark:)).
but it is an interesting bug, it is hard to reproduce, since it occurs spontaneously. i found out, that if i manage to ignore it, it would stop after 15 or 20 minutes.
i like the name pulsecrap. thumbs up.

Simon Allen (garfunkel) wrote :

Pulseaudio is being sporatic on me. Right now it isn't making the funny
noises. Before I rebooted about 5 minutes ago it was (and there were no
upgrades to pulseaudio to change that). But just wait because if I reboot it
probably will. I have NO IDEA where or why the hell the is occurring. And
still every time I change the front/rear balance in the sound settings
everything just falls in a heap.

It just makes me so damn resistant to try SystemD,

On 17 February 2011 07:29, cccccccc <email address hidden> wrote:

> I'm happy I am not alone with this slowdown on sound (video sometimes is
> slowed, sometimes not) and interference. Please, do join me in my bug with
> more comments (now it looks like I am alone in the dark:)).
> but it is an interesting bug, it is hard to reproduce, since it occurs
> spontaneously. i found out, that if i manage to ignore it, it would stop
> after 15 or 20 minutes.
> i like the name pulsecrap. thumbs up.
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (440921).
> https://bugs.launchpad.net/bugs/445849
>
> Title:
> Highpitched rattling like sound with 5.1 surround configuration
>

Jmadero (jmadero) wrote :

When will this be committed to Lucid? I'm a bit frustrated that long term release is so far behind (I always thought that LTS meant that it was stable and but up to date...this fix has been out for several months now yet for those of us who want to stick with LTS we're stuck with high pitched 5.1 sound). Sorry, not trying to be unappreciative, my 10.10 system sounds great now but my stable LTS system still can't use 5.1 and I'm hesitant to upgrade it to 10.10 (it's a netbook version and I like 10.04 a lot more than the new Unity interface). Thanks in advance

David Henningsson (diwic) wrote :

@Jmadero, jova, I believe you're right, this fix should be backported to Lucid.

Here comes a debdiff for lucid SRU.

David Henningsson (diwic) wrote :

@Jmadero, jova, can you help me by testing this package under Lucid before I ask for it to be officially released? I've made a test package in ppa:diwic/ppa - please install all packages beginning with "pulseaudio" or "libpulse".

jova (jova3078) wrote :

David Henningsson, I applied the patched version of pulseaudio from your ppa on a new install of Ubuntu 10.04 and it fixed the problem. Thank you!

Clint Byrum (clint-fewbar) wrote :

REJECTED: the package version 1:0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu14.1 uploaded to lucid-proposed should not be accepted.

David, please add a bug reference to the changelog entry and re-upload to lucid-proposed.

The rest of the diff looks fine.

Changed in pulseaudio (Ubuntu Lucid):
status: New → Confirmed
Luke Yelavich (themuso) wrote :

Whoops, thats totally my fault, I totally missed that.

Adding bug reference and uploading again, thanks for the feedback.

Clint Byrum (clint-fewbar) wrote :

APPROVED: the package version 1:0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu14.1 should be accepted into lucid-proposed

No worries Luke, thanks for fixing it!

Jmadero (jmadero) wrote :

Thanks all for the quick work on getting this back-ported. My system running 10.04 sounds great now, really appreciate how fast this proceeded.

Accepted pulseaudio into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in pulseaudio (Ubuntu Lucid):
status: Confirmed → Fix Committed
tags: removed: verification-done
tags: added: verification-needed
nebcanuck (nebcanuck) wrote :

Running Natty Beta 2 and experiencing a similar problem, though it seems to be slightly different than the original description. My 5.1 surround sound system seems to rattle only when my volume is lower than the maximum; so long as I keep it on max and adjust the volume of individual applications I do not hear the rattle.

Is there some way to resolve this on Natty? My driver is an ALC888. Don't know if that makes any difference.

Bartosz Kosiorek (gang65) wrote :

Right now the package pulseaudio - 1:0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu21.1 it is in lucid-proposed and needs some testing to ensure it fixes the bug and does not create any regression before it can go as an SRU. Can you give it a try?

Instructions:
https://wiki.ubuntu.com/Testing/EnableProposed

David Henningsson (diwic) wrote :

Hi folks,

It seems like the previous patch only solved the hiss for amd64 and not for i386. Is that consistent with what you're experiencing? Anyhow, I believe I've managed to come up with a patch that should fix it for i386 as well. I have also uploaded one for Natty into ppa:diwic/ppa, could you test it? It should build in a few hours. (Note: You need to upgrade everything starting with "pulseaudio" or "libpulse", just the pulseaudio package is not enough)

I'm also attaching the patch here if you want to try compiling it yourself.

1 comments hidden view all 258 comments

Most of these issues are gone for me with the latest natty updates. But
every so often pulseaudio screws up. I don't get the rattling sound anymore,
but what I do get is this weird high pitch gurgling noise. The only way I
can describe it is that noise you hear on TV when your watching a show about
war and a granade goes off and deafens someone and they play that loud high
pitch noise. It sounds a bit like that. Killing pulseaudio and playing the
file again fixes it. If I had to have an educated guess on what it's doing
i'd say it's something to do with the sample rates of the playback going
awry or something.

It's very annoying when other's are on the computer with you, it just makes
Ubuntu/Linux look bad.

Obviously, all sound still breaks completely if I so much as touch the
balance/volume/subwoofer sliders in the sound preferences. I don't think
anyone on earth actually understands how this crappy code works. It makes me
scared to ever try SystemD. That's gonna be pulseaudio 2.0.

On 27 May 2011 19:09, David Henningsson <email address hidden> wrote:

> ** Patch added:
> "0001-SSE-MMX-Fix-problem-with-highpitched-noise-on-i386.patch"
>
> https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/445849/+attachment/2144422/+files/0001-SSE-MMX-Fix-problem-with-highpitched-noise-on-i386.patch
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (440921).
> https://bugs.launchpad.net/bugs/445849
>
> Title:
> Highpitched rattling like sound with 5.1 surround configuration
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/445849/+subscribe
>

Simon Allen (garfunkel) wrote :

I should also say, this is on 64bit.

On 27 May 2011 20:05, Simon Allen <email address hidden> wrote:

> Most of these issues are gone for me with the latest natty updates. But
> every so often pulseaudio screws up. I don't get the rattling sound anymore,
> but what I do get is this weird high pitch gurgling noise. The only way I
> can describe it is that noise you hear on TV when your watching a show about
> war and a granade goes off and deafens someone and they play that loud high
> pitch noise. It sounds a bit like that. Killing pulseaudio and playing the
> file again fixes it. If I had to have an educated guess on what it's doing
> i'd say it's something to do with the sample rates of the playback going
> awry or something.
>
> It's very annoying when other's are on the computer with you, it just makes
> Ubuntu/Linux look bad.
>
> Obviously, all sound still breaks completely if I so much as touch the
> balance/volume/subwoofer sliders in the sound preferences. I don't think
> anyone on earth actually understands how this crappy code works. It makes me
> scared to ever try SystemD. That's gonna be pulseaudio 2.0.
>
> On 27 May 2011 19:09, David Henningsson <email address hidden> wrote:
>
>> ** Patch added:
>> "0001-SSE-MMX-Fix-problem-with-highpitched-noise-on-i386.patch"
>>
>> https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/445849/+attachment/2144422/+files/0001-SSE-MMX-Fix-problem-with-highpitched-noise-on-i386.patch
>>
>> --
>> You received this bug notification because you are a direct subscriber
>> of a duplicate bug (440921).
>> https://bugs.launchpad.net/bugs/445849
>>
>> Title:
>> Highpitched rattling like sound with 5.1 surround configuration
>>
>> To unsubscribe from this bug, go to:
>>
>> https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/445849/+subscribe
>>
>
>

Jmadero (jmadero) wrote :

Simon, that's really strange. Since the patch pulse works flawlessly for me, no sounds what so ever, and I can use balance/volume/sub perfectly (I actually wish that they would make sub go even lower sometimes, watching a movie at 1am with deep bass can be an issue). I wonder why you're seeing issues still

I have a creative surround 5.1 USB card, and the card just gives high pitched noise in any setting.
The noise gets higher in 5.1 setting.
The bug fix only mentions Maverick, and Lucid, what about Natty?
Is the patch already available in Natty or will be made available soon?

Changed in pulseaudio:
status: New → Invalid
Anton Statutov (astatutov) wrote :

I can't figure out how to assign this bug to Natty also. It's affected by this bug too. I've tested patches from ppa:diwic/ppa and can confirm they solve the rattling problem, but new problems appears. First, the sound checking utility from the pulseaudio settings produces very strange sound (just like vintage phone ring, but I don't think it is conceived). Second, 5.1 audio now plays like stereo, i.e. the front and rear channels are not independent now (I have an ac3 audio for checking this).

David Henningsson (diwic) wrote :

@Anton, you must have downloaded other packages from my ppa, not only the pulseaudio packages (e g the ubuntu-sounds package where I experiment with speaker-test sounds...).

To make testing easier for all of you, I have now instead made a separate ppa with only the pulseaudio packages in. Testing should now be as simple as:

sudo apt-get install ppa-purge
sudo ppa-purge ppa:diwic/ppa
sudo add-apt-repository ppa:diwic/pulseaudio-testing
sudo apt-get update
sudo apt-get dist-upgrade

Alexey Loukianov (lexa2) wrote :

Ok, well, I'm mostly from LFS/Gentoo/Fedora side of the table, but this month I'm working off-site and has to use external HDD with Linux Mint 9 (Ubuntu 10.04 LTS based) Live CD copied into as the main working system. Speakers setup here is an ordinary 5.1 cheap set from Defender connected to the MB's build-in HDA codec. Having problems with PulseAudio had become such a typical thing so I hadn't been surprised to run into high-pith sound distortions I get as soon as set soundcard to work with Analog Out 5.1 profile. For a first few weeks I hadn't had enough time to investigate so the solution was to simply set "autospawn = no" into /etc/pulse/client.conf, 'echo "pcm.!default plug:dmix" > ~/.asoundrc"' and reconfigure all relevant stuff to use alsa instead of pulse (gstreamer-properties, mplayer, vlc, e.t.c.).

Today I finally had found some time to hunt down this bug. Quick google search lead me into this bug report, and reading a bunch of comments made me believe that the problem is related with incorrect PulseAudio SIMD optimizations and that it might be fixed in ubuntu-proposed and/or in the diwic/pulseaudio-testing ppa. Unfortunately both ubuntu-testing and diwic ppa hadn't been able to fix the problem. As for pusle* and libpulse* packages from lucid-testing - nothing seems to be changed after installing them. The problems with 5.1 distorted sound remain the same. Diwic's pulseaudio-testing ppa seems to be maverik-only, but the diwic/ppa seems to had fresh pulseaudio stuff. It is broken the same was as the packages in lucid-proposed though.

Trying to investigate a bit mode I had turned off the PA auto spawning again, killalled pulseaudio and run "PULSE_NO_SIMD=1 pulseaudio" in the terminal. Having SIMD optimizations disabled this way fixes the problem: no more sound distortions caused by "smart and cool daemon every desktop user should use" PulseAudio. For now I'm going to export PULSE_NO_SIMD=1 system wide and maybe wait another year till this thing would be finally fixed in so-called "LTS" release.

I'm quite disappointed in LTS support policy, really. This bug had been known for ages, and releasing such a simple thing as a workaround using aforementioned environment variable should had taken no longer than about a week. After making suffering people happy by applying workaround it would be reasonable to implement and test the real fix (for ex., rewrite SIMD assembly optimizations) and then finally release a patched version that "does it right". Looks like Ubuntu's (and thus derivate distros) support policy is totally the opposite, leaving people suffer from the bug and hunting around for workarounds themselves (like switching into using "Major Market Share OS" or following one of the numerous FAQ about "how to get the f***ing rid of this sh*tty PA on Ubuntu/Mint/Whatever"). *sadface smile*

Alexey Loukianov (lexa2) wrote :

Upd: Sad so report, but the PULSE_NO_SIMD=1 fixed only one part of the problem: the high frequency distortion. What had left is the strange volume pulsation over the channels. The most close match I can imagine to describe the problem is like someone is sitting at the mixer control and constantly moves the channel volume fader up and down in cycles. Or spins balance potentiometer forward-and-backwards. Perceived audio picture is mad and no-no for normal use. Have to revert back info disabling PA system wide.

Anton Statutov (astatutov) wrote :

@David, I forgot to notify, that I've tested new ppa packages on my system (Maverick) and can confirm they're working well. I haven't noticed any problem during more than month of using it.

David Henningsson (diwic) wrote :

New debdiff for Lucid which includes fixes for both amd64 and i386

1 comments hidden view all 258 comments
Bartosz Kosiorek (gang65) wrote :

Hi.
Could you please install pulseaudio package from Maveric into Lucid, and check if it helps?

Maybe in that way?:

Step 1:
Fetch the maveric .deb file. You can get this from:
https://launchpad.net/ubuntu/natty/+package/pulseaudio

Step 2:
Remove the current version of pulseaudio from your machine.
sudo dpkg --purge pulseaudio

Step 3:
Install the version that you downloaded in Step 1.
sudo dpkg -i pulseaudio .....deb

The fix for this bug has been awaiting testing feedback in the -proposed repository for lucid for more than 90 days. Please test this fix and update the bug appropriately with the results. In the event that the fix for this bug is still not verified 15 days from now, the package will be removed from the -proposed repository.

tags: added: removal-candidate
Brian Murray (brian-murray) wrote :

The version of pulseaudio in lucid-proposed has been removed as the bugs it was fixing (including this one) were not verified in a timely fashion.

tags: removed: verification-needed
tags: removed: removal-candidate
Changed in pulseaudio (Ubuntu Lucid):
status: Fix Committed → Triaged
GoncaloP (goncalop) wrote :

Hello. I still have this problem in Ubuntu 13.04. The sound fails all the time, and the only way to fix it is to manually change the sound controls in the sound panel. By changing balance and volume, it comes back. As soon as I increase or decrease the volume again, it goes bad again. The only way to prevent this is to only change volume in the hardware.

Please note: I don't have any problems when using stereo headphones.

Murz (murznn) wrote :

I also confirm issue described by GoncaloP (goncalop) on Ubuntu 12.10 and 13.04 using 5.1 or 5.0 surround system. Is this the same problem or sepearate issue?

David Henningsson (diwic) wrote :

It's a separate issue. This issue is fixed since long ago.

Displaying first 40 and last 40 comments. View all 258 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.