Ubuntu

ALSA/PulseAudio output connector identification wrong on Dell XPS M1330 (Karmic A3)

Reported by Craig Ringer on 2009-08-23
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gnome-media

gnome-volume-control or the underlying PulseAudio / ALSA system(s) misidentify the output channels on this Dell XPS M1330 laptop.

The "Analog Output" connector, which is selected by default, is the 2ndary headphone / line out port.

The "Analog Headphones" connector, which is not the default selection, is the main headphone connector and (if no headphones are connected) drives the built-in speakers.

ProblemType: Bug
Architecture: i386
Date: Sun Aug 23 20:38:01 2009
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia
Package: gnome-media 2.27.90-0ubuntu1 [modified: usr/bin/gnome-audio-profiles-properties usr/bin/gnome-sound-recorder usr/bin/gnome-volume-control usr/bin/gnome-volume-control-applet usr/bin/gstreamer-properties]
ProcEnviron:
 PATH=(custom, user)
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-6.25-generic
SourcePackage: gnome-media
Uname: Linux 2.6.31-6-generic i686

Craig Ringer (ringerc) wrote :
Craig Ringer (ringerc) wrote :

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu karmic (development branch)
Release: 9.10
Codename: karmic

$ uname -a
Linux ayaki 2.6.31-6-generic #25-Ubuntu SMP Fri Aug 14 16:25:04 UTC 2009 i686 GNU/Linux

Changed in gnome-media (Ubuntu):
importance: Undecided → Low
affects: gnome-media (Ubuntu) → pulseaudio (Ubuntu)
Jamie Bennett (jamiebennett) wrote :

The result of this is that the volume is _very_ low to the point that unless you are listening carefully (or you don't have the volume up to max) you could be mistaken into thinking that sound isn't working on your machine.

This resulted in a good 10 minutes of head scratching and searching launchpad for me so I'm sure it will effect a lot of users with this hardware.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 1:0.9.22~0.9.21+341-g62bf-0ubuntu1

---------------
pulseaudio (1:0.9.22~0.9.21+341-g62bf-0ubuntu1) lucid; urgency=low

  * New snapshot based on stable-queue git branch (testing requested
    specifically by upstream)
    - LP: #164745, #173212, #201391, #204536, #207796, #210016, #221038,
    - LP: #226342, #230408, #236423, #237443, #250059, #269585, #274304,
    - LP: #274577, #275474, #277532, #277566, #277932, #278025, #280534,
    - LP: #283049, #286816, #287036, #292732, #298011, #298301, #300290,
    - LP: #302038, #311497, #311853, #324062, #339448, #344057, #348979,
    - LP: #350829, #356206, #367379, #367544, #369822, #371897, #374846,
    - LP: #375570, #381801, #399515, #402950, #403786, #408169, #409322,
    - LP: #409723, #410326, #410446, #417695, #417976, #419271, #421072,
    - LP: #422774, #423979, #424655, #425028, #427016, #431072, #432660,
    - LP: #437640, #437996, #442191, #443306, #443389, #446719, #449762,
    - LP: #455417, #461532, #464652, #483191, #497537, #503780
  * debian/patches/:
    + add: 0099-change-configure-git-version-tag.patch: Match released
           upstream 0.9.21 for shlibs and LIBPULSE_VERSION_INFO
    - drop: 0004-set-tsched0.patch (no longer relevant)
            0050-revert-pacmd-poll-argv.patch (no longer relevant)
            0056-dont-bail-on-sound-class-modem.patch (merged)
            0056-ignore-sound-class-modem.patch (merged)
            0058-Backport-4c793.patch (merged)
            0059-Backport-978d3.patch (merged)
            0060-fix-implicit-func-decl-cpu-arm.patch (merged)
            0061-Backport-c5fdb.patch (merged)
            0070-dont-bail-on-sound-class-modem-devs.patch (merged)
    + refresh: 0001-change-resample-and-buffering.patch
               0090-disable-flat-volumes.patch
               0091-dont-load-cork-music-on-phone.patch
               0057-load-module-x11-bell.patch
 -- Daniel T Chen <email address hidden> Thu, 14 Jan 2010 20:33:05 -0500

Changed in pulseaudio (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers