pulseaudio doesn't remember last volume, sets to 0 every boot

Bug #410446 reported by xtknight on 2009-08-07
78
This bug affects 13 people
Affects Status Importance Assigned to Milestone
pulseaudio (Debian)
Fix Released
Unknown
pulseaudio (Ubuntu)
Low
Luke Yelavich
Nominated for Karmic by Sanne Wouda

Bug Description

This bug happens every time. Any time I reboot, pulseaudio's volume is set to 0. I have to increase volume every time I play the first song on my PC.

--
At least Master, Front, Surround, Center and LFE volume levels are changing after every tune when play has started. Using ESound instead of Alsa will change all volume levels to 100% on next play. No problems occured while using OSS.

jarteq (j.p.s.) on 2009-08-09
description: updated
tags: added: sound volume
description: updated

Could you please try the following, note that this is only if you run pulseaudio in your user session, not system wide:

1. Remove all pulseaudio related files from your home directory, so .pulse_cookie and .pulse/* leave the .pulse directory in tact for the next step.
2. Create /home/your-username/.pulse/client.conf and add the following line to it:
autospawn = no

This is so that when we kill pulseaudio, it won't start right back up again when we don't want it to.
3. Kill pulseaudio with "pulseaudio -k"
4. Reset your alsa volume settings with the following command: "sudo /etc/init.d/alsa-utils reset". You will be asked for your password due to using the sudo command.
 5. Start pulseaudio again with "start-pulseaudio-x11".
6. Check the alsa mixer again, and report back as to whether your volume levels are reset to 0.

If you have any questions as to the above steps, please let me know also.

 affects ubuntu/pulseaudio
 status incomplete

Changed in pulseaudio (Ubuntu):
status: New → Incomplete
xtknight (xt-knight) wrote :

Luke: the volumes are now fine. Thanks. I will have to see if this helps in the long run, though.

xtknight (xt-knight) wrote :

On the next reboot, it was still messed up. I didn't try executing the commands again yet.

jarteq (j.p.s.) wrote :

Problems came back also for me. It's quite odd, I play songs with Xmms and after each song sound volumes are changing. First time I noticed the problem was when I played video on Xine and sound was gone everytime.

xtknight (xt-knight) wrote :

jarteq: I also have the same problems using audacious2.

The volume is either out of sync or reduces on each new song.

xtknight (xt-knight) wrote :

It's funny because alsa and oss worked well all the time. The new audio system is getting a little carried away with complexity?

LCID Fire (lcid-fire) wrote :

Same here for me.

Changed in pulseaudio (Ubuntu):
status: Incomplete → Confirmed
xtknight (xt-knight) wrote :

Yeah, still have the issue. :(

xtknight (xt-knight) wrote :

Yeah, still have the issue after each reboot, even on my Mythbuntu 9.10 alpha machine, which is very frustrating. :( Luke, how do we fix this issue permanently?

jarteq (j.p.s.) wrote :

I stopped using pulseaudio and got rid of the issue. I set other sound managers to be primary.

Changed in pulseaudio (Ubuntu):
importance: Undecided → Low
tags: added: regression-potential
removed: sound volume
summary: - [regression] karmic: pulseaudio doesn't remember last volume, sets to 0
- every boot
+ pulseaudio doesn't remember last volume, sets to 0 every boot
Juanma (jm-mico) wrote :

Similar is happening here on a Dell Latitude D-820 running Kubuntu Karmic Koala up-to-date (as today). Really annoying, after every reboot the PCM value is down to zero, and I have to manually bring it up so that I can listen something. Interestingly, I do not have the issue that the volume changes between playing songs.

 * PulseAudio configured for per-user sessions
Linux dell 2.6.31-11-generic #36-Ubuntu SMP Fri Sep 25 06:37:23 UTC 2009 x86_64 GNU/Linux

Pedro Villavicencio (pedro) wrote :

Luke, could you have a look to the report ? Thanks.

Changed in pulseaudio (Ubuntu):
assignee: nobody → Luke Yelavich (themuso)

I have this problem too (in Karmic RC), however it doesn't happen to me on every boot... Do you use Automatic login? because I deactivated automatic login (in GDM) and i don't have this problem anymore... I have one little question...

- Does alsa-utils starts before or after X Window System start?

If it starts after... is there any way to start alsa-utils before starting X Window System? I think this could be a solution for this bug.

I thought this because i noticed that if the mixer that comes with ubuntu by default start before alsa-utils, the master volume will reset to 0. I'm a non english native speaker, i hope that you will understand what i mean in this post.

mixer or pulseaudio, i don't know exactly what it is. ;)

I mean, wich one, not what ;)

I've posted this issue in #447395 too, because it randomly happens.

Ludovico Cavedon (cavedon) wrote :

Daniel T Chen wrote:
> We already do this in Lucid.

Good to know! Are you not zeroing in alsa, or you making sure pulseaudio
is killed before stopping alsa-utils?

Thanks,
Ludovico

Changed in pulseaudio (Debian):
status: Unknown → New
tags: added: regression-release
removed: regression-potential
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 1:0.9.22~0.9.21+341-g62bf-0ubuntu1

---------------
pulseaudio (1:0.9.22~0.9.21+341-g62bf-0ubuntu1) lucid; urgency=low

  * New snapshot based on stable-queue git branch (testing requested
    specifically by upstream)
    - LP: #164745, #173212, #201391, #204536, #207796, #210016, #221038,
    - LP: #226342, #230408, #236423, #237443, #250059, #269585, #274304,
    - LP: #274577, #275474, #277532, #277566, #277932, #278025, #280534,
    - LP: #283049, #286816, #287036, #292732, #298011, #298301, #300290,
    - LP: #302038, #311497, #311853, #324062, #339448, #344057, #348979,
    - LP: #350829, #356206, #367379, #367544, #369822, #371897, #374846,
    - LP: #375570, #381801, #399515, #402950, #403786, #408169, #409322,
    - LP: #409723, #410326, #410446, #417695, #417976, #419271, #421072,
    - LP: #422774, #423979, #424655, #425028, #427016, #431072, #432660,
    - LP: #437640, #437996, #442191, #443306, #443389, #446719, #449762,
    - LP: #455417, #461532, #464652, #483191, #497537, #503780
  * debian/patches/:
    + add: 0099-change-configure-git-version-tag.patch: Match released
           upstream 0.9.21 for shlibs and LIBPULSE_VERSION_INFO
    - drop: 0004-set-tsched0.patch (no longer relevant)
            0050-revert-pacmd-poll-argv.patch (no longer relevant)
            0056-dont-bail-on-sound-class-modem.patch (merged)
            0056-ignore-sound-class-modem.patch (merged)
            0058-Backport-4c793.patch (merged)
            0059-Backport-978d3.patch (merged)
            0060-fix-implicit-func-decl-cpu-arm.patch (merged)
            0061-Backport-c5fdb.patch (merged)
            0070-dont-bail-on-sound-class-modem-devs.patch (merged)
    + refresh: 0001-change-resample-and-buffering.patch
               0090-disable-flat-volumes.patch
               0091-dont-load-cork-music-on-phone.patch
               0057-load-module-x11-bell.patch
 -- Daniel T Chen <email address hidden> Thu, 14 Jan 2010 20:33:05 -0500

Changed in pulseaudio (Ubuntu):
status: Confirmed → Fix Released
Jeremy Nickurak (nickurak) wrote :

Is there a PPA those of us in Karmic can be testing for all the fixes in 9.22?

Juanma (jm-mico) wrote :

I do not have the bug any more (I updated to Jaunty and lately to lucid). Good luck with old distros.

Juanma.

Richard (r-maugendre) wrote :

No problem with Lucid.

Richard

Changed in pulseaudio (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.