OpenAL Broken in Jaunty

Bug #311853 reported by nullack on 2008-12-28
44
This bug affects 8 people
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)
Undecided
Unassigned
Declined for Lucid by Daniel T Chen

Bug Description

Binary package hint: libao-pulse

As part of my testing of Jaunty, I have discovered that OpenAL applications have broken sound. Sound playback is distorted and scratchy. Other users with default Jaunty configurations are replicating the problem. So far, I have tried Warzone 2100 and Glest as applications using OpenAL. Another tester reported that he does not replicate the problem on the current GIT revision of pulse audio.

Doing a pkill pulseaudio; sleep 2; pulseaudio -vv it is seen that underruns occur and sound is rewound while OpenAL apps are trying to be run:

D: sink.c: Processing rewind...
D: sink-input.c: Have to rewind 64568 bytes on render memblockq.
D: protocol-native.c: Requesting rewind due to end of underrun.
D: module-alsa-sink.c: Requested to rewind 65536 bytes.
D: module-alsa-sink.c: Limited to 168 bytes.
D: module-alsa-sink.c: before: 42
D: module-alsa-sink.c: after: 42
D: module-alsa-sink.c: Rewound 168 bytes.
D: sink.c: Processing rewind...
D: sink-input.c: Have to rewind 168 bytes on render memblockq.
I: module-alsa-sink.c: Underrun!
D: protocol-native.c: Requesting rewind due to end of underrun.
D: module-alsa-sink.c: Requested to rewind 5504 bytes.
D: module-alsa-sink.c: Limited to 308 bytes.
D: module-alsa-sink.c: before: 77
D: module-alsa-sink.c: after: 77
D: module-alsa-sink.c: Rewound 308 bytes.
D: sink.c: Processing rewind...
D: sink-input.c: Have to rewind 308 bytes on render memblockq.
I: module-alsa-sink.c: Underrun!
D: module-suspend-on-idle.c: Sink alsa_output.pci_1102_4_sound_card_0_alsa_playback_ 0 becomes idle.
D: module-alsa-sink.c: hwbuf_unused_frames=0
D: module-alsa-sink.c: setting avail_min=65185
D: module-alsa-sink.c: Requested to rewind 65536 bytes.
D: module-alsa-sink.c: Limited to 204 bytes.
D: module-alsa-sink.c: before: 51
D: module-alsa-sink.c: after: 51
D: module-alsa-sink.c: Rewound 204 bytes.
D: sink.c: Processing rewind...

marmuta (marmuta) wrote :

Yep, confirming for Jaunty Alpha2 and pulseaudio 0.9.13-2ubuntu3.
I get garbled sound and buffer underruns with

mplayer -ao openal /usr/lib/openoffice/share/gallery/sounds/space2.wav

It works fine though after killing pulseaudio (pulseaudio -k).

Changed in libao-pulse:
status: New → Confirmed
Daniel T Chen (crimsun) wrote :

fixed in git head and in jaunty.

Changed in pulseaudio:
status: Confirmed → Fix Released
marmuta (marmuta) wrote :

Is the fix still on it's way? There is no change with pulseaudio 0.9.14-0ubuntu1 and libao2 10.8.8-4.

marmuta (marmuta) wrote :

s/it's/its/

Antti Kaijanmäki (kaijanmaki) wrote :

I'm experiencing this bug even today. This is not fixed yet. What's the holdup?

Ryan Thompson (rct86) wrote :

It's still broken.

Ryan Thompson (rct86) wrote :

Sorry, false alarm. I had a ppa enabled that had a bad version of pulseaudio.

MyR (myr-jedi) wrote :

I also experience this bug with the latest pulseaudio

Andre (ajx) wrote :

I still get choppy sound with all updates installed. This affects games like Chromium. Can be reproduced by playing any audio file via

mplayer -ao openal audiofile

trendzetter (trendzetter) wrote :

Please reopen. This bug is not fixed

Laurent Séguin (cybersdf) wrote :

I confirm this bug on karmic

Changed in pulseaudio (Ubuntu):
status: Fix Released → New
status: New → Fix Released
Cliff1000000 (cliff1000000) wrote :

I'm having the same issue in Karmic as well.
Sound pops and cuts out while playing Warzone 2100, Glest, and my purchased copy of X3 Reunion.
Sound seems to work okay in other applications.
Sound Card Realtek ALC889A connected to my home receiver via Optical S/PDIF.

Tried turning off Power saving by editing /etc/modprobe.d/alsa-base.conf
options snd-hda-intel power_save=0 power_save_controller=N
Problem still continues.

Cliff1000000 (cliff1000000) wrote :

I fixed it by updating my Kernel to 2.6.32-020632-generic
Apparently there is something wrong with the Intel Realtek ALC889A sound Driver which is updated in the new kernel.
Follow these steps in order to update your Kernel.
Download the deb files here.
http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.32/

you will need 3 packages from the kernel version that you choose (the final 2.6.32 kernel has the release date of 03-Dec-2009)....download:

1)linux-headers-2.6.32-020632_2.6.32-020632_all.deb
2)linux-headers-2.6.32-020632-generic_2.6.32-020632**either i386 or amd64**.deb ...depending on which architecture you are using
3)linux-image-2.6.32-020632-generic_2.6.32-020632**either i386 or amd64**.deb ...depending on which architecture you are using
Make sure you do this in the order listed and back up all your data. Only do this if you are so pissed about your sound not working your willing to risk crashing and re-installing your os!!!
Thanks to some one else for figuring this out I have since lost the link.
My sound is now working flawlessly but now my MCE remote doesn't work?? The LIRC remotes list has changed for some reason. Oh well my sound is definitely more important than the remote.

Jörn Dreyer (j.dreyer) wrote :
Download full text (3.6 KiB)

hm still having distorted sound with warzone 2100:
...
I: sink-input.c: Created input 3 "ALSA Playback" on alsa_output.pci-0000_00_14.2.analog-stereo with sample spec s16le 2ch 44100Hz and channel map front-left,front-right
I: sink-input.c: media.name = "ALSA Playback"
I: sink-input.c: application.name = "ALSA plug-in [warzone2100]"
I: sink-input.c: native-protocol.peer = "UNIX socket client"
I: sink-input.c: native-protocol.version = "16"
I: sink-input.c: application.process.id = "5496"
I: sink-input.c: application.process.user = "jfd"
I: sink-input.c: application.process.host = "cutter"
I: sink-input.c: application.process.binary = "warzone2100"
I: sink-input.c: application.language = "de_DE.UTF-8"
I: sink-input.c: window.x11.display = ":0.0"
I: sink-input.c: application.process.machine_id = "e042fa99bcfcf79205c5f7f44b2a687a"
I: sink-input.c: application.process.session_id = "e042fa99bcfcf79205c5f7f44b2a687a-1263033931.272866-1882946726"
I: sink-input.c: application.icon_name = "warzone2100"
I: sink-input.c: media.role = "game"
I: sink-input.c: module-stream-restore.id = "sink-input-by-media-role:game"
I: protocol-native.c: Requested tlength=92,88 ms, minreq=0,72 ms
D: protocol-native.c: Early requests mode enabled, configuring sink latency to minreq.
D: memblockq.c: memblockq requested: maxlength=4194304, tlength=16384, base=4, prebuf=13568, minreq=2820 maxrewind=0
D: memblockq.c: memblockq sanitized: maxlength=4194304, tlength=16384, base=4, prebuf=13568, minreq=2820 maxrewind=0
I: protocol-native.c: Final latency 108,88 ms = 60,91 ms + 2*15,99 ms + 16,00 ms
D: alsa-sink.c: Latency set to 16,00ms
D: alsa-sink.c: hwbuf_unused=349948
D: alsa-sink.c: setting avail_min=88017
D: alsa-sink.c: Requesting rewind due to latency change.
D: alsa-sink.c: Requested to rewind 352768 bytes.
D: alsa-sink.c: Limited to 349000 bytes.
D: alsa-sink.c: before: 87250
D: alsa-sink.c: after: 87250
D: alsa-sink.c: Rewound 349000 bytes.
D: sink.c: Processing rewind...
D: sink-input.c: Have to rewind 349000 bytes on render memblockq.
D: source.c: Processing rewind...
D: protocol-native.c: Requesting rewind due to end of underrun.
D: alsa-sink.c: Requested to rewind 352768 bytes.
D: alsa-sink.c: Mhmm, actually there is nothing to rewind.
I: alsa-sink.c: Underrun!
I: alsa-sink.c: Increasing wakeup watermark to 7,98 ms
D: protocol-native.c: Underrun on 'ALSA Playback', 0 bytes in queue.
D: protocol-native.c: Requesting rewind due to end of underrun.
D: alsa-sink.c: Requested to rewind 10252 bytes.
D: alsa-sink.c: Limited to 748 bytes.
D: alsa-sink.c: before: 187
D: alsa-sink.c: after: 187
D: alsa-sink.c: Rewound 748 bytes.
D: sink.c: Processing rewind...
D: sink-input.c: Have to rewind 748 bytes on render memblockq.
D: source.c: Processing rewind...
D: alsa-sink.c: hwbuf_unused=0
D: alsa-sink.c: setting avail_min=87841
D: module-suspend-on-idle.c: Sink alsa_output.pci-0000_00_14.2.analog-stereo becomes idle, timeout in 5 seconds.
D: alsa-sink.c: Requested to rewind 352768 bytes.
D: alsa-sink.c: Limited to 1152 bytes.
D: alsa-sink.c: before: 288
D: alsa-sink.c: after: 288
D: alsa-sink.c: Rewound 1152 bytes.
D:...

Read more...

Changed in pulseaudio (Ubuntu):
status: Fix Released → New
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 1:0.9.22~0.9.21+341-g62bf-0ubuntu1

---------------
pulseaudio (1:0.9.22~0.9.21+341-g62bf-0ubuntu1) lucid; urgency=low

  * New snapshot based on stable-queue git branch (testing requested
    specifically by upstream)
    - LP: #164745, #173212, #201391, #204536, #207796, #210016, #221038,
    - LP: #226342, #230408, #236423, #237443, #250059, #269585, #274304,
    - LP: #274577, #275474, #277532, #277566, #277932, #278025, #280534,
    - LP: #283049, #286816, #287036, #292732, #298011, #298301, #300290,
    - LP: #302038, #311497, #311853, #324062, #339448, #344057, #348979,
    - LP: #350829, #356206, #367379, #367544, #369822, #371897, #374846,
    - LP: #375570, #381801, #399515, #402950, #403786, #408169, #409322,
    - LP: #409723, #410326, #410446, #417695, #417976, #419271, #421072,
    - LP: #422774, #423979, #424655, #425028, #427016, #431072, #432660,
    - LP: #437640, #437996, #442191, #443306, #443389, #446719, #449762,
    - LP: #455417, #461532, #464652, #483191, #497537, #503780
  * debian/patches/:
    + add: 0099-change-configure-git-version-tag.patch: Match released
           upstream 0.9.21 for shlibs and LIBPULSE_VERSION_INFO
    - drop: 0004-set-tsched0.patch (no longer relevant)
            0050-revert-pacmd-poll-argv.patch (no longer relevant)
            0056-dont-bail-on-sound-class-modem.patch (merged)
            0056-ignore-sound-class-modem.patch (merged)
            0058-Backport-4c793.patch (merged)
            0059-Backport-978d3.patch (merged)
            0060-fix-implicit-func-decl-cpu-arm.patch (merged)
            0061-Backport-c5fdb.patch (merged)
            0070-dont-bail-on-sound-class-modem-devs.patch (merged)
    + refresh: 0001-change-resample-and-buffering.patch
               0090-disable-flat-volumes.patch
               0091-dont-load-cork-music-on-phone.patch
               0057-load-module-x11-bell.patch
 -- Daniel T Chen <email address hidden> Thu, 14 Jan 2010 20:33:05 -0500

Changed in pulseaudio (Ubuntu):
status: New → Fix Released

This bug still affects Karmic as of 20th Feb 2010. Can we have this fix in Karmic please? The latest versions in my Karmic are:

ii pulseaudio 1:0.9.19-0ubuntu4.1 PulseAudio sound server
ii libopenal1 1:1.8.466-2 Software implementation of the OpenAL API (s

Daniel T Chen (crimsun) wrote :

It's much too invasive to backport both pulseaudio and openal-soft from lucid into karmic-proposed. See karmic-backports for a possible path; you'll need to be willing to do the work yourself.

Putting openal-soft-1.11.753 in /usr/local/lib (and running ldconfig) fixes this issue by making openal-soft work directly with pulse, rather than using the (presumably broken) alsa-pulse hooks.

Someone please remind me why, after oss, alsa, nas, esd, aRts, jack, gstreamer, SDL, ClanLib, libao and allegro, why did we really need pulse? It feels like the '90s all over again. Who else remembers "You can have a sound card, but you probably can't have duplex."

gruntlips_ (castaldo) wrote :

I am still having an audio skipping/stuttering problem in 10.04 after a fresh install. I disabled pulse and the problems goes away. So, I am not sure what fix is part of current pulseaudio package but it doesn't work on my machine.

http://ubuntuforums.org/showthread.php?t=1471262

My specs:
10.04
Serval System76 laptop (serp4)
Core2 Duo 2.5o GHz
nVidia GeForce 8600M GT
HDA Intel Realtek ALC268
4GB ram

gruntlips, please file a separate bug against alsa-driver.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers