pulseaudio crash using module-combine and usb sound

Bug #300290 reported by Tim Cole on 2008-11-20
32
This bug affects 4 people
Affects Status Importance Assigned to Milestone
PulseAudio
Fix Released
Unknown
pulseaudio (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: pulseaudio

Using the module-combine feature of PulseAudio in combination with a USB sound card leads to a crash.

I have an on board Intel HDA and a USB Soundblaster Audigy 2 NX.

If the USB sound card is not plugged in when PulseAudio starts, after plugging in the USB audio device, the next program that tries to access PulseAudio causes it to crash.

Error output from pulse audio:

E: module-combine.c: Assertion '!op->outq_rtpoll_item' failed at modules/module-combine.c:584, function sink_process_msg(). Aborting.

reproducible every time.

See attached debug log.

Ubuntu Intrepid 8.10
pulseaudio 0.9.10-2ubuntu9

$ cat /proc/asound/cards
 0 [Intel ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xfebfc000 irq 21
 1 [NX ]: USB-Audio - SB Audigy 2 NX
                      Creative Technology Ltd SB Audigy 2 NX at usb-0000:00:1d.7-3, high speed

Tim Cole (timothy-j-cole) wrote :
Changed in pulseaudio:
status: New → Confirmed
Changed in pulseaudio:
status: Unknown → New
Joshua Wise (joshua-joshuawise) wrote :

I have a similar setup; I've also seen Pulse crash under similar conditions with malloc()-trashing-related explosions, although I can't seem to reproduce it reliably enough to paste one.

Daniel T Chen (crimsun) wrote :

This should be fixed in jaunty; please reproduce.

Changed in pulseaudio:
importance: Undecided → Medium
Daniel T Chen (crimsun) on 2009-01-07
Changed in pulseaudio:
status: Confirmed → Incomplete
OliFre (freyermuth) wrote :

I experienced this problem, too, using the same setup.

Installing Pulseaudio 0.9.13 fixed it for me (there is a Jaunty-Backport for Intrepid here: https://launchpad.net/~racb/+archive ).
Before installing it, please understand that installing from an external package-source is on your own risk.

Murz (murznn) wrote :

Confirm on Kubuntu Intrepid AMD64 with playing audio on A2DP Bluetooth device:

I: sink-input.c: Created input 4 "Simultaneous output on ALSA PCM on bluetooth (bluetooth) via DMA" on alsa_output.bluetooth with sample spec s16le 6ch48000Hz and channel map front-left,side-left,front-center,front-right,side-right,lfe
I: module-alsa-sink.c: Starting playback.
E: module-combine.c: Assertion '!op->outq_rtpoll_item' failed at modules/module-combine.c:584, function sink_process_msg(). Aborting.

Upgrading to 0.9.13 (from https://launchpad.net/~racb/+archive ) didn't help me, the error is:

I: sink-input.c: Created input 3 "Simultaneous output on bluetooth" on alsa_output.bluetooth with sample spec s16le 2ch 44100Hz and channel map front-left,front-right
I: module-alsa-sink.c: Starting playback.
D: module-alsa-sink.c: Wakeup from ALSA! OUTPUT
D: module-alsa-sink.c: Wakeup from ALSA! OUTPUT
D: module-alsa-sink.c: Wakeup from ALSA! OUTPUT
D: module-alsa-sink.c: latency set to 139.32ms
D: module-alsa-sink.c: hwbuf_unused_frames=1
D: module-alsa-sink.c: setting avail_min=10462
D: module-alsa-sink.c: Requesting rewind due to latency change.
D: module-alsa-sink.c: Wakeup from ALSA! OUTPUT
D: module-alsa-sink.c: Requested to rewind 24576 bytes.
D: module-alsa-sink.c: Limited to 10464 bytes.
D: module-alsa-sink.c: before: 2616
D: module-alsa-sink.c: after: 2616
D: module-alsa-sink.c: Rewound 10464 bytes.
D: sink.c: Processing rewind...
D: sink-input.c: Have to rewind 10464 bytes on render memblockq.
E: module-combine.c: Assertion '!op->outq_rtpoll_item_read && !op->inq_rtpoll_item_write' failed at modules/module-combine.c:691, function sink_process_msg(). Aborting.
Aborted

Andres Mujica (andres.mujica) wrote :

i'm having this issue with Jaunty 64Bits and even Karmic (but i must retest with Karmic to be sure)

BrowneR (chris-scotland) wrote :

Pulseaudio also crashes for me when I plug in my USB soundcard.

Interestingly if audio is playing at the time you plug it in then there is no problem and the audio output on my usb soundcard quickly starts. Otherwise pulseaudio crashes but I haven't managed to get a debug output yet.

Changed in pulseaudio:
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 1:0.9.22~0.9.21+341-g62bf-0ubuntu1

---------------
pulseaudio (1:0.9.22~0.9.21+341-g62bf-0ubuntu1) lucid; urgency=low

  * New snapshot based on stable-queue git branch (testing requested
    specifically by upstream)
    - LP: #164745, #173212, #201391, #204536, #207796, #210016, #221038,
    - LP: #226342, #230408, #236423, #237443, #250059, #269585, #274304,
    - LP: #274577, #275474, #277532, #277566, #277932, #278025, #280534,
    - LP: #283049, #286816, #287036, #292732, #298011, #298301, #300290,
    - LP: #302038, #311497, #311853, #324062, #339448, #344057, #348979,
    - LP: #350829, #356206, #367379, #367544, #369822, #371897, #374846,
    - LP: #375570, #381801, #399515, #402950, #403786, #408169, #409322,
    - LP: #409723, #410326, #410446, #417695, #417976, #419271, #421072,
    - LP: #422774, #423979, #424655, #425028, #427016, #431072, #432660,
    - LP: #437640, #437996, #442191, #443306, #443389, #446719, #449762,
    - LP: #455417, #461532, #464652, #483191, #497537, #503780
  * debian/patches/:
    + add: 0099-change-configure-git-version-tag.patch: Match released
           upstream 0.9.21 for shlibs and LIBPULSE_VERSION_INFO
    - drop: 0004-set-tsched0.patch (no longer relevant)
            0050-revert-pacmd-poll-argv.patch (no longer relevant)
            0056-dont-bail-on-sound-class-modem.patch (merged)
            0056-ignore-sound-class-modem.patch (merged)
            0058-Backport-4c793.patch (merged)
            0059-Backport-978d3.patch (merged)
            0060-fix-implicit-func-decl-cpu-arm.patch (merged)
            0061-Backport-c5fdb.patch (merged)
            0070-dont-bail-on-sound-class-modem-devs.patch (merged)
    + refresh: 0001-change-resample-and-buffering.patch
               0090-disable-flat-volumes.patch
               0091-dont-load-cork-music-on-phone.patch
               0057-load-module-x11-bell.patch
 -- Daniel T Chen <email address hidden> Thu, 14 Jan 2010 20:33:05 -0500

Changed in pulseaudio (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.