canberra-gtk-play crashed with SIGSEGV in free()

Bug #277566 reported by jo on 2008-10-03
198
This bug affects 13 people
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)
Medium
Unassigned

Bug Description

The crash occurred when playing the login sound, but the only thing showing that something bad happened was the appearing of apport. The rest is hopefully visible in the stack trace.

ProblemType: Crash
Architecture: amd64
DistroRelease: Ubuntu 8.10
ExecutablePath: /usr/bin/canberra-gtk-play
Package: libcanberra-gnome 0.6-0ubuntu2
ProcAttrCurrent: unconfined
ProcCmdline: /usr/bin/canberra-gtk-play --id=desktop-login --description=GNOME\ Login
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: libcanberra
Stacktrace:
 #0 0x00007fd2db9a7988 in ?? () from /lib/libc.so.6
 #1 0x00007fd2db9a7f86 in free () from /lib/libc.so.6
 #2 0x00007fd2d8b0bddf in ?? () from /usr/lib/libpulse.so.0
 #3 0x0000000000000000 in ?? ()
StacktraceTop:
 ?? () from /lib/libc.so.6
 free () from /lib/libc.so.6
 ?? () from /usr/lib/libpulse.so.0
 ?? ()
Title: canberra-gtk-play crashed with SIGSEGV in free()
Uname: Linux 2.6.27-4-generic x86_64
UserGroups: adm admin cdrom dialout fuse lpadmin plugdev sambashare

jo (josef-kirmair) wrote :

StacktraceTop:_int_free () from /lib/libc.so.6
free () from /lib/libc.so.6
__do_global_dtors_aux () from /usr/lib/libpulse.so.0
g_option_context_set_help_enabled@plt ()
?? ()

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please try to obtain a valgrind log following the instructions at https://wiki.ubuntu.com/Valgrind and attach the file to the bug report. This will greatly help us in tracking down your problem.

Changed in libcanberra:
importance: Undecided → Medium
status: New → Incomplete
goto (gotolaunchpad) wrote :

Hello,
I dunno how to reproduce with Valgrind. The problem is that it starts automatically on startup without Valgrind. But I was hard-working and created a new backtrace with all debug packages enabled and so on. Maybe you can see a bit more with that.
If not: Can you give me a hint, how to start automatically with Valgrind or reproduce it without having to restart?

By that way: I have also this problem with the login sound: Bug 290454. Dunno though if it has to do with it.

Thanks!

Changed in libcanberra:
status: Incomplete → Confirmed
Damiön la Bagh (kat-amsterdam) wrote :

I started from the LiveCD in a LiveSession with the kernel option xforcevesa
Before when I started the sound worked but the video didn't.

affects: libcanberra (Ubuntu) → pulseaudio (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 1:0.9.22~0.9.21+341-g62bf-0ubuntu1

---------------
pulseaudio (1:0.9.22~0.9.21+341-g62bf-0ubuntu1) lucid; urgency=low

  * New snapshot based on stable-queue git branch (testing requested
    specifically by upstream)
    - LP: #164745, #173212, #201391, #204536, #207796, #210016, #221038,
    - LP: #226342, #230408, #236423, #237443, #250059, #269585, #274304,
    - LP: #274577, #275474, #277532, #277566, #277932, #278025, #280534,
    - LP: #283049, #286816, #287036, #292732, #298011, #298301, #300290,
    - LP: #302038, #311497, #311853, #324062, #339448, #344057, #348979,
    - LP: #350829, #356206, #367379, #367544, #369822, #371897, #374846,
    - LP: #375570, #381801, #399515, #402950, #403786, #408169, #409322,
    - LP: #409723, #410326, #410446, #417695, #417976, #419271, #421072,
    - LP: #422774, #423979, #424655, #425028, #427016, #431072, #432660,
    - LP: #437640, #437996, #442191, #443306, #443389, #446719, #449762,
    - LP: #455417, #461532, #464652, #483191, #497537, #503780
  * debian/patches/:
    + add: 0099-change-configure-git-version-tag.patch: Match released
           upstream 0.9.21 for shlibs and LIBPULSE_VERSION_INFO
    - drop: 0004-set-tsched0.patch (no longer relevant)
            0050-revert-pacmd-poll-argv.patch (no longer relevant)
            0056-dont-bail-on-sound-class-modem.patch (merged)
            0056-ignore-sound-class-modem.patch (merged)
            0058-Backport-4c793.patch (merged)
            0059-Backport-978d3.patch (merged)
            0060-fix-implicit-func-decl-cpu-arm.patch (merged)
            0061-Backport-c5fdb.patch (merged)
            0070-dont-bail-on-sound-class-modem-devs.patch (merged)
    + refresh: 0001-change-resample-and-buffering.patch
               0090-disable-flat-volumes.patch
               0091-dont-load-cork-music-on-phone.patch
               0057-load-module-x11-bell.patch
 -- Daniel T Chen <email address hidden> Thu, 14 Jan 2010 20:33:05 -0500

Changed in pulseaudio (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers