Headset volume control doesn't change headset volume

Bug #201391 reported by Julian Edwards on 2008-03-12
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)
Low
Luke Yelavich

Bug Description

I use Kubuntu Hardy and have a Plantronics USB headset that has its own volume and mute controls.

When using its volume controls, they affect the master volume only and have no effect on the headset volume. I can only alter the headset volume by going into kmix and selecting the appropriate device and altering its PCM volume.

The master volume setting should affect the headset volume too.

Ian Weisser (ian-weisser) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately we can't fix it without more information.

Please include the information requested from the "Reporting Sound Bugs" section of https://wiki.ubuntu.com/DebuggingSoundProblems as separate attachments.

Julian Edwards (julian-edwards) wrote :
Changed in linux:
status: Incomplete → New
Daniel T Chen (crimsun) wrote :

Is this symptom reproducible in 9.04 using linux-image-2.6.28-1-ub-generic?

Changed in linux:
status: New → Incomplete
Julian Edwards (julian-edwards) wrote :

I don't have 9.04 and I'm unlikely to install it until 3-4 weeks before it's released :(
(As a Launchpad developer, I need a stable system!)

Is there anyone else who can test this?

Yes, I can confirm the issue on 9.04 Jaunty.
The volume controls of plantronics headset don't work.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Julian Edwards (julian-edwards) wrote :

Happens in Jaunty for me as well.

Julian Edwards (julian-edwards) wrote :

Assigning as advised by Rick

Changed in linux (Ubuntu):
assignee: nobody → Ubuntu Foundations Team (ubuntu-foundations)
corneliupa (corneliupa) wrote :

I can confirm this bug with Kubuntu 8.04 and even before.
All volume controls translate into key presses - please see:
"/etc/acpi/volupbtn.sh" and inside this script "acpi_fakekey $KEY_VOLUMEUP".

cat /proc/asound/cards
 0 [Intel ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xfe9fc000 irq 20
 1 [Device ]: USB-Audio - USB Audio Device
                      Elite Silicon USB Audio Device at usb-0000:00:1d.0-2, full speed

would always list the HDA-Intel as first sound card.

I never got a clue how to use alsa - it's so obscure and their documentation really sucks.
And I never really got the time on how to tweak the acpi_fakekey and the usb/hid interface. What if when I press the "KEY_CALC" I want to launch a specific application, not the default one. I would be really interested in an easy way to do this.

One solution would be to set as first soundcard the USB one - when plugged.
A workaround would be to extend the "/etc/acpi/volupbtn.sh" script - when it detects a second soundcard to use commands like "/usr/bin/amixer -c 1 set PCM 10+" , for instance.

Changed in linux (Ubuntu):
assignee: Canonical Foundations Team (canonical-foundations) → Canonical Desktop Team (canonical-desktop-team)
corneliupa (corneliupa) wrote :

The suggested workaround won't work: the "/etc/acpi/volupbtn.sh" is not called when pressing the volume hardware keys. It's the other way around: the script is simulating a hardware key press. And in addition the nice OSD bar with the volume percentage won't appear any longer. So, the best outcome would be controlling the USB volume with some shortcuts. I couldn't use the hardware keys as keys for a shortcut - I am using "xbindkeys" program.

Martin Pitt (pitti) wrote :

Please ignore /etc/acpi/ stuff, this is pretty obsolete, and faking keys is known broken. Apparently the headset's keys actually work, so it's a question of changing the real mixer level.

As far as I know, the kernel side of this is done once it correctly determines the keypresses and forwards them to userspace as input events. Luke, Daniel, do you know which part of the stack is/should be responsible for changing mixer levels like that? pulseaudio? GNOME mixer applet?

affects: linux (Ubuntu) → pulseaudio (Ubuntu)
Changed in pulseaudio (Ubuntu):
assignee: Canonical Desktop Team (canonical-desktop-team) → Luke Yelavich (themuso)
status: Confirmed → Incomplete
importance: Undecided → Low

I would hope it's not a GNOME mixer applet fix, since this also affects me on Kubuntu - read my bug description :)

Also, since pulseaudio is a total and unmitigated disaster area on KDE (I frequently ended up with no sound until I removed the packages from my system) I hope that the fix DTRT on both desktop environments regardless.

Thanks!

corneliupa (corneliupa) wrote :

Thanks for the replies, guys.
The only workaround I could find (in order to make the volume keys working) is this one:
http://forums.opensuse.org/archives/sls-archives/archives-suse-linux/archives-hardware-support/384118-keeping-alsa-sound-device-order.html

Anyway, I will look into an even more straightforward solution: I will just rmmod snd_hda_intel whenever I use the USB speakers and load it back once I don't use them any more. It seems to be working.

 Thanks again.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 1:0.9.22~0.9.21+341-g62bf-0ubuntu1

---------------
pulseaudio (1:0.9.22~0.9.21+341-g62bf-0ubuntu1) lucid; urgency=low

  * New snapshot based on stable-queue git branch (testing requested
    specifically by upstream)
    - LP: #164745, #173212, #201391, #204536, #207796, #210016, #221038,
    - LP: #226342, #230408, #236423, #237443, #250059, #269585, #274304,
    - LP: #274577, #275474, #277532, #277566, #277932, #278025, #280534,
    - LP: #283049, #286816, #287036, #292732, #298011, #298301, #300290,
    - LP: #302038, #311497, #311853, #324062, #339448, #344057, #348979,
    - LP: #350829, #356206, #367379, #367544, #369822, #371897, #374846,
    - LP: #375570, #381801, #399515, #402950, #403786, #408169, #409322,
    - LP: #409723, #410326, #410446, #417695, #417976, #419271, #421072,
    - LP: #422774, #423979, #424655, #425028, #427016, #431072, #432660,
    - LP: #437640, #437996, #442191, #443306, #443389, #446719, #449762,
    - LP: #455417, #461532, #464652, #483191, #497537, #503780
  * debian/patches/:
    + add: 0099-change-configure-git-version-tag.patch: Match released
           upstream 0.9.21 for shlibs and LIBPULSE_VERSION_INFO
    - drop: 0004-set-tsched0.patch (no longer relevant)
            0050-revert-pacmd-poll-argv.patch (no longer relevant)
            0056-dont-bail-on-sound-class-modem.patch (merged)
            0056-ignore-sound-class-modem.patch (merged)
            0058-Backport-4c793.patch (merged)
            0059-Backport-978d3.patch (merged)
            0060-fix-implicit-func-decl-cpu-arm.patch (merged)
            0061-Backport-c5fdb.patch (merged)
            0070-dont-bail-on-sound-class-modem-devs.patch (merged)
    + refresh: 0001-change-resample-and-buffering.patch
               0090-disable-flat-volumes.patch
               0091-dont-load-cork-music-on-phone.patch
               0057-load-module-x11-bell.patch
 -- Daniel T Chen <email address hidden> Thu, 14 Jan 2010 20:33:05 -0500

Changed in pulseaudio (Ubuntu):
status: Incomplete → Fix Released
goofiekidd (goofiekidd) wrote :

I have Ubuntu Studio 14, and I had to go into the sound settings and change the USB sound to "Set as Fallback" then all the volume buttons on the keyboard, the ones on my USB headset and the ones in the notification panel all changed the USB volume level.

Jonathan Neufeld (jonath2n) wrote :

This is still an issue in Kubuntu 16.04, if I adjust the volume via the volume controls on my Logitech ClearChat PC Wireless headset, it adjusts the volume for ALL devices instead of the just the one device.

CuTeBoi (anthony-hernandez) wrote :

This occurs with G933 Logitech.

I have my default audio as the line out. But I use the G933 headset for chrome output. Changing volume on the headset results in a default media key volume up and down. It's only controlling the configured default audio in the volume controls.

Anything I can provide?

CuTeBoi (anthony-hernandez) wrote :

Sorry, forgot to mention I'm on

```
workstation:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.04.2 LTS
Release: 18.04
Codename: bionic
```

Daniel van Vugt (vanvugt) wrote :

It's been over 9 years since this bug was closed.

So if you'd like to discuss any problems you're still having today then it would be better to open a new bug by running:

  ubuntu-bug pulseaudio

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers