stuttering of sound with pulseaudio on high loads

Bug #164745 reported by exactt on 2007-11-23

This bug report was converted into a question: question #19542: stuttering of sound with pulseaudio on high loads.

8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: pulseaudio

here on latest gutsy amd64

i recently switched to pulseaudio by installing pulseaudio-esd-compat . now when i play music using totem or songbird (both use gstreamer) i get little interruptions like stutterings when the computer is on high loads(high cpu and hd usage). i haven't had these problems with esd...

anyone else who can confirm this?

Daniel T Chen (crimsun) wrote :

Does this also occur under Hardy?

Changed in pulseaudio:
importance: Undecided → Low
status: New → Incomplete
exactt (giesbert) wrote :

will try that as soon as the alpha is out...

Daniel T Chen (crimsun) wrote :

Hardy Alpha 1 is available at http://cdimage.ubuntu.com/releases/8.04/alpha-1/ . Please remember to install the pulseaudio-esound-compat and gstreamer0.10-pulseaudio packages, too.

exactt (giesbert) wrote :

thx. i already downloaded it but no time to install/test yet.

what i found out is that the pulseaudio process runs with nice level 0. if i lower it(raise priority) things get better.

Daniel T Chen (crimsun) wrote :

You could try adding your user to the 'pulse-rt' group, then logging out and back in.

Daniel T Chen (crimsun) wrote :

The symptom described in this bug report is alleviated by adjusting the scheduling for the pulseaudio daemon. Suggested adding the user account to the 'pulse-rt' group then logging out and back in.

Changed in pulseaudio:
status: Incomplete → Invalid
exactt (giesbert) wrote :

i added my user to the pulse-rt group. after a restart nothing has changed.

Aroll605 (aroll605) wrote :

Karmic 9.10 RC

Same problem.

Why is this a big issue?
If using Pulse, sound is getting interrupted by static every time loading a new page in FireFox.

If removing pulse and use ALSA instead, gnome controls don't support that anymore (GNOME 2.28). WHO had the idea to force the use of pulseaudio on GNOME after 2.26 I have no idea but that was the worst thing to do. The further it goes, the worst it gets.

Changed in pulseaudio (Ubuntu):
status: Invalid → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 1:0.9.22~0.9.21+341-g62bf-0ubuntu1

---------------
pulseaudio (1:0.9.22~0.9.21+341-g62bf-0ubuntu1) lucid; urgency=low

  * New snapshot based on stable-queue git branch (testing requested
    specifically by upstream)
    - LP: #164745, #173212, #201391, #204536, #207796, #210016, #221038,
    - LP: #226342, #230408, #236423, #237443, #250059, #269585, #274304,
    - LP: #274577, #275474, #277532, #277566, #277932, #278025, #280534,
    - LP: #283049, #286816, #287036, #292732, #298011, #298301, #300290,
    - LP: #302038, #311497, #311853, #324062, #339448, #344057, #348979,
    - LP: #350829, #356206, #367379, #367544, #369822, #371897, #374846,
    - LP: #375570, #381801, #399515, #402950, #403786, #408169, #409322,
    - LP: #409723, #410326, #410446, #417695, #417976, #419271, #421072,
    - LP: #422774, #423979, #424655, #425028, #427016, #431072, #432660,
    - LP: #437640, #437996, #442191, #443306, #443389, #446719, #449762,
    - LP: #455417, #461532, #464652, #483191, #497537, #503780
  * debian/patches/:
    + add: 0099-change-configure-git-version-tag.patch: Match released
           upstream 0.9.21 for shlibs and LIBPULSE_VERSION_INFO
    - drop: 0004-set-tsched0.patch (no longer relevant)
            0050-revert-pacmd-poll-argv.patch (no longer relevant)
            0056-dont-bail-on-sound-class-modem.patch (merged)
            0056-ignore-sound-class-modem.patch (merged)
            0058-Backport-4c793.patch (merged)
            0059-Backport-978d3.patch (merged)
            0060-fix-implicit-func-decl-cpu-arm.patch (merged)
            0061-Backport-c5fdb.patch (merged)
            0070-dont-bail-on-sound-class-modem-devs.patch (merged)
    + refresh: 0001-change-resample-and-buffering.patch
               0090-disable-flat-volumes.patch
               0091-dont-load-cork-music-on-phone.patch
               0057-load-module-x11-bell.patch
 -- Daniel T Chen <email address hidden> Thu, 14 Jan 2010 20:33:05 -0500

Changed in pulseaudio (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions