users-admin crashes on start because of mixed GTK2 and 3 symbols

Bug #789333 reported by Mark Hull on 2011-05-27
322
This bug affects 34 people
Affects Status Importance Assigned to Milestone
policykit-1-gnome (Ubuntu)
High
Julien Lavergne
Oneiric
High
Julien Lavergne

Bug Description

Binary package hint: gnome-system-tools

users-admin when clicked used to just not show up in Gnome 3 but I noticed that recently there were some updates to it so I thought I'd try it again. I've been able to work around the problem but it would be nice to have the tool available.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: gnome-system-tools 2.32.0-0ubuntu7
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Fri May 27 15:39:25 2011
ExecutablePath: /usr/bin/users-admin
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
ProcCmdline: users-admin
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, no user)
 LANG=en_US.utf8
 SHELL=/bin/bash
Signal: 6
SourcePackage: gnome-system-tools
StacktraceTop:
 ?? () from /usr/lib/libgtk-x11-2.0.so.0
 g_option_context_parse () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 gtk_parse_args () from /usr/lib/libgtk-x11-2.0.so.0
 gtk_init_check () from /usr/lib/libgtk-x11-2.0.so.0
 gtk_init () from /usr/lib/libgtk-x11-2.0.so.0
Title: users-admin crashed with SIGABRT in g_option_context_parse()
UpgradeStatus: Upgraded to natty on 2011-05-27 (0 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

lp:~gilir/policykit-1-gnome/fix-789333
Martin Pitt: Approve on 2011-08-22
Mark Hull (mark-hull) wrote :

StacktraceTop:
 do_pre_parse_initialization (context=<value optimized out>, group=<value optimized out>, data=<value optimized out>, error=<value optimized out>) at /build/buildd/gtk+2.0-2.24.4/gtk/gtkmain.c:676
 pre_parse_hook (context=<value optimized out>, group=<value optimized out>, data=<value optimized out>, error=<value optimized out>) at /build/buildd/gtk+2.0-2.24.4/gtk/gtkmain.c:785
 g_option_context_parse (context=0x20d4110, argc=0x7fff2b3ab8bc, argv=0x7fff2b3ab8b0, error=0x7fff2b3ab868) at /build/buildd/glib2.0-2.28.6/./glib/goption.c:1737
 IA__gtk_parse_args (argc=0x7fff2b3ab8bc, argv=0x7fff2b3ab8b0) at /build/buildd/gtk+2.0-2.24.4/gtk/gtkmain.c:956
 IA__gtk_init_check (argc=<value optimized out>, argv=<value optimized out>) at /build/buildd/gtk+2.0-2.24.4/gtk/gtkmain.c:992

Changed in gnome-system-tools (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace

users-admin isn't part of the stock GNOME3 experience, but it should work if you still need it rather than the new users control panel.

The crash here comes from a bad packaging/build that mixes GTK2 and GTK3 symbols:
#2 0x00007f87f66eca22 in g_logv (log_domain=0x7f87f95c779b "Gtk", log_level=<value optimized out>, format=0x7f87f9659d88 "GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported", args1=0x7fff2b3ab690) at /build/buildd/glib2.0-2.28.6/./glib/gmessages.c:557

So that's not a crash per se, rather a broken package.

users-admin 2.32 is supposed to use GTK2 only, while users-admin 3.0 uses GTK3 only. When you speak of GNOME3, do you mean you installed it from the PPA?

visibility: private → public
Changed in gnome-system-tools (Ubuntu):
status: New → Triaged
summary: - users-admin crashed with SIGABRT in g_option_context_parse()
+ users-admin crashes on start because of mixed GTK2 and 3 symbols
svenw (svenw1973-launchpad) wrote :

I did install gnome 3 from PPA (http://ppa.launchpad.net/gnome3-team/gnome3/ubuntu).
gnome-system-tools is version 2.32.0-0ubuntu7. I did not find any newer package.

Milan Bouchet-Valat (nalimilan) wrote :

That's most likely a GNOME3 PPA bug then.

tags: added: gnome3
tags: added: bugpattern-needed

Apport retracing service has marked bug 819821, which is *not* a GNOME3 PPA bug (c.f. similar bug 814060 which is also not a GNOME3 PPA bug), as a duplicate of this bug (and removed all the useful attachments). Should I reverse that operation and manually attach a stack trace to bug 819821? Or should this bug be elevated to High (like bug 814060) and no longer considered a GNOME3 PPA bug?

Jean-Baptiste Lallement (jibel) wrote :

gnome-system-tools is deprecated in gnome3.
Derivatives which still use it need to either fix it to make it work with gtk3 or use equivalent gtk3 based tools.

tags: added: iso-testing
Julien Lavergne (gilir) wrote :

I find at least 1 package which use GTK3 and linked to this : libpolkit-gtk-1-0. policykit-1-gnome needs to provide a package of the library build against GTK2 if we want to fix it.

polkit-gtk shouldn't link to GTK3, but to GTK2: polkit-gtk isn't needed by GTK3 programs, since they have to use GtkLockButton to replace PolkitLockButton. Linking to GTK2 is still the upstream default actually.

Charlie Kravetz (charlie-tca) wrote :

If gnome-system-tools is deprecated in Gnome3, is the gnome2 package available? We did have this in 11.04. Is it possible to simply pin the package for 11.10?

fnu (fnu) wrote :

Ok, if gnome-system-tools is deprecated in Gnome3, what about Xfce, means Xubuntu?

It seems they still use and need this package. I realized this bug, while using Xubuntu@Xfce (pls. see Bug #824485) ...

Changed in gnome-system-tools (Ubuntu):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Changed in gnome-system-tools (Ubuntu Oneiric):
importance: Medium → High
Martin Pitt (pitti) wrote :

As gnome-system-tools is obsolete and replaced with accountsservice/gnome-control-center, I downgrade this to Medium. It is not a release critical bug.

Changed in gnome-system-tools (Ubuntu Oneiric):
importance: High → Medium
Jonathan Marsden (jmarsden) wrote :

@pitti: Are you sure that all flavours of Ubuntu (Ubuntu, Kubuntu, Xubuntu and Lubuntu) include the new accountsservice/gnome-control-center in Oneiric? Would their doing so noticeably increase disk or memory footprint by requiring other depedencies also be installed by default?

If in fact any of the official-but-non-default flavours of Ubuntu still need to use gnome-system-tools, then I submit that this *is* in fact a release critical bug for those flavours and should be accorded appropriately high priority and upgraded back to High.

Martin Pitt (pitti) wrote :

OK, fair enough. This got assigned to the desktop team, but please anyone feel free to grab this bug.

Changed in gnome-system-tools (Ubuntu Oneiric):
importance: Medium → High
Julien Lavergne (gilir) wrote :

I confirm that rebuilding policykit-1-gnome with GTK2 fix the problem. Also, the rdepends are only using GTK2 also, so it's should be safe to switch to GTK2 :
gnome-time-admin
gnome-system-tools
gnome-network-admin

I'll prepare a merge proposal.

affects: gnome-system-tools (Ubuntu Oneiric) → policykit-1-gnome (Ubuntu Oneiric)
Changed in policykit-1-gnome (Ubuntu Oneiric):
assignee: Canonical Desktop Team (canonical-desktop-team) → Julien Lavergne (gilir)
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package policykit-1-gnome - 0.101-2ubuntu5

---------------
policykit-1-gnome (0.101-2ubuntu5) oneiric; urgency=low

  * debian/control, debian/rules: Build against GTK2, all reverse-depends still
    use GTK2 (LP: #789333).
 -- Julien Lavergne <email address hidden> Mon, 22 Aug 2011 10:29:17 +0200

Changed in policykit-1-gnome (Ubuntu Oneiric):
status: In Progress → Fix Released
To post a comment you must log in.