Ubuntu

Unable to retrieve MSN Address Book

Reported by montana_skyline on 2009-01-12
338
This bug affects 51 people
Affects Status Importance Assigned to Milestone
Pidgin
Fix Released
Unknown
pidgin (Ubuntu)
High
Unassigned
Nominated for Intrepid by Iain Lane

Bug Description

Binary package hint: pidgin

I installed the latest updates today and now Pidgin won't load my MSN address book.

ProblemType: Bug
Architecture: i386
Date: Sun Jan 11 20:52:27 2009
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/pidgin
Package: pidgin 1:2.5.1-1~getdeb1
PackageArchitecture: i386
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: pidgin
Uname: Linux 2.6.24-22-generic i686
UnreportableReason: This is not a genuine Ubuntu package

Eugene Cormier (eugene-cormier) wrote :

I have the same problem with the official version (2.5.2) from intrepid as of today (Jan 11)

Sam M (sammymason) wrote :

I'm also having this problem as of today on Xubuntu 8.10 with 2.5.2

Pidgin was working properly several hours ago.

Richard.F (r-friedman01) wrote :

I have the exact same problem guys. Running Pidgin 2.5.3 on Windows Vista SP1. This has happened this yesterday (11/1/09) and hasn't resolved itself since. Perhaps Microsoft blocked Pidgin or something?

hvwees (hvwees) wrote :

I'm having this issue as well on Ubuntu 8.10 with 2.5.2.
It seems that mickeysoft changed something, which makes pidgin puke... :-(

Paco Cotera (paco-cotera) wrote :

Same here, Ubuntu 8.10, Pidgin 2.5.2,

Attach debug log.

: (01:00:58) msn: Retrieving contact list failed: Passport Authorization Failed

Broken on Adium as well, which makes it a libpurple problem.

nzfatmatt (nzfatmatt) wrote :

Same problem on Ubuntu 8.10, Pidgin 2.5.2

However on Win XP SP3 Pidgin 2.4.3 it works fine for msn. Regression bug?

Elie De Brauwer (elie) wrote :

Another one here on Ubuntu 8.10

Elie De Brauwer (elie) wrote :

Btw more information at http://developer.pidgin.im/ticket/8080 apparently the issue is related to some server side outage ?

dfszb (dnotob) wrote :

this is probably not a server side outage.
I can connect with amsn.
I can also do the following: install msn-pecan, and add the same account as 'wlm' account.
It also connects.
So this is a pidgin bug.

Waiwit (jwaiwit) wrote :

2.5.3 ride on hardy.
yesterday still fine. failed start this morning ..

Adium users are having the same problem.

2009/1/12 dfszb <email address hidden>

> this is probably not a server side outage.
> I can connect with amsn.
> I can also do the following: install msn-pecan, and add the same account as
> 'wlm' account.
> It also connects.
> So this is a pidgin bug.
>
> --
> Unable to retrieve MSN Address Book
> https://bugs.launchpad.net/bugs/316252
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Pidgin: Unknown
> Status in "pidgin" source package in Ubuntu: New
>
> Bug description:
> Binary package hint: pidgin
>
> I installed the latest updates today and now Pidgin won't load my MSN
> address book.
>
> ProblemType: Bug
> Architecture: i386
> Date: Sun Jan 11 20:52:27 2009
> DistroRelease: Ubuntu 8.04
> ExecutablePath: /usr/bin/pidgin
> Package: pidgin 1:2.5.1-1~getdeb1
> PackageArchitecture: i386
> ProcEnviron:
>
> PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SourcePackage: pidgin
> Uname: Linux 2.6.24-22-generic i686
> UnreportableReason: This is not a genuine Ubuntu package
>

adam_ant_tt (adam-ant-tt) wrote :

hi people.

my pidgin failed on ubuntu and at the same time, my adium refused to connect also on my mac.

however, 'microsoft' messenger on the mac and 'msn' messenger on xp both work fine.....

could it be microsoft updated something on their servers?

Henti Smith (henti) wrote :

empathy on intrepid ubuntu works fine ..

dfszb (dnotob) wrote :

can somebody confirm that pidgin connects with msn-pecan installed and protocol changed to 'wlm'?

Matt Austin (mattaustin) wrote :

A comment on the bug report on the pidgin website suggests that this is a server-side issue.

Apparently the server has stopped handling a certain MSN protocol version MSNP15 (as used by pidgin/purple)?

The clients that are continuing to function are using earlier protocol versions, or fall-back to previous protocol versions (as in the case of the official clients).

Ramon Casha (rcasha) wrote :

Confirmed; However KOPETE works fine.

BartG (bart-goyens) wrote :

Confirm bug in intrepid and pidgin 2.5.2 as of today.

Ramon Casha (rcasha) wrote :

Works with msn-pecan however.

sturm31 (sturm31) wrote :

Same here... everything is fine with emesene and aMSN, but not with pidgin.
Anyone know a fix?

nzadLithium (cmaster2) wrote :

I have this bug in both intrepids version of pidgin as well as 2.5.3. installing msn-pecan and adding as a wlm account works.

Invincicble Mutant (ngkengyap) wrote :

I would suggest an option for user to choose between protocols...That would help in future to cope with M$ behaviour.

Johan Westin (3ch0) wrote :

By installing the msn-pecan package and readding my msn accont in pidgin and choosing 'wdl' instead of 'msn' everything works fine.
I installed msn-pecan by writing:

sudo apt-get install msn-pecan

installing msn-pecan and adding as a wlm account works for some accounts . i have two live.com accounts , one is working with msn-pecan but the other one no. the one that is not working is very new, i mean i created it just 2 months ago. here is its error : Unable to authenticate: The e-mail address or password is incorrect. but changing it network to msn gives this with the same username and password : Unable to authenticate: The e-mail address or password is incorrect.

Damian Senn (damian-senn) wrote :

the protocol from msn-pecan is called 'wlm' not 'wdl' ...
anyway, thanks it works fine with msn-pecan! :)

lehaug (lehaug) wrote :

msn-pecan and wlm method confirmed working on Vista X64 SP1 altso. Thanks!

installing msn-pecan and adding as a wlm account works for some accounts . i have two live.com accounts , one is working with msn-pecan but the other one no. the one that is not working is very new, i mean i created it just 2 months ago. here is its error : Unable to authenticate: The e-mail address or password is incorrect. but changing it network to msn gives this with the same username and password : Unable to retrieve MSN Address Book

Nolochemical (nolochemical) wrote :

Pidgin requested certificate authentication from "rsi.hotmail.com" before the error. I cancelled the first time, accepted the second. Will try the msn-pecan fix..

Superna (superna) wrote :

emesene client works well

Nolochemical (nolochemical) wrote :

Msn-Pecan Works.

luka8088 (luka8088) wrote :

msn-pecan and WLM confirmed working on XP SP3 !

Chris (chrislazari) wrote :

Confirmed msn-pecan and setting protocol to WLM on Intrepid works.

Great work and thanks for the workaround.

mattycoze (mattycoze) wrote :

Retrieving contact list failed: Passport Authorization Failed

Same problem as of today Jan 12th 2009

What's going on!?

Confirmed msn-pecan and setting protocol to WLM on Intrepid 64bit works.

Many Thanks

I take it WLM stands for Windows Live Messenger..?

Is this a newer protocol than the standard Pidgin one?

Mark - Holland (spykie) wrote :

Confirmed msn-pecan and setting protocol to WLM on Intrepid 32bit works.

Thanks alot.

Le@ (crazy-lea86) wrote :

It's says "Unable to retrieve MSN Address Book" when I try to log in..... :-(

Le@ (crazy-lea86) wrote :

msn-pecan and setting protocol to WLM does not work for me... Can someone help me???

Daniel Castro (castromd) wrote :

may be a bug in Pidgin... but definitively caused by a change on the MSN side...

Luca Corbo (lucor) wrote :

msn-pecan and setting protocol to WLM on Intrepid 32bit works.
Thanks.

32 comments hidden view all 112 comments
Erik (lnchpd-elaan) wrote :

Just for the stats I chime in: Got hit by this too, using msn-pecan works as a work-around. Would like to be able to delete that additional package again in the future though, so please keep working on a solution within Pidgin.

Pedro Villavicencio (pedro) wrote :

confirming, pidgin isn't working with msn, what you can try as well is empathy which is working fine for me.

Changed in pidgin:
importance: Undecided → High
status: New → Confirmed
sc00ter (gosdenj) wrote :

Anyone got this working under Hardy 8.04? I tried the install below, but it still fails for my version of Pidgin, 2.5.3 (from GetDeb)

http://code.google.com/p/msn-pecan/wiki/HowToInstall

I've fallen back to Emesene for the time being until the dust settles.

kosmoz (kosmoz) wrote :

moojix workaround works for me too ((Ubuntu 8.10, pidgin 2.5.2).

GregR1 (bluepowder7) wrote :

in Hardy 8.04-64 Xubuntu, the fix is the same:

install msn-pecan
restart pidgin
change protocol of msn contact from msn to wlm
enable account

only issue i found is that i now have two contact lists - one with my aliased names, and one with default names. not sure if i can merge them or blow one list away safely...... kinda annoying having TWO lists with the same people show up...

Afiefh (afiefh) wrote :

For those who say they would like to uninstall msn-pecan, you might want to know that it has some neat additional features like handwritten messages and faster file transfer.

I for one will keep it.

taotao07 (b000ja) wrote :

WLM keeps crashing my pidgin... tried 2.5.3, 2.5.2 and 2.5.1 versions... any ideas?

"Unable to retrieve MSN Address Book"

As of today (12/01/2009) I am unable to use Pidgin to connecto to my msn account :-(

qabulin (abulin) wrote :

USER PLATFORM:
Vista Ultimate 64bit SP1

AFFECTED SOFTWARE:
Pidgin 2.5.3

PROCEDURE:
1) Downloaded and installed 'msn-pecan' from http://msn-pecan.googlecode.com/files/msn-pecan-0.0.17.exe
2) Re-started Pidgin
3) Disabled 'MSN' account.
4) Added 'WLM' account.

STATUS:
Currently communicating with MSN contacts quite well. Standing by for for further repairs/updates to Pidgin 2.5.3.

Savvas Radevic (medigeek) wrote :

Ubuntu 8.10 intrepid 64-bit

WLM Protocol (msn-pecan package) works as expected.
Using pidgin 2.5.3a by getdeb: http://www.getdeb.net/app/Pidgin
msn-pecan from the repositories: sudo apt-get install msn-pecan

GregR1 (bluepowder7) wrote :

i have 2.5.2 and worked fine. before doing the msn-pecan install, i
did try to reinstall pidgin, though. not sure if that helped reset
certain things or not.

VGT (vgt4eva) wrote :

There is a quick fix for this issue by using the WLM protocol rather than the MSN protocol.
Open your terminal and type in

[Ubuntu Intrepid Ibex]
"sudo apt-get install msn-pecan"

This is a plugin for your pidgin allowing you to use the WLM protocol.
Afterwards, just edit your current account and point it from MSN -> WLM in the protocol dropdown list.

cako (goldencako) wrote :

USER PLATFORM:
Ubuntu 8.10

AFFECTED SOFTWARE:
Pidgin 2.5.3

PROCEDURE:
1) Downloaded and installed 'msn-pecan' from repository
2) Re-started Pidgin
3) Disabled 'MSN' account.
4) Added 'WLM' account.

STATUS:
Currently communicating with MSN contacts quite well, though it has no updates on new email.

VGT (vgt4eva) wrote :

(Continue...)
Here's the installation link for several linux distribution

http://code.google.com/p/msn-pecan/wiki/HowToInstall

Richard Corner (rcorner) wrote :

Not just an issue in Linux versions of Pidgin - from today I have the same problem in Pidgin 2.5.3 on Windows XP.

Gerwin Tammenga (gerwin) wrote :

I have the problem to, there is need for a update fast because not every one is able to install a work around. so what can i do to solve this problem for every one?
my system:
ubuntu 8.10
kernel: 2.3.27-9-generic
gnome: 2.24.1
Pidgin 2.5.2

error??

(18:17:25) msn: Got the Address Book!
(18:17:25) msn: AB Faultstring: Passport Authorization Failed
(18:17:25) msn: AB Error Code: PassportAuthFail
(18:17:25) msn: C: NS 000: OUT
(18:17:25) proxy: No environment settings found, not using a proxy
(18:17:25) account: Disconnecting account 0x1ca95a0
(18:17:25) connection: Disconnecting connection 0x328f260
(18:17:25) msn: destroy the OIM 0x328e000
(18:17:25) msn: destroy httpconn (0x328ebd0)
(18:17:25) connection: Destroying connection 0x328f260

1 comments hidden view all 112 comments

Seems like there is a lot of confirmations but I will add this anyway: I tried with an old version on Vista this morning and then updated and it doesn't work there. Similar conditions with Ubuntu 8.10.

Birunthan Mohanathas (poiru) wrote :

By installing msn-pecan, and by selecting it from the accounts place (instead of MSN), everything works. Hope Pidgin will get an official fix soon..

Ben Romer (bromer) wrote :

The msn-pecan WLM workaround fails for me, with "unknown error code 403." Apparently this means that my contact list is not available, which is not all that different from the original error with the MSN plug-in.

Iain Lane (laney) wrote :

There is no need to further confirm this issue. The people that need to know are aware and preparing a fix. Further, this is not the proper place to discuss workarounds. Please use the Ubuntu forums or other arenas for this.

Thanks.

It works on Ubuntu/Jaunty at 64-bit too: msn-pecan is in the repositories...

Iain Lane (laney) wrote :

It seems it just fixed itself. Can a couple of people confirm?

Richard Corner (rcorner) wrote :

I had the same problem in Pidgin 2.5.3 on Windows XP (see my post above). It appears to have just resolved itself with no action from me.

Lemmiwinks (lemmiwinks) wrote :

I can confirm this! Works for me again too!!

Tony Manco (trmanco) wrote :

Everything back to normal, looks like it was a server side issue...

Michael W. (hotdog003-gmail) wrote :

This bug seems to be fixed on its own.

The pidgin devs were right- seems like it really was an MSN server outage.

Maybe we should have a rule not to create new MSN outage bugs within 24 hours of it happening to avoid clogging Launchpad if it resolves itself again..

GregR1 (bluepowder7) wrote :

going back to MSN protocol (8.04-64, 2.5.2) and things work again, so
confirmed. for now...

PeterKraus (peter-kraus) wrote :

AFAIK, from googling the internet, this was caused by temporary outage of the latest protocol version (15) on MS servers. MSN-pecan uses v.14; older pidgins use, obviously, older msn versions as well. While newest official clients use the newest version, they have a fallback feature enabled to fall back to older protocol.

Savvas Radevic (medigeek) wrote :

Set as "Invalid" - Bug seems to be not relevant to pidgin.

Changed in pidgin:
status: Confirmed → Invalid
KitBarnes (ambience) wrote :

Can confirm no sign of bug for me at all, successful sign on for first time today at ~20:00.
Looks like an M$ hiccough to me.

Ferk (ferkiwi) wrote :

It is valid!

From rekkanoryo (Pidgin developed):

We initially thought this was a server-side issue; now we know it is a server-side change that requires the client to send additional data that we do not currently send. It's outlined here (http://forums.cocoaforge.com/viewtopic.php?f=13&t=19141). We are currently working on a fix.

Savvas Radevic (medigeek) wrote :

Apologies, I reacted too soon. :)
Thanks Ferk!

Changed in pidgin:
status: Invalid → Confirmed
Changed in pidgin:
status: Unknown → New

They release 2.5.4 today on pidgin.im with the fix included. Please update it on repository, thanks

Savvas Radevic (medigeek) wrote :

Are you sure? Their bugs list doesn't close #8080:
http://developer.pidgin.im/query?status=closed&milestone=2.5.4

I've asked in #pidgin and someone replied:
< savvas> does 2.5.4 close #8080 bug? http://developer.pidgin.im/ticket/8080
< Err> actually, MSN closed bug 8080, by not breaking on pidgin's login anymore
< savvas> Err: yes, I know that, but in the comments they say that it's going to have a workaround about it in pidgin's code
< Err> there is a work-around, I think, but it's not complete

Stan (stan1) wrote :

The new version doesn't include a fix:

"# Change Contact Server to temporarily fix connection problems. (Thanks to Youness Alaoui)"

It's just a temporary fix which is not needed anymore (because all users report the problem is fixed) . There is no need to update pidgin in my opinion.

Yeah you're right, the main server is ok but seems the others are still not working for someone (like omega contact list server) as you can see on their bug report and on some forums.

Changed in pidgin:
status: New → Fix Released
Nicolò Chieffo (yelo3) wrote :

works for me

Changed in pidgin:
status: Confirmed → Fix Released

I updated my Ubuntu 8.10 today and Pidgin stopped working with MSN, works fine with Jabber.
The message I get is "Unable to retrieve MSN Address Book"
I'm not sure that it stopped working exactly after the update.

Download full text (6.3 KiB)

Update!

I do not know if it is relevant but these are the packages installed during todays update:
peter@peter-laptop:~$ grep 2009-09-23 /var/log/dpkg.log
2009-09-23 07:46:22 startup archives unpack
2009-09-23 07:46:48 upgrade libneon27 0.28.2-2build1 0.28.2-2ubuntu0.1
2009-09-23 07:46:48 status half-configured libneon27 0.28.2-2build1
2009-09-23 07:46:48 status unpacked libneon27 0.28.2-2build1
2009-09-23 07:46:48 status half-installed libneon27 0.28.2-2build1
2009-09-23 07:46:48 status half-installed libneon27 0.28.2-2build1
2009-09-23 07:46:48 status unpacked libneon27 0.28.2-2ubuntu0.1
2009-09-23 07:46:48 status unpacked libneon27 0.28.2-2ubuntu0.1
2009-09-23 07:46:48 upgrade libneon27-gnutls 0.28.2-2build1 0.28.2-2ubuntu0.1
2009-09-23 07:46:48 status half-configured libneon27-gnutls 0.28.2-2build1
2009-09-23 07:46:48 status unpacked libneon27-gnutls 0.28.2-2build1
2009-09-23 07:46:48 status half-installed libneon27-gnutls 0.28.2-2build1
2009-09-23 07:46:48 status half-installed libneon27-gnutls 0.28.2-2build1
2009-09-23 07:46:49 status unpacked libneon27-gnutls 0.28.2-2ubuntu0.1
2009-09-23 07:46:49 status unpacked libneon27-gnutls 0.28.2-2ubuntu0.1
2009-09-23 07:46:49 upgrade libpq-dev 8.3.7-0ubuntu8.10.1 8.3.8-0ubuntu8.10
2009-09-23 07:46:49 status half-configured libpq-dev 8.3.7-0ubuntu8.10.1
2009-09-23 07:46:49 status unpacked libpq-dev 8.3.7-0ubuntu8.10.1
2009-09-23 07:46:49 status half-installed libpq-dev 8.3.7-0ubuntu8.10.1
2009-09-23 07:46:49 status triggers-pending man-db 2.5.2-2
2009-09-23 07:46:49 status half-installed libpq-dev 8.3.7-0ubuntu8.10.1
2009-09-23 07:46:49 status half-installed libpq-dev 8.3.7-0ubuntu8.10.1
2009-09-23 07:46:50 status unpacked libpq-dev 8.3.8-0ubuntu8.10
2009-09-23 07:46:50 status unpacked libpq-dev 8.3.8-0ubuntu8.10
2009-09-23 07:46:50 upgrade libpq5 8.3.7-0ubuntu8.10.1 8.3.8-0ubuntu8.10
2009-09-23 07:46:50 status half-configured libpq5 8.3.7-0ubuntu8.10.1
2009-09-23 07:46:50 status unpacked libpq5 8.3.7-0ubuntu8.10.1
2009-09-23 07:46:50 status half-installed libpq5 8.3.7-0ubuntu8.10.1
2009-09-23 07:46:50 status half-installed libpq5 8.3.7-0ubuntu8.10.1
2009-09-23 07:46:50 status unpacked libpq5 8.3.8-0ubuntu8.10
2009-09-23 07:46:50 status unpacked libpq5 8.3.8-0ubuntu8.10
2009-09-23 07:46:50 upgrade postgresql-client-8.3 8.3.7-0ubuntu8.10.1 8.3.8-0ubuntu8.10
2009-09-23 07:46:50 status half-configured postgresql-client-8.3 8.3.7-0ubuntu8.10.1
2009-09-23 07:46:50 status unpacked postgresql-client-8.3 8.3.7-0ubuntu8.10.1
2009-09-23 07:46:50 status half-installed postgresql-client-8.3 8.3.7-0ubuntu8.10.1
2009-09-23 07:46:51 status half-installed postgresql-client-8.3 8.3.7-0ubuntu8.10.1
2009-09-23 07:46:51 status unpacked postgresql-client-8.3 8.3.8-0ubuntu8.10
2009-09-23 07:46:51 status unpacked postgresql-client-8.3 8.3.8-0ubuntu8.10
2009-09-23 07:46:51 upgrade postgresql-8.3 8.3.7-0ubuntu8.10.1 8.3.8-0ubuntu8.10
2009-09-23 07:46:51 status half-configured postgresql-8.3 8.3.7-0ubuntu8.10.1
2009-09-23 07:46:52 status unpacked postgresql-8.3 8.3.7-0ubuntu8.10.1
2009-09-23 07:46:52 status half-installed postgresql-8.3 8.3.7-0ubuntu8.10.1
2009-09-23 07:46:53 status half-installed postgresql-8.3 8.3.7-0...

Read more...

Displaying first 40 and last 40 comments. View all 112 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.