Ubuntu

Wx/Wx.so: undefined symbols

Reported by Nadav on 2009-11-18
78
This bug affects 17 people
Affects Status Importance Assigned to Milestone
libwx-perl (Ubuntu)
Undecided
Unassigned
padre (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: padre

$ padre
/usr/bin/perl: relocation error: /usr/lib/perl5/auto/Wx/Wx.so: symbol _ZN12wxSearchCtrl18SetDescriptiveTextERK8wxString, version WXU_2.8.2 not defined in file libwx_gtk2u_core-2.8.so.0 with link time reference

ProblemType: Bug
Architecture: i386
Date: Wed Nov 18 22:53:08 2009
DistroRelease: Ubuntu 9.10
Package: padre 0.42-1
PackageArchitecture: all
ProcEnviron:
 LANG=he_IL.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: padre
Uname: Linux 2.6.31-14-generic i686
XsessionErrors:
 (gnome-settings-daemon:3328): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (polkit-gnome-authentication-agent-1:3457): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (nautilus:3425): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed
 (gnome-panel:3422): Gdk-WARNING **: /build/buildd/gtk+2.0-2.18.3/gdk/x11/gdkdrawable-x11.c:952 drawable is not a pixmap or window
 (gnome-power-manager:3464): Gdk-CRITICAL **: gdk_window_thaw_toplevel_updates_libgtk_only: assertion `private->update_and_descendants_freeze_count > 0' failed

Nadav (nadavvin) wrote :
McFly81 (christian-lange-81) wrote :

same error here. Runnung Ubuntu Karmic Koala (9.10). Padre does not start , only gives "/usr/bin/perl: relocation error: /usr/lib/perl5/auto/Wx/Wx.so: symbol _ZN12wxSearchCtrl18SetDescriptiveTextERK8wxString, version WXU_2.8.2 not defined in file libwx_gtk2u_core-2.8.so.0 with link time reference"

dingsi (born2lie) wrote :

deinstall and new install (including direct dependencies) did not help to fix the problem. still same error. also running karmic

dingsi (born2lie) wrote :

workaround:

edit ~/.padre/config.yml
change main_directory: 1
to main_directory: 0

and do not start the directory view

dingsi (born2lie) wrote :

UBUNTU KARMIC: another workaround for those who want to have limited functionality with directory tree (searching will kill the app):

uncomment (#) line 26 in file /usr/share/perl5/Padre/Wx/Directory/SearchCtrl.pm

Steffen Mueller (smueller-cpan) wrote :

This is an issue with the libwx-perl package. I could reproduce the bug with:

perl -e'BEGIN { @INC = grep {not m(/usr/local)} @INC; }use Wx; Wx::SearchCtrl->new->SetDescriptiveText("foo");'

Where the BEGIN{...} is just necessary to shadow the modules I manually installed from CPAN, which would otherwise load my own copy of Wx.

On a virgin ubuntu, this would cause the same problem:

perl -MWx -e'Wx::SearchCtrl->new->SetDescriptiveText("foo");'

summary: - padre not open after crash when open file directory from the menu
+ Wx/Wx.so: undefined symbols
Changed in libwx-perl (Ubuntu):
status: New → Confirmed
Damyan Ivanov (dmn-debian) wrote :

Here's the debdiff for simple rebuild. No surprises.

======================================
debdiff libwx-perl_0.96-1.dsc /var/cache/pbuilder/result/libwx-perl_0.96-1build1.dsc
diff -u libwx-perl-0.96/debian/changelog libwx-perl-0.96/debian/changelog
--- libwx-perl-0.96/debian/changelog
+++ libwx-perl-0.96/debian/changelog
@@ -1,3 +1,9 @@
+libwx-perl (0.96-1build1) lucid; urgency=low
+
+ * Rebuld to pick the right Wx symbols. (LP: #495012)
+
+ -- Damyan Ivanov <email address hidden> Sun, 18 Apr 2010 21:02:33 +0300
+
 libwx-perl (0.96-1) unstable; urgency=low

   * require alien-wxwidgets version 0.48
======================================

Changed in libwx-perl (Ubuntu):
status: Confirmed → Fix Released
Changed in padre (Ubuntu):
status: New → Fix Released
Vol7ron Forum (vol7ron-forum) wrote :

https://bugs.launchpad.net/ubuntu/+source/padre/+bug/485012

Yeah... not fixed for me.
Ubuntu 9.10 x64

Changed in padre (Ubuntu):
status: Fix Released → Incomplete
aquanaut (thecrux) wrote :

Ubuntu Maverick x86_64
libwx-perl 0.9702-1

When i try to run Padre it receive SIGSEGV.

$ gdb --args perl /usr/bin/padre
(gdb) run
Starting program: /usr/bin/perl /usr/bin/padre
[Thread debugging using libthread_db enabled]

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff5bf6712 in XS_Wx__load_plugin () from /usr/lib/perl5/auto/Wx/Wx.so
......

$ LD_BIND_NOW=1 perl -MWx
Can't load '/usr/lib/perl5/auto/Wx/Wx.so' for module Wx: /usr/lib/perl5/auto/Wx/Wx.so: symbol _ZN14wxTreeCtrlBase11CollapseAllEv, version WXU_2.8 not defined in file libwx_gtk2u_core-2.8.so.0 with link time reference at /usr/lib/perl/5.10/DynaLoader.pm line 192.
 at - line 0
Compilation failed in require.
BEGIN failed--compilation aborted.

It seems rebuild of libwx-perl required

Zeno Gantner (zeno-gantner) wrote :

One possible workaround is to install wx-perl from CPAN:

sudo cpan Alien::wxWidgets
sudo cpan Wx

Harald Jörg (harald-joerg) wrote :

This is just to confirm that I had the same problem with Padre on Ubuntu 10.10 (Maverick, 32Bit), with a fresh installation of all components.
The workaround to directly install wx-perl from CPAN helps.

Ubuntu versions: Padre = 0.63.ds1-1
                            libwxgtk2.8-0 = 2.8.11.0-0ubuntu4
                            Alien::wxWidgets = 0.50
                            Wx = 0.9702-1

CPAN versions: Alien::wxWidgets = 0.51
                            Wx = 0.98

Bettina (vmutius-googlemail) wrote :

I have the same problem with Ubuntu 11.04 beta version (32bit)

The workaround with the cpan modul does not work for me.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers