kernel update breaks oss4

Bug #601342 reported by Schaap on 2010-07-03
750
This bug affects 67 people
Affects Status Importance Assigned to Milestone
oss4 (Ubuntu)
Undecided
Unassigned
Lucid
Medium
Unassigned

Bug Description

# BUG IMPACT:
Module fails FTBFS in lucid rendering oss4 unusable, fix at least allows the modules to build

# DEVELOPMENT BRANCH FIX:
oss4-4.2-build2003 dkms.conf in maverick uses /lib/modules/${kernelver}/build/include/linux/limits.h, this is the fix backported, currently lucid version uses /lib/modules/${kernelver}/source/include/linux/limits.h

# MINIMAL PATCH
oss4_4.2-build2002-2ubuntu0.1.debdiff attached to end of bug report

# TEST CASE
$ sudo apt-get install oss4-dkms
Building module:
cleaning build area....
cp /lib/modules/2.6.35-22-generic/source/include/linux/limits.h /var/lib/dkms/oss4/4.2-build2002/build/core && make -C /lib/modules/2.6.35-22-generic/build SUBDIRS=/var/lib/dkms/oss4/4.2-build2002/build/core modules && make -C /var/lib/dkms/oss4/4.2-build2002/build/drivers osscore_symbols.inc && make -C /lib/modules/2.6.35-22-generic/build SUBDIRS=/var/lib/dkms/oss4/4.2-build2002/build/drivers modules....(bad exit status: 1)

Error! Bad return status for module build on kernel: 2.6.35-22-generic (i686)
Consult the make.log in the build directory
/var/lib/dkms/oss4/4.2-build2002/build/ for more information.
0
0
dpkg: error processing oss4-dkms (--install):
 subprocess installed post-installation script returned error exit status 10
Errors were encountered while processing:
 oss4-dkms

nb: 2.6.35 kernel in example but verified broken on 2.6.32 lucid kernels too

# REGRESSION POTENTIAL:
The package is unusable as the module fails to build. Problems that could be caused by actually using the oss4 modules
are unknown but certainly possible

********** ORIGINAL MESSAGE **********
After running an update to a new kernel I got an error about packacge oss4-dkms. I ignored it, alas, and rebooted the next day. After reboot, all sound was gone. Indeed, no modules for sound were loaded. I remembered the error and forced a reinstall:

apt-get --reinstall install oss4-base oss4-dkms

This went wrong when installing oss4-dkms: it tried to update the new kernel (2.6.32-23-generic on 10.04 x64) to include the oss4 modules but couldn't proceed since /lib/modules/2.6.32-23-generic/source/ doesn't exist. I checked, kernel sources are installed. A simple ln -s /usr/src/linux-headers-2.6.32-23-generic/ /lib/modules/2.6.32-23-generic/source solved the problem.

Proposed solution: either have the oss4-dms package look in /usr/src/linux-headers-xxx for it's files, or create the symlink given above by default.

Romain Beauxis (toots) wrote :

This problem is caused by an inconsistency in the linux-headers packages.
Some of them provide the symlink, some other don't.

The latest oss4-dkms package (4.2build3002-1) now explicitely requires a linux-header package to be installed, which should fix the problem is most cases.

In general, I am not sure that pointing to /usr/src/... is a good solution, the existence of a /lib/modules/`uname -r`/build symlink is a pretty standard requirement for generic module build so this problem will happen again for other external modules and I would recommend investigating why this symlink does not exist in some installs...

Schaap (t-m-schaap) wrote :

I only just noticed: you talked about the standard requirement of having a /lib/modules/`uname -r`/build symlink. As far as I've seen, though, that very symlink is available. The oss4-dkms package, however, seems to require the /lib/modules/`uname -r`/source symlink. I'm not sure whether that is a standard symlink as well, or a non-standard requirement from oss4-dkms.

Also, at this moment the bug still exists: last kernel-update (2.6.32-24-generic) required me to create the symlink again. Not a big deal for me, but a showstopper for the less knowledgeable user running OSS4.

oss4 (4.2-build2002-2ubuntu1.1) lucid; urgency=low

  * debian/dkms/dkms.conf.template:
  - Fix FTBS by changing path to limits.h. Fixed in Maverick version
  oss4-4.2-build2003 (LP: #636746)

Test-build: https://edge.launchpad.net/~sevenmachines/+archive/release/+packages

Changed in oss4 (Ubuntu):
status: New → Confirmed
assignee: nobody → SevenMachines (sevenmachines)
status: Confirmed → In Progress

* Change version and release for SRU
* actually update-maintainer!

Many if not all of the reported lucid build bugs against oss4 are most likely fixed by this but there isnt enough information to be absolutely sure. If someone in the know could check if they should be duplicates of this or left?

 oss4 (4.2-build2002-2ubuntu0.1) lucid-proposed; urgency=low

  * debian/dkms/dkms.conf.template:
  - Fix FTBS by changing path to limits.h. Fixed in Maverick version
  oss4-4.2-build2003 (LP: #601342)

description: updated
tags: added: patch
description: updated
Changed in oss4 (Ubuntu):
status: In Progress → Confirmed
assignee: SevenMachines (sevenmachines) → nobody

Hi SevenMachines:

Thanks for the heads up on the fix. I installed the fix with no
errors. However, my audio is still not working. I reinstalled all the
alsa software and still no audio. The audio failed when the oss4
system crash occurred. FYI

Gary

On Fri, Sep 17, 2010 at 7:43 AM, SevenMachines
<email address hidden> wrote:
>
> ** Attachment added: "installation log"
>   https://bugs.edge.launchpad.net/ubuntu/+source/oss4/+bug/601342/+attachment/1598402/+files/installation.log
>
> ** Changed in: oss4 (Ubuntu)
>       Status: In Progress => Confirmed
>
> ** Changed in: oss4 (Ubuntu)
>     Assignee: SevenMachines (sevenmachines) => (unassigned)
>
> --
> kernel update breaks oss4
> https://bugs.launchpad.net/bugs/601342
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (624980).
>

--
Gary Evans
<email address hidden>

I am getting this error whenever I install or update packages.
I am a relatively new user of UBUNTU and wondered if I could get some instructions of how to download and apply this patch.

Thanks,

Richard

James Kevin Jones (james-jones) wrote :
Download full text (3.3 KiB)

I got the same thing...I installed 10.10 and ditched 10.04

Kevin
http://free4leafclover.com/

________________________________
From: M Richard Weiss <email address hidden>
To: <email address hidden>
Sent: Tue, November 16, 2010 10:30:38 AM
Subject: [Bug 601342] Re: kernel update breaks oss4

I am getting this error whenever I install or update packages.
I am a relatively new user of UBUNTU and wondered if I could get some
instructions of how to download and apply this patch.

Thanks,

Richard

--
kernel update breaks oss4
https://bugs.launchpad.net/bugs/601342
You received this bug notification because you are a direct subscriber
of a duplicate bug (618053).

Status in “oss4” package in Ubuntu: Confirmed

Bug description:
# BUG IMPACT:
Module fails FTBFS in lucid rendering oss4 unusable, fix at least allows the
modules to build

# DEVELOPMENT BRANCH FIX:
oss4-4.2-build2003 dkms.conf in maverick uses
/lib/modules/${kernelver}/build/include/linux/limits.h, this is the fix
backported, currently lucid version uses
/lib/modules/${kernelver}/source/include/linux/limits.h

# MINIMAL PATCH
oss4_4.2-build2002-2ubuntu0.1.debdiff attached to end of bug report

# TEST CASE
$ sudo apt-get install oss4-dkms
Building module:
cleaning build area....
cp /lib/modules/2.6.35-22-generic/source/include/linux/limits.h
/var/lib/dkms/oss4/4.2-build2002/build/core && make -C
/lib/modules/2.6.35-22-generic/build
SUBDIRS=/var/lib/dkms/oss4/4.2-build2002/build/core modules && make -C
/var/lib/dkms/oss4/4.2-build2002/build/drivers osscore_symbols.inc && make -C
/lib/modules/2.6.35-22-generic/build
SUBDIRS=/var/lib/dkms/oss4/4.2-build2002/build/drivers modules....(bad exit
status: 1)

Error! Bad return status for module build on kernel: 2.6.35-22-generic (i686)
Consult the make.log in the build directory
/var/lib/dkms/oss4/4.2-build2002/build/ for more information.
0
0
dpkg: error processing oss4-dkms (--install):
 subprocess installed post-installation script returned error exit status 10
Errors were encountered while processing:
 oss4-dkms

nb: 2.6.35 kernel in example but verified broken on 2.6.32 lucid kernels too

# REGRESSION POTENTIAL:
The package is unusable as the module fails to build. Problems that could be
caused by actually using the oss4 modules
are unknown but certainly possible

********** ORIGINAL MESSAGE **********
After running an update to a new kernel I got an error about packacge oss4-dkms.
I ignored it, alas, and rebooted the next day. After reboot, all sound was gone.
Indeed, no modules for sound were loaded. I remembered the error and forced a
reinstall:

apt-get --reinstall install oss4-base oss4-dkms

This went wrong when installing oss4-dkms: it tried to update the new kernel
(2.6.32-23-generic on 10.04 x64) to include the oss4 modules but couldn't
proceed since /lib/modules/2.6.32-23-generic/source/ doesn't exist. I checked,
kernel sources are installed. A simple ln -s
/usr/src/linux-headers-2.6.32-23-generic/ /lib/modules/2.6.32-23-generic/source
solved the problem.

Proposed solution: either have the oss4-dms package look in
/usr/src/linux-headers-xxx for it's files, or create the symlink given above b...

Read more...

Stefano Rivera (stefanor) wrote :

This issue was already fixed in maverick. Natty and oneiric are broken, but for different reasons.

This SRU looks good to me. SevenMachines: You should have subscribed ubuntu-sponsors.

Changed in oss4 (Ubuntu):
status: Confirmed → Fix Released
Changed in oss4 (Ubuntu Lucid):
importance: Undecided → Medium
Stefano Rivera (stefanor) wrote :

Uploaded to lucid-proposed, pending SRU team review.

Changed in oss4 (Ubuntu Lucid):
status: New → Fix Committed

Accepted oss4 into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Stefano Rivera (stefanor) wrote :

I see no independent verification yet, but I can report that it DKMS builds for me in a lucid VM.

However it doesn't support the new proposed lucid 2.6.38 backport kernel, for that we'd need the patch from LP: #746048

Martin Pitt (pitti) on 2011-06-24
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package oss4 - 4.2-build2002-2ubuntu0.1

---------------
oss4 (4.2-build2002-2ubuntu0.1) lucid-proposed; urgency=low

  * debian/dkms/dkms.conf.template:
    - Fix dkms build failure by changing path to limits.h. Fixed in Maverick
      version oss4-4.2-build2003 (LP: #601342)
 -- Niall Creech <email address hidden> Fri, 03 Jun 2011 18:59:26 +0200

Changed in oss4 (Ubuntu Lucid):
status: Fix Committed → Fix Released
tags: added: testcase
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers