Default openoffice font unusable in greek

Bug #9093 reported by Giorgos Logiotatidis on 2004-10-14
14
Affects Status Importance Assigned to Milestone
openoffice.org (Debian)
Fix Released
Unknown
openoffice.org (Ubuntu)
Medium
Matthias Klose

Bug Description

Hello,
The default font chosen for openoffice documents is unusable in Greek language
and maybe others. Freesans freeserif and freemono work perfectly. Please
consider changing the default font to increase usability.

thnx in advance
g.l.

Giorgos Logiotatidis (seadog) wrote :

Hello,
The default font chosen for openoffice documents is unusable in Greek language
and maybe others. Freesans freeserif and freemono work perfectly. Please
consider changing the default font to increase usability.

thnx in advance
g.l.

Matt Zimmerman (mdz) wrote :

As I recall, we decided on the existing font strategy in order to achieve the
best coverage for international character sets. Jeff, Mako?

Jeff Waugh (jdub) wrote :

(In reply to comment #1)
> As I recall, we decided on the existing font strategy in order to achieve the
> best coverage for international character sets. Jeff, Mako?

Nup, we're still using Bitstream Vera as the default, because no one wanted to
commit to using one of the Lucidux or similar fonts. That means that we'll have
problems for 'unusual' characters in this set (Greek, Welsh, etc).

Matthias Klose (doko) wrote :

1.1.3-2.3ubuntu9

Giorgos Logiotatidis (seadog) wrote :

I tested yesterday's night build and oo.org still uses Nimbus Roman No9 L as the
default font. package version 1.1.3-7.8ubuntu1

thnx
g.l.

Matthias Klose (doko) wrote :

which version of the gsfonts package is installed?

Giorgos Logiotatidis (seadog) wrote :

gsfonts : 8.14+v8.11-0.1ubuntu1

Simos Xenitellis  (simosx) wrote :

I am reopening this bug report with new info.

Not all fonts contain Greek glyphs, so font substitution takes place.
This is the case with "Nimbus Roman No9 L" and OOo; it's the default font in OOo
but does not have glyphs for Greek, so OpenOffice.org 1.1.3 appears to take them
from an Asian-CJK font (probably "Baekmuk Batang" or "AR PL Mingti2L Big5").

The above Asian fonts are not related to "gsfonts", mentioned in this bug report.

I do not know how to tell OOo to prefer FreeSans over the Asian fonts, for the
Greek language, in an elegant way.

A quick&nasty fix would be to
1) Click Tools/Options/Fonts/Font Substitution and setup a font substitution,
for "Nimbus Roman No9 L"
to be substituted with "FreeSans". However, this will substitute Nimbus in
english as well to FreeSans.

I am adding some screenshots below to demonstrate.

Simos Xenitellis  (simosx) wrote :

Created an attachment (id=1844)
Default font in OOo, showing text in Greek. Lines 3-4 are not even shown
(characters have accents)

I wrote some sample text. In the next screenshot, you will see the proper
representation of the text. The Nimbus font does not have Greek, and OOo 1.1.3
probably takes the glyphs from an Asian font (Baekmuk?).

Simos Xenitellis  (simosx) wrote :

Created an attachment (id=1845)
Changing font to FreeSans, text is shown correctly. Can see two lines that were
invisible previously.

Simos Xenitellis  (simosx) wrote :

Created an attachment (id=1846)
The Nimbus font does not have Greek glyphs, as demonstrated.

"fontforge" would have been better to demonstrate. Sorry, I do not have it
available.

Simos Xenitellis  (simosx) wrote :

Created an attachment (id=1847)
Slightly irrelevant - The same problematic font is used for the interface of
"oopadmin" (OOo printer configuration).

This screenshot is FYI only. Depending on the solution given, it might get
solved as well in one go.
Else, we will file another bug report.

Simos Xenitellis  (simosx) wrote :

Created an attachment (id=1849)
Text shown in the screenshot, in UTF-8 encoding.

The text file has the BOM character (it's the special UTF-8 character that
appears in the beginning of the UTF-8 encoded text files...)

Simos Xenitellis  (simosx) wrote :

Done with uploads.

Matthias Klose (doko) wrote :

so why do you know better?

Simos Xenitellis  (simosx) wrote :

(In reply to comment #14)
> so why do you know better?
>

I suppose this is a rhetorical question (that is, does not require answer).
I would be interested to see where PENDINGUPLOAD refers to.

I hope the issue gets clarified before release time.

Simos Xenitellis  (simosx) wrote :

Created an attachment (id=1903)
Patch to enable OOo to select a proper font to display Greek, when the locale
is Greek (el-GR).

Default font selection/substitution in OpenOffice.org is specified in the
system file
/usr/lib/openoffice/share/registry/data/org/openoffice/VCL.xcu

This file allows to set per-locale the list of available fonts.
In the patch attached, I add a section "el-GR", including the suitable fonts
(FreeSans, FreeSerif, FreeMono) to display Greek.

Please ACK if this works for you.

Matthias Klose (doko) wrote :

Simos, a status "PENDINGUPLOAD" means, that the bug is fixed and the package is
waiting for upload. We usually don't make uploads for every single bug fix.
I see that the explanation of the Status field is missing a description of this
value. I'll file a bug.

Simos Xenitellis  (simosx) wrote :

I just installed Ubuntu Hoary Release Candidate and I noticed that bug has not
been solved yet.

I am not quite sure what change has taken place to solve the problem.
According to my investigation described in
https://bugzilla.ubuntu.com/show_bug.cgi?id=2374#c16
the problem is related to the font substitution mechanism of OpenOffice.org that
does not list FreeSans/FreeSerif,
therefore it falls back to crude double-width Asia fonts.

I am reattaching the patch bellow.

Simos Xenitellis  (simosx) wrote :

Created an attachment (id=1958)
Patch to enable Greek-specific font substitution rules for OOo

This patch enables the choosing of FreeSans/FreeSerif when doing font
substitution in OpenOffice.org for the Greek (el_GR) locale.

Giorgos Logiotatidis (seadog) wrote :

the release day is comming, anything new on this?

Matthias Klose (doko) wrote :

fixed in openoffice.org 1.1.3-8ubuntu2

Simos Xenitellis  (simosx) wrote :

I just updated my Ubuntu Hoary 5.04 RC system and openoffice.org was updated to
1.1.3-8ubuntu2.
I checked /usr/lib/openoffice/share/registry/data/org/openoffice/VCL.xcu
and indeed there is section for the Greek locale (el-GR).

However, the references to the FreeSans, FreeSerif and FreeMono are missing. It
appears that the new
greek section is simply a copy of the default "en" (English), therefore this
issue is not resolved.

My patch changes each line of
<value>Albany;Arial;Luxi Serif;Helvetica;Lucida;Geneva;Helmet;Andale Sans
UI;Arial Unicode MS;Lucida Sans Unicode;Tahoma;SansSerif</value>
to
<value>Albany;Arial;Luxi Serif;Helvetica;Lucida;Geneva;Helmet;Andale Sans
UI;Arial Unicode MS;Lucida Sans Unicode;Tahoma;SansSerif;FreeSans</value>

and I make sure that there is correspondence between Serif, SansSerif or Mono.
For example, above, FreeSans is required, and so on.

Therefore, I attach a new patch based on 1.1.3-8ubuntu2 that fixes exactly this
issue.
It applies cleanly, it affect the Greek section only, and has been tested
extensively.

Simos Xenitellis  (simosx) wrote :

Created an attachment (id=2025)
Patch against OpenOffice.org (1.1.3-8ubuntu2) that specify correct fonts in
VCL.xcu, for the Greek language.

The patch updates the Greek section in VCL.xcu
(/usr/lib/openoffice/share/registry/data/org/openoffice/VCL.xcu)
by adding the FreeSans/FreeSerif/FreeMono font in the list. It makes sure to
specify FreeSans, when a SansSerif font is needed and so on.

It has been extensively verified and works beautifully on my system.

The change in VCL.xcu does not affect any other language, but only the Greek
locale.

I also upgrade the locale specifier from "el-GR" to "el" (that is,
- <node oor:name="el-GR" oor:op="replace">
+ <node oor:name="el" oor:op="replace">)
The reason is, Greek is spoken in Greece (GR) and Cyprus (CY).
Keeping "el-GR" at this point would not apply Cypriot users!

I understand at these last moments of the release of Ubuntu you are very busy
fixing stuff.
If you can add this one, you would have resolved all outstanding localisation
bugs for the Greek language!

Simos Xenitellis  (simosx) wrote :

Created an attachment (id=2026)
(updated) Patch against OpenOffice.org (1.1.3-8ubuntu2) that specify correct
fonts in VCL.xcu, for the Greek language.

Updated, final patch.

This fixes "oopadmin" as well (mentioned in the report) by specifying the
interface font.

Matthias Klose (doko) wrote :

no, that's definitely not the case. on a fresh greek install, I get the greek
fonts in the UI. Please verify with a fresh install.

try to remove fonts installed from universe and find the font, which is the
cause for the wrong display.

Simos Xenitellis  (simosx) wrote :

(In reply to comment #25)
> no, that's definitely not the case. on a fresh greek install, I get the greek
> fonts in the UI. Please verify with a fresh install.

I just finished a fresh install + full updates of hoary release candidate.
I verified that with a fresh install, the problem is not solved.

It still looks like https://bugzilla.ubuntu.com/attachment.cgi?id=1844 (wrong)
while it should look like https://bugzilla.ubuntu.com/attachment.cgi?id=1845
(correct).

> try to remove fonts installed from universe and find the font, which is the
> cause for the wrong display.

I do not have universe in my repositories.
I verified that the (wrong) font shown is Baekmuk Batang, from the ttf-baekmuk
package.
The ttf-baekmuk package is a standard font package found on the installation
CDROM of Ubuntu Linux.
The reasons why Baekmuk Batang is not an appropriate font to represent Greek are
1. It's a double-width font, so not appropriate for western alphabets.
2. It does not contain glyphs of accented characters, therefore they do not
appear at all.

I still stand by the patch show above in #24
(https://bugzilla.ubuntu.com/show_bug.cgi?id=2374#c24)
and I really would like to ask you to apply it.

Martin Pitt (pitti) wrote :

I just installed Hoary from the latest CD, installed openoffice.org-l10n-el,
switched to a greek locale (el_GR.UTF-8). The menus are translated to greek and
I can type greek letters into OO.o writer.

Simos Xenitellis  (simosx) wrote :

(In reply to comment #27)
> I just installed Hoary from the latest CD, installed openoffice.org-l10n-el,
> switched to a greek locale (el_GR.UTF-8). The menus are translated to greek and
> I can type greek letters into OO.o writer.

You can type Greek in OOo, though the font selected (Baekmuk Batang) is not
suitable.
Define "suitable":
1. It's a double-width Asian font that happens to have Greek glyphs. The
character spacing is too big and odd.
2. The glyphs have been designed in italics in the font, so no chance to have
"regular" typeface.
3. The font does not contain accented Greek glyphs, so it does not show those
characters! You end up having incorrect text.
4. It appears that the Baekmuk Batang font is a last (ultimate?) choice font to
display Greek, based on the fontconfig settings for font substitution.
5. The program "oowriter" uses FreeMono to show the menus in Greek, which is
good. Please try "oopadmin" as well (it uses Baekmuk Batang).

When you type Greek and you get the result:
https://bugzilla.ubuntu.com/attachment.cgi?id=1844
this is INCORRECT. The font is Baekmuk Batang as described above.

If you read up this bug report, you will see a test suite, that I repeat here.
A. The text file https://bugzilla.ubuntu.com/attachment.cgi?id=1849 (attached
above) is UTF-8 Greek text
Open this file and paste into OpenOffice.org Writer.
B. Compare the rendering of the Greek text with what I get:
https://bugzilla.ubuntu.com/attachment.cgi?id=1844
If you get the same (or similar, as the browser window may carry formatting
information),
then this is INCORRECT Greek. This is what I am talking about all along.
C. You should see something like https://bugzilla.ubuntu.com/attachment.cgi?id=1845
(you can verify it's similar to the browser rendering of the sample text,
https://bugzilla.ubuntu.com/attachment.cgi?id=1849)
D. Please provide a screenshot of what you get. If you get by default what is
shown in step C above,
I'll shut up forever on this bug report.

I am online (ahem, work...) and I am happy to provide any other information
required to sort out this issue.

All my money though are on https://bugzilla.ubuntu.com/show_bug.cgi?id=2374#c26

Simos Xenitellis  (simosx) wrote :

Question: Could fontconfig be configured so that it substitutes to
FreeSans/FreeSerif/FreeMono
when the system is asked to show Greek?
Answer: Possibly yes, though I have not no idea how it can be done.

Question: Your (well, my) proposed solution will fix the display of Greek only
when users
select the Greek locale. Isn't that suboptimal?
Answer: Yes it is. Though, at this point, it appears as an "acceptable"
solution, seeing the time constraints.

Question: How does OpenOffice.org do font substitution?
Answer: It appears to be a combination for fontconfig magic and a bit of font
substitution by OOo itself, as described in
/usr/lib/openoffice/share/registry/data/org/openoffice/VCL.xcu

Question: Why does fontconfig specify Baekmuk Batang to display Greek?
Answer: I have checked the file; it does not mention the font. Somehow, due to
fontconfig magic(?),
Baekmuk Batang is chosen in place of FreeSans/FreeSerif/FreeMono.

Question: How do you know that Baekmuk Batang is the font shown?
Answer: I simply removed the .ttf file from /usr/share/fonts/..., started OOo
again and I could see that no Greek were being displayed.

Question: Are you happy to test this fontconfig configuration file to see if it
works better?
Answer: Yes, contact my by e-mail (link above), or at http://simos.info/

Question: Is this a serious issue?
Asnwer: Yes it is. The "It just works" does not apply here, as when a person
types something, bad greek are shown.

Simos Xenitellis  (simosx) wrote :

It has been reported to work by installing
openoffice.org-gtk-gnome
openoffice.org-kde
(depending on whether you have Ubuntu or Kubuntu).

Haven't tried it myself and I do not know the details how it is fixed.

I am closing the bug for now. If someone still has this problem, please open it
again.

Simos Xenitellis  (simosx) wrote :

I got more feedback on the "solved" report and
it appears that it refers to another issue. Specificaly, it was refering
to OOo showing correctly Greek in the menus of "oowriter", "oocalc" and so on.
This issue was actually already fixed in Hoary (probably also ok in Warty), by
allowing
gtk+ to draw the menus (openoffice.org-gtk-gnome).

However, this bug (#2374) has not been solved, thus I am reopening it.

Simos Xenitellis  (simosx) wrote :

The same bug appears to be mentioned in Debian Bugzilla,
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=252014
X-linking here.

tags 252014 moreinfo
thanks

This discussion in the Ubuntu bugzilla, is related and
summarizes/explains some of the reasons why this bug exists.

https://bugzilla.ubuntu.com/show_bug.cgi?id=2374

Actually this bug is not apparent _if_ the openoffice.org-gtk-gnome
package is installed by default. KDE does not present this behaviour.
I'm going to put this particular package, in the greek-desktop task
list.

Konstantinos

Matthias Klose (doko) wrote :

(In reply to comment #31)
> I got more feedback on the "solved" report and
> it appears that it refers to another issue. Specificaly, it was refering
> to OOo showing correctly Greek in the menus of "oowriter", "oocalc" and so on.
> This issue was actually already fixed in Hoary (probably also ok in Warty), by
> allowing
> gtk+ to draw the menus (openoffice.org-gtk-gnome).
>
> However, this bug (#2374) has not been solved, thus I am reopening it.

Looking at the patch, it looks like it's applied in both hoary and in breezy
(only difference is that "el-GR" is used in the package, and "el" in the patch.
I'm moving the Free* fonts to the first place in the font list. Please could you
check, if that makes a difference?

Download full text (16.7 KiB)

Source: openoffice.org
Source-Version: 1.1.4-7

We believe that the bug you reported is fixed in the latest version of
openoffice.org, which is due to be installed in the Debian FTP archive:

openoffice.org-bin_1.1.4-7_powerpc.deb
  to pool/main/o/openoffice.org/openoffice.org-bin_1.1.4-7_powerpc.deb
openoffice.org-dev_1.1.4-7_powerpc.deb
  to pool/main/o/openoffice.org/openoffice.org-dev_1.1.4-7_powerpc.deb
openoffice.org-evolution_1.1.4-7_powerpc.deb
  to pool/main/o/openoffice.org/openoffice.org-evolution_1.1.4-7_powerpc.deb
openoffice.org-gnomevfs_1.1.4-7_powerpc.deb
  to pool/main/o/openoffice.org/openoffice.org-gnomevfs_1.1.4-7_powerpc.deb
openoffice.org-gtk-gnome_1.1.4-7_powerpc.deb
  to pool/main/o/openoffice.org/openoffice.org-gtk-gnome_1.1.4-7_powerpc.deb
openoffice.org-l10n-af_1.1.4-7_all.deb
  to pool/main/o/openoffice.org/openoffice.org-l10n-af_1.1.4-7_all.deb
openoffice.org-l10n-ar_1.1.4-7_all.deb
  to pool/main/o/openoffice.org/openoffice.org-l10n-ar_1.1.4-7_all.deb
openoffice.org-l10n-ca_1.1.4-7_all.deb
  to pool/main/o/openoffice.org/openoffice.org-l10n-ca_1.1.4-7_all.deb
openoffice.org-l10n-cs_1.1.4-7_all.deb
  to pool/main/o/openoffice.org/openoffice.org-l10n-cs_1.1.4-7_all.deb
openoffice.org-l10n-cy_1.1.4-7_all.deb
  to pool/main/o/openoffice.org/openoffice.org-l10n-cy_1.1.4-7_all.deb
openoffice.org-l10n-da_1.1.4-7_all.deb
  to pool/main/o/openoffice.org/openoffice.org-l10n-da_1.1.4-7_all.deb
openoffice.org-l10n-de_1.1.4-7_all.deb
  to pool/main/o/openoffice.org/openoffice.org-l10n-de_1.1.4-7_all.deb
openoffice.org-l10n-el_1.1.4-7_all.deb
  to pool/main/o/openoffice.org/openoffice.org-l10n-el_1.1.4-7_all.deb
openoffice.org-l10n-en_1.1.4-7_all.deb
  to pool/main/o/openoffice.org/openoffice.org-l10n-en_1.1.4-7_all.deb
openoffice.org-l10n-es_1.1.4-7_all.deb
  to pool/main/o/openoffice.org/openoffice.org-l10n-es_1.1.4-7_all.deb
openoffice.org-l10n-et_1.1.4-7_all.deb
  to pool/main/o/openoffice.org/openoffice.org-l10n-et_1.1.4-7_all.deb
openoffice.org-l10n-eu_1.1.4-7_all.deb
  to pool/main/o/openoffice.org/openoffice.org-l10n-eu_1.1.4-7_all.deb
openoffice.org-l10n-fi_1.1.4-7_all.deb
  to pool/main/o/openoffice.org/openoffice.org-l10n-fi_1.1.4-7_all.deb
openoffice.org-l10n-fr_1.1.4-7_all.deb
  to pool/main/o/openoffice.org/openoffice.org-l10n-fr_1.1.4-7_all.deb
openoffice.org-l10n-gl_1.1.4-7_all.deb
  to pool/main/o/openoffice.org/openoffice.org-l10n-gl_1.1.4-7_all.deb
openoffice.org-l10n-he_1.1.4-7_all.deb
  to pool/main/o/openoffice.org/openoffice.org-l10n-he_1.1.4-7_all.deb
openoffice.org-l10n-hi_1.1.4-7_all.deb
  to pool/main/o/openoffice.org/openoffice.org-l10n-hi_1.1.4-7_all.deb
openoffice.org-l10n-hu_1.1.4-7_all.deb
  to pool/main/o/openoffice.org/openoffice.org-l10n-hu_1.1.4-7_all.deb
openoffice.org-l10n-it_1.1.4-7_all.deb
  to pool/main/o/openoffice.org/openoffice.org-l10n-it_1.1.4-7_all.deb
openoffice.org-l10n-ja_1.1.4-7_all.deb
  to pool/main/o/openoffice.org/openoffice.org-l10n-ja_1.1.4-7_all.deb
openoffice.org-l10n-kn_1.1.4-7_all.deb
  to pool/main/o/openoffice.org/openoffice.org-l10n-kn_1.1.4-7_all.deb
openoffice.org-l10n-ko_1.1.4-7_all.deb
  to pool/main/o/openoffice.org/openoffice.org-l10n-ko_1.1.4-7_all.deb
open...

Simos Xenitellis  (simosx) wrote :

(In reply to comment #33)
> (In reply to comment #31)
> > I got more feedback on the "solved" report and
> > it appears that it refers to another issue. Specificaly, it was refering
> > to OOo showing correctly Greek in the menus of "oowriter", "oocalc" and so on.
> > This issue was actually already fixed in Hoary (probably also ok in Warty), by
> > allowing
> > gtk+ to draw the menus (openoffice.org-gtk-gnome).
> >
> > However, this bug (#2374) has not been solved, thus I am reopening it.
>
> Looking at the patch, it looks like it's applied in both hoary and in breezy
> (only difference is that "el-GR" is used in the package, and "el" in the patch.
> I'm moving the Free* fonts to the first place in the font list. Please could you
> check, if that makes a difference?

I do not have Colony 3 at the moment and I am unable to check (sorry).

I have asked on a local forum for assistance and they tried with:
  Linux mini-ubu 2.6.12-7-powerpc #1 Fri Aug 19 14:48:03 UTC 2005 ppc GNU/Linux
  openoffice.org2-core 1.9.121-1ubuntu11. Sat Aug 20 12:17:17 BST 2005
  Default repos, default fonts.
  English Locale

The output was
http://img171.imageshack.us/img171/1117/untitled6nu1.png

which is expected. The fix most probably solves the issue when the document
language is Greek.
If it is English, or any other, the problem remains.

I am trying to get the submitted to change the document language to Greek and
test for the fix above.

Regarding the locale name, "el" or "el-GR", it would be more appropriate to have
"el" as these settings are common for both Greece and Cyprus.
There is a shift from el_GR to plain "el".

Simos Xenitellis  (simosx) wrote :

Contributor verifies that when the locale is el (or el_GR), the current fix in
Ubuntu Colony 3 solves the issue of this report.
The display looks like
http://img359.imageshack.us/img359/2252/untitled3vf.jpg
(first two lines are in "Nimbus Roman No9 L" which does not contain Greek and
there is substitution with an appropriate font.

The issue that remains is that of when the default language of the document is
other than Greek.
Is there a section in vcl.xcu where one can say that in any substitutions,
consider FreeFonts.,etc ?

Matthias Klose (doko) wrote :

(In reply to comment #35)
> Contributor verifies that when the locale is el (or el_GR), the current fix in
> Ubuntu Colony 3 solves the issue of this report.
> The display looks like
> http://img359.imageshack.us/img359/2252/untitled3vf.jpg
> (first two lines are in "Nimbus Roman No9 L" which does not contain Greek and
> there is substitution with an appropriate font.

ok.

> The issue that remains is that of when the default language of the document is
> other than Greek.
> Is there a section in vcl.xcu where one can say that in any substitutions,
> consider FreeFonts.,etc ?

I don't know ... OOo2 does have a fallback, so please could you check with that
version as well? 1.9.125+beta2-2ubuntu2 (not yet in the archive)

Giorgos Logiotatidis (seadog) wrote :

Hi,
 I tested the bug with 1.9.125+2.0beta2-1ubuntu1 and el_GR locale and the
problem still exists!

Matthias should we wait for 1.9.125+beta2-2ubuntu2 to recheck?

Matthias Klose (doko) wrote :

(In reply to comment #37)
> Hi,
> I tested the bug with 1.9.125+2.0beta2-1ubuntu1 and el_GR locale and the
> problem still exists!
>
> Matthias should we wait for 1.9.125+beta2-2ubuntu2 to recheck?

sorry, yes, 1.9.125+beta2-2ubuntu2 has the patched font config file.

Matthias Klose (doko) wrote :

closing the report, to me, it looks ok. please reopen, if necessary

Debian Bug Importer (debzilla) wrote :

Message-Id: <email address hidden>
Date: Tue, 01 Jun 2004 00:55:33 -0300
From: Konstantinos Margaritis <email address hidden>
To: Debian Bug Tracking System <email address hidden>
Subject: [INTL:el] Blank characters appear with Greek locale

Package: openoffice.org
Version: 1.1.1-3
Severity: normal
Tags: l10n

(I am assigning this bug as normal, because it renders the program
unusable in a localized environment).

When in el_GR.UTF-8 locale, and when openoffice.org-l10n-el is installed
(which is the case when a user selects 'Greek environment' in d-i), the
program menus and dialog fonts appear as blanks.
The solution (pointed by Chris Halls) is to include a font known to
support Greek locale in file:
/usr/lib/openoffice/share/registry/data/org/openoffice/VCL.xcu

adding FreeSans to the UI_Sans entry for English seemed to fix this.

Thanks

Konstantinos

-- System Information:
Debian Release: testing/unstable
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: i386 (i686)
Kernel: Linux 2.4.25
Locale: LANG=el_GR.UTF-8, LC_CTYPE=el_GR.UTF-8

Versions of packages openoffice.org depends on:
ii dictionaries-common [openoffi 0.22.24 Common utilities for spelling dict
ii openoffice.org-bin 1.1.1-3 OpenOffice.org office suite binary
ii openoffice.org-debian-files 1.1.1-2+3 Debian specific parts of OpenOffic
ii openoffice.org-l10n-el [openo 1.1.1-3 Greek language package for openoff
ii openoffice.org-l10n-en [openo 1.1.1-3 English (US) language package for

-- no debconf information

Debian Bug Importer (debzilla) wrote :

Message-Id: <email address hidden>
Date: Thu, 18 Aug 2005 21:11:12 +0300
From: Konstantinos Margaritis <email address hidden>
To: <email address hidden>,
 <email address hidden>
Subject: Update on the bug.

tags 252014 moreinfo
thanks

This discussion in the Ubuntu bugzilla, is related and
summarizes/explains some of the reasons why this bug exists.

https://bugzilla.ubuntu.com/show_bug.cgi?id=2374

Actually this bug is not apparent _if_ the openoffice.org-gtk-gnome
package is installed by default. KDE does not present this behaviour.
I'm going to put this particular package, in the greek-desktop task
list.

Konstantinos

Debian Bug Importer (debzilla) wrote :
Download full text (16.9 KiB)

Message-Id: <email address hidden>
Date: Wed, 24 Aug 2005 06:49:54 -0700
From: Rene Engelhard <email address hidden>
To: <email address hidden>
Subject: Bug#252014: fixed in openoffice.org 1.1.4-7

Source: openoffice.org
Source-Version: 1.1.4-7

We believe that the bug you reported is fixed in the latest version of
openoffice.org, which is due to be installed in the Debian FTP archive:

openoffice.org-bin_1.1.4-7_powerpc.deb
  to pool/main/o/openoffice.org/openoffice.org-bin_1.1.4-7_powerpc.deb
openoffice.org-dev_1.1.4-7_powerpc.deb
  to pool/main/o/openoffice.org/openoffice.org-dev_1.1.4-7_powerpc.deb
openoffice.org-evolution_1.1.4-7_powerpc.deb
  to pool/main/o/openoffice.org/openoffice.org-evolution_1.1.4-7_powerpc.deb
openoffice.org-gnomevfs_1.1.4-7_powerpc.deb
  to pool/main/o/openoffice.org/openoffice.org-gnomevfs_1.1.4-7_powerpc.deb
openoffice.org-gtk-gnome_1.1.4-7_powerpc.deb
  to pool/main/o/openoffice.org/openoffice.org-gtk-gnome_1.1.4-7_powerpc.deb
openoffice.org-l10n-af_1.1.4-7_all.deb
  to pool/main/o/openoffice.org/openoffice.org-l10n-af_1.1.4-7_all.deb
openoffice.org-l10n-ar_1.1.4-7_all.deb
  to pool/main/o/openoffice.org/openoffice.org-l10n-ar_1.1.4-7_all.deb
openoffice.org-l10n-ca_1.1.4-7_all.deb
  to pool/main/o/openoffice.org/openoffice.org-l10n-ca_1.1.4-7_all.deb
openoffice.org-l10n-cs_1.1.4-7_all.deb
  to pool/main/o/openoffice.org/openoffice.org-l10n-cs_1.1.4-7_all.deb
openoffice.org-l10n-cy_1.1.4-7_all.deb
  to pool/main/o/openoffice.org/openoffice.org-l10n-cy_1.1.4-7_all.deb
openoffice.org-l10n-da_1.1.4-7_all.deb
  to pool/main/o/openoffice.org/openoffice.org-l10n-da_1.1.4-7_all.deb
openoffice.org-l10n-de_1.1.4-7_all.deb
  to pool/main/o/openoffice.org/openoffice.org-l10n-de_1.1.4-7_all.deb
openoffice.org-l10n-el_1.1.4-7_all.deb
  to pool/main/o/openoffice.org/openoffice.org-l10n-el_1.1.4-7_all.deb
openoffice.org-l10n-en_1.1.4-7_all.deb
  to pool/main/o/openoffice.org/openoffice.org-l10n-en_1.1.4-7_all.deb
openoffice.org-l10n-es_1.1.4-7_all.deb
  to pool/main/o/openoffice.org/openoffice.org-l10n-es_1.1.4-7_all.deb
openoffice.org-l10n-et_1.1.4-7_all.deb
  to pool/main/o/openoffice.org/openoffice.org-l10n-et_1.1.4-7_all.deb
openoffice.org-l10n-eu_1.1.4-7_all.deb
  to pool/main/o/openoffice.org/openoffice.org-l10n-eu_1.1.4-7_all.deb
openoffice.org-l10n-fi_1.1.4-7_all.deb
  to pool/main/o/openoffice.org/openoffice.org-l10n-fi_1.1.4-7_all.deb
openoffice.org-l10n-fr_1.1.4-7_all.deb
  to pool/main/o/openoffice.org/openoffice.org-l10n-fr_1.1.4-7_all.deb
openoffice.org-l10n-gl_1.1.4-7_all.deb
  to pool/main/o/openoffice.org/openoffice.org-l10n-gl_1.1.4-7_all.deb
openoffice.org-l10n-he_1.1.4-7_all.deb
  to pool/main/o/openoffice.org/openoffice.org-l10n-he_1.1.4-7_all.deb
openoffice.org-l10n-hi_1.1.4-7_all.deb
  to pool/main/o/openoffice.org/openoffice.org-l10n-hi_1.1.4-7_all.deb
openoffice.org-l10n-hu_1.1.4-7_all.deb
  to pool/main/o/openoffice.org/openoffice.org-l10n-hu_1.1.4-7_all.deb
openoffice.org-l10n-it_1.1.4-7_all.deb
  to pool/main/o/openoffice.org/openoffice.org-l10n-it_1.1.4-7_all.deb
openoffice.org-l10n-ja_1.1.4-7_all.deb
  to pool/main/o/openoffice.org/openoffice.org-l10n-ja_1.1.4-7_all.deb
openoffice....

Debian Bug Importer (debzilla) wrote :

Message-Id: <20050828211455.17D25C2CE9@localhost>
Date: Sun, 28 Aug 2005 23:14:55 +0200 (CEST)
From: <email address hidden> (Rene Engelhard)
To: <email address hidden>
Subject: severity of 302875 is normal, closing 302875, merging 302875 252014

severity 302875 normal
close 302875
merge 302875 252014

Giorgos Logiotatidis (seadog) wrote :

hi, I'm testing dapper and the problem still exists. Have you installed the patches above?

Simos Xenitellis  (simosx) wrote :

There have been some reports that OOo 2.0.2 selects the appropriate fonts in Dapper. Can someone confirm this?

Konstantinos Togias (ktogias) wrote :

I can confirm that in dapper with openoffice.org 2.0.2-1ubuntu2 the appropriate font is selected for greek characters. The following attachments are screenshots of various doc, xls and ppt documents that I collected from my inbox and contain greek text in fonts as Arial, Arial Greek, Verdana, Times new roman, Tahoma. The screenshot have been taken from a clean and updated dapper drake filgt 5 installation. No msttcorefonts or other fonts where manually installed.

The screenshot is form openoffice.org 2.0.2-1ubuntu2 writer

Simos Xenitellis  (simosx) wrote :

Closing the Debian leg of this bug as well.
It would be good to find the exact change in OOo that fixes the issue (or just verify that another build of OOo 2.0.2 works fine on Linux), so that we can safely close http://qa.openoffice.org/issues/show_bug.cgi?id=57426

Many thanks Kostas for your work!

Changed in openoffice.org:
assignee: nobody → simosx
status: Unconfirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.