notify-osd images appear at the middle right of screen

Bug #419894 reported by Richard Cavell on 2009-08-27
326
This bug affects 61 people
Affects Status Importance Assigned to Milestone
notify-osd (Ubuntu)
Medium
Mirco Müller

Bug Description

Binary package hint: notify-osd

64-bit Karmic alpha 4 with all updates applied to 27 August.

After recent updates, notify-osd now places notifications toward the middle of the right hand side of my screen. It is entirely reproducible on my machine.

Screenshot attached.

Richard

Richard Cavell (richardcavell) wrote :
Michalxo (michalxo) wrote :

Same problem here. On amd64 version of Karmic Alpha 4
ii libevent-1.4-2 1.4.11-stable-1 An asynchronous event notification library
ii libnotify1 0.4.5-1ubuntu1 sends desktop notifications to a notificatio
ii libstartup-notification0 0.10-1 library for program launch feedback (shared
ii libzephyr4 3.0~beta.2483-2 Project Athena's notification service - non-
ii notify-osd 0.9.18-0ubuntu1 daemon that displays passive pop-up notifica
ii python-notify 0.1.1-2build2 Python bindings for libnotify
ii python-pyinotify 0.8.6-2ubuntu2 simple Linux inotify Python bindings
ii update-notifier 0.87 Daemon which notifies about package updates
ii update-notifier-common 0.87 Files shared between update-notifier and ade

Mirco Müller (macslow) wrote :

That's a feature and not a bug as is. Please see https://wiki.ubuntu.com/NotifyOSD#Outside%20the%20bubble

Changed in notify-osd (Ubuntu):
status: New → Invalid
assignee: nobody → Mirco Müller (macslow)
Nate Wiebe (natew) wrote :

If it is a feature, is there a way to change it so it shows up where it used to and not in the middle of the screen?

Michalxo (michalxo) wrote :

+1 Got beaten by 13 secs :)

Yotam Benshalom (benshalom) wrote :

This feature is intrusive. It means that notification windows will block me from reading a web page or writing a document. When they appear on the top left corner, they hide some window-control buttons; when they appear in the middle of the screen they pop right on top of my main work area.
I have not seen any reasoning for changing the traditional behavior in the wiki page. Whatever this reasoning may be, I join the plea: please let us configure the notifications location. It is very inconvenient in its current form.

Michalxo (michalxo) wrote :

And very distracting too. Dunno how can someone use it... Please, fix it. Thank you :)

bear24rw (bear24rw) wrote :

I also find it annoying, it should be configurable as to where it displays..

Michalxo (michalxo) wrote :

It drives me VERY CRAZY. Where can I change that "update" to previous state? I loved when it popped up in top right corner as it does and now this. Or maybe the better solution will be to remove it?

Yes very very annoying.

Raul Silva (raulpsilva) wrote :

It is very intrusive, I know it is suppose to be a notification, but I think the upper right (or left) is the best place to show the notifications.

I believe that in a few months I would be confortable and used to thus new positioning, but till then...

As I don't know the rationale for this change, if it is good I would accept it and get used to it, but otherwise, please, at least leave some room so that it can be a configurable setting (as the current documentation does leave any room for it).

Thanks for the great work (except for the positioning thing, of course :)

Raul

Michalxo (michalxo) wrote :

Managed to repair the sourcecode and compile it to original top-right

Here's a short tutorial for newbies like me:
sudo apt-get source notify-osd
sudo dpkg-source -x notify-osd_0.9.19-0ubuntu1.dsc
edit file notify-osd_xx/src/bubble.c -> Look for PLACEMENT_NEW and change to PLACEMENT_OLD
sudo apt-get build-dep notify-osd
fakeroot debian/rules binary
cd .. && dpkg -i notify-osd_your_version

I hope I did not make any mistake..
This solved this freaking "feature" and I am satisfied again.

Angel Guzman Maeso (shakaran) wrote :

Mirco, could you please add a panel configuration with the position of the bubble? It would be very useful to the usability of users.

Jack Leigh (leighman) wrote :

Really unnatural and ugly.
Should be configurable at the very least.

Nicolò Chieffo (yelo3) wrote :

I'm definitely not used to add "mee too" comments to bugs, but trust me, in this case I must add it. Really.

ignasi (igp-oenus) wrote :

It is very annoying having the notifications in this new position. I'd vote to put it back where it was (which is close to the task bar), or at least give the user an option to choose where it wants it.

Mirco Müller (macslow) wrote :

The best place to discuss such things, like UI-design, is the Ayatana mailing-list. Please provide your feedback there https://lists.launchpad.net/ayatana/threads.html, thanks in advance!

Mirco Müller wrote:
> The best place to discuss such things, like UI-design, is the Ayatana
> mailing-list. Please provide your feedback there
> https://lists.launchpad.net/ayatana/threads.html, thanks in advance!
>
>
Also #ayatana on freenode irc.

M.

manzur (sl-solaris) wrote :

OHHH my god, what is happening to caninical, what do u with hands, you destroy it using your feet

manzur (sl-solaris) wrote :

I agree with Michalxo, my GOD remove that notify-osd or put it the place it was before, i like ubuntu but u are taking really BAD desition.....

i'm on of those guys that try to line up with new stuff, but I cant on this one.
Please revert it ASAP
thanks

Dean Loros (autocrosser) wrote :

This is ONE OF THE WORST places to have a notification!!! PLEASE at least make it configurable so I can get it out of the middle of my Gkrellm display & it shows for far too long--a time limit would be a must....Please---at least a gconf key for those two......

Nate Wiebe (natew) wrote :

alright.. so for everyone who wants notifications in the top right and not in the middle, here they are:
http://www.wiebeswheels.com/notify-osd_0.9.19-0ubuntu1_i386.deb for 32bit
http://www.wiebeswheels.com/notify-osd_0.9.19-0ubuntu1_amd64.deb for 64bit

manzur (sl-solaris) wrote :

butman that is not the solution, i mean who can imagine this will work in the middle of a screen, it is terrible, i mena the solution would be to open a brainstorm idea with two option, one in the top right corner and the oter in the middle of the screen and i am sure everyone will like to leave it in the top right corer, dont u?

Guy Van Sanden (gvs) wrote :

This is a really bad choice. I have notification bubbles in empathy for people that go online/offline and it's just plain annoying to use the computer like this.

Iain Lane (laney) wrote :

I don't like commenting on these bugs usually, but this seems to be a bad choice. I am finding the notifications to be much more distracting and actually get in the way now. Please consider reverting it.

Richard Cavell (richardcavell) wrote :

I submitted the original bug. The notify-osd package has now been fixed to return to the previous behaviour. So let's stop discussing it and move on to something else.

I find it interesting that although this bug has been correctly declared 'invalid', it could also now be described as 'fix released'.

Richard

tekstr1der (tekstr1der) wrote :

> The notify-osd package has now been fixed to return to the previous behaviour.

Where do you see this? Please don't tell me you are referring to the repacked .debs linked above for download?

I am not seeing a fix released in source: https://launchpad.net/ubuntu/+source/notify-osd

Nor any mention of a fix on the mailing list: https://lists.launchpad.net/ayatana/maillist.html#00576

manzur (sl-solaris) wrote :

Richard Cavell, yeah, with all due respect, what are u talking about?

Changed in notify-osd (Ubuntu):
status: Invalid → Confirmed
Richard Cavell (richardcavell) wrote :

Okay, my bad.

I have uninstalled Karmic in frustration at these types of things. A guy on IRC confirmed that a fix had been released in the repos. I have not seen any fix myself. I retract my statement.

Richard

Moisa Doru (moisadoru) wrote :

+1 for configurable position of the bubble, or at least put it back to the top-right corner.
Thanks

manzur (sl-solaris) wrote :

i do not want event o use karmic too, i thinks canonical is taking really bad decision

fondle-em (mcribbb) wrote :

It's totally user unfriendly to make notify-osd non-configurable. I'd call it "user hostile". It was tolerable (though distasteful as a matter of principle) when the unchangeable location of the bubbles was where I wanted them. Locked permanently to the middle of the screen on the right side with no recourse for users who don't want them there? Please don't do this.

burli (mb-embedit) wrote :

NotifyOSD in the center right position is like The Annoying Thing
http://www.youtube.com/watch?v=oNnRGtVkr6E

Annoying

PLEASE bring it back to top right or make it configurable. PLEASE

Scholli (schollidesign) wrote :

Don't like this idea. It's not so cool as before and it's in a freak position - nearly so freak as put it in the centre of the screen. I wish a *redo*, because it isn't a feature, it's a ugly BUG.

Dominik George (natureshadow) wrote :

Please either make this configurable or revert the change so notifications appear in the upper right corner of the screen, where they belong.

parda (parda-dapar) wrote :

Pleasee..

Marc Gariépy (mgariepy) wrote :

I would like it to be in the top right corner like it was too.

Oded Arbel (oded-geek) wrote :

1. Me not: While I found the new position troubling, I'd like to see if it works better for me. Of course having this configurable would be the best.
2. The Ayatana mailing list is open only for members - I personally would not want to bother asking for membership based only on this small issue I'm interested in. In the archive I've seen there are some interesting discussions going on right now both on how to have a better (and less intrusive) notification and on configuration of the notifications.

manzur (sl-solaris) wrote :

hello everyone, i have posted it at brainstorm, please promote it: http://brainstorm.ubuntu.com/idea/19526/

Stefan (sbossb) wrote :

+1 for the right hand conner. At least make it configurable with right hand conner being the default.

Kerin (cernunnos) wrote :

Add another for topright (although configurable would be roughly a thousand times better,) and another who isn't willing to join another site to complain. Have downloaded the source and corrected this miserable "feature," thank you very much. Kindly spend less time working to make our assorted escapes from the confines of proprietary software irrelevant.

tl;dr: This is why I left Windows. Let us configure positioning.

Mirco Müller (macslow) wrote :

Support for the gconf-key /apps/notify-osd/gravity is on it's way.

Changed in notify-osd (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → Medium
Mirco Müller (macslow) on 2009-09-01
Changed in notify-osd (Ubuntu):
status: In Progress → Fix Committed
Sebastien Bacher (seb128) wrote :

the new version has been uploaded

Changed in notify-osd (Ubuntu):
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
Sebastien Bacher (seb128) wrote :

the new version is in karmic now

Changed in notify-osd (Ubuntu):
status: Fix Committed → Fix Released
DavidW617 (davidw617) wrote :

My notifications are still showing up at the wrong place. Should I create a new bug report then? I am using a fully updated Karmic.

 Hi, mate. I think so. Notifications were placed back at the top right ages ago.

Richard

-----Original Message-----
From: Again617 <email address hidden>
To: <email address hidden>
Sent: Thu, Oct 22, 2009 2:22 pm
Subject: [Bug 419894] Re: notify-osd images appear at the middle right of screen

My notifications are still showing up at the wrong place. Should I
create a new bug report then? I am using a fully updated Karmic.

--
notify-osd images appear at the middle right of screen
https://bugs.launchpad.net/bugs/419894
You received this bug notification because you are a direct subscriber
of the bug.

Status in “notify-osd” package in Ubuntu: Fix Released

Bug description:
Binary package hint: notify-osd

64-bit Karmic alpha 4 with all updates applied to 27 August.

After recent updates, notify-osd now places notifications toward the middle of
the right hand side of my screen. It is entirely reproducible on my machine.

Screenshot attached.

Richard

Darth Trix (atristezza) wrote :

Mine too

Damir Butmir (d4m1r2) wrote :

This is still an issue in 32 bit 11.10 Ubuntu:

http://i.imgur.com/Ov6kj.png

^Sometimes at boot it shows at the top like its supposed to, other times it is in the middle...Any ideas on how to fix this?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers