[intrepid] new 0.7 branch ignores /etc/network/interfaces

Bug #256054 reported by Chad Waters on 2008-08-08
238
This bug affects 12 people
Affects Status Importance Assigned to Milestone
NetworkManager
Fix Released
Medium
network-manager (Ubuntu)
High
Unassigned
Intrepid
High
Unassigned

Bug Description

NOTE: Instead of adding more information here, please open a new bug for your particular issue and mention that you think that this bugs is related. Thanks!

The NetworkManager 0.7 preview shipped in the ubuntu 8.10 beta release does
not yet have a feature to "unmanage" devices configured in /etc/network/interfaces.

Affected:
Users that have their network devices configured in /etc/network/interfaces are affected.

Workarounds:

1. If you don't rely on your network connnection being constantly up during
boot you can test the "ifupdown" system setting plugin, by adjusting a
configuration file followed by a system restart.

/etc/NetworkManager/nm-system-settings.conf:
  [main]
  plugins=keyfile,ifupdown

2. If you rely on your network connection being constantly up during boot, you
have to disable NetworkManager for the time being:

  sudo update-rc.d NetworkManager remove

========== Original Report:
nm 0.7 branch is ignoring /etc/network/interfaces

Its ignoring my static IP settings and defaulting to dhcp. I can bypass nm with the /etc/init.d/networking script.

See also: http://ubuntuforums.org/showthread.php?t=882842

========== Original Report:
nm 0.7 branch is ignoring /etc/network/interfaces

Its ignoring my static IP settings and defaulting to dhcp. I can bypass nm with the /etc/init.d/networking script.

See also: http://ubuntuforums.org/showthread.php?t=882842

Alexander Sack (asac) wrote :

this is known.

Depending on how stable the ifupdown/eni system setting plugin becomes we will either:

 1. make the ifupdown/eni system config plugin blacklist interfaces configured there
 2. conflict with ifupdown and instead support old configurations as good as possible through the ifupdown/eni system settings plugin.

Soft-Milestoning for alpha 6 too keep this on radar.

Changed in network-manager:
assignee: nobody → asac
importance: Undecided → High
milestone: none → intrepid-alpha-6
status: New → Triaged
Alexander Sack (asac) wrote :

i linked the branch where i develop the eni/ifupdown system config plugin to this bug.

Chad Waters (chad) wrote :

Pardon me if I misinterpreted your comment:

I hope that cli/conf files won't be abandoned. The 2 should be able to coexist and honor each others settings.

Regardless of preference: cli utils are needed in lack of X for numerous occasions including... remote ssh, no X (ubuntu-server installs), broken X (happens a lot while testing development branches).

Changed in network-manager:
status: Unknown → New
Changed in network-manager:
status: New → Invalid
Changed in network-manager:
status: Invalid → Confirmed
Alexander Sack (asac) wrote :

system-settings will work even without X running. so thats not an argument. not sure what you want to do with remote ssh.

Alexander Sack (asac) wrote :

moving to beta. to keep this off from release team radar for alpha-6

Changed in network-manager:
milestone: intrepid-alpha-6 → ubuntu-8.10-beta

Same problem here. However I have to rmmod ndiswrapper, modprobe ndiswrapper and /etc/init.d/networking restart for the Wifi to work. Just doing the network restart doesn't solve the problem.

Running:
jose@amd64:~/network-manager-bug$ dpkg -l | grep network-manager
ii network-manager 0.7~~svn20080908t183521+eni0-0ubuntu2 network management framework daemon
ii network-manager-kde 1:0.7svn830754-0ubuntu3 KDE systray applet for controlling NetworkMa

However after doing the rmmod ndiswrapper, modprobe ndiswrapper and /etc/init.d/networking restart trick, I get the following output:
jose@amd64:~/network-manager-bug$ sudo /etc/init.d/networking restart
 * Reconfiguring network interfaces...RTNETLINK answers: No such process
There is already a pid file /var/run/dhclient.wlan0.pid with pid 4860
killed old client process, removed PID file
Internet Systems Consortium DHCP Client V3.1.1
Copyright 2004-2008 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/wlan0/00:80:5a:39:8f:36
Sending on LPF/wlan0/00:80:5a:39:8f:36
Sending on Socket/fallback
DHCPRELEASE on wlan0 to 192.168.1.1 port 67
send_packet: Network is unreachable
send_packet: please consult README file regarding broadcast address.
Internet Systems Consortium DHCP Client V3.1.1
Copyright 2004-2008 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/wlan0/00:80:5a:39:8f:36
Sending on LPF/wlan0/00:80:5a:39:8f:36
Sending on Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8
DHCPOFFER of 192.168.1.101 from 192.168.1.1
DHCPREQUEST of 192.168.1.101 on wlan0 to 255.255.255.255 port 67
DHCPACK of 192.168.1.101 from 192.168.1.1
bound to 192.168.1.101 -- renewal in 34337 seconds.
grep: /etc/network/run/ifstate: No such file or directory
[: 164: 0: unexpected operator
grep: /etc/network/run/ifstate: No such file or directory
[: 164: 0: unexpected operator

Even despite theses errors, after this, network works OK

Mirar (launchpad-sort) wrote :

Confirmed. I had a machine go "offline" saturday because it went dhcp-hunting instead of using the static IP (upgraded on friday). Highly annoying since I was 300km away at that time and really didn't expect that behaviour, so I couldn't find it... :p
(Yes, I've done the Right Thing now and added it's MAC to the static DHCP-given IP numbers, but...)

Martin Jackson (mhjacks) wrote :

I confirm this issue on a dist-upgrade from Hardy to Intrepid today.

I would appreciate if Ubuntu keeps a straightforward mechanism to edit config file(s) (preferably /etc/network/interfaces, as it's extremely well-understood and functional) and have network-manager honor them by ignoring the interfaces configured there. This has been possible at least since gutsy (when I seriously started using Ubuntu).

I'm a network engineer and sometimes finding myself configuring odd things like vlan and bridging on my laptop's wired interface - there's no way to do that in nm at the moment nor should there be, necessarily. At the same time, having the wireless interface doing its thing via network-manager is also useful, e.g. for scp'ing wireshark traces.

Thanks for listening.

Charlie Kravetz (charlie-tca) wrote :

I'm willing to add confirmed here, too. I filed another report on this, and the answer appears to be to unstall Network Manager. After doing that, I can get online with my static IP address. It's working so far.

This after using static IP since Ubuntu 5.10.

I removed all four files after searching in Synaptic Package Manager for Network Manager. That seems to allow you to use /etc/network/interfaces again.

On Tue, Sep 23, 2008 at 12:14:02AM -0000, Charlie Kravetz wrote:
> I'm willing to add confirmed here, too. I filed another report on this,
> and the answer appears to be to unstall Network Manager. After doing
> that, I can get online with my static IP address. It's working so far.
>
> This after using static IP since Ubuntu 5.10.
>
> I removed all four files after searching in Synaptic Package Manager for
> Network Manager. That seems to allow you to use /etc/network/interfaces
> again.
>

You could try the experiemental ifupdown plugin. just append ,ifupdown
to the plugins= line in /etc/NetworkManager/nm-system-settings.conf
and restart your system.

This should NM honour not-too-fancy /etc/network/interfaces
configurations.

 - Alexander

Charlie Kravetz (charlie-tca) wrote :

Thank you, Alexander

I did a new installation of Xubuntu Intrepid 8.10 using the desktop CD. Even though Network Manager still won't allow me to make any changes, after following your suggestion and making the changes manually to /etc/network/interfaces, I was able to connect. I am using static IP addresses, and could leave Network Manager installed.

Marcus Granado (mrc-gran) wrote :

Hi, Alexander,
appending ,ifupdown to the plugins= line in /etc/NetworkManager/nm-system-settings.conf works for me, making NM honor again my /etc/network/interfaces file. NM, however, still erases my resolv.conf after every boot, as per bug #259539.

Kees Cook (kees) wrote :

Will the ifupdown plugin get added to the list by default before Intrepid releases?

wiz (wiz) wrote :

Or there should be a button in NM interface to turn it on/off.

Roland Dreier (roland.dreier) wrote :

I have a system connected to a wired network that requires a static IP and 802.1x authentication, and I have an /etc/network/interfaces stanza like

auto eth1
iface eth1 inet static
    address 10.33.42.9
    netmask 255.255.255.0
    gateway 10.33.42.1
    wpa-driver wired
    wpa-ap-scan 0
    wpa-key-mgmt IEEE8021X
    wpa-identity XXXXXX
    wpa-password YYYYYY

even with the ifupdown plugin added to nm-system-settings.conf that interface is not configured properly on boot if NM is enabled (up-to-date Intrepid as of today). So I am just doing

update-rc.d -f NetworkManager remove

every time an upgrade reenables NM.

quink (quinks) wrote :

This bug may be a duplicate of bug #5364.

description: updated
Alexander Sack (asac) wrote :

Roland, thats an interesting configuration. have you tried to configure the same in NM connnection editor as a system connection? for that create a new wired connection and configure in the 802.1x security tab. Remember to comment the complete stanza so ifupdown doesnt interfere.

Jeremy Bar (j.b) wrote :

I am hitting the same issue, I use bridging with VirtualBox, I can't have NetworkManager manage any interfaces listed in /etc/network/interfaces. NetworkManager's old behavior was perfect. (I don't have VirtualBox running yet because networking is all confused on my test box ...)

Alexander Sack (asac) wrote :

Jeremy, plesae post your interfaces file. Thanks!

Changed in network-manager:
milestone: ubuntu-8.10-beta → ubuntu-8.10
Alexander Sack (asac) on 2008-09-30
description: updated
Jeremy Bar (j.b) wrote :

I list eth0 & 1 as "inet manual" so that NetworkManager doesn't touch them. It works very well with Hardy.

________________ /etc/network/interfaces ______________
auto lo
iface lo inet loopback

# auto eth0
# iface eth0 inet static
# address 172.19.0.4
# netmask 255.255.0.0
# gateway 172.19.0.7

auto eth0
iface eth0 inet manual

auto eth1
iface eth1 inet manual

auto br0
iface br0 inet static
        bridge_ports eth1
        address 172.19.0.4
        netmask 255.255.0.0
        gateway 172.19.0.7

# auto wlan0
iface wlan0 inet dhcp
        wireless-essid MyWifi
____________________________________________________

Brian Curtis (bcurtiswx) wrote :

I can't get my internet working, i've tried the suggestion above to no help.
all i have is a loopback interface.

Alexander Sack (asac) wrote :

On Fri, Sep 26, 2008 at 04:44:11PM -0000, Kees Cook wrote:
> Will the ifupdown plugin get added to the list by default before
> Intrepid releases?
>

Yes. I am making this Release-Fit right now. Hope to get this upstream
and into our archive by monday.

 - Alexander

Alexander Sack (asac) wrote :

On Sat, Sep 27, 2008 at 12:16:04AM -0000, Roland Dreier wrote:
> I have a system connected to a wired network that requires a static IP
> and 802.1x authentication, and I have an /etc/network/interfaces stanza
> like
>
> auto eth1
> iface eth1 inet static
> address 10.33.42.9
> netmask 255.255.255.0
> gateway 10.33.42.1
> wpa-driver wired
> wpa-ap-scan 0
> wpa-key-mgmt IEEE8021X
> wpa-identity XXXXXX
> wpa-password YYYYYY
>
> even with the ifupdown plugin added to nm-system-settings.conf that
> interface is not configured properly on boot if NM is enabled (up-to-
> date Intrepid as of today). So I am just doing

Thats protected wired. I will try to get that going too in the final
version.

 - Alexander

Alexander Sack (asac) wrote :

Ok. A quick heads up on what is planned. Please comment in case you think it won't fit your need.

We will introduce a new config for /etc/NetworkManager/nm-system-settings.conf that reads like:

[ifupdown]
managed=true/false

The default will be "false" for intrepid and depending on how well it works and how well the ifupdown plugin evolves over time we might make this "true" for jaunty.

So what does this mean:

1. in unmanaged mode (managed=false), ifupdown plugin will tell networkmanager to not touch devices whose hal interface.name is configured in /etc/network/interfaces; unmanaged mode doesnt require any changes to the debian ifupdown package itself. Configurations for interfaces in /etc/network/interfaces that have no matching device will still be made available in networkmanager. However, since they are not locked to any device it wont hurt.

2. in managed mode (managed=true), ifupdown plugin will tell networkmanager to "lock" the parsed configuration to devices by mac address. The device the connection configuration gets locked to will be determined by the interface.name. So configurations like:

  iface eth0 inet static ...

will make networkmanager to always use that configuration for the device whose hal info has the interface.name "eth0".

3. in managed mode, we make ifup -a to not auto up the interfaces configured in /etc/network/interfaces. To make this happen we will add an iniparser to the ifupdown package that will teach ifupdown to honour /etc/NetworkManager/nm-system-settings.conf appropriately.

Alexander Sack (asac) wrote :
Changed in network-manager:
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager - 0.7~~svn20081004t225044-0ubuntu1

---------------
network-manager (0.7~~svn20081004t225044-0ubuntu1) intrepid; urgency=low

  new upstream snapshot: Sat 2008-10-04 22:50:44 (bzrrev 3602) from
  lp:~vcs-imports/network-manager/main branch

  * merging final revision of main.eni branch which brings
    us back to parity with upstream branch. features temporarily lost from
    "upstream" code base due to this
    + graceful defaults for ifupdown ip4settings
    + wep-tx-keyidx support
    + pre-run intltoolize
  * we run intltoolize -f -c in pre-build:: target
    - update debian/rules
  * drop lp276253_fix_system_hostname.patch; upstream behaviour became more
    graceful and we will add ifupdown plugin support to read/write
    /etc/hostname
    - delete debian/patches/lp276253_fix_system_hostname.patch
    - update debian/patches/series
  * enable ifupdown system-config-interface implementation by default
    (LP: #256054)
    - update debian/nm-system-settings.conf
  * rewrite README.Debian; we document "managed" vs. "unmanaged" mode as well
    as "dial up configurations"
    - update debian/README.Debian
  * reflect the implicit default mode (unmanaged) in default
    nm-system-settings.conf shipped by ubuntu package in intrepid
    - update debian/nm-system-settings.conf
  * (disabled) add code that enforces -Os instead of -O2
    - update debian/rules

  Cherry-Picking upstream submitted patches:
  * debian/patches/000-FIXCRASH-in-add_default_dhcp_connection.loom.patch:
    - fix crash of nm-system-settings when replugging devices that get a
      default connection created (wired)
  * debian/patches/001-IFUPDOWN-wep-tx-keyidx.loom.patch:
    - add support for wep-tx-keyidx wpa setting to ifupdown plugin
  * debian/patches/002-IFUPDOWN-hostname.loom.patch:
    - implement read/write support for /etc/hostname in ifupdown system config
  * debian/patches/003-IFUPDOWN-remove-unused-callbacks.loom.patch:
    - remove some unused callbacks (cleanup)
  * debian/patches/004-IFUPDOWN-devtracking.loom.patch:
    - add device tracking infrastructure - prepare managed/unmanaged mode
  * debian/patches/005-IFUPDOWN-unmanaged-mode.loom.patch:
    - implement global unmanaged mode (LP: #256054)
  * debian/patches/006-IFUPDOWN-parse-system-settings.loom.patch:
    - implement system-settings boolean key ifupdown:managed - default: false
      (LP: #256054)
  * debian/patches/007-IFUPDOWN-managed-mode.loom.patch:
    - implement managed-mode: update mac address of nm-wired/wirless-settings
      (LP: #256054)
  * debian/patches/008-BACKEND-debian-fallback-to-generic-loopback.loom.patch:
    - use ifconfig (instead of ifup) to bring up loopback. If ifconfig is not
      available we fallback to the generic (libnl based) implementation
      shipped by NetworkManager

 -- Alexander Sack <email address hidden> Mon, 06 Oct 2008 13:40:08 +0200

Changed in network-manager:
status: Fix Committed → Fix Released
cman (diegoocampo8) wrote :

I've just upgrade to network manager 0.7~~svn20081004t225044-0ubuntu1 version, and still not working here.
I am not an expert so maybe i am missing something!... i looked into my /etc/modprobe.d/blacklist file and i am sure e1000e is not there..
And i configure my network card with static IP but when i open the file /etc/network/interfaces i can not see the anything related with the eth0 interface (this is the interface of my wired network!) is it normal???
Also i have a small doubt: what is this DNS search? i have never had to put anything like that, i am use to introduce primary DNS and secundary DNS...

Thanks in advance.

On Mon, Oct 06, 2008 at 07:30:05PM -0000, cman wrote:
> I've just upgrade to network manager 0.7~~svn20081004t225044-0ubuntu1 version, and still not working here.
> I am not an expert so maybe i am missing something!... i looked into my /etc/modprobe.d/blacklist file and i am sure e1000e is not there..
> And i configure my network card with static IP but when i open the file /etc/network/interfaces i can not see the anything related with the eth0 interface (this is the interface of my wired network!) is it normal???
> Also i have a small doubt: what is this DNS search? i have never had to put anything like that, i am use to introduce primary DNS and secundary DNS...
>
> Thanks in advance.
>

I have just upgraded to the latest network-manager, and I had to
manually delete ifupdown plugin from the list, because it was not
working (there were no DNS servers specified, and I couldn't edit this
connection by hand because it is "read-only").

--
Regards, Gregory.

Alexander Sack (asac) wrote :

Hi,

Anyway, the current default configuration shipped is:

/etc/NetworkManager/nm-system-settings.conf:
  [main]
  plugins=ifupdown,keyfile

  [ifupdown]
  managed=false

Please ensure that your file looks similar to that and that you have everything restarted (e.g. reboot).

If your /etc/network-manager/interfaces does not confiugre your eth0 or any other device (except lo), then this is not your bug. You are most likely file a separate bug against the "linux" package, stating that your device isnt seen by NetworkManager.

If you have other issues that you think are related to this bug, please file new bugs and post your bug number here.

Thanks!

Changed in network-manager:
status: Confirmed → Fix Released
Ivan Nemet (inemet) wrote :

Hi,
When I change in /etc/NetworkManager/nm-system-settings.conf:
from
[ifupdown]
 managed=false
to
ifupdown]
 managed=true

NM, after reboot show:
eth0 interface (this is O.K. - I have static config), and
ifupdown (eth0) interface ??? (not active, I can't delete this interface)

Malac (malacusp) wrote :

Perhaps I'm missing the point here but it seems you have altered the network manager applet to NOT manage the networks??????
I have a static network here and this broke it totally.
As of today NetworkManager is unusable for me using any of the suggestions here.

Perhaps this helps for some thing but I can't for the life of me see what situation these changes was supposed to address.
I'm no networking expert though so that is not surprising :).

Alexander Sack (asac) wrote :

Malac, please open a bug and give detailed information about your setup. Attach your /etc/network/interfaces and your complete /var/log/syslog to that bug.

Alexander Sack (asac) wrote :

Ivan, ifupdown (eth0) is the configuration your have in /etc/network/interfaces. by turning on managed=true you opted-in to get that system connection presented. If you dont want it to appear at all, you can remove it from /etc/network/interfaces .. or just use it as it should contain the static config you previously had in /etc/network/interfaces.

Claudio Satriano (claudiodsf) wrote :

Since I'm upgrading from Hardy, it's not clear to me what is the currently default for
/etc/network/interfaces

Ivan Nemet (inemet) wrote :

Hi Alexander,
Sorry for my english
I use Ubuntu 8.04 and this source for update NM:
           deb http://ppa.launchpad.net/network-manager/ubuntu hardy main
           deb-src http://ppa.launchpad.net/network-manager/ubuntu hardy main
After todate update NM my network connection is broken. and my NM show ifupdown (eth0) interface, without MAC address, with correct IP settings and no DNS inputs.
Then I go to Sistem->Administration->Network and load my previously saved location, and I have working network agan but NM not show eth0 interface.
When I change nm-system-settings.conf and reboot NM show two interfaces (eth0, and ifupdown (eth0)).
My /etc/network/interfaces is very simple(no ifupdown (eth0) ):
____/etc/network/interfaces __________________________________
  auto lo
  iface lo inet loopback
  auto eth0
  iface eth0 inet static
  address 10.128.65.136
  netmask 255.255.255.0
  gateway 10.128.65.2

  iface ppp0 inet ppp
  provider ppp0
  auto ppp0

____________________________________________________________

And part of my ~.gnome2/network-admin-locations/MyNetwork:

____________~.gnome2/network-admin-locations/MyNetwork___________________
...
[eth0]
  auto=true
  active=true
  configured=true
  ip-address=10.128.65.136
  ip-mask=255.255.255.0
  gateway-address=10.128.65.2
  network-address=
  broadcast-address=
  config-method=static
...
____________________________________________________________

Alexander Sack (asac) wrote :

On Tue, Oct 07, 2008 at 10:20:03AM -0000, Ivan Nemet wrote:
> Hi Alexander,
> Sorry for my english
> I use Ubuntu 8.04 and this source for update NM:
> deb http://ppa.launchpad.net/network-manager/ubuntu hardy main
> deb-src http://ppa.launchpad.net/network-manager/ubuntu hardy main
> After todate update NM my network connection is broken. and my NM
> show ifupdown (eth0) interface, without MAC address, with correct IP
> settings and no DNS inputs.

dns is gathered from dns-nameservers entry in interfaces for now, like:

  dns-nameservers 192.168.1.1

 - Alexander

Rick Allard (rick-allard) wrote :

I made some changes a few weeks ago to get my (now) Ubuntu 8.04.1 (/etc/issue) going with a WPA access point. (That was a horrid struggle.) I've been through some automatic updates since then including one this morning after which Firefox seemed to stick with Work Offline checked (even in a brand new user account).

Things are pretty hosed.

I've found a work-around in Firefox so that I don't have to explicitly turn off Work Offline (set toolkit.networkmanager.disable to true), and I can do that manually in Liferea. But Pidgin has no obvious setting.

If anyone needs further detail, do ask.

Sokraates (sokraates) wrote :

Same problem here (Kubuntu Intrepid), though I found a different solution: I commented out the "iface XXX inet dhcp"-lines and now NM works like a charm again.

Here's my /etc/network/interfaces, just to make it clear, what I mean:

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
#iface eth0 inet dhcp

# The wireless network interface
auto wlan0
#iface wlan0 inet dhcp

Vladimir Hidalgo (vlad88sv) wrote :

Thank you Rick Allard for comment #38, Firefox was driving me crazy with goin offline each time.

Alexander Sack (asac) wrote :

On Tue, Oct 07, 2008 at 09:40:56PM -0000, Rick Allard wrote:
> I made some changes a few weeks ago to get my (now) Ubuntu 8.04.1
> (/etc/issue) going with a WPA access point. (That was a horrid
> struggle.) I've been through some automatic updates since then including
> one this morning after which Firefox seemed to stick with Work Offline
> checked (even in a brand new user account).

If you are configuring your network in /etc/network/interfaces and
have managed=false in /etc/NetworkManager/nm-system-settings.conf then
you will experience that behaviour. We will fix that for final.

>
> Things are pretty hosed.

At best try to disable your configurations in /etc/network/interfaces
and see if things work better in intrepid for you.

>
> I've found a work-around in Firefox so that I don't have to explicitly
> turn off Work Offline (set toolkit.networkmanager.disable to true), and
> I can do that manually in Liferea. But Pidgin has no obvious setting.
>

Yes, that option exists. We will fix the issue for all setups that
have unmanaged devices.

 - Alexander

Alexander Sack (asac) wrote :

On Tue, Oct 07, 2008 at 09:47:37PM -0000, Sokraates wrote:
> Same problem here (Kubuntu Intrepid), though I found a different
> solution: I commented out the "iface XXX inet dhcp"-lines and now NM
> works like a charm again.

Yes, I if you have configurations in /etc/network/interfaces and dont
want NM to manage your devices (e.g. managed=true in
/etc/NetworkManager/nm-system-settings.conf), you will for now
experience this offline bug. Try managed=true and restart (with your
configuration enabled again) otherwise stick to managed=false and just
remove things from /etc/network/interfaces, just like you did.

 - Alexander

cangia (magonzo) wrote :

I upgraded from 8.04 to Intrepid this morning. No way to make NM work.
I tried all the hints above, none solved. I had problems both with NM and /etc/network/interfaces interaction, and /etc/resolv.conf.
Disabling a (static) eth0 from interfaces, made NM work, except no resolver could be used, I had to change them by hand in resolv.conf. At boot time, NM clears the file.
Solution: uninstalled NM and returned to the old static interfaces and resolv.conf files.

Alexander Sack (asac) wrote :

On Thu, Oct 09, 2008 at 11:46:57AM -0000, cangia wrote:
> I upgraded from 8.04 to Intrepid this morning. No way to make NM work.
> I tried all the hints above, none solved. I had problems both with NM and /etc/network/interfaces interaction, and /etc/resolv.conf.
> Disabling a (static) eth0 from interfaces, made NM work, except no resolver could be used, I had to change them by hand in resolv.conf. At boot time, NM clears the file.
> Solution: uninstalled NM and returned to the old static interfaces and resolv.conf files.
>

in managed=true mode you need dns-nameservers x.y.z.0 in your
interfaces file.

If you remove the configurations from interfaces, you can configure
DNS and static ip in the network manager connection editor since 0.7.

 - Alexander

Sokraates (sokraates) wrote :

@Alexander Sack: Just to make it clear: I was running with the default configuration as far as /etc/network/interfaces and /etc/NetworkManager/nm-system-settings.conf is concerned.

The latter file looks like this:

[main]
plugins=ifupdown,keyfile

[ifupdown]
managed=false

As far as I can tell, that's how it should look like per default.

Also I do want NM to manage all my devices. Shouldn't this be the default? In any case, that's why I uncommented the lines in interfaces (they were added by the system, not myself).

Richard Rickwood (rickwookie) wrote :

Alexander, please let's make this clearer.

Previously static configuration was achieved by setting address, netmask, network, broadcast and gateway in /etc/network/interfaces and DNS servers where specified as nameserver in /etc/resolv.conf.

My networking was effectively 'broken' for the last couple of days because I (as like many I suspect) had no entry in /etc/network/interfaces for dns-nameservers.

You have mentioned this entry in two posts above:
"dns is gathered from dns-nameservers entry in interfaces for now, like:

  dns-nameservers 192.168.1.1"
and
"in managed=true mode you need dns-nameservers x.y.z.0 in your
interfaces file."

Why dns in not gathered from /etc/resolv.conf I don't know, instead it is now 'written' to /etc/resolv.conf once it is specified in /etc/network/interfaces by dns-nameservers, e.g.:

# Generated by NetworkManager
nameserver 192.168.11.1

but anyway just to reiterate:
Whatever the value for 'managed' in /etc/NetworkManager/nm-system-settings.conf, you won't get proper internet functionality without manually adding e.g. dns-nameservers 192.168.1.1 to /etc/network/interfaces.

Of course the point of NM is that you could set this using the GUI I suppose, but doing so involves this long process:
Right-click on the NM icon -> Edit connections... -> double click on the connection in question ->Click the IPv4 Settings tab -> Enter the server in the box 'DNS Servers' (the mouse-over hint example shows 10.0.0.1, 10.0.0.2 so I suppose multiple servers are to be separated by a comma?) -> Click the 'OK' button.
All to get this error:
Updating connection failed: nm-ifupdown-connection.c.82 - connection update not supported (read-only)..

Oh dear!

Alexander Sack (asac) wrote :

Richard, managed mode is not yet enabled by default. If you dont want resolv.conf to be overwritten you have to use "unmanaged" mode and configure all your devices in /etc/network/interfaces.

The bug about unmanaged mode that you appear to be "offline" all the time is a bug that will be fixed for release.

Dana Goyette (danagoyette) wrote :

I have a bridge device in my (attached) Interfaces file, for any VMs I may run; this bridge device uses dnsmasq to serve up dns and dhcp, for NAT. However, with the latest few versions of NetworkManager... NetworkManager seems to try to connect as a _client_ on that interface... which I am the _host_ of. It appears in nm-applet as "Ifupdown (br0)". Switching to my eth0 entry works... but I really shouldn't have to do that manually. There seems to be no way to associate specific network profiles to specific network devices; the new NetworkManager feature would be totally useless on a computer with multiple wired NICs. Same for Mobile Broadband connections... no way to specify what modem to use.

I think I reported a side effect of this "fix". An upgrade from a perfectly normal and fresh Hardy installation results in having eth0 unmanaged. Why a *managed* network must become unmanaged by virtue of an upgrade?
By the way, KNetworkManager ignores not only Interfaces, but itself! There is no way to have a Kubuntu beta live CD connected to a dhcp-less ethernet. The card is detected, up and working and ifconfig + route allowed me to connect to my router.
I hope you do not intend to ship this as is, you are going to break many systems.

Hi, I'm also having problems where my ethp0 is unmanaged.
Any idea what can I do, I've updated to the latest patches but still have problems.
Here are my files:

laptop:~$ sudo ifconfig -a

eth0 Link encap:Ethernet HWaddr 00:16:41:e6:65:23
          inet addr:192.168.1.2 Bcast:192.168.1.255 Mask:255.255.255.0
          inet6 addr: fe80::216:41ff:fee6:6523/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:262 errors:0 dropped:0 overruns:0 frame:0
          TX packets:273 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:134734 (134.7 KB) TX bytes:37149 (37.1 KB)
          Memory:dc100000-dc120000

lo Link encap:Local Loopback
          inet addr:127.0.0.1 Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING MTU:16436 Metric:1
          RX packets:418 errors:0 dropped:0 overruns:0 frame:0
          TX packets:418 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:29620 (29.6 KB) TX bytes:29620 (29.6 KB)

-laptop:~$ cat /etc/network/interfaces
auto lo
iface lo inet loopback
auto eth0
iface eth0 inet dhcp

Vladimir Hidalgo (vlad88sv) wrote :

After updating today:

:~$ apt-cache policy network-manager
network-manager:
  Instalados: 0.7~~svn20081008t224042-0ubuntu2
  Candidato: 0.7~~svn20081008t224042-0ubuntu2
  Tabla de versión:
 *** 0.7~~svn20081008t224042-0ubuntu2 0
        500 http://sv.archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status

:~$ apt-cache policy network-manager-gnome
network-manager-gnome:
  Instalados: 0.7~~svn20081005t082522-0ubuntu1
  Candidato: 0.7~~svn20081005t082522-0ubuntu1
  Tabla de versión:
 *** 0.7~~svn20081005t082522-0ubuntu1 0
        500 http://sv.archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status

:~$ sudo ifconfig -a
eth0 Link encap:Ethernet direcciónHW 00:06:4f:52:8b:cc
          inet dirección:192.168.1.6 Difusión:192.168.1.255 Máscara:255.255.255.0
          dirección inet6: fe80::206:4fff:fe52:8bcc/64 Alcance:Vínculo
          ARRIBA DIFUSIÓN CORRIENDO MULTICAST MTU:1500 Métrica:1
          RX packets:109807 errors:0 dropped:0 overruns:0 frame:0
          TX packets:118050 errors:0 dropped:0 overruns:0 carrier:0
          colisiones:0 txqueuelen:1000
          RX bytes:59949575 (59.9 MB) TX bytes:28980228 (28.9 MB)
          Interrupción:11 Dirección base: 0x1400

lo Link encap:Bucle local
          inet dirección:127.0.0.1 Máscara:255.0.0.0
          dirección inet6: ::1/128 Alcance:Anfitrión
          ARRIBA LOOPBACK CORRIENDO MTU:16436 Métrica:1
          RX packets:358 errors:0 dropped:0 overruns:0 frame:0
          TX packets:358 errors:0 dropped:0 overruns:0 carrier:0
          colisiones:0 txqueuelen:0
          RX bytes:21344 (21.3 KB) TX bytes:21344 (21.3 KB)

:~$ cat /etc/network/interfaces
auto lo
iface lo inet loopback

iface eth0 inet static
address 192.168.1.6
netmask 255.255.255.0
gateway 192.168.1.1
auto eth0

:~$ cat /etc/resolv.conf
domain XXX
nameserver 208.67.222.222
nameserver 208.67.220.220

----

Now I don't see any icon in the Gnome-Panel, but I'm not having problems with going "offline" mode with Firefox.

Ka-Hing Cheung (kahing) wrote :

Why is the upstream bug set to #548114? There's little, if any, relevance.

What is this dns-nameservers entry? As far as I can tell it's not documented in interfaces(5). Is it some made up thing just for the network manager ifupdown plugin? Alex, you realized that approximately zero machines out there actually have this setting in /etc/network/interfaces, right?

Ka-Hing Cheung (kahing) wrote :

Also, should https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/255839 be reopened? system setting, as Richard pointed out, doesn't work

Roland Dreier (roland.dreier) wrote :

FWIW, "dns-nameservers" comes from the resolvconf package.

Richard Rickwood (rickwookie) wrote :

I was aware that managed mode was not the default. I only changed to managed mode because an update to NM (around about the 8th October) stopped my internet connection working, and I was trying lots of things to get it working again. Launching Firefox I found that offline mode was checked (I had not had this bug previously), however, unchecking it I still could not navigate to any website and the NM icon was reporting no connection (I think).

After changing to managed mode I then noticed the lack of DNS Server setting in NM and so found the 'dns-nameservers' entry from the posts on this bug report. That got me back 'online'.

My point is this, before the update my static configuration was fine, after the update I had no working internet connection. That's not good. Why did it break? I suspect something to do with NM writing it's 'blank' DNS Server setting to resolv.conf, but since I didn't check that file before desperately enabling managed mode (my bad) I can't say for sure.

Had I been able to simply set my static settings in the NM GUI (including the DNS Server) without the afrementioned 'read-only' error (what's that all about?), I would have been fine and would not have had to boot into Windows to access the web to find this bug and hence the fix!

Richard Rickwood (rickwookie) wrote :

Maybe my issue is related to this bug: https://bugs.launchpad.net/ubuntu/+source/ifupdown/+bug/281984

Looks like the reporter of that bug was as miffed as I was to suddenly have their networking break.

Should I file a new bug regarding the 'read-only' issue?

zika (4zika4) wrote :

hello,

a week ago I have upgraded my Hardy to Intrepid beta on 3 machines. the oldest one is still with Intrepid but two new had to be downgraded to Hardy since network did not work.

is it safe now to upgrade them to Intrepid beta or should I wait for official release?

(I've posted the same question today in wrong thread, my network cards worked with Vista and do work with Hardy, but the question is: is a version of beta that I would download now free of problems with networking ...?)

yes, I like Intrepid and I am anxious to have it on all machines.

Alexander Sack (asac) wrote :

On Mon, Oct 13, 2008 at 08:33:46AM -0000, Richard Rickwood wrote:
> Had I been able to simply set my static settings in the NM GUI
> (including the DNS Server) without the afrementioned 'read-only' error
> (what's that all about?), I would have been fine and would not have had
> to boot into Windows to access the web to find this bug and hence the
> fix!
>

you _can_ do that. just dont modify the ifupdown connection, but
create a new one

 - Alexander

Alexander Sack (asac) wrote :

On Mon, Oct 13, 2008 at 08:51:50AM -0000, Richard Rickwood wrote:
> Maybe my issue is related to this bug:
> https://bugs.launchpad.net/ubuntu/+source/ifupdown/+bug/281984
>
> Looks like the reporter of that bug was as miffed as I was to suddenly
> have their networking break.
>
> Should I file a new bug regarding the 'read-only' issue?
>

no. ifupdown is read-only. You can still create new connections and
set them as "system" ... which would then be managed by the keyfile
plugin - which also is installed by default.

 - Alexander

seeker5528 (seeker5528) wrote :

Don't know how the duplicates are handled, but everything I reported in:

https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/270762

: works for me now.

Julien Aubin (gojulgarbmail) wrote :

Does not fix the issue for me.

A work around consists in rewriting the /etc/resolv.conf file.

Content of my /etc/network/interfaces file
---------------------
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet static
        address 192.168.0.5
        netmask 255.255.255.0
        network 192.168.0.0
        broadcast 192.168.0.255
        gateway 192.168.0.1
        # dns-* options are implemented by the resolvconf package, if installed
        dns-nameservers 192.168.0.1

---------------------

Below is the result if my ifconfig command :
--------------------------------------------
eth0 Link encap:Ethernet HWaddr 00:1b:fc:a4:07:0c
          inet adr:192.168.0.5 Bcast:192.168.0.255 Masque:255.255.255.0
          adr inet6: fe80::21b:fcff:fea4:70c/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          Packets reçus:100101 erreurs:0 :0 overruns:0 frame:0
          TX packets:62816 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          Octets reçus:113517622 (113.5 MB) Octets transmis:6214973 (6.2 MB)
          Interruption:217 Adresse de base:0x6000

eth1 Link encap:Ethernet HWaddr 00:1b:fc:a4:25:de
          UP BROADCAST MULTICAST MTU:1500 Metric:1
          Packets reçus:0 erreurs:0 :0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          Octets reçus:0 (0.0 B) Octets transmis:0 (0.0 B)
          Interruption:216 Adresse de base:0xa000

lo Link encap:Boucle locale
          inet adr:127.0.0.1 Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING MTU:16436 Metric:1
          Packets reçus:432 erreurs:0 :0 overruns:0 frame:0
          TX packets:432 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          Octets reçus:187991 (187.9 KB) Octets transmis:187991 (187.9 KB)
--------------------------------------------

Rgds.

Filipe Sousa (natros) wrote :

I have the same problem. After every reboot I have to setup the static IP address in network manager applet. It's very annoying

$ cat /etc/network/interfaces
auto lo
iface lo inet loopback

$ cat /etc/NetworkManager/nm-system-settings.conf
[main]
plugins=ifupdown,keyfile

[ifupdown]
managed=false

Alexander Sack (asac) wrote :

On Thu, Oct 23, 2008 at 06:16:13PM -0000, Julien Aubin wrote:
> Does not fix the issue for me.

>
> A work around consists in rewriting the /etc/resolv.conf file.

Sorry, what exactly does not work for you?

 - Alexander

Alexander Sack (asac) wrote :

On Fri, Oct 24, 2008 at 10:32:28PM -0000, Filipe Sousa wrote:
> I have the same problem. After every reboot I have to setup the static
> IP address in network manager applet. It's very annoying

Did you try to rename the (auto) connection or create a new one and
set that to "auto connect"?

Do you have "system settings" enabled or not in the connection editor?

 - Alexander

Filipe Sousa (natros) wrote :

I have both "Connect automatically" and "System setting" enabled.

If I rename the connection name from "Auto eth0" to something else
doesn't work as after a reboot the connection name defaults to "Auto eth0"

$ groups
fsousa adm cdrom audio plugdev fuse lpadmin admin sambashare

Alexander Sack (asac) wrote :

On Mon, Oct 27, 2008 at 10:05:06PM -0000, Filipe Sousa wrote:
> I have both "Connect automatically" and "System setting" enabled.
>
> If I rename the connection name from "Auto eth0" to something else
> doesn't work as after a reboot the connection name defaults to "Auto eth0"
>
> $ groups
> fsousa adm cdrom audio plugdev fuse lpadmin admin sambashare

rename should work. just remove the auto thing afterwards. you cannot
save auto connections without renaming atm ... especially when using
"system settings"

 - Alexander

Filipe Sousa (natros) wrote :

Now I have the new connection renamed, but after a reboot I have the connection that I renamed and "Auto eth0". The "Auto eth0" is the default with dhcp :( Removing "Auto eth0" doesn't work.

I'm giving up, it's easier to set up the network using the old /etc/network/interfaces

kszys (ksocha) wrote :

Same here - no way to make it work :( The network manager always knows better... :(

Alexander Sack (asac) wrote :

On Tue, Oct 28, 2008 at 09:20:29PM -0000, Filipe Sousa wrote:
> Now I have the new connection renamed, but after a reboot I have the
> connection that I renamed and "Auto eth0". The "Auto eth0" is the
> default with dhcp :( Removing "Auto eth0" doesn't work.
>

Well ... usually NM doesnt add a auto connection if there is a valid
connection. It doesnt do that here at least.

It would be much more helpful if you could say what doesnt work and
what the symptoms are instead of saying "just doesnt work" ... which
doesnt help me at all.

> I'm giving up, it's easier to set up the network using the old
> /etc/network/interfaces
>

 - Alexander

Alexander Sack (asac) wrote :

On Wed, Oct 29, 2008 at 10:00:46AM -0000, kszys wrote:
> Same here - no way to make it work :( The network manager always knows
> better... :(
>

Could you please not put comments without any content in bug
reports. that makes the bugs unreadable and will make things become
even worse (e.g. nobody can identify what the issue is here).

 - Alexander

Vladimir Hidalgo (vlad88sv) wrote :

I can't see anymore the NM icon on gnome-panel, but I see NetworkManager running, did I turned off something? or is this normal?.

:~$ cat /etc/network/interfaces
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
address 192.168.1.6
netmask 255.255.255.0
gateway 192.168.1.1

:~$ apt-cache policy network-manager network-manager-gnome
network-manager:
  Instalados: 0.7~~svn20081018t105859-0ubuntu1
  Candidato: 0.7~~svn20081018t105859-0ubuntu1
network-manager-gnome:
  Instalados: 0.7~~svn20081020t000444-0ubuntu1
  Candidato: 0.7~~svn20081020t000444-0ubuntu1

 Vladimir Durán >

Did the "notification area" get accidentally removed from your panel?
Right click the panel > Add applet(item?)> scroll way down and add the
notification bar to your panel. See if that helps you out. :)

On Wed, Oct 29, 2008 at 12:53:30PM -0000, Vladimir Durán wrote:
> I can't see anymore the NM icon on gnome-panel, but I see
> NetworkManager running, did I turned off something? or is this normal?.

Thats "normal". It is currently discussed in bug 289466 ... please
subscribe and lets continue discussion there.

 - Alexander

Changed in network-manager:
assignee: asac → nobody
Vladimir Hidalgo (vlad88sv) wrote :

Nop :(, I have it visible (I use it a lot :) ). I have "notification area" applet version 2.24.1 if it matters.

gnome-applets: 2.24.1-0ubuntu1

I see running:
/usr/sbin/NetworkManager
/usr/sbin/nm-system-settings --config /etc/NetworkManager/nm-system-settings.conf
nm-applet --sm-disable

I did: $ killall `pidof nm-applet` and then started "nm-applet", then I got:

:~$ nm-applet
** (nm-applet:28148): WARNING **: No connections defined

And nothing happens after it (well, I really don't expect anything to happen after seeing that warning).

Vladimir Hidalgo (vlad88sv) wrote :

Oh sorry Alexander Sack, I'll subscribe to that; if anybody can/wants to delete my message go ahead.

jokker (david-las-solanas) wrote :

I can't get this to work. I am really upset, pissed off.. EVERYTHING! All my ftp, apache, ssh, samba, cups servers and VPN are down !!!! PLEASE someone fix this mess !!!!! People like me can't afford to stay with dhcp on a "server"
Is there someone working on this already? Who is responsible for this miserable crappy network program not even tested before release??????!!!!!!!!! Somebody please fired this person !!
Seriously...

Charlie Kravetz (charlie-tca) wrote :

@jokker :

As one of the early testers for intrepid, this was well tested. Had you read through this bug, you already know that.

If you are on a server, it does not use a gui, thus does not use network manager.

Most individuals working on Ubuntu are volunteers.

¨I can't get this to work.¨ sounds like a support issue. Perhaps the forums or mailing lists would be able to assist you getting this working. If you have information to add to a bug report, more information will be necessary. This report is marked fix released. That means it has been resolved and the initial reason for it has been fixed.

To help fix problems, please provide enough information for us to help you. Please include the information requested at https://wiki.ubuntu.com/DebuggingNetworkManager. If you have trouble, do not hesitate to ask for more assistance. You will probably be filing a new bug, also.

Alexander Sack (asac) wrote :

correct, server + NM is currently a no go and the ubuntu server edition definitly doesnt install NM by default.

jokker (david-las-solanas) wrote :

No I use a desktop edition as a server, because I need it as a station too. It worked like this for years, that an old dual athlon MP server. So no, I do not use server edition, I have the GUI, it is just on 24/7 on a ups...
Here is my problem:
I installed cleanly a brand new intrepid by keeping my /home from hardy. First boot I noticed that it was dhcp, so I started to change ip settings (using system - preferences - network config.) but after every boot it went back to dhcp. Then I foud out that /etc/network/interfaces was empty (only loopback setup) so I edit it... after restarting the service, no internet ! after reboot no internet ! I try to remove NetworkManager from rc.d, no luck, so I restore defaults in rc.d, I commented all I added in interfaces, and I'm back to dhcp. So no progress at all. So no this bug is not fixed, at least not for me and of it is not for me it is not for a lot of people.

# lspci
02:06.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit Ethernet (rev 10)
02:07.0 Ethernet controller: Linksys Gigabit Network Adapter (rev 12)

Luke P. R. (siriusfox) wrote :

I'm having a similar problem.

I ran an upgrade from an 8.04 install, and lost network connectivity. I tried fighting with it for a few hours and decided it would be less work to just reinstall the system with the new OS. After the reinstall I found that my system would not maintain the Static IP that I had assigned to it. So after every reboot I have to reconfigure my network. This system is designed to be headless and be run through remote administration using NX, but I can't do that if every time I reboot the system I have to have physical access to get it working again.

Are there any plans to get a patch in place to make static networking usable again?

jokker (david-las-solanas) wrote :

It is not even similar, it is the same story... I forgot to mention that I first upgraded from hardy... Seeing that I could not get the network right and discovering that some people o the web had the same issue from upgrading, I decided to reinstall the whole thing be keeping my $home, but it is the same...

Alexander Sack (asac) wrote :

jokker, dont add more info to this bug please. open a new one for your particular issue and just mention in that bug that you think that it belongs here. thanks a bunch!

Alexander Sack (asac) wrote :

the same for anyone who feels like posting here is the right thing ;)

description: updated
nullrend (nullrend) wrote :

Using Ubuntu 8.10 amd64, updated from RC

I was able to setup VirtualBox Host Networking with this tutorial here:
https://help.ubuntu.com/community/VirtualBox#Networking

However, after using the system for a few days, I noticed instances where the system would lose all connectivity and would not regain it until a reboot. Trying various solutions previously stated within this bug report provided no satisfactory solution. As a work-around I uninstalled network-manager using aptitude, then manually configured all interfaces in /etc/network/interfaces:

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet static
    address 192.168.1.10
    netmask 255.255.255.0
    network 192.168.1.0
    broadcast 192.168.0.255
    gateway 192.168.1.254

#VirtualBox interface bridging for Host Networking
auto br0
iface br0 inet static
    address 192.168.1.10
    netmask 255.255.255.0
    network 192.168.1.0
    broadcast 192.168.0.255
    gateway 192.168.1.254
bridge_ports eth0 vbox0 vbox1 vbox2

Use the values appropriate for your own situation, but do mind the configuration of br0, as it overrides the configuration of eth0. Myself I'm using static IP addresses; to use DHCP just set both to use dhcp. Afterwards changed /etc/NetworkManager/nm-system-settings.conf so the ifupdown plugin is set to false (I had previously set it to "true"):

[main]
plugins=ifupdown,keyfile

[ifupdown]
managed=false

Then manually edited /etc/resolv.conf with the settings I wanted:
domain gateway.2wire.net
search gateway.2wire.net
nameserver 192.168.1.254
nameserver 208.67.222.222
nameserver 208.67.220.220

This lets me use the 2wire DSL functions and OpenDNS's nameservers, as my ISP's nameservers fail constantly.

Rebooted system, networking works as expected for both the Host and Guest systems. I do realize this is not the most appropriate place to post this information, but I thought it important to have a written workaround somewhere. As usual, your mileage may vary depending on your own system setup.

arndtc (arndtc) wrote :

I finally got a static IP to work using the Network Manager.

I had to do the following.
Set my /etc/network/interfaces as follows:
_______________ /etc/network/interfaces _______________
# The loopback network interface
auto lo
iface lo inet loopback

# Wireless interface
auto wlan0
#iface wlan0 inet dhcp

# The primary network interface
auto eth0
#iface eth0 inet dhcp

# The secondary network interface
auto eth1
#iface eth1 inet dhcp
_________________________________________________________

Then after a reboot I had to remove auto eth0.
Then I created a new wired connection called Wired Ethernet 1.
Once I did this I was able to set a static address and this new profile was written to
/etc/NetworkManager/system-connections

I'll look at getting a bridge network up for Virtual Box later.

Saku Ytti (ubuntu-ip) wrote :

I'm somewhat confused from above connections. I have similar need to that of Martin Jackson's. That is I would like network manager to automatically connect to say wlan0, but on the same time, it would let me do what ever I want on eth0. (It could just the same be other way around).

Rationale is that I have some own experiment running on eth0, but I also want to be connected to Internet via wlan0. Or, that I have Internet in eth0, and I want to share it in wlan0.

Now it does not work, since lets assume that I'm currently happily connected to Internet via NM on wlan0, if I plug-in my eth0 for my experiements, wlan0 is torn down and is unconfigurable by NM, even if eth0 is seen as 'unmanaged' by NM, it still tears down wlan0 when eth0 sees link up.

Now I just need to kill whole NM, and configure everything by hand.

What I'd want to see, as solution, is ability to tell NM from configuration to completely ignore some interface, just
forget it exists from NM point of view. This way I could easily do ad'hoc hacks, by connecting to Internet normally
and then ignoring the remaining interface, connect it and configure it manually.

Thanks.

Changed in network-manager:
status: Fix Released → Fix Committed
Changed in network-manager:
status: Fix Committed → Fix Released
tags: added: iso-testing
cwsupport (netsupport) wrote :

Just a quick bit of info as I saw a similar problem...which may or may not have been related on 9.10.

The problem as I see it was caused by have a static ip setup on eth0 - but the network manager was 'swiping' the connection and attempting dhcp (which is not available on the particular network). I found that the following changes to my /etc/network/interfaces cured problems.

1. On lines following iface use a tab to indent not spaces.
2. Between keywords and data (i.e. netmask 255.255.0.0) use a single space not multiple spaces.

After a reboot this cured my problems.

Changed in network-manager:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.