wireless fails when configured in interfaces while networkmanager is installed

Bug #270762 reported by seeker5528 on 2008-09-16
4
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: network-manager

Ubuntu Intrepid

Networkmanager Version: 0.7~~svn20080908t183521+eni0-0ubuntu2
WPA Supplicant version: 0.6.4-2
wireless card: 00:0c.0 Network controller: RaLink RT2561/RT61 802.11g PCI
wireless driver: rt61pci

I configure my wireless in the interfaces with.........

iface wlan0 inet static
address 192.168.1.10
netmask 255.255.255.0
gateway 192.168.1.1
dns-nameservers 68.87.85.98 68.87.69.146
wireless-essid [my ssid]
wireless-key [my WEP key]

............it fails while networkmanager is installed, work after I purge network manager.

If I ifdown/ifup the interface it looks like everything gets configured, address, netmask, etc.... but something fails while authenticating so it disassociates from the access point.

My next thought was maybe if fails because networkmanager wants to use the wpa-supplicant, but I did not supply wpa options or that WEP fails with wpa-supplicant with my card/driver combination, with some research I found this configuration works..............................

iface wlan0 inet static
address 192.168.1.10
netmask 255.255.255.0
gateway 192.168.1.1
dns-nameservers 68.87.85.98 68.87.69.146
wpa-ssid [my ssid]
wpa-key_mgmt NONE
wpa-wep_key0 [my WEP key]

.............So wpa-supplicant can do WEP with my combination of card and driver.

With the above working configuration that uses the wpa-* options I fired up synaptic and selected network-manager-kde for installation, letting it pull in the rest of the networkmanger packages and rebooted the system.

After rebooting I opened a terminal and ran ifconfig which displayed not configuration for wlan0 and iwconfig shows encryption being disabled. After doing ifdown, then ifup, then ifconfig shows address, gateway, etc... attempting to ping the router fails, iwconfig shows encryption is still disabled.

I copied /var/log/syslog to my home directory for inclusion with this bug report, attachment follows. Then purged the networkmanager packages and rebooted and the wirless works again.

seeker5528 (seeker5528) wrote :
Alexander Sack (asac) wrote :

this is a known issue.

Changed in network-manager:
importance: Undecided → High
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager - 0.7~~svn20081018t105859-0ubuntu1

---------------
network-manager (0.7~~svn20081018t105859-0ubuntu1) intrepid; urgency=low

  * new upstream snapshot Sat 2008-10-18 10:58:59 +0000 (rev 3648)
    from lp:~vcs-imports/network-manager/main. Includes:
    + (bzr3642) proper wireless capability detection
      - update src/nm-device-wifi.c
    + update translations nb

  * More cherry-picks:
    + (bzr3650) Updated Belarusian Latin translation.
      - update <email address hidden>

  * Changes in upstream snapshot that don't affect directly produced binary
    packages:
    + (bzr3645) NA/openvpn: support .cer and .crt certificates for openvpn (related
      to LP: #270762)
      - update vpn-daemons/openvpn/properties/auth-helpers.c
    + (bzr3646) NA/openvpn: The "Certificates (TLS)" tab should also be
      present for NM_OPENVPN_CONTYPE_PASSWORD (LP: #280429)
      - update vpn-daemons/openvpn/properties/auth-helpers.c
    + updated vpn translations es, sv

 -- Alexander Sack <email address hidden> Mon, 20 Oct 2008 17:35:58 +0200

Changed in network-manager:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments