0.7 N-M "system setting" does not work

Bug #255839 reported by Alexander Jones on 2008-08-07
34
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Undecided
Unassigned
Nominated for Intrepid by Jonathan Rascher

Bug Description

Binary package hint: network-manager

Checking "system setting" and hitting OK gives me an error dialogue "Adding connection failed: Saving connection failed.." (sic)

This then /sometimes/ breaks the "Network Connections" window. It re-paints and handles expose events properly but it doesn't respond to mouse clicks. Looks like it's stuck in a GtkDialog.run() inner loop.

#0 0x00007f50eb309126 in poll () from /lib/libc.so.6
#1 0x00007f50eb5db4d8 in g_main_context_iterate (context=0x157ce60, block=1,
    dispatch=1, self=<value optimized out>)
    at /build/buildd/glib2.0-2.17.6/glib/gmain.c:3033
#2 0x00007f50eb5dbb6d in IA__g_main_loop_run (loop=0x1dc96d0)
    at /build/buildd/glib2.0-2.17.6/glib/gmain.c:2928
#3 0x00007f50eed19634 in gtk_dialog_run () from /usr/lib/libgtk-x11-2.0.so.0

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 8.10
NonfreeKernelModules: ath_hal
Package: network-manager 0.7~~svn20080720t224551+eni1-0ubuntu1
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/home/username/.local/bin
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: network-manager
Uname: Linux 2.6.26-5-generic x86_64

Alexander Jones (alex-weej) wrote :
Alexander Sack (asac) wrote :

have you properly restarted your system after getting the upgrade?

Changed in network-manager:
status: New → Incomplete
Alexander Jones (alex-weej) wrote :

Yes.

At some point in the past (maybe a few weeks ago), I tried the same thing and managed to see a PolicyKit authn dialogue, but it failed after authenticating.

Changed in network-manager:
status: Incomplete → New

Confirming the "Adding connection failed: Saving connection failed.." message.

Changed in network-manager:
status: New → Confirmed

From daemon.log:

Aug 9 02:10:37 snifer-laptop nm-system-settings: Error chowning '/etc/NetworkManager/system-connections/Auto snifer': 2
Aug 9 02:10:37 snifer-laptop nm-system-settings: Error while saving connection: Failed to create file '/etc/NetworkManager/system-connections/Auto snifer.2WZ3EU': No such file or directory

LaserJock (laserjock) wrote :

I just got the same error as Juan above. To fix it I just did:

sudo mkdir /etc/NetworkManager/system-connections

Saving thereafter worked.

Alexander Sack (asac) wrote :

committed to ubuntu.0.7 development branch.

Changed in network-manager:
status: Confirmed → Fix Committed
f4hy (bmfahy+bug) wrote :

I just did an upgrade to ibex today and had the same issue. creating the directory as described by Jordan fixed it.
the version I have installed is:
network-manager/intrepid uptodate 0.7~~svn20080818t061112+eni0-0ubuntu1

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager - 0.7~~svn20080908t183521+eni0-0ubuntu1

---------------
network-manager (0.7~~svn20080908t183521+eni0-0ubuntu1) intrepid; urgency=low

  [ Alexander Sack <email address hidden> ]
  * new upstream snapshot (Mon 2008-09-08 18:35:21 rev3504)
  * merge improved ifupdown system config implementation from main.eni branch;
    Mon 2008-09-08 20:47:20 +0200; rev 2828
  * Fix LP: #255839 - "0.7 N-M "system setting" does not work"; we create the
    /etc/NetworkManager/system-connections/ directory during package install now
    - update debian/network-manager.dirs
  * adjust patch due to changed ifupdown plugin source dir
    - update debian/patches/50_gcc43.patch
  * fix LP: #256480 - "network-manager 0.7 breaks resolvconf integration"; we
    pass --with-resolvconf=/sbin/resolvconf to configure.
    - update debian/rules
  * (proposed) fix LP: #259503 - "crashes when unplugging device (or unloading
    module)" - crash caused by idle handler accessing already freed device.
    We fix that for wireless and ethernet, which both were affected by
    properly refcounting the device gobjects.
    - add debian/patches/80_lp259503_access_to_freed_device_struct.patch
    - update debian/patches/series
  * drop ifupdown from Depends: - there is no sense to depend on replacements
    - update debian/control
  * drop patch applied upstream
    - delete debian/patches/05-debian_backend.patch
    - update debian/patches/series
  * Fix LP: #261688 - NetworkManager build dependency for "libdbus-glib-1-dev
    (>= 0.60)" incorrect; we adjust the version to >= 0.74.
    - update debian/control
  * bump shlibs requirements for libnm-util0 and libnm-glib0 packages to >=
    0.7~~svn20080908
    - update debian/rules
  * Fix - Networkmanager doesn't update resolv.conf when resolvconf is
    installed, but /etc/resolv.conf isnt a link; we fix that by honouring
    the resolvconf exit code and fall back to "normal" named behaviour in case
    it fails. This requires a resolvconf update which currently doesnt return
    a non-zero exit code when it fails in such a way.
    - add debian/patches/honour_resolvconf_exitcode.patch
    - update debian/patche/series

  [ Matt Zimmerman <email address hidden> ]
  * Add apport package hook (LP: #258552)
    - add debian/network-manager.links
    - add debian/source_network-manager.py
    - update debian/network-manager.install

 -- Alexander Sack <email address hidden> Tue, 09 Sep 2008 16:24:08 +0200

Changed in network-manager:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers