Ubuntu

nm-connection-editor assert failure: ERROR:nm-connection-editor.c:207:connection_editor_validate: assertion failed: (s_con)

Reported by vedavata on 2009-10-28
206
This bug affects 51 people
Affects Status Importance Assigned to Milestone
network-manager-applet (Ubuntu)
Undecided
Unassigned

Bug Description

Description: Ubuntu 9.10
Release: 9.10

network-manager:
  Установлен: 0.8~a~git.20091013t193206.679d548-0ubuntu1
  Кандидат: 0.8~a~git.20091013t193206.679d548-0ubuntu1
  Таблица версий:
 *** 0.8~a~git.20091013t193206.679d548-0ubuntu1 0
        500 http://ua.archive.ubuntu.com karmic/main Packages
        100 /var/lib/dpkg/status

Changing Network (CDMA-modem) connection.

ProblemType: Crash
Architecture: i386
AssertionMessage: ERROR:nm-connection-editor.c:207:connection_editor_validate: assertion failed: (s_con)
CRDA: Error: [Errno 2] No such file or directory
CrashCounter: 1
Date: Wed Oct 28 23:08:44 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/nm-connection-editor
Gconf:

IfupdownConfig:
 auto lo
 iface lo inet loopback
IpRoute:
 195.128.182.23 dev ppp0 proto kernel scope link src 93.180.231.44
 default dev ppp0 scope link
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.

 ppp0 no wireless extensions.
Package: network-manager-gnome 0.8~a~git.20091014t134532.4033e62-0ubuntu1
ProcCmdline: /usr/bin/nm-connection-editor
ProcEnviron:
 LANG=ru_UA.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
RfKill:

Signal: 6
SourcePackage: network-manager-applet
StacktraceTop:
 __kernel_vsyscall ()
 raise () from /lib/tls/i686/cmov/libc.so.6
 abort () from /lib/tls/i686/cmov/libc.so.6
 g_assertion_message () from /lib/libglib-2.0.so.0
 g_assertion_message_expr () from /lib/libglib-2.0.so.0
Title: nm-connection-editor assert failure: ERROR:nm-connection-editor.c:207:connection_editor_validate: assertion failed: (s_con)
Uname: Linux 2.6.31-14-generic i686
UserGroups: adm admin audio cdrom dialout dip fax fuse lpadmin netdev plugdev root sambashare tape video
WpaSupplicantLog:

vedavata (vedavrata) wrote :
Sunil Mekathotti (sbmekathotti) wrote :

Cannot connect to the Wireless Broadband using Network Manager Applet. the similar crash is observed.
However i can connect through 'wvdial' to Wireless Broadband

Evgeny Remizov (ram3ai) wrote :

Upgraded from Jaunty.

Steps to reproduce:
1. Try to edit an old DSL (PPPoE) connection, which has been created before Karmic.
2. An error window 'Insufficient privileges' appears.
3. Assertion fails.

Evgeny Remizov (ram3ai) on 2009-11-01
Changed in network-manager-applet (Ubuntu):
status: New → Confirmed
Nicolai_J. (fireandfuel) wrote :

A bug while editing system wide pppoe connections, doesn't matter whether they are created before or after upgrading to Karmic.

Package: network-manager-gnome 0.8~a~git.20091031t032958.8ac4994-0ubuntu2~nmt1 or older/newer.

mono1984 (jcereijo) wrote :

After setting the "available for all users" in the conection properties a dialog comes up asking for authentication (root) and at the same time another dialog advicing of "insuficient privileges". This won't change neither if i write the password before or after closing the privileges failure window. Thus won't allow to alter the connection settings anymore unless deleted and created again.

Karmic Koala 9.10 (updated from 9.04)

Problem in:
nm-connection-editor

network-manager-gnome:
0.8~a~git.20091014t134532.4033e62-0ubuntu1

Suyog (suyog) wrote :

Yes, I wonder how they released without fixing this bug, its causing problem for sooo many users.
Only workaround is to go to terminal and sudo nm-connection-editor

Alexander Sack (asac) wrote :

can you attach your /etc/NetworkManager/system-connections/ file that causes this issue?

This is the content of the only file i've got on the folder you ask, its
called Auto eth0. What i can understand for eth0 is that uses a NIC on my
machine, but my internet goes trough a 3g usb modem...

[connection]
id=Auto eth0
uuid=fc6adc9d-1dd4-445f-97c5-7cd284bfdeed
type=802-3-ethernet
autoconnect=false
timestamp=0

[ipv4]
method=auto
ignore-auto-routes=false
ignore-auto-dns=false
never-default=false

[802-3-ethernet]
speed=0
duplex=full
auto-negotiate=true
mac-address=0:24:81:41:46:85
mtu=0

2009/11/9 Alexander Sack <email address hidden>

> can you attach your /etc/NetworkManager/system-connections/ file that
> causes this issue?
>
> --
> nm-connection-editor assert failure:
> ERROR:nm-connection-editor.c:207:connection_editor_validate: assertion
> failed: (s_con)
> https://bugs.launchpad.net/bugs/462944
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Julio Cereijo

Evgeny Remizov (ram3ai) wrote :

Access restrictions are:
-rw------- 1 root root 641 2009-10-04 19:46 /etc/NetworkManager/system-connections/providername-pppoe

Other users: be careful! The file you post can contain important information, such as your username/password, mac address, etc.

Suyog (suyog) wrote :

only workaround is while creating connection dont check/enable "for all users"

even then i get the same problem... it tries to connect but doesn't connect
.
so i am still relying on 'sudo wvdial'. And it connects immediately.
 I am happy that i can connect to internet , but i want to connect thru
network manager.
On Wed, Nov 11, 2009 at 10:21 PM, Suyog <email address hidden> wrote:

> only workaround is while creating connection dont check/enable "for all
> users"
>
> --
> nm-connection-editor assert failure:
> ERROR:nm-connection-editor.c:207:connection_editor_validate: assertion
> failed: (s_con)
> https://bugs.launchpad.net/bugs/462944
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in "network-manager-applet" package in Ubuntu: Confirmed
>
> Bug description:
> Description: Ubuntu 9.10
> Release: 9.10
>
> network-manager:
> Установлен: 0.8~a~git.20091013t193206.679d548-0ubuntu1
> Кандидат: 0.8~a~git.20091013t193206.679d548-0ubuntu1
> Таблица версий:
> *** 0.8~a~git.20091013t193206.679d548-0ubuntu1 0
> 500 http://ua.archive.ubuntu.com karmic/main Packages
> 100 /var/lib/dpkg/status
>
>
> Changing Network (CDMA-modem) connection.
>
> ProblemType: Crash
> Architecture: i386
> AssertionMessage:
> ERROR:nm-connection-editor.c:207:connection_editor_validate: assertion
> failed: (s_con)
> CRDA: Error: [Errno 2] No such file or directory
> CrashCounter: 1
> Date: Wed Oct 28 23:08:44 2009
> DistroRelease: Ubuntu 9.10
> ExecutablePath: /usr/bin/nm-connection-editor
> Gconf:
>
> IfupdownConfig:
> auto lo
> iface lo inet loopback
> IpRoute:
> 195.128.182.23 dev ppp0 proto kernel scope link src 93.180.231.44
> default dev ppp0 scope link
> IwConfig:
> lo no wireless extensions.
>
> eth0 no wireless extensions.
>
> ppp0 no wireless extensions.
> Package: network-manager-gnome 0.8~a~git.20091014t134532.4033e62-0ubuntu1
> ProcCmdline: /usr/bin/nm-connection-editor
> ProcEnviron:
> LANG=ru_UA.UTF-8
> SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
> RfKill:
>
> Signal: 6
> SourcePackage: network-manager-applet
> StacktraceTop:
> __kernel_vsyscall ()
> raise () from /lib/tls/i686/cmov/libc.so.6
> abort () from /lib/tls/i686/cmov/libc.so.6
> g_assertion_message () from /lib/libglib-2.0.so.0
> g_assertion_message_expr () from /lib/libglib-2.0.so.0
> Title: nm-connection-editor assert failure:
> ERROR:nm-connection-editor.c:207:connection_editor_validate: assertion
> failed: (s_con)
> Uname: Linux 2.6.31-14-generic i686
> UserGroups: adm admin audio cdrom dialout dip fax fuse lpadmin netdev
> plugdev root sambashare tape video
> WpaSupplicantLog:
>

Suyog (suyog) wrote :

@Sunil, I think your issue is more related to connection and this bug for NM not allowing editing of connection.

Which USB modem you are using? Huawei? ZTE? because I am having Huawei and bug is fixed in latest updates.
please check following bug for details.
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/408555

@Suyog,

Unfortunately i got both problems :-(
I am using Huawei modem. Let me check after updating all the packages if i
connect thru network manager applet.
However still the editing problem exists(the original problem).
thx..
On Fri, Nov 13, 2009 at 4:36 AM, Suyog <email address hidden> wrote:

> @Sunil, I think your issue is more related to connection and this bug
> for NM not allowing editing of connection.
>
> Which USB modem you are using? Huawei? ZTE? because I am having Huawei and
> bug is fixed in latest updates.
> please check following bug for details.
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/408555
>
> --
> nm-connection-editor assert failure:
> ERROR:nm-connection-editor.c:207:connection_editor_validate: assertion
> failed: (s_con)
> https://bugs.launchpad.net/bugs/462944
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in "network-manager-applet" package in Ubuntu: Confirmed
>
> Bug description:
> Description: Ubuntu 9.10
> Release: 9.10
>
> network-manager:
> Установлен: 0.8~a~git.20091013t193206.679d548-0ubuntu1
> Кандидат: 0.8~a~git.20091013t193206.679d548-0ubuntu1
> Таблица версий:
> *** 0.8~a~git.20091013t193206.679d548-0ubuntu1 0
> 500 http://ua.archive.ubuntu.com karmic/main Packages
> 100 /var/lib/dpkg/status
>
>
> Changing Network (CDMA-modem) connection.
>
> ProblemType: Crash
> Architecture: i386
> AssertionMessage:
> ERROR:nm-connection-editor.c:207:connection_editor_validate: assertion
> failed: (s_con)
> CRDA: Error: [Errno 2] No such file or directory
> CrashCounter: 1
> Date: Wed Oct 28 23:08:44 2009
> DistroRelease: Ubuntu 9.10
> ExecutablePath: /usr/bin/nm-connection-editor
> Gconf:
>
> IfupdownConfig:
> auto lo
> iface lo inet loopback
> IpRoute:
> 195.128.182.23 dev ppp0 proto kernel scope link src 93.180.231.44
> default dev ppp0 scope link
> IwConfig:
> lo no wireless extensions.
>
> eth0 no wireless extensions.
>
> ppp0 no wireless extensions.
> Package: network-manager-gnome 0.8~a~git.20091014t134532.4033e62-0ubuntu1
> ProcCmdline: /usr/bin/nm-connection-editor
> ProcEnviron:
> LANG=ru_UA.UTF-8
> SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
> RfKill:
>
> Signal: 6
> SourcePackage: network-manager-applet
> StacktraceTop:
> __kernel_vsyscall ()
> raise () from /lib/tls/i686/cmov/libc.so.6
> abort () from /lib/tls/i686/cmov/libc.so.6
> g_assertion_message () from /lib/libglib-2.0.so.0
> g_assertion_message_expr () from /lib/libglib-2.0.so.0
> Title: nm-connection-editor assert failure:
> ERROR:nm-connection-editor.c:207:connection_editor_validate: assertion
> failed: (s_con)
> Uname: Linux 2.6.31-14-generic i686
> UserGroups: adm admin audio cdrom dialout dip fax fuse lpadmin netdev
> plugdev root sambashare tape video
> WpaSupplicantLog:
>

Suyog (suyog) wrote :

So only way to go is wvdial - as you are using it now :-), same with editing networks, sudo nm-connection-editor.

I also normally use wvdial as its so easy.

Suyog (suyog) wrote :

Hey , its broken again. I guess new updates messed up. I cant connect via Network Manager with Huawei modem.
Its so horrible, What the developers are doing?
Someone should put their hands up and fix this, dont play around with normal users.

axelsvag (darinsson) wrote :

I can confirm this bug. After a fresh install of 9.10 and try to edit my mobile broadband connection everything locked up and the privileges sign came up.

Nicolai_J. (fireandfuel) wrote :

It seems that this bug is fixed in network-manager 0.8-RC1.
Add this line to your /etc/apt/source.list or to system's software sources :

deb http://ppa.launchpad.net/network-manager/trunk/ubuntu karmic main

Then you simply update the network-manager packages. (e.g. "sudo apt-get update" and "sudo apt-get upgrade" via terminal)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager-applet - 0.8~rc2-0ubuntu1

---------------
network-manager-applet (0.8~rc2-0ubuntu1) lucid; urgency=low

  * upstream snapshot 2009-11-12 07:27:27 (GMT)
    + 4162285fd7c53e8b684e1c1513a2ba6ce865e073

  * upstream 0.8-rc1 release
      - applet: don't crash if we can't get some ActiveConnection attrs (rh: #545011)
      - editor: serialize PolicyKit auth requests (rh #462944) (LP: #462944)
      - applet: don't crash if wireless dialog goes away quickly (rh #542617)
      - eap: handle PEM files without and ending newline (rh #507315)
      - tls: require password-protected private keys
      - applet: fix connecting to system connections from wireless dialog
      - menu: show BT connections when no other devices available (rh #532049)
      - applet: don't assert when auto connections can't be made (rh #532680)
      - editor: fix various IP page tooltips (bgo #595287)
      - applet: fix animation issues
      - mobile-wizard: add a "My Country is not listed" option (rh #530981) (bgo #599705)
      - applet: fix issues with icon loading when panel is slow to resize (rh #529766)
      - applet: Connect to Hidden doesn't work for non-New networks (LP: #446394)
      - applet: nm-applet does not start at login (LP: #146896)

  * upstream 0.8-rc2 release
    - editor: protect against invalid CEPolkitButton objects (rh #549579)
    - menu: ensure active menu item is valid before trying to use it (rh #546901)
    - editor: fix bad assignment
    - core: add "Enable Mobile Broadband" menu item
    - applet: escape notification text

  [ Mathieu Trudel <email address hidden> ]
  * updated device sensitive disconnect notification patch
    - update debian/patches/lp341684_device_sensitive_disconnect_notify.patch

  [ Tony Espy <email address hidden> ]
  * add logic to map '~rc' versions to '-rc' tag format used upstream. This
    allows the upstream tags to be used, while managing to keep the version
    numbers less than the final release version.
    - update debian/rules
  * update build and runtime depends for network-manager to >= 0.8~rc2
    - update debian/control
  * backout string changes in preparation for SRU
    - add deb/debian/patches/revert_more_networks.patch
    - add deb/debian/patches/revert_disable_notifications.patch
    - add deb/debian/patches/revert_country_not_listed.patch
    - add deb/debian/patches/revert_cleartext_priv_keys.patch
    - add deb/debian/patches/revert_enable_broadband.patch
    - update debian/series
 -- Tony Espy <email address hidden> Wed, 20 Jan 2010 10:16:56 -0500

Changed in network-manager-applet (Ubuntu):
status: Confirmed → Fix Released

This bug is either not released, or the update to network manager is not being picked up when I try to upgrade.
I have a brand-new, clean install from the latest Karmic live cd - which I then applied an upgrade to all upgradeable packages.

I get the same "insufficient privileges" bug for my Huawei connection the moment that I check "allow access for all users". I change it back to *not* allow access by running nm-connection-editor with sudo... but that just means that the mobile broadband connection suddenly *dissapears* for my one and only user on the system (appears again when I run nm-connection-editor with sudo again). I then had to put all y mobile broadband settings back into network manager for it to work once more.

This bug is *not* fixed.

Changed in network-manager-applet (Ubuntu):
status: Fix Released → Confirmed
chrisfaron (chrisfaron) wrote :

Had the same problem being able to connect but dns not working, when trying to change got "insufficient privileges". With "sudo nm-connection-editor" could change the dhcp to address only & insert DNS manually. Works like a charm

Nicolai_J. (fireandfuel) wrote :

The bug is already fixed!

Add the source
deb http://ppa.launchpad.net/network-manager/trunk/ubuntu karmic main
to your /etc/sources.list and update the network manager to 0.8 RC2.

It is not in the official ubuntu karmic repos(-itory).
I hope that Lucid is released with (working) network manager 0.8 RC2 or newer!

Ooops..

at last it works for me :)

Fololwed the steps below, and upgraded -
network-manager and network-manager-gnome packages. Then i could add my WBB
connection without any errors and could connect to the net as before.

thanks to the dev-guys...

On Fri, Feb 26, 2010 at 2:25 PM, Nicolai_J. <email address hidden> wrote:

> The bug is already fixed!
>
> Add the source
> deb http://ppa.launchpad.net/network-manager/trunk/ubuntu karmic main
> to your /etc/sources.list and update the network manager to 0.8 RC2.
>
> It is not in the official ubuntu karmic repos(-itory).
> I hope that Lucid is released with (working) network manager 0.8 RC2 or
> newer!
>
> --
> nm-connection-editor assert failure:
> ERROR:nm-connection-editor.c:207:connection_editor_validate: assertion
> failed: (s_con)
> https://bugs.launchpad.net/bugs/462944
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in "network-manager-applet" package in Ubuntu: Confirmed
>
> Bug description:
> Description: Ubuntu 9.10
> Release: 9.10
>
> network-manager:
> Установлен: 0.8~a~git.20091013t193206.679d548-0ubuntu1
> Кандидат: 0.8~a~git.20091013t193206.679d548-0ubuntu1
> Таблица версий:
> *** 0.8~a~git.20091013t193206.679d548-0ubuntu1 0
> 500 http://ua.archive.ubuntu.com karmic/main Packages
> 100 /var/lib/dpkg/status
>
>
> Changing Network (CDMA-modem) connection.
>
> ProblemType: Crash
> Architecture: i386
> AssertionMessage:
> ERROR:nm-connection-editor.c:207:connection_editor_validate: assertion
> failed: (s_con)
> CRDA: Error: [Errno 2] No such file or directory
> CrashCounter: 1
> Date: Wed Oct 28 23:08:44 2009
> DistroRelease: Ubuntu 9.10
> ExecutablePath: /usr/bin/nm-connection-editor
> Gconf:
>
> IfupdownConfig:
> auto lo
> iface lo inet loopback
> IpRoute:
> 195.128.182.23 dev ppp0 proto kernel scope link src 93.180.231.44
> default dev ppp0 scope link
> IwConfig:
> lo no wireless extensions.
>
> eth0 no wireless extensions.
>
> ppp0 no wireless extensions.
> Package: network-manager-gnome 0.8~a~git.20091014t134532.4033e62-0ubuntu1
> ProcCmdline: /usr/bin/nm-connection-editor
> ProcEnviron:
> LANG=ru_UA.UTF-8
> SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
> RfKill:
>
> Signal: 6
> SourcePackage: network-manager-applet
> StacktraceTop:
> __kernel_vsyscall ()
> raise () from /lib/tls/i686/cmov/libc.so.6
> abort () from /lib/tls/i686/cmov/libc.so.6
> g_assertion_message () from /lib/libglib-2.0.so.0
> g_assertion_message_expr () from /lib/libglib-2.0.so.0
> Title: nm-connection-editor assert failure:
> ERROR:nm-connection-editor.c:207:connection_editor_validate: assertion
> failed: (s_con)
> Uname: Linux 2.6.31-14-generic i686
> UserGroups: adm admin audio cdrom dialout dip fax fuse lpadmin netdev
> plugdev root sambashare tape video
> WpaSupplicantLog:
>
> To unsubscribe from this bug, go to:
>
> https://bugs.launchpad.net/ubuntu/+source/network-manager-applet/+bug/462944/+subscribe
>

Sebastien Bacher (seb128) wrote :

the bug has been fixed so closing it, you can reopen with details if you still get the issue on lucid though using the current versions

Changed in network-manager-applet (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers