Ubuntu

Connect to Hidden...select Saved Secure Connection; Connect not possible

Reported by Binoy on 2009-10-08
404
This bug affects 98 people
Affects Status Importance Assigned to Milestone
Network Manager Applet
New
Medium
network-manager-applet (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by comand
Nominated for Lucid by WubiNeophyte

Bug Description

Binary package hint: network-manager

please check the attached screenshot
I have a wifi network configured with wep.
The left side windows in the screenshot show the wifi network configured with the wep key
when the machine boots up, I click on the network manager icon and select "Connect to hidden wireless network". Select the network from the connection drop down. The connect button stays disabled probably because the key shows up blank. see the right side of the screenshot
--------------------
$ lsb_release -rd
Description: Ubuntu karmic (development branch)
Release: 9.10
--------------------
$ apt-cache policy network-manager
network-manager:
  Installed: 0.8~a~git.20091005t192303.1d28ad1-0ubuntu2
  Candidate: 0.8~a~git.20091005t192303.1d28ad1-0ubuntu2
  Version table:
 *** 0.8~a~git.20091005t192303.1d28ad1-0ubuntu2 0
        500 http://in.archive.ubuntu.com karmic/main Packages
        100 /var/lib/dpkg/status
--------------------

ProblemType: Bug
Architecture: i386
CRDA: Error: [Errno 2] No such file or directory
Date: Thu Oct 8 20:02:10 2009
DistroRelease: Ubuntu 9.10
IfupdownConfig:
 auto lo
 iface lo inet loopback
IpRoute:
 192.168.0.0/24 dev wlan0 proto kernel scope link src 192.168.0.2 metric 2
 169.254.0.0/16 dev wlan0 scope link metric 1000
 default via 192.168.0.1 dev wlan0 proto static
NonfreeKernelModules: nvidia
Package: network-manager 0.8~a~git.20091005t192303.1d28ad1-0ubuntu2
ProcEnviron:
 LANG=en_IN
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-12.41-generic
SourcePackage: network-manager
Uname: Linux 2.6.31-12-generic i686

Binoy (mailbinoyv) wrote :
Tim McGee (jarz) on 2009-10-08
Changed in network-manager (Ubuntu):
status: New → Confirmed
Tony Espy (awe) wrote :

Can you please attach the screenshot?

Tim McGee (jarz) wrote :

The "Connect" button is disabled because there is no key stored. The same happens when I connect to a WPA2 Enterprise networking using Tunneled TLS with MSCHAPv2.

While I'm unable to confirm this, I believe the issue involves NetworkManager not pulling the key from the keyring.

Tim McGee (jarz) wrote :

I realized I contradicted myself after posting my comment.

Could you open the "Passwords and Encryption Keys" application and look for "Network secret for [your network]" under the "Passwords: login" section? Does it exist?

In my case it appears that NetworkManager adds the network secret to the keyring but fails to retrieve the secret. When a user goes to reconnect to a network already stored, I believe a dialog prompting for access to the keyring is supposed to be displayed.

Binoy (mailbinoyv) wrote :

screen shot attached.

Binoy (mailbinoyv) wrote :

yes there is a entry for the wireless security named 'Network secret for babu_wifi/802-11-wireless-security/wep-key0'

The dialog prompting the password popup's automatically as soon as I login to my desktop, and connects to wifi without problems.
But if that fails or the dialog does not show up, there is no way to connect to the stored wifi network.

Tony Espy (awe) on 2009-10-08
summary: - karmic hidden wireless network connect button
+ Connect to Hidden...select Connection other then New; Connect not
+ possible
Tony Espy (awe) on 2009-10-08
summary: - Connect to Hidden...select Connection other then New; Connect not
- possible
+ Connect to Hidden...select Saved Secure Connection; Connect not possible
Tony Espy (awe) wrote :

Tim, looks like your correct. The Connect button doesn't get enabled because the key hasn't been retrieved when this dialog is displayed.

I have always used this dialog with Connection set to "New". I enter my AP details, and NM seems to do the right thing ( ie. it makes a connect attempt, and saves the connection ).

I wiped my saved networks, changed my AP to hidden, and re-booted.

I clicked "Connect to Hidden...", left Connection set to "New". Next I entered my SSID, then changed the Security Combo to WEP Key. I filled in my key, and clicked Connect...and sure enough was connected OK.

I tried suspend / resume, and again was connected to my hidden network.

Next, I explicitly disconnected, then clicked "Connect to Hidden..." again. If I selected my network from the "Connections" drop-down, the key / passphrase is not pre-filled, nor can I click the "Connect" button as it's grayed out.

Note, I checked a saved open network that appeared in the 'Connections" drop down, and if selected, the "Connect" button is enabled.

affects: network-manager (Ubuntu) → network-manager-applet (Ubuntu)
Binoy (mailbinoyv) wrote :

Is this going to be fixed before Karmic is released? I noticed it has been sent upsteam, but there has been no activity on the bug.

fredking (fredplusplus) wrote :

I have exactly the same issue here.

Tony Espy (awe) wrote :

Fix committed in upstream network-manager-applet git tree ( git://git.gnome.org/network-manager-applet ):

commit 39bf65351dd8d8dc6a5740ff0644999efddad049
Author: Dan Williams <email address hidden>
Date: Mon Oct 19 12:27:23 2009 -0700

    applet: request secrets in the applet's wireless dialog

    Somewhat broken by the libnm-glib settings service refactor,
    but it wouldn't have worked with system connections before anyway,
    since nothing explicitly requested system setting secrets from
    the wireless dialog. (The connection editor was OK)

    This commit basically refactors the population of the various
    GtkEntry widgets for secrets and the TLS private key filepicker to
    happen both at UI creation time, *and* to update them after
    getting secrets. The wireless dialog now explicitly requests
    secrets from a connection every time that connection is selected
    from the Connection: combo, and when the secrets come back populates
    the UI with them, which triggers dialog validation, which will
    then enable the Connect... button.

Changed in network-manager-applet (Ubuntu):
status: Confirmed → Fix Committed
Mephisto (ferrylandzaat) wrote :

So when can we expect this fix? Current NM package uses git 20091014 and it's still broken. I'm having trouble connecting to the network at the office now, since it doesnt broadcast ssid...

birky (birky) wrote :

I have same issue. attached picture, "connect and password" is grayed out.
and of course the networkmanager was unable to autoconnect to hidden wireless network.

freelsjd (freelsjd-gmail) wrote :

Same error here. I waited until a stable releae of karmic to upgrade, and ran into this bug. It is now November 2. The original bug was posted on 10/8, and the fix was posted on 10/20. So, when WILL this fix be implemented. Is there a workaround short of reverting back to jaunty. This makes the machine unusuable in my situation. PLEASE send this fix on !

freelsjd (freelsjd-gmail) wrote :

OK. Sorry for the snippet. I dug a little deeper, found a solution posted on another ubuntu bug report here:

https://bugs.launchpad.net/ubuntu/+source/network-manager-applet/+bug/449287

Put in the change, rebuilt the package, installed the .deb, and it worked. At least until the official package is released, I can access my hidden network.

Changed in network-manager-applet (Ubuntu):
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
Luís Silva (luis) wrote :

Fix commited? where can I get it? Is it even in the repositories?

Andromeda (mdefendi) wrote :

The same for me...

Thanx

Lorenzo (lorped) on 2009-11-10
Changed in network-manager-applet (Ubuntu):
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
Anje (c-rosenfield) wrote :

Just waiting for the fix to come through the repositories....

just to sum it up this bug seems to be the same posted in https://bugs.launchpad.net/ubuntu/+source/network-manager-applet/+bug/449287 and https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/455161

Since the fix has already been commited when will a fix be released?

Fix is very urgent for me... Could anybody give the time frame when this fix will be available through the repositories?

Psy[H[] (vovik-wfa) wrote :

there is a workaround: Disable wireless networks. Set up the wireless connection profile, with passwords, etc. Then make it the only one having "connect automatically" option. (if it already has this option, then uncheck and re-check it). Then enable wireless connections. Your connection profile should be activated.

Thanks for advice.... When will be at the work I will check this workaround.... I will let you know about results.

Best regards,
Vladimir

Andromeda (mdefendi) wrote :

> Anje wrote on 2009-11-10: #17
>
> Just waiting for the fix to come through the repositories....

Hi.

Is this been fixed and released ?
Which is the repository ?

Thanx
Mauro

fontinalis (sfontinalis) wrote :

Hello,

I am experiencing this in Karmic 32 bit on three machines with all the current updates. This bug seems like it has been duped with others here:

This looks like the original:
https://bugs.launchpad.net/ubuntu/+s...et/+bug/446394

Post #20 in this post worked for my Broadcom BCM4318 with the b43xx cutter driver. .

Duped in these:
https://bugs.launchpad.net/ubuntu/+s...er/+bug/450097 - looks like the original bug report
https://bugs.launchpad.net/ubuntu/+s...et/+bug/449287 - marked as dup of 446394
https://bugs.launchpad.net/ubuntu/+s...er/+bug/455161 - marked as dup of 446394
https://bugs.launchpad.net/ubuntu/+s...et/+bug/461385 - marked as dup of 450097

Can someone please confirm that 445161, 449287, & 443694 are dups of 450097 and mark them as so. It may be less confusing for devs and users alike.

If people are still experiencing this like I was on a Broadcom BCM4318, probably no need to hack the driver with all the workarounds in ubuntu forum posts about uninstalling the b43xx driver and using ndiswrapper, etc...Those hacks were unnecessary in my case.

Cheers,
brook

_VZ_ (formatc-meta) wrote :

I have the same

randName (kwokshungit) wrote :

For me I also have a greyed out button, but after I wait a while (usually when the system clock is near a multiple of 10 minutes) NetworkManager does connect automatically. And even after that when I go to the dialog again the button is greyed out.

Andromeda (mdefendi) wrote :

> Anje wrote on 2009-11-10: #17
>
> Just waiting for the fix to come through the repositories....

Hi.
Someone can tell me if the fix has been released ?

Thanx in advance

Mauro

Hendy Irawan (ceefour) wrote :

Where is the fix ?

I have :

$ aptitude show network-manager
Package: network-manager
State: installed
Automatically installed: no
Version: 0.8~a~git.20091013t193206.679d548-0ubuntu1

And the problem still persists.

Architecture: i386
CRDA: Error: [Errno 2] No such file or directory
DistroRelease: Ubuntu 9.10
IfupdownConfig:
 auto lo
 iface lo inet loopback
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
IpRoute:
 10.17.4.12 dev ppp0 proto kernel scope link src 10.11.28.68
 192.168.1.0/24 dev wlan0 proto kernel scope link src 192.168.1.1 metric 2
 169.254.0.0/16 dev wlan0 scope link metric 1000
 default dev ppp0 scope link
Package: network-manager-applet (not installed)
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-16.53-generic
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
Uname: Linux 2.6.31-16-generic i686
UserGroups: adm admin cdrom dialout dip lpadmin plugdev sambashare vboxusers www-data

tags: added: apport-collected
gidantribal (aedo999) wrote :

People, il 20091224 karmic koala up-to-date kernel (x64) problem is STILL NOT SOLVED.

Marking as targetted for karmic-updates, as we should be shipping a fix for this soon, and it's already in the head branch.

Changed in network-manager-applet (Ubuntu):
milestone: none → karmic-updates

For anyone wondering why this is fix committed and what it means: this bug in "Fix Committed" stage means it has been fixed upstream and the fix is also available in a Bazaar branch for the network-manager-applet package. It also means that a fix should be made available soon, through an update or through an upload to the current development release.

As this bug is marked targetted for karmic-updates, there should be an update published soon that will contain this fix. However, in the meantime, you could test the fix using the network-manager packages from the NetworkManager team PPA: https://edge.launchpad.net/~network-manager/+archive/trunk. Please do note that the packages provided there are likely to change regularly as they are daily builds (and may contain new bugs). We'd however very much appreciate any and all testing :)

Mitch Towner (kermiac) wrote :

I can confirm that the fix posted above by Matt Trudel (installing the NetworkManager team PPA) has resolved this issue for me when connecting to routers using WEP, WPA or WPA2 encryption. Thanks to all involved for all of your work on resolving this issue!

LukeQuake (luke-lukepotter) wrote :

Just installed the test updates as kindly suggested by Matt - but still no joy, the same problem.

Does anyone have a successful for this?

Psy[H[] (vovik-wfa) wrote :

I was able to connect to my ad-hoc network with wep password. Button becomes active as soon as password field is not empty.

But I have another problem: If I create a network with wpa protection, then I can not connect to it from another machine: password dialog gives only wep options. And if I set up auto profile for this network with correct wpa password, it tries to connect, then fail and shows the same password dialog with only wep option.

Andy Extance (aextance) wrote :

I installed the /trunk network manager fix, and it now remembers my password, which it didn't before, and tries to connect automatically. However, connecting to my WPA2 network still takes several attempts. I don't know whether this is likely to be sorted by this fix, but it would be nice if it was!

windharp (dkuhn) wrote :

Applied the workaround patch right now, bug fixed. Able to connect to a hidden WPA2 without problems.

For those people where it didn't work out: I had to reboot with the new patch, remove all the old connections and create a new hidden connection. After doing that once, it works like a charme. After the next reboot it reconnected automatically.

Psy[H[] (vovik-wfa) wrote :
Download full text (9.0 KiB)

With latest updates from NM trunk ppa I was not able to connect to WPA protected network

I've created the network on first computer with "WPA & WPA2 Personal" password. Creation was successful. But when I tried to connect to it from another computer, I could not enter the password (see screenshot).

Then I tried to create a profile for the network on second computer. It gave the ability to set WPA password. But connection attempts were futile:
Jan 6 17:59:21 mindflash2 NetworkManager: <info> (wlan0): bringing up device.
Jan 6 17:59:21 mindflash2 kernel: [ 869.308340] Registered led device: iwl-phy0::radio
Jan 6 17:59:21 mindflash2 kernel: [ 869.308381] Registered led device: iwl-phy0::assoc
Jan 6 17:59:21 mindflash2 kernel: [ 869.308416] Registered led device: iwl-phy0::RX
Jan 6 17:59:21 mindflash2 kernel: [ 869.308448] Registered led device: iwl-phy0::TX
Jan 6 17:59:21 mindflash2 kernel: [ 869.349037] wlan0: Trigger new scan to find an IBSS to join
Jan 6 17:59:21 mindflash2 kernel: [ 869.498386] Registered led device: iwl-phy0::radio
Jan 6 17:59:21 mindflash2 kernel: [ 869.498478] Registered led device: iwl-phy0::assoc
Jan 6 17:59:21 mindflash2 kernel: [ 869.498503] Registered led device: iwl-phy0::RX
Jan 6 17:59:21 mindflash2 kernel: [ 869.498526] Registered led device: iwl-phy0::TX
Jan 6 17:59:21 mindflash2 kernel: [ 869.542113] ADDRCONF(NETDEV_UP): wlan0: link is not ready
Jan 6 17:59:21 mindflash2 NetworkManager: <info> (wlan0): supplicant interface state: starting -> ready
Jan 6 17:59:21 mindflash2 NetworkManager: <info> (wlan0): device state change: 2 -> 3 (reason 42)
Jan 6 17:59:21 mindflash2 wpa_supplicant[1193]: CTRL-EVENT-SCAN-RESULTS
Jan 6 17:59:21 mindflash2 wpa_supplicant[1193]: WPS-AP-AVAILABLE
Jan 6 17:59:24 mindflash2 NetworkManager: <info> Activation (wlan0) starting connection 'Auto wtc1'
Jan 6 17:59:24 mindflash2 NetworkManager: <info> (wlan0): device state change: 3 -> 4 (reason 0)
Jan 6 17:59:24 mindflash2 NetworkManager: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...
Jan 6 17:59:24 mindflash2 NetworkManager: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) started...
Jan 6 17:59:24 mindflash2 NetworkManager: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...
Jan 6 17:59:24 mindflash2 NetworkManager: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.
Jan 6 17:59:24 mindflash2 NetworkManager: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) starting...
Jan 6 17:59:24 mindflash2 NetworkManager: <info> (wlan0): device state change: 4 -> 5 (reason 0)
Jan 6 17:59:24 mindflash2 NetworkManager: <info> Activation (wlan0/wireless): connection 'Auto wtc1' has security, and secrets exist. No new secrets needed.
Jan 6 17:59:24 mindflash2 NetworkManager: <info> Config: added 'ssid' value 'wtc1'
Jan 6 17:59:24 mindflash2 NetworkManager: <info> Config: added 'mode' value '1'
Jan 6 17:59:24 mindflash2 NetworkManager: <info> Config: added 'key_mgmt' value 'WPA-NONE'
Jan 6 17:59:24 mindflash2 NetworkManager: <info> Config: added 'psk' value '<omitted>'
Jan 6 17:59:24 mindflash2 NetworkManager: <info> Config...

Read more...

Psy[H[] (vovik-wfa) wrote :

after today update of network-manager-gnome, it still gives authentication prompt with only wep options.

_VZ_ (formatc-meta) wrote :

Thank you Mathieu Trudel! The problem was fixed.

Psy[H[] (vovik-wfa) wrote :

I've tried to connect to some neighbor wireless points with wpa protection, NM correctly prompted wpa password,
So problem with wpa password prompting is limited to ubuntu-ubuntu ad-hoc connections.

Andy Extance (aextance) wrote :

It seems that the trunk NM PPA fix has now stopped connecting for me - although there are no problems remembering the password.

gidantribal (aedo999) wrote :

thank you , problem solved here too (karmic x64)

James Wylder (jim.wylder) wrote :

I may be missing something but I wasn't able to get this to work.

I added the network-manager & network-manager-gnome from the ppa referenced and I still get the greyed out Apply button as soon as I pick any security option. I deleted all the connections as mentioned, but still no luck.

windharp (dkuhn) wrote :

Di you use the Update system to actually download the network-manager?

James Wylder (jim.wylder) wrote :

I think I did it correctly but I never underestimate my ability to make a mistake. I added the ppa then apt-get update & apt-get install network-manager=0.8~rc2~git.20100108t192339.a74e2cf-0ubuntu1~nmt1~karmic
and apt-cache showpkg network-manager returns that this version is installed.

Yfff (yfff) wrote :

Hi,

While I can't see why bug 468741 is a duplicate of this one, I posted comment #29 there. It solved my problem connecting to hidden ssid/wpa/psk with kubuntu 9.10.

Yfff

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager-applet - 0.8~rc2-0ubuntu1

---------------
network-manager-applet (0.8~rc2-0ubuntu1) lucid; urgency=low

  * upstream snapshot 2009-11-12 07:27:27 (GMT)
    + 4162285fd7c53e8b684e1c1513a2ba6ce865e073

  * upstream 0.8-rc1 release
      - applet: don't crash if we can't get some ActiveConnection attrs (rh: #545011)
      - editor: serialize PolicyKit auth requests (rh #462944) (LP: #462944)
      - applet: don't crash if wireless dialog goes away quickly (rh #542617)
      - eap: handle PEM files without and ending newline (rh #507315)
      - tls: require password-protected private keys
      - applet: fix connecting to system connections from wireless dialog
      - menu: show BT connections when no other devices available (rh #532049)
      - applet: don't assert when auto connections can't be made (rh #532680)
      - editor: fix various IP page tooltips (bgo #595287)
      - applet: fix animation issues
      - mobile-wizard: add a "My Country is not listed" option (rh #530981) (bgo #599705)
      - applet: fix issues with icon loading when panel is slow to resize (rh #529766)
      - applet: Connect to Hidden doesn't work for non-New networks (LP: #446394)
      - applet: nm-applet does not start at login (LP: #146896)

  * upstream 0.8-rc2 release
    - editor: protect against invalid CEPolkitButton objects (rh #549579)
    - menu: ensure active menu item is valid before trying to use it (rh #546901)
    - editor: fix bad assignment
    - core: add "Enable Mobile Broadband" menu item
    - applet: escape notification text

  [ Mathieu Trudel <email address hidden> ]
  * updated device sensitive disconnect notification patch
    - update debian/patches/lp341684_device_sensitive_disconnect_notify.patch

  [ Tony Espy <email address hidden> ]
  * add logic to map '~rc' versions to '-rc' tag format used upstream. This
    allows the upstream tags to be used, while managing to keep the version
    numbers less than the final release version.
    - update debian/rules
  * update build and runtime depends for network-manager to >= 0.8~rc2
    - update debian/control
  * backout string changes in preparation for SRU
    - add deb/debian/patches/revert_more_networks.patch
    - add deb/debian/patches/revert_disable_notifications.patch
    - add deb/debian/patches/revert_country_not_listed.patch
    - add deb/debian/patches/revert_cleartext_priv_keys.patch
    - add deb/debian/patches/revert_enable_broadband.patch
    - update debian/series
 -- Tony Espy <email address hidden> Wed, 20 Jan 2010 10:16:56 -0500

Changed in network-manager-applet (Ubuntu):
status: Fix Committed → Fix Released
Luís Silva (luis) wrote :

Isn't this going to get fixed in Karmic?

This problem is incredibly aggravating for average users. When is this fix
going to hit the common repositories? I'm running a few fully upgraded
karmic machines and all of them are experiencing these problems stemming
from a release of network-manager from October (the newest available in the
repositories). If this can be fixed by recompiling network-manager, could
we have a link to the svn repository? I've searched for hours and can't
seem to locate the source code of a newer version.

On Wed, Jan 20, 2010 at 8:12 PM, Luís Silva <email address hidden>wrote:

> Isn't this going to get fixed in Karmic?
>
> --
> Connect to Hidden...select Saved Secure Connection; Connect not possible
> https://bugs.launchpad.net/bugs/446394
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

Rui Araújo (rui-araujo) wrote :

There is no need to compile the code yourself, as mentioned in a previous comment, there a PPA with the fix, https://launchpad.net/~network-manager/+archive/trunk. If you add it, you will get more recent packages with this fix already applied.

But I do agree with this being a very annoying problem, specially when at your workplace the Wifi network is hidden. The update should have arrived to the karmic-updates by now.

Tony Espy (awe) wrote :

@ Alaric

This problem existed pre-Karmic and as such should not be considered a regression. Furthermore, the case outlined here is not the typical use case, as NM should automatically re-connect a hidden network that's been previously connected. Unfortunately, drivers don't always support the ability to scan for a specific ESSID ( that's how NM is able to detect that the hidden AP is available ), and there's not much NM can do about it... although one could argue that if the driver isn't fully capable, the feature should be disabled in the UI.

As for landing in Karmic, the plan was to try and get 0.8~rc2 released as an SRU for Karmic, however if that's not excepted then a stable version will be pushed to the NM main PPA.

Luís Silva (luis) wrote :

@Tony Espy
"This problem existed pre-Karmic and as such should not be considered a regression":
I can't agree on that without saying a word... This problem in fact didn't exist pre karmic... I used to be able to connect correctly before karmic (In jaunty it worked perfectly... I used this almost every day...) and until middle/late (I can't remember exactly wich) karmic alphas it worked ok... It is indeed a regression! And a serious one... Think of all the college students who want to connect to eduroam network and whose default implementation tipically involves hidding the network...

"NM should automatically re-connect a hidden network that's been previously connected":
On this I agree... But this in fact never worked reliably for me... This is not a regression and in fact it is not so serious...

"the plan was to try and get 0.8~rc2 released as an SRU for Karmic"
If we ever want Ubuntu to beat or at least match windows this sort of bugs can't happen...When they do happen, they should be fixed... I'm tired of having to reintroduce my password every day or even several times a day... Going from an alpha release of network manager to an rc version with lots of bugs corrected should be possible without question... These are the kind of bugs that also keep users away...

Please see this report in a constructive and respectfull way... I try to help this project with bug reporting and testing because I believe my (small) contribution can lead to a better product and it is my way of "paying" for the hard work the developers put on it.

Sotomajor (miccots) wrote :

Totally agree with Luis. If the bug (at least such annoying one) fixed it should be available through standard upgrade mechanism asap.

cometdog (ericctharley) wrote :

@ Tony Espy

This is absolutely a regression and absolutely should be released to the standard repositories.

RE: Furthermore, the case outlined here is not the typical use case, as NM should automatically re-connect a hidden network that's been previously connected.

It may not be the "typical" use case, whatever that use case is, but it seriously breaks basic, essential functionality in other use cases, like mine. Automatically re-connecting to networks is no good unless there is only one network in range that you have ever used.

I work at a place where the secured intranet is hidden, but there is also an unsecured visitor network that is visible. With my laptop I have to reconnect at hourly as I move between meetings (different access points) and my desk. With this bug, the network manager always connects to the unsecured visitor network, which is useless to me.

To work around it I had to lock in the Jaunty version of network manager, which is semi-broken with the Karmic network applet (can't edit existing network connections), which prevents me from getting security updates for these packages, and which also downgrades the bluetooth code.

Ryan Daly (daly-ctcnet) wrote :

I can confirm this bug in Ubuntu 9.10, and I can also confirm that the fix (from packages in ppa:network-manager/trunk) appears to have corrected the problem.

Thank-you.

Andy Extance (aextance) wrote :

When initially I applied the fix I was able to connect via my wireless adapter (Ralink RT2870) to my hidden WPA2 network intermittently. Shortly after I became unable to connect to the hidden network, but can connect when the SSID is broadcast. I definitely feel that this is something to do with this fix. There are no problems so far with a broadcast SSID.

cometdog (ericctharley) wrote :

I had the PPA fix installed. Network Manager upgrade yesterday broke my network connectivity completely, both wired and wireless. The versions that broke it for me were:
network-manager_0.8-0ubuntu4~nmt4~karmic
and
network-manager-gnome_0.8-0ubuntu3~nmt2~karmicl.

Not sure if these came from the PPA or from the main Karmic repository. No current version from PPA or from Karmic main is working for me.

I was sometimes able to get connected intermittently by doing
sudo dhclient
from the terminal.

I had to downgrade to the rc4 versions that used to be in the PPA (still had them on my machine in /var/cache/apt/archives). Posting this info here as it is relevant to those looking for a solution -- PPA above may no longer help anyone.

Any updates on the possibility of getting a working version in Karmic main?

Mathieu Marquer (slasher-fun) wrote :

network-manager_0.8-0ubuntu4~nmt4~karmic comes from the "trunk" Network Manager PPA, which is currently buggy. You should use the main one instead : https://launchpad.net/~network-manager/+archive/ppa (which works and fixes that bug)

Jay Daniels (dasautotec) wrote :

It's almost time for the next release and this still has not been fixed in Karmic. A work around here...

After creating a hidden network, you find that you cannot connect automatically or manually since the hidden wifi network you created has a greyed out connect button. Try clicking network manager and then select connect to hidden wireless network and create the wifi network from here. This sometimes requires a reboot since the connection string will become corrupt.

Also, you may also need to change from the default ad-hoc to infrastructure and also change to automatic dns under settings.

I cannot believe a fix for this hasn't made it into karmic updates!

Aravind (aravind-a) wrote :

I moved from 9.10 to 10.04 LTS. I had difficulty connecting to my hidden wifi network at home.
I temporarily configured the wifi as visible and was able to connect.

The problem however did not go away on moving back to hidden wi-fi.
I removed network-manager and installed wicd and removed nm-applet from the system tray.
WiCD did not work either. So I removed it and installed network-manager but found that nm-applet
does not run in the system tray. Going through the various threads I found Alt+F2 would help me run /usr/bin/nm-applet.

When I run nm-applet like this after the system is booted up and I am logged in I find that I am prompted for
the WPA2-PSK key and I can connect without any problem.

Not sure what in all the above steps fixed the issue, but I now manually launch nm-applet.
I would say that launching nm-applet before the system is all booted up is one of the symptoms of the problem.
It seems to work if we launch nm-applet after the system is booted up.

If someone can point me to how to enable debug messages for nm-applet and the source code I could help
in debugging the problem.

Changed in network-manager-applet:
importance: Unknown → Medium
status: Unknown → New

I figured that this had been fixed - on Lucid I can select a "hidden" network and connect to it without issue (the "Connect" button becomes enabled).
As far as I can remember, I've not installed any weird patches or anything.

m0sfet (riccardo-donato) wrote :

Not working on Ubuntu 10.10 with kernel 2.6.35-23-generic (64 bit).
I wrote a small Python Qt application as a workaround and seems to work fine!
Have a look here: http://rdonato.altervista.org/?p=81

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.