Incorrect Translation in Spanish Network (ENG)->Red (SPA) ¿?-> Rojo (red colour)

Bug #358641 reported by franlade on 2009-04-09
46
This bug affects 2 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Undecided
Unassigned
Ubuntu Netbook Remix Launcher
High
Unassigned
Ubuntu Translations
High
David Planella
language-pack-gnome-es (Ubuntu)
High
Ubuntu Spanish Translators
Jaunty
Undecided
Unassigned
Karmic
High
Ubuntu Spanish Translators
netbook-launcher (Ubuntu)
Undecided
Unassigned
Jaunty
High
Unassigned
Karmic
Undecided
Unassigned

Bug Description

* Impact of the bug on users and justification for backporting the fix to the stable release

When displaying the main Ubuntu Netbook Remix UI, Spanish users are presented with a completely wrong and misleading translation of the 'Network' tab.

The proper translation of 'Network' in Spanish should be 'Red', and not 'Rojo' as it is currently translated in the distribution package. 'Rojo' is the name for the colour 'red' in Spanish, which somehow might have confused the original translator.

This translation is not only misleading to users, but due to its high visibility (it is shown on the main UI) leaves also an undeserved bad quality impression on the project.

* How the bug has been addressed in the development branch

The bug has not yet addressed in the development branch. Attached is a debdiff containing a patch correcting only this particular translation. Although the proper fix in the development release would be to export all translations from Launchpad and release a new package with those updated translations, for the stable release it might be safer to first fix only the current bug (i.e. correct only the Spanish 'Network' translation).

TEST CASE:

* Start Ubuntu Netbook Remix using the Spanish locale
* Once the UI is loaded, the 'Network' tab on the right is displayed wrongly translated as 'Rojo'

* Discussion of the regression potential of the patch and how users could get inadvertently affected.

If the patch only touches that particular string (i.e. change 'Rojo' by 'Red'), there shouldn't be any regression potential.

franlade (franlade) wrote :
Fabián Rodríguez (magicfab) wrote :

To be clear "Red" was change to "Rojo" by a translator that didn't have enough context to know that it referred to Network and didn't need translation. Confirming this as High, given the confusion it will bring.

Changed in netbook-remix-launcher:
importance: Undecided → High
status: New → Confirmed
Loïc Minier (lool) wrote :

This was also reported in bug #338221 and I had fixed that in bzr; this does deserve a jaunty update IMO.

Changed in netbook-launcher (Ubuntu):
milestone: none → jaunty-updates
Paul Larson (pwlars) wrote :

Bug has been moved to Ubuntu distribution

Changed in netbook-remix-launcher:
status: Confirmed → Won't Fix
tags: added: ubuntu-unr
Ricardo Pérez López (ricardo) wrote :

Fixed in Launchpad:

https://translations.edge.launchpad.net/netbook-remix-launcher/trunk/+pots/netbook-launcher/es/26/+translate

Unfortunately, this application is in Universe, so we can only translate it in the "trunk" branch, and therefore anybody can translate it without any QA. Even more, the translations aren't included in any langpack, so the fix will probably stay waiting for a new package update (probably for Karmic) :(

affects: language-pack-es (Ubuntu) → language-pack-gnome-es (Ubuntu)
Changed in language-pack-gnome-es (Ubuntu):
assignee: nobody → Ubuntu Spanish Translators (ubuntu-l10n-es)
status: New → Fix Committed
Ricardo Pérez López (ricardo) wrote :

Not a netbook-launcher bug.

Changed in netbook-launcher (Ubuntu):
status: New → Invalid
Changed in netbook-launcher (Ubuntu Jaunty):
status: New → Invalid
Jisakiel (jisakiel) wrote :

This really detracts from the quality of netbook-launcher, as *everyone* who sees my laptop asks "what's the colour doing there?", making it unusable for non-knowing users and very unprofessional. I agree that an update should be published to fix it.

Fabián Rodríguez (magicfab) wrote :

@Ricardo, correct me if I am wrong but I see language-pack-gnome-es is in Main.

are you saying this specific string is hardcoded ?

Changed in language-pack-gnome-es (Ubuntu):
importance: Undecided → High
Ricardo Pérez López (ricardo) wrote :

No, the string isn't hardcoded, but netbook-launcher is in universe, so the translations are not included in any langpack (like language-pack-gnome-es), but in the .mo file included in the package.

Maybe the language-pack-gnome-es task is not the right one to mark this bug as Commited, because that langpack is not related in any way. I'll mark Commited the netbook-launcher task, even though the problem isn't in the code, but in the translation.

Changed in netbook-launcher (Ubuntu):
assignee: nobody → Ubuntu Spanish Translators (ubuntu-l10n-es)
status: Invalid → Fix Committed

This is a translation bug, but the netbook-launcher translations aren't in this langpack.

Changed in language-pack-gnome-es (Ubuntu):
status: Fix Committed → Invalid
Changed in language-pack-gnome-es (Ubuntu Jaunty):
status: New → Invalid
Fabián Rodríguez (magicfab) wrote :

Ricardo, how can we get the translations in the langpack ? Could you provide a bit more detail on how anyone else could speed up (or just work towards) this issue's resolution ?

Langpacks has nothing to do with the translations of the Universe software, because that translations go into the software packages themselves. In order to get this translation issue fixed, the netbook-launcher package must be re-packaged with the latest translations from trunk as an SRU. As far as I know, that's the responsibility of the ubuntu-universe-sponsors team, which has been already notified by this issue as a subscriber of this bug.

Then, according to Ricardo, this one really is a bug from netbook-launcher, right??

To be accurate: the problem is a bad translation in the netbook-launcher's trunk translations. The problem isn't in the netbook-launcher code, but in the translation.

David Planella (dpm) on 2009-06-12
description: updated
tags: added: l10n
David Planella (dpm) wrote :

Has a fix been actually comitted to the package?

I see that this has been corrected in Launchpad Translations, but by having a look at the bug's history I don't think there has been an actual fix yet. If this is the case, the status should be changed to e.g. Confirmed

What needs to happen is that a patch against the package sources changing only this particular string 'Rojo' -> 'Red' must be provided.

Ricardo, would that be enough, or were there other translation fixes which would require updating the whole es.po translation?

Hi, David. This is a translation issue, and was fixed on 2009-05-13 in the trunk template:

  https://translations.launchpad.net/netbook-remix-launcher/trunk/+pots/netbook-launcher/es/26/+translate

(That's the meaning of the "Fix Commited" status.) Previously, the above #26 string was "Rojo", but now is "Red".

In order to fully fix the issue, we need to rebuild the netbook-launcher package to include the latests translations updates into the package itself.

The current netbook-launcher version is 1.6.20-0ubuntu2, so we could build the 1.6.20-0ubuntu3 version with the latests translations and without any change in the code.

I hope to have explained well :).

David Planella (dpm) on 2009-06-14
Changed in netbook-launcher (Ubuntu):
assignee: Ubuntu Spanish Translators (ubuntu-l10n-es) → nobody
status: Fix Committed → Confirmed
David Planella (dpm) wrote :

Please find a debdiff containing a patch which fixes this particular translation.

I've created a PPA package with this fix for those willing to test it: https://launchpad.net/~dpm/+archive/ppa

description: updated
David Planella (dpm) wrote :

Please find attached a new version of the patch, this time with the correct distribution (Jaunty) and a more adequate version number.

@Ricardo: could you get the Spanish translators/LoCo to test the PPA package [1] and see whether it solves the problem and that it doesn't cause any regressions?

[1] https://launchpad.net/~dpm/+archive/ppa

Changed in netbook-launcher (Ubuntu Jaunty):
status: Invalid → Confirmed
David Planella (dpm) wrote :

ACK. Approved for SRU.

Changed in language-pack-gnome-es (Ubuntu Jaunty):
status: Invalid → Won't Fix
Changed in netbook-launcher (Ubuntu):
milestone: jaunty-updates → none
status: Confirmed → Fix Released
Changed in language-pack-gnome-es (Ubuntu Jaunty):
status: Won't Fix → Invalid
Changed in netbook-launcher (Ubuntu Jaunty):
importance: Undecided → High
Changed in ubuntu-translations:
status: New → Confirmed
Changed in netbook-launcher (Ubuntu Jaunty):
status: Confirmed → Fix Committed
Martin Pitt (pitti) wrote :

Accepted netbook-launcher into jaunty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
David Planella (dpm) on 2009-07-08
Changed in ubuntu-translations:
assignee: nobody → David Planella (dpm)
importance: Undecided → High
status: Confirmed → Fix Committed
Vish (vish) wrote :

Thank you for bringing this bug to our attention. Unfortunately a paper cut should be a small
usability issue that affects *many* people . I'm afraid this bug can't be addressed as part of this project.

A paper cut is a minor usability annoyance that an average user would encounter on his/her first day of using a new installation of Ubuntu 9.10.

For further info about papercuts criteria , pls read > https://wiki.ubuntu.com/PaperCut

Don't worry though, This bug has been marked as "invalid" ONLY in the papercuts project.

Changed in hundredpapercuts:
status: New → Invalid
David Planella (dpm) wrote :

I've tested the new package from -updates and it solves the problem. So far I haven't detected any regression.

If any users of UNR in Spanish could test and give feedback here as explained by Martin on comment #21, that would be great.

David Planella (dpm) wrote :

Sorry, I meant from *jaunty-proposed*.

Jisakiel (jisakiel) wrote :

Works fine for me as of 1.6.20-0ubuntu2.1. Perhaps should be linked to https://bugs.launchpad.net/easypeasy/+bug/378753 as well.

Martin Pitt (pitti) on 2009-07-15
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package netbook-launcher - 1.6.20-0ubuntu2.1

---------------
netbook-launcher (1.6.20-0ubuntu2.1) jaunty-proposed; urgency=low

  * Corrected the 'Network' tab Spanish translation. (LP: #358641)

 -- David Planella <email address hidden> Sun, 14 Jun 2009 10:21:37 +0200

Changed in netbook-launcher (Ubuntu Jaunty):
status: Fix Committed → Fix Released
David Planella (dpm) on 2009-07-15
Changed in ubuntu-translations:
status: Fix Committed → Won't Fix
status: Won't Fix → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers