Login screen never appears on early generation Intel GPUs (Core2 and Atom etc)

Bug #1727356 reported by Traumflug on 2017-10-25
264
This bug affects 40 people
Affects Status Importance Assigned to Milestone
mutter (Ubuntu)
High
Unassigned
Bionic
High
Marco Trevisan (Treviño)
Cosmic
High
Unassigned

Bug Description

[ Impact ]

In some early intel GPUs gdm can't start in wayland mode, and so gnome-shell

[ Test case ]

- Start the pc or logout/end session
- Try to login with the "Ubuntu on Wayland" session
- Ubuntu should start

[ Regression potential ]

Possible false positive on wayland support check on some cards

---

https://gitlab.gnome.org/GNOME/mutter/issues/127

---

Wayland sessions (including the login screen itself) don't start up on older Intel GPUs.

---

Workaround:

Ctrl+Alt+F4, log in, edit /etc/gdm3/custom.conf and uncomment the line:
#WaylandEnable=false

---

$ lsb_release -rd
Description: Ubuntu 17.10
Release: 17.10

Upgraded from 17.04 today.

Steps to reproduce:

- Start the PC or log out/end session in case it's running with an Xorg desktop already.
- Attempt to log in, using 'Ubuntu'

Expected to happen:

Desktop appears.

Actually happening:

5 seconds of black screen, then the login screen appears again.

Partial diagnosis:

- Logging in using 'Ubuntu on Xorg' works fine and as expected.

- Extracted a syslog of such a failed attempt, see attached file.
---
ApportVersion: 2.20.7-0ubuntu3.1
Architecture: amd64
CurrentDesktop: ubuntu:GNOMEDisplayManager: gdm3DistroRelease: Ubuntu 17.10
InstallationDate: Installed on 2016-05-04 (539 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
Package: gnome-shell 3.26.1-0ubuntu5
PackageArchitecture: amd64
ProcVersionSignature: Ubuntu 4.13.0-16.19-generic 4.13.4
Tags: artful package-from-proposed third-party-packages
Uname: Linux 4.13.0-16-generic x86_64
UpgradeStatus: Upgraded to artful on 2017-10-25 (0 days ago)
UserGroups: adm cdrom dialout dip lpadmin plugdev sambashare sudo www-data
_MarkForUpload: True

Related branches

Traumflug (mah-jump-ing) wrote :

Other than reported at #1726192 I can't get into a Wayland desktop shortly after a Xorg session either.

Traumflug (mah-jump-ing) wrote :

As requested in the other bug I turned on GDM debugging and tried to log in again. Relevant section (identified by time stamp) see attached.

Totally different set of messages. These appear to indicate something going wrong:

gnome-shell[5180]: Shader compilation failed:#0120:44(42): warning: `cogl_texel0' used uninitialized#0120:72(36): error: could not implicitly convert operands to arithmetic operator#0120:72(18): error: operands to arithmetic operators must be numeric

gnome-shell[5180]: Failed to link GLSL program:#012error: linking with uncompiled shader

gnome-shell[5180]: driver/gl/cogl-pipeline-progend-glsl.c:384: GL error (1282): Invalid operation

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1727356/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
affects: ubuntu → wayland (Ubuntu)
Traumflug (mah-jump-ing) wrote :

> It seems that your bug report is not filed about a specific source package

See, Mr. Bot, if I'd knew the package, I'd report the bug not here, but upstream.

Traumflug (mah-jump-ing) wrote :

Thanks for the help, @Brian. I thought about the package 'wayland', too, but trying to report a bug against it came out like this:

$ ubuntu-bug wayland
dpkg-query: no packages found matching wayland

affects: wayland (Ubuntu) → gnome-shell (Ubuntu)
Daniel van Vugt (vanvugt) wrote :

"wayland" is just the bare protocol libraries, so not relevant here. The package you want is one of:

  gnome-shell
  mutter
  gdm3

Daniel van Vugt (vanvugt) wrote :

Please run this command to help us collect more information:

apport-collect 1727356

Changed in gnome-shell (Ubuntu):
status: New → Incomplete
summary: - Wayland does not start up
+ Wayland does not start up on "Integrated Graphics Chipset: Intel(R)
+ G33": Shader compilation failed
Changed in gnome-shell:
importance: Unknown → Critical
status: Unknown → Confirmed

apport information

tags: added: apport-collected artful package-from-proposed third-party-packages
description: updated

apport information

apport information

apport information

apport information

Changed in gnome-shell (Ubuntu):
status: Incomplete → New
Changed in gnome-shell (Ubuntu):
importance: Undecided → High
status: New → Triaged

As the G33 graphics chipset is 10 years old it will be difficult for developers to find hardware to test on. And unlikely very many users will encounter the problem.

We definitely want to fix this, but calling it High importance is probably not accurate.

Changed in gnome-shell (Ubuntu):
importance: High → Medium
Traumflug (mah-jump-ing) wrote :

Intel integrated graphics is probably the most widely used PC graphics on this planet. The problem is apparently that shaders are called without being present, which applies to many most recent hardware platforms as well. Calling it High is more than accurate.

Instead of trying to discuss the problem away it'd be much better to give instructions on how to find a way to actually solve the problem. To get an idea about what's going on I dedicated a full day on finding a starting point, but failed. Re-building gnome-shell from sources is a snap, but startup procedures are obfuscated enough to not allow a mere user to change or intercept it somehow. Instructions (or documentation pointers) on how to start up a Wayland session manually, without GDM, would be very helpful.

Sebastien Bacher (seb128) wrote :

Having the default desktop not working on a class of hardware seems an High issue indeed, the GNOME bug tracker might be a better place to discuss it though since that's where the people working most on gnome-shell are more likely to read the comments

Changed in gnome-shell (Ubuntu):
importance: Medium → High
Daniel van Vugt (vanvugt) wrote :

You should both be aware you're preaching to the converted. When we encountered these kinds of problems in Compiz/Mir/Unity8, I was the one fighting to keep old hardware supported and performing well. I will still fight to keep older hardware working well because there's no reason why the software should not work. I've been using OpenGL for 20 years so yes I know it should just work, and it should work efficiently. This is just a bug...

My point is only that the bug will affect very few people, and we likely will never be able to get similar old hardware to test on, or can justify spending or money time on it. So probably not "High". Plus there is a workaround; just use "Ubuntu on Xorg".

Traumflug (mah-jump-ing) wrote :

Great to see you're into supporting "old" hardware. I'm pretty sure the times when people bought new hardware every other year are long gone. This G33 PC is a Core2Duo 2.1 GHz and it's perfectly up to speed for all the daily tasks, including software development.

"Older" hardware also comes with advantages. Just try to get something like CoreBoot running on recent hardware - it won't work. There's a reason why many hackers still use IBM ThinkPads.

And then there's the observation that newer hardware isn't all high end. Instead of faster and faster hardware, newer trends go into smaller form factors and shared hardware. Think of MiniITX boards, Raspberry Pis, BeagleBones or virtual machines. They do what they're expected to do and some have no OpenGL at all. Certainly they should be able to run Ubuntu. Xorg is expected to go away, so Wayland bugs have to be fixed sooner or later.

Back to the bug: having more capable hardware might even be an advantage for solving this bug. If OpenGL features shaders, one can turn this feature off, but one can't turn it on on hardware not featuring shaders. ... and I'm not too sure about the last one. Mesa has software renderers.

I've searched for the error messages logged:

$ grep -rn 'linking with uncompiled shader' /usr
Binary file /usr/lib/i386-linux-gnu/dri/r200_dri.so matches
Binary file /usr/lib/i386-linux-gnu/dri/nouveau_vieux_dri.so matches
...

13 of 18 drivers existing in each, i386 and x86_64, match, including i915 and i965.

I've looked into gnome-shell sources. To my surprise I found not kind of a traditional application there, but lots of CSS and JavaScript. Not too bad, I'm fairly good at web development.

Next plan is to remove all code which mentions 'shader' in the C sources and see whether this makes the error messages going away.

And if somebody happens to know whether this JS stuff can use shaders, too, please let me know.

Traumflug (mah-jump-ing) wrote :

Success! Applying the attached Diff keeps gnome-shell working for Xorg, still makes these shader compilation errors going away. More of this success see next comment here.

This Diff is not a solution, of course, but it should narrow down the problematic area a lot.

Traumflug (mah-jump-ing) wrote :

Success, part II:

When attempting a Wayland session, the relevant syslog section grew from 107 lines to 396 lines. 'gnome-shell' messages are gone, it looks like a session gets actually started. And then there are now a lot of messages like this one:

Oct 31 18:08:01 piccard gnome-screensav[2194]: Anzeige kann nicht geöffnet werden:
Oct 31 18:08:01 piccard org.gnome.SettingsDaemon.Power.desktop[2208]: Anzeige kann nicht geöffnet werden:
Oct 31 18:08:01 piccard org.gnome.SettingsDaemon.Clipboard.desktop[2242]: Anzeige kann nicht geöffnet werden:

"Anzeige kann nicht geöffnet werden" = "can't open display".

So far no idea how this display should be set/activated/opened.

Daniel van Vugt (vanvugt) wrote :

Let me emphasise that I have been the champion of supporting "older" hardware. I have spent weeks of my life just getting Mir working on the original Atom chips. And before that even trying to support Pentium 3's.

But the decision isn't up to me. My work on Pentium 3 graphics was cut off by Mesa (v8.0?) dropping support for the hardware. And my work on the original Atoms is now also nullified by Ubuntu dropping support for 32-bit installations. I have tried really hard to make sure we can support everyone's hardware, but there are other opposing forces.

On the simple matter of priorities though, I think we need to be paying more attention to Ubuntu 17.10's issues on Radeon and Nvidia hardware more than this. Simply because many more people are affected by those problems.

Traumflug (mah-jump-ing) wrote :

Daniel, your current efforts apparently put much emphasis on alienating users capable of fixing bugs. Also on getting rid of allies for low end hardware support.

I really wish you had put half as much efforts into explaining the software situation a bit. For example, what does this "cannot open display" mean? To my understanding, Wayland has no display server. What could get into the way of opening this display? How could one mimick a Wayland session from within a Xorg session? How could one start something Wayland-graphical from the recovery console (which is apparently the only way to get a command line without the display being occupied)?

Elaboration on that would really help. And also fix bugs for these people believing that they need a dedicated graphics card.

Daniel van Vugt (vanvugt) wrote :

I fully agree this bug is valid and needs to be fixed. I only disagree with Sebastian's selection of High importance in the bigger picture.

"cannot open display" either means it's an X app and XOpenDisplay failed (Xwayland isn't running because mutter failed to start). Or it means it's a native Wayland client and it can't start because mutter failed to start. Either way, "cannot open display" is an expected error that's a side-effect of this bug (mutter failed to start). But it's not the cause of this bug and not relevant.

I have some older hardware laying around that might experience this or similar issues. So I'll try to get to testing it out before we're too far into the new year.

Traumflug (mah-jump-ing) wrote :

> "cannot open display" either means ...

Thank you! This is valuable information.

So far I thought that the bug is about gnome-shell not starting. With this solved, it's now mutter. Well, interesting adventure game :-)

Traumflug (mah-jump-ing) wrote :

With 18.04 the situation got worse. Apparently, the login screen tries to run now on Wayland as well, so the opportunity to turn it off is gone. Booting simply stops at the Ubuntu logo, with the first of these five dots filled.

Booting in recovery mode, then choosing 'continue'(?) gives a black screen most of the time, with some text blinking up shortly from time to time. Managed to catch it, see attached picture.

The only way I could get this PC up running after the 18.04 upgrade was to boot into recovery mode, then get a root shell, then edit /etc/gdm3/custom.conf to remove the comment sign in front of WaylandEnable..., then reboot.

summary: - Wayland does not start up on "Integrated Graphics Chipset: Intel(R)
- G33": Shader compilation failed
+ Wayland sessions (including the login screen itself) don't start up on
+ older Intel GPUs.
Changed in mutter (Ubuntu):
importance: Undecided → High
status: New → Triaged
tags: added: bionic
description: updated

Bug confirmed by more users, including:

Intel(R) Core(TM)2 CPU T5500 @ 1.66GHz
Intel(R) Atom(TM) CPU N550 @ 1.50GHz

This is reminiscent of bug 1583532, so we may need to review the shaders used in mutter/clutter/cogl.

I now agree with "High" importance.

summary: - Wayland sessions (including the login screen itself) don't start up on
- older Intel GPUs.
+ Wayland sessions (including the login screen itself in 18.04 onward)
+ don't start up on older Intel GPUs.
summary: - Wayland sessions (including the login screen itself in 18.04 onward)
- don't start up on older Intel GPUs.
+ Wayland sessions (including the login screen itself) don't start up on
+ older Intel GPUs.
Daniel van Vugt (vanvugt) wrote :

Also recently seen on:

Intel(R) Core(TM)2 Duo CPU E6750 @ 2.66GHz
Intel(R) Pentium(R) M processor 1.86GHz
Intel(R) Core(TM)2 Duo CPU E4500 @ 2.20GHz

summary: Wayland sessions (including the login screen itself) don't start up on
- older Intel GPUs.
+ older Intel GPUs (pre-Sandy Bridge)
Daniel van Vugt (vanvugt) wrote :

And:

Intel Core2 Duo E7200

Yousef Saber (yousefsaber) wrote :

I'm facing the same problem on my Intel Core 2 duo E8500 with G33 graphics Ubuntu 18.04 can't boot

shouldn't canonical at least notified us that Bionic Beaver doesn't work on old hardware so no one tries it ??

Oh, Ubuntu does boot on such hardware just fine. And seeing how well it works I'd feel guilty of wasting money and polluting the environment when buying newer hardware.

It does not boot all up into native Wayland. Nevertheless, one can run X11 just fine.

How to turn Wayland off? Key is to disable it in /etc/gdm3/custom.conf. Code ('WaylandEnable=false') is already there, just commented out. Accordingly, to get the hardware booting all up to the desktop, proceed as following (written from head, so actual wording might be slightly different):

- Turn the PC on.
- As soon as the Grub boot selection screen appears, use up and down arrows on the keyboard to select 'Ubuntu (recovery mode)'.
- Hit 'Enter'.
- After a while, another selection screen appears. Select 'Enable Network', which happens to be a simple way to re-mount the boot disk in read-write mode.
- Back on the same selection screen, select a root shell.
- Being at the root shell, enter 'vi /etc/gdm3/custom.conf'.
- Using arrow keys, navigate to the line reading '#WaylandEnable=false'.
- Make sure the cursor is over this first '#'.
- Hit the 'x' key once, the '#' should disappear.
- Enter ':wq'. This gets you back to the root shell.
- Type 'reboot' and hit Enter.

From there on, your hardware should boot all into the desktop as if it had been the case all the time.

Another way to get this file edited is to boot another OS on that hardware or to physically connect the disk elsewhere, of course.

Yousef, Canonical should and does notify people of known problems in the release notes [1]. We only failed/forgot to mention this one and its workaround in the release notes. Although scrolling up, it appears nobody figured out what the workaround was until after 18.04 was released. And even then only one person was experiencing the bug at the time. It took more time to get more bug reports and a clearer idea that it was specific to early-generation Intel GPUs. At the moment I'm having authentication problems and am unable to update the release notes...

As for a fix, it looks like upstream have found the problem just last night [2]. So hopefully a proper fix will be available to try soon.

[1] https://wiki.ubuntu.com/BionicBeaver/ReleaseNotes#Known_issues
[2] https://gitlab.gnome.org/GNOME/mutter/issues/127

Changed in mesa (Ubuntu):
status: New → Triaged
importance: Undecided → High
summary: - Wayland sessions (including the login screen itself) don't start up on
- older Intel GPUs (pre-Sandy Bridge)
+ Login screen never appears on early generation Intel GPUs (Core2 and
+ Atom etc)
Changed in mesa (Ubuntu):
milestone: none → ubuntu-18.04.1
description: updated
Daniel van Vugt (vanvugt) wrote :

The fix (we hope it works for you all) has finally landed upstream:
https://gitlab.gnome.org/GNOME/mutter/commit/f7af32a3eaef

Changed in mesa (Ubuntu):
milestone: ubuntu-18.04.1 → none
no longer affects: mesa (Ubuntu)
Traumflug (mah-jump-ing) wrote :

Great news! Thank you for your work.

tags: added: fixed-in-mutter-3.29.91
tags: added: cosmic
no longer affects: gnome-shell (Ubuntu)
Eugene Romanenko (eros2) wrote :

No fix in proposed for bionic yet?

Updated libmutter/gnome-shell from proposed, commented WaylandEnable=false in /etc/gdm3/custom.conf - still black screen on Fujitsu M2010 netbook.

Now that you remind me, I have not had this issue with either 16.04 or
18.04 in several days., running both on this old laptop.

Thanks

On 08/14/2018 11:48 PM, Daniel van Vugt wrote:
> ** Tags added: fixed-in-mutter-3.29.91
>
> ** Tags added: cosmic
>
> ** No longer affects: gnome-shell (Ubuntu)
>

Daniel van Vugt (vanvugt) wrote :

The fix is in mutter version 3.29.91 ... I think you will find that's not in any Ubuntu version yet.

D.J. Galanides (hector014) wrote :

How interesting. No idea in that case.

On 08/15/2018 09:15 PM, Daniel van Vugt wrote:
> The fix is in mutter version 3.29.91 ... I think you will find that's
> not in any Ubuntu version yet.
>

Daniel van Vugt (vanvugt) wrote :

1. If you have applied the workaround at the top of the bug then you won't hit it any more.

2. If your system is experiencing a crash in the eglnative (Wayland) code on startup then it will automatically fall back to using Xorg and you will never hit this bug.

3. Finally, if you are subscribed to the wrong bug (ie. you don't use a Core2 or Atom CPU) then your issues was something different and might have been resolved elsewhere.

Yousef Saber (yousefsaber) wrote :

can you please give me details on how to update to mutter v3.29.91?

Daniel van Vugt (vanvugt) wrote :

That version containing the fix has not been released yet :)

https://gitlab.gnome.org/GNOME/mutter/tags

Yousef Saber (yousefsaber) wrote :

alright thank you for the last additional information

Ubuntu 18.04 runs fine now with unity desktop environment selected as my main desktop manager

meanwhile I'll wait for the next version of GNOME to run it on my device

Daniel van Vugt (vanvugt) wrote :

The workaround at the top of the bug should allow you to use GNOME right now.

Yousef Saber (yousefsaber) wrote :

it isn't that simple my default desktop manager must be put to lightdm

sudo dpkg-reconfigure lightdm

and in the login session I must choose Ubuntu desktop environment ( which is GNOME ) and the system reboot successfully boot to GNOME automatically every time

you must deal with this weird behavior and improve the experience

and thanks for your hard work

Daniel van Vugt (vanvugt) wrote :

Wait, mutter 3.29.91 was released to Ubuntu 18.10 yesterday.

Can anyone confirm the issue is fixed in 18.10 ?

Changed in mutter (Ubuntu Cosmic):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mutter (Ubuntu Bionic):
status: New → Confirmed
Eunheui (yohno) wrote :

Hi, I'm pretty sure that this is the bug that has been affecting me -- my pc is like 10 years old, with Intel Core 2 vPro, originally came with Windows Vista. When I upgraded to 18.04 LTS from 16.04, I encountered this issue.

I applied the workaround at the top of this page (uncommenting WaylandEnable=false), but I still can't get to the login screen. I see the arrow cursor, but nothing else.

Daniel van Vugt (vanvugt) wrote :

If you have applied the workaround and still can't get things working then please open a new bug by:

  1. Connect to a (wired) network.
  2. Ctrl+Alt+F4 or similar and login to the console.
  3. Run: ubuntu-bug gdm3

Eunheui (yohno) wrote :

Thanks, I will. (At the moment, I'm having trouble sending my report. The system says that my SSL handshake is not good.)

I've noticed that once I Ctrl+Alt+F4 and log myself in, I have no problem startx-ing and using 18.04 graphically.

Yousef Saber (yousefsaber) wrote :

did anyone submit a bug report on Gitlab

https://gitlab.gnome.org/GNOME/mutter/issues

Daniel van Vugt (vanvugt) wrote :

Yes. On Gitlab the bug is already fixed (in mutter version 3.29.91):

https://gitlab.gnome.org/GNOME/mutter/merge_requests/160
https://gitlab.gnome.org/GNOME/mutter/issues/127

This is fixed upstream as said, and I'll cherry-picked to the 3.28 branch upstream [1], so will be backported to bionic soon.

Ideally we were waiting for an upstream point release, to make this easier to get in ubuntu, but if that won't be done quick enough we'll cherry pick the commit.

[1] https://gitlab.gnome.org/GNOME/mutter/commit/1276cc97d1e

Changed in mutter (Ubuntu Bionic):
status: Confirmed → Triaged
importance: Undecided → High
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
tags: added: fixed-in-mutter-3.28.4
Yousef Saber (yousefsaber) wrote :

GNOME Shell 3.30 has been announced

when will canonical release it for Ubuntu ?

Daniel van Vugt (vanvugt) wrote :

Ubuntu 18.10 already uses version 3.30.

Ubuntu 18.04 is unlikely to be upgraded from 3.28 any time soon.

Yousef Saber (yousefsaber) wrote :

did anyone try to test mutter 3.30 to see if the issue is fixed or not

I don't want to be shocked that the issue isn't fixed when 18.10 is released then I'll have to wait for another 6 months for the fix

Yousef Saber (yousefsaber) wrote :

installed 18.10 development branch which contained mutter v3.30 and yes it fixed the issue

the login screen now appears even when choosing gdm3 as the default desktop manager

sudo dpkg-reconfigure gdm3

A Raghuram (araghuramindia) wrote :

Looks like the next point release i.e. 18.04.2 is scheduled to be along with release of 18.10 which is likely to be in Feb-19. Will we have to wait for the fix until then ? What are the chances of backporting the fix to 3.28 branch (as mentioned by Mr.Marco Trevisan) before Feb-19 ?

I always prefer to install only LTS stable releases and therefore, will not be installing 18.10.

Tom Reynolds (tomreyn) wrote :

Off-topic but possibly necessary context:

Ubuntu (major) releases are time based. The time of the release is indicated in the release version. As such, Ubuntu 18.10 will be released in year (20)18, month 10.
More precise release dates are provided at https://wiki.ubuntu.com/Releases

Point releases of LTS versions do not necessarily coincide with other releases. Ubuntu 16.04.2 LTS was released on February 16, 2017 (so between Ubuntu 16.10 (Oct '16) and Ubuntu 17.04 (Apr '17)), which suggests that Ubuntu 18.04.2 may release in February 2019.

Will Cooke (willcooke) on 2018-10-01
tags: added: rls-cc-incoming
no longer affects: gnome-shell
description: updated
Yousef Saber (yousefsaber) wrote :

Can't believe that we had to wait for six months for a fix for this horrible issue

Traumflug (mah-jump-ing) wrote :

I can confirm that upgrading to 18.10 solves this issue. While there are still a few caveats (e.g. toolbar becoming intransparent when launching an application), the hardware which failed before can now log into 'Ubuntu' as well as 'Ubuntu on Wayland'.

Well done, Ubuntu, thank you very much!

A Raghuram (araghuramindia) wrote :

Has this been fixed in 18.04.1 as well ? Please confirm.

Daniel van Vugt (vanvugt) wrote :

No the bug is not fixed in 18.04 yet.

Yousef Saber (yousefsaber) wrote :

this bug won't ever be solved in 18.04 because Canonical won't update its archive or repository to mutter 3.30 anyone who wants to fix this issue must upgrade to Ubuntu 18.10

rew (r-e-wolff) wrote :

Well that's annoying: I need an LTS for a project. (The 5 years support frame for the LTS versions is too short, but we'll have to get by....) so the remaining option is to wait for 20.4, right?

Daniel van Vugt (vanvugt) wrote :

That's incorrect. Ubuntu 18.04 will get the fix because the fix is small and should be easy to backport to 3.28. I don't know the timeframe though.

Daniel van Vugt (vanvugt) wrote :

Actually the fix is in the next future point release of 3.28 already as Marco pointed out:

https://gitlab.gnome.org/GNOME/mutter/commit/1276cc97d1e

It appears mutter version 3.28.4 will have the fix.

Traumflug (mah-jump-ing) wrote :

When putting emphasis on a stable system, staying with Xorg is probably a good idea for the time being. While I use Xwayland daily now, it definitely comes with a number of quirks.

- Transparency comes and goes. For example, moving a window to near the top of the screen makes the top menu bar intransparent.

- Sometimes shadows flicker around, which probably want to be window frame shadows, but get misplaced.

- Copy & Paste by left/middle mouse button sometimes works, sometimes not. Be prepared to use Ctrl-C/Ctrl-V more often and/or to check every pasted text.

- gnome-shell collects a lot more memory. Currently at ~500 MB after two days of usage.

- Commodities like 'sudo synaptic' no longer work, it needs 'xhost +local:; sudo synaptic'. sudo somehow doesn't forward screen settings.

Ignoring such quirks, it runs at least stable. No crashes so far. And screen drawing happens faster.

Changed in mutter (Ubuntu Bionic):
status: Triaged → In Progress
description: updated
tags: added: testcase
Changed in mutter (Ubuntu Bionic):
status: In Progress → Fix Committed

Hello Traumflug, or anyone else affected,

Accepted mutter into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mutter/3.28.3-2~ubuntu18.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed verification-needed-bionic
Crao (come-desplats) wrote :

Bug fixed for me on Intel(R) Atom(TM) CPU N550 @ 1.50GHz with mutter 3.28.3-2~ubuntu18.04.2

tags: added: verification-done-bionic
removed: verification-needed-bionic
tags: added: verification-done
removed: verification-needed
To post a comment you must log in.