Please provide current version of logrotate

Bug #64964 reported by Uwe Menges on 2006-10-09
4
Affects Status Importance Assigned to Milestone
logrotate (Ubuntu)
Undecided
Martin Pitt

Bug Description

Binary package hint: logrotate

Hi kubuntu package maintainers!

The version currently coming with kubuntu 6.0.6 is logrotate 3.7.1-2.
The current version seems to be 3.7.4-7 and the latest 'upstream release' is 3.7.3-1, dated Sat Nov 12 2005.

I'm mainly missing the 'yearly' option:

* Thu Aug 18 2005 Peter Vrabec <email address hidden> 3.7.2-2
  - allow yearly rotations(#134612)

But there were also numerous bug fixes according to the changelog.
The current release is 3.7.6-3 on Fedora, see
http://fr2.rpmfind.net/linux/rpm2html/search.php?query=logrotate for the latest version.

Yours, Uwe

Related branches

Caroline Ford (secretlondon) wrote :

Subscribed Ubuntu Backports as you want logrotate backported into Dapper.

Edgy has 3.7.1-3, which doesn't seem much better for you.

Uwe Menges (uwe-menges) wrote :

I take this as 'confirmed' as everyone can see in the package list that it's really old.

description: updated
Changed in logrotate:
status: Unconfirmed → Confirmed
Uwe Menges (uwe-menges) wrote :

I am not familiar with the process of how packages come into kubuntu. Would your team transport fedora's srpm into (k)ubuntu package directly, applying the Debian patches, or would you wait for upstream Debian packager doing so?

If the latter, I doubt there will be progress without further intervention, as the newest line at http://packages.qa.debian.org/l/logrotate.html indicates ("[2006-04-22] logrotate 3.7.1-3 MIGRATED to testing (Britney)" - compare this to the respective version in fedoras srpm .spec: "* Mon Dec 06 2004 Peter Vrabec <email address hidden> - 3.7.1-3
- compressed logfiles and logrotate (#140353)").

But then I would know I have to file a bug against Debian, too (or instead).

BTW, I don't need a backport, I'd like to get a recent version into one of the next (k)ubuntu releases. Nobody would accept a 2-year old kernel, or samba package with a new release.

John Dong (jdong) wrote :

Unsubscribing Backporters from this bug. There is no newer version in Feisty, especially not the version the original filer is asking for.

Please resubscribe when Feisty gets a newer upsream release of logrotate.

Daniel Hahler (blueyed) on 2008-02-20
description: updated
Uwe Menges (uwe-menges) wrote :

Sadly there seems to be no progress in this case. We have 8.04 now, still with logrotate 3.7.1-3.

Can someone advise me how to proceed further, where to address an update-this-package-please request?

Uwe Menges (uwe-menges) wrote :

I just upgraded to 8.10, the version there is 3.7.1-5ubuntu1. I subscribed Martin Pitt to this bug. As he committed the last change, he may be the right one to provide a current package (most current seems to be 3.7.7-9.2 according to http://fr2.rpmfind.net/linux/rpm2html/search.php?query=logrotate .

Martin Pitt (pitti) wrote :

Will do. Incidentally, Debian experimental has 3.7.7 now. \o/

Changed in logrotate:
assignee: nobody → pitti
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package logrotate - 3.7.7-1ubuntu1

---------------
logrotate (3.7.7-1ubuntu1) jaunty; urgency=low

  * Merge with Debian experimental (LP: #64964). Remaining Ubuntu changes:
    - debian/control: Drop mailx to Suggests for Ubuntu; it's only used on
      request, and we don't configure an MTA by default.

logrotate (3.7.7-1) experimental; urgency=low

  * New upstream release (based on upstream 3.7.7-1)
    + The source code has been run through "indent" which makes looking
      for differences "interesting".
    + Debian patches no longer required:
      - compress-499502.patch: upstream has fix.
      - globfix-277652: upstream has a fix. In addition, logrotate will
        attempt to continue rather than stopping dead if there are any
        errors in its config files. (Closes: #285858)
      - script-argument.patch: upstream has fixed this.
      - rh-dateext.patch: upstream has it.
      - rh-maxage.patch: upstream has it.
      - rh-noTMPDIR.patch: upstream has it.
      - rh-selinux.patch: upstream has it.
      - taboo-to-debug.patch: upstream has it.
      - scripterrors.patch: upstream has fix.
      - man-lastaction.patch: upstream has it.
      - man-mailtypo.patch: upstream has it.
      - man-rh-1.patch: upstream has it.
      - man-333996.patch: upstream has fix.
    + New features:
      - yearly rotations
      - minsize
      - optionally use shred when deleting files
      - dateformat, to control the date format when using dateext
      - Tabooexts can be wildcards.
    + Upstream fixes:
      - Manpage fixed for example using /var/log/news. (Closes: #339502)

  * dateext-504079.patch: If dateext is used with delaycompress and
    mailfirst, the wrong filename (one that has compressext added) is
    attempted to be mailed. (Closes: #504079,#433496)
  * dst.patch: Update to add the current "hour" to the struct tm, so
    that DST changes don't cause the date to be off by one.
    (Closes: #416177)
  * Corrected upstream URL (Closes: #410420)
  * deb-taboos.patch: added .cfsaved to taboo list. (Closes: #463581)

 -- Martin Pitt <email address hidden> Fri, 07 Nov 2008 14:57:09 +0100

Changed in logrotate:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers