Ubuntu

[Dell Studio XPS 1340,Alienware m17x] Kernel panic with 3.0.0-19 and 3.2.0-18 on boot

Reported by Daniel Manrique on 2012-04-17
146
This bug affects 37 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
High
Steve Apodaca
Oneiric
High
Luis Henriques
Precise
High
Luis Henriques

Bug Description

Steps to reproduce:

- Install Ubuntu 11.10 on the XPS 1340
- Reboot, it boots fine into the graphical desktop
- Enable -proposed
- Install latest kernel from proposed (3.0.0-19)
- Reboot

Expected result:
- Desktop!

Actual result:
- Kernel panics with blinking capslock light before reaching the desktop.

I asked the kernel to log to console and it did spit out trace from a kernel panic, but all I got were the last few lines in a picture.

Things I tried:

- Install the latest stable Oneiric kernel (3.0.0-17). This boots fine into the desktop.
- Give the noapic parameter to the kernel (3.0.0-19). This also boots fine.
- I tried xforcevesa and noacpi, each on their own, and it didn't help, it still crashes.

I'll attach the picture of the panic in a moment.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: linux-image-3.0.0-19-generic 3.0.0-19.32
ProcVersionSignature: Ubuntu 3.0.0-19.32-generic 3.0.27
Uname: Linux 3.0.0-19-generic i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.23-0ubuntu4
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: NVidia [HDA NVidia], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 1797 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'NVidia'/'HDA NVidia at 0xf0880000 irq 5'
   Mixer name : 'Nvidia MCP79/7A HDMI'
   Components : 'HDA:111d7675,10280271,00100103 HDA:10de0007,10280271,00100100'
   Controls : 20
   Simple ctrls : 11
Date: Tue Apr 17 17:17:36 2012
HibernationDevice: RESUME=UUID=38a72593-afe3-4d17-be32-2357041068f6
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 002: ID 05ca:18a0 Ricoh Co., Ltd
MachineType: Dell Inc. Studio XPS 1340
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-19-generic root=UUID=f4c227c6-c296-4a70-974c-136366ff8495 ro quiet splash initcall_debug vt.handoff=7 noapic
RelatedPackageVersions:
 linux-restricted-modules-3.0.0-19-generic N/A
 linux-backports-modules-3.0.0-19-generic N/A
 linux-firmware 1.60.1
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 09/08/2009
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A11
dmi.board.name: 0K183D
dmi.board.vendor: Dell Inc.
dmi.board.version: A11
dmi.chassis.asset.tag: 1234567890
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A11
dmi.modalias: dmi:bvnDellInc.:bvrA11:bd09/08/2009:svnDellInc.:pnStudioXPS1340:pvrA11:rvnDellInc.:rn0K183D:rvrA11:cvnDellInc.:ct8:cvrA11:
dmi.product.name: Studio XPS 1340
dmi.product.version: A11
dmi.sys.vendor: Dell Inc.

Daniel Manrique (roadmr) wrote :
Brad Figg (brad-figg) on 2012-04-17
Changed in linux (Ubuntu):
status: New → Confirmed
Daniel Manrique (roadmr) wrote :
Ara Pulido (apulido) on 2012-04-18
tags: added: regression-proposed

This could be related to, or infact a duplicate of, https://bugs.launchpad.net/ubuntu/+source/linux/+bug/974412

Daniel, the InfraRed reciever (which would appear to be built in to the XPS) may be the culprit. If you could switch it off in the BIOS and retest that might tell us whether that is infact the problem. Alternatively, blacklist the 'ite-cir' module.

tags: added: needs-bisect needs-upstream-testing

Hi Brendan and Daniel,

Can you confirm if you see this same issue with Precise on this system (ie. 3.2.0-23.36 kernel)? It looks similar to the issue being seen on bug 972723. The bug reporters there have documented a workaround and analysis in comments #10 and #11 in bug 972723. They have also forwarded the issue upstream.

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/972723

I'd like to know if this affects the soon to be 12.04 release asap. If so, I'd like to propose disabling this driver for Precise until a proper fix can be indentified.

Daniel Manrique (roadmr) wrote :

OK, as per Brendan's suggestion I blacklisted the ite-cir module, by creating /etc/modprobe.d/blacklist-ite-cir.conf with this content:

blacklist ite_cir

then I rebooted with the 3.0.0-19 kernel and it boots fine!

And to confirm that the ite-cir module is the one causing the problem, I did

sudo modprobe ite_cir

I immediately get a crash dump to a text console, panic and freeze.

I guess the next step on this one is to try the mainline kernel, I'll get to that ASAP and report back.

Daniel Manrique (roadmr) wrote :

Note that this is also happening on Precise, see bug 972723.

Changed in linux (Ubuntu):
importance: Undecided → Medium
importance: Medium → High
tags: added: kernel-da-key

Confirmed with Daniel that this is present in Precise. Disabling the IR reciever is not going to block certification so we wouldn't have any objections.

tags: added: kernel-key
tags: added: rls-mgr-p-tracking
Changed in linux (Ubuntu Oneiric):
importance: Undecided → High
status: New → Confirmed

Brendan and Daniel,

I've posted a Precise test kernel, please let me know your feedback as soon as possible. Thanks.

http://people.canonical.com/~ogasawara/lp984387/i386/

Brendan and Daniel,

Could we also get testing with the following as well. It it more along the lines of a proper fix:

http://people.canonical.com/~henrix/lp984387-postponeirq/i386/

Daniel Manrique (roadmr) wrote :

@Leann:

I tested with Precise's daily image, kernel 3.2.0-23.36, and I still see this problem on boot, so yes, it's present on recent Precise builds.

Also, I tried blacklisting the module in the kernel command line, if I make it so the module doesn't load on boot, then the system boots fine.

Then I booted with the test kernel from comment #9, this also boots OK although, of course, the ite_cir is not loaded and indeed, not even available (modprobe ite_cir says module not found).

This test kernel version is:

 3.2.0-23-generic #37-lp984387v1

Let me know if you need more tests done.

Thanks!

Daniel Manrique (roadmr) wrote :

Hi,

I tested again with the kernel from #10, the system boots OK, and once it's booted I can see the ite_cir module :

ubuntu@200912-4906:~$ lsmod |grep ite_cir
ite_cir 24743 0
rc_core 21263 10 ir_lirc_codec,ir_mce_kbd_decoder,ir_sony_decoder,ir_jvc_decoder,ir_rc6_decoder,ir_rc5_decoder,ir_nec_decoder,rc_rc6_mce,ite_cir
ubuntu@200912-4906:~$

Kernel version is:

Linux version 3.2.0-23-generic (root@tangerine) (gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu5) ) #37~postponeirq SMP Wed Apr 18 16:30:58 UTC 2012

Thanks again, and let me know if you want me to test more stuff.

Luis Henriques (henrix) wrote :

I've uploaded another test kernel for Oneiric with the same fix here:

http://people.canonical.com/~henrix/lp984387-postponeirq-oneiric/

Could someone running Oneiric give it a try and report back?

summary: - [Dell Studio XPS 1340] Kernel panic with 3.0.0-19 on boot
+ [Dell Studio XPS 1340,Alienware m17x] Kernel panic with 3.0.0-19 and
+ 3.2.0-18 on boot
Daniel Manrique (roadmr) wrote :

Hi Luis,

Sorry for the delay in testing this.

I tested the Oneiric kernel with the fix on two of our three Dell XPS laptops, one of which is the one from the original report.

- Kernel 3.0.0-12 boots fine
- When upgrading to 3.0.0-19 from -proposed, the system panics on boot as observed
- With your fixed kernel, the system boots correctly and the ite_cir module is loaded:

$ uname -a && lsmod |grep ite_cir
Linux 200912-4906 3.0.0-19-generic #33~postponeirq SMP Wed Apr 18 21:16:51 UTC 2012 i686 i686 i386 GNU/Linux
ite_cir 24743 0
rc_core 25797 9 rc_rc6_mce,ir_lirc_codec,ir_sony_decoder,ir_jvc_decoder,ir_rc6_decoder,ir_rc5_decoder,ite_cir,ir_nec_decoder

On the other XPS I get the same (note only the hostnames are different):
Linux 200910-4256 3.0.0-19-generic #33~postponeirq SMP Wed Apr 18 21:16:51 UTC 2012 i686 i686 i386 GNU/Linux
ite_cir 24743 0
rc_core 25797 9 ir_lirc_codec,ir_sony_decoder,ir_jvc_decoder,ir_rc6_decoder,rc_rc6_mce,ir_rc5_decoder,ir_nec_decoder,ite_cir

So it looks like the Oneiric fix is also valid.

Thanks, let me know if you need other tests done :)

Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in linux (Ubuntu Precise):
status: Confirmed → Fix Committed
Changed in linux (Ubuntu Oneiric):
status: Confirmed → Fix Committed
assignee: nobody → Luis Henriques (henrix)
Changed in linux (Ubuntu Precise):
assignee: nobody → Luis Henriques (henrix)
Luis Henriques (henrix) wrote :

This bug is awaiting verification that the kernel for Oneiric in -proposed solves the problem (3.0.0-19.33). Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-oneiric' to 'verification-done-oneiric'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-oneiric
Daniel Manrique (roadmr) wrote :

Hi Luis,

I installed the new kernel on all my XPS 1340s (3 of them):

- Boot with a working kernel (3.0.0-12 for instance)
- apt-get update; apt-get dist-upgrade
  (this installs the new 3.0.0-19.33 kernel replacing 3.0.0-19.32)
- Reboot

All three systems rebooted fine (they didn't before, they kernel panicked with blinking caps lock). Upon booting I checked for presence of the ite_cir kernel module and it was there no problem.

I'll mark verification-done-oneiric as per your latest comment.

Thanks!

tags: added: verification-done-oneiric
removed: verification-needed-oneiric
Luis Henriques (henrix) wrote :

Daniel, that's great. Thanks for testing.

JorSol (jorsol) wrote :

Tested the new kernel on my XPS 1340 :

- Boot with kernel 3.0.0-17.
- upgrade using update-manager to kernel 3.0.0-19.33

Reboot with new kernel fine,

I will be testing on precise this weekend.

Thanks,

Hello Daniel, or anyone else affected,

Accepted linux into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

John Steele Scott (toojays) wrote :

Martin,

I can report that my XPS 1340 failed to boot with 3.2.0-23.36, but 3.2.0-24.37 from -proposed fixed the problem for me.

Martin Pitt (pitti) on 2012-04-26
tags: added: verification-done
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.2.0-24.37

---------------
linux (3.2.0-24.37) precise-proposed; urgency=low

  [ Herton Ronaldo Krzesinski ]

  * d-i: Add hid-logitech-dj to input-modules
    - LP: #975198
  * d-i: Add rtl8187 driver to nic-usb-modules
    - LP: #971719

  [ Ian Abbott ]

  * SAUCE: staging: comedi: Add module parameters for default buffer size
    - LP: #981234
  * SAUCE: staging: comedi: Add kernel config for default buffer sizes
    - LP: #981234

  [ K. Y. Srinivasan ]

  * SAUCE: hv_storvsc: Account for in-transit packets in the RESET path
    - LP: #978394

  [ Leann Ogasawara ]

  * [Config] Set CONFIG_COMEDI_DEFAULT_BUF_[SIZE_KB,MAXSIZE_KB]
    - LP: #981234

  [ Luis Henriques ]

  * SAUCE: ite-cir: postpone ISR registration
    - LP: #984387

  [ Manoj Iyer ]

  * SAUCE: Bluetooth: btusb: Add vendor specific ID (0489 e042) for
    BCM20702A0
    - LP: #980965

  [ Tim Gardner ]

  * Extract firmware module info during getabi
  * [Config] Remove hiq-quanta module references
    - LP: #913164
  * [Config] powerpc-smp: build in ATI and RADEON frame buffer drivers
    - LP: #949288

  [ Trond Myklebust ]

  * SAUCE: NFSv4: Ensure that the LOCK code sets exception->inode
    - LP: #974664
  * SAUCE: NFSv4: Ensure that we check lock exclusive/shared type against
    open modes
    - LP: #974664

  [ Upstream Kernel Changes ]

  * Input: psmouse - allow drivers to use psmouse_{de,}activate
    - LP: #969334
  * Input: psmouse - use psmouse_[de]activate() from sentelic and hgpk
    drivers
    - LP: #969334
  * Input: sentelic - refactor code for upcoming new hardware support
    - LP: #969334
  * Input: sentelic - enabling absolute coordinates output for newer
    hardware
    - LP: #969334
  * Input: sentelic - minor code cleanup
    - LP: #969334
  * Input: sentelic - improve packet debugging information
    - LP: #969334
  * Input: sentelic - filter taps in absolute mode
    - LP: #969334
  * drm/i915: Fixes distorted external screen image on HP 2730p
    - LP: #796030
  * NFSv4: Minor cleanups for nfs4_handle_exception and
    nfs4_async_handle_error
    - LP: #974664
  * NFSv4: Rate limit the state manager for lock reclaim warning messages
    - LP: #974664
  * HID: multitouch: merge quanta driver into hid-multitouch
    - LP: #913164
  * HID: usbhid: add quirk no_get for quanta 3008 devices
    - LP: #913164
 -- Leann Ogasawara <email address hidden> Tue, 24 Apr 2012 07:47:49 -0700

Changed in linux (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Alex Burfee (joop-wow) wrote :

i get this error when try to install ubuntu 12.04 using the image downloaded from ubuntu.com

it doesn't seem fixed. will there be another image uploaded?

i have dell studio xps 1340

JorSol (jorsol) wrote :

@Alex Burfee, sadly the fix don't make it to the final version, but the patch is already released in the kernel 3.2.0-24.37 (the final version comes with 3.2.0-23)

You should
1. wait for 12.04.1 to be released on July 19, or

2. blacklist the problematic module following instruccions in comment #6, for this you must start with a live cd and add the blacklist to the /etc/modprobe.d/ of your actual instalation (not the modprobe.d of the live cd) and reboot.
2.1 when boot to the desktop update your system, and if you need the ite-cir then remove the file for the blacklist.

Daniel Manrique (roadmr) wrote :

A workaround to be able to install Precise on these systems:
- Boot with a 12.04 Live CD or USB.
- Press a key to acces the options, select your language.
- Press f6 to edit the commandline (advanced options), then press esc to dismiss the popup.
- On the kernel command line, after the --, add ite_cir.blacklist=yes
- Press enter

This will allow you to boot into the Live environment and try out or install 12.04.

On first boot, you'll be affected by this problem again, so:
- When booting, right after your PC's POST routine finishes, press the right SHIFT key. Keep it pressed until the GRUB menu appears.
- Press 'e' to edit parameters for the boot entry.
- Move down to the "linux" line (next to last), then move to the end of that line.
- again, type ite_cir.blacklist=yes at the end of this line
- Press ctrl-x.

This should have you booted into your new system. From here you can do the workaround from comment #6 to make the blacklisting permanent.

anna (aaaia33) on 2012-04-28
Changed in linux (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Changed in linux (Ubuntu Oneiric):
status: Fix Released → Fix Committed
Alex Burfee (joop-wow) wrote :

This is really disappointing... I think i'll stay away from it... I heard people with dell studio facing the same problem.

Launchpad Janitor (janitor) wrote :
Download full text (24.1 KiB)

This bug was fixed in the package linux - 3.0.0-19.33

---------------
linux (3.0.0-19.33) oneiric-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #985736

  [ Luis Henriques ]

  * SAUCE: ite-cir: postpone ISR registration
    - LP: #984387

linux (3.0.0-19.32) oneiric-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #974368

  [ Brad Figg ]

  * SAUCE (no-up) Provide a param for allowing the BIOS to handle changing
    the brightness on AC/battery status changes.
    - LP: #949311
  * SAUCE (no-up) Quirk for enabling backlight hotkeys on Samsung N150P
    - LP: #875893

  [ Daniel Vetter ]

  * SAUCE: (drop after 3.5) drm/i915: reinstate GM45 TV detection fix
    - LP: #638939

  [ Herton Ronaldo Krzesinski ]

  * SAUCE: (no-up) Reinstate missing hunk from nx emulation
    - LP: #972821

  [ Tim Gardner ]

  * SAUCE: ubuntu drivers: use UMH_WAIT_PROC consistently
    - LP: #963685
  * SAUCE: disable_nx should not be in __cpuinitdata section for X86_32
    - LP: #968233
  * SAUCE: (no-up) remove __initdata from vesafb_fix
    - LP: #969309

  [ Upstream Kernel Changes ]

  * usermodehelper: use UMH_WAIT_PROC consistently
    - LP: #963685
  * usermodehelper: introduce umh_complete(sub_info)
    - LP: #963685
  * usermodehelper: implement UMH_KILLABLE
    - LP: #963685
  * usermodehelper: kill umh_wait, renumber UMH_* constants
    - LP: #963685
  * usermodehelper: ____call_usermodehelper() doesn't need do_exit()
    - LP: #963685
  * kmod: introduce call_modprobe() helper
    - LP: #963685
  * kmod: make __request_module() killable
    - LP: #963685
  * x86, tsc: Fix SMI induced variation in quick_pit_calibrate()
    - LP: #965586
  * ata_piix: Add Toshiba Satellite Pro A120 to the quirks list due to
    broken suspend functionality.
    - LP: #886850
  * ACPICA: Fix regression in FADT revision checks
    - LP: #883441
  * ASPM: Fix pcie devices with non-pcie children
    - LP: #961482
  * USB: option: Add MediaTek MT6276M modem&app interfaces
    - LP: #971808
  * USB: option driver: adding support for Telit CC864-SINGLE, CC864-DUAL
    and DE910-DUAL modems
    - LP: #971808
  * USB: option: make interface blacklist work again
    - LP: #971808
  * USB: option: add ZTE MF820D
    - LP: #971808
  * USB: ftdi_sio: fix problem when the manufacture is a NULL string
    - LP: #971808
  * USB: ftdi_sio: add support for BeagleBone rev A5+
    - LP: #971808
  * USB: Microchip VID mislabeled as Hornby VID in ftdi_sio.
    - LP: #971808
  * USB: ftdi_sio: new PID: Distortec JTAG-lock-pick
    - LP: #971808
  * USB: ftdi_sio: add support for FT-X series devices
    - LP: #971808
  * USB: ftdi_sio: new PID: LUMEL PD12
    - LP: #971808
  * powerpc/usb: fix bug of kernel hang when initializing usb
    - LP: #971808
  * usb: musb: Reselect index reg in interrupt context
    - LP: #971808
  * usb: gadgetfs: return number of bytes on ep0 read request
    - LP: #971808
  * USB: gadget: Make g_hid device class conform to spec.
    - LP: #971808
  * futex: Cover all PI opcodes with cmpxchg enabled check
    - LP: #971808
  * sysfs: Fix memory leak in sysfs_sd_setsecdata().
    - LP: #971808
  * tty: ...

Changed in linux (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Joseph Salisbury (jsalisbury) wrote :

Similar looking bug: bug 989677

Steve Apodaca (sapodaca) on 2012-06-08
Changed in linux (Ubuntu):
assignee: Luis Henriques (henrix) → Steve Apodaca (sapodaca)
shedler (she-dl-er) wrote :

Hi. good morning. I have the same problem with my xps1340. I used the ubuntu builder and I edit my *.iso of ubuntu.
my instalation finish with the kernel 3.2.0.25 and install without kernel panic and noacpi, just normally.
any suggestion of where can i upload the *.iso for download? or, what can I do to help the comunity?
I can paste here the link. now I can use ubuntu 12.04 normally.
my english is so so, sorry :)

Have a nice day buddies.

merlinpr (merlinpr) wrote :

Having the same issue with a Dell Precision M4400. The weird thing is that I can get Ubuntu to install, everything works fine for a few days, and then I get the Kernel Panic. At first I needed a Linux box up and running quickly and didn't have time to debug so I reinstalled 12.04 (I used the alternate dvd both times) and the same result...it worked for a full day, as soon as I shut it down and tried to start it again this morning I got Kernel panic.

I tried to blacklist the module in grub and then booting to then follow the instructions on comment #6 but no luck. I then tried booting using a LiveCD, mounted the partition, and created the file on comment # 6 but when I rebooted I had the same problem. I just started working on this so I'll keep digging around, see what I can find, and report anything useful.

merlinpr, if you are having a problem in Ubuntu, please file a new report by executing the following via the Terminal and feel free to subscribe me to it:
ubuntu-bug linux

Thanks!

Daniel Manrique (roadmr) wrote :

merlinpr:

If your system "works fine for a few days", and you're able to install Ubuntu without the ite_cir blacklist workaround, and the module blacklisting doesn't help you, then it looks like it's not the "same issue". Thus, as Christopher advises, it'd be best for you to file a new bug, by following Christopher's instructions your system will attach relevant information automatically. Also, if your system panics again, please take a picture of the screen (try to ensure the text is legible) and attach it to the bug report.

Thanks!

Changed in linux:
status: Confirmed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.