Ubuntu

alternate iso missing hid-logitech-dj driver

Reported by Peter Hurley on 2012-04-06
66
This bug affects 38 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Tim Gardner
Precise
Medium
Herton R. Krzesinski
Quantal
Undecided
Tim Gardner
Raring
Medium
Tim Gardner

Bug Description

SRU Justification

Impact

Loss of input during installation.

Fix

Include hid-logitech-dj in input-modules udeb.

Test Case

Install using a wireless keyboarded handled by hid-logitech-dj

------------------------------------------------------------------------------

With amd64 alternate iso 20120406, the installer appears to 'hang' at location selection. Hard restart necessary.

However this is actually due to the wireless keyboard being non-responsive. This is because the hid-logitech-dj driver (for Logitech Unifying Receiver devices) is not present.
---
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
DistroRelease: Ubuntu 11.10
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
MachineType: Dell Inc. Precision WorkStation T5400
MemoryUsage:
 total used free shared buffers cached
 Mem: 10109508 1472064 8637444 0 72548 522324
 -/+ buffers/cache: 877192 9232316
 Swap: 10996456 0 10996456
NonfreeKernelModules: nvidia
Package: debian-installer (not installed)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-21-core2 root=UUID=29fc6be6-1991-4b27-b762-9d2753cecad3 ro crashkernel=384M-2G:64M,2G-:128M video=vesafb:mtrr:2 apparmor=0
ProcVersionSignature: Ubuntu 3.2.0-21.34-core2 3.2.13
Tags: oneiric
UdevDb: Error: [Errno 2] No such file or directory
Uname: Linux 3.2.0-21-core2 x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare svn
dmi.bios.date: 08/21/2008
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A04
dmi.board.name: 0RW203
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 7
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA04:bd08/21/2008:svnDellInc.:pnPrecisionWorkStationT5400:pvr:rvnDellInc.:rn0RW203:rvr:cvnDellInc.:ct7:cvr:
dmi.product.name: Precision WorkStation T5400
dmi.sys.vendor: Dell Inc.

apport information

tags: added: apport-collected oneiric
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/975198

tags: added: iso-testing
Changed in debian-installer (Ubuntu):
importance: Undecided → Medium
summary: - alternate iso appears to hang at location selection
+ alternate iso missing hid-logitech-dj driver
Colin Watson (cjwatson) wrote :

The kernel packaging needs to add this to the input-modules udeb.

affects: debian-installer (Ubuntu) → linux (Ubuntu)
Brad Figg (brad-figg) on 2012-04-19
Changed in linux (Ubuntu):
status: New → Confirmed
description: updated
description: updated
Changed in linux (Ubuntu Precise):
status: Confirmed → Fix Committed
assignee: nobody → Herton R. Krzesinski (herton)

Hello Peter, or anyone else affected,

Accepted linux into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

I've examined the contents of the input-modules udeb from the 3.2.0-24.37 kernel in precise-proposed and can confirm the hid-logitech-dj module is included:

$ dpkg -c input-modules-3.2.0-24-generic-di_3.2.0-24.37_amd64.udeb | grep "hid-logitech-dj"
-rw-r--r-- root/root 27192 2012-04-25 04:52 ./lib/modules/3.2.0-24-generic/kernel/drivers/hid/hid-logitech-dj.ko

tags: added: verification-done-precise
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.2.0-24.37

---------------
linux (3.2.0-24.37) precise-proposed; urgency=low

  [ Herton Ronaldo Krzesinski ]

  * d-i: Add hid-logitech-dj to input-modules
    - LP: #975198
  * d-i: Add rtl8187 driver to nic-usb-modules
    - LP: #971719

  [ Ian Abbott ]

  * SAUCE: staging: comedi: Add module parameters for default buffer size
    - LP: #981234
  * SAUCE: staging: comedi: Add kernel config for default buffer sizes
    - LP: #981234

  [ K. Y. Srinivasan ]

  * SAUCE: hv_storvsc: Account for in-transit packets in the RESET path
    - LP: #978394

  [ Leann Ogasawara ]

  * [Config] Set CONFIG_COMEDI_DEFAULT_BUF_[SIZE_KB,MAXSIZE_KB]
    - LP: #981234

  [ Luis Henriques ]

  * SAUCE: ite-cir: postpone ISR registration
    - LP: #984387

  [ Manoj Iyer ]

  * SAUCE: Bluetooth: btusb: Add vendor specific ID (0489 e042) for
    BCM20702A0
    - LP: #980965

  [ Tim Gardner ]

  * Extract firmware module info during getabi
  * [Config] Remove hiq-quanta module references
    - LP: #913164
  * [Config] powerpc-smp: build in ATI and RADEON frame buffer drivers
    - LP: #949288

  [ Trond Myklebust ]

  * SAUCE: NFSv4: Ensure that the LOCK code sets exception->inode
    - LP: #974664
  * SAUCE: NFSv4: Ensure that we check lock exclusive/shared type against
    open modes
    - LP: #974664

  [ Upstream Kernel Changes ]

  * Input: psmouse - allow drivers to use psmouse_{de,}activate
    - LP: #969334
  * Input: psmouse - use psmouse_[de]activate() from sentelic and hgpk
    drivers
    - LP: #969334
  * Input: sentelic - refactor code for upcoming new hardware support
    - LP: #969334
  * Input: sentelic - enabling absolute coordinates output for newer
    hardware
    - LP: #969334
  * Input: sentelic - minor code cleanup
    - LP: #969334
  * Input: sentelic - improve packet debugging information
    - LP: #969334
  * Input: sentelic - filter taps in absolute mode
    - LP: #969334
  * drm/i915: Fixes distorted external screen image on HP 2730p
    - LP: #796030
  * NFSv4: Minor cleanups for nfs4_handle_exception and
    nfs4_async_handle_error
    - LP: #974664
  * NFSv4: Rate limit the state manager for lock reclaim warning messages
    - LP: #974664
  * HID: multitouch: merge quanta driver into hid-multitouch
    - LP: #913164
  * HID: usbhid: add quirk no_get for quanta 3008 devices
    - LP: #913164
 -- Leann Ogasawara <email address hidden> Tue, 24 Apr 2012 07:47:49 -0700

Changed in linux (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Minjae (minjae-d-kim) wrote :

I see an identical symptom for Ubuntu 12.04 and 12.10 *Server* during the very first step of installation. Logitech Unifying Receiver keyboards do not work while a regular USB keyboard works fine.

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Peter Hurley (phurley) wrote :

Still broken in quantal mini iso.....

Changed in linux (Ubuntu):
status: Fix Released → New

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Changed in linux (Ubuntu):
assignee: Herton R. Krzesinski (herton) → Canonical Kernel Team (canonical-kernel-team)
Tim Gardner (timg-tpi) on 2013-02-26
Changed in linux (Ubuntu Quantal):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → In Progress
Changed in linux (Ubuntu Raring):
assignee: Canonical Kernel Team (canonical-kernel-team) → Tim Gardner (timg-tpi)
status: Confirmed → In Progress
Changed in linux (Ubuntu Quantal):
status: In Progress → Fix Committed
Changed in linux (Ubuntu Raring):
status: In Progress → Fix Committed
davidr (davaweb) wrote :

AMD64 ALTERNATIVE
This bug was firt reported when 12.04 was released.
It was confirmed and 'fixed'.

When 12.04.1 was released - it is still there.

Are there any instructions for streamlimining the 'fixed' code into the 12.04.1 iso or will the iso be updated? Or do wew wait for 13.04.x?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.8.0-8.17

---------------
linux (3.8.0-8.17) raring; urgency=low

  [Tim Gardner]

  * Release Tracking Bug
    - LP: #1133552
  * Bump ABI to fix armhf FTBS

  [ Herton Ronaldo Krzesinski ]

  * d-i: Add hid-logitech-dj to input-modules
    - LP: #975198
 -- Tim Gardner <email address hidden> Tue, 26 Feb 2013 12:12:21 -0700

Changed in linux (Ubuntu Raring):
status: Fix Committed → Fix Released
davidr (davaweb) wrote :

That doesn't answer my question -

Are there any instructions for streamlimining the 'fixed' code into the 12.04.1 iso? (by users)

12.04.1 still requires a different or wired keyboard for installation.

Åka Sikrom (akrosikam) wrote :

Same issue here. 12.04.1 still requires a different or wired keyboard for installation.

Brett Lehrer (brett-lehrer) wrote :

I'm having the same problem, except I've tried multiple different wired USB keyboards and none have worked.

Tim Gardner (timg-tpi) wrote :

Marking "Won't Fix" since no more ISOs will be created with the Quantal kernel.

Changed in linux (Ubuntu Quantal):
status: Fix Committed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers