Ubuntu

Logitech Unifying Receiver can't reset device

Reported by Anders Bruun Olsen on 2012-04-30
104
This bug affects 22 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

Very often (meaning not every time) when booting Ubuntu 12.04 (Precise Pangolin) my Logitech Unifying Receiver (and therefore my Logitech mouse) does not work. If I unplug and replug the receiver, it works again. This kernel message seems to demonstrate the problem:

logitech-djreceiver 0003:046D:C52B.0006: can't reset device, 0000:00:1d.7-6.4.1/input2, status -71

The message is repeated at lot. These messages are shown when I replug the device:

usb 2-6.4.1: new full-speed USB device number 6 using ehci_hcd
logitech-djreceiver 0003:046D:C52B.0009: hiddev0,hidraw3: USB HID v1.11 Device [Logitech USB Receiver] on usb-0000:00:1d.7-6.4.1/input2
input: Logitech Unifying Device. Wireless PID:1028 as /devices/pci0000:00/0000:00:1d.7/usb2/2-6/2-6.4/2-6.4.1/2-6.4.1:1.2/0003:046D:C52B.0009/input/input13
logitech-djdevice 0003:046D:C52B.000A: input,hidraw4: USB HID v1.11 Mouse [Logitech Unifying Device. Wireless PID:1028] on usb-0000:00:1d.7-6.4.1:1

It worked correctly on 11.10 with kernel 3.0.0-17-generic.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-24-generic 3.2.0-24.37
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic 3.2.14
Uname: Linux 3.2.0-24-generic x86_64
NonfreeKernelModules: nvidia
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: abo 2111 F.... pulseaudio
CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xe9100000 irq 46'
   Mixer name : 'Realtek ALC888'
   Components : 'HDA:10ec0888,1458a002,00100001'
   Controls : 45
   Simple ctrls : 20
Date: Mon Apr 30 14:46:03 2012
HibernationDevice: RESUME=UUID=2882946e-914b-4483-9d8e-2657d3e8cca8
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
MachineType: Gigabyte Technology Co., Ltd. EP45-DS3L
ProcFB: 0 VESA VGA
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-24-generic root=UUID=db1489c7-bca2-4235-bcbe-ac06ac08212b ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-24-generic N/A
 linux-backports-modules-3.2.0-24-generic N/A
 linux-firmware 1.79
RfKill:

SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/18/2008
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F8
dmi.board.name: EP45-DS3L
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF8:bd08/18/2008:svnGigabyteTechnologyCo.,Ltd.:pnEP45-DS3L:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnEP45-DS3L:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: EP45-DS3L
dmi.sys.vendor: Gigabyte Technology Co., Ltd.

Anders Bruun Olsen (drzero) wrote :
affects: ubuntu → linux (Ubuntu)
Brad Figg (brad-figg) on 2012-04-30
Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.4kernel[1] (Not a kernel in the daily directory). Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4-rc4-precise/

Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: needs-upstream-testing
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Anders Bruun Olsen (drzero) wrote :

Will do. I expect to be able to do this within the next 24 hours.

Anders Bruun Olsen (drzero) wrote :

Today I am unable to reproduce the problem. I have rebooted at least 25 times and today it work every time. Yesterday it would fail 8 times out of 10. It might just be dodgy hardware. This bug can be closed. If the problem returns I will research it better before reporting it.

Changed in linux (Ubuntu):
status: Incomplete → Invalid
Montblanc (montblanc) on 2012-05-17
Changed in linux (Ubuntu):
status: Invalid → Confirmed
Montblanc (montblanc) wrote :

We are 2 at least, so it can't be dodgy hardware. :) Plus, it wasn't happening on Oneiric. Please, take a look at bug at #995715 that shows another regression about the Unifying Receiver support; in the last comment I realized I was having this issue too. Could you please try typing in the username box at the login screen to see if your keyboard locale is correct (unless you're already using en_US)? Maybe we're talking about the same bug.

Anders Bruun Olsen (drzero) wrote :

I don't have a wireless keyboard. My unified receiver is for the Trackman 570. The weird thing is that I have a 570 (with unified receiver) both at home and work, and it is only at work I have ever had this problem. That is why I concluded it to be dodgy hardware. The problem manifests itself about once every week or two at work, but never at home. I will gladly try out anything I can to help track down the reason to this problem, just let me know what to do.

Cbm (cbm-mailbox) wrote :
Download full text (3.9 KiB)

Hi, I am having a similar problem here. All started with the upgrade to 12.10.

Sometimes the mouse works, sometimes not, sometimes only for a couple of minutes and then fails.

I tried using 3.2 kernel, but without any luck. If I plug the receiver to an Ubuntu 11.10 it works fine.

On the syslog I am getting the following messages:

May 18 15:45:06 Hubble kernel: [29127.763411] usb 2-1.1: new full-speed USB device number 49 using ehci_hcd
May 18 15:45:06 Hubble kernel: [29127.863599] logitech-djreceiver 0003:046D:C52B.0086: hiddev0,hidraw1: USB HID v1.11 Device [Logitech USB Receiver] on usb-0000:00:1d.0-1.1/input2
May 18 15:45:06 Hubble kernel: [29127.866226] input: Logitech Unifying Device. Wireless PID:1017 as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.1/2-1.1:1.2/0003:046D:C52B.0086/input/input47
May 18 15:45:06 Hubble kernel: [29127.866580] logitech-djdevice 0003:046D:C52B.0087: input,hidraw2: USB HID v1.11 Mouse [Logitech Unifying Device. Wireless PID:1017] on usb-0000:00:1d.0-1.1:1
May 18 15:45:06 Hubble mtp-probe: checking bus 2, device 49: "/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.1"
May 18 15:45:06 Hubble mtp-probe: bus: 2, device: 49 was not an MTP device
May 18 15:46:26 Hubble dbus[949]: [system] Activating service name='com.ubuntu.SoftwareProperties' (using servicehelper)
May 18 15:46:26 Hubble dbus[949]: [system] Successfully activated service 'com.ubuntu.SoftwareProperties'
May 18 15:49:15 Hubble kernel: [29375.865562] usb 2-1.1: reset full-speed USB device number 49 using ehci_hcd
May 18 15:49:15 Hubble kernel: [29375.937376] usb 2-1.1: device descriptor read/64, error -32
May 18 15:49:15 Hubble kernel: [29376.113176] usb 2-1.1: device descriptor read/64, error -32
May 18 15:49:15 Hubble kernel: [29376.288843] usb 2-1.1: reset full-speed USB device number 49 using ehci_hcd
May 18 15:49:15 Hubble kernel: [29376.360432] usb 2-1.1: device descriptor read/64, error -32
May 18 15:49:15 Hubble kernel: [29376.536033] usb 2-1.1: device descriptor read/64, error -32
May 18 15:49:16 Hubble kernel: [29376.711807] usb 2-1.1: reset full-speed USB device number 49 using ehci_hcd
May 18 15:49:16 Hubble kernel: [29377.118615] usb 2-1.1: device not accepting address 49, error -32
May 18 15:49:16 Hubble kernel: [29377.190689] usb 2-1.1: reset full-speed USB device number 49 using ehci_hcd
May 18 15:49:17 Hubble kernel: [29377.597478] usb 2-1.1: device not accepting address 49, error -32
May 18 15:49:17 Hubble kernel: [29377.598038] usb 2-1.1: USB disconnect, device number 49
May 18 15:49:17 Hubble kernel: [29377.681576] usb 2-1.1: new full-speed USB device number 50 using ehci_hcd
May 18 15:49:17 Hubble kernel: [29377.753419] usb 2-1.1: device descriptor read/64, error -32
May 18 15:49:17 Hubble kernel: [29377.929009] usb 2-1.1: device descriptor read/64, error -32
May 18 15:49:17 Hubble kernel: [29378.048865] hub 2-1:1.0: unable to enumerate USB device on port 1
May 18 15:49:18 Hubble kernel: [29378.623391] usb 2-1.1: new full-speed USB device number 52 using ehci_hcd
May 18 15:49:18 Hubble kernel: [29378.695265] usb 2-1.1: device descriptor read/64, error -32
May 18 15:49:18 Hubble kernel: [29378.870869] usb 2-1.1: device descri...

Read more...

Cbm (cbm-mailbox) wrote :

*3.4 kernels

Sorry for the prev long post... I am attaching the log as a file

I have definitely the same problem with two logitech devices:

- Logitech DiNovo Edge wireless keyboard: This one sometimes connects, but very soon loses connection and will not reconnect until reboot.
- Logitech Performance MX wireless mouse: This one sometimes does not connect after a booting up. Removing the receiver and reinserting it always helps, but only until the next boot.

Both problems started immediately after the upgrade from 11.10 to 12.04

Neil Gunther (neil-gunther) wrote :

Really odd- I never had a problem with the K350 on 11.10 but periodically on 12.04 64bit this issue crops up. The Logitech mouse I've got is not an issue.

If anyone wants me to try anything to resolve this- I'll give it a go.

MarcelG (marcel-vandengoor) wrote :

Hi,

I also have this problem also. When running ubuntu 11.10 i had no problem at all. After the upgrade it is not working always.
On the same reciever is also a mouse connected. This is working fine than it is always the keyboard that is not working.

Martin S. (storzi-o) wrote :

having the same problem using the k800 keyboard with unifying receiver.
ubuntu 12.04 with old 3.0 kernel works fine, problems occur with the current 3.2 kernel.
same problem with mainline-kernel 3.3, 3.4 and 3.5rc2

I'm also experiencing a similar problem.
Logitech M515 mouse with Unified Receiver
about 40% of the time on powerup mouse doesn't work
pulling out nano receiver and putting it back it seems to resolve issue.

typing commands:
sudo modprobe -r hid_logitech_dj
sudo modprobe hid_logitech_dj

also resolves the issue about 90% of the time, occasionally have to repeat the above 2 commands again, or a 3rd time
before mouse behaves, but once it behaves, it stays working until next reboot. (Timing issue somewhere in updated hid_logitech_dj code?)

triple boot machine, Windows7/Ubuntu 10.04/Ubuntu 12.04 64bit, problem only occurs in 12.04

I disagree with this being tagged as a duplicate of bug #975198.

That was an earlier bug, where the older version of hid_logitech_dj had been removed (the one that worked solidly!) and the new one hadn't been added.

This is really more a duplicate of bug #958174, which is still open.

The issue seems to be related to the changes made to the hid_logictech_dj. My understanding is that the older 'solid' version didn't support the "Unified" portion of the "Unified Receiver" in that you couldn't add a second Logitech accessory to the same receiver, but the updated code had been changed to enable this capability.

It may or may not be an interaction between the Logitech devices sleep mode and the unified receiver, but, as noted, it wasn't an issue with the older, dumber hid_logitech_dj.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers