3.2.0-19 kernel fails to boot (-18 OK)

Bug #961482 reported by Jim Leinweber on 2012-03-21
158
This bug affects 21 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Unknown
linux (Ubuntu)
Critical
Colin Ian King
Oneiric
Critical
Tim Gardner
Precise
Critical
Colin Ian King

Bug Description

Ran "sudo update-manager" at 2012-03-02 14:45 UTC, installing a linux 3.2.0-19 generic kernel on Ubuntu precise beta 1. That kernel fails to boot on a Dell Latitude E5420 laptop (intel core i7 CPU). It won't boot in either normal or recovery mode, wedging around 1.7 seconds in. The previous 3.2.0-18 kernel is fine, and is being used to submit this report.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-19-generic 3.2.0-19.31
ProcVersionSignature: Ubuntu 3.2.0-18.29-generic 3.2.9
Uname: Linux 3.2.0-18-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.94.1-0ubuntu2
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: jiml 2303 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xe5440000 irq 46'
   Mixer name : 'Intel CougarPoint HDMI'
   Components : 'HDA:111d76e7,1028049b,00100102 HDA:14f12c06,14f1000f,00100000 HDA:80862805,80860101,00100000'
   Controls : 37
   Simple ctrls : 13
Date: Wed Mar 21 13:25:11 2012
HibernationDevice: RESUME=UUID=31be3dc4-595b-43bf-9f54-16a2331c8879
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120117)
MachineType: Dell Inc. Latitude E5420
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-18-generic root=UUID=3fa83626-cdb9-497b-b689-225abe500015 ro quiet splash vt.handoff=7
PulseList:
 Error: command ['pacmd', 'list'] failed with exit code 1: Home directory /home/jiml not ours.
 No PulseAudio daemon running, or not running as session daemon.
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-18-generic N/A
 linux-backports-modules-3.2.0-18-generic N/A
 linux-firmware 1.71
SourcePackage: linux
StagingDrivers: mei
UpgradeStatus: Upgraded to precise on 2012-03-16 (5 days ago)
dmi.bios.date: 09/19/2011
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A03
dmi.board.name: 0675PR
dmi.board.vendor: Dell Inc.
dmi.board.version: A01
dmi.chassis.type: 9
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA03:bd09/19/2011:svnDellInc.:pnLatitudeE5420:pvr01:rvnDellInc.:rn0675PR:rvrA01:cvnDellInc.:ct9:cvr:
dmi.product.name: Latitude E5420
dmi.product.version: 01
dmi.sys.vendor: Dell Inc.

Jim Leinweber (jiml-mail) wrote :

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get dist-upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: New → Confirmed
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-19.31
Joseph Salisbury (jsalisbury) wrote :

When the system hangs, can you see if you can access some of the other ttys? That can be done by pressing "CTRL+ALT" and F1.

Changed in linux (Ubuntu):
importance: Undecided → High
status: Incomplete → Confirmed
tags: added: kernel-da-key
Joseph Salisbury (jsalisbury) wrote :

Also, would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.3 kernel[1] (Not a kernel in the daily directory). Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[1] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.3-precise/

tags: added: needs-upstream-testing
Joseph Salisbury (jsalisbury) wrote :

Can you also take a look at the following wiki page:
https://wiki.ubuntu.com/DebuggingKernelBoot

It provides some suggestions to get additional debug information during the boot hang.

Joseph Salisbury (jsalisbury) wrote :

One additional request, It would be great if we could run a kernel bisect, to identify the commit that caused this bug. Would you be able to test a few test kernels?

tags: added: kernel-key
GNAServicesInc (gnaservicesinc) wrote :

I think I may suffer from the same bug. Not sure, https://bugs.launchpad.net/ubuntu/+source/linux/+bug/961823

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get dist-upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-20.32
Joseph Salisbury (jsalisbury) wrote :

The 3.2.0-20 kernel is out. Can you see if you have the same issue booting this kernel?

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
importance: High → Critical
tags: removed: needs-upstream-testing
Joseph Salisbury (jsalisbury) wrote :

It would be good to first identify which mainline kernel introduce the regression. The 3.2.0-18.28 kernel was based off of upstream 3.2.9. The 3.2.0-19.31 kernel was rebased to 3.2.10, 3.2.11 and 3.2.12.

Could you test the mainline 3.2.11[0] kernel and see if the bug was introduce in that version? If it was not, please test the 3.2.12[1] kernel. There was a build issue with the mainline 3.2.10 kernel, so there is not a prebuilt kernel to test that version.

Once we know what version introduced the bug, we can bisect to find the exact commit.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.2.11-precise/
[1] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.2.12-precise/

Joseph Salisbury (jsalisbury) wrote :

So to clarify the next steps:

1. First test the 3.2.0-20.32 kernel
2. Then test the mainline kernels posted in comment #10.

Thanks in advance!

tags: added: bot-stop-nagging
Jim Leinweber (jiml-mail) wrote :

Wow, this bug is getting a lot of attention! Thanks, everyone.

Joseph Salisbury asked:
   When the system hangs, can you see if you can access some of the other ttys?

Sorry, it hangs too early for VTY switching. Specifically, the last two messages from around 1.47 seconds into boot are tagged: "start_kernel" and "gs_change". If the more specific address info would be useful I can transcribe the hex.

Joseph also asks:
   ... we could run a kernel bisect ...

Yes, I could install and try a series of other kernels. It's a work laptop, and I don't have time to build them from source, but I can run boot experiments with kernels someone else is compiling to try and pin this down.

In response to GNAServicesInc, yes bug 961823 sounds like the same one as mine. It's the same symptoms, anyway. The "recovery boot" options are noisier than the default boot and more informative. What I did to use apport-bug was first run "dpkg-query -l "linux*" to identify the full name of the kernel package I wanted to complain about.

Brad Figg notes:
    ... there is a newer version of the development kernel ...

I ran update-manager again, installed the 3.2.0-20 kernel, and it has the same symptoms.

Joseph Salisbury asks:
    ... would it be possible for you to test the latest upstream kernel?
I installed 3.3.0-030300.201203182135 and got a kernel panic at 0.32s into boot instead. Different, but not better.

Does anyone know if the "SerialConsoleHowto" document results in not just grub but also the kernel logging out a serial port? Maybe I could scrounge up a null modem cable and use kermit on another PC to capture the boot messages?

Joseph Salisbury (jsalisbury) wrote :

The serial console may give you the same result if you already removed quiet and splash keywords from grub, as mentioned in:
https://wiki.ubuntu.com/DebuggingKernelBoot

You may be able to use netconsole to capture additional debug info:
https://wiki.ubuntu.com/Kernel/Netconsole

Joseph Salisbury (jsalisbury) wrote :

Jim,

Could you also test the following upstream kernels and see if they boot:

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.2.9-precise/
http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.2.11-precise/
http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.2.12-precise/

Based on your results, I can kick of a bisect to identify the bad commit.

Jim Leinweber (jiml-mail) wrote :

3.2.12 dies at 1.368s into boot after logging gs_change, similarly to 3.2.0-19 and 3.2.0-20
3.2.11 works
3.2.9 works

Jim Leinweber (jiml-mail) wrote :

netconsole isn't going to be an option; it's dying well before getting any NIC's up.
Let me know if I should hunt down a null modem cable or a digital camera.

Joseph Salisbury (jsalisbury) wrote :

Thanks for the update, Jim.

So we now know the regression was introduced in the 3.2.12 mainline kernel. I'll bisect between 3.2.11 and 3.2.11. I'll post a test kernel shortly.

Pic from latest upstream kernel

Joseph Salisbury (jsalisbury) wrote :

Typo, I'm biscecting between 3.2.11 and 3.2.12.

Joseph Salisbury (jsalisbury) wrote :

@GNAServicesInc

Did this panic happen with the v3.3 mainline kernel?

Yes, I just tested t he latest mainline from today from http://kernel.ubuntu.com/~kernel-ppa/mainline/daily/current/ in response to a request for me to do it in my orig bug report

Changed in linux:
importance: Unknown → Critical
Jim Leinweber (jiml-mail) wrote :

gnaservicesinc's screenshot from his daily/current kernel try is pretty much identical to what I get with the 3.3.0 mainline kernel from 3/18.

In case it wasn't obvious from the attachments, I'm using the 64-bit amd64 kernels, not the 32-bit i386 kernels.

Joseph Salisbury (jsalisbury) wrote :

Hi All,

I created the first bisected test kernel, which is available at:
http://people.canonical.com/~jsalisbury/lp961482/

This test kernel is built up to commit:
cd3d5286e46aa60ff36a1f7431860d2e7e2fade2

Can folks affected by this bug try this test kernel and report back if it boots or not? Based on the feed back, I will build the next test kernel.

Jim Leinweber (jiml-mail) wrote :

On my Dell E5420 jsalisbury's lp961482 kernel exhibits the bug, so the offending commit seems to be earlier than cd3d5286e46aa60ff36a1f7431860d2e7e2fade2. This kernel also wedges during boot at 1.36 seconds in, with last two tokens logged being "parse_early_options" and "gs_change".

Joseph Salisbury (jsalisbury) wrote :

Thanks for the update, Jim. I'll kick off the next kernel build. It will be built up to commit:
989961646eaad60b22efb8e23090aea563514874

Joseph Salisbury (jsalisbury) wrote :

The next bisected kernel is available at:
http://people.canonical.com/~jsalisbury/lp961482/

It is built up to commit:
989961646eaad60b22efb8e23090aea563514874

This bug may be related to:
https://lkml.org/lkml/2012/3/19/232

I'll build a test kernel with commit 4949be16822e92a18ea0cc1616319926628092ee reverted, and post it next.

Joseph Salisbury (jsalisbury) wrote :

@GNAServiceInc,
Thanks for the update, I'll update the bisect that commit 989961646eaad60b22efb8e23090aea563514874 is bad.

Before I build the next bisected kernel, I'd like you have a test kernel with commit 4949be16822e92a18ea0cc1616319926628092ee reverted. That test kernel is available at:

http://people.canonical.com/~jsalisbury/lp961482/4949be16822e92a18ea0cc1616319926628092ee-reverted/

Can folks affected by this bug test that kernel and report back if it allows you to boot. If it does, we know what commit introduced this bug. If it does not allow you to boot, we can continue with the bisect.

Works now

Joseph Salisbury (jsalisbury) wrote :

The following commit appears to have caused the regression:

f043ddb60c84ea64a23b755004572afe922e653c PCI: ignore pre-1.1 ASPM
quirking when ASPM is disabled
diff --git a/drivers/pci/pcie/aspm.c b/drivers/pci/pcie/aspm.c
index 1cfbf22..24f049e 100644
--- a/drivers/pci/pcie/aspm.c
+++ b/drivers/pci/pcie/aspm.c
@@ -500,6 +500,9 @@ static int pcie_aspm_sanity_check(struct pci_dev *pdev)
        int pos;
        u32 reg32;

+ if (aspm_disabled)
+ return 0;
+
        /*
         * Some functions in a slot might not all be PCIe functions,
         * very strange. Disable ASPM for the whole slot

I will now build a precise test kernel with this commit reverted and post a link to it.

Joseph Salisbury (jsalisbury) wrote :

I built an amd64 Precise test kernel with the previously mentioned commit reverted. The test kernel is located at:
http://people.canonical.com/~jsalisbury/lp961482

Can you confirm that this test kernel still boots? If it does, that would be the test kernel to run, until this bug is resolved.

Jim Leinweber (jiml-mail) wrote :

Yes, the
  Ubuntu 3.2.0-20.32~lp961482v1-generic 3.2.12
kernel build from
  http://people.canonical.com/~jsalisbury/lp961482
boots and runs fine for me. I'm posting this comment using it.

Joseph Salisbury (jsalisbury) wrote :

Thanks for the update, Jim.

I would suggest using that test kernel(Or an earlier kernel that boots), until this bug is resolved. The commit that caused this bug is currently being discussed upstream on LKML:

https://lkml.org/lkml/2012/3/19/408

Thanks to everyone that helped out with this bug!

Jim Leinweber (jiml-mail) wrote :

The LKML discussion was along the lines I anticipated: evidently different subsets of machines crash with and without the patch, leaving the poor kernel maintainers with a dilemma. Clearly a more complex if condition is called for, if only what it needs to be can be worked out. I presume it's related to either hardware or BIOS bugs and/or quirks.

Joseph Salisbury (jsalisbury) wrote :

A possible workaround is to boot with the kernel parameter: pcie_aspm=force

Jim Leinweber (jiml-mail) wrote :

Yes, pcie_aspm=force let's me boot kernels such as 3.3.0 on that Dell E5420 laptop. So I can confirm the workaround.

Just tried the workaround on my ASUS P8Z68-V PRO and it works.

Giuseppe Pennisi (giupenni78) wrote :

Same problem on my Gigabyte GA-Z68X-UD3H-B3

Giuseppe Pennisi (giupenni78) wrote :

Same problem on my Gigabyte GA-Z68X-UD3H-B3
Kernel 3.2.0-20

Same problem using Kernel 3.2.0-19 and kernel 3.2.0-20 amd64 on 12.04 LTS.

DELL Latitude E5520.

Same problem with 3.2.0-20 on a Gigabyte H61M-S2PV.

Workaround pcie_aspm=force works fine.

blinkblink (thomasthoma) wrote :

same on a Gigabyte Z68XP-UD3, duplicate bug: #962510

I too confirm that pcie_aspm=force solves the issue. :D

tags: added: rls-mgr-p-tracking
Christian Brandt (brandtc) wrote :

same on Asus P8Z68-V Gen3.

Ubuntu -20 Kernel and pcie_aspm=force fixed the problem. Details about my system see 963128

Sorry can't really deep test the issue as the system is out of house and I only have inexpierenced hands in situ.

Colin Ian King (colin-king) wrote :

OK - so to make any real progress with the underlying issue we really need a full trace of the crash, so I've spun a kernel that will dump out the stack trace with some delays inserted to allow us to take a few photos of the stack trace.

The debug kernel .debs can be found in:

http://zinc.canonical.com/~cking/lp-961482/

Can somebody see if these allow us to capture the full crash trace, and if so, please attach photos to the bug. Thanks!

Ara Pulido (ara) on 2012-03-26
tags: added: blocks-hwcert

Please find attached the requested picture when the kernel hangs. I hope that can help

Changed in linux:
importance: Critical → Unknown
status: Unknown → Confirmed
Colin Ian King (colin-king) wrote :

Photo DSC03081.JPG looks like we are jumping to pcie_aspm_configure_common_clock + 0x25b which seems to be 0xd4b so I suspect that is the BUG_ON(!pci_is_pcie(child)) statement below:

     d4a: c3 retq
     d4b: 0f 0b ud2a <------
     d4d: 0f 1f 00 nopl (%rax)

static void pcie_aspm_configure_common_clock(struct pcie_link_state *link)
{
        int ppos, cpos, same_clock = 1;
        u16 reg16, parent_reg, child_reg[8];
        unsigned long start_jiffies;
        struct pci_dev *child, *parent = link->pdev;
        struct pci_bus *linkbus = parent->subordinate;
        /*
         * All functions of a slot should have the same Slot Clock
         * Configuration, so just check one function
         */
        child = list_entry(linkbus->devices.next, struct pci_dev, bus_list);
        BUG_ON(!pci_is_pcie(child));

Tim Gardner (timg-tpi) wrote :

(pre-stable) ASPM: Fix pcie devices with non-pcie children

Changed in linux (Ubuntu Precise):
assignee: nobody → Colin King (colin-king)
status: Confirmed → Fix Committed
Pete Graner (pgraner) on 2012-03-27
tags: added: rls-p-tracking
removed: rls-mgr-p-tracking
Colin Ian King (colin-king) wrote :

We've been working with upstream and we've got a patch that should be tested. I've put some new kernel .debs in:

http://zinc.canonical.com/~cking/lp-961482

Can you please try these out and see if it works without the pcie_aspm=force workaround and let us know if it helps.

By the way, kudos to Matthew Garrett.

Yes, that's work fine. Attached the dmeg of my system after logging into ubuntu.

Colin Ian King (colin-king) wrote :

Thanks for the speedy response Hatem.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.2.0-20.33

---------------
linux (3.2.0-20.33) precise; urgency=low

  [ Upstream Kernel Changes ]

  * (pre-stable) ASPM: Fix pcie devices with non-pcie children
    - LP: #961482
 -- Leann Ogasawara <email address hidden> Tue, 27 Mar 2012 08:37:43 -0700

Changed in linux (Ubuntu Precise):
status: Fix Committed → Fix Released
Tim Gardner (timg-tpi) on 2012-04-02
Changed in linux (Ubuntu Oneiric):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → In Progress
Changed in linux:
status: Confirmed → Fix Released
Changed in linux (Ubuntu Oneiric):
importance: Undecided → Critical
Tim Gardner (timg-tpi) on 2012-04-03
Changed in linux (Ubuntu Oneiric):
status: In Progress → Fix Committed
Jim Leinweber (jiml-mail) wrote :

I can confirm that both the ubuntu 12.04 "precise" kernel 3.2.0-21.34 and the upstream daily kernel 3.4.0-999.201204040406 boot for my Dell E5420 laptop without the workaround. Hurrah!

Thanks everyone for the quick and successful work on this.

Brad Figg (brad-figg) on 2012-04-07
tags: added: verification-needed-oneiric
Luis Henriques (henrix) wrote :

This bug is awaiting verification that the kernel for Oneiric in -proposed solves the problem ( 3.0.0-19.32). Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-oneiric' to 'verification-done-oneiric'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

Luis Henriques (henrix) wrote :

Jim Leinweber, or anyone reporting this issue, could you please verify that the latest kernel (3.0.0-19.32) actually fixes this problem? Thank you.

Herton R. Krzesinski (herton) wrote :

We got confirmation from bug 973111, which is a duplicate on Oneiric, that the patch for this bug solves the problem (reporter tested both a kernel with only the patch plus tested the 3.0.0-19.3 release from -proposed). Thus marking this as verification-done-oneiric. Also we got confirmation in other bugs, like bug 973444.

tags: added: verification-done-oneiric
removed: verification-needed-oneiric
Launchpad Janitor (janitor) wrote :
Download full text (24.1 KiB)

This bug was fixed in the package linux - 3.0.0-19.33

---------------
linux (3.0.0-19.33) oneiric-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #985736

  [ Luis Henriques ]

  * SAUCE: ite-cir: postpone ISR registration
    - LP: #984387

linux (3.0.0-19.32) oneiric-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #974368

  [ Brad Figg ]

  * SAUCE (no-up) Provide a param for allowing the BIOS to handle changing
    the brightness on AC/battery status changes.
    - LP: #949311
  * SAUCE (no-up) Quirk for enabling backlight hotkeys on Samsung N150P
    - LP: #875893

  [ Daniel Vetter ]

  * SAUCE: (drop after 3.5) drm/i915: reinstate GM45 TV detection fix
    - LP: #638939

  [ Herton Ronaldo Krzesinski ]

  * SAUCE: (no-up) Reinstate missing hunk from nx emulation
    - LP: #972821

  [ Tim Gardner ]

  * SAUCE: ubuntu drivers: use UMH_WAIT_PROC consistently
    - LP: #963685
  * SAUCE: disable_nx should not be in __cpuinitdata section for X86_32
    - LP: #968233
  * SAUCE: (no-up) remove __initdata from vesafb_fix
    - LP: #969309

  [ Upstream Kernel Changes ]

  * usermodehelper: use UMH_WAIT_PROC consistently
    - LP: #963685
  * usermodehelper: introduce umh_complete(sub_info)
    - LP: #963685
  * usermodehelper: implement UMH_KILLABLE
    - LP: #963685
  * usermodehelper: kill umh_wait, renumber UMH_* constants
    - LP: #963685
  * usermodehelper: ____call_usermodehelper() doesn't need do_exit()
    - LP: #963685
  * kmod: introduce call_modprobe() helper
    - LP: #963685
  * kmod: make __request_module() killable
    - LP: #963685
  * x86, tsc: Fix SMI induced variation in quick_pit_calibrate()
    - LP: #965586
  * ata_piix: Add Toshiba Satellite Pro A120 to the quirks list due to
    broken suspend functionality.
    - LP: #886850
  * ACPICA: Fix regression in FADT revision checks
    - LP: #883441
  * ASPM: Fix pcie devices with non-pcie children
    - LP: #961482
  * USB: option: Add MediaTek MT6276M modem&app interfaces
    - LP: #971808
  * USB: option driver: adding support for Telit CC864-SINGLE, CC864-DUAL
    and DE910-DUAL modems
    - LP: #971808
  * USB: option: make interface blacklist work again
    - LP: #971808
  * USB: option: add ZTE MF820D
    - LP: #971808
  * USB: ftdi_sio: fix problem when the manufacture is a NULL string
    - LP: #971808
  * USB: ftdi_sio: add support for BeagleBone rev A5+
    - LP: #971808
  * USB: Microchip VID mislabeled as Hornby VID in ftdi_sio.
    - LP: #971808
  * USB: ftdi_sio: new PID: Distortec JTAG-lock-pick
    - LP: #971808
  * USB: ftdi_sio: add support for FT-X series devices
    - LP: #971808
  * USB: ftdi_sio: new PID: LUMEL PD12
    - LP: #971808
  * powerpc/usb: fix bug of kernel hang when initializing usb
    - LP: #971808
  * usb: musb: Reselect index reg in interrupt context
    - LP: #971808
  * usb: gadgetfs: return number of bytes on ep0 read request
    - LP: #971808
  * USB: gadget: Make g_hid device class conform to spec.
    - LP: #971808
  * futex: Cover all PI opcodes with cmpxchg enabled check
    - LP: #971808
  * sysfs: Fix memory leak in sysfs_sd_setsecdata().
    - LP: #971808
  * tty: ...

Changed in linux (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.