Ubuntu

14e4:4727 Broadcom BCM4313 random AP disconnects and network hang

Reported by Terry on 2012-02-27
114
This bug affects 20 people
Affects Status Importance Assigned to Milestone
Linux
Confirmed
Medium
linux (Arch Linux)
New
Undecided
Unassigned
linux (Ubuntu)
Medium
Unassigned

Bug Description

Using the brcmsmac driver I'm experiencing random AP disconnects and network hangs. I can usually come out of a hang by reconnecting using the network manager. I'm unable to try the STA driver as this appears to be uninstallable at this time although I would prefer to use the free driver.

I got a lot of the following in kern.log during the issues

Feb 27 00:30:10 lenny kernel: [ 455.059482] ieee80211 phy0: brcms_c_ampdu_dotxstatus_complete: Pkt tx suppressed, illegal channel possibly 2
Feb 27 00:30:10 lenny kernel: [ 455.059494] ieee80211 phy0: AMPDU status: BA Timeout, seq 264, in_transit 15
Feb 27 00:30:10 lenny kernel: [ 455.059517] ieee80211 phy0: AMPDU status: BA Timeout, seq 265, in_transit 14
Feb 27 00:30:10 lenny kernel: [ 455.059522] ieee80211 phy0: AMPDU status: BA Timeout, seq 266, in_transit 13
Feb 27 00:30:10 lenny kernel: [ 455.059527] ieee80211 phy0: AMPDU status: BA Timeout, seq 267, in_transit 12
Feb 27 00:30:10 lenny kernel: [ 455.059532] ieee80211 phy0: AMPDU status: BA Timeout, seq 268, in_transit 11
Feb 27 00:30:10 lenny kernel: [ 455.059539] ieee80211 phy0: AMPDU status: BA Timeout, seq 269, in_transit 10
Feb 27 00:30:10 lenny kernel: [ 455.059544] ieee80211 phy0: AMPDU status: BA Timeout, seq 270, in_transit 9
Feb 27 00:30:10 lenny kernel: [ 455.059550] ieee80211 phy0: AMPDU status: BA Timeout, seq 271, in_transit 8
Feb 27 00:30:10 lenny kernel: [ 455.059556] ieee80211 phy0: AMPDU status: BA Timeout, seq 272, in_transit 7
Feb 27 00:30:10 lenny kernel: [ 455.059561] ieee80211 phy0: AMPDU status: BA Timeout, seq 273, in_transit 6
Feb 27 00:30:10 lenny kernel: [ 455.059566] ieee80211 phy0: AMPDU status: BA Timeout, seq 274, in_transit 5
Feb 27 00:30:10 lenny kernel: [ 455.059572] ieee80211 phy0: AMPDU status: BA Timeout, seq 275, in_transit 4
Feb 27 00:30:10 lenny kernel: [ 455.059576] ieee80211 phy0: AMPDU status: BA Timeout, seq 276, in_transit 3
Feb 27 00:30:10 lenny kernel: [ 455.059581] ieee80211 phy0: AMPDU status: BA Timeout, seq 277, in_transit 2
Feb 27 00:30:10 lenny kernel: [ 455.059587] ieee80211 phy0: AMPDU status: BA Timeout, seq 278, in_transit 1
Feb 27 00:30:10 lenny kernel: [ 455.059592] ieee80211 phy0: AMPDU status: BA Timeout, seq 279, in_transit 0
Feb 27 00:30:10 lenny kernel: [ 455.069190] ieee80211 phy0: brcms_c_ampdu_dotxstatus_complete: Pkt tx suppressed, illegal channel possibly 2
Feb 27 00:30:10 lenny kernel: [ 455.069193] ieee80211 phy0: AMPDU status: BA Timeout, seq 280, in_transit 3
Feb 27 00:30:10 lenny kernel: [ 455.069199] ieee80211 phy0: AMPDU status: BA Timeout, seq 281, in_transit 2
Feb 27 00:30:10 lenny kernel: [ 455.069205] ieee80211 phy0: AMPDU status: BA Timeout, seq 282, in_transit 1
Feb 27 00:30:10 lenny kernel: [ 455.069210] ieee80211 phy0: AMPDU status: BA Timeout, seq 283, in_transit 0
Feb 27 00:30:10 lenny kernel: [ 455.428023] ieee80211 phy0: brcms_c_dotxstatus: INTERMEDIATE but not AMPDU
Feb 27 00:30:10 lenny kernel: [ 455.428914] ieee80211 phy0: brcms_c_dotxstatus: INTERMEDIATE but not AMPDU
Feb 27 00:30:10 lenny kernel: [ 455.429236] ieee80211 phy0: brcms_c_dotxstatus: INTERMEDIATE but not AMPDU
Feb 27 00:30:10 lenny kernel: [ 455.626571] ieee80211 phy0: brcms_c_dotxstatus: INTERMEDIATE but not AMPDU
Feb 27 00:30:10 lenny kernel: [ 455.627441] ieee80211 phy0: brcms_c_dotxstatus: INTERMEDIATE but not AMPDU
Feb 27 00:30:11 lenny kernel: [ 456.131106] ieee80211 phy0: brcms_c_dotxstatus: INTERMEDIATE but not AMPDU
Feb 27 00:30:11 lenny kernel: [ 456.132082] ieee80211 phy0: brcms_c_dotxstatus: INTERMEDIATE but not AMPDU
Feb 27 00:30:11 lenny kernel: [ 456.328771] ieee80211 phy0: brcms_c_dotxstatus: INTERMEDIATE but not AMPDU
Feb 27 00:30:11 lenny kernel: [ 456.329630] ieee80211 phy0: brcms_c_dotxstatus: INTERMEDIATE but not AMPDU
Feb 27 00:30:11 lenny kernel: [ 456.713335] ieee80211 phy0: brcms_c_dotxstatus: INTERMEDIATE but not AMPDU
Feb 27 00:30:11 lenny kernel: [ 456.714013] ieee80211 phy0: brcms_c_dotxstatus: INTERMEDIATE but not AMPDU
Feb 27 00:30:12 lenny kernel: [ 456.908024] ieee80211 phy0: brcms_c_dotxstatus: INTERMEDIATE but not AMPDU
Feb 27 00:30:12 lenny kernel: [ 456.908935] ieee80211 phy0: brcms_c_dotxstatus: INTERMEDIATE but not AMPDU
Feb 27 00:30:12 lenny kernel: [ 457.166170] ieee80211 phy0: brcms_c_dotxstatus: INTERMEDIATE but not AMPDU
Feb 27 00:30:12 lenny kernel: [ 457.167601] ieee80211 phy0: brcms_c_dotxstatus: INTERMEDIATE but not AMPDU

$ lsb_release -rd
Description: Ubuntu precise (development branch)
Release: 12.04

02:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller [14e4:4727] (rev 01)
 Subsystem: Broadcom Corporation Device [14e4:051b]
 Flags: bus master, fast devsel, latency 0, IRQ 17
 Memory at d0400000 (64-bit, non-prefetchable) [size=16K]
 Capabilities: <access denied>
 Kernel driver in use: brcmsmac
 Kernel modules: bcma, brcmsmac

My main workstation is also running precise with an Atheros 802.11n card and various other wifi devices that work fine so I'm almost convinced it's not the router which is a BT Home Hub v3.0

Please let me know if you require further information.
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.94.1-0ubuntu1
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: mrkennie 2064 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xd0600000 irq 43'
   Mixer name : 'Intel CougarPoint HDMI'
   Components : 'HDA:14f1506e,17aac013,00100002 HDA:80862805,80860101,00100000'
   Controls : 14
   Simple ctrls : 6
DistroRelease: Ubuntu 12.04
EcryptfsInUse: Yes
InstallationMedia: Lubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
MachineType: LENOVO 4334
NonfreeKernelModules: atl1c
Package: linux (not installed)
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-18-generic root=UUID=586704a1-137a-4d00-8163-fda5148ced0a ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.2.0-18.28-generic 3.2.9
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-18-generic N/A
 linux-backports-modules-3.2.0-18-generic N/A
 linux-firmware 1.71
StagingDrivers: rts5139 mei
Tags: precise staging
Uname: Linux 3.2.0-18-generic x86_64
UpgradeStatus: Upgraded to precise on 2012-01-08 (60 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 10/07/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 40CN28WW(V2.14)
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Base Board Product Name
dmi.board.vendor: LENOVO
dmi.board.version: Base Board Version
dmi.chassis.asset.tag: Chassis Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Chassis Manufacturer
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnLENOVO:bvr40CN28WW(V2.14):bd10/07/2011:svnLENOVO:pn4334:pvrLenovoG570:rvnLENOVO:rnBaseBoardProductName:rvrBaseBoardVersion:cvnChassisManufacturer:ct10:cvrChassisVersion:
dmi.product.name: 4334
dmi.product.version: Lenovo G570
dmi.sys.vendor: LENOVO

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/941695/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Terry (terry-kryogenic) on 2012-02-28
affects: ubuntu → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 941695

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: precise

unfortunately I'm unable to submit any log files using apport-collect because it is crashing due to a bug of its own. Are there any logs I can send over manually that would be useful?

Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.3 kernel[1] (Not a kernel in the daily directory). Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed by the mainline kernel, please add the following tag 'kernel-fixed-upstream-KERNEL-VERSION'. For example, if kernel version 3.3-rc5 fixed the issue, the tag would be: 'kernel-fixed-upstream-v3.3-rc5'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[1] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.3-rc5-precise/

Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: needs-upstream-testing
Terry (terry-kryogenic) on 2012-02-29
tags: added: kernel-bug-exists-upstream
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: removed: needs-upstream-testing

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-17.27
Terry (terry-kryogenic) on 2012-02-29
Changed in linux (Ubuntu):
status: Incomplete → Confirmed

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report at bugzilla.kernel.org [1]? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

If you are comfortable with opening a bug upstream, It would be great if you can report back the upstream bug number in this bug report. That will allow us to link this bug to the upstream report.

[1] https://wiki.ubuntu.com/Bugs/Upstream/kernel

Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in linux (Ubuntu):
status: Confirmed → Triaged
Terry (terry-kryogenic) wrote :

I'm not sure if this will help with this issue but I came across this:
https://bugzilla.redhat.com/show_bug.cgi?id=787649
which is the exact same issue I'm having. There is a patch but nobody can confirm it has been fixed. I've also had a go myself but it was a real pain to find a working wireless stack that compiles and loads correctly. I'm not even sure if I can add the patch from that bug report here? Is that the done thing?

Seems dead on the upstream front, I guess I'm one of very very few people this happens to.

apport information

tags: added: apport-collected staging
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Terry: Do you get the warning mentioned in the other bug reports? Does the warning always coincide with the network problems?

Seth Forshee (sforshee) on 2012-03-09
Changed in linux (Ubuntu):
status: Triaged → Incomplete
Terry (terry-kryogenic) wrote :

When the problems start I tail kern.log and after a minute or so I'll see the crash message with backtrace. The A-MPDU messages I posted initially are quite normal apparently.

Seth Forshee (sforshee) wrote :

So you have tested the patch from the fedora bug, "brcm80211: smac: fix endless retry of A-MPDU transmissions", and found that it didn't help, correct? Really I think that's only intended to be a fix for the warning that's triggered in brcms_c_wait_for_tx_completion(), which seems like it was a symptom of the problem and not related to the cause. These attempts to fix the warning don't seem to be getting at the root of your hangs and disconnects.

I'd say that some of the AMPDU messages are normal, especially in noisy RF environments, but an extreme number of them may be indicative of a problem.

The illegal channel messages are more interesting. The driver is trying to transmit some packets, but the hardware comes back with an error that the comments in the code note as "channel mismatch." The driver won't retry when it sees this error, so the BA timeout messages are a result of the code iterating through all the fragments that were part of this failed transfer. I'm going to have to go through the code more to try and better understand what it all means.

Once you get into this state, do you continually get a stream of these messages when trying to use the network until you use network manager to reconnect? Can you explain exactly what you're doing when you use network manager to reconnect? I.e., do you disable and re-enable wirless, or do you just disconnect and reconnect to the network?

Can you also trigger this error and take note of whether the channel number in the "illegal channel" messages matches the channel the AP you're connected to is using?

Thanks!

Changed in linux (Ubuntu):
assignee: nobody → Seth Forshee (sforshee)
Terry (terry-kryogenic) wrote :

Yup, it didn't fix the problem I was having but it fixed what the patch described and the A-MPDU messages were more frequent, I remember that much.

Normally the messages will appear one after the other at different intervals but I'm not flooded with them. What I will do is collect logs prior to the issues up to the point it recovers itself as it were. That might give you a better idea of what is happening.

Terry (terry-kryogenic) wrote :

I've attached the log I captured between the time I'm downloading a Ubuntu DVD and after the network connection came back to life again. Channel seemed to stay at 6 in this case which is pretty noisy according to the android wifi analyser app.

Connection resumes normally again at: Mar 9 18:03:06 bert kernel: [ 801.270584] ieee80211 phy0: brcms_c_dotxstatus: INTERMEDIATE but not AMPDU

Terry (terry-kryogenic) wrote :

Unless I missed it, I've never seen the following message before. I get about 20 of these within the space of a second.
Mar 9 18:25:19 bert kernel: [ 2131.803393] ieee80211 phy0: brcms_c_prec_enq_head: No where to go, prec == 4
Network seems unresponsive around this time too.

Channel definitely stays at 6 throughout.

Terry (terry-kryogenic) wrote :

Hm, still looking for a pattern and while I was at it I have tried the cw-3.3 and this results in an connectivity issue and stays like it until a reboot. No messages at all, just nothing. I can't get out of this by reconnecting this time either.There's no longer a crash with this version so there is some progress.

using the following to get cw-3.3

linux-backports-modules-cw-3.3-3.2.0-18-generic:
  Installed: 3.2.0-18.1
  Candidate: 3.2.0-18.1
  Version table:
 *** 3.2.0-18.1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status

I hope this helps.

Li Chong (l-chong-v) wrote :

In Ubuntu 11.04 this bug is not present, but in 11.10 and 12.04 is a hard problem.

Terry (terry-kryogenic) wrote :

I've since replaced my card with an Intel based card so if it helps I'm more than happy to donate the BCM4313 based card to anyone who wants to work on it.

Li Chong (l-chong-v) wrote :

Terry, that's a very sad joke. Anyway, i hope find a wireless card wich works, because this bug doesn't look well...

Terry (terry-kryogenic) wrote :

I wasn't joking but upstream they are not interested. I'm offering a developer the hardware for free to help fix this for others in the future, that's all.

Seth Forshee (sforshee) wrote :

I just found that I actually have a machine with BCM4313 wireless that I hadn't been using. I'm currently trying to reproduce the issue. If anyone has suggestions about circumstances that are likely to trigger the problem (e.g. idle connection, heavy network traffic, low signal, etc.) I'd love to hear about it.

Terry (terry-kryogenic) wrote :

Probably not helpful to you but it just happens for me. To be honest, I've been testing by downloading a Ubuntu DVD ISO and at some point it will happen but I don't have to be downloading for it to happen, that's the thing. I've been trying to find a pattern but I've not found anything consistent enough, it just happens. My only thought was perhaps it's something to do with A-MPDU causing the hang but what I don't know because my experience with kernel hacking and even C is very limited.

CW-3.3 seemed to fix some of the issues (as per the log messages in this bug description) but I get no messages when the main issue starts. If there something I need to do to make it more verbose then let me know and I will see what I can capture, otherwise I guess it needs more debugging?

Li Chong (l-chong-v) wrote :

Well, i will try to describe what happens to me, even with my poor english. Apologies if you can't understand what i mean.

- Ubuntu 11.10 or 12.04 beta 2 and daily releases.
- Kernel 3 and 3.2
- The indicator in HP 425 isn't recognised. Even if the wireless connection works normally, -except for the hotspot -the indicator is in red, not in white, as is turned off.
- This issue is not present in 11.04. It says in "Connection Information" is using the wl controller.
- The controller in 11.10 is brmsc or something like that, i don't remember exactly.
- When, in 11.10 and Kernel 3 and newer versions, i try to create "New wireless connection" in Unity it tries to connect to de AP but never success. It says as the password is not recognised, -wow, is created and don't recognise is own password... haha
- In Gnome Shell i push the button "Create Hotspot" with the same result.
- I tried in all configurations create the hotspot but never can create the connection.

As you could understand, the AP is necessary in my work, because we haven't always a Internet connection, so, i we want a on line work with a collaborative app -as Gobby or Abiword -we need the hotspot.
Thanks for your patience.

Ben (a0-ben-ch) wrote :

My experience has been that it works well with some wifi access points/routers and locks up with others. The router I use at home is a Belkin F5D8236-4 (http://www.belkin.com/IWCatProductPage.process?Product_Id=459569) and I have frequent problems when connected to it, while I don't recall having any issues with the Apple Airport router at work.

Anecdotally I would say that the weaker the signal the more likely it is to have trouble, but I will pay more attention over the next few days and try to provide more information.

Seth Forshee (sforshee) wrote :

I've been trying on-and-off to reproduce this for several days now, but unfortunately no luck. I must not have the right equipment to trigger the bug.

Li Chong (l-chong-v) wrote :

What hardware you have, Seth?

Seth Forshee (sforshee) wrote :

The machine is a Samsung NF310 with BCM4313 wireless, PCI id 14e4:4727 just like in the original bug report. I'm testing with a Linksys E3000 router.

Terry (terry-kryogenic) wrote :

One thing I never tried was trying a different security mechanism, like changing from WPA2 to WPA (and trying both TKIP or AES) and WEP. I just thought of it when I had issues with a PSP connecting to my AP last night. I had to change the wireless settings from TKIP to AES in order for it to work. I can reinstall the card and give it a try later on. Has anyone tried this?

Li Chong (l-chong-v) wrote :

I tried the wireless settings and the hotspot still don't work. (Are we talking about of create hotspots, rigth?)

Terry (terry-kryogenic) wrote :

Just the wifi settings where you set the keys/passphrase usually. You should have WEP or WPA/WPA2 in most cases. Probably not a good idea to change things if you are not sure.

Seth Forshee (sforshee) wrote :

Terry, correct me if I'm wrong, but I believe the bug report is regarding using BCM4313 as a STA (i.e. a client connected to an AP) and not as an AP.

Changed in linux (Ubuntu):
assignee: Seth Forshee (sforshee) → nobody
status: Incomplete → Confirmed
Terry (terry-kryogenic) wrote :

I'm not running it as an AP, I'm merely suggesting that we test with different security modes on the AP (WEP, WPA/WPA2 w/ AES or TKIP) since different AP's sometimes behave slightly differently with different hardware as was the case with my PSP. I only mentioned my PSP because it seemed unusual that it didn't work with the TKIP but did on a previous AP I had. I then thought about this bug and wondered if the encryption method used could be causing issues.

Colin Matheson (biodojo) wrote :

I am getting a similar error using the BCM4313 card on our Acer Aspire One 722 netbooks running 12.04. They see the network and connect using the brcmsmac driver, but will occasionally stop being able to transfer over wifi. Network manager says the netbooks are connected and they have an IP address, but they cannot ping anything. That lasts for about a minute and then they can load webpages again. It seems to happen under heavy network load on the device (but not on the network at large). Running dmesg | grep iee shows that it is constantly reporting the following info:

[ 637.012316] ieee80211 phy0: brcms_c_dotxstatus: INTERMEDIATE but not AMPDU
[ 637.012533] ieee80211 phy0: brcms_c_dotxstatus: INTERMEDIATE but not AMPDU
[ 645.588396] ieee80211 phy0: brcms_ops_bss_info_changed: qos enabled: true (implement)
[ 648.650949] ieee80211 phy0: brcms_ops_bss_info_changed: qos enabled: true (implement)
[ 649.676131] ieee80211 phy0: brcms_ops_bss_info_changed: qos enabled: true (implement)
[ 650.595325] ieee80211 phy0: brcms_ops_bss_info_changed: qos enabled: true (implement)
[ 654.590220] ieee80211 phy0: brcms_ops_bss_info_changed: qos enabled: true (implement)

This error and the messages only appear on our school network. The netbooks work fine on my home network and don't have those log messages. Our school network does use qos for VoIP, but I am not sure why that would have to be reported over and over again. Also I don't know what the AMPDU message is about at all. The same netbooks with an Atheros card have no issue connecting and staying connected, so it seems like an interaction between some aspect of our school network and the BCM4313 card in Linux.

Terry, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the kernel in the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested and remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream-VERSION-NUMBER', where VERSION-NUMBER is the version number of the kernel you tested.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream-VERSION-NUMBER', where VERSION-NUMBER is the version number of the kernel you tested.

If you are unable to test the mainline kernel, please comment as to why specifically you were unable to test it and add the tag: 'kernel-unable-to-test-upstream'.

Please let us know your results. Thank you for your understanding.

Helpful Bug Reporting Links:
https://help.ubuntu.com/community/ReportingBugs#Bug_Reporting_Etiquette
https://help.ubuntu.com/community/ReportingBugs#A3._Make_sure_the_bug_hasn.27t_already_been_reported
https://help.ubuntu.com/community/ReportingBugs#Adding_Apport_Debug_Information_to_an_Existing_Launchpad_Bug
https://help.ubuntu.com/community/ReportingBugs#Adding_Additional_Attachments_to_an_Existing_Launchpad_Bug

summary: - Broadcom BCM4313 random AP disconnects and network hang
+ 14e4:4727 Broadcom BCM4313 random AP disconnects and network hang
tags: added: bot-stop-nagging needs-upstream-testing
removed: kernel-bug-exists-upstream kernel-request-3.2.0-17.27
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Changed in linux:
status: Confirmed → Expired
Ben (a0-ben-ch) wrote :

I can confirm that this bug continues to exist in the stable 3.5.2 kernel from kernel.org

Ben (a0-ben-ch) wrote :

I should have added that I can also confirm that the issue is more prevalent when there is a weak wifi signal. The easiest way to reproduce seems to be to connect to the wifi network and then walk with the laptop away from the AP towards the edge of the wifi range. When the network is hung the load on the machine will go into the 14+ range. Unloading the module with modprobe -r takes a long time, but will eventually unload the module and return the machine to normal where the module can be reloaded.

Changed in linux:
status: Expired → Confirmed
Adam (dr-rockso) wrote :

I can confirm this bug exists in Ubuntu 12.10. My kernel is 3.5.0-17-generic x86_64. I did not have this issue in Ubuntu 12.04, it was only after I upgraded did the issue begin.

For me, my wireless stops working intermittently and then I see "ieee80211 phy0: >brcms_c_prec_enq_head: No where to go, prec == 4" several times repeated in dmesg/kern.log. Like others, iwconfig and network manager both indicate that I am still connected but I cannot ping or connect to any IP, including my router.

My router is a Belkin WR1043ND v1 and I'm connect over 802.11N. My router configuration is the same as it was prior to the 12.10 upgrade and my laptop's hardware hasn't changed either.

Ben / Adam, if you have a bug in Ubuntu, could you please file a new report by executing the following in a terminal:
ubuntu-bug linux

For more on this, please see the Ubuntu Bug Control and Ubuntu Bug Squad article:
https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue

and Ubuntu Community article:
https://help.ubuntu.com/community/ReportingBugs

When opening up the new report, please feel free to subscribe me to it. Thank you for your understanding.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.