10de:1057 "reduce brightness" key freezes system

Bug #922037 reported by Andreas Hasenack on 2012-01-26
This bug affects 10 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)

Bug Description

When I have the Nvidia discrete graphics selected in the bios, pressing the "reduce brightness" key (blue fn + end), the system freezes. It doesn't matter if I'm in X or in text mode, it happens all the time.

I did it while watching the logs (/var/log/syslog, ~/.xsession-errors) and even the debug console when in text mode (F8 iirc), but nothing was written there.

The machine was also unreachable from the network after the fact.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: linux-image (not installed)
ProcVersionSignature: Ubuntu 3.0.0-15.26-generic 3.0.13
Uname: Linux 3.0.0-15-generic x86_64
NonfreeKernelModules: nvidia
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
 /dev/snd/controlC1: andreas 2535 F.... pulseaudio
 /dev/snd/controlC0: andreas 2535 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
 Card hw:0 'PCH'/'HDA Intel PCH at 0xf5320000 irq 46'
   Mixer name : 'Conexant CX20590'
   Components : 'HDA:14f1506e,17aa21ce,00100002'
   Controls : 9
   Simple ctrls : 6
 Card hw:1 'NVidia'/'HDA NVidia at 0xf3000000 irq 17'
   Mixer name : 'Nvidia GPU 1c HDMI/DP'
   Components : 'HDA:10de001c,17aa21ce,00100100'
   Controls : 4
   Simple ctrls : 1
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
 Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw unknown'
   Mixer name : 'ThinkPad EC (unknown)'
   Components : ''
   Controls : 1
   Simple ctrls : 1
 Simple mixer control 'Console',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Thu Jan 26 09:44:29 2012
HibernationDevice: RESUME=UUID=0e0159cb-88a6-4653-9902-6c3934f00ef7
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111011)
MachineType: LENOVO 4177CTO
 PATH=(custom, user)
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.0.0-15-generic root=/dev/mapper/vg0-root ro quiet splash vt.handoff=7
 linux-restricted-modules-3.0.0-15-generic N/A
 linux-backports-modules-3.0.0-15-generic N/A
 linux-firmware 1.60
SourcePackage: linux
StagingDrivers: mei
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/29/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 83ET63WW (1.33 )
dmi.board.asset.tag: Not Available
dmi.board.name: 4177CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr83ET63WW(1.33):bd07/29/2011:svnLENOVO:pn4177CTO:pvrThinkPadT420:rvnLENOVO:rn4177CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 4177CTO
dmi.product.version: ThinkPad T420
dmi.sys.vendor: LENOVO

Andreas Hasenack (ahasenack) wrote :
Brad Figg (brad-figg) on 2012-01-26
Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . If possible, please test the latest v3.2 kernel[1] (Not a kernel in the daily directory). Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed by the mainline kernel, please add the following tag 'kernel-fixed-upstream-KERNEL-VERSION'. For example, if kernel version 3.2-rc1 fixed the issue, the tag would be: 'kernel-fixed-upstream-v3.2-rc1'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'. If you believe this bug does not require upstream testing, please add the tag: 'kernel-upstream-testing-not-needed'.

Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[1] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.2-precise/

Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: needs-upstream-testing
Andreas Hasenack (ahasenack) wrote :

Sorry, the machine wouldn't boot with the Precise kernel 3.2.0-030200-generic_3.2.0-030200.201201042035.

The boot would start, but then the screen would be filled with error messages about some DMA read (see attached photo).

tags: added: kernel-unable-to-test-upstream
Herton R. Krzesinski (herton) wrote :

Andreas, can you try booting with intel_iommu=off kernel parameter? I think you hit another issue in 3.2, or try the newer 3.2.2 build from http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.2.2-precise/, which should have intel_iommu disabled by default.

tags: added: kernel-bug-exists-upstream
removed: kernel-unable-to-test-upstream
tags: removed: needs-upstream-testing
Andreas Hasenack (ahasenack) wrote :

Hm, LP ate my previous comment.

Thanks Herton, that kernel booted, but the freeze problem is still there. As soon as I press Fn+End to decrease the brightness, the machine locks up. Not even the caps lock led reacts.

Andreas Hasenack (ahasenack) wrote :

I updated the BIOS of this laptop from 1.33 to 1.37, no change.

I then installed precise alpha 2 and upgraded, also no change. Still freezes.

Finally, I reinstalled precise alpha 2 but 32bits, not 64 as I had before, and now it works. I can dimm the backlight without having the laptop freeze.

Andreas Hasenack (ahasenack) wrote :

I tried booting with some kernel options, here are the results. Kernel was 3.2.0-14-generic #23 x86_64:
- nointremap: no freeze
- nox2apic: no freeze
- x2apic_phys: didn't boot properly, corrupted graphics and eventually froze on its own

Andreas Hasenack (ahasenack) wrote :

Here is the dmesg output with nox2apic and debug.

Herton R. Krzesinski (herton) wrote :

Ok, so this is the summary about what we found so far regarding this bug:

- The freeze happens only on x86_64, because it has the interrupt remapping/x2apic and it is enabled, compared to the 32 bits version.
- The freeze only happens with x2apic and interrupt remapping. Interrupt remapping and xapic works, only with x2apic mode enabled the freeze happens.

Chow Loong Jin (hyperair) wrote :

The same happens with the Thinkpad Edge E220S, in which the F7/8 keys hang the system with x2apic is enabled. When this happens, even the Thinklight stops responding (eventhough it responds during a kernel panic). I suspect that the BIOS just doesn't know how to handle x2apic mode, causing the entire machine to freeze up.

Andreas Hasenack (ahasenack) wrote :

I just updated the BIOS using the bootable CD from lenovo's support site (worked nicely, btw!):

root@nsn7:~# dmidecode -s bios-version
83ET72WW (1.42 )

I will try a 64bit install this weekend.

Andreas Hasenack (ahasenack) wrote :

Didn't work. I was able to reproduce the problem with the live "cd" from quantal, 64bits.

I downloaded the ISO just now, created a bootable pendrive, booted from it and in the desktop, once loaded, hit the key to dimm the backlight. Instant hard lock.

So, the problem happens in quantal, 64bits, with lenovo's 83ET72WW (1.42 ) BIOS for my T420.

Youquan Song (youquan-song) wrote :

Please try to apply the attached patch to 3.7-rc kernel, then try if it issue is fixed or not.

tags: added: patch
Lukas Z. (lukas-zaruba) wrote :

couldn't this one be a duplicate of https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1007765 or the other way around?

Youquan Song (youquan-song) wrote :

Hi Lukas,

No. this bug is about BIOS SMI broken in x2APIC mode.
While the bug at https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1007765 does not enable x2APIC at all.
so there are different bugs.


Andreas Hasenack (ahasenack) wrote :

Isn't this patch a bit naive? It would disable x2apic on my machine even in the scenario where the bug doesn't happen, like when I have nvidia disabled and only the intel graphics card enabled.

Also, is that simple string comparison seems brittle. Aren't there other submodels of these laptops that are affected?

Youquan Song (youquan-song) wrote :

This issue comes from broken BIOS SMI (like generated when you kick specifica keys etc) hang because it does not aware of OS in x2apic mode. So the workround way is to blacklist issued platform.

Yes. there are other T420 platforms have the issue (https://launchpadlibrarian.net/109393850/dmidecode.txt), so I tend to disable x2apic at all of T420 platforms.

Refer to bug reports:

Please try the patches if it works on your T420.

Daniel Platon (dplaton) wrote :

Hello everyone,

Please note that I'm experiencing the same problem on a Lenovo W520

Licanueto (licanueto) wrote :

Hi there, same here with a fresh 12.10.
I'm on a Dell N5010 without any video card, just intel HD graphics

Youquan Song (youquan-song) wrote :

Hi Licanueto,

Can you upload the information of Dell N5010? Doing like the "bug description" and attachments for this bug.


Imre Benedek (v-nucleo) wrote :

This issue affects people at least one and half years and nothing happens.

Andreas Hasenack, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:

where VERSION-NUMBER is the version number of the kernel you tested. For example:

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:

If the mainline kernel does not fix this bug, please add the following tags:

As well, please remove the tag:

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

tags: added: bios-outdated-1.46 needs-upstream-testing
summary: - "reduce brightness" key freezes system
+ 10de:1057 "reduce brightness" key freezes system
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
eastsun (eastsun) wrote :

The same happens with Thinkpad Edge E220S and Ubuntu 13.04(x64)

eastsun, if you have a bug in Ubuntu, the Ubuntu Kernel team, Ubuntu Bug Control team, and Ubuntu Bug Squad would like you to please file a new report by executing the following in a terminal while booted into a Ubuntu repository kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Please note, not filing a new report would delay your problem being addressed as quickly as possible.

No need exists to comment here at this time. After reading the above documentation in it's entirety, if you have further questions, you are welcome to redirect them to the appropriate mailing list or forum via http://www.ubuntu.com/support/community/mailinglists , or you may contact me directly.

Thank you for your understanding.

Andreas Hasenack (ahasenack) wrote :

fwiw, it still happens with:
$ uname -a
Linux nsn7 3.19.0-30-generic #33~14.04.1-Ubuntu SMP Tue Sep 22 09:27:00 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

And the BIOS is newer also:
# dmidecode -s bios-version
83ET76WW (1.46 )


Andreas Hasenack, while that's fine you provided some new information, nothing has really changed regarding this report as it is still missing the information requested 2+ years ago in https://bugs.launchpad.net/ubuntu/+source/linux/+bug/922037/comments/23 .

tags: added: latest-bios-1.46
removed: bios-outdated-1.46
tags: added: vivid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.