[Lenovo W520] laptop freezes on ACPI-related actions

Bug #776999 reported by Emil F. on 2011-05-04
274
This bug affects 55 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: gnome-power-manager

I got the latest Ubuntu installed on a Lenovo W520 with graphics set to Nvidia discrete card. The laptop freezes, however, on power-management actions, such as brightness change and sleep/wake-up. A particularly annoying problem is that the machine freezes automatically after a GUI login if I had started gnome-power-manager previously. I have to remove the gnome-power-manager settings directory in order to get back in.

If I boot with acpi=off parameter to the kernel things work fine, but then again no ACPI functionality is available.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: gnome-power-manager 2.32.0-2ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Wed May 4 13:09:50 2011
EcryptfsInUse: Yes
GnomeSessionIdleInhibited: No
GnomeSessionInhibitors: None
GnomeSessionSuspendInhibited: No
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
MachineType: LENOVO 427638U
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=df7a5cd8-18b4-4b7a-92c8-6cc8f3647cc9 ro quiet splash vt.handoff=7
SourcePackage: gnome-power-manager
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 03/02/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 8BET30WW (1.06 )
dmi.board.asset.tag: Not Available
dmi.board.name: 427638U
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr8BET30WW(1.06):bd03/02/2011:svnLENOVO:pn427638U:pvrThinkPadW520:rvnLENOVO:rn427638U:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 427638U
dmi.product.version: ThinkPad W520
dmi.sys.vendor: LENOVO

Emil F. (ubuntubugs-morp) wrote :
Emil F. (ubuntubugs-morp) wrote :

Forgot to add... this freeze also occurs when the system is switched from AC to battery power, as well as when it is booted on battery. My wild guess is that this is related to automatic change to the brightness settings. Basically the system is not usable on battery power.

I also had this problem.
when i disable the wireless in bios the laptop works as expected.
This is a bug in the wireless driver.

very strange,

i reinstalled with wireless disabled, updated, enabled wireless and everything is ok.

Emil F. (ubuntubugs-morp) wrote :

Disabling the Wireless card in the BIOS does not solve the problem for me. Even with disabled Wireless when the laptop freezes instantly when I change the brightness in the GUI.

Emil F. (ubuntubugs-morp) wrote :

I removed the nvidia drivers coming with the distro, and installed the latest 64bit drivers from the Nvidia website (270.41.06) just in case. Problem still persists.

I then removed those drivers, and installed the nouveau driver via apt. Problem still persists.

Sumary: This problem does not seem to be directly related to the GPU drivers.

just remembered i also did a bios update to 1.22 maybe that solved that prob?

Emil F. (ubuntubugs-morp) wrote :

I updated BIOS to 1.22 but still have the same problem. I'm testing Kubuntu (11.04) right now, and the same problem is present there as well.

Robin: Do you have the 2000M card or the 1000M? I'm with 1000M here.

I have the 2000m nvidia card (w520 model 4284-49G)
using 64 bit ubuntu 11.01

maybe you can try to set the same bios settings

display to discrete autodetect off
intel amt disabled
security chip inactive
memory protection off
virtualization on

Emil F. (ubuntubugs-morp) wrote :

I set my BIOS settings to match yours, but still no joy - the laptop freezes on any operation that involves changing the display brightness.

majki (spam-majki) wrote :

Wow. Everything Emil F. wrote applies to my case. I too have W520 with 1000M and when I change to discreet it freezes shortly after logging into gnome/unity with either nvidia or nouveau driver. However it works well with integrated card or with discreet before installing nvidia/nouveau driver.

issue is back for met to.
every time i change brightness it crashes

majki (spam-majki) on 2011-05-09
summary: - Lenovo W520 laptop freezes on ACPI-related actions
+ [Lenovo W520] laptop freezes on ACPI-related actions

brightness adjustment still freezes my system, however i did find some workarounds

- in gnome power management disable the function to reduce brightness when running on battery
- you can change the brightness in the nvidia-settings tool

some other observations:

- i even tried kernel 2.6.39 and reinstalled the nvidia driver but that didn't helped aswell

I hope somebody can fix this problem

Pedro Villavicencio (pedro) wrote :

more like a linux issue.

affects: gnome-power-manager (Ubuntu) → linux (Ubuntu)
Brad Figg (brad-figg) on 2011-05-18
Changed in linux (Ubuntu):
status: New → Confirmed

I have the same issue on all our new W520 in the lab. Some of them have the 1000M GPU, other the 2000M. As soon as I switch to discrete graphics mode, I experience the issues described above. All works fine when switching to integrated graphics. But on the other hand, when I change brightness during boot-up, the system still freezes at least some times, so I am not sure if this is really GPU related at all...

Peter Giles (g1l3sp) wrote :

I'm stuck with this issue too. I noticed through experimentation that this doesn't happen with 32 bit 11.04. Maybe that will be a clue for somebody? I was on the verge of moving to the 32 bit version when I discovered this launchpad bug and the workaround. Whew!

description: updated

In my case the W520 always freezes after Grub and before reaching the login screen when Discrete Graphics is enabled in the BIOS.

I've tried BIOS version 1.06, 1.22 and the latest 1.25 (1.25 on the Lenovo website but 1.24 when flashed), with the same result.

I've read https://wiki.ubuntu.com/DebuggingACPI and can confirm that acpi=off always works and acpi=ht never does. According to that page this means that "the issue is in the ACPI table parsing code itself, or perhaps the SMP code."

Peter Giles (g1l3sp) wrote :

Following up, the gnome power settings workaround helped slightly, but I still got lots of crashes and unsuspend failures. I did end up going w/ 32 bit Ubuntu 11.04 + nVidia binary driver and things are working quite smoothly now, albeit with 1/2 the bits :-P

Changing the brightness works great after I add

Option "RegistryDwords" "EnableBrightnessControl=1"

under the "Device" section of my xorg.conf.

So who knows why this works fine in 32 bit-ville but not 64?

orGSD (orgsd) wrote :

I will add that unsurprisingly these problems exist with the dock as well. I have through trial and error been unable to find a good stable solution with 64bit whether integrated or discrete graphics used. I am going to try the bios update before taking more drastic measures. The ACPI ones echoed those of this bug, however with integrated graphics I have had some more difficult to diagnose problems recently as well.
I will also add that while googling around for solutions, it seems there are some Windows issues as well:
http://forums.lenovo.com/t5/W-Series-ThinkPad-Laptops/W520-BIOS-1-25-doesn-t-fix-resume-from-sleep-with-16GB-of-RAM/td-p/444921

My machine does have 16GB of RAM so that may be interesting to investigate.

Peter Giles (g1l3sp) wrote :

Adding my data point to what orGSD added to the conversation, I have 12 GB of ram, so maybe there is some threshold, say over 8 (wild guess) where these issues manifest?

W520 config:
   Ubuntu 11.04 64 bit
   12 GByte Ram
   SSD + HD
   Nvidia M2000

freezing on:
   1. BIOS discrete + "change brightness Fn+Pos1 / Fn+End"
   2. BIOS integrated + "powersave-setting energysaving on AC after 1 hour" -> never wakeup from energysaving-state (ramsleep)
   3. BIOS integrated + "playing sound" (while editing this bug report :o) ... Display-Content/Mouse freeze + sound playing endless-loop

go4run (goran-stepic) wrote :

It affects me too in the following configuration: Ubuntu 11.04 64-bit, Lenovo Thinkapd W520 , dedicated graphic Nvidia 2000M selected in BIOS, Nvidia proprietary driver installed. Running in the docking station oder with power supply no issues, running on battery the boot process stops at the line: "... <30>udev[84]: starting version 167".
The same behaviour occures if using the experimental Nuveau driver.
Running without issues on battery wenn integrated IntelHD 3000 graphic selected in BIOS.
Suggested workaround by forcing pm-utils to version 1.3.x did not work for me...

go4run (goran-stepic) wrote :

Following the user gatman3 tip (http://ubuntuforums.org/showpost.php?p=10977811&postcount=4) have switched to 32-bit of Ubuntu 11.04 on my Thinkpad W520 and wonder oh wonder - everything is working to the very satisfactory level, see first impression here http://ubuntuforums.org/showpost.php?p=11004403&postcount=7.
Now I am not quite happy to run 32-bit system on the "fastest laptop of the world", is like driving with handbrake on. Since I am paying for Ubuntu Advantage Advance Desktop - 3 Year support (anywhere else around paying for Linux support?) I will see if I can manage to get the developers attention to focus on fixing the issue with 64-bit version.

Andrew Rowe (emlinhanhdy) wrote :

same issue here.
8GB mem
running 11.04 x64

~most~ of the time, the system cycles just fine. Been running 64bit out of the gate on discrete graphics (Quadro disabled in the BIOS).

However, in the past 2-3 days, the system does not behave well when booting from cold or warm reboot. it hangs on restart & then I have to seriously jerk the thing around to get it to come back up.

AC power/Batery/Docked/Undocked...doesn't matter. One thing that is weird. It seems to act a little better when I boot up with my Seagate portable eSATA drive connected. Who the hell knows why that would be, but in any case...i go from about 40% success to 70% success on reboot when that sucker is plugged in.

I never use the dimming buttons (Fn+Home/Fn+End), but tested it for S & giggles....it froze the box. I'll try the recommended xorg fix above to see if that does anything.

I really need the extra memory & can't really go back down to 32bit. I run a couple virtualbox systems at the same time and having enough mem is important. also having multiple monitors is important too.

go4run (goran-stepic) wrote :

Andrew, Ubuntu 11.04 32-bit automatically installs the PAE extension so you will be to use up to 64 GB memory. I am running 16GB RAM and tested it, see further information here http://ubuntuforums.org/showpost.php?p=11004403&postcount=7. Also the 32-bit Ubuntu 11.04 solved the issues with NVidia GPU, external monitors are working very well too.
On one hand, I have a subjective impression that the 32-bit system is slightly slower than 64-bit one but on the other hand, even the 32-bit Ubuntu 11.04 is far away faster then MS Windows 7 Enterprise 64-bit, again, my subjective opinion, feeling and some objective test I performed (I recall, my "fastest laptop in the world" has i7-2820QM, 16GB RAM, SSD Vertex3 Pro 240 GB with 6.0 GB/s speed)
- MS Window 7 64-bit takes 2.2 GB Memory after the start, running nothing else, Ubuntu ~ 400MB after the start.
- Ubuntu reacts faster and smoother then MS Windows 7 etc...
Never then less, Ubuntu team, wake up and fix the 64-bit version!

w520, i7-2820QM, 16GB RAM, nvidia 275.19:
more acpi mess ups:
KUbuntu 11.04 32-bit: Fn + brightness up / down does not work (no hangs)
KUbuntu 11.04 64-bit: Fn + brightness up / down works, but hangs as people reported above

orGSD (orgsd) wrote :

I have found a solution to brightness changing if you have gone the 32bit route to solve the issues in this bug report.

In Kubuntu 11.04 32-bit, change to a virtual console, ie: alt+ctrl+F1, change brightness with Fn+brightness to the desired level, then alt+ctrl+F7 to get back to X and the level should be retained. This isn't the most elegant but it is repeatable for my machine.

Also for what it is worth, it seems that other distros are not having these problems. I have read reports of very happy slackware and Gentoo users running 64bit gnome and KDE on the w520 with Discrete graphics. I simply haven't had the chance to mess with trying something else yet.

Kubuntu 11.04 32-bit brightness workaround confirmed:
alt+ctrl+F1, Fn+brightness, alt+ctrl+F7

gentoo people have same problems; they are just smarter then us :-)
http://forums.gentoo.org/viewtopic-t-883277-start-0.html

this: Option "RegistryDwords" "EnableBrightnessControl=1"

resolves Kubuntu 11.04 32-bit brightness problem

Charles Profitt (cprofitt) wrote :

The xorg.conf did not resolve my ACPI issues.

Charlie Kravetz (charlie-tca) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Charles Profitt (cprofitt) wrote :

Boots:
Try booting with the "acpi=off" kernel parameter
Try booting with "pci=noacpi"
Try booting with "noapic"

add:
Option "RegistryDwords" "EnableBrightnessControl=1"

I can control brightness but the OSD does not work properly:
Try booting with the "acpi=off" kernel parameter
Try booting with "pci=noacpi"

OSD works and I can reduce brightness:
Try booting with "noapic"

Did not boot:
Try booting with "acpi=ht"
Try booting with "acpi=noirq"
Try booting with "pnpacpi=off"

Charles Profitt (cprofitt) wrote :

Try booting with "pci=noacpi"
Option "RegistryDwords" "EnableBrightnessControl=1"

results in OSD working, brightness control working and I can suspend and resume.

@ Charles Profitt: what is your hardware / os details?

Charles Profitt (cprofitt) wrote :

Andrei:

Lenovo W520 - 4284-WJ3 - i72720QM

2.6.38-10-generic #46-Ubuntu SMP Tue Jun 28 15:07:17 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

@ Charles Profitt:
my config info, that works:
http://ubuntuforums.org/showpost.php?p=11116461&postcount=68

Ian Lacey (iansta-guy) wrote :

Things that started happening at the same time that I began getting this bug: Brightness meter APP stopped working, it disappears when i click the slider bar; wireless says pending connection and requires a reboot; wireless cuts out often soon after changing to powersaver with CPU Frequency Scaling Monitor APP; power usage dropped but crashes randomly after plug in/out. Ubuntu crash randomly after a startup off battery.

Things that I tried but didn't work: I Downgraded "pm-utils" to 1.3 and locked it. Restarted and it froze again quickly.

Things that seemed to work so far: Completely removed "pm-util" along with "acpi-support"?(memory laps) and "can't remember"
;then for fun and good measure i searched for "power save" and I installed "laptop-mode-tools"(Tools for powersavings based on battery/ac status) "rovclock" (frequency control for Radeon Cards) "uswusp" (tools to use userspace software suspend provided by linux) I restarted and left it sit running on battery and it didn't seem to crash but laptop mode gave me a little trouble sending me to a message screen so i removed it after
;Currently after realizing what to tools are for I removed "laptop-mode-tools" "rovclock" "uswusp" rebooted and have been running on battery on and off for 30 minutes after booting off battery with decent power usage and fan off time. Then I reinstalled "pm-utuil" without restarting and without reinstalling "ACP-support" and it continues to run so far even when i mess with the CPU frequency unplugged.

I have a HP TouchSmart Tx2 1024ca Ubuntu 10.10 (Not 11.04 because I'm afraid of grub2 updates for compatibility with startup manager and my default boot) 64 bit AMD x2 64, ATI Radion 3200 with catalyst control center installed and powerplay on.
I'm not shure if this is to much info but this is my experience.

Flemming (flhou) wrote :

Hi

I see the same problem with Ubuntu 10.10 & 11.04 - any status on the bug?

ThinkPad W520 4284-49g (Nvidia Quadro 2000M, 16 Gb RAM, Nvidia 280.13)

regards
Flemming

Andy (abeani) wrote :

This bug also hit me - but I can confirm, that after booting with "pci=noacpi" and adding the EnableBrightnessControl option almost everything works like a charm for me: Almost - just the OSD of the brightness control is shown but does not follow the brightness change - but I can live with that... ;-)

My config:
W520 NY549GE/428449G
Nvidia Quadro 2000M, 16Gb, Nvidia 280.13
Natty with 2.6.39 Kernel

Samson Yeung (fragmede) wrote :

Thinkpad W520 - 4270CTO (Nvidia Quadro 1000M - 4 Gb RAM - nouveau)
BIOS version 8BET50WW ( 1.30 ) - latest on lenovo's site
(setup UEFI boot - BIOS set to UEFI only)

If I disable VT-d extensions in the BIOS, then I don't need to set pci=noacpi to prevent crashes.
(vmx is still enabled.)

Yoav Weiss (yeeeev) wrote :

Running W520 - Nvidia quadro 2000M, 16GB, 11.10 x64
Turning on VT-d option in the BIOS cause the system to fail to boot at all. Turned off VT-d, and everything works fine.

After updating to the latest BIOS 1.32 and Ubuntu 11.10 I can now successfully boot into Ubuntu without using acpi=off. I can even leave Optimus switched on in BIOS and Ubuntu seems to be using the Intel card when the nvidia driver is not installed.
I'm booting with legacy BIOS mode (not UEFI), both virtualisation options turned on, Optimus turned on with OS detection turned off.

Charles Profitt (cprofitt) wrote :

I flashed to 1.32 and can not complete a boot with discrete graphics turned on unless I add the noapic to boot options.

See my bug report #787809 for complete information.

My ASUS x56TR freezes when power cord is unplugged or plugged. I've updated my BIOS to the newest version -> no success. Adding "acpi=off noacpi" to boot command, seems to help however, but i've not tested it long enough to be certain.

Daniel A. (alive-dienub) wrote :

I have a Thinkpad T520 with Nvidia NVS 4200M, using proprietary drivers. It also freezes whenever brightness is turned up/down. Disabling VT-d fixes the crashes when trying to turn up/down brightness but disables brightness (adjusting brightness does not work).

Disabling ACPI is not a good workaround, as this disables ALL power management and makes it so that Ubuntu fails to recognize the laptop as a laptop. It breaks the "power plugged in" light on the laptop.

I think this warrants that the Thinkpad series of laptops is no longer advised as "compatible" with Ubuntu. I bought this laptop because of that recommendation and feel cheated! The recommendation is dishonest.

Joshua Cloud (joshua-cloud) wrote :

I, too, can confirm this bug. I also noticed the connection when I flip on the wireless hardware switch - it freezes then, too. I thought they were separate issues (they may still be), but reading above makes me wonder if it is indeed related. I can boot up about 30% of the time. Adjusting the brightness freezes it. I can live without adjusting the brightness, but the 30% boot success rate and the failure to boot at all on battery is not an option for me anymore. Real embarassing going to meetings and spending 15 minutes power cycling my machine. (It'd be funny if it wasn't so frustrating) REAL close to just going back to Windows 7 64-bit. Been dealing with this for upwards of 6 months. Issue existed in 11.04 as well for me.

I am running 64 bit 11.10, and VMware Workstation within Ubuntu with a 64-bit Windows 7 Guest for certain business apps. nVidia 2000M in my case. 16GB RAM.

I will try the suggestion by Andy (abeani) above and update below.

Peter Giles (g1l3sp) wrote :

I would strongly encourage people struggling with these issues on 64 bit Ubuntu to go with 32 bit Ubuntu instead. It will automatically use the PAE kernel so that you can take advantage of all your ram, and everything will be rock solid (or much closer to it) -- hugely, vastly better. That was certainly my experience. I lost so much productivity struggling with the 64 bit version that I hate to even think about it.

re: "go with 32 bit" - yes, I also recommend this.

Joshua Cloud (joshua-cloud) wrote :

Re: 32 bit recommendation - Just out of curiosity - can you still use VMware to run a 64-bit guest OS if you do that?

BTW - I tried Andy's suggestions and it was stable for about a week. However, after the latest round of updates, it did a PSOD and after getting into grub, I notice my changes were suddenly reverted back.

Pattrick Hueper (phueper) wrote :

I am also affected by this bug, but found a solution where for several days now booting works, suspend works
using 64bit 11.10

all i did was:

use "noapic" as Kernel cmdline parameter

I have successfully suspended/restarted in the last few days, i am not sure about booting on battery, but this has made the system much more stable for me while keeping acpi working.

Andreas Hasenack (ahasenack) wrote :

Can you still change the brightness after going with a 32b installation, or using the "noapic" parameter?

I reinstalled with precise 32bits and it doesn't freeze anymore, but the brightness control doesn't work either. The indicator shows up in the right top corner and the slider moves about, but the actual brightness doesn't change.

I'll try rebooting with acpi_backlight=vendor later.

Andreas Hasenack (ahasenack) wrote :

btw, mine is a T420, but it had the same symptom, so I posted here.

Pattrick Hueper (phueper) wrote :

I cannot control brightness with my current setup.
However i remember having tested brightness with a clean install on another disk and brightness control worked after adding

Option "RegistryDwords" "EnableBrightnessControl=1"

in xorg.conf

I am using the nvidia proprietary drivers and running in Discrete Graphics mode.

I cannot verify this right now, since i dont want to restart X, but will try to verify later on. Would be worth a try anyway

Andreas Hasenack (ahasenack) wrote :

There is no /etc/X11/xorg.conf anymore, do I need to start one from scratch nowadays to add that EnableBrightnessControl option?

Pattrick Hueper (phueper) wrote :

Hm... mine was there... it only contained this:

Section "Device"
        Identifier "Default Device"
        Option "NoLogo" "True"
EndSection

and i added the EnableBrightnessControl line inside the Device section.

Cley Faye (1vd1jn03c) wrote :

FYI if you still need something from xorg.conf on a recent system, you should look at things like HAL configuration.

But to do a quick fix with xorg.conf stuff, you can create little files in "/usr/share/X11/xorg.conf.d" with only a section (or part of a section). This path should be visible if you look at your xorg startup log.

This also allow easier management of all the little hacks you could do.

Pattrick Hueper (phueper) wrote :

I verified it.

Adding EnableBrightnessControl to xorg.conf (either in /etc/X11/xorg.conf or other ways as suggested by Cley) fixed it for me, i can now change brightness.

Andreas Hasenack (ahasenack) wrote :

On 64bits, where the problem occurs, can someone try these boot options, one at a time:
- nointremap
- nox2apic
- x2apic_phys

On my T420, the first two prevented the freeze when changing the brightness. See https://bugs.launchpad.net/ubuntu/+source/linux/+bug/922037/comments/7

otakuj462 (otakuj462) wrote :

I have also encountered this issue. Running 64-bit linux was a requirement for me, and so all of my tests were performed against that. I found that I was able to boot reliably by setting the graphics to Intel in the BIOS. When graphics were set to Discrete in the BIOS, and Vt-d was turned on, the system would inevitably hang at boot. This could be worked around by setting either noacpi, or noapic - either option would allow the machine to boot reliably. I then discovered that disabling Vt-d in the BIOS would allow the machine to boot reliably with Discrete graphics selected in the BIOS, and without noacpi/noapic flags set. This is the configuration I have been using for the past month, and I'm happy to report that I have no longer had trouble booting. I would like to get Vx-d working again, however, as I use qemu/kvm a lot.

I have a w520 running Ubuntu 11.10 64-bit with the graphics option set to discrete in the BIOS. I was experiencing the same system freezes when I tried to use fn+home/fn+end lcd brightness controls.

Adding 'nox2apic' to the boot options and the nvidia-specific EnableBrightnessControl=1 option in xorg.conf solved the problem for me. The brightness adjusts correctly and the OSD indicator works properly. The wireless kill switch and AC plug/unplug are all working fine as well.

It looks like other, more drastic acpi kernel options work as well, but I'm happy with this relatively minor twiddle. Hopefully this is something that will be fixed in the upstream kernel.

As a follow-up, I still have Vt-d enabled in the BIOS. That may help your case, otakuj462.

Tony Burns (tabolario) wrote :

I can confirm that adding nox2apic to the boot options fixed the freezes, and brightness adjustment works correctly. Here's my set up for reference:

- ThinkPad W520
- NVidia Quadro 1000M
- Intel i7 QM2760
- 32GB DDR3 1600 (PC 12800)
- 2x Samsung 830 256GB SSD configured with Linux software RAID0, LVM, and LUKS
- 64-bit Ubuntu 12.04 Beta w/binary NVidia drivers

One little kernel flag to solve all my problems and everything is working great now. Thanks Bob!

Tony Burns (tabolario) wrote :

And I also have all virtualization settings enabled in BIOS.

Hans Bayle (hansb-i) wrote :

Under BIOS 1.36, Ubuntu 12.04 Beta2, Linux xxxx 3.2.0-21-generic #34-Ubuntu SMP Fri Mar 30 04:25:35 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux, the problem still occurs.

Indeed, with the nox2apic kernel option, I can still enable VT-d, nvidia 295.33 and things stay stable.

But whats is impact of nox2apic ? That you have to keep devices running with less IRQs ?

I'm far from an expert on the subject, but my understanding is that the primary enhancement of x2apic over apic/xapic is 32-bit vs 8-bit addressability of the proc for interrupts. Apic/xapic should be capable of having 255 interrupt processors registered, which should be more than any of our laptops would need.

So from the descriptions above, it sounds like the Lenovo BIOS SMI handling is not supporting x2apic mode. Will post a kernel patch to blacklist x2apic enabling on this system, once I figure out what I need to use for the blacklist.

Kenneth (kron-aikido) wrote :

I am having similar problems on a lenovo T520. Ubuntu 11.10 worked fine but could not talk to the docking station graphic ports. Backtrack 5.2 (an 11.10 branch) worked fine also (again minus docking station). 12.04 can talk to the docking station graphics ports but frequently hangs. I can run it in failsafe graphics mode and it hangs much less often.

bub (kam3bombh-bob-wph05ilav) wrote :

I too have this problem. I solved it with the nox2apic solution.

My question is: What is the downside to using nox2apic or nointremap?

Especially related to virtual machines, and to cpu or other performance considerations.

Any help is greatly appreciated!

Charles Profitt (cprofitt) wrote :

Note: Still having this issue with 12.04

Alexandr Novel (normalex) wrote :

OK, T420, 64 bit, Precise 12.04, the only option that helped to battle those booting freezes is "nox2apic" in the /etc/default/grub

Finally the discrete Nvidia chip graphics works with and without docking station, as well as booting to different primary monitors.

Sergio Mena (sergio-mena) wrote :

Hi,

Lenovo W520. Mint 13 (Maya) 64bit with MATE.

Boot freezes with Discrete Graphics selected on BIOS.

I am also annoyed by this bug, since I need to attach an external monitor on a daily basis.

Best workaround I found: booting W7 (booo!), then using Virtual Box to run Mint off its partition (raw vmdk). Virtual machine configured with two virtual screens. I know, it's a hack, but it does the job, and performance-wise doesn't look that terrible. I can work this way.

Waiting for this bug to be fixed to move back to native Linux :-(

Steve Trotman (doctordos) wrote :

Hello,
I can confirm that this bug also affects the W530. With discrete graphics enabled I get boot hanging at udev in Mint 13 Maya 64-bit. Adding the nox2apic boot parameter allows the system to boot without issue.

Michael Iles (michael-iles) wrote :

I'm also affected. I thought things were going well with my W520: I got 12.04 64-bit working in discrete mode with Unity3D and it was all good until I installed VirtualBox and realized that VT-X was turned off in my BIOS. I turned it on and then could no longer boot (I need fast virtual machines so disabling VT-X isn't an option for me).

My current symptom is that it will boot with a lot of long pauses, show the purple blank screen, sometimes show the 'Ubuntu' screen with four progress dots, and eventually hang on a BusyBox screen after saying "(initramfs)".

I think I need to go down to 32-bit.

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Triaged → Won't Fix
Tal Weiss (major-tal) wrote :

Please reopen.
T530. Ubuntu 12.10 64 bit.
Freezes when brightness is changed (automatically by os).
Sometimes does not boot at all.

tinotom (tinotom) wrote :

Same here, ubuntu 13.04 64 bit, brightness changed by fn+up/down and the system freezes.

I'm also affected. Ubuntu 13.10 64 bit. Freezes between GRUB and login if I set graphics to discrete card.

Sorry, forgot to say this is on a Lenovo T520 with Intel HD3000 + Nvidia 4200M

Mark Allan (mallanmba) wrote :

Please reopen. Same issues for me on Ubuntu 12.04 64 bit. Frequent lockups during boot, cannot resume, locks up when brightness changed.
T520 + NVidia 4200M
32 bit install of Ubuntu 12.04 is solid, 64 bit install of Ubuntu 12.04 is unusable

Ingo Bürk (ingo-buerk) wrote :

Please reopen. This happens to me for Ubuntu 14.04 on a Lenovo T530 with nvidia drivers. It only happens when I switch to Discrete Graphics in the BIOS, but running in Optimus breaks other things (cannot change the virtual layout of external screens without glitches).

Using all the proposed kernel parameters in this thread so far as well as adding the EnableBrightnessControl line only prevents freezing the system, but the brightness does not change. I also tried xbacklight and changing the value in /sys/class/brightness/.../brightness.

Ingo Bürk (ingo-buerk) wrote :

This is what happens when I tried "echo 5 > sudo tee /sys/class/backlight/acpi_video0/brightness". It instantly froze everything except the mouse pointer, which froze after about 10 seconds as well. You can see lots of erros in the log file.

prs (peteo) wrote :

Had problem on Lenovo W520 with Kubuntu 14.04 to get external VGA AND LVDS working.
With Optimus no chance.
Had to switch to discrete graphics in Bios.
Nvidia drivers nogo.
Switched to Nouveau i.e. reinstalled the driver.
But than had problem with brightness on LVDS.
Finally figured out working boot params:

GRUB_CMDLINE_LINUX_DEFAULT="agp=off quiet splash acpi_osi=linux thinkpad-acpi.brightness_enable=1 nox2apic"

Other settings like recommended here https://wiki.ubuntu.com/Kernel/Debugging/Backlight did not work.

Works for now. Will check next on docking station.

Mario Splivalo (mariosplivalo) wrote :

I case anyone runs into this later in time:

I just got W520 and moved my Trusty installation from T520. Had various issues, mostly explained above. Upgraded to nvidia-352, upgraded to linux-image-generic-lts-wily (linux 4.2.0), problems persisted.

Then I just disabled VT-d in BIOS, and all the problems are gone. Didn't need to supply any special kernel boot parameters (my GRUB_CMDLINE_LINUX_DEFAULT line holds only 'verbose' in it).

I am running BIOS v1.30.

jz (syed-zaib) wrote :

This problem still Presist in Ubuntu 14.04 (fully updated as of today). I have Lenovo W520 running Ubuntu 14.04 and NVIDIA Corporation GF108GLM [Quadro 1000M]. Anything that tries to change brightness can freeze the system, but only if running in Discrete Graphics Mode (in BIOS). I need Discrete mode to run multi-monitor setup.

Workaround I am currently using successfully is to disable Vt-d through bios (as others suggested). But this is limiting my system's capability to effectively utilize visualization technologies.

Please fix this. (Please let me know if I can be of any help in this regard).

bub (kam3bombh-bob-wph05ilav) wrote :

Under Fedora I use the kernel parameter of nox2apic
Perhaps there is a similar one for Debian.

linuxball (linuxball) wrote :

The bug still exists in Ubuntu 14.04 LTS and 16.04 LTS. As proposed in comment #76 I filed a new bug report as bug #1687910.

tags: added: trusty xenial
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers