1814:3090 RT3090 Network speed are very low

Bug #896582 reported by Hansen on 2011-11-26
100
This bug affects 22 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Ike Panhc

Bug Description

Ubuntu 11.10 Oneiric ocelot Desktop 64-AMD. Lenovo Ideapad s205
After blacklisting acer_wmi in /etc/modprobe.d/blacklist.conf wifi seems to work and can connect. see Bug: #875659
But Network speed drops very fast and after1-2 minutes it is stable under 50-70Kb/s, and other devices on the wifi network looses their connection.
Bug #651778 is an older bug (unsolved) about R3090 but concerns RT3090 being unstable, it does not appear to be the same bug.
On Ubuntu forums there are several threads with different solutions: Installing older version of Markus Heberling's Ralink 3090 driver, install compat-wireless driver, but some solutions are not consistent for different users on the same hardware.

WORKAROUND: In Oneiric with kernel >= 3.0.0.13, blacklist acer_wmi , and use the rt2x00 drivers from https://launchpad.net/ubuntu/+source/linux-backports-modules-3.0.0 from 22nd November 2011.

Add to /etc/rc.local:
iwconfig wlan0 power off

WORKAROUND: In release prior to Precise, I installed this driver: https://launchpad.net/~markus-tisoft...0~ppa1_all.deb
It did not work with newer driver.

Blacklisted "acer_wmi" in /etc/modprobe.d/blacklist.conf

Added "rt3090sta" to /etc/modules

Original source: http://ubuntuforums.org/showpost.php?p=11391544&postcount=20

WORKAROUND: In Precise, once the Ralink driver is downloaded, unpack and edit the file ../common/cmm_wpa.c :

Code:

UCHAR PrimaryRsnie;
  BOOLEAN bMixCipher = FALSE; // indicate the pairwise and group cipher are different
  UCHAR p_offset;
- WPA_MIX_PAIR_CIPHER FlexibleCipher = MIX_CIPHER_NOTUSE; // it provide the more flexible cipher combination in WPA-WPA2 and TKIPAES mode
+ WPA_MIX_PAIR_CIPHER FlexibleCipher = WPA_TKIPAES_WPA2_TKIPAES; // it provide the more flexible cipher combination in WPA-WPA2 and TKIPAES mode

then lastly in the file ../os/linux/config.mk :
Code:

HAS_GREENAP_SUPPORT=n
 #Support MAC80211 LINUX-only function
-HAS_CFG80211_SUPPORT=y
+HAS_CFG80211_SUPPORT=n

 #Support RFKILL hardware block/unblock LINUX-only function
 HAS_RFKILL_HW_SUPPORT=y

Run "sudo make ; sudo make install", blacklist "acer_wmi" in /etc/modprobe.d/blacklist.conf , and you should have a working built module/driver.

It's helpful to blacklist rt2800pci so the system doesn't use this - it will use the new rt3090sta/rt2860 instead after a reboot...

Original Source: http://ubuntuforums.org/showpost.php?p=11672761&postcount=71

---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.23-0ubuntu3
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 1: SB [HDA ATI SB], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: mads 1601 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Generic'/'HD-Audio Generic at 0xf0244000 irq 44'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,00aa0100,00100200'
   Controls : 4
   Simple ctrls : 1
Card0.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Card1.Amixer.info:
 Card hw:1 'SB'/'HDA ATI SB at 0xf0240000 irq 16'
   Mixer name : 'Conexant CX20590'
   Components : 'HDA:14f1506e,17aa6005,00100002'
   Controls : 8
   Simple ctrls : 5
DistroRelease: Ubuntu 11.10
HibernationDevice: RESUME=UUID=43d5b530-46f6-47fd-9f9f-382af486bce3
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
MachineType: LENOVO 1038D4G
Package: linux (not installed)
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-12-generic root=UUID=84e0bb29-2934-4576-9619-4d55b3707f23 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
RelatedPackageVersions:
 linux-restricted-modules-3.0.0-12-generic N/A
 linux-backports-modules-3.0.0-12-generic N/A
 linux-firmware 1.60
StagingDrivers: rts5139
Tags: oneiric running-unity staging
Uname: Linux 3.0.0-12-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 08/10/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 4BCN24WW
dmi.board.asset.tag: Base Board Asset Tag Unknown
dmi.board.name: Inagua
dmi.board.vendor: LENOVO
dmi.board.version: 109-B78210-00A
dmi.chassis.asset.tag: Chassis Asset Tag Unknown
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Chassis Version Unknown
dmi.modalias: dmi:bvnLENOVO:bvr4BCN24WW:bd08/10/2011:svnLENOVO:pn1038D4G:pvrIdeapadS205:rvnLENOVO:rnInagua:rvr109-B78210-00A:cvnLENOVO:ct10:cvrChassisVersionUnknown:
dmi.product.name: 1038D4G
dmi.product.version: Ideapad S205
dmi.sys.vendor: LENOVO

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 896582

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: oneiric

apport information

tags: added: apport-collected running-unity staging
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Hansen (moteprime) wrote : Lspci.txt

apport information

Hansen (moteprime) wrote : Lsusb.txt

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

This bug affects me too, on a Lenovo S205 running Oneiric 64-bit with the latest 3.0.0.13 kernel.

The laptop uses an RT3090 WLAN chipset and is serviced by the rt2800pci kernel module/driver.

I too see VERY poor speeds (downstream of well under 1Mbps) "out of the box" unless I workaround the issue. After weeks of tests I have found one such fix:

My workaround (after blacklisting acer_wmi to get the WLAN up in the first place - see https://bugs.launchpad.net/ubuntu/+source/linux/+bug/875659) is to run with the latest kernel (at least 3.0.0.13 - this does NOT work with earlier versions) plus also use the rt2x00 drivers from compat-wireless from 22nd November 2011. This daily version (plus the ones from a few days before) included a patch to rt2800pci.c which appears to solve the situation. See the patch here: https://git.kernel.org/?p=linux/kernel/git/linville/wireless.git;a=commit;h=4ba7d9997869d25bd223dea7536fc1ce9fab3b3b

There was a bug raised on the Redhat bugzilla about this too:
https://bugzilla.redhat.com/show_bug.cgi?id=658451

HOWEVER: this particular patch to the wireless branch of git was *reverted* after 22/11/11 since the owner did not think the patch was correct despite it actually fixing this speed issue (at least on my hardware)! See here: https://git.kernel.org/?p=linux/kernel/git/linville/wireless.git;a=commit;h=82e5fc2a34fa9ffea38f00c4066b7e600a0ca5e6

What has also helped for me is adding to /etc/rc.local:

iwconfig wlan0 power off

Now I have acceptible working wireless under Oneiric 64-bit on this Lenovo S205 machine but ONLY after the above workaround.

It certainly appears to be an issue with the kernel modules (or more specifically the rt2x00 drivers included with the Ubuntu-packaged kernel).

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
importance: Undecided → Medium
Joseph Salisbury (jsalisbury) wrote :

I wonder if this could be a duplicate of bug 868225 Is it possible for you to try the rt2860sta driver?

tags: added: kernel-da-key
Hansen (moteprime) wrote :

Hi Joseph Salisbury

Following the Guide at:
http://michael-peeters.blogspot.com/2011/06/fixing-rt2860-wifi-chipset-under-ubuntu.html
I am getting to point 5 at the line:
sudo rmmod rt2860sta
It returns:
ERROR: Module rt2860sta does not exist in /proc/modules
The line:
sudo mv /lib/modules/$(uname -r)/kernel/drivers/staging/rt2860/rt2860sta.ko /lib/modules/$(uname -r)/kernel/drivers/staging/rt2860/rt2860sta.ko.dist
mv: cannot stat `/lib/modules/3.0.0-12-generic/kernel/drivers/staging/rt2860/rt2860sta.ko': No such file or directory

I guess it is because i haven't got it installed at all. ??

Rod Hull (iwantmyjelly) wrote :

Joseph:
Are you sure the rt2860sta driver can definitely service the RT3090 chipset under Linux 3.x?

I have built and installed the latest Ralink rt2860sta driver. However I decided not to follow those instructions that were linked to in the other bug report since they were originally written for 11.04 where the staging drivers were still included under 2.x - they are not any more, hence why that particular command is probably failing for Hansen.

After installation, an "lspci -v" doesn't show the module as available - only the built-in rt2800pci is listed.

In theory if you did want to go ahead and get it to install all is needed after the "sudo make install" is to blacklist any currently loaded rt2x00 or rt2800 drivers (so rt2x00pci/lib/usb and rt2800pci/lib/usb), add a line with only "rt2860sta" in it (excl. quotes) to /etc/modules and reboot. If the driver is able to service the card, it will attempt to be loaded at boot.

It is also apparently possible to build/install the more specific rt3090sta driver to service the RT3090 chipset - see here: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/869502/comments/127

I've yet to try this since my workaround in #23 of installing a specific revision of compat-wireless, plus making sure to use 3.0.0.13 works for me. Unfortunately that patch/revision that worked for me has been reverted in later revisions of compat-wireless.

However, overall I'm not sure trying to get these Ralink drivers to install is really the best approach (unless of course if successful they can be cleanly packaged up as DKMS modules in a PPA specifically for Oneiric).

Wouldn't it be better to focus on getting the built-in rt2x00 driver working correctly?

Hansen (moteprime) wrote :

Hi Joseph Salisbury.
Are there any updates on this bug?

Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . If possible, please test the latest v3.2-rcN kernel (Not a kernel in the daily directory). Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed by the mainline kernel, please add the following tag 'kernel-fixed-upstream-KERNEL-VERSION'. For example, if kernel version 3.2-rc1 fixed and issue, the tag would be: 'kernel-fixed-upstream-v3.2-rc1'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'. If you believe this bug does not require upstream testing, please add the tag: 'kernel-upstream-testing-not-needed'.

Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

tags: added: needs-upstream-testing
Hansen (moteprime) wrote :

I tested with kernel:
3.2.0-6-generic #12-Ubuntu SMP Mon Dec 19 03:37:01 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux
and
3.2.0-030200rc6-generic #201112162235 SMP Sat Dec 17 03:36:15 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux
Bug are still there in both.

tags: removed: needs-upstream-testing
tags: added: kernel-bug-exists-upstream

I can confirm this bug.

This is fixed with Linux 3.3rc1 through this patch: http://git.kernel.org/?p=linux/kernel/git/stable/linux-stable.git;a=commit;h=dfd00c4c8f3dfa1fd7cec45f83d98b2a49743dcd

Please backport it for the Ubuntu 12.04 kernel!

Joseph Salisbury (jsalisbury) wrote :

@Denis, thanks for the info.

Is there any discussion upstream about having that patch added back into 3.2.1 stable?

People affected by this bug are probably wondering why the kernel team doesn't just add the patch and fix it. The reason is that the kernel team is reluctant (not opposed) to apply any patch/driver to a kernel that is not from upstream. Applying patches and adding drivers that don't come from upstream add greatly to the support of the kernel as other upstream patches/drivers may touch the same area as the non-upstream patch and may prevent them from applying cleanly.

Joseph Salisbury (jsalisbury) wrote :

Could you also test the latest v3.3 kernel and confirm the issue is resolved. The kernel is available at:
http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.3-rc1-precise/

Hansen (moteprime) wrote :

Testet with Kernel:
linux-headers-3.3.0-030300rc1_3.3.0-030300rc1.201201191835_all.deb
linux-headers-3.3.0-030300rc1-generic_3.3.0-030300rc1.201201191835_amd64.deb
linux-image-3.3.0-030300rc1-generic_3.3.0-030300rc1.201201191835_amd64.deb

Installed with "sudo dpkg -i *.deb"

mads@Test-Ideapad-S205-oneiric:~$ uname -a
Linux Test-Ideapad-S205-oneiric 3.3.0-030300rc1-generic #201201191835 SMP Thu Jan 19 23:36:54 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Where not able to enable wireless in panel.

Did rfkill list:

mads@Test-Ideapad-S205-oneiric:~$ rfkill list
0: hci0: Bluetooth
 Soft blocked: no
 Hard blocked: no
1: ideapad_wlan: Wireless LAN
 Soft blocked: no
 Hard blocked: no
2: ideapad_bluetooth: Bluetooth
 Soft blocked: no
 Hard blocked: no
3: acer-wireless: Wireless LAN
 Soft blocked: yes
 Hard blocked: no
4: phy0: Wireless LAN
 Soft blocked: no
 Hard blocked: no

Then did:
rfkill unblock wifi
rfkill unblock all
sudo modprobe -r acer_wmi

Was then able to enable wireless, but network speed was not at 60-70 Kb/sec but now at 40-50Kb/sec.

Kernel did not solve bug at my laptop.
Please advice if i performed test wrong.

Yeah unfortunately 3.3rc1 does not fix the issue for me neither. This is weird because some pre-release of Linux 3.2 fixed it for me I think (they had a fix in the 3.2 series but removed it and replaced it with a better one in the 3.3 series). I asked the developers and they say the new fix will be in Linux 3.2.2 or 3.2.3 so should be in precise soon enough, it should work for some at least, while I try to work out what the rest of us can do.

Changed in linux (Ubuntu):
status: Confirmed → Triaged

The fix I was talking about is now included in Ubuntu 12.04 development branch, with the 3.2.0-12.20 kernel. Could you please upgrade and tell me if this fixes the issue for anyone? It does not fix it for me, but it seems like there are two performance issues and I am hitting another one, so it may help some and I'd like to report back to the developers.

Ike Panhc (ikepanhc) wrote :

Hi,

I cherry-pick the patch and disable acer-wmi and build the kernel debs. You can find them at

  http://people.canonical.com/~ikepanhc/lp/896582-1/

Please compare the wireless speed between Oneiric-15.26 and this one, see how it goes.

Hansen (moteprime) wrote :

Sorry for the late reply, i have not been available.

Hi Ike Panhc.
I tested your patched Kernel at http://people.canonical.com/~ikepanhc/lp/896582-1/.

uname -a
Linux Test-Ideapad-S205-oneiric 3.0.0-15-generic #1 SMP Mon Jan 30 10:30:34 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

No problems with acer-wmi. The networkspeed is stable at 70-80 kb/s. It looks like it's the same speed as all ways except when testing kernel 3.3.0-030300rc1.

Dennis-martin-herber.
To be sure, please if you provide a link to the kernel, i will test it as soon as possible.

Ike Panhc (ikepanhc) wrote :

Looks we still do not locate the fix yet. Ok, I will review the patch for rt2x00 and see if there is any hint.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/896582

tags: added: iso-testing

I am still trying to figure this one out with the devs, but my time is limited at the moment. If anyone wants to look into this that would be great: http://rt2x00.serialmonkey.com/pipermail/users_rt2x00.serialmonkey.com/2012-February/004549.html there are two patches (try them seperately, not together) that are worth giving a try according to the developers.

Hansen (moteprime) wrote :

@Dennis-martin-herbers
I am afraid that my technical skill are not good enough to test the patches using compat.

Ike Panhc (ikepanhc) on 2012-02-03
Changed in linux (Ubuntu):
assignee: nobody → Ike Panhc (ikepanhc)
status: Triaged → Confirmed
Thibault Dupuis (dthibault) wrote :

What's new about this bug?
I have the same problem on my HP ProBook 4520s and a RT3090 Wireless Chip (Using rt2800pci driver).
The speed is very slow (50-70Kb/s).

I use Oneiric 11.10.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu laptop testing tracker.

A list of all reports related to this bug can be found here:
http://laptop.qa.ubuntu.com/qatracker/reports/bugs/896582

tags: added: laptop-testing
vonibenz (vonibenz) wrote :

Hi, not only Lenovo machine, but the most common Asus eeePC netbook are affected (or afflicted!) by this issue.
On my machine (1001HA) is installed the ill-famed RT3090 Ralink card, and the WiFi doesn't work at all. It worked fine with the Ubuntu 10.10 but, from then on, it stopped to work (no detection of signal, nor with 11.04 neither with 11.10).
I wrote to Markus Heberling (Launchpad) just to know if it's more advisable to install the driver from the "ppa" (automatic updating) or install from the web-site RaLink (manual updating at every kernel change).
Now I'm waiting, maybe that with Ubuntu 12.04 LTS we will be safe!

vonibenz (vonibenz) wrote :

Here is the email mentioned above:

Dear Markus, my name is Enzo and I'm becoming crazy from the version 11.04 of Ubuntu because, from then on, I can't use the WiFi connection (it worked well only with the 10.10). My netbook is an Asus eeePC 1001 HA, equipped with the WiFi card Ralink rt3090.
About two years ago I downloaded the driver from your site in Launchpad and I added your "ppa" to my Software Sources in order to receive the updates. Upgrading to newer version of Ubuntu maybe something was going wrong.
Now I have downloaded from the site of Ralink the package RT2860 Firmware V26.zip (created on march 2010) but:

1) I'm not sure if this is the last version; if yes, may I install it?

2) Does Canonical, or the Linux foundation, keep up-to-date the drivers or not?
When I open in Ubuntu the window "Added Drivers" (System>Administration) I can see the driver rt3090 "installed and activated" and a note says : "maintained from the developers of Ubuntu".

I don't know what I have to do now: waiting for the new version of Ubuntu (12.04 LTS) or installing by myself the package mentioned above?

Note please that I have NO PROBLEM working with Windows XP (dual-boot) on the same netbook!!
Thank you very much for your attention and forgive my poor english, best regards.

Hansen (moteprime) wrote :

@vonibenz
Hi. We had a longer thread about getting the rt3090 to work in Ideapad s205 here: http://ubuntuforums.org/showthread.php?t=1849602
The was two solutions that worked for me, the one i posted in post #20, and rodhulls in post #71
I have had both of then working until I upgraded to 12.04, but for some unknown reason only sollution in post #71 works for me in 12.04.
Feel free to PM me if you (or anybody) need help.

Hansen (moteprime) wrote :

After header updates to 3.2.0-24 i start having fall-backs to the sub 70Kb/s speeds on the workarounds.
Are there any updates to the RT3090 driver bugs?

Yeah, seems to be works with the latest kernel update

I tried the current kernel for precise 3.2.0-26-generic with and without linux-backports-modules-cw-3.3-precise-generic on my lenovo s205 with RT3090 chipset.
The problem still exists. After some time wireless speed no longer exceeds approx 70KB/s.
While downloading data at this speed, the roundtrip to the access point increases drastically

64 bytes from 192.168.1.254: icmp_req=1025 ttl=64 time=1.34 ms
64 bytes from 192.168.1.254: icmp_req=1026 ttl=64 time=1.33 ms
64 bytes from 192.168.1.254: icmp_req=1027 ttl=64 time=2.12 ms
64 bytes from 192.168.1.254: icmp_req=1028 ttl=64 time=127 ms
64 bytes from 192.168.1.254: icmp_req=1029 ttl=64 time=500 ms
64 bytes from 192.168.1.254: icmp_req=1030 ttl=64 time=501 ms
64 bytes from 192.168.1.254: icmp_req=1031 ttl=64 time=479 ms
64 bytes from 192.168.1.254: icmp_req=1032 ttl=64 time=253 ms
64 bytes from 192.168.1.254: icmp_req=1033 ttl=64 time=894 ms
64 bytes from 192.168.1.254: icmp_req=1034 ttl=64 time=1472 ms
64 bytes from 192.168.1.254: icmp_req=1035 ttl=64 time=1718 ms
64 bytes from 192.168.1.254: icmp_req=1036 ttl=64 time=1952 ms
64 bytes from 192.168.1.254: icmp_req=1037 ttl=64 time=2266 ms
64 bytes from 192.168.1.254: icmp_req=1038 ttl=64 time=2567 ms
64 bytes from 192.168.1.254: icmp_req=1039 ttl=64 time=3319 ms
64 bytes from 192.168.1.254: icmp_req=1040 ttl=64 time=4639 ms
64 bytes from 192.168.1.254: icmp_req=1041 ttl=64 time=5066 ms
64 bytes from 192.168.1.254: icmp_req=1042 ttl=64 time=4938 ms

summary: - RT3090 Network speed are very low with Oneiric.
+ 1814:3090 RT3090 Network speed are very low with Oneiric.

Hansen, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the kernel in the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested and remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, please comment as to why specifically you were unable to test it and add the tag: 'kernel-unable-to-test-upstream'.

Please let us know your results. Thanks in advance.

Helpful Bug Reporting Links:
https://help.ubuntu.com/community/ReportingBugs#Bug_Reporting_Etiquette
https://help.ubuntu.com/community/ReportingBugs#A3._Make_sure_the_bug_hasn.27t_already_been_reported
https://help.ubuntu.com/community/ReportingBugs#Adding_Apport_Debug_Information_to_an_Existing_Launchpad_Bug
https://help.ubuntu.com/community/ReportingBugs#Adding_Additional_Attachments_to_an_Existing_Launchpad_Bug

description: updated
tags: added: needs-upstream-testing
removed: kernel-bug-exists-upstream
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Hansen (moteprime) on 2012-07-31
tags: added: kernel-bug-exists-upstream
removed: needs-upstream-testing

hansen, thank you for testing the mainline. Just to be clear, you tested http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.5-rc7-quantal/ ?

Hansen (moteprime) wrote :

Hi.
The bug does still exist. But i don't thing much has been done to solve it.
I have tested Quantal Alpha 2 for Laptop QA team, plus with kernel v3.5-rc6-quantal. The driver are still far from working properly, the behaviour has changed some, but the network speed are still very poor, and unstable.
I have opened a new bug (Bug #1020081) for the Quantal Laptop test report, the bug started out with the RT3090 being recognized in live session, but are recognized after installed.
I am able to connect to an access point but the network speed are really slow and unstable. Are there anyway for me to do documentation of the scale/extend of the problems with the connection?
Thanks

Hansen (moteprime) wrote :

@Christopher M. Penalver.

I think that you wrote #52 while i was writing my answer #53. ;-)
Please, if my answer are not sufficient, tell me and i will add more information.
Thanks.

hansen:
+ Regarding your comment https://bugs.launchpad.net/ubuntu/+source/linux/+bug/896582/comments/54 :
>"I think that you wrote #52 while i was writing my answer #53."

Just to be clear, you tested http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.5-rc7-quantal/ ? If not, could you please do so?

+ As a potential WORKAROUND, does ndiswrapper work for you following https://help.ubuntu.com/community/WifiDocs/Driver/Ndiswrapper ?

summary: - 1814:3090 RT3090 Network speed are very low with Oneiric.
+ 1814:3090 RT3090 Network speed are very low
Hansen (moteprime) wrote :

I have tested with http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.5-rc7-quantal/ on Quantal. With network speed are slow and very unstable. The same as other Quantal kernels.
As a workaround until the bug gets fixed i use a the proprietary ralink driver, modified by Rod Hull # 23. (IF anybody needs help with this, please tell me and i will provide the information).

description: updated

Marking Triaged as newest mainline tested.

Changed in linux (Ubuntu):
status: Incomplete → Triaged

Hansen, could you please provide the missing information following https://wiki.ubuntu.com/Kernel/LinuxWireless ?

Changed in linux (Ubuntu):
status: Triaged → Incomplete
Hansen (moteprime) wrote :

HI.
The Bugs are consistent on the 4 AP i have tried. It seems that using another AP makes no difference.
AP tested are (Linksys, Icotera, Tilgin and Sagem)
All testing have been within 3-4 meters of AP's.
If the is a regression or not depends. I think that the driver for RT3090 was ok in Ubuntu 11.04, in 11.10 and 12.04 it has this bug, and in 12.10 Bug #1020081.
I have only tested ndiswrapper in 11.10, and it did not work, but i use the proprietary Ralink driver, which has been modified by "Rod Hull" (#23)
I haven't tried Compat drivers, and have no experience with Compat. (and lack of knowledge).

I hope this was "The missing information"?

Hansen, thank you for providing the information.

For regression testing purposes, could you please test for this problem in Natty via http://cdimage.ubuntu.com/releases/11.04/release/ ?

tags: added: precise regression-potential
tags: added: amd64 quantal
Hansen (moteprime) wrote :

Hi, and sorry for the late reply.
I have now tried in several ways, and also tried to get help from others. But i cannot get WiFi working in Natty with the build in open source driver.
The only way i have been able to figure out to get WiFi working in older Ubuntu versions are using WiCd.

Hansen, just to clarify, using WiCd works in Natty?

Hansen (moteprime) wrote :

Well, it seems I got it a bit wrong with the version names against the version numbers. -Sorry about that.
Myself I have not been able to get it to work with Wicd in Natty, but acording to this blog Wicd works in Maverick 10.10:
http://helms-deep.cable.nu/~rwh/blog/?p=177
The blog had many reader and great participation just after the release of the S205, i believe it is credible as documentation.

Quote from blog:
-----------------------------------------------------
Update: Turns out that wireless works in 10.10… OK I have found a workaround for the wireless. It even works with suspend/resume. Update 2: there’s an even simpler method in the comments, though I’ve not tested it myself. Here’s how you can connect using wireless:
- connect via the wired ethernet port
- apt-get install wicd
- apt-get remove network-manager
- disconnect the wired ethernet port
- rfkill unblock all
- start wicd from the applications menu, then use it to connect to your wireless connection.
-----------------------------------------------------

Hansen, unfortunately, if you have not personally followed the directions and it works, it is not helpful for the purposes of this report. Could you please verify what is the earliest release that this problem did not occur in, and how you got it to work?

Hansen (moteprime) wrote :

Ok. thank you.
I far as i can figure out, the rt2800pci driver for RT3090 never worked in Ubuntu (linux).
Wicd did not work for me.
11.10, 12.04, the bug behaviour is that the network speed are very low (40kb/s) but staying there. (and blocking Wifi net).
In 12.10 behaviour the has changed, now the speed goes up and down between full speed and blocked. But the result are still that not much data are coming through.
The solution i use are the proprietary driver from Ralink, modified and installed according the description here:
http://ubuntuforums.org/showpost.php?p=11672761&postcount=71
and blocking the open source rt2800pci driver.

tags: added: natty
tags: removed: regression-potential
tags: added: kernel-bug-exists-upstream-v3.5-rc6-quantal

Hansen, thank you for providing this information.

What WiFi connection type(s) does this issue occur in (e.g. 802.11n, 802.11g, etc.)?

Hansen (moteprime) wrote :

Yes, the issue occur on both 802.11n and 802.11g

Hansen, could you please test the newest mainline kernel http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.6-rc6-quantal/ ?

Hansen (moteprime) wrote :

Hi. Should this be tested on Quantal? -The daily's build does have some graphics driver problems that prevent me from running it.

Hansen, regarding your comments https://bugs.launchpad.net/ubuntu/+source/linux/+bug/896582/comments/69 :
>"Hi. Should this be tested on Quantal?"
Could you please provide the information previously requested in https://bugs.launchpad.net/ubuntu/+source/linux/+bug/896582/comments/68 ?

>"The daily's build does have some graphics driver problems that prevent me from running it."
The daily build of what specifically? Mainline kernel? Quantal?

Hansen (moteprime) wrote :

Hi.
At :http://cdimages.ubuntu.com/daily-live/current/
The builds i tried the last week boots into a black screen. (I had my laptop at warranty repair until a week ago (mouse button)).

Hansen (moteprime) wrote :

Hi. I got Quantal installed now.
There are some changes in the wifi networkspeed bug. -I will do more testing.

Hansen (moteprime) wrote :

Are there any tools i can use to see what's going on with the wifi.
Now i just start 4-5 large downloads from different fast sites and look at System Monitor, but it would be nice to have and idea about what it is that's going wrong.

I've Lenovo S205 with the same wireless chipset and experiencing the same problem.
A few days ago I upgraded to the current dev version of quantal, running kernel 3.5.0-16-generic.
The low speed problem seems to be gone.
I tried it over a longer time and across suspend an resume cycles in a 802.11g network.
Using scp, I copied a larger file reaching about 2.6MB/s contiuously, several times.
Looks fine now!

Hansen (moteprime) wrote :

Hi Florian.
I'm also on kernel 3.5.0-16-generic now, and i think that you are right, but i almost cannot believe it. There has be so much trouble with the rt3090.
I can now maintain a high speed in network throughput.
For now i looks like the has been fixed.

PS: Florian.
I have some difficulties with HDMI sound on the S205, please see this bug:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1020041
Thanks you

Update: The slow-speed problem still occurs. After some time of usage, network speed is limited to about 70kB/s, like it was before. This occurs on another access point, not the one that worked well (see comment #74). I don't have a clue yet, what criteria influence this behavior.

Remark: the rt3090-dkms driver produces a hard-freeze when connecting to a network. It does no longer work on kernel 3.5.

Hansen (moteprime) wrote :

Through the last three days running Quantal, i have not had the 70kB/s bug, but switching between Precise (with proprietary driver), and Quantal with default driver I'm in no doubt that the Quantal default driver does not work as well as the proprietary driver on Precise. The throughput seems unstable and occasionally clogs or stops sending data through for some seconds.
Are there no tools available to test these things?

Florian Achleitner, could you please file a new report by executing the following in a terminal:
ubuntu-bug linux

For more on this, please see the Ubuntu Bug Control and Ubuntu Bug Squad article:
https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue

and Ubuntu Community article:
https://help.ubuntu.com/community/ReportingBugs#Bug_Reporting_Etiquette

When opening up the new report, please feel free to subscribe me to it. Thank you for your understanding.

Helpful Bug Reporting Links:
https://help.ubuntu.com/community/ReportingBugs#A3._Make_sure_the_bug_hasn.27t_already_been_reported
https://help.ubuntu.com/community/ReportingBugs#Adding_Apport_Debug_Information_to_an_Existing_Launchpad_Bug
https://help.ubuntu.com/community/ReportingBugs#Adding_Additional_Attachments_to_an_Existing_Launchpad_Bug

Hansen (moteprime) wrote :

@ Christopher M. Penalver (penalvch)
Would the new bug be marked as a duplicate of this bug?

Hansen (moteprime) wrote :

For me this bug has been solved in Kernel 3.5.

Changed in linux (Ubuntu):
status: Incomplete → Fix Released

I can confirm this.
The problem I reported last was definitely related to that particular access point. Trying different settings showed that it is faster if WMM is turned off.

Florian Achleitner, if you have a bug in Ubuntu, could you please file a new report by executing the following in a terminal:
ubuntu-bug linux

For more on this, please see the Ubuntu Bug Control and Ubuntu Bug Squad article:
https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue

and Ubuntu Community article:
https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Please note, not filing a new report may delay your problem being addressed as quickly as possible.

Thank you for your understanding.

Christopher M. Penalver, I'm still guessing and trying what causes the problems on this access point. Not enough knowledge for a bug report yet.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.