Ubuntu

Logitech camera microphone does not work / makes "chipmunk" sound

Reported by Alex Boardman on 2011-09-07
482
This bug affects 96 people
Affects Status Importance Assigned to Milestone
Linux
New
Medium
Unassigned
linux (Debian)
New
Undecided
Unassigned
linux (Ubuntu)
Medium
Unassigned
Oneiric
Medium
Brad Figg

Bug Description

Did not know which application to log so feel free to let me know and I'll upload the correct log. In Natty, this mic worked great. Now, in the sound control panel, the mic does not show any input level at all and sound recorder does not record any sound.

edit: I can also confirm the same behavior as Alex Popovskiy. It either works but plays too fast (high pitch) or it doesn't work at all.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gnome-control-center 1:3.1.91-0ubuntu3
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
Uname: Linux 3.0.0-10-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Tue Sep 6 20:31:13 2011
ExecutablePath: /usr/bin/gnome-control-center
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110901)
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
SourcePackage: gnome-control-center
UpgradeStatus: No upgrade log present (probably fresh install)
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.22.1-0ubuntu2
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: alex 1594 F.... pulseaudio
 /dev/snd/controlC0: alex 1594 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'SB'/'HDA ATI SB at 0xf9ef4000 irq 16'
   Mixer name : 'VIA VT1708S'
   Components : 'HDA:11060397,18490397,00100000'
   Controls : 36
   Simple ctrls : 20
Card1.Amixer.info:
 Card hw:1 'U0x46d0x809'/'USB Device 0x46d:0x809 at usb-0000:00:13.2-6, high speed'
   Mixer name : 'USB Mixer'
   Components : 'USB046d:0809'
   Controls : 2
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'Mic',0
   Capabilities: cvolume cvolume-joined cswitch cswitch-joined penum
   Capture channels: Mono
   Limits: Capture 0 - 6400
   Mono: Capture 6400 [100%] [31.00dB] [on]
DistroRelease: Ubuntu 11.10
HibernationDevice: RESUME=UUID=8ccfea11-7ba8-42e2-bc75-a37e20a8c83c
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110901)
MachineType: To Be Filled By O.E.M. To Be Filled By O.E.M.
NonfreeKernelModules: nvidia
Package: linux (not installed)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-10-generic root=UUID=3c8a3aec-07c0-47ad-bab8-0365abb68a42 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
RelatedPackageVersions:
 linux-restricted-modules-3.0.0-10-generic N/A
 linux-backports-modules-3.0.0-10-generic N/A
 linux-firmware 1.60
Tags: oneiric running-unity
Uname: Linux 3.0.0-10-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 09/07/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: P1.70
dmi.board.name: M3A770DE
dmi.board.vendor: ASRock
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP1.70:bd09/07/2010:svnToBeFilledByO.E.M.:pnToBeFilledByO.E.M.:pvrToBeFilledByO.E.M.:rvnASRock:rnM3A770DE:rvr:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: To Be Filled By O.E.M.
dmi.product.version: To Be Filled By O.E.M.
dmi.sys.vendor: To Be Filled By O.E.M.

Alex Boardman (boardinary) wrote :
affects: gnome-control-center (Ubuntu) → alsa-utils (Ubuntu)
affects: alsa-utils (Ubuntu) → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 843431

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

I have similar issue with microphone too. But in my case I can record from camera's microphone with 'sound recorder', but resulting recording seems like the recording source was playing very fast.
My camera is Logitech C210 (ID 046d:0819) and it worked ok on Natty

Alex Boardman (boardinary) wrote :

I can also confirm the same behavior as Alex Popovskiy. It either works but plays to fast (high pitch) or it doesn't work at all.

description: updated
description: updated

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel currently in the release pocket than the one you tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

Thank you for your help.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.0.0-11.18

Latest kernel update didn't solve the problem for me

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
lunix (bob-l-lewis) wrote :

Latest 3.0.0-11.18 kernel didn't help for me either. I am using a Logitech C910. Camera works but not the microphone.

I ran some tests and here is what I found: I can record normal sound from webcam's microphone, but only once after reboot. Any subsequent attempts will record high pitch garbage. I've also noticed that track duration counter in gnome-sound-recorder lags (one second in counter is like 2-3 normal seconds) as well as input level indicator. There is also noticeable sound glitch when starting first (normal) record, so maybe this bug is not about the kernel but pulseaudio's fault.

I was wrong about pulseaudio. Now I'm sure its 3.x kernel bug/regression. I've just tested 3 different kernels: 3.0.0 (current oneiric) - no mic input/glitches, 3.1-rc4 (from mainline ppa) - same as above, 2.6.38 (from natty) - mic works flawlessly.

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.0.0-12.19

I did a fresh install of Ubuntu Beta 2 and the microphone now works for me. I'll let the original reporter status this
and close it if he no longer has the issue.

Microphone still doesn't work after cold boot or reboot from windows, but I can get it working by reconnecting the webcam now. It is a workaround, but not really comfortable :(

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.0.0-12.20

I confirm the same problem with a Logitech C310.

No change for me with new kernel

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: regression-release
Changed in linux (Ubuntu):
status: Confirmed → Triaged
sordna (sordna) on 2011-10-15
summary: - Logitech camera microphone does not work
+ Logitech camera microphone does not work / makes "chipmunk" sound
sordna (sordna) wrote :

Adding patch that fixes the issue. Patch taken from kernel bug #35922 as well as archlinux and redhat who already fixed the issue in their kernels. I added many more affected cameras in the present patch. I hope we see it applied to oneiric kernels soon, otherwise the wikis that report how nicely all these Logitech cameras play with linux should be rewritten because the audio has been terribly broken, while it worked fine with natty.

--- drivers/usb/core/quirks.c 2011-10-14 12:48:20.000000000 -0700
+++ quirks.c 2011-10-14 22:31:12.000000000 -0700
@@ -38,6 +38,33 @@ static const struct usb_device_id usb_qu
  /* Creative SB Audigy 2 NX */
  { USB_DEVICE(0x041e, 0x3020), .driver_info = USB_QUIRK_RESET_RESUME },

+ /* Logitech Webcam C600 */
+ { USB_DEVICE(0x046d, 0x0808), .driver_info = USB_QUIRK_RESET_RESUME },
+
+ /* Logitech Webcam Pro 9000 */
+ { USB_DEVICE(0x046d, 0x0809), .driver_info = USB_QUIRK_RESET_RESUME },
+
+ /* Logitech Webcam C210 */
+ { USB_DEVICE(0x046d, 0x0819), .driver_info = USB_QUIRK_RESET_RESUME },
+
+ /* Logitech Webcam C260 */
+ { USB_DEVICE(0x046d, 0x081a), .driver_info = USB_QUIRK_RESET_RESUME },
+
+ /* Logitech Webcam C310 */
+ { USB_DEVICE(0x046d, 0x081b), .driver_info = USB_QUIRK_RESET_RESUME },
+
+ /* Logitech Webcam C910 */
+ { USB_DEVICE(0x046d, 0x0821), .driver_info = USB_QUIRK_RESET_RESUME },
+
+ /* Logitech Webcam C270 */
+ { USB_DEVICE(0x046d, 0x0825), .driver_info = USB_QUIRK_RESET_RESUME },
+
+ /* Logitech Quickcam Pro 9000 */
+ { USB_DEVICE(0x046d, 0x0990), .driver_info = USB_QUIRK_RESET_RESUME },
+
+ /* Logitech Quickcam Vision Pro */
+ { USB_DEVICE(0x046d, 0x09a6), .driver_info = USB_QUIRK_RESET_RESUME },
+
  /* Logitech Harmony 700-series */
  { USB_DEVICE(0x046d, 0xc122), .driver_info = USB_QUIRK_DELAY_INIT },

Changed in linux (Ubuntu):
importance: Undecided → Medium
Edward Hunt (ephunt) wrote :

same problem with a Logitech C310

diqrtvpe (ccollett) wrote :

I can verify that the patch works, with a Logitech C310.

Edward Hunt (ephunt) wrote :

how can I apply the patch?

tags: added: patch
tags: added: kernel-key
47 comments hidden view all 127 comments
saverio (saverio001) wrote :

Same here. If I do a skype test call, I sound like Donald Duck.

Linux Zero 3.0.0-13-generic #22-Ubuntu SMP Wed Nov 2 13:27:26 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux
Bus 002 Device 004: ID 046d:0808 Logitech, Inc. Webcam C600

Andy Whitcroft (apw) wrote :

It seems that the patch in question may have just hit mainline as the commit below:

  commit 2394d67e446bf616a0885167d5f0d397bdacfdfc
  Author: Oliver Neukum <email address hidden>
  Date: Tue Sep 13 08:42:21 2011 +0200

    USB: add RESET_RESUME for webcams shown to be quirky

    The new runtime PM code has shown that many webcams suffer
    from a race condition that may crash them upon resume.
    Runtime PM is especially prone to show the problem because
    it retains power to the cameras at all times. However
    system suspension may also crash the devices and retain
    power to the devices.
    The only way to solve this problem without races is in
    usbcore with the RESET_RESUME quirk.

    Signed-off-by: Oliver Neukum <email address hidden>
    Signed-off-by: stable <email address hidden>
    Signed-off-by: Greg Kroah-Hartman <email address hidden>

$ git describe --contains 2394d67e446bf616a0885167d5f0d397bdacfdfc
v3.2-rc1~183^2~146

As it is marked for stable we should be expecting to see this dropping into the stable tree soon.

Joseph Salisbury (jsalisbury) wrote :

Would it be possible for someone seeing this issue to test the latest 3.2 release candidate, which is available at:

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.2-rc1-oneiric/

tags: added: needs-upstream-testing
Tofi (sq6gtt) wrote :

I have got chipmunk problem too. My webcam is Logitech, Inc. Webcam C200, ID 046d:0802

sordna (sordna) wrote :

Joseph, I tested the 3.2-rc1-oneiric candidate you pointed to, and it resolves the issue for my Logitech Webcam C310 webcam.

By they way, with the affected kernels, apart from the workaround already posted (putting "default-sample-rate = 16000" in ~/.pulse/daemon.conf)

I learned of another workaround; passing the following option to the kernel on boot time: usbcore.autosuspend=-1

This workaround works well. Of course it turns off the feature than allows USB devices to "autosuspend" to reduce energy consumption when not in use.

Dima Spivak (dimaspivak) wrote :

Just writing to confirm that sordna's workaround works. For anyone looking to apply it:

- $ sudo nano /etc/default/grub
- Find the line that begins with GRUB_CMDLINE_LINUX_DEFAULT and append usbcore.autosuspend=-1 to tell the system to never autosuspend USB devices. Note that, within the quotes, this field is space-separated. My line now reads:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash usbcore.autosuspend=-1"
- Save your updated grub file (using nano, CTRL+O and then ENTER to confirm the change).
- Exit your text editor (using nano, CTRL+X).
- $ sudo update-grub

Worked for me.

Am 31.10.2011 15:30, schrieb Santiago Franco:
> Found a quick workaround(Ubuntu Forums) while kernel gets patched.
> Works great with my logitech pro:
>
> Hello. The problem is that the microphone is in the wrong sound rate by
> the pulse audio. As a user do the following:
>
> Code:
> gedit $HOME/.pulse/daemon.conf
> and put the following line on the file:
> Code:
> default-sample-rate = 16000
> save it, and then restart pulseaudio as a user with the following command
>
> Code:
> pulseaudio --kill && pulseaudio --start
> This should solve the problem.
>

Pithikos (manossef) wrote :

Nothing worked for me. I don't have neither the free time to go to an older kernel so will just wait for a fix.

I use the logitech 270c camera on Ubuntu 11.11 64bit. I tryied the daemon.conf solution but that didn't do anything. The audio input will not appear at all for me if I do that.

My problem: Recorded audio is fast forwarded.

Dima Spivak (dimaspivak) wrote :

Pithikos,

Did you try the solution posted by sordna? I have a very similar camera and installation to you and it works flawlessly now.

PS: With the daemon.conf solution, if the audio device doesn't appear at start up, unplug and replug the webcam and it will show up.

-Dima

Alexander Orlov (alxorlov) wrote :

I have the same problem too. My webcam is Logitech C310, 046d:081b.

"usbcore.autosuspend=-1" solved the problem.

diqrtvpe (ccollett) wrote :
Maui Muc (stefan-mauerberger) wrote :

Also for me and my Logitech c210, Santiago's fix worked fine. Thank you very much therefore.

Btw.: I really do not understand why it takes so long to apply a fix which was announced more than a month ago and was already tested by RedHat a.o.? This totally sucks!

sordna (sordna) wrote :

Some good news, official kernel 3.0.9 contains patches that fix this issue for several of the
affected webcams (C200, C250, C270, C300, C310, B/C500, Pro 9000),
so the patch posted here doesn't need to by applied to the oneiric kernel,
we just need the oneiric kernel updated to a newer version.
I believe the latest oneiric kernel 3.0.0-13 corresponds to official linux kernel 3.0.6 ...
How soon can Ubuntu maintainers update the next oneiric kernel to be based on 3.0.9 ?

You can see 2 relevant patches mentioned here:
http://www.kernel.org/pub/linux/kernel/v3.0/ChangeLog-3.0.9

rosencreuz (rosencreuz) wrote :

@sordna: I have C905, the Santiago's fix (#80) worked for me, but I'm not sure if the patch to kernel 3.0.9 contains my camera version as well. I'm using v3.0.0-12-generic in ubuntu and not very comfortable with compiling and patching kernel. My camera is : 046d:080a Logitech, Inc. Portable Webcam C905.

sordna (sordna) wrote :

The webcams I did not list, such as the C905, which are in the patch posted here, will be covered in kernel 3.0.11,
so with the 3.0.9 ( which corresponds to upcoming ubuntu kernel 3.0.0-14 according to this mapping table:
http://kernel.ubuntu.com/~kernel-ppa/info/kernel-version-map.html )
you'll need to keep using on of the workarounds.

Dennis Shimer (dshimer) wrote :

Santiago's fix (#80) made skype work for me but broke gmail voice functions and Audacity (for me). As they are more important to me than Skype I tried Tuomo's (#87) and it worked not only with the test, but with an actual call. I guess starting the camera before the call made it work.

Brad Figg (brad-figg) on 2011-12-09
Changed in linux:
importance: Undecided → Medium
Changed in linux (Ubuntu Oneiric):
importance: Undecided → Medium
assignee: nobody → Brad Figg (brad-figg)
Brad Figg (brad-figg) wrote :

There are test kernels at: http://people.canonical.com/~bradf/lp843431.

These kernels contain the commit by sordna which add quirks for
3 Logitech webcams. Please test the appropriate kernel for your
install and report back here on how these kernels work for you.

Changed in linux (Ubuntu Oneiric):
status: New → In Progress

The attachment "patch with fix for additional webcams as of 2011-10-25" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: kernel-da-key
tags: removed: kernel-key
sordna (sordna) wrote :

When is a the standard 3.0.0-14-generic going to be released ? It's taking very long.
Hopefully 3.0.0-15-generic will follow soon after, will that be based on 3.0.11 or on some other kernel version?

Brad Figg (brad-figg) wrote :

@sordna,

It has passed testing and is currently waiting to be copied from -proposed to -updates.

sordna (sordna) wrote :

Great, I got the update and can confirm linux-image-3.0.0-14-generic fixes the problem on my C310, and should do the same for the all webcams in the earlier patch: (C200, C250, C270, C300, C310, B/C500, Pro 9000)

For other webcams like the C600, C905, the E3500 and others, people will have to wait for ubuntu kernel 3.0.0-15 (assuming will be based on official linux kernel 3.0.11 or later, which has the latest, more complete patch)

Brad Figg (brad-figg) wrote :

A newly released kernel fixes the problem for the original submitter (and others).

Changed in linux (Ubuntu Oneiric):
status: In Progress → Fix Released
Changed in linux (Ubuntu):
status: Triaged → Fix Released
Sergey (gansbrest) wrote :

Same problem for me, mic doesnt work in sound settings or skype. Kernel linux-image-3.0.0-14-generic didn't fix the problem.

I've got Hercules Duplex Exchange Usb camera with built in MIC, not sure how to get the ID.

Gilbert (yowtse) wrote :

I can confirm that 3.0.0-14-server fixes the chipmunk sound in my case, my usb webcam is the following (using lsusb):

046d:0809 Logitech, Inc. Webcam Pro 9000

Agent (agent-m) wrote :

I reversed the 2 workarounds that were posted earlier, Installed 3.0.0-14-generic and can confirm that it appears to be fixed so far.
Webcam Pro 9000

I have tested 3.014 kernel and i think it sill doesnt fix the bug for Logitech Webcam B500.

Bus 001 Device 006: ID 046d:0807 Logitech, Inc. Webcam B500

as Sergey wrote on 2011-12-13:, mic doesnt work in sound settings or skype.

Holger Seelig (holger-seelig) wrote :

The kernel 3.0.0-14-generic works for me :)
Webcam Pro 9000

sordna (sordna) wrote :

Sergey, the Hercules Dualpix webcap fix is in the 3.0.0-14 kernel, to get the ID do: lsusb on a terminal and you should see a device with ID 06f8:0804

Carlos, the B500 fix is in this kernel as well. I suspect you are having some other issue or haven't configured the applications correctly. Maybe you need to use pavucontrol and asociatiate your webcam to your applications.

Same problem as Sergey: 3.0.0-14 kernel from updates and 3.0.0-15 kernel from proposed do not fix the microphone problem for Hercules Dualpix Exchange webcam.

@sordna : Indeed, the ID associated to the webcam in the patch from comment #74 is not correct:
lsusb says
ID 06f8:3005 Guillemot Corp. Hercules Dualpix Exchange

@Brad Figg : is it possible to included to fix this in kernel 3.0.0-15 before it goes to ubuntu-updates repository.

Thanks a lot

sordna (sordna) wrote :

Serge, you are right, looks like the patch had the ID of the Hercules Dualpix Exchange wrong as you can see here:
http://kernel.opensuse.org/cgit/kernel/commit/?id=2394d67e446bf616a0885167d5f0d397bdacfdfc

The patch says USB_DEVICE(0x06f8, 0x0804) but it should instead say USB_DEVICE(0x06f8, 0x3005)
I suggest you email the 2 people you see in the Sign-Off line of the above patch, and ask them to fix it. This should be fixed in the official Linux Kernel rather Ubuntu.

Thanks sordna, after trying some changes in the Skype settings, now it works with the Ubuntu kernel 3.0.0-14

Follows comments 110, 115 and 116.
Fix for Hercules Dualpix webcams sold after 2009 has been included in kernel 3.2.1.
The new version of quirks.c includes many fixes for new devices.

See http://git.kernel.org/?p=linux/kernel/git/stable/linux-stable.git;a=blob;f=drivers/usb/core/quirks.c;h=4c65eb6a867a1974d8596caaccc9d3d3f15152ef;hb=b8ed9e5b8c34dc9fb1882669e45b21e3d0194881

Could this new version of quiks.c file be included in next kernel update for oneiric ?
Must I open a new bug for this ?

bwallum (rbw2) wrote :

I've just found an excellent little web cam that works out of the box in Oneiric. 1.3Mpixel native resolution, cost £6 delivered UK.
http://www.ebay.co.uk/itm/260830581589?ssPageName=STRK:MEWNX:IT&_trksid=p3984.m1439.l2649

You'll need to select the web cam as microphone input in System Settings>Sound then Input tab. Works with just a USB plug, no separate microphone plug required.

jpritikin73 (joshua-peeredit) wrote :

"There are test kernels at: http://people.canonical.com/~bradf/lp843431"

Brad, I'd like to try but you do not include the non-arch specific headers. Without a full set of headers, I cannot compile my nvidia driver and I lose my audio output device.

samaris (samaris) wrote :

For your information, I had the same sound problem with
kernel 3.0.0.16-generic-pae
Bus 001 Device 003: ID 06f8:300c Guillemot Corp. (Hercules "Classic Silver" according to sound settings)

I tried both solutions (add a daemon.conf file and usbcore.autosuspend=-1), then update grub and restart skype and now it's fixed. Thank you.

The only solution to make microphone work is to install linux-backports-modules-alsa-generic...

Just go to:

Menu / System / Administration / Synaptic Package Manager

And search and mark for installation:

linux-backports-modules-alsa-generic

tip: if you have multiple versions click on the first and read the description which should inform what name to install...

If after the reboot and mic mute is off, still does not work, just go to terminal and type:

sudo nano /etc/modprobe.d/alsa-base.conf

and add or change the following:

options snd-hda-intel model=auto enable=yes

Then Ctrl+X, type Y to write and exit, reboot and mic will work.

Bye and have lots of fun with Ubuntu (the best).

squid (paul-fogel) wrote :

thanks jmim. this last one was what worked for me (editing alsa-base.conf). microphone now works properly.

Daniele Dellafiore (ildella) wrote :

I had the same issue with C910 camera + mic.

I make it work using comment #123 solution, just the alsa-base.conf modification, did not install any backported module.
on 3.2.0-23-generic #36-Ubuntu SMP x86_64 x86_64 x86_64 GNU/Linux
Ubuntu 12.04

I might add that in Ubuntu Sound preferences I've two input device, referring to that only device. If I keep the first selected, as in attached screenshot, it works. If I switch to the second one, it got back to the usual issue.

GreatKir (deminkirill) wrote :

Logitech c270 don't work in Linux 3.5 RC again. Same problem?

Joseph Salisbury (jsalisbury) wrote :

@GreatKir

bug 1018020 has been opened for the issue in 3.5

Displaying first 40 and last 40 comments. View all 127 comments or add a comment.