Regression: Logitech webcam microphone makes "chipmunk" sound after Oneiric beta upgrade

Bug #858412 reported by David Raymond Christiansen on 2011-09-24
128
This bug affects 24 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

After updating to the Oneiric beta, my Logitech USB webcam stopped recording audio properly. The sound is there, but it is very fast, producing a "chipmunk" effect. This has been observed both in Skype and in the sound recorder application. Using a microphone in the motherboard's line in port leads to normal recording of the voice. Restarting the machine and connecting/disconnecting the webcam had no effect.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: linux-image-3.0.0-11-generic 3.0.0-11.18
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
NonfreeKernelModules: nvidia
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.23-0ubuntu1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: davidc 1963 F.... pulseaudio
 /dev/snd/controlC2: davidc 1963 F.... pulseaudio
 /dev/snd/controlC0: davidc 1963 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf7df4000 irq 42'
   Mixer name : 'VIA VT1718S'
   Components : 'HDA:11064428,18496718,00100100'
   Controls : 33
   Simple ctrls : 19
Card1.Amixer.info:
 Card hw:1 'U0x46d0x808'/'USB Device 0x46d:0x808 at usb-0000:00:1d.0-1.1.1, high speed'
   Mixer name : 'USB Mixer'
   Components : 'USB046d:0808'
   Controls : 2
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'Mic',0
   Capabilities: cvolume cvolume-joined cswitch cswitch-joined penum
   Capture channels: Mono
   Limits: Capture 0 - 6400
   Mono: Capture 3758 [59%] [20.67dB] [on]
Card2.Amixer.info:
 Card hw:2 'NVidia'/'HDA NVidia at 0xfbffc000 irq 17'
   Mixer name : 'Nvidia GPU 11 HDMI/DP'
   Components : 'HDA:10de0011,10de0101,00100100'
   Controls : 16
   Simple ctrls : 4
Date: Sat Sep 24 20:27:43 2011
HibernationDevice: RESUME=UUID=e221565b-ad32-4c19-a7e5-3ec686d372e5
InstallationMedia: Kubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
MachineType: To Be Filled By O.E.M. To Be Filled By O.E.M.
ProcEnviron:
 PATH=(custom, user)
 LANG=en_DK.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-11-generic root=UUID=79006608-7125-469d-8b7a-e5dc54f4361a ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.0.0-11-generic N/A
 linux-backports-modules-3.0.0-11-generic N/A
 linux-firmware 1.60
RfKill:
 0: hci0: Bluetooth
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
UpgradeStatus: Upgraded to oneiric on 2011-09-24 (0 days ago)
dmi.bios.date: 08/06/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: P2.20
dmi.board.name: H55M Pro
dmi.board.vendor: ASRock
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP2.20:bd08/06/2010:svnToBeFilledByO.E.M.:pnToBeFilledByO.E.M.:pvrToBeFilledByO.E.M.:rvnASRock:rnH55MPro:rvr:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: To Be Filled By O.E.M.
dmi.product.version: To Be Filled By O.E.M.
dmi.sys.vendor: To Be Filled By O.E.M.

An Arch user seems to have had this problem as well, and there's a patch in this forum post:

https://bbs.archlinux.org/viewtopic.php?id=121607

Brad Figg (brad-figg) on 2011-09-24
Changed in linux (Ubuntu):
status: New → Confirmed

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.0.0-12.19
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Christian Heitjan (heitjan) wrote :

Bug is still there after latest update (today) - what kind of new report do you need?

sl45sms (sl45sms) wrote :

when i remove cam from usb port and plugged it back on another port the mic works fine!

sl45sms (sl45sms) wrote :

I found that the problem created when run skype fisrt, and even after you quit it the sound recorder have the same problem.
If i start sound recorder before run skype (after restart) mic works fine.

The following "procedure" fix the problem for skype (i don't know why this "magic" happens but works every time i tested!)

run and login to skype
open terminal
pulseaudio -k //to kill pulse audio
ps _A | grep skype //to finde skype pid
kill -9 *skypepid* //kill the pid i found
pulseaudio --start //start the daemon again
run skype and login, the mic sould work.

description: updated

Does not work for me...

Am 01.10.2011 19:55, schrieb sl45sms:
> when i remove cam from usb port and plugged it back on another port the
> mic works fine!
>

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.0.0-12.20
Christian Heitjan (heitjan) wrote :

latest kernel update does not fix the issue. Maybe it's a pulseaudio bug?

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
j0c1323 (j0c1323) wrote :

It's a kernel bug.

 I have the same problem with a logitech C310 with all distros using the kernel 3.0.

Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

tags: added: needs-upstream-testing
Download full text (5.1 KiB)

Sorry, I'm not a developer so I don't know, how to test an upstream kernel on my (private but productive) machine.

Can I help with other things?

-------- Original-Nachricht --------
> Datum: Tue, 11 Oct 2011 19:38:11 -0000
> Von: Joseph Salisbury <email address hidden>
> An: <email address hidden>
> Betreff: [Bug 858412] Re: Regression: Logitech webcam microphone makes "chipmunk" sound after Oneiric beta upgrade

> Would it be possible for you to test the latest upstream kernel? It
> will allow additional upstream developers to examine the issue. Refer to
> https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the
> upstream kernel, please remove the 'needs-upstream-testing' tag. This
> can be done by clicking on the yellow pencil icon next to the tag
> located at the bottom of the bug description and deleting the 'needs-
> upstream-testing' text. Please let us know your results.
>
> Thanks in advance.
>
> ** Tags added: needs-upstream-testing
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/858412
>
> Title:
> Regression: Logitech webcam microphone makes "chipmunk" sound after
> Oneiric beta upgrade
>
> Status in “linux” package in Ubuntu:
> Confirmed
>
> Bug description:
> After updating to the Oneiric beta, my Logitech USB webcam stopped
> recording audio properly. The sound is there, but it is very fast,
> producing a "chipmunk" effect. This has been observed both in Skype
> and in the sound recorder application. Using a microphone in the
> motherboard's line in port leads to normal recording of the voice.
> Restarting the machine and connecting/disconnecting the webcam had no
> effect.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.10
> Package: linux-image-3.0.0-11-generic 3.0.0-11.18
> ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
> Uname: Linux 3.0.0-11-generic x86_64
> NonfreeKernelModules: nvidia
> AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
> ApportVersion: 1.23-0ubuntu1
> Architecture: amd64
> AudioDevicesInUse:
>  USER PID ACCESS COMMAND
>  /dev/snd/controlC1: davidc 1963 F.... pulseaudio
>  /dev/snd/controlC2: davidc 1963 F.... pulseaudio
>  /dev/snd/controlC0: davidc 1963 F.... pulseaudio
> CRDA: Error: [Errno 2] No such file or directory
> Card0.Amixer.info:
>  Card hw:0 'Intel'/'HDA Intel at 0xf7df4000 irq 42'
>    Mixer name : 'VIA VT1718S'
>    Components : 'HDA:11064428,18496718,00100100'
>    Controls : 33
>    Simple ctrls : 19
> Card1.Amixer.info:
>  Card hw:1 'U0x46d0x808'/'USB Device 0x46d:0x808 at
> usb-0000:00:1d.0-1.1.1, high speed'
>    Mixer name : 'USB Mixer'
>    Components : 'USB046d:0808'
>    Controls : 2
>    Simple ctrls : 1
> Card1.Amixer.values:
>  Simple mixer control 'Mic',0
>    Capabilities: cvolume cvolume-joined cswitch cswitch-joined penum
>    Capture channels: Mono
>    Limits: Capture 0 - 6400
>    Mono: Capture 3758 [59%] [20.67dB] [on]
> Card2.Amixer.info:
>  Card hw:2 'NVidia'/'HDA NVidia at 0xfbffc000 irq 17'
>    Mixer name : 'N...

Read more...

Joseph Salisbury (jsalisbury) wrote :

@Christian,

Thanks for the feedback.

Would it be possible for others affected by this bug to test the mainline kernel:
Refer to https://wiki.ubuntu.com/KernelMainlineBuilds

sordna (sordna) wrote :

I am using oneiric, linux-image-3.0.0-12-generic 3.0.0-12.20 (latest) and have this same problem with a Logitech C310 webcam.
Apart from archlinux already mentioned, even redhat has this bug fixed!!! Here is the diff:
https://bugzilla.redhat.com/attachment.cgi?id=517377&action=diff

Please fix this in Ubuntu as well, just copy the patch from arch or redhat.

sordna (sordna) wrote :

Here is the patch, for all 3 webcams reported having this problem.:

--- drivers/usr/core/quirks.c 2011-10-13 23:06:44.000000000 -0700
+++ quirks.c 2011-10-13 23:09:39.000000000 -0700
@@ -41,6 +41,15 @@ static const struct usb_device_id usb_qu
        /* Logitech Harmony 700-series */
        { USB_DEVICE(0x046d, 0xc122), .driver_info = USB_QUIRK_DELAY_INIT },

+ /* Logitech Webcam C270 */
+ { USB_DEVICE(0x046d, 0x0825), .driver_info = USB_QUIRK_RESET_RESUME },
+
+ /* Logitech Webcam C310 */
+ { USB_DEVICE(0x046d, 0x081b), .driver_info = USB_QUIRK_RESET_RESUME },
+
+ /* Logitech Webcam Pro 9000 */
+ { USB_DEVICE(0x046d, 0x0809), .driver_info = USB_QUIRK_RESET_RESUME },
+
        /* Philips PSC805 audio device */
        { USB_DEVICE(0x0471, 0x0155), .driver_info = USB_QUIRK_RESET_RESUME },

Yes, it's a kernel bug but who knows when it will be fixed, even the latest 3.1-rc4 kernel doesn't have the fix.
Please apply the patch to the oneiric ubuntu kernels, like redhat and archlinux are doing for some time now.
These are extremely popular cameras, and it's very embarassing to sound like mickey mouse with skype on oneiric installations.
How soon can you apply the patch?

Changed in linux (Ubuntu):
status: Confirmed → Triaged
tags: added: regression-release
sordna (sordna) wrote :

heitjan, sl45sms, anyone else, what's your webcam's usb id? I just realized that the bug originator's camera was not included in the patch, so I'm adding it, please do lsusb and supply your webcam id if it's not found in the following patch.
For example, Webcam Pro 9000 is in the below patch, but the Quickcam Pro 9000 is not (usb id 046d:0990) but we can't be sure it's affected by the bug unless we hear about it. For now I added the Webcam C600 (046d:0808).

--- /home/alx/quirks.c 2011-10-14 12:48:20.000000000 -0700
+++ quirks.c 2011-10-14 13:09:09.000000000 -0700
@@ -38,6 +38,18 @@ static const struct usb_device_id usb_qu
  /* Creative SB Audigy 2 NX */
  { USB_DEVICE(0x041e, 0x3020), .driver_info = USB_QUIRK_RESET_RESUME },

+ /* Logitech Webcam C600 */
+ { USB_DEVICE(0x046d, 0x0808), .driver_info = USB_QUIRK_RESET_RESUME },
+
+ /* Logitech Webcam Pro 9000 */
+ { USB_DEVICE(0x046d, 0x0809), .driver_info = USB_QUIRK_RESET_RESUME },
+
+ /* Logitech Webcam C310 */
+ { USB_DEVICE(0x046d, 0x081b), .driver_info = USB_QUIRK_RESET_RESUME },
+
+ /* Logitech Webcam C270 */
+ { USB_DEVICE(0x046d, 0x0825), .driver_info = USB_QUIRK_RESET_RESUME },
+
  /* Logitech Harmony 700-series */
  { USB_DEVICE(0x046d, 0xc122), .driver_info = USB_QUIRK_DELAY_INIT },

Riccardo Pelizzi (r-pelizzi) wrote :

i get this bug with a (0x046d, 0x081a) camera, which is a logitech c260. if you could please add this device to the patch as well, i could stop using my custom "3.0.4-chipmunk" kernel :-)

sordna (sordna) wrote :

Found duplicates of this bug about other webcams and added a few more (including the C260) to the patch. So this will be a more complete fix than arch/redhat have, but they were faster to actually release the fix, hopefully Ubuntu will pick this up soon and relieve us from this serious webcam issue.

--- quirks.c 2011-10-14 12:48:20.000000000 -0700
+++ quirks.c 2011-10-14 15:32:02.000000000 -0700
@@ -38,6 +38,30 @@ static const struct usb_device_id usb_qu
  /* Creative SB Audigy 2 NX */
  { USB_DEVICE(0x041e, 0x3020), .driver_info = USB_QUIRK_RESET_RESUME },

+ /* Logitech Webcam C600 */
+ { USB_DEVICE(0x046d, 0x0808), .driver_info = USB_QUIRK_RESET_RESUME },
+
+ /* Logitech Webcam Pro 9000 */
+ { USB_DEVICE(0x046d, 0x0809), .driver_info = USB_QUIRK_RESET_RESUME },
+
+ /* Logitech Webcam C210 */
+ { USB_DEVICE(0x046d, 0x0819), .driver_info = USB_QUIRK_RESET_RESUME },
+
+ /* Logitech Webcam C260 */
+ { USB_DEVICE(0x046d, 0x081a), .driver_info = USB_QUIRK_RESET_RESUME },
+
+ /* Logitech Webcam C310 */
+ { USB_DEVICE(0x046d, 0x081b), .driver_info = USB_QUIRK_RESET_RESUME },
+
+ /* Logitech Webcam C910 */
+ { USB_DEVICE(0x046d, 0x0821), .driver_info = USB_QUIRK_RESET_RESUME },
+
+ /* Logitech Webcam C270 */
+ { USB_DEVICE(0x046d, 0x0825), .driver_info = USB_QUIRK_RESET_RESUME },
+
+ /* Logitech Quickcam Pro 9000 */
+ { USB_DEVICE(0x046d, 0x0990), .driver_info = USB_QUIRK_RESET_RESUME },
+
  /* Logitech Harmony 700-series */
  { USB_DEVICE(0x046d, 0xc122), .driver_info = USB_QUIRK_DELAY_INIT },

sordna (sordna) on 2011-10-15
tags: removed: kernel-request-3.0.0-12.19 needs-upstream-testing running-unity
sordna (sordna) wrote :

I marked this as a duplicate of 843431, since 843431 was the first bug reporting this problem.
Let's all subscribe / say that we are affected by bug 843431

Hi,

I've got an Logitech Webcam C160

Am 14.10.2011 22:18, schrieb sordna:
> heitjan, sl45sms, anyone else, what's your webcam's usb id? I just realized that the bug originator's camera was not included in the patch, so I'm adding it, please do lsusb and supply your webcam id if it's not found in the following patch.
> For example, Webcam Pro 9000 is in the below patch, but the Quickcam Pro 9000 is not (usb id 046d:0990) but we can't be sure it's affected by the bug unless we hear about it. For now I added the Webcam C600 (046d:0808).
>
>
> --- /home/alx/quirks.c 2011-10-14 12:48:20.000000000 -0700
> +++ quirks.c 2011-10-14 13:09:09.000000000 -0700
> @@ -38,6 +38,18 @@ static const struct usb_device_id usb_qu
> /* Creative SB Audigy 2 NX */
> { USB_DEVICE(0x041e, 0x3020), .driver_info = USB_QUIRK_RESET_RESUME },
>
> + /* Logitech Webcam C600 */
> + { USB_DEVICE(0x046d, 0x0808), .driver_info = USB_QUIRK_RESET_RESUME },
> +
> + /* Logitech Webcam Pro 9000 */
> + { USB_DEVICE(0x046d, 0x0809), .driver_info = USB_QUIRK_RESET_RESUME },
> +
> + /* Logitech Webcam C310 */
> + { USB_DEVICE(0x046d, 0x081b), .driver_info = USB_QUIRK_RESET_RESUME },
> +
> + /* Logitech Webcam C270 */
> + { USB_DEVICE(0x046d, 0x0825), .driver_info = USB_QUIRK_RESET_RESUME },
> +
> /* Logitech Harmony 700-series */
> { USB_DEVICE(0x046d, 0xc122), .driver_info = USB_QUIRK_DELAY_INIT },
>

sordna (sordna) wrote :

The C160 is not in the usb id repository http://www.linux-usb.org/usb.ids
what's the output of your "lsusb" command?

Christian Heitjan (heitjan) wrote :

The output is "Bus 001 Device 003: ID 046d:0824 Logitech, Inc."

Does it help?

Am 15.10.2011 16:44, schrieb sordna:
> *** This bug is a duplicate of bug 843431 ***
> https://bugs.launchpad.net/bugs/843431
>
> The C160 is not in the usb id repository http://www.linux-usb.org/usb.ids
> what's the output of your "lsusb" command?
>

sordna (sordna) wrote :

Yup, I'll add it to the patch later today.
Make sure to subscribe to bug #843431 and say you're affected (if you haven't already)

Christian Heitjan (heitjan) wrote :

Thank you very much - I subscribed a view seconds ago.

Am 15.10.2011 22:07, schrieb sordna:
> *** This bug is a duplicate of bug 843431 ***
> https://bugs.launchpad.net/bugs/843431
>
> Yup, I'll add it to the patch later today.
> Make sure to subscribe to bug #843431 and say you're affected (if you haven't already)
>

Kurt Miller (miller-kurt-e) wrote :

FYI: I added the 3.1.0-999-generic kernel and that took care of the Skype chipmunk problem. However, the chipmunk persists in Sound Recorder.

sordna (sordna) wrote :

Where can someone download the 3.1.0-999-generic kernel ?
Also, is there a source package for it to try the patch on?

Joseph Salisbury (jsalisbury) wrote :

Sordna,

The latest release candidate is the best kernel to test. It can be found at:

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.1-rc10-oneiric/

The following page has details on the mainline kernel:
https://wiki.ubuntu.com/Kernel/MainlineBuilds

Joseph Salisbury (jsalisbury) wrote :

@Sordna,

It would be great if you can update bug 843431 if you are able to test the mainline kernel.

sordna (sordna) wrote :

I tested the mainline yesterday (uname gave me: 3.1.0-0301rc10-generic #201110190851) and still got the problem.

I wish Kurt provides more info about the mysterious 3.1.0-999-generic kernel and where to get it from, but I doubt it solves the issue since Kurt says sound recorder was still affected.

Kurt Miller (miller-kurt-e) wrote :

I see others have steered you toward http://kernel.ubuntu.com/~kernel-ppa/mainline/daily/ as the source for the 3.1.0-999-generic kernel.

Anyway, that solved the problem only momentarily.

Basically everything having to do with the mic on the webcam is unstable. At one point, Sound Recorder was working normally while Skype was not - a complete reverse of the situation I had before. Now Sound Recorder is back to "chipmunk" mode and Skype won't play back anything on a test call even though the input meter shows good sound levels coming in from the mic.

Holger Seelig (holger-seelig) wrote :

I have this problem too with my
Logitech, Inc. Webcam Pro 9000
both in skype and soundrecorder
with Linux qualle 3.0.0-12-generic #20-Ubuntu SMP Fri Oct 7 14:56:25 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux
and oneiric

To post a comment you must log in.