Wlan hardware blocked after suspend lenovo X121e

Bug #812866 reported by Mads Brouer on 2011-07-19
68
This bug affects 14 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Mads Brouer

Bug Description

Lenovo X120e, core i3
Ubuntu 2.6.38-8.42-generic 2.6.38.2

02:00.0 Network controller: Intel Corporation Centrino Wireless-N 1000
 Subsystem: Intel Corporation Centrino Wireless-N 1000 BGN
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0, Cache Line Size: 64 bytes
 Interrupt: pin A routed to IRQ 41
 Region 0: Memory at e1500000 (64-bit, non-prefetchable) [size=8K]
 Capabilities: <access denied>
 Kernel driver in use: iwlagn
 Kernel modules: iwlagn

After suspend the wlan interface is hard blocked
I have tried unloading iwlagn driver, restarting network-manager, rfkill to unblock all, unloading the thinkpad_acip module.
The only way I can unblock it is by restarting (the laptop does not have a physical switch)

I have seen the same behavior on Fedora 15, so this might be a driver og kernel problem.

PM and iwlagn info from dmesg:

[ 0.000000] PM: Registered nosave memory: 000000000009d000 - 000000000009e000
[ 0.000000] PM: Registered nosave memory: 000000000009e000 - 00000000000a0000
[ 0.000000] PM: Registered nosave memory: 00000000000a0000 - 00000000000e0000
[ 0.000000] PM: Registered nosave memory: 00000000000e0000 - 0000000000100000
[ 0.000000] PM: Registered nosave memory: 00000000bac4b000 - 00000000baede000
[ 0.000000] PM: Registered nosave memory: 00000000baede000 - 00000000baf9f000
[ 0.000000] PM: Registered nosave memory: 00000000baf9f000 - 00000000bafff000
[ 3.224674] PM: Hibernation image not present or could not be loaded.
[ 8.906049] iwlagn: Intel(R) Wireless WiFi Link AGN driver for Linux, in-tree:
[ 8.906054] iwlagn: Copyright(c) 2003-2010 Intel Corporation
[ 8.906125] iwlagn 0000:02:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[ 8.906137] iwlagn 0000:02:00.0: setting latency timer to 64
[ 8.906175] iwlagn 0000:02:00.0: Detected Intel(R) Centrino(R) Wireless-N 1000 BGN, REV=0x6C
[ 8.927558] iwlagn 0000:02:00.0: device EEPROM VER=0x15d, CALIB=0x6
[ 8.927562] iwlagn 0000:02:00.0: Device SKU: 0X9
[ 8.927565] iwlagn 0000:02:00.0: Valid Tx ant: 0X1, Valid Rx ant: 0X3
[ 8.927582] iwlagn 0000:02:00.0: Tunable channels: 13 802.11bg, 0 802.11a channels
[ 8.927694] iwlagn 0000:02:00.0: irq 41 for MSI/MSI-X
[ 9.734034] iwlagn 0000:02:00.0: loaded firmware version 128.50.3.1 build 13488
[ 590.192450] PM: Syncing filesystems ... done.
[ 590.194043] PM: Preparing system for mem sleep
[ 590.818495] PM: Entering mem sleep
[ 591.020055] PM: suspend of drv:psmouse dev:serio5 complete after 181.702 msecs
[ 591.138213] PM: suspend of drv:usb dev:1-1 complete after 117.945 msecs
[ 591.138231] PM: suspend of drv:usb dev:2-1 complete after 117.966 msecs
[ 591.288178] PM: suspend of drv:tpm_tis dev:00:0a complete after 195.834 msecs
[ 591.517169] PM: suspend of drv:sd dev:0:0:0:0 complete after 497.335 msecs
[ 591.517225] PM: suspend of drv:scsi dev:target0:0:0 complete after 497.294 msecs
[ 591.517251] PM: suspend of drv:scsi dev:host0 complete after 497.144 msecs
[ 591.528053] PM: suspend of drv:HDA Intel dev:0000:00:1b.0 complete after 239.817 msecs
[ 591.588117] PM: suspend of drv:ahci dev:0000:00:1f.2 complete after 299.964 msecs
[ 592.307576] PM: suspend of drv:rts_pstor dev:0000:03:00.0 complete after 1019.903 msecs
[ 592.307598] PM: suspend of drv:pcieport dev:0000:00:1c.2 complete after 1019.862 msecs
[ 592.307615] PM: suspend of drv: dev:pci0000:00 complete after 1019.648 msecs
[ 592.307640] PM: suspend of devices complete after 1489.681 msecs
[ 592.307645] PM: suspend devices took 1.490 seconds
[ 592.387607] PM: late suspend of devices complete after 80.000 msecs
[ 592.517536] PM: Saving platform NVS memory
[ 593.068018] PM: Restoring platform NVS memory
[ 594.239204] iwlagn 0000:02:00.0: restoring config space at offset 0xf (was 0x100, writing 0x10a)
[ 594.239253] iwlagn 0000:02:00.0: restoring config space at offset 0x4 (was 0x4, writing 0xe1500004)
[ 594.239264] iwlagn 0000:02:00.0: restoring config space at offset 0x3 (was 0x0, writing 0x10)
[ 594.239277] iwlagn 0000:02:00.0: restoring config space at offset 0x1 (was 0x100000, writing 0x100006)
[ 594.239736] PM: early resume of devices complete after 1.634 msecs
[ 594.240052] iwlagn 0000:02:00.0: RF_KILL bit toggled to disable radio.
[ 594.377970] PM: resume of drv:atl1c dev:0000:08:00.0 complete after 137.985 msecs
[ 594.447841] PM: resume of drv:usb dev:2-1 complete after 207.168 msecs
[ 594.447863] PM: resume of drv:hub dev:2-1:1.0 complete after 207.168 msecs
[ 594.447873] PM: resume of drv: dev:ep_81 complete after 207.153 msecs
[ 594.447881] PM: resume of drv: dev:ep_00 complete after 207.128 msecs
[ 594.447927] PM: resume of drv:usb dev:1-1 complete after 207.364 msecs
[ 594.447941] PM: resume of drv:hub dev:1-1:1.0 complete after 207.351 msecs
[ 594.447951] PM: resume of drv: dev:ep_81 complete after 207.336 msecs
[ 594.447958] PM: resume of drv: dev:ep_00 complete after 207.318 msecs
[ 594.447973] PM: resume of drv:rts_pstor dev:0000:03:00.0 complete after 208.037 msecs
[ 594.448007] PM: resume of drv:scsi dev:host6 complete after 207.012 msecs
[ 594.448018] PM: resume of drv:scsi_host dev:host6 complete after 206.997 msecs
[ 594.448029] PM: resume of drv:scsi dev:target6:0:0 complete after 206.984 msecs
[ 594.448047] PM: resume of drv:sd dev:6:0:0:0 complete after 206.969 msecs
[ 594.448057] PM: resume of drv:scsi_device dev:6:0:0:0 complete after 206.954 msecs
[ 594.461124] PM: resume of drv:i915 dev:0000:00:02.0 complete after 221.419 msecs
[ 595.324447] PM: resume of drv:usb dev:2-1.4 complete after 1084.115 msecs
[ 595.324474] PM: resume of drv:uvcvideo dev:2-1.4:1.0 complete after 1084.118 msecs
[ 595.324506] PM: resume of drv: dev:ep_00 complete after 1084.071 msecs
[ 595.324513] PM: resume of drv:uvcvideo dev:2-1.4:1.1 complete after 1084.104 msecs
[ 595.324518] PM: resume of drv: dev:ep_83 complete after 1084.137 msecs
[ 595.481702] PM: resume of drv:sd dev:0:0:0:0 complete after 1241.518 msecs
[ 595.481728] PM: resume of drv:scsi_device dev:0:0:0:0 complete after 1241.523 msecs
[ 595.481767] PM: resume of drv:scsi_disk dev:0:0:0:0 complete after 1026.344 msecs
[ 595.486347] PM: resume of devices complete after 1247.332 msecs
[ 595.486584] PM: resume devices took 1.240 seconds
[ 595.486636] PM: Finishing wakeup.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: linux-image-2.6.38-8-generic 2.6.38-8.42
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: mads 1642 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xe1600000 irq 42'
   Mixer name : 'Intel CougarPoint HDMI'
   Components : 'HDA:14f1506e,17aa21ed,00100000 HDA:80862805,80860101,00100000'
   Controls : 12
   Simple ctrls : 6
Card29.Amixer.info:
 Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw unknown'
   Mixer name : 'ThinkPad EC (unknown)'
   Components : ''
   Controls : 1
   Simple ctrls : 1
Card29.Amixer.values:
 Simple mixer control 'Console',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Tue Jul 19 14:06:09 2011
HibernationDevice: RESUME=UUID=07ad25b0-b2d3-40d2-87c0-68a1adee6d96
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
Lsusb:
 Bus 002 Device 003: ID 04f2:b2b9 Chicony Electronics Co., Ltd
 Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
 Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: LENOVO 30456UG
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=badc8553-6820-4bc2-8508-2aa6fbcd5027 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-2.6.38-8-generic N/A
 linux-backports-modules-2.6.38-8-generic N/A
 linux-firmware 1.52
SourcePackage: linux
StagingDrivers: rts_pstor
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 06/16/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 8QET23WW (1.07 )
dmi.board.asset.tag: Not Available
dmi.board.name: 30456UG
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr8QET23WW(1.07):bd06/16/2011:svnLENOVO:pn30456UG:pvrThinkPadX121e:rvnLENOVO:rn30456UG:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 30456UG
dmi.product.version: ThinkPad X121e
dmi.sys.vendor: LENOVO

Mads Brouer (mads-x) wrote :
Brad Figg (brad-figg) on 2011-07-19
Changed in linux (Ubuntu):
status: New → Confirmed
Mads Brouer (mads-x) wrote :

Suspend to ram works perfectly under Windows, so that properly rules out a Bios bug.

Mads Brouer (mads-x) wrote :

Problem solved... in a very mysterious way...

After my suspend test with the pre-installed Lenovo Windows (restored with CloneZilla), I went back to my Ubuntu image and very surprising suspend was now working perfectly.

The only explanation I can come up with is that the initial setup steps in the pre-installed Windows uploaded some firmware to my wifi card.

Now it looks like all the hardware works out-of-box, what a joy :)
(Lenovo Thinkpad X121e)

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
assignee: nobody → Mads Brouer (mads-x)
owang (owangler) wrote :

I've got the exact same bug (Lenovo E320); I tried nearly all the solutions provided in the ubuntu forums concerning bugs like these but nothing helped. The authors description fits my observations absolutely but unfortunately I got no windows installation I could test with.
Any ideas?

Mads Brouer (mads-x) wrote :

The problem resurrected after I was playing around with WWAN card, I guess it was due to enabling and disabling the card in the bios.
I was again able to fix it by restoring my pre-installed Windows image, and then restoring my Ubuntu image.

@owang: I have like yourself tried all solutions I could find on the web, and nothing works. I have absolutely no idea how the Windows restore fixes the problem. (is Windows able to write some changes to the bios??)

Florian Hiemeyer (flohiemeyer) wrote :

I have the same problem with x121e w/intel core i3 and Centrino 1000 wireless: Wireless marked as "hardblocked" after hibernate

Florian Hiemeyer (flohiemeyer) wrote :

To clear the suspense/hibernate problem, try this (rather old one):
http://lilserenity.wordpress.com/2007/10/31/fix-ubuntu-dropping-wireless-on-suspendhibernate-resume/

At least at my last two hibernates (doing hibernation to not more than 10 minutes), it did restart wlan nicely!

But two other things: What about startup of the wlan0 device after normal boot? At my laptop, it only works due to having edited my /etc/rc.local:

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

# Florian Start Wlan at boot (unblock)
rfkill unblock 2

# Florian: Setup power management support for wlan0
iwconfig wlan0 power on

exit 0

Florian Hiemeyer (flohiemeyer) wrote :

... and the second thing is aout bluetooth: After my tweaking from above, the bluetooth device is also hardblocked, no chance to change via the IBM hotkeys.

What solution is proposed, to reactivate the hotkey button?

Florian Hars (florian-hars) wrote :

Installing Windows is not a valid fix for a bug in ubuntu (see also bug #1), somebody with the appropriate permissions should revert this bug to Confirmed.

owang (owangler) wrote :

Florian Hiemeyers link didnt work for me, Wlan is still not working after a suspend.
And yes, I also added these lines to my /etc/rc.local file to make wlan work in the first place.

Florian Hiemeyer (flohiemeyer) wrote :

okay, owang, I just had laptop suspended for longer: recover from suspend/hibernate DOESN'T work, owang is right.

Florian Hiemeyer (flohiemeyer) wrote :

The other Florian: Yes agree, this bug should be confirmed! No obvious solution can be found!

Mads Brouer (mads-x) wrote :

Yes,, agree with the Florians.

Reverted to Confirmed.

Changed in linux (Ubuntu):
status: Fix Released → Confirmed
dahias (wengahias) wrote :

Same Problem with Ubuntu 11.10 Alpha 3 - 64bit.

Detro (detronizator) wrote :

Hello.
Did anyone found a solution to this?

I just got an x121e Thinkpad and this problem is killing me :(

dahias (wengahias) wrote :

Hi All,

Finally resolved the Issue.

After i assumed a Bug to be in Package "rfkill" i was disabused by doing a Bios-Firmware Upgrade on the Lenovo x121e (3045-6RG).
Problems are gone, now this wonderful piece of hardware runs perfectly well.

Upgraded Bios Version from Version 1.07 to 1.09

A ISO File for the bootable Firmwaretool can be found at:
http://support.lenovo.com/en_SE/downloads/detail.page?&DocID=DS019251
( Click on the link "BIOS Bootable CD", Download, Burn Iso, Make sure Battery is full and Power is connected, Boot from Disk, Follow Instructions, Be happy :)

Florian Hiemeyer (flohiemeyer) wrote :

Pro: WLAN came back after about 1 min of hibernate (have few time right now)
Con: you still need to unblock the device at startup.

That's my first assessment :)

dahias (wengahias) wrote :

As Workaround for the Wlan starting at boot-time you coud insert the following line into "/etc/rc.local"

/usr/sbin/rfkill unblock wlan

Florian Hiemeyer (flohiemeyer) wrote :

Just checked after having hibernated the laptop for a night: Direct restart of WLAN *WORKED!*

My build is the same as dahias: Lenovo x121e (3045-6RG)

I thought about updating bios two weeks ago, but it did not state something of interest about WLAN in the Release notes.

Thank you very much, dahias, for this useful tip!

Detro (detronizator) wrote :

Same here!
Thanks a lot Dahias for the hint ;)

Mads Brouer (mads-x) wrote :

Since there is not option like "won't fix", this bug is now marked as fix released.

Looks like this is fixed by a bios update from Lenovo. Thanks for your help with this bug.

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
owang (owangler) wrote :

Bios Update fixed it for my system, too. (Thinkpad E320)

look at the release notes:

Version 1.11 (for ThinkPad Edge E320)

[Problem fixes]
 - Fixed issues of WiFi enabling on Linux.

greetings

markovuc (markovuc) wrote :

Updating of the firmware helped me too (on thinkpad edge e320) regarding the 'wireless hard blocked' problem.

But, the problem I face now is activation of bluetooth. Before firmware upgrade, I was able to turn it on with Fn+F9, but now it is impossible. Even writing to thinkpad_acpi related files under /proc and /sys ('enable', '1') does not help.

Florian Hiemeyer (flohiemeyer) wrote :
Download full text (12.2 KiB)

My X121e (i3) does now have functioning Wireless, but a strange behaving Bluetooth: Bluetooth logo in status line is "greyed out"/"deactivated", but preferences (on/off of bluetooth and visibility of the PC) can be set, and (one out of several tries) a bluetooth connection can be established and used with my android phone.

However, a sequence of rfkill list / unblock gives the following results:
florian@ocelot:~$ rfkill list all
0: tpacpi_bluetooth_sw: Bluetooth
 Soft blocked: yes
 Hard blocked: yes
1: phy0: Wireless LAN
 Soft blocked: no
 Hard blocked: no
florian@ocelot:~$ rfkill unblock all
florian@ocelot:~$ rfkill list
0: tpacpi_bluetooth_sw: Bluetooth
 Soft blocked: no
 Hard blocked: yes
1: phy0: Wireless LAN
 Soft blocked: no
 Hard blocked: no
4: hci0: Bluetooth
 Soft blocked: no
 Hard blocked: no
florian@ocelot:~$
florian@ocelot:~$ sudo rfcomm -a
florian@ocelot:~$
(!!!!)

Guess this is a new Bug to be reported?

Further information about my Bluetooth device:

florian@ocelot:~$ sudo lsusb -vs 001:004
Bus 001 Device 004: ID 0a5c:217f Broadcom Corp. Bluetooth Controller
Device Descriptor:
  bLength 18
  bDescriptorType 1
  bcdUSB 2.00
  bDeviceClass 224 Wireless
  bDeviceSubClass 1 Radio Frequency
  bDeviceProtocol 1 Bluetooth
  bMaxPacketSize0 64
  idVendor 0x0a5c Broadcom Corp.
  idProduct 0x217f Bluetooth Controller
  bcdDevice 7.48
  iManufacturer 1 Broadcom Corp
  iProduct 2 Broadcom Bluetooth Device
  iSerial 3 CCAF78EB5AEE
  bNumConfigurations 1
  Configuration Descriptor:
    bLength 9
    bDescriptorType 2
    wTotalLength 216
    bNumInterfaces 4
    bConfigurationValue 1
    iConfiguration 0
    bmAttributes 0xe0
      Self Powered
      Remote Wakeup
    MaxPower 0mA
    Interface Descriptor:
      bLength 9
      bDescriptorType 4
      bInterfaceNumber 0
      bAlternateSetting 0
      bNumEndpoints 3
      bInterfaceClass 224 Wireless
      bInterfaceSubClass 1 Radio Frequency
      bInterfaceProtocol 1 Bluetooth
      iInterface 0
      Endpoint Descriptor:
        bLength 7
        bDescriptorType 5
        bEndpointAddress 0x81 EP 1 IN
        bmAttributes 3
          Transfer Type Interrupt
          Synch Type None
          Usage Type Data
        wMaxPacketSize 0x0010 1x 16 bytes
        bInterval 1
      Endpoint Descriptor:
        bLength 7
        bDescriptorType 5
        bEndpointAddress 0x82 EP 2 IN
        bmAttributes 2
          Transfer Type Bulk
          Synch Type None
          Usage Type Data
        wMaxPacketSize 0x0040 1x 64 bytes
        bInterval 1
      Endpoint Descriptor:
        bLength 7
        bDescriptorType 5
        bEndpointAddress 0x02 EP 2 OUT
        bmAttributes ...

markovuc (markovuc) wrote :

After I did 'reset to defaults' in bios, bluetooth started working as before firmware upgrade.

So, to conclude, firmware upgrade to 1.14 solves this problem for wireless (wifi hard blocked after resume from suspend) on lenovo thinkpad edge e320.

Only issue I have now is that both wifi and wireless are started on boot; previous to fw upgrade, I think laptop 'remembered state' (e.g. if wifi was 'off' before shutdown, it would be 'off' at next boot).

I understand there are workarounds for this, but maybe new fw update from lenovo will address this issue ;)

Currently, as soon as system boots, I press Fn+F9 to turn off wifi and bluetooth.

Florian Hiemeyer (flohiemeyer) wrote :

I have to confirm what markovuc said (for the X121e laptop): Bluetooth icon in Ubuntu 11.10 deactivated after firmware update. Status then "hardblocked" at all times (despite few links being possible to my smartphone). Now, with a reset to defaults in the bios, bluetooth works again in "full" operation mode (bluetooth icon not greyed-out, all options available)!

On my X121e, with fn+f4, both wlan and bluetooth (at the same time) can now be hardblocked/unblocked again. This was not possible until now.

(Strange behavior in fact)

I guess this is more likely to be a bug in the firmware than in Ubuntu? Please comment!

Henning Hasemann (hhasemann) wrote :

Bios update and resetting bios to defaults fixes all hardblocks for me on x121 too.
It might be noteworthy that there is a nice method for updating the bios without the need for an optical drive or a microsoft operating system: http://www.thinkwiki.org/wiki/BIOS_update_without_optical_disk

chielchiel (chiel) wrote :

I still experiencing this problem from time to time. Especially when the laptop runs to 0% battery and shutdown. Then I need to reload bios defaults and it works again. Was hoping that there might be a bios firmware update soon, but non yet, Therefore sending this update.

Oz123 (nahumoz) wrote :

I'd also like to confirm that bug. It seems like it's partially also a kernel problem.
I did a firmware upgrade, but I still have problems with the bluetooth after suspend being blocked. Mostly the problem appears after battery is depleted.
As stated above - restore defaults in the bios, reactivates the bluetooth device.

Jörn Frenzel (2-jf) wrote :

Like Oz123, i notice this behavior after my x121e (intel) shuts down hardly with an empty battery. A bios reset is not an option for me, because i'm using EFI-boot and so i'll loose my bootloader every time i do so.

 Hard blocked: yes !!!!!!

rfkill will not do anything.
Its a problem with the bios or the HW and it happens with windows too.

Unfortunately I don't know how to solve. Maybe its possible to disable the signal by cutting pin 20.
http://dampeftw.com/howto-bypass-a-laptops-hardware-wireless-switch/

Sergey V. Udaltsov (svu) wrote :

Why is the status "fix released"? It seems it is still there...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers