Wireless not enabled with Lenovo Thinkpad x121e and Fn+F5 stop working after an update

Bug #951810 reported by bnj on 2012-03-10
16
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

Since an update last week:
 1 - The wireless is not enabled after login in the unity interface
 2 - The Fn+F5 switch stop to work.

It remain possible to enable the wireless network with NetworkManager. I tried the Beta 1 of Precise with Live USB and the same issue is present. Before the update it was working perfectly. Indeed it is a regression.

Version: Ubuntu 11.10 (Oneiric)

cat /proc/version_signature
Ubuntu 3.0.0-16.29-generic 3.0.20

lshw -c network
  *-network
       description: Wireless interface
       product: Centrino Wireless-N 1000
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlan0
       version: 00
       serial: 74:e5:0b:86:32:ae
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlagn driverversion=3.0.0-16-generic firmware=39.31.5.1 build 35138 ip=192.168.0.40 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
       resources: irq:41 memory:d1500000-d1501fff
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: bnj 1702 F.... pulseaudio
 /dev/snd/pcmC0D0p: bnj 1702 F...m pulseaudio
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xd1600000 irq 43'
   Mixer name : 'Intel CougarPoint HDMI'
   Components : 'HDA:14f1506e,17aa21ed,00100002 HDA:80862805,80860101,00100000'
   Controls : 12
   Simple ctrls : 6
Card29.Amixer.info:
 Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw unknown'
   Mixer name : 'ThinkPad EC (unknown)'
   Components : ''
   Controls : 1
   Simple ctrls : 1
Card29.Amixer.values:
 Simple mixer control 'Console',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
DistroRelease: Ubuntu 11.10
HibernationDevice: RESUME=UUID=94b61129-0fe0-4800-8e6c-5d3925923e3a
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
 Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
 Bus 002 Device 003: ID 064e:e285 Suyin Corp.
MachineType: LENOVO 3045CTO
Package: linux (not installed)
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-16-generic root=UUID=91e86ab7-e9dc-4071-abcf-8b497ebb40f5 ro quiet splash pcie_aspm=force i915.i915_enable_rc6=1 vt.handoff=7
ProcVersionSignature: Ubuntu 3.0.0-16.29-generic 3.0.20
RelatedPackageVersions:
 linux-restricted-modules-3.0.0-16-generic N/A
 linux-backports-modules-3.0.0-16-generic N/A
 linux-firmware 1.60
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
StagingDrivers: rts_pstor mei
Tags: oneiric running-unity staging
Uname: Linux 3.0.0-16-generic x86_64
UpgradeStatus: Upgraded to oneiric on 2012-02-01 (38 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 10/25/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 8QET53WW (1.14 )
dmi.board.asset.tag: Not Available
dmi.board.name: 3045CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr8QET53WW(1.14):bd10/25/2011:svnLENOVO:pn3045CTO:pvrThinkPadX121e:rvnLENOVO:rn3045CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 3045CTO
dmi.product.version: ThinkPad X121e
dmi.sys.vendor: LENOVO

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 951810

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: oneiric
bnj (b2besses) wrote : AcpiTables.txt

apport information

tags: added: apport-collected running-unity staging
description: updated

apport information

apport information

bnj (b2besses) wrote : BootDmesg.txt

apport information

bnj (b2besses) wrote : CRDA.txt

apport information

apport information

apport information

apport information

apport information

bnj (b2besses) wrote : IwConfig.txt

apport information

bnj (b2besses) wrote : Lspci.txt

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

bnj (b2besses) wrote : UdevDb.txt

apport information

bnj (b2besses) wrote : UdevLog.txt

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.3 kernel[1] (Not a kernel in the daily directory). Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[1] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.3-rc7-precise/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
tags: added: needs-upstream-testing
bnj (b2besses) wrote :

I have installed the kernel from http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.3-rc7-precise/ according instruction from https://wiki.ubuntu.com/KernelMainlineBuilds as per your request.

I have downloaded:
linux-headers-3.3.0-030300rc7_3.3.0-030300rc7.201203101735_all.deb
linux-image-3.3.0-030300rc7-generic_3.3.0-030300rc7.201203101735_amd64.deb
linux-headers-3.3.0-030300rc7-generic_3.3.0-030300rc7.201203101735_amd64.deb

Then install
sudo dpkg -i *.deb

Unfortunatly the boot fails with this kernel. The Maj key on boot save me...
I revert to the initial kernel.

tags: added: kernel-unable-to-test-upstream
bnj (b2besses) wrote :

Problem solved according this bug https://bugs.launchpad.net/ubuntu/+source/linux/+bug/812866
I update the bios then reset the bios to default, and everything working correctly now.

bnj (b2besses) on 2012-03-23
Changed in linux (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers