Optiplex 990 fails to reboot/shutdown

Bug #768039 reported by Sean Crosby
62
This bug affects 10 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Leann Ogasawara
Oneiric
Medium
Leann Ogasawara

Bug Description

== SRU Justification ==

It's been reported that the Dell Optiplex 990 doesn't reboot unless using reboot=pci. The following patch resolves this issue and has been successfully tested. Upstream is unfortunately not accepting any additional quirk patches like this as they would prefer to migrate to a more systematic approach. Given that the patch is system specific (ie low risk of regression), precedence for similar quirk patches already existing, and having received positive test results, I feel it should be carried as a SAUCE patch until a more systematic approach can be found which upstream will accept.

== Impact ==
Affects Dell Optiplex 990 models.

== Test Case ==
Without the patch, those with a Dell Optiplex 990 must use reboot=pci as a workaround in order for the system to successfully reboot. With the patch applied, the work around is no longer needed.

== Fix ==
See Comment #9

------------------

Machine hangs on "Restarting system" when restarted, and fails to shutdown when sudo halt -n is run. The machine also hung at the reboot screen during the installation of Natty beta 2

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: linux-image-2.6.38-8-generic 2.6.38-8.42
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: ALC269VB Analog [ALC269VB Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: ALC269VB Analog [ALC269VB Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/by-path', '/dev/snd/controlC0', '/dev/snd/hwC0D0', '/dev/snd/pcmC0D0c', '/dev/snd/pcmC0D0p', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xe1560000 irq 45'
   Mixer name : 'Realtek ALC269VB'
   Components : 'HDA:10ec0269,1028047e,00100100'
   Controls : 18
   Simple ctrls : 12
Date: Thu Apr 21 14:18:16 2011
HibernationDevice: RESUME=UUID=c1141128-f083-4b67-8401-b87c0a1f8669
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
MachineType: Dell Inc. OptiPlex 990
ProcEnviron:
 SHELL=/bin/bash
 LC_MESSAGES=en_AU.UTF-8
 LANG=en_AU
 LANGUAGE=en_AU:en
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-2.6.38-8-generic root=UUID=04112303-6d56-4aa2-a5cf-053c205d461f ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-2.6.38-8-generic N/A
 linux-backports-modules-2.6.38-8-generic N/A
 linux-firmware 1.50
RfKill:

SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 02/26/2011
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A02
dmi.board.name: 0VNP2H
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 3
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA02:bd02/26/2011:svnDellInc.:pnOptiPlex990:pvr01:rvnDellInc.:rn0VNP2H:rvrA00:cvnDellInc.:ct3:cvr:
dmi.product.name: OptiPlex 990
dmi.product.version: 01
dmi.sys.vendor: Dell Inc.

Revision history for this message
Sean Crosby (richardnixonshead) wrote :
Revision history for this message
Antonio Vasconcelos (anthonws) wrote :

"reboot=b" kernel option is there, but still it won't work...

Brad Figg (brad-figg)
Changed in linux (Ubuntu):
status: New → Confirmed
Revision history for this message
Steve Atwell (satwell) wrote :

I'm seeing this on an OptiPlex 990 as well. Dell just released BIOS revision A03 a few days ago, and I've installed that.

Here's what I've found:

Lucid's 2.6.32-28 kernel is able to reboot the machine just fine.

Neither Maverick's 2.6.35-22 nor Natty's 2.6.38-8 kernel can reboot the machine with default options. Tried adding reboot=bios and reboot=acpi, neither helps.

However, adding reboot=pci *does* work.

Revision history for this message
Sean Crosby (richardnixonshead) wrote :

I can confirm that it reboots without any changes in Lucid (temporarily I have downgraded the machine to Lucid, as regular reboots are important for this machine)

I tried reboot=bios and reboot=acpi, and it had no effect under Natty - never tried reboot=pci (didn't even know that option existed)

Revision history for this message
Paul Handly (mephaust) wrote :

I changed /etc/default/grub and added the following:

GRUB_CMDLINE_LINUX="reboot=pci"

Then ran `update-grub` and rebooted (the hard way).

It's working properly for me now, so it sounds a bit like some kernel/ACPI/bios stuff needs to be worked out.

Revision history for this message
fabio.hipolito (fabio-hipolito) wrote :

Hello,

I also have a Dell Optiplex 990 which had the same problem, Steve Atwell's solution worked thanks.

Also thanks to Paul Handly for explaining were to add Atwell's solution.

Revision history for this message
Massimo Cora' (pescio) wrote :

I've got this too on my fresh new Optiplex 990.

Revision history for this message
Arnaud Soyez (weboide) wrote :

"reboot=pci" works for me as well, on an Optiplex 990.

Changed in linux (Ubuntu):
assignee: nobody → Leann Ogasawara (leannogasawara)
status: Confirmed → In Progress
importance: Undecided → Medium
Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

Hi everyone,

I've created a quirk patch for the OptiPlex 990 and built a test kernel which can be found at:

http://people.canonical.com/~ogasawara/dell-reboot-quirks/

If you could please test and confirm you no longer need to use the reboot=pci work around that would be great. Thanks in advance.

Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

I'd really appreciate it if I could get feedback for the test kernel I posted in comment #9. Ubuntu kernel freeze for Oneiric is next week (Thurs Sept 15) so assuming the patch resolves the issue, I'd like to get it submitted prior to the freeze.

Revision history for this message
Sean Crosby (richardnixonshead) wrote :

Leann,

Your test kernel shuts down correctly on a fresh install of Natty on an Optiplex 990.

Many thanks...

Revision history for this message
Leann Ogasawara (leannogasawara) wrote :
description: updated
Tim Gardner (timg-tpi)
Changed in linux (Ubuntu Oneiric):
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.0.0-12.19

---------------
linux (3.0.0-12.19) oneiric; urgency=low

  [ Alex Bligh ]

  * SAUCE: (drop after v3.1) net/netfilter/nf_conntrack_netlink.c: fix Oops
    on container destroy
    - LP: #843892

  [ Andy Whitcroft ]

  * [Config] standardise on HZ=250
  * SAUCE: headers_install: fix #include "..." usage for userspace
    - LP: #824377
  * make module-inclusion selection retain the left overs
  * add a new linux-image-extras package for virtual

  [ edwin_rong ]

  * SAUCE: Staging: add driver for Realtek RTS5139 cardreader
    - LP: #824273

  [ Greg Kroah-Hartman ]

  * SAUCE: staging: rts5139: add vmalloc.h to some files to fix the build.
    - LP: #824273

  [ Jesse Sung ]

  * SAUCE: Unregister input device only if it is registered
    - LP: #839238

  [ Keng-Yu Lin ]

  * [Config] Enable CONFIG_RTS5139=m on i386/amd64
    - LP: #824273

  [ Leann Ogasawara ]

  * SAUCE: x86: reboot: Make Dell Optiplex 990 use reboot=pci
    - LP: #768039
  * SAUCE: x86: reboot: Make Dell Latitude E6220 use reboot=pci
    - LP: #838402

  [ Ming Lei ]

  * SAUCE: ata: make DVD drive recognisable on systems with Sandybridge CPT
    chipset
    - LP: #794642

  [ Paolo Pisati ]

  * [Config] Compile-in vfat support for armel
    - LP: #853783

  [ Randy Dunlap ]

  * SAUCE: staging: fix rts5139 depends & build
    - LP: #824273

  [ Tim Gardner ]

  * [Config] Fix binary-% build target
  * SAUCE: (drop after 3.0.0) OMAP3 and 4 hwmod I2C units only allow 16 bit
    access
    - LP: #852225

  [ Upstream Kernel Changes ]

  * hfsplus: Fix kfree of wrong pointers in hfsplus_fill_super() error path
    - LP: #854987
  * rt2x00: Serialize TX operations on a queue.
    - LP: #855239
 -- Leann Ogasawara <email address hidden> Wed, 14 Sep 2011 06:14:30 -0700

Changed in linux (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

As suggested in the bug description, this bug still exists upstream in kernel 3.1. However it appears to be fixed upstream in 3.2-rc1:
http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.2-rc1-oneiric/

tags: added: kernel-fixed-upstream-v3.2-rc1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers