Ubuntu

8086:2a42 [eMachines E527] On startup, the backlight is off on laptop

Reported by Travis DePrato on 2011-04-19
436
This bug affects 77 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
Medium
Unassigned

Bug Description

When Ubuntu starts up, the back-light is off on my laptop. I can plug it into an external monitor and the display is fine. I can easily turn the back-light on with "sudo setpci -s 00:02.0 F4.B=[HEX]" where 00 is the brightest and FF is off. In past distributions, the GUI-based brightness utilities did not work and I used this command to change by back-light brightness. I know that there are many people who can not use back-light GUI-utilities on the past distributions as well. This issue also occurs if I close my screen and raise it again.

This issue also effected the installation process as well as when I was using the i686 installer.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: xorg 1:7.6+4ubuntu3
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: compiz
CurrentDmesg:
 [ 29.430043] eth0: no IPv6 routers present
 [ 30.988586] EXT4-fs (sda7): re-mounted. Opts: errors=remount-ro,commit=0
DRM.card0.DP.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1366x768
 edid-base64: AP///////wANr5kVAAAAAAcUAQOAIhN4Cj2VlFZPjigmUFQAAAABAQEBAQEBAQEBAQEBAQEBeh1W0lAAHjA8KDYAWMEQAAAYAAAA/gBOMTU2QjMtTDBCCiAgAAAA/gBDTU8KICAgICAgICAgAAAA/gBOMTU2QjMtTDBCCiAgAEg=
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
Date: Mon Apr 18 21:34:59 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
GdmLog1:

GdmLog2:

GraphicsCard:
 Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Acer Incorporated [ALI] Device [1025:0459]
   Subsystem: Acer Incorporated [ALI] Device [1025:0459]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110413)
MachineType: eMachines eMachines E527
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=83376c0e-9440-4ba9-bbdb-363565bf5e72 ro quiet splash vt.handoff=7
Renderer: Unknown
SourcePackage: xorg
Symptom: display
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 04/16/2010
dmi.bios.vendor: eMachines
dmi.bios.version: V1.01
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: eMachines E527
dmi.board.vendor: eMachines
dmi.board.version: V1.01
dmi.chassis.type: 10
dmi.chassis.vendor: eMachines
dmi.chassis.version: V1.01
dmi.modalias: dmi:bvneMachines:bvrV1.01:bd04/16/2010:svneMachines:pneMachinesE527:pvrV1.01:rvneMachines:rneMachinesE527:rvrV1.01:cvneMachines:ct10:cvrV1.01:
dmi.product.name: eMachines E527
dmi.product.version: V1.01
dmi.sys.vendor: eMachines
version.compiz: compiz 1:0.9.4+bzr20110411-0ubuntu1
version.ia32-libs: ia32-libs 20090808ubuntu12
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu1
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

Travis DePrato (skidbladnir) wrote :
description: updated
madbiologist (me-again) on 2011-04-19
affects: ubuntu → linux (Ubuntu)
description: updated
Sergey Kovalev (kovalev-s) wrote :

Another workaround:

Add "acpi_osi=Linux" in your boot options. For example, modify /etc/default/grub like this:
GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash acpi_osi=Linux”
then run update-grub and reboot.

After boot you will be enable to change backlight power with notebook hardware keys.

diehard67 (diehard67) wrote :

I have an aspire 7715 and I had the same problem.
also that work around worked for me.

another note.
adding acpi_backlight=video to the kernel command line makes the system aware of when the brightness changes, it still can't change it in software.
acpi_backlight=vender the backlight keys still work but the os doesn't seem to see when you change the brightness.

also software brightness control works in windows, for whatever that is worth.

Travis DePrato (skidbladnir) wrote :

Thank you for that! Although, my backlight is still completely off when the laptop boots, but, at least I can use it without waiting for the crontab to run the command every time I close my laptop.

JaxterBlax (w0anm73) wrote :

I have an Emachines E527 laptop, I have tried the work around without success.

Travis DePrato (skidbladnir) wrote :

Actually, after adding this, it works, but only AFTER I turn the backlight on, using the command I mentioned earlier. So, I can change the brightness, but, when it's off, I still can't turn it back on without running that command (which I have a shortcut for, by the way. :P)

JaxterBlax (w0anm73) wrote :

Thanks, I was able to get my display turned on and working after using setpci, first.

JimBo (barreda-jm) wrote :

Same problem for me on Packard Bell Easynote TK36 (Model # PEW92).
"setpci -s 00:02.0 F4.B=0" solution works fine (added to my /etc/rc.local)

m_a_n_u (emmanuel-legrand) wrote :

I've got the same problem, though it affects any live boot such as gnome3, xubuntu 1104. I was on linux mint debian edition with xfce, and i've got the black screen after last update. So i'm back on Xubuntu 10.04 !

This bug indicates the problem affects 6 people, and it has Confirmed status in duplicate bug 772050 (which indicates it affects 6 people, and is itself a very strong bug report which had duplicates before it became a duplicate) as well as in duplicate bug 772690 (which indicates it affects 3 people). The bug has now been documented and people tend to experience it in the same way. I realize there may be some double-counting of users affected between this and the various duplicates, but even if the overlap were absolute, I think cause would still be more than sufficient to change this bug's status from New to Confirmed. So that's what I'm doing.

Changed in linux (Ubuntu):
status: New → Confirmed

A patched kernel and gnome-power-manager exist to get the backlight hotkeys working:

https://launchpad.net/~kamalmostafa/+archive/linux-kamal-mjgbacklight
add it to your sources e.g. with:
sudo apt-add-repository ppa:kamalmostafa/linux-kamal-mjgbacklight
then reload the package information and upgrade your system (e.g. with synaptic)

This should give you a the patched kernel and gnome-power-manager. Shut down and boot.

For my system this kernel gives me full hotkey backlight control (with the caveat that I have to up the brightness again after every time I close the lid - with the now working hotkeys).

Test and report back.

No, there is not a kernel named 2.6.38-9 there was only the 2.6.38-8 with the recovery mode of the same generation below it.

JimBo (barreda-jm) wrote :

@ Wolfgang Kufner, I tried patched kernel & gnome-power-manager from ppa : doesn't work for me...
(same issue : blank screen !);

Perhaps another way :
https://patchwork.kernel.org/patch/499221/
(but need to recompile kernel from sources... no time for me today)

Stay tuned

@Wolfgang Kufner
Thanks alot!!!!!! itś works
the only thing about it are that the light switch is going in the wrong direction
Can you patch a new kernel when LCD brightness goes in the right way???

so when i set my LCD brightness to 0 % it works
@Jimbo test to set the brigtness to 10 % and restar ... this might work

@Kenneth Thorell
Glad to hear it works.
Please report the direction problem to LP: #568611. Provide your machine make/model and the output from:
uname -a
ls /sys/class/backlight
cat /sys/class/backlight/intel_backlight/max_brightness
along with your report.

I find it interesting that people affected by this bug report that
sudo setpci -s 00:02.0 F4.B=00 is the brightest while
sudo setpci -s 00:02.0 F4.B=FF is off

Does this pattern hold for everyone affected by the backlight off bug or is it the other way round for anybody?
If this setpci command works for you at all then please test this.

Thanks

Tested on my gateway NV-78 laptop (Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)) on kernel 2.6.35, 2.6.38, and 2.6.39

In all instances FF gives me backlight off, and 00 gives me max brightness.

Kangarooo Jānis (kangarooo) wrote :

Funny i just installed using another monitor
omg. i had this since beta here i wrote in bug 683775 https://bugs.launchpad.net/ubuntu/+source/linux/+bug/683775/comments/36 so now i waited maybe new cd will come that fix this. still no new iso. And a while later here in this bug @Eliah Kagan says that 8 affected makes this confirmed. NO id heres one report then multiply that 50x more couse not all are using Launchpad and on this bug- well they can even open FF couse they see black screen
Thats not how it should be
this is mega important bug if some part of computer is not usable or working and monitor isnt
if theres even one reporter and here developers check bugs and they code then they know their code and can immidiatlly recognize :"yes that line there in my code makes wrong for that and that intel monitor" and he can confirm bug
This bug makes new people not to install ubuntu couse they cant see it when trying live cd.
Buggyest cd ever.
For next times immidiatly is needed to put a sign in www.ubuntu.com that users check witch are working and witch not so users dont even try live cd.
cant believe how wrong can go good project- making it better till 11.04 BAM users who didnt get completly used to previous menu now have new menu. so now im just starting .. but thats another bug.

Just to clarify my reasoning in marking this as Confirmed:

You really only need two people to mark a bug as Confirmed (and under *some* circumstances, the second person might not necessarily have actually experienced the bug), so long as (1) there is good reason to believe that they're experiencing the same bug (or the second person has some other way of identifying the bug, for example by examining the affected source code), and (2) there is enough information for a developer to start working on the bug. See https://help.launchpad.net/Bugs/Statuses. When I marked this as Confirmed, I gave my reasoning in this case, but that should not be interpreted as an explanation of what it takes to correctly mark a bug as Confirmed. The official and correct explanation is at https://help.launchpad.net/Bugs/Statuses.

This is not commentary on the request for this bug to be worked on quickly or to be marked with a high importance, just a clarification of what I posted earlier, when I changed this bug's status to Confirmed. (I don't have enough familiarity with the Linux kernel to identify where the problem is and write a fix, and I have no affiliation with Canonical, so I'm not one of the people Kangarooo is probably petitioning.)

By the way, I don't think bug 683775 is the same as this bug. Not only is that bug marked Fix Released (and that's usually accurate, though not always), but that bug affected 2.6-series kernels whereas this bug affects 2.8-series kernels, and the workarounds proposed for that bug were not the same as those proposed for this bug.

Marianne Bergem (tari-c) wrote :

I also had this problem and tried everything above without success. The only thing that worked was to go back to the old kernel 2.6.35-28.

Hi. I've been having the same problem, too since the releace of Natty and I 've been working on this on https://bugs.launchpad.net/ubuntu/+source/linux/+bug/773740. I' m using the kamal mostafa patched kernel now and when I turn on my laptop from the mains I always get no backlight on the welcoming screen and as soon as I hear the log-in sound I can tell that the desktop is now active and I use the brightness hotkeys to increase the brightness. Note that the keys work in reverse way meaning that the hotkey which should reduce the brightness now increases it. But, yesterday I noticed something strange. When I power my laptop on with its battery only I get the "Ubuntu" starting/welcoming screen with no backlight as usual but just before that screen disappears in order to be replaced by the desktop screen the bachlight is restored and I can see. And then, when I press the brightness hotkey I am surprised to see that the brightness bar is halfway full.
Note 1: The hotkeys still work in reverse way.
Note 2: This isn't happening when I use battery AND mains in order to recharge it.
Note 3: I am not using the i915.alse_backlight=1 parameter though it fixes the backlight because
a) It is pretty irritating to do this every time I turn my laptop on and
b) It somewhat messes up my screen by making it wider and that is something I don't like.
That 's all the information I can give you.
Peace.

Amedeo (amedeo-salvati) wrote :
Download full text (4.7 KiB)

I've same problem on Packard Bell EasyNote TH36 and setpci command onto rc.local work's fine. Below some useful information.

From dmidecode:
Manufacturer: Packard Bell
Product Name: EasyNote TH36
Version: V1.02

From lspci:
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller])
        Subsystem: Acer Incorporated [ALI] Device 0459
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0
        Interrupt: pin A routed to IRQ 44
        Region 0: Memory at d0000000 (64-bit, non-prefetchable) [size=4M]
        Region 2: Memory at c0000000 (64-bit, prefetchable) [size=256M]
        Region 4: I/O ports at 50f0 [size=8]
        Expansion ROM at <unassigned> [disabled]
        Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
                Address: fee0300c Data: 4191
        Capabilities: [d0] Power Management version 3
                Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
        Kernel driver in use: i915
        Kernel modules: i915

From sysfs:
root@amedeo:~# systool -c backlight -v
Class = "backlight"

  Class Device = "acpi_video0"
  Class Device path = "/sys/devices/pci0000:00/0000:00:02.0/backlight/acpi_video0"
    actual_brightness = "9"
    bl_power = "0"
    brightness = "9"
    max_brightness = "9"
    type = "firmware"
    uevent =

    Device = "0000:00:02.0"
    Device path = "/sys/devices/pci0000:00/0000:00:02.0"
      boot_vga = "1"
      broken_parity_status= "0"
      class = "0x030000"
      config = 86 80 42 2a 07 04 90 00 09 00 00 03 00 00 80 00
                             04 00 00 d0 00 00 00 00 0c 00 00 c0 00 00 00 00
                             f1 50 00 00 00 00 00 00 00 00 00 00 25 10 59 04
                             00 00 00 00 90 00 00 00 00 00 00 00 0b 01 00 00
                             00 00 00 00 48 00 00 00 09 00 0a 61 b1 6d 51 1f
                             b9 e1 70 03 19 00 00 00 00 00 00 00 00 00 00 bc
                             00 00 00 00 00 00 02 00 00 00 00 00 00 00 00 00
                             00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
                             00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
                             05 d0 01 00 0c 30 e0 fe 91 41 00 00 00 00 00 00
                             00 00 00 00 09 00 06 20 00 00 00 00 00 00 00 00
                             00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
                             00 00 00 00 00 00 00 00 00 00 00 00 40 01 00 00
                             01 00 23 00 00 00 00 00 00 00 00 00 34 00 00 00
                             00 00 00 00 00 00 00 00 00 80 00 1a 41 20 00 00
                             0b 19 34 07 00 00 00 00 a0 0f 09 00 18 c0 a8 bb
      consistent_dma_mask_bits= "36"
      de...

Read more...

Thank you for everyone who commented on this thread. With the exception of my hardware keys beings reversed, with the information on this post I was able to get Linux to install and the back light restored. I have a Gateway NV78.

I ended up adding "acpi_osi=Linux" to /etc/default/grub, "setpci -s 00:02.0 F4.B=00" to etc/rc.local, and installing the back light patched kernel. "acpi_osi=Linux" restored backwards functionality to the hardware buttons, "setpci -s..." set my back light to max on boot, and the back light patched kernel allowed me to use the hardware buttons after going into suspend mode or if the screen dimmed.

I also ended up having to use "i915.broken=1/i915.alse_backlight=1" to get in with the boot cd. Not sure why, but "acpi_osi=Linux" wasn't doing it for me then.

Thank you all again!

Id2ndR (id2ndr) wrote :

Same on :

System Information
 Manufacturer: Acer
 Product Name: Aspire 5736Z
 Version: V1.04
 Serial Number: LXRDE02007047431C01601
 UUID: DF4475A4-F14C-11DF-AAF9-1C750839F54B
 Wake-up Type: Power Switch
 SKU Number: Montevina_Fab
 Family: Intel_Mobile

"sudo setpci -s 00:02.0 F4.B=[HEX]" works like a charm. Thanks !

exrvs (exrvs) on 2011-10-15
Changed in linux (Ubuntu):
status: Confirmed → Incomplete

@exrvs
I'm assuming the change from Confirmed to Incomplete, which carried no explanation and does not make sense from context, was unintentional. If it was not by accident and you really are sure this bug should have Incomplete status, then please feel free to make the change again, but please provide an accompanying explanation.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

This bug is happening with Oneiric stable on a Gateway NV78; see https://answers.launchpad.net/ubuntu/+source/linux/+question/174545.

tags: added: oneiric

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.0.0-12.20

This bug remains, only with the boot parameter "acpi_backlight=vendor" at least we can change the backlight, but the controls are inverted (min brightness equal real max brightness). I hope someone can fix this regression.

cgonzalez (cmgonzalez) wrote :

I tested with the last 11.10 live cd....

The live CD contains the Oneiric release kernel, which is version 3.0.0-12.20 as indicated at https://launchpad.net/ubuntu/+source/linux (expand The Oneiric Ocelot). This fulfills kernel-request-3.0.0-12.20 (https://bugs.launchpad.net/ubuntu/+source/linux/+bug/765438/comments/27), so I'm marking this bug back to Confirmed.

@Brad Figg / Brad Figg's bot
Yes, as reported by cgonzalez (https://bugs.launchpad.net/ubuntu/+source/linux/+bug/765438/comments/28 & https://bugs.launchpad.net/ubuntu/+source/linux/+bug/765438/comments/29), this bug still occurs with the latest kernel in Oneiric.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Jens Elbaek (jens-elbaek) wrote :

The error persists in Ubuntu 10.11 and even worse. It reoccurs when the screen goes into pause mode.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Timothy Mayoh (timothy-m) wrote :

This bug is not incomplete.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Sorry. Hope you can fix it quickly. It is very anoying!

Med venlig hilsen
Jens Elbæk
Skejbytoften 83
8200 Århus N
http://jenselbaek.dk

2011/10/17 Timothy Mayoh <email address hidden>

> This bug is not incomplete.
>
> ** Changed in: linux (Ubuntu)
> Status: Incomplete => Confirmed
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/765438
>
> Title:
> On startup, the backlight is off on laptop
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/765438/+subscriptions
>

Would it be possible for you to test the latest upstream kernel? It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the release candidate kernel versus the daily build. Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

tags: added: needs-upstream-testing
cgonzalez (cmgonzalez) wrote :

This bugs also are related:

779166
752165
773471
568611

cgonzalez (cmgonzalez) wrote :

Currently i'm running rc9 and also tested the 3.1.0-999.201110171146 daily, and the bugs remain.

i can only control the brightness with the parameter acpi_backlight=vendor, and also the backlight control is inverted.

tags: removed: needs-upstream-testing
Changed in linux (Ubuntu):
status: Confirmed → Triaged

I have a different problem though. On startup, my backlight is not off but is at its highest. It's an HP Pavilion dv3 with Intel GMA 45 graphics card.

tags: added: kernel-bug-exists-upstream
Kangarooo Jānis (kangarooo) wrote :

I have eMachines E525 to be exact E525-902G16Mi
more info on http://www.notebookcheck.net/Acer-eMachines-E525-Series.28013.0.html
PROBLEM?
backlight so dark that cant see even when very close with glass enlager.
I reproduce this on Ubuntu and Xubuntu 11.04 and NOW also on 11.10 all on Live CD versions and cant install couse cant see.
Can see only on external monitor half couse other half is on dark plaptop monitor if plugged in after computer started or all if plugged in before starting comp.

Joseph Wagner (jryanwagner00) wrote :

Also on a Gateway NV78, and confirming that the bug exists. The "sudo pci..." command worked for me, though the grub fix did not.

Joseph Wagner (jryanwagner00) wrote :

Edit to previous comment, the grub fix did indeed work, I just failed to note that the commands were backwards. :)

james (silent-at-night) on 2012-07-13
Changed in linux (Ubuntu):
status: Triaged → Confirmed
Changed in linux (Ubuntu):
importance: Undecided → Critical
status: Confirmed → Triaged
Changed in linux:
importance: Undecided → Unknown
status: New → Unknown
Changed in linux:
importance: Unknown → Medium
status: Unknown → Incomplete
tags: added: laptop-testing
Changed in linux:
status: Incomplete → Expired
Changed in linux:
status: Expired → Confirmed
66 comments hidden view all 146 comments
Kangarooo Jānis (kangarooo) wrote :

Emachines e525
Intel Celeron 900 @ 2.20 GHz
12.04 black screen.
Latest kernel: Found linux image: /boot/vmlinuz-3.2.0-33-generic-pae
Tryd
acpi_osi=Linux

Since on booting its still black and i dont know when its started but only after doing one change of brightness then i added setpci -s 00:02.0 F4.B=00 to sudo gedit etc/rc.local and it works on boot already.
BUT after suspend doesnt so i need again to change brightness once so it lights up again.

I did the same with my Emachines g525 ubuntu 12.10 64 bit
and i did the edit in rc.local
and the same when suspend the screen is black

problem no. two with this is that sometimes the screen goes into suspend still after i have set the screenlock to never suspend and in power setting that nothing should happend even if i close my lid

i have tried to get help regarding my second but no one can help with this
but still the backlight problem is not solved on my machine

Download full text (5.2 KiB)

I did the same exact thing and I got the same exact results. I have to
press FN and the left arrow key to get the back light on.

On Thu, Nov 29, 2012 at 2:06 PM, Kenneth Thorell
<email address hidden>wrote:

> I did the same with my Emachines g525 ubuntu 12.10 64 bit
> and i did the edit in rc.local
> and the same when suspend the screen is black
>
> problem no. two with this is that sometimes the screen goes into suspend
> still after i have set the screenlock to never suspend and in power
> setting that nothing should happened even if i close my lid
>
> i have tried to get help regarding my second but no one can help with this
> but still the backlight problem is not solved on my machine
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (772050).
> https://bugs.launchpad.net/bugs/765438
>
> Title:
> On startup, the backlight is off on laptop
>
> Status in The Linux Kernel:
> Confirmed
> Status in “linux” package in Ubuntu:
> Triaged
> Status in “linux” package in Fedora:
> New
>
> Bug description:
> When Ubuntu starts up, the back-light is off on my laptop. I can plug
> it into an external monitor and the display is fine. I can easily
> turn the back-light on with "sudo setpci -s 00:02.0 F4.B=[HEX]" where
> 00 is the brightest and FF is off. In past distributions, the GUI-
> based brightness utilities did not work and I used this command to
> change by back-light brightness. I know that there are many people
> who can not use back-light GUI-utilities on the past distributions as
> well. This issue also occurs if I close my screen and raise it again.
>
> This issue also effected the installation process as well as when I
> was using the i686 installer.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.04
> Package: xorg 1:7.6+4ubuntu3
> ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
> Uname: Linux 2.6.38-8-generic x86_64
> Architecture: amd64
> CompizPlugins:
> [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
> CompositorRunning: compiz
> CurrentDmesg:
> [ 29.430043] eth0: no IPv6 routers present
> [ 30.988586] EXT4-fs (sda7): re-mounted. Opts:
> errors=remount-ro,commit=0
> DRM.card0.DP.1:
> status: disconnected
> enabled: disabled
> dpms: Off
> modes:
> edid-base64:
> DRM.card0.LVDS.1:
> status: connected
> enabled: enabled
> dpms: On
> modes: 1366x768
> edid-base64:
> AP///////wANr5kVAAAAAAcUAQOAIhN4Cj2VlFZPjigmUFQAAAABAQEBAQEBAQEBAQEBAQEBeh1W0lAAHjA8KDYAWMEQAAAYAAAA/gBOMTU2QjMtTDBCCiAgAAAA/gBDTU8KICAgICAgICAgAAAA/gBOMTU2QjMtTDBCCiAgAEg=
> DRM.card0.VGA.1:
> status: disconnected
> enabled: disabled
> dpms: Off
> modes:
> edid-base64:
> Date: Mon Apr 18 21:34:59 2011
> DistUpgraded: Fresh install
> DistroCodename: natty
> DistroVariant: ubuntu
> GdmLog1:
>
> GdmLog2:
>
> GraphicsCard:
> Intel Corporation Mobile 4 Series Chipset Integrated Graphics
> Controller [8086:...

Read more...

Emachines e525
Intel Celeron 900 @ 2.20 GHz
12.10 black screen.
Latest kernel: Found linux image: /boot/vmlinuz-3.5.0-17-generic
Tryd nomodeset
On booting Ubuntu says it will go to safe mode and reconfigure doesnt work. Nothing works.

Kangarooo Jānis (kangarooo) wrote :

Emachines e525
Intel Celeron 900 @ 2.20 GHz
12.10 black screen.
Latest kernel: Found linux image: /boot/vmlinuz-3.5.0-17-generic
Tryd
acpi_osi=Linux

when booted i change brightness once and
black dissapears and i see all.
CAN
change brightness but doing fn + brightness up gives ±±±±±±±±±±±±±±±±±±±±
And did test if unity supported /usr/lib/nux/unity_support_test -p
Yes to all

sma (m-0622) wrote :
Download full text (3.5 KiB)

Notebook Acer TravelMate 5735Z-452G32MNSS

1) Ubuntu 12.10 (Quantal Queezal):
The parameter i915.invert_brightness=1 fixes the bug! :-)

Step-by-step - beginning from installation:
- Boot with the Ubuntu Live-CD or Live-USB-Stick.
- When the display becomes purple press CursorLeft or CursorRight. You see the menu.
- Choose your language and press F6, then press Esc.
- Put the cursor to the end of the line (after --) and enter: i915.invert_brightness=1
- Start the installation. At the end of the installation restart.
- When the Notebook starts to boot again press Shift and hold the key unless the menu of GRUB appears.
- Press the key e (e for edit).
- Put the cursor after 'quiet splash', and enter after a blank: i915.invert_brightness=1 (Note: looks like: .... quiet splash i915.invert_brightness=1). Note: On my Laptop at this time the keyboard has the US-layout, not my common layout!
- Press F10 to boot.
- Open a terminal and enter: gksu gedit /etc/default/grub
- Replace the line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash“ by this line: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor i915.invert_brightness=1"
- Save the file.
- In the terminal enter: sudo update-grub
- After restarting my Acer TravelMate 5735Z works perfekt. It boots into a bright display. Also after waking up from hibernate and standby the display is bright. :-))

2) Ubuntu 12.04 LTS (Precise Pangolin):
The parameter i915.invert_brightness=1 doesn't work. But a workaround exists, that has the same result! :-)

Step-by-step - beginning from installation:
- Boot with the Ubuntu Live-CD or Live-USB-Stick.
- When the display becomes purple press CursorLeft or CursorRight. You see the menu.
- Choose your language and press F6, then press Esc.
- Put the cursor to the end of the line (after --) and enter: acpi_osi=Linux acpi_backlight=vendor (Note: this is necessary to turn on brightness after booting by using the keys FN+CursorRight or Fn+CursorLeft).
- Start booting (Option 'Testing Ubuntu without installation'). You will boot into a black screen. Press FN+CursorRight or Fn+CursorLeft to turn on brightness. Start the installation of Ubuntu using the icon on the desktop. At the end of the installation restart.
- When the Notebook starts to boot again press Shift and hold the key unless the menu of GRUB appears.
- Press the key e (e for edit).
- Put the cursor after 'quiet splash', and enter after a blank: acpi_osi=Linux acpi_backlight=vendor (Note: looks like: .... quiet splash acpi_osi=Linux acpi_backlight=vendor). Note: On my Laptop at this time the keyboard has the US-layout, not my common layout!
- Press F10 to boot.
- Open a terminal and enter: gksu gedit /etc/default/grub
- Replace the line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash“ by this line: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor"
- Save the file.
- In the terminal enter: sudo update-grub
- In the terminal enter: gksu gedit /etc/rc.local
- Above the line exit 0 enter: echo "1" > /sys/class/backlight/intel_backlight/brightness
- Save the file.
- After restarting my Acer TravelMate 5735Z works perfekt. It boots into a bright display. Also after waking up fr...

Read more...

2012/11/30 sma <email address hidden>

> GRUB_CMDLINE_LINUX_DEFAULT="quiet splash“ by this line:
> GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux
> acpi_backlight=vendor i915.invert_brightness=1"
>

I added this line and it works for me EXCEPT that I get a lower resolution.
I had 1366 x 768, now it's 1024 x 768. Can it be tweaked?

Acer emachnines e725 with Mobile 4 Series Chipset Integrated Graphics
Controller

Gilbert Dion

Kangarooo Jānis (kangarooo) wrote :

try without acpi_osi and check if works with changing brightness and
if alt+tab gives 3d effect.
if not good then try it should work.
acpi_osi=nomodeset

Gilbert Dion (diong) wrote :
Download full text (4.7 KiB)

Both parameters had no effect. The screen backlighting went off, as it did
in the first place.
g

2012/12/8 Kangarooo <email address hidden>

> try without acpi_osi and check if works with changing brightness and
> if alt+tab gives 3d effect.
> if not good then try it should work.
> acpi_osi=nomodeset
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (934707).
> https://bugs.launchpad.net/bugs/765438
>
> Title:
> On startup, the backlight is off on laptop
>
> Status in The Linux Kernel:
> Confirmed
> Status in “linux” package in Ubuntu:
> Triaged
> Status in “linux” package in Fedora:
> New
>
> Bug description:
> When Ubuntu starts up, the back-light is off on my laptop. I can plug
> it into an external monitor and the display is fine. I can easily
> turn the back-light on with "sudo setpci -s 00:02.0 F4.B=[HEX]" where
> 00 is the brightest and FF is off. In past distributions, the GUI-
> based brightness utilities did not work and I used this command to
> change by back-light brightness. I know that there are many people
> who can not use back-light GUI-utilities on the past distributions as
> well. This issue also occurs if I close my screen and raise it again.
>
> This issue also effected the installation process as well as when I
> was using the i686 installer.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.04
> Package: xorg 1:7.6+4ubuntu3
> ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
> Uname: Linux 2.6.38-8-generic x86_64
> Architecture: amd64
> CompizPlugins:
> [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
> CompositorRunning: compiz
> CurrentDmesg:
> [ 29.430043] eth0: no IPv6 routers present
> [ 30.988586] EXT4-fs (sda7): re-mounted. Opts:
> errors=remount-ro,commit=0
> DRM.card0.DP.1:
> status: disconnected
> enabled: disabled
> dpms: Off
> modes:
> edid-base64:
> DRM.card0.LVDS.1:
> status: connected
> enabled: enabled
> dpms: On
> modes: 1366x768
> edid-base64:
> AP///////wANr5kVAAAAAAcUAQOAIhN4Cj2VlFZPjigmUFQAAAABAQEBAQEBAQEBAQEBAQEBeh1W0lAAHjA8KDYAWMEQAAAYAAAA/gBOMTU2QjMtTDBCCiAgAAAA/gBDTU8KICAgICAgICAgAAAA/gBOMTU2QjMtTDBCCiAgAEg=
> DRM.card0.VGA.1:
> status: disconnected
> enabled: disabled
> dpms: Off
> modes:
> edid-base64:
> Date: Mon Apr 18 21:34:59 2011
> DistUpgraded: Fresh install
> DistroCodename: natty
> DistroVariant: ubuntu
> GdmLog1:
>
> GdmLog2:
>
> GraphicsCard:
> Intel Corporation Mobile 4 Series Chipset Integrated Graphics
> Controller [8086:2a42] (rev 09) (prog-if 00 [VGA controller])
> Subsystem: Acer Incorporated [ALI] Device [1025:0459]
> Subsystem: Acer Incorporated [ALI] Device [1025:0459]
> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110413)
> MachineType: eMachines eMachines E527
> ProcEnviron:
> LANGUAGE=en_US:en
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> ProcKernelCmdLine: BOOT_...

Read more...

Kangarooo Jānis (kangarooo) wrote :

Did you really tryd changing brightness when comp has loaded? Using
FN+Right/Left arrow? In all 3 variations?

Hey, thanks sma!!! It really worked! Great tip! I've been searching for the answer for a looong time.

I'm using an acer 5732z and i already had ubuntu 12.10 installed. I only followed your advice starting with the grub part and it still worked.

Download full text (5.1 KiB)

I tried
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor
i915.invert_brightness=1"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux
acpi_backlight=vendor i915.invert_brightness=1"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=nomodeset
acpi_backlight=vendor i915.invert_brightness=1"

All give me the same lower screen resolution (1024 x 768) instead of the
one I used to have (1366 x 768). Changing brightness does not work and
using Alt-Tab reminds me of Windows 3.1.

Merci,

Gilbert

2012/12/8 Kangarooo <email address hidden>

> Did you really tryd changing brightness when comp has loaded? Using
> FN+Right/Left arrow? In all 3 variations?
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (934707).
> https://bugs.launchpad.net/bugs/765438
>
> Title:
> On startup, the backlight is off on laptop
>
> Status in The Linux Kernel:
> Confirmed
> Status in “linux” package in Ubuntu:
> Triaged
> Status in “linux” package in Fedora:
> New
>
> Bug description:
> When Ubuntu starts up, the back-light is off on my laptop. I can plug
> it into an external monitor and the display is fine. I can easily
> turn the back-light on with "sudo setpci -s 00:02.0 F4.B=[HEX]" where
> 00 is the brightest and FF is off. In past distributions, the GUI-
> based brightness utilities did not work and I used this command to
> change by back-light brightness. I know that there are many people
> who can not use back-light GUI-utilities on the past distributions as
> well. This issue also occurs if I close my screen and raise it again.
>
> This issue also effected the installation process as well as when I
> was using the i686 installer.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.04
> Package: xorg 1:7.6+4ubuntu3
> ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
> Uname: Linux 2.6.38-8-generic x86_64
> Architecture: amd64
> CompizPlugins:
> [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
> CompositorRunning: compiz
> CurrentDmesg:
> [ 29.430043] eth0: no IPv6 routers present
> [ 30.988586] EXT4-fs (sda7): re-mounted. Opts:
> errors=remount-ro,commit=0
> DRM.card0.DP.1:
> status: disconnected
> enabled: disabled
> dpms: Off
> modes:
> edid-base64:
> DRM.card0.LVDS.1:
> status: connected
> enabled: enabled
> dpms: On
> modes: 1366x768
> edid-base64:
> AP///////wANr5kVAAAAAAcUAQOAIhN4Cj2VlFZPjigmUFQAAAABAQEBAQEBAQEBAQEBAQEBeh1W0lAAHjA8KDYAWMEQAAAYAAAA/gBOMTU2QjMtTDBCCiAgAAAA/gBDTU8KICAgICAgICAgAAAA/gBOMTU2QjMtTDBCCiAgAEg=
> DRM.card0.VGA.1:
> status: disconnected
> enabled: disabled
> dpms: Off
> modes:
> edid-base64:
> Date: Mon Apr 18 21:34:59 2011
> DistUpgraded: Fresh install
> DistroCodename: natty
> DistroVariant: ubuntu
> GdmLog1:
>
> GdmLog2:
>
> GraphicsCard:
> Intel Corporation Mobile 4 Series Chipset Integrated Graphics
> Controller [8086:2a42] (rev 09) (prog-if 00 [...

Read more...

Hi everybody
- Dell Latitude E4310 / core i5 with intel graphics chip
- LTS 12.04
This bug is VERY SEVERE on my laptop (actually, it is almost broken now and I will soon need a new one).
reason:
- when it happens there is no backlight and nothing to do, or almost
- it is quite random. I tried almost all of the above tricks (stepci, boot options --- but not yet i915 invert brighness nor the change in rc.local, this is for next time it happens) and it does not work, or sometimes it does but it is never very clear what works, since the bug always reappears later
- I tried (using an external display) : to echo 1 in intel_backlight/brightness, to manually (after login) increase the brightness, etc, etc. No effect.
- I tried also Kamal's kernels (it was almost worst: sometimes instead of going blank in power save mode it was turning white)
- Sometimes (not always) suspending / resuming works
- sometimes rebooting works. last time I rebooted using a different kernel and it worked, I will check whether this is reproducible (next time I get the bug... but I'd rather never have it again)
- sometimes unplugging the battery and waiting for some time works (not anymore, though, it seems)
- sometimes nothing works and my laptop is unusable for some time
- when the backlight is broken, it stays broken even when I boot Windows
- Dell came and changed my display 1 month ago. Now Windows is broken (thanks a lot Dell, I was not using it very often but now I have no choice :-), but the bug happened again after a few weeks (bizarre, uh?)

I'm afraid I will have to forget about using Linux if all recent kernels of all major distributions can break your computer.....
(But what? get a mac?? --- in fact I'll certainly get a different graphics system next time...)
sorry for being so pessimistic, this is the first time I encounter such a severe problem under linux...
Best, thanks to all developers

Here i made Gdocs Spreadsheet for accumulating all info.
https://docs.google.com/spreadsheet/ccc?key=0Al_jJwVplfK7dFdPdURaQkdlQlhCaDlfM3hZOGhMa0E
Post ur laptop name and what works and what doesnt and how

@ kangaroo : thanks
I'll try to get as much info as possible next time I am affected by the bug (hopefully, never). As I told it is very random, the laptop may work for 2 weeks and then suddenly it gets dark and none of the standard tricks wakes it up (or never the same...)
Right now I removed all modifications in grub, etc, and it's been working for one week without trouble.

News:
my guess is that it is still the randomness of the bug working around, or there has been a substantial improvements in recent kernels/Xorg drivers, but the bug is still present however in the past month EVERY time it occurred I could log in, suspend the computer (not hibernate), wake it up, and after usually one or two trials it went up again (in November/December it was not working even after 10 or 15 rounds).
So now, as far as my Dell E4310 laptop is concerned, it is less critical.
I must make clear that I use NONE of the other tricks (I tried them all in the past months, and none was solving the issue in a stable way, now they are all removed and I'm running the standard 12.04 (amd64) up to date distribution).

Changed in linux:
status: Confirmed → Fix Released
maxicastro (maxicastro) wrote :

in eMachines E725 remains the same at first. (Ubuntu 12.04 up to date)

the fix for the kernel is only the kernel? when implemented in ubuntu?

sorry for my bad english

Ihorko (ihorchyhin) wrote :

On my HP 62-a35er with integrated intel gpu and discrete radeon gpu fix is not correct. If I don't add kernel parameter acpi_backlight=vendor backlight is off.
As I tested at boot there are 4 items under /sys/class/backlight:
acpi_video0
acpi_video1
intel_backlight
radeon_bl1

After login brightness is controlled under acpi_video1 for some reason.
But brightness was set under intel_backlight to 4394 (maximum 4882).
Kernel version: 3.7.5-1 (currently I use Arch but believe that kernel in Ubuntu is roughly the same)

Ihorko (ihorchyhin) wrote :

Just found that laptop-mode-tools installed changed brightness under intel_backlight to 4394...
Originally it was set to 0.

G.TORES (ggom20) wrote :

Hello!
Got semi-erratic troubles with the backlight too:

Laptop Asus N76VZ

Ubuntu 12.10

Starts with a medium- low luminosity so i made shortcut to (french language system): "parametres systeme , then : lumisosité et verrouillage" witch could be translated as something like "system configuration , light and locking".

then suddently light changes to maximum, without any action on cursor.

The standard control doesnt work well as when it goes to screen saving, it comes out with a very low light,
thats why i look for work around.

Been trying to restore keyboard keys for setting the backlight by installing xbacklight:

sudo apt-get install xbacklight

Did also at startup xbacklight =75

And then affected the lumisosity keys to, respectivly,

xbacklight +5
xbacklight -5

This thing as been working , but is erratic , sometimes woks fine ,
sometimes my keys acting as a bistable switch , variing light with only two values.

I'd like to use my keys shortcuts to adress this in a more direct way, like sending the right parameters to
the standard program and uninstalling xbacklight.

There is a problem somewhere.
I fell like it could be related to broken communication between some programs , the variable related to light.

Thanks for the care you take on Linux Systems !

Paul (alldev) wrote :

Hello.

Friend of mine kept bugging me to look at his problem. He has Gateway NV78 and tried to install ubuntu 12.10. Encountered backlight problem (he thought all was dead).

Tried a few suggestions to no avail. The 'setpci' worked, but did not help after screen-saver/hibernate/etc.

I have not had any real time to spend of this, nor look at source so...
here is a pathetic work-a-round that got him working and not complaining:

file: /etc/rc.local (add):

    if [ -x /lib/init/backlight_workaround ]
    then
        /lib/init/backlight_workaround
    fi

create file '/lib/init/backlight_workaround' and
chmod +x /lib/init/backlight_workaround

put in file: /lib/init/backlight_workaround

    #!/bin/sh
    ( while sleep 1; do /usr/bin/setpci -s '00:02.0' 'F4.B=00'; done & ) &

hope this helps someone else too.
(file name & location used is just an example, but demonstrates the idea).

Jani Nikula (jnikula) wrote :

If you're having this problem on an Acer/eMachines/Packard Bell/Gateway laptop, try booting with i915.invert_brightness=1 module parameter (https://help.ubuntu.com/community/BootOptions). If it works, consider filing an upstream bug on Product=DRI, Component=DRM/Intel (https://01.org/linuxgraphics/documentation/how-report-bugs-0) with the output of 'lspci -vmmnn' attached.

After updating to the latest kernerl 3.8.0.13 on 13.04 somehow the rc.local file is not activeted any more and the fix of "setpci -s 00:02.0 F4.B=00 only works after the computer is ready after boot and i have to use a externa screen to acces terminal window to setpci again
And five times i an row the gpu is frosen and closing with the powerbutton is the only way

is this somehow connected to one and another?

Tobias Bannert (toba) wrote :

Where is the fix?

Ubuntu 13.04 (I made an usb live stick) nothing fixed.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu (Ubuntu):
status: New → Confirmed

I believe this problem also affect Packard Bell EasyNote LV. It need i915.invert_brightness=1 to avoid the black screen of death when installing Ubuntu and when booting the installed system. With the setting in place, one can log into Gnome, but when one log into KDE, the screen is turned off again.

See http://www.linlap.com/packard_bell_easynote_lv for my notes about Linux on this machine. I've reported the problem to the kernel developers and as Debian bugs http://bugs.debian.org/710938 and http://bugs.debian.org/711237 .

m_a_n_u (emmanuel-legrand) wrote :

Boot is (at last) OK with last update in KUBUNTU (kernel 3.8.0-22-generic), on ACER emachines G725.

On my system (Ubuntu 13.04 Kernel 3.8.0-25-generic, Acer V3-771G) the issue still exists.

Kangarooo Jānis (kangarooo) wrote :

How to make this fixed? Why isnt it fixed?

Download full text (4.7 KiB)

Since I upgraded to 13.04, everything is just fine again. No need of any
extra parameters in grub file.
g

2013/6/13 Kangarooo Jānis <email address hidden>

> How to make this fixed? Why isnt it fixed?
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (934707).
> https://bugs.launchpad.net/bugs/765438
>
> Title:
> On startup, the backlight is off on laptop
>
> Status in The Linux Kernel:
> Fix Released
> Status in “linux” package in Ubuntu:
> Triaged
> Status in “ubuntu” package in Ubuntu:
> Confirmed
> Status in “linux” package in Fedora:
> New
>
> Bug description:
> When Ubuntu starts up, the back-light is off on my laptop. I can plug
> it into an external monitor and the display is fine. I can easily
> turn the back-light on with "sudo setpci -s 00:02.0 F4.B=[HEX]" where
> 00 is the brightest and FF is off. In past distributions, the GUI-
> based brightness utilities did not work and I used this command to
> change by back-light brightness. I know that there are many people
> who can not use back-light GUI-utilities on the past distributions as
> well. This issue also occurs if I close my screen and raise it again.
>
> This issue also effected the installation process as well as when I
> was using the i686 installer.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.04
> Package: xorg 1:7.6+4ubuntu3
> ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
> Uname: Linux 2.6.38-8-generic x86_64
> Architecture: amd64
> CompizPlugins:
> [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
> CompositorRunning: compiz
> CurrentDmesg:
> [ 29.430043] eth0: no IPv6 routers present
> [ 30.988586] EXT4-fs (sda7): re-mounted. Opts:
> errors=remount-ro,commit=0
> DRM.card0.DP.1:
> status: disconnected
> enabled: disabled
> dpms: Off
> modes:
> edid-base64:
> DRM.card0.LVDS.1:
> status: connected
> enabled: enabled
> dpms: On
> modes: 1366x768
> edid-base64:
> AP///////wANr5kVAAAAAAcUAQOAIhN4Cj2VlFZPjigmUFQAAAABAQEBAQEBAQEBAQEBAQEBeh1W0lAAHjA8KDYAWMEQAAAYAAAA/gBOMTU2QjMtTDBCCiAgAAAA/gBDTU8KICAgICAgICAgAAAA/gBOMTU2QjMtTDBCCiAgAEg=
> DRM.card0.VGA.1:
> status: disconnected
> enabled: disabled
> dpms: Off
> modes:
> edid-base64:
> Date: Mon Apr 18 21:34:59 2011
> DistUpgraded: Fresh install
> DistroCodename: natty
> DistroVariant: ubuntu
> GdmLog1:
>
> GdmLog2:
>
> GraphicsCard:
> Intel Corporation Mobile 4 Series Chipset Integrated Graphics
> Controller [8086:2a42] (rev 09) (prog-if 00 [VGA controller])
> Subsystem: Acer Incorporated [ALI] Device [1025:0459]
> Subsystem: Acer Incorporated [ALI] Device [1025:0459]
> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110413)
> MachineType: eMachines eMachines E527
> ProcEnviron:
> LANGUAGE=en_US:en
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic
> root=U...

Read more...

I have this problem with 13.04 on a Lenovo y410p (4th gen Intel + nvidia gpu). My workaround was to add

echo 100 | sudo tee /sys/class/backlight/acpi_video0/brightness

to my /etc/rc.local file but this isn't exactly an ideal solution.

Tyler Burton (tylerburtonca) wrote :

I've actually managed to "fix" this problem without the workaround by adding "acpi_backlight=vendor" to the GRUB_CMDLINE_LINUX of /etc/default/grub

summary: - On startup, the backlight is off on laptop
+ 8086:2a42 On startup, the backlight is off on laptop
tags: added: bot-stop-nagging
removed: kernel-request-3.0.0-12.20
tags: added: precise
summary: - 8086:2a42 On startup, the backlight is off on laptop
+ 8086:2a42 [eMachines E527] On startup, the backlight is off on laptop
no longer affects: ubuntu (Ubuntu)
no longer affects: linux (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Travis DePrato, could you please confirm this issue exists with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ . If the issue remains, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available (not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue.Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.13-rc1

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

Changed in linux (Ubuntu):
status: New → Confirmed
affects: linux (Fedora) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: New → Incomplete
importance: Undecided → Medium
tags: added: bios-outdated-v1.06 needs-upstream-testing
Photon (michael-kogan) wrote :

I encountered this problem on an HP Compaq CQ58-d69sg right now. The kernel option acpi_backlight=vender fully solved the problem (backlight control with the keyboard also works properly).

Photon, thank you for your comment. If you would like your problem addressed without any WORKAROUNDs, please feel free to file a new report with Ubuntu by executing the following in a terminal while booted into a Ubuntu repository kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

Photon (michael-kogan) wrote :

Thanks for the hint, Christopher! Unfortunately, I set up this machine for some relatives of mine, so I don't have access to it any more. However I installed Teamviewer for urgent cases, so if they should encounter any problems and I can get access to it, I will use the opportunity to file a bug report. For now I just permanently added the kernel option to the GRUB configuration.

jonata (jbopen) wrote :

Bug still present in Ubuntu 14.04

jonata, thank you for your comment. So your hardware and problem may be tracked, could you please file a new report with Ubuntu by executing the following in a terminal while booted into a Ubuntu repository kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

Displaying first 40 and last 40 comments. View all 146 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.