Ubuntu

[STAGING]soft switch on keyboard doesn't work

Reported by Michael on 2011-04-13
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
Medium
Unassigned

Bug Description

My wi-fi and bluetooth soft switch on keyboard doesn't work, so that i can't use wireless. And it works fine in Ubuntu 10.10.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: linux-image-2.6.38-8-generic 2.6.38-8.42
Regression: No
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: wl fglrx
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: SB [HDA ATI SB], device 0: ALC271X Analog [ALC271X Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: michael 1706 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'SB'/'HDA ATI SB at 0xd0400000 irq 16'
   Mixer name : 'Realtek ALC271X'
   Components : 'HDA:10ec0269,10250429,00100100'
   Controls : 18
   Simple ctrls : 10
Card1.Amixer.info:
 Card hw:1 'HDMI'/'HDA ATI HDMI at 0xd0110000 irq 19'
   Mixer name : 'ATI RS690/780 HDMI'
   Components : 'HDA:1002791a,00791a00,00100000'
   Controls : 4
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Wed Apr 13 22:42:21 2011
HibernationDevice: RESUME=UUID=becdecc2-8439-4880-af4d-c886d0618da9
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110330)
MachineType: Acer Aspire One 721
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-2.6.38-8-generic root=UUID=5d2e9501-c497-4af0-977a-8732a18a0a6e ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-2.6.38-8-generic N/A
 linux-backports-modules-2.6.38-8-generic N/A
 linux-firmware 1.50
SourcePackage: linux
StagingDrivers: brcm80211
Title: [STAGING]
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/14/2010
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: V1.11
dmi.board.asset.tag: No Asset Tag
dmi.board.name: Aspire One 721
dmi.board.vendor: Acer
dmi.board.version: V1.11
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: V1.11
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvrV1.11:bd05/14/2010:svnAcer:pnAspireOne721:pvrV1.11:rvnAcer:rnAspireOne721:rvrV1.11:cvnAcer:ct10:cvrV1.11:
dmi.product.name: Aspire One 721
dmi.product.version: V1.11
dmi.sys.vendor: Acer

Michael (michael-james-chou) wrote :
Michael (michael-james-chou) wrote :

my laptop is acer aspire one 721. the soft switch for wifi and bluetooth is fn+f3.

Brad Figg (brad-figg) on 2011-05-04
Changed in linux (Ubuntu):
status: New → Confirmed
Resolution (norman-abi02) wrote :

Got the same problem, but with a different network controller.
Worked fine under 10.10. After upgrade i could not activate WLAN like Michael

Resolution (norman-abi02) wrote :

As you can see in the duplicate Bugreport 791373 you can fix it with blacklisting acer_wmi in the /etc/modprobe.d/blacklist.conf

This is a nice and simple workaround. I tried it 5 minutes ago and it works. All FN key combinations work properly.

sbraz (sbraz) wrote :

same here.
 it's a kernel problem, we're trying to fix it here:
https://bugzilla.kernel.org/show_bug.cgi?id=41562

compiling acer-wmi.c from 2.6.39.4 in 3.0's tree solves temporarily.

Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed

sbraz, this bug is still present for you in Oneiric? For me on the same laptop it's already fixed.

Changed in linux:
status: Confirmed → Fix Released

Michael, thank you for reporting this and helping make Ubuntu better. Natty reached EOL on October 2012.
Please see this document for currently supported Ubuntu releases:
https://wiki.ubuntu.com/Releases

We were wondering if this is still an issue in a supported release? If so, could you please test for this with the latest development release of Ubuntu? ISO CD images are available from http://www.ubuntu.com/download/desktop .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the kernel in the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested and remove the tag:
needs-upstream-testing

This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the text:
needs-upstream-testing

If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested.

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested.

If you are unable to test the mainline kernel, please comment as to why specifically you were unable to test it and add the following tags:
kernel-unable-to-test-upstream
kernel-unable-to-test-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested.

Please let us know your results. Thank you for your understanding.

Helpful Bug Reporting Tips:
https://help.ubuntu.com/community/ReportingBugs

tags: added: regression-release
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Changed in linux (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.