Ubuntu

driver ath9k is too slow or not responding

Reported by Le Gluon Du Net on 2011-03-14
248
This bug affects 44 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Arch Linux)
Invalid
Undecided
Unassigned
linux (Ubuntu)
Medium
Tim Gardner
Natty
Medium
Tim Gardner

Bug Description

For several kernel build now the ath9k is not fully fonctionnal with my :

#lspci
02:00.0 Network controller: Atheros Communications Inc. AR5008 Wireless Network Adapter (rev 01)

The connection is too slow or not responding.

Happily I found a solution:
I use the last tarball from here:
http://linuxwireless.org/en/users/Download#Directly_downloading_the_tarball

But each time the kernel is updated, I have to compile it and install it again.
Are you aware of this problem?

Thanks for your help.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: linux-image-2.6.38-6-generic 2.6.38-6.34
Regression: No
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.38-6.34-generic 2.6.38-rc7
Uname: Linux 2.6.38-6-generic i686
NonfreeKernelModules: nvidia
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: romain 1841 F.... pulseaudio
 /dev/snd/controlC0: romain 1841 F.... pulseaudio
CRDA: Error: [Errno 2] Aucun fichier ou dossier de ce type
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xfdff8000 irq 43'
   Mixer name : 'Realtek ALC1200'
   Components : 'HDA:10ec0888,103c2a5e,00100101'
   Controls : 37
   Simple ctrls : 20
Card1.Amixer.info:
 Card hw:1 'Q9000'/'Logitech, Inc. QuickCam Pro 9000 at usb-0000:00:1d.7-4, high speed'
   Mixer name : 'USB Mixer'
   Components : 'USB046d:0990'
   Controls : 2
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'Mic',0
   Capabilities: cvolume cvolume-joined cswitch cswitch-joined penum
   Capture channels: Mono
   Limits: Capture 0 - 3072
   Mono: Capture 0 [0%] [18.00dB] [on]
Date: Mon Mar 14 23:23:45 2011
HibernationDevice: RESUME=UUID=980b477e-8465-4c8f-927e-516c167ce02e
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110302)
MachineType: HP-Pavilion GX598AA-ABF a6221.fr
ProcEnviron:
 LANGUAGE=fr:en
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-6-generic root=UUID=16c9140c-d87b-4d72-97d9-c796f9b870f5 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-2.6.38-6-generic N/A
 linux-backports-modules-2.6.38-6-generic N/A
 linux-firmware 1.48
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/27/2007
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: 5.21
dmi.board.name: Leonite2
dmi.board.vendor: ASUSTek Computer INC.
dmi.board.version: 6.00
dmi.chassis.type: 3
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: 1111
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvr5.21:bd07/27/2007:svnHP-Pavilion:pnGX598AA-ABFa6221.fr:pvr:rvnASUSTekComputerINC.:rnLeonite2:rvr6.00:cvnHewlett-Packard:ct3:cvr1111:
dmi.product.name: GX598AA-ABF a6221.fr
dmi.sys.vendor: HP-Pavilion

Le Gluon Du Net (legluondunet) wrote :
Kent deVillafranca (kdevilla) wrote :

I'm also seeing this problem with the ath9k driver. Using what comes with Ubuntu, scp over my wireless LAN is less than 1/8th the speed I can get with the driver compiled from that tarball.

This is using Ubuntu Natty on an x86_64 computer.

Le Gluon Du Net (legluondunet) wrote :

same bug with the last ubuntu natty kernel version, 2.6.38-7: connection too slow with the ath9k driver, , web site does not load completely...
I compiled the last version of compat-wireless and my connection is at the top!
Tips: to compile the last compat-wireless on Ubuntu Natty, you have to add this line:

#include <linux/sched.h>

in the file

compat/compat-2.6.39.c

--> see this thread: http://thread.gmane.org/gmane.linux.kernel.wireless.general/66503

Hope this help.

LGDN

J. Cook (cookiecaper) wrote :

I'm seeing this bug on Arch Linux with 2.6.38-1 from testing, too. I think it's an obvious kernel regression. I'm about to try compiling the latest version of compat-wireless and see what I get from that.

Le Gluon Du Net (legluondunet) wrote :

Like I said in my previous mail, I have this bug with all 2.6.38 ubuntu natty kernel series, but I didn't try with another kernel (vanilla).
Do the kernel devs read this report on launchpad or do we report a bug on the kernel dev site?

LGDN

J. Cook (cookiecaper) wrote :

This is also affecting ath5k for me. Using the compat-wireless tarball from 3/18/2011 didn't fix anything; reverting to 2.6.37 has fixed the problem for me. I will try a compat-wireless from a different date soon.

J. Cook (cookiecaper) wrote :

This seems only to occur when the card is in certain modes, like wireless n or ad-hoc. I will be filing a bug report with the kernel later tonight.

Jerome Oufella (jerome-oufella) wrote :

I noticed the same problem with ath9k on an AR9280 rev.2 chipset.
I tried compat-wireless for 2.6.38 but that didn't helped much (fixed dma errors and chip lockup issues, but speeds were still bad).

Using today's compat-wireless snapshot (compat-wireless-2011-03-20) seems to restore normal traffic speeds, Hurrah.

Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in linux:
status: Confirmed → Incomplete
John (john-ettedgui) wrote :

I have the exact same behavior on Arch Linux.
With stock kernel testing my bandwith is around 60-90kb, with the compat-wireless I'm back around 6Mb, which makes a HUGE difference.
Also connecting to my network seems faster.

Thanks!

Le Gluon Du Net (legluondunet) wrote :

Ubuntu kernel 2.6.38-7 updated but bug still present:

download speed without compat-wireless driver: 60 ko/s
with compat-wireless driver: 390 ko/s

Why is this bug status is incomplete?

Michael Helmling (supermihi) wrote :

I also have a very slow network connection (1-2kB/s instead of > 1MB). I found out that I had to install the firmware for carl9170, which is supposed to be the successor of the (now deprecated) ar9170usb driver. With the carl9710 driver compiled from linuxwireless.org, everything works fine. Seems to be related to #713987.

Ohad Lutzky (lutzky) wrote :

Hello, I'm quite glad I found this bug report. Compiling compat-wireless is very easy (nice scriptwork there!), and made a major improvement: Running an scp from a different (also wireless) machine on my network used to work at 15kB/s. Now it's around 300kB/s, which makes much more sense. Also, browsing websites (especially image-heavy ones) has become much smoother; it used to be quite choppy.

Ohad Lutzky (lutzky) wrote :

This seems to happen again upon resuming from suspend (checked using scp from my other machine again), until the ath9k module is reloaded. Here's a workaround: Create a file /etc/pm/config.d/modules, chmod +x it, and have it contain the following line:
SUSPEND_MODULES="ath9k"

Michael Helmling (supermihi) wrote :

Status update: The upgrade to 2.6.38-8-generic did not resolve the issue, and also shows that just having the carl9710-firmware does NOT suffice, I had to again compile the compat-wireless modules for the new kernel.

Le Gluon Du Net (legluondunet) wrote :

ubuntu kernel updated to 2.6.38-8, bug still present for Atheros AR5008 with ath9k driver.
I compiled again linux-wireless driver and my WIFI card is working now at normal speed.
Does the Ubuntu team plan to correct with bug?
It is very annoying for people who are using a lot the WIFI network and today it is not a minority...

Ohad Lutzky (lutzky) wrote :

I've reverted to the ubuntu-included ath9k module, and it works just as well - providing that you reload it on suspend, as I've explained earlier. However, this sometimes causes suspend to take a long time, as the module is perceived as "in use" for several more seconds (~10 seconds)

Tim Gardner (timg-tpi) on 2011-04-25
Changed in linux (Ubuntu):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → In Progress
Changed in linux (Arch Linux):
status: New → Invalid
Tim Gardner (timg-tpi) on 2011-04-26
Changed in linux (Ubuntu Natty):
status: In Progress → Fix Committed
Jeremie (j-harel) wrote :

Hi,

I have the same problem with my Atheros card AR9280 on a eeepc 1000HE
the committed fix will be include in a next update ?

Gav (gkimpson) wrote :

This problem has been around for years without a fix - can this be set as an Important priority? Many users like myself have netbooks that cannot get online wirelessly because of this bug with atheros chipset.

I'm no pro with Ubuntu - does any one have their own patched Ubuntu distro with this working that I could download in the meantime?

Luca Manzari (manzariluca) wrote :

Same problem on hp pavilion dv6 with an atheros ar9285 with ubuntu 11.04, recompiling compat-wireless didn't fix anything :( hoping for the fix to be up soon! I see an encouraging

status: In Progress → Fix Committed

: )

Accepted linux into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Luca Manzari (manzariluca) wrote :

Something really strange just happened: on a natty fresh install, no upgrade - no proposed repo enabled, my ar9285 was NOT working. I inserted a rt73 usb dongle, used it for a while, disconnected, re-enabled the ar9285...now it works like a charm, but don't ask me why O_o" system has crashed a few minute later with a complete freeze, though.
Now I just rebooted and the ar9285 is working out of the box without any crash nor speed or connection troubles - for now xD

Brad Figg (brad-figg) wrote :

This commit is an early application of a commit that will be coming in via upstream stable. As such it is not subject to the standard bug verification process.

tags: added: verification-done-natty
Jan Nijtmans (jan-nijtmans) wrote :

I upgraded from linux-image-2.6.38-8.42 to linux-image-2.6.38-9.43
(through natty/proposed), and wireless appears to work fine now.

Thanks for committing the fix!

Axe Naqvi (axe-naqvi) wrote :

I upgraded as well but i have to turn wlan0 down and then up using ifconfig.. otherwise it only shows that the network is connected but there is no activity... speeds are good.. same as my Ubuntu 10.10 ...
so thanks for the fix..

ethos_dacapo (ethos-dacapo) wrote :

Still not working for me on a Acer Aspire One ZG5 and clean install. I do see the adapter and it does show networks but its never able to connect whether wpa, wep, unsecured, etc.

Changed in linux:
status: Incomplete → Fix Released
Mark Fraser (launchpad-mfraz) wrote :

Installed the new Kernel from proposed, but it still drops to 0 B/s after a while and can only get it back by turning wireless off and then on. Acer Aspire One D250.

Martin Pitt (pitti) wrote :

Marking as verification-failed, but as this is not a regression, this doesn't block -updates migration.

tags: added: verification-failed-natty
removed: verification-done-natty
Michael Helmling (supermihi) wrote :

I still have the problem with the kernels from natty-proposed: Wireless connection is extremely slow (<5kB/s) and frequently breaks completely.
Installing compat-wireless-2011-03-31 (and carl9170-1.fw) resolves the issue.

Danté (dante-ashton) wrote :

I googled the problem, and came up with this command;

sudo -s

echo "options ath9k nohwcrypt=1" > /etc/modprobe.d/ath9k.conf

taken from here;

http://ubuntuforums.org/showthread.php?t=1746326

Jan Reucker (slowhand-47) wrote :

I have the same problem. ath9k wireless on my Samsung N145 netbook is slow to unusable. Installed the 2.6.38-9.43 kernel from natty-proposed and the connection rate went up to 100-200kB/s for some minutes, now it's settled at about 50-100 kB/s. Much better than before, but less than perfect. I think I'll try the compat-wireless drivers next. I'd like to avoid turning off hardware decryption on a low-performance netbook.

michael (n3140f) wrote :

I have this problem, too. Used ubuntu and mint for years dual booting with xp or without and many many installs trying things out. Last fall bought a hp dm3 1030us with win7. Everything cool until my hard drive failed. Got new hard drive but the backup I had made was not good. Wiped the drive - now my xp won't install. No version of Ubuntu or min't can log onto a linksys WRT54G2 with WPA2 Personal (w/AES), even though I got on this same system back when I had both win7 and mint installed, just put the encryption key in and it worked with both OS's.. I am baffled.

Steve (steven-bell) wrote :

It worked fine for me too until this kernel...
Wireless now drops and becomes unusable...

Atheros AR5008
Kernel 2.6.38-8

When I restart using kernel 2.6.35, works fine...

Ian McGee (ian-imcgee) wrote :

another noobie here

I have a similar problem with a wired lan, i have seen the link on this page, is this a bigger issue than the wireless cards, is it the kernel issue as mentioned on the link below, has anyone tried it or having this problem with wired networks

https://bugs.launchpad.net/ubuntu/+bug/763974

Frank (uargh) wrote :

Running Natty on a Sony Vayo
Post #29 from Dante fixed the problem for me
add nohwcrypt=1 to module options of ath9k module

Thanks Dante :)

Steve Conklin (sconklin) wrote :

From Seth:

The patch in question is already released in 2.6.38.5, and the feedback
on testing the kernel in proposed is split (two say their wireless
worked better, two say it didn't). There's probably another issue
producing similar symptoms. So I think we ought to keep the patch.

Seth

Steve Conklin (sconklin) wrote :

Marking as verification complete and we'll keep this fix

tags: added: verification-done-natty
removed: verification-failed-natty
Ryan (ubuntu-draziw) wrote :

Asus UL30A-X5 here - Everything worked great with Ubuntu 10.04, and 10.10. Went to 11.04, and on N networks, I'll get full speed (>5MB/sec briefly, then it drops to ~1MB/sec, and sometimes stalls.

$ uname -a
Linux lap 2.6.38-8-generic #42-Ubuntu SMP Mon Apr 11 03:31:24 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.04
Release: 11.04
Codename: natty

lspci -v -s 02:00.0 |egrep -v 'Serial Number'
02:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
 Subsystem: AzureWave Device 1089
 Flags: bus master, fast devsel, latency 0, IRQ 17
 Memory at feaf0000 (64-bit, non-prefetchable) [size=64K]
 Capabilities: [40] Power Management version 3
 Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit-
 Capabilities: [60] Express Legacy Endpoint, MSI 00
 Capabilities: [100] Advanced Error Reporting
 Capabilities: [140] Virtual Channel
 Capabilities: [170] Power Budgeting <?>
 Kernel driver in use: ath9k
 Kernel modules: ath9k

Ryan (ubuntu-draziw) on 2011-05-28
Changed in linux (Ubuntu Natty):
status: Fix Committed → Confirmed
Ryan (ubuntu-draziw) wrote :

761176 has more people still affected by this. I followed the idea in that bug to try the ppa kernel - Looks like the fix is in there.. I'm back to >5 MB/sec on 802.11n links with it.

$ uname -a

apt history for the upgrade
Start-Date: 2011-05-27 20:01:03
Commandline: apt-get dist-upgrade
Install: linux-image-2.6.39-0-generic:amd64 (2.6.39-0.5~20110427), linux-headers-2.6.39-0:amd64 (2.6.39-0.5~20110427, automatic), linux-headers-2.6.39-0-generic:amd64 (2.6.39-0.5~20110427, automatic)
Upgrade: linux-generic:amd64 (2.6.38.8.22, 2.6.39.0.1~20110419), linux-headers-generic:amd64 (2.6.38.8.22, 2.6.39.0.1~20110419), linux-image-generic:amd64 (2.6.38.8.22, 2.6.39.0.1~20110419)
End-Date: 2011-05-27 20:03:30

apt-cache policy linux-image
linux-image:
  Installed: (none)
  Candidate: 2.6.39.0.1~20110419
  Version table:
     2.6.39.0.1~20110419 0
        500 http://ppa.launchpad.net/kernel-ppa/ppa/ubuntu/ natty/main amd64 Packages
     2.6.38.8.22 0
        500 http://archive.ubuntu.com/ubuntu/ natty/main amd64 Packages

Seth Forshee (sforshee) wrote :

Ryan: The natty kernel you have installed doesn't contain the fix. If you want to test the fix you need to install the kernel currently in proposed.

Changed in linux (Ubuntu Natty):
status: Confirmed → Fix Committed
Mark Fraser (launchpad-mfraz) wrote :

The only way I could get wireless to work again is to compile the driver from source as explained above. The new kernel in proposed didn't help.

I enabled proposed repository and installed the new kernel:

$ uname -a
Linux maggie 2.6.38-9-generic #43-Ubuntu SMP Thu Apr 28 15:23:06 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

The problem is not solved, although the situation has significantly improved in both speed and stability.
The issue, however, remains:
# Internet download speed is limited if compared to a wired connection. Response time is visually slower and downloads won't go faster than 600KB/s without hanging.
# the driver is not completely stable yet. Downloading big files, for instance a Ubuntu ISO using torrent, will hang the connection. In that case I have to disconnect and reconnect.
# the computer runs much hotter. A video call on Skype will make the internal temperature increase by 4-5 degrees if compared to the same call using a wire. My hardware encryption is ON.

Network controller: Atheros Communications Inc. AR928X Wireless Network Adapter (PCI-Express) (rev 01)

Dylan McCall (dylanmccall) wrote :

Kernel update in -proposed (2.6.38-10-generic2.6.38-10-generic) appears to have solved the issue for me. That's with an AR5008 chipset; same as the reporter. I haven't noticed much of a pattern in when the connection gives up, so I'm kind of guessing. I'll keep you posted if something happens.

Dylan McCall (dylanmccall) wrote :

Hmph. Actually, it died as well with 2.6.38-10. It just lasted for a surprisingly long time. (Something like 24 hours). This time around it actually disconnected and wouldn't reconnect, though. I have seen that before recently, but it's a little different from what I usually get here (and what the reporter describes) where Network Manager says there is a connection but nothing actually gets through.

It seems that running a torrent client is a sure way to trigger this collapse.

Launchpad Janitor (janitor) wrote :
Download full text (26.1 KiB)

This bug was fixed in the package linux - 2.6.38-10.46

---------------
linux (2.6.38-10.46) natty-proposed; urgency=low

  [ Steve Conklin ]

  * Release Tracking Bug
    - LP: #802464

  [ Upstream Kernel Changes ]

  * Revert "put stricter guards on queue dead checks"
  * Revert "fix oops in scsi_run_queue()"

linux (2.6.38-10.45) natty-proposed; urgency=low

  [ Upstream Kernel Changes ]

  * Revert "af_unix: Only allow recv on connected seqpacket sockets."

linux (2.6.38-10.44) natty-proposed; urgency=low

  [ Steve Conklin ]

  * Release Tracking Bug
    - LP: #792013

  [ Robert Nelson ]

  * SAUCE: omap3: beagle: detect new xM revision B
    - LP: #770679
  * SAUCE: omap3: beagle: detect new xM revision C
    - LP: #770679
  * SAUCE: omap3: beagle: if rev unknown, assume xM revision C
    - LP: #770679

  [ Stefan Bader ]

  * Include nls_iso8859-1 for virtual images
    - LP: #732046

  [ Thomas Schlichter ]

  * SAUCE: vesafb: mtrr module parameter is uint, not bool
    - LP: #778043

  [ Tim Gardner ]

  * Revert "SAUCE: acpi battery -- move first lookup asynchronous"
    - LP: #775809
  * updateconfigs after update to v2.6.38.6

  [ Upstream Kernel Changes ]

  * Revert "ALSA: hda - Fix pin-config of Gigabyte mobo"
    - LP: #780546
  * Revert "[SCSI] Retrieve the Caching mode page"
    - LP: #788691
  * Revert "USB: xhci - fix unsafe macro definitions"
  * Revert "USB: xhci - fix math in xhci_get_endpoint_interval()"
  * Revert "USB: xhci - also free streams when resetting devices"
  * ath9k_hw: fix stopping rx DMA during resets
    - LP: #775809
  * netxen: limit skb frags for non tso packet
    - LP: #775809
  * ath: add missing regdomain pair 0x5c mapping
    - LP: #775809
  * block, blk-sysfs: Fix an err return path in blk_register_queue()
    - LP: #775809
  * p54: Initialize extra_len in p54_tx_80211
    - LP: #775809
  * qlcnic: limit skb frags for non tso packet
    - LP: #775809
  * nfsd4: fix struct file leak on delegation
    - LP: #775809
  * nfsd4: Fix filp leak
    - LP: #775809
  * virtio: Decrement avail idx on buffer detach
    - LP: #775809
  * x86, gart: Set DISTLBWALKPRB bit always
    - LP: #775809
  * x86, gart: Make sure GART does not map physmem above 1TB
    - LP: #775809
  * intel-iommu: Fix use after release during device attach
    - LP: #775809
  * intel-iommu: Unlink domain from iommu
    - LP: #775809
  * intel-iommu: Fix get_domain_for_dev() error path
    - LP: #775809
  * drm/radeon/kms: pll tweaks for r7xx
    - LP: #775809
  * drm/nouveau: fix notifier memory corruption bug
    - LP: #775809
  * drm/radeon/kms: fix bad shift in atom iio table parser
    - LP: #775809
  * drm/i915/tv: Remember the detected TV type
    - LP: #775809
  * tty/n_gsm: fix bug in CRC calculation for gsm1 mode
    - LP: #775809
  * serial/imx: read cts state only after acking cts change irq
    - LP: #775809
  * ASoC: Fix output PGA enabling in wm_hubs CODECs
    - LP: #775809
  * ASoC: codecs: JZ4740: Fix OOPS
    - LP: #775809
  * ALSA: hda - Add a fix-up for Acer dmic with ALC271x codec
    - LP: #775809
  * ahci: don't enable port irq before handler is registered
    - LP: #775809
  * libata: Implement ATA_FLAG_NO_...

Changed in linux (Ubuntu Natty):
status: Fix Committed → Fix Released
Mark (1aunchpad-nct) wrote :

2.6.38-10.46 came through the Update Manager today and I can confirm it fixes the problem. On one speedtest.net run I got 45Mbps download speed though the average is around 32Mbps. Plus I can ping my router without losing packets.

So I offer big thank you to the people who fixed these bugs. But to whoever labeled these changes "urgency=low" I say, please make a better judgement next time. These bug(s) all but crippled my HTPC. I had to connect a wired network to get it to function.

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Le Gluon Du Net (legluondunet) wrote :

I updated my Ubuntu Natty today with the 2.6.38-10-generic #46-Ubuntu SMP kernel update and my Atheros AR5008 wifi card (ath9k driver) works again like a rocket!! Thank you very much for all developpers behind this patch!

Mark Fraser (launchpad-mfraz) wrote :

Upgraded to the latest kernel 2.6.38-10 and I'm still seeing my connection speed drop to nothing whilst using rsync.

Stumbled across this bug while searching for information on why I can only get a very slow and unstable connection with my 802.11n wireless card, which used to work just fine under 10.04. I now have to use a shared Internet connection through a LAN cable connected to my laptop, which is much less than ideal for me. Running a fully up-to-date install of 11.04 64-bit.

$ lspci | grep Network
01:07.0 Network controller: Atheros Communications Inc. AR5008 Wireless Network Adapter (rev 01)

$ uname -a
Linux Xyz 2.6.38-10-generic #46-Ubuntu SMP Tue Jun 28 15:07:17 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

DooMMasteR (winrootkit) wrote :

seems not really fixed yet

I am still getting pretty poor performance

Laurent Dinclaux (dreadlox) wrote :

True.

Also in 12.04 the connection randomly drops (https://bugs.launchpad.net/ubuntu/+source/linux/+bug/945379)

Changed in linux (Ubuntu):
importance: Undecided → Medium
Changed in linux (Ubuntu Natty):
importance: Undecided → Medium
florin (florin-arjocu) wrote :

Oneiric also once in a while (minutes/hours, depending on how much traffic I make) disconnects the Wifi (WPA2) connection and cannot connect back to it. Usually a restart either of the router, or of the ubuntu system makes it work again (until it disconnects again).

I use the latest official launched kernel on Oneiric (3.0.0-16-generic) and all updates up-to-date. Should I open a new bug report?
These issues with ath9k last since forever :(

sudo lspci -v -s 02:00.0 |egrep -v 'Serial Number'
02:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
 Subsystem: Lite-On Communications Inc Device 6611
 Flags: bus master, fast devsel, latency 0, IRQ 17
 Memory at d4400000 (64-bit, non-prefetchable) [size=64K]
 Capabilities: [40] Power Management version 3
 Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit-
 Capabilities: [60] Express Legacy Endpoint, MSI 00
 Capabilities: [100] Advanced Error Reporting
 Capabilities: [140] Virtual Channel
 Capabilities: [170] Power Budgeting <?>
 Kernel driver in use: ath9k
 Kernel modules: ath9k

uname -a
Linux florin-Satellite-C650 3.0.0-16-generic #29-Ubuntu SMP Tue Feb 14 12:48:51 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Laurent Dinclaux (dreadlox) wrote :

Florin, please subscribe to that bug that has been repported upstream too: https://bugs.launchpad.net/linux/+bug/945379

florin (florin-arjocu) wrote :

I also posted on kernel bugzilla (https://bugzilla.kernel.org/show_bug.cgi?id=42877), I live with the impression that when more people get involved (even with just posting their impressions) it might be a little faster to see the fix :D.

We should have a look there from time to time.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.