Ubuntu

168c:002b Wireless connection randomly drops -- ath9k

Reported by Laurent Dinclaux on 2012-03-03
168
This bug affects 30 people
Affects Status Importance Assigned to Milestone
Linux
Confirmed
High
linux (Ubuntu)
High
Unassigned

Bug Description

This an old problem that oneiric had in its early days. The wifi connection randomly drops. Sometimes it reconnect itself (after asking for the WPA key again ...), but most of time it is needed to deactivate/activate wireless networking from nm-applet or, when it doesn't do the trick, I need to turn off/on wireless networks using the hw switch.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-17-generic 3.2.0-17.27
ProcVersionSignature: Ubuntu 3.2.0-17.27-generic 3.2.6
Uname: Linux 3.2.0-17-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.94-0ubuntu1
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: VT1802 Analog [VT1802 Analog]
   Subdevices: 2/2
   Subdevice #0: subdevice #0
   Subdevice #1: subdevice #1
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: lox 2205 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xdf600000 irq 44'
   Mixer name : 'Intel CougarPoint HDMI'
   Components : 'HDA:11068446,10431053,00100000 HDA:80862805,80860101,00100000'
   Controls : 37
   Simple ctrls : 19
Date: Sat Mar 3 15:19:16 2012
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120301)
MachineType: ASUSTeK Computer Inc. U30Sd
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-17-generic root=UUID=30a646df-2e56-4842-b0ae-3c78db7c0b05 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-17-generic N/A
 linux-backports-modules-3.2.0-17-generic N/A
 linux-firmware 1.71
SourcePackage: linux
StagingDrivers: mei
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/06/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: U30Sd.211
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: U30Sd
dmi.board.vendor: ASUSTeK Computer Inc.
dmi.board.version: 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer Inc.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrU30Sd.211:bd07/06/2011:svnASUSTeKComputerInc.:pnU30Sd:pvr1.0:rvnASUSTeKComputerInc.:rnU30Sd:rvr1.0:cvnASUSTeKComputerInc.:ct10:cvr1.0:
dmi.product.name: U30Sd
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK Computer Inc.

Laurent Dinclaux (dreadlox) wrote :
Brad Figg (brad-figg) on 2012-03-03
Changed in linux (Ubuntu):
status: New → Confirmed

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-18.28
Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.3 kernel[1] (Not a kernel in the daily directory). Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed by the mainline kernel, please add the following tag 'kernel-fixed-upstream-KERNEL-VERSION'. For example, if kernel version 3.3-rc6 fixed the issue, the tag would be: 'kernel-fixed-upstream-v3.3-rc6'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[1] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.3-rc6-precise/

Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: needs-upstream-testing
Laurent Dinclaux (dreadlox) wrote :

I have updated to 3.3 RC6, due to the random nature of the bug, I'll come back here in a couple of days to set the proper tags.

Laurent Dinclaux (dreadlox) wrote :

That wasn't long, the exact same bug sadly occurred with 3.3. RC6.

tags: added: kernel-bug-exists-upstream
removed: needs-upstream-testing
Joseph Salisbury (jsalisbury) wrote :

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report at bugzilla.kernel.org [1]? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

If you are comfortable with opening a bug upstream, It would be great if you can report back the upstream bug number in this bug report. That will allow us to link this bug to the upstream report.

[1] https://wiki.ubuntu.com/Bugs/Upstream/kernel

Laurent Dinclaux (dreadlox) wrote :

Here you go: https://bugzilla.kernel.org/show_bug.cgi?id=42877

And this is the bug that got it solved when the exact same issue occurred in oneiric: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/735171

Changed in linux (Ubuntu):
status: Confirmed → Triaged
Changed in linux:
importance: Unknown → High
status: Unknown → Confirmed
florin (florin-arjocu) wrote :

Yes, it is a very old and nasty bug, I could see it during the last Ubuntu versions.

I get it once in a while (minutes/hours, depending on how much traffic I make); it disconnects the Wifi (WPA2) connection and I cannot connect back to it. Usually a restart either of the router, or of the ubuntu system makes it work again (until it disconnects again) (haven't tried disabling&enabling the adapter since Natty).

I use the latest official launched kernel on Oneiric (3.0.0-16-generic) and all updates up-to-date.

sudo lspci -v -s 02:00.0 |egrep -v 'Serial Number'
02:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
 Subsystem: Lite-On Communications Inc Device 6611
 Flags: bus master, fast devsel, latency 0, IRQ 17
 Memory at d4400000 (64-bit, non-prefetchable) [size=64K]
 Capabilities: [40] Power Management version 3
 Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit-
 Capabilities: [60] Express Legacy Endpoint, MSI 00
 Capabilities: [100] Advanced Error Reporting
 Capabilities: [140] Virtual Channel
 Capabilities: [170] Power Budgeting <?>
 Kernel driver in use: ath9k
 Kernel modules: ath9k

uname -a
Linux florin-Satellite-C650 3.0.0-16-generic #29-Ubuntu SMP Tue Feb 14 12:48:51 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Brad Figg (brad-figg) on 2012-04-11
tags: added: kernel-wifi
florin (florin-arjocu) wrote :

A noob question: does "Triaged " mean that we are getting closer to a solution?

This bug makes a system running Ubuntu totally unreliable for long automated run or for any kind of larger/faster downloads (I can never download torrents without hardware restarting my router) using wifi connection.

Laurent Dinclaux (dreadlox) wrote :

Nope, it means "abandonned" but if you look closely you'll notice that this bug is now handle directly on the linux kernel bug tracker with a "Confirmed" status and a "hight" importance.

That just means that fixing that issue is not Ubuntu devs job but linux kernel developers.

florin (florin-arjocu) wrote :

If we are to post on bugzilla more information about this bug taken when it occurs, what package should we pass to collect debugging data?

I tried this command, but it seems to be quite poor in information:
  ubuntu-bug linux --save=~/Downloads/bug-report.txt

Joseph Salisbury (jsalisbury) wrote :

The 3.4 kernel is now available. Would it be possible for you to test that kernel, to see if the bug has been fixed? The v3.4 kernel can be downloaded from:
http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4-rc2-precise/

Changed in linux (Ubuntu):
importance: Medium → High
florin (florin-arjocu) wrote :

Maybe there is someone else from here who installed Precise Pangolin.

I cannot test it as I installed Precise on a virtual machine to see how it works (BTW, it seems to be great!), it is not installed on the laptop hardware and I don't plan to install the Beta on the real machine, I will wait for the final release. I guess it's not exactly the same if I run the live version from a USB stick (can't install software there, etc.).

florin (florin-arjocu) wrote :

Ok, I run Precise Pangolin (Ubuntu 12.04) for almost one week already and I can add more data.

uname -a
Linux florin-Satellite-C650 3.2.0-24-generic #37-Ubuntu SMP Wed Apr 25 08:43:22 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

The bug is still there.

This bug haunted me as well, but I have not had this issue again since
creating
/etc/modprobe.d/ath9k.conf with the following line:

options atk9k nohwcrypt=1

While this is not a proper fix it might help file a solution and it makes
using
this laptop much more usable.

--
David Duffey, Director of Technical Partnerships
+1-512-850-6776 (work), +1-512-287-4289 (work fax)

@David Duffey (#15) - how do you feel the load on CPU with this option?

Did anyone test some other RC kernels to see if the bug is fixed?

David Duffey (david-duffey) wrote :

It's not something I've measured and would probably have to done in context that streaming lots of data probably has impact elsewhere too (disk, CPU, etc.) so would need to be done with a variety for use cases and at different loads.

For me I haven't noticed any significant power or performance difference during typical use, except my network stack doesn't crash.

florin (florin-arjocu) wrote :

I tried this and I did not see any difference.

The solution that worked for me (I only tested it in the last 24 hours with 5-6 high speed torrent downloads 3-4 MB/s) was replacing the driver (https://bbs.archlinux.org/viewtopic.php?pid=1085620#p1085620):

1º install kernel linux-headers
2º wget http://wireless.kernel.org/download/compat-wireless-2.6/compat-wireless-2.6.tar.bz2
(or manually download compat-wireless-2.6.tar.bz2 from that folder, it is the latest daily source)
3º tar jxvf compat-wireless-2.6.tar.bz2
4º cd compat-wireless<tab>
5º make
6º sudo make install
7º sudo make unload
8º Reboot and try...
If it doesn't resolve the problem do:
cd compat-wireless<tab>
sudo make uninstall and reboot

I will update this in few days to let you know if I had any problem.

PS: In a short test, the latest kernel 3.4 RC6 (http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4-rc6-precise/) did not do the job.

florin (florin-arjocu) wrote :

After a few days of testing this, I got the same inability to connect to wifi (wpa2, 802.11n). I start thinking it might not be the driver, but something else. I get the feeling that it works in the begining and after a while something happens (like something getts full) and there I have it.

Thomas Hood (jdthood) on 2012-06-26
summary: - Wireless connection randomly drops
+ Wireless connection randomly drops -- ath9k
summary: - Wireless connection randomly drops -- ath9k
+ 168c:002b Wireless connection randomly drops -- ath9k
Laurent Dinclaux (dreadlox) wrote :

The options ath9k nohwcrypt=1 doesn't work

tags: added: oneiric
TheMadGeneral (jamacarthur) wrote :

I can confirm that this is still a problem. I have run sudo apt-get update and sudo apt-get upgrade and the problem still exists. I wish I knew more about Linux to be able to investigate the problem.

florin (florin-arjocu) wrote :

I said it and I say it again: if anyone is interested in debugging this, I can help with leaving access to my computer or sending any log it is needed. Last night I had to reset my router 7-8 times to stay online.

I do not get what is the trigger for the bug (I was very low with space on / partition but I don't think it is the cause)...

TheMadGeneral (jamacarthur) wrote :

florin (florin-arjocu) wrote "I was very low with space on / partition but I don't think it is the cause)..." At the moment I am also getting this message. Is this a coincidence or is there something in the fact that when hard disk space is low the wireless signal turns itself off?

florin (florin-arjocu) wrote :

I might have found something relevant - when the bug occurs, I can ping an IP, but not an address. So there is a problem with NS related services.

My steps:
1. wait for the bug; I force the things by downloading some torrents, it usually occurs like this
2. ping the router IP, it works:
ping -c3 192.168.2.1
3. ping google.ro/google.com, it will not work (Error: Unknown host google.ro)
ping -c3 google.ro
4. ping 8.8.8.8 (I think it is Google's public DNS) - it works
ping -c3 8.8.8.8

Also, the torrent download continued for 25 minutes (until I restarted the router), so the active connection was working (I guess it uses IP to connect directly to the users) without any problem.

@TheMadGeneral (jamacarthur) - can you please also try these steps?

PS: I deleted some files today and I am not in the same situation with low disk space for /, unless I get false reports, it is not this cause.?field.comment=I might have found something relevant - when the bug occurs, I can ping an IP, but not an address. So there is a problem with NS related services.

My steps:
1. wait for the bug; I force the things by downloading some torrents, it usually occurs like this
2. ping the router IP, it works:
ping -c3 192.168.2.1
3. ping google.ro/google.com, it will not work (Error: Unknown host google.ro)
ping -c3 google.ro
4. ping 8.8.8.8 (I think it is Google's public DNS) - it works
ping -c3 8.8.8.8

Also, the torrent download continued for 25 minutes (until I restarted the router), so the active connection was working (I guess it uses IP to connect directly to the users) without any problem.

@TheMadGeneral (jamacarthur) - can you please also try these steps?

PS: I deleted some files today and I am not in the same situation with low disk space for /, unless I get false reports, it is not this cause.

TheMadGeneral (jamacarthur) wrote :

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/945379

I tried the following;

My steps before the Wi-Fi connection fails:

1. ping the router IP, it works:
      ping -c3 192.168.0.1
2. ping google.ro and google.com, it works
      ping -c3 google.ro
      ping -c3 google.com
3. ping 8.8.8.8 - it works
      ping -c3 8.8.8.8

After the Wi-Fi connection fails:

1. ping -c3 192.168.0.1
       connect: Network is unreachable
2. ping -c3 google.ro
       ping: unknown host google.ro
       ping -c3 google.com
       ping: unknown host google.com
3. ping -c3 8.8.8.8
       connect: Network is unreachable

TheMadGeneral (jamacarthur) wrote :

When I run

sudo lspci -v -s 02:00.0 |egrep -v 'Serial Number'

I get the following;

02:00.0 Ethernet controller: Atheros Communications Inc. AR242x / AR542x Wireless Network Adapter (PCI-Express) (rev 01)
 Subsystem: Askey Computer Corp. WLL3141 (Toshiba PA3613U-1MPC) 802.11bg Wireless Mini PCIe Card
 Flags: bus master, fast devsel, latency 0, IRQ 17
 Memory at ff2f0000 (64-bit, non-prefetchable) [size=64K]
 Capabilities: [40] Power Management version 2
 Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit-
 Capabilities: [60] Express Legacy Endpoint, MSI 00
 Capabilities: [90] MSI-X: Enable- Count=1 Masked-
 Capabilities: [100] Advanced Error Reporting
 Capabilities: [140] Virtual Channel
 Kernel driver in use: ath5k
 Kernel modules: ath5k

Don't know if this will help.

florin (florin-arjocu) wrote :

After some more tests, after a time, I cannot ping ip-s either.
My card:

02:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
 Subsystem: Lite-On Communications Inc Device 6611
 Flags: bus master, fast devsel, latency 0, IRQ 17
 Memory at d4400000 (64-bit, non-prefetchable) [size=64K]
 Capabilities: [40] Power Management version 3
 Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit-
 Capabilities: [60] Express Legacy Endpoint, MSI 00
 Capabilities: [100] Advanced Error Reporting
 Capabilities: [140] Virtual Channel
 Capabilities: [170] Power Budgeting <?>
 Kernel driver in use: ath9k
 Kernel modules: ath9k

Qu Bit (qbit-v) on 2012-10-17
tags: added: ath9k
Jack Johnson (knapjack) wrote :

We have a few thousand AR9285 devices in production and are just now moving from 10.04 to 12.04. So far in our testing we aren't seeing any issues, but I noticed that these are all AzureWave AW-NE785 adapters (no Lite-On adapters).

But, I have a very fresh demo unit with AR9462 / AzureWave Device 2110 that is experiencing the problem. So far the "options atk9k nohwcrypt=1" workaround has been ineffective.

I'll only have the demo unit for about another week if there's anything you'd like me to test, or if there are additional tests you'd like me to run on the AzureWave AW-NE785 to see if there really is a difference in behavior between it and the Lite-On Communications Inc Device 6611.

Timo Jyrinki (timo-jyrinki) wrote :

Jack: you can at least try out the 3.9rc3 kernel from http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.9-rc3-raring/ (you need to install both linux-image and linux-image-extra before rebooting) and report back.

That said, even though a lot of commits have been put there recently [1], there are some more commits in 'linux-next' (what will become 3.10 eventually, unless some of the commits are backported to 3.9 and earlier kernels) [2]. Most interestingly, [2] has "Update initvals for AR9462" and "Fix fixed antenna for AR9462". It's somewhat harder to test as there are no pre-build kernels, but it is possible via drivers-compat backports [3] [4] - latest 2013-03-15 package again misses a couple of commits though, including a commit that says "... Running it on those queues anyway can introduce some race conditions leading to unnecessary chip resets.".

[1] http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/log/drivers/net/wireless/ath/ath9k?id=HEAD
[2] http://git.kernel.org/cgit/linux/kernel/git/next/linux-next.git/log/drivers/net/wireless/ath/ath9k?id=HEAD
[3] https://backports.wiki.kernel.org/index.php/Documentation/compat-drivers
[4] https://www.kernel.org/pub/linux/kernel/projects/backports/2013/

(I've personal interest in AR9485 problems on my Zenbook)

description: updated
description: updated
Jack Johnson (knapjack) wrote :

Just tested linux-backports-modules-cw-3.6-3.2.0-36-generic (because it was easy) with notably better than stock results but still not great.

I thought I would also see what easy options are available via the LTS Enablement Stack.

Jack Johnson (knapjack) wrote :

So, some more weirdness.

I was able to get a copy of the shipping Ubuntu image for this demo unit, and it performs significantly better. We're going to do some additional testing and comparison, and there's still a wake from sleep issue as Guest. It's using 3.2.0-32-generic (which I believe I've already tested), but it's running a 64-bit kernel and I had only been testing 32-bit.

Module info for anyone who wants to try:

filename: /lib/modules/3.2.0-32-generic/kernel/drivers/net/wireless/ath/ath9k/ath9k.ko
license: Dual BSD/GPL
description: Support for Atheros 802.11n wireless LAN cards.
author: Atheros Communications
srcversion: 93B309EBD15DF78FA6B027B
alias: platform:ar934x_wmac
alias: platform:ar933x_wmac
alias: platform:ath9k
alias: pci:v0000168Cd00000037sv*sd*bc*sc*i*
alias: pci:v0000168Cd00000034sv*sd*bc*sc*i*
alias: pci:v0000168Cd00000033sv*sd*bc*sc*i*
alias: pci:v0000168Cd00000032sv*sd*bc*sc*i*
alias: pci:v0000168Cd00000030sv*sd*bc*sc*i*
alias: pci:v0000168Cd0000002Esv*sd*bc*sc*i*
alias: pci:v0000168Cd0000002Dsv*sd*bc*sc*i*
alias: pci:v0000168Cd0000002Csv*sd*bc*sc*i*
alias: pci:v0000168Cd0000002Bsv*sd*bc*sc*i*
alias: pci:v0000168Cd0000002Asv*sd*bc*sc*i*
alias: pci:v0000168Cd00000029sv*sd*bc*sc*i*
alias: pci:v0000168Cd00000027sv*sd*bc*sc*i*
alias: pci:v0000168Cd00000024sv*sd*bc*sc*i*
alias: pci:v0000168Cd00000023sv*sd*bc*sc*i*
depends: ath9k_hw,ath9k_common,mac80211,cfg80211,ath
intree: Y
vermagic: 3.2.0-32-generic SMP mod_unload modversions
parm: debug:Debugging mask (uint)
parm: nohwcrypt:Disable hardware encryption (int)
parm: blink:Enable LED blink on activity (int)
parm: btcoex_enable:Enable wifi-BT coexistence (int)

Jack Johnson (knapjack) wrote :

I spoke too soon.

Looking back at my previous posts, I should clarify that we're seeing two symptoms with the AR9462 / AzureWave Device 2110 and ath9k drivers from 32-bit 3.2.0-36-generic (and intermittently onwards): excessive connection drops, and excessive data retries from the wireless access point.

With AR9285 / AzureWave AW-NE785 adapters, I cannot reproduce either problem.

Testing 64-bit 3.2.0-32-generic, data retries are back within acceptable limits (on par with AR9285, or about an order of magnitude fewer retries than 32-bit 3.2.0-36-generic) but connection drops are as horrible as ever, about once every three minutes or so.

Now doing some additional testing with 64-bit versions beyond 3.2.0-32-generic.

florin (florin-arjocu) wrote :

Just a question: did any of the tests get to the point where it cannot connect to the access point until one restart the router/acces point?

I use AR9285 and I get it from time to time, sometimes multiple times a day, other times, once in a few days. Cannot predict it, cannot reproduce it by myself, but it sometimes was triggered by heavy transfers (torrents, etc.).
Stock Ubuntu 12.10 kernel, 3.5.0-25-generic, adm64

Jack Johnson (knapjack) wrote :

Hi Florin,

I haven't seen that issue yet, but I do have some more info that may be related.

Just finished initial tests on 3.2.0-39-generic and the number of retries are again through the roof (for hard numbers, on an 8 MB file transfer, 325 retries with 3.2.0-32, 2020 retries with 3.2.0-39). But, I sat down with the network team to look through the logs during the connection drops with 3.2.0-32 and we're seeing MIC errors again:

"The AP 'kn_office_100' received a WPA MIC error on protocol '0' from Station 'dc:85:de:8a:14:0e'. Counter measures have been activated and traffic has been suspended for 60 seconds. - Controller Name: kn_254_17AP"

...which leads back to a bug I'm all too familiar with:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/580753

Florin, it's possible that if you're seeing the same MIC challenge failures that your AP is taking more hostile countermeasures at some point (maybe the nth failure). Especially if you see that other devices remain connected but your AR9285 won't get reconnected until the AP reboots, I'd be tempted to point the finger at the MIC failure. But that's just supposition on my part.

florin (florin-arjocu) wrote :

Is there something I can run to help you in your quest for fixing this? It is not very nice to not be able to use the wifi connection, especially that I come from Windows where I did not find anything like this... What if I used some public router and could not restart it when I need it, what would I do then?

During time I reported this bug until I quit doing it, nothing really changed until your tests. It is I think 2 years since I found this bug (since my conversion to Ubuntu/Linux).

florin (florin-arjocu) wrote :

I forgot to tell that in my case, when this bug occurs and internet does not work any more, all new connections to the internet are not working, but those that are active, still work for a while.

Let us say that I am downloading a large file (or online watching some movie, so it downloads it on my computer), if I try to open a new website in Firefox or ping some website, it does not work, but the download continues for a while. My thought it that it cannot make new connections, but the active ones continue working (usually till the end of that download if it involves a single server/IP).

Download full text (3.8 KiB)

Fuck You!

2013/4/5 florin <email address hidden>

> I forgot to tell that in my case, when this bug occurs and internet does
> not work any more, all new connections to the internet are not working,
> but those that are active, still work for a while.
>
>
> Let us say that I am downloading a large file (or online watching some
> movie, so it downloads it on my computer), if I try to open a new website
> in Firefox or ping some website, it does not work, but the download
> continues for a while. My thought it that it cannot make new connections,
> but the active ones continue working (usually till the end of that download
> if it involves a single server/IP).
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (568657).
> https://bugs.launchpad.net/bugs/945379
>
> Title:
> 168c:002b Wireless connection randomly drops -- ath9k
>
> Status in The Linux Kernel:
> Confirmed
> Status in “linux” package in Ubuntu:
> Triaged
>
> Bug description:
> This an old problem that oneiric had in its early days. The wifi
> connection randomly drops. Sometimes it reconnect itself (after asking
> for the WPA key again ...), but most of time it is needed to
> deactivate/activate wireless networking from nm-applet or, when it
> doesn't do the trick, I need to turn off/on wireless networks using
> the hw switch.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 12.04
> Package: linux-image-3.2.0-17-generic 3.2.0-17.27
> ProcVersionSignature: Ubuntu 3.2.0-17.27-generic 3.2.6
> Uname: Linux 3.2.0-17-generic x86_64
> AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
> ApportVersion: 1.94-0ubuntu1
> Architecture: amd64
> ArecordDevices:
> **** List of CAPTURE Hardware Devices ****
> card 0: PCH [HDA Intel PCH], device 0: VT1802 Analog [VT1802 Analog]
> Subdevices: 2/2
> Subdevice #0: subdevice #0
> Subdevice #1: subdevice #1
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC0: lox 2205 F.... pulseaudio
> Card0.Amixer.info:
> Card hw:0 'PCH'/'HDA Intel PCH at 0xdf600000 irq 44'
> Mixer name : 'Intel CougarPoint HDMI'
> Components : 'HDA:11068446,10431053,00100000
> HDA:80862805,80860101,00100000'
> Controls : 37
> Simple ctrls : 19
> Date: Sat Mar 3 15:19:16 2012
> EcryptfsInUse: Yes
> InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64
> (20120301)
> MachineType: ASUSTeK Computer Inc. U30Sd
> ProcEnviron:
> TERM=xterm
> PATH=(custom, no user)
> LANG=fr_FR.UTF-8
> SHELL=/bin/bash
> ProcFB: 0 inteldrmfb
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-17-generic
> root=UUID=30a646df-2e56-4842-b0ae-3c78db7c0b05 ro quiet splash vt.handoff=7
> RelatedPackageVersions:
> linux-restricted-modules-3.2.0-17-generic N/A
> linux-backports-modules-3.2.0-17-generic N/A
> linux-firmware 1.71
> SourcePackage: linux
> StagingDrivers: mei
> UpgradeStatus: No upgrade log present (probably fresh install)
> dmi.bios.date: 07/06/2011
> dmi.bios.vendor: American Megatrends Inc.
> dmi.bios.version: U30Sd.2...

Read more...

tags: added: kernel-bug-exists-upstreamv3.3-rc6 needs-upstream-testing
removed: kernel-bug-exists-upstream kernel-request-3.2.0-18.28

Laurent Dinclaux, as per http://www.asus.com/Notebooks_Ultrabooks/U30SD/#support_Download_30 an update is available for your BIOS (213). If you update to this, does it change anything?

If not, please provide the output of the following terminal command:
sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date

Could you please confirm this issue exists with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ . If the issue remains, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the kernel in the mainline kernels archive directory daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.10-rc3

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

If you are unable to test the mainline kernel, please comment as to why specifically you were unable to test it and add the following tags:
kernel-unable-to-test-upstream
kernel-unable-to-test-upstream-VERSION-NUMBER

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

tags: added: kernel-bug-exists-upstream-v3.3-rc6
removed: ath9k kernel-bug-exists-upstreamv3.3-rc6
tags: added: bios-outdated-213
tags: added: regression-potential
Changed in linux (Ubuntu):
status: Triaged → Incomplete
Timo Jyrinki (timo-jyrinki) wrote :

A related upstream bug report (https://bugzilla.kernel.org/show_bug.cgi?id=49201) was now marked as fixed, not sure if it directly affects this one or not. I checked that the latest fixes are now in Ubuntu 13.10, kernel 3.10-rc7.

I'm _not_ sure if all the kernel configuration parameters are correct. Specifically CONFIG_ATH9K_LEGACY_RATE_CONTROL is set on Ubuntu, but I find no mention of that option in the bug reports (only the one without LEGACY, which apparently should not be set).

Timo Jyrinki (timo-jyrinki) wrote :

As noted in bug #971809 though, there are some patches still not merged which improve the situation for AR9485 tremendously, but might not be required for other Atheros chips.

friendlyfrank (frank-richards) wrote :

wifi looses connection after sometime (hours) and cannot see home connection at all although the table is populated with other services was unable to reconnect untill I rebooted.
using emachine netbook upgraded to ubuntu13, was ok on previous releases. system is ok if placed on hibernate just fails if left unattended for long periods.

friendlyfrank, if you have a bug in Ubuntu, the Ubuntu Kernel team, Ubuntu Bug Control team, and Ubuntu Bug Squad would like you to please file a new report by executing the following in a terminal:
ubuntu-bug linux

For more on this, please see the Ubuntu Kernel team article:
https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports

the Ubuntu Bug Control team and Ubuntu Bug Squad team article:
https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue

and Ubuntu Community article:
https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Please note, not filing a new report would delay your problem being addressed as quickly as possible.

Thank you for your understanding.

friendlyfrank (frank-richards) wrote :

updated the bios but no change, still fails looses ip adress shows no inet adress . powering off the wifi and on again has no effect but deselecting wifi and reconecting restores the connection.

Sujith Manoharan (msujith) wrote :

Hi Florin/Jack Johnson,

Are you still seeing stability issues with ath9k ?

florin (florin-arjocu) wrote :

@Christopher M. Penalver (penalvch) - actually, from the user's perspective, I only want it to work. There are dozen of reports for this bug and nothing happened for years. No offence, but as long as it will work, I would take any help.

For now I am a little blocked with testing as I use an older router and it does not have 802.11 N connection.

Sujith Manoharan (msujith) wrote :

@penalvch: Ok, understood.
Florian, if you still encounter this issue, please open a bug in bugzilla.kernel.org and CC me (<email address hidden>). Thanks.

Sujith Manoharan (msujith) wrote :

Well, I currently maintain ath9k and am interested in resolving this issue. Analyzing this issue will mostly involve using backports [1], which is distribution-agnostic.

[1] : https://backports.wiki.kernel.org/index.php/Main_Page

psil0cybin (psil0cybin) wrote :

Please can we find a fix for this issue, it was working perfectly fine for me a week or two ago!! now i cannot download anything.
Please!! i cannot afford a new card, is there anything i can do to attempt to be proactive? My wifi conncetion disconnects after a breif idle period, and only gets internet again after i disconnect and reconnect causing all downloads to malfunction and halt.

florin (florin-arjocu) wrote :

I have tested the backported driver and for about one week of using the 802.11N connection, it seems to have been working better. It disconnected once or twice, but I could connect, which I could not do before this driver. I cannot bet it is a perfect test, as I could only use N connection for more than one week, but before this driver, it was very common (maybe more than once daily) that I had to restart the router, as it only worked when resetting the router.

psil0cybin, if you have a bug in Ubuntu, the Ubuntu Kernel team, Ubuntu Bug Control team, and Ubuntu Bug Squad would like you to please file a new report by executing the following in a terminal while booted into a Ubuntu repository kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Please note, not filing a new report would delay your problem being addressed as quickly as possible.

No need exists to comment here at this time. After reading the above documentation in it's entirety, if you have further questions, you are welcome to redirect them to the appropriate mailing list or forum via http://www.ubuntu.com/support/community/mailinglists , or you may contact me directly.

Thank you for your understanding.

florin (florin-arjocu) wrote :

Is is possible this to be related to a bug I got in Ubuntu 13.10 with "wpa_supplicant"?

If not, I have no idea hot to report it, as I do not know which package to report for. I get multiple crashed on startup and not only startup, but it does not seem to report the but, although I press Report. On this startup I got 4 crashes, I spread the windows to be visible.

florin, please see the following on reporting crashes https://help.ubuntu.com/community/ReportingBugs#Reporting_an_application_crash .

As well, it would be most helpful if you filed a new report via a terminal so that your hardware may be reviewed:
ubuntu-bug linux

Bruce Rout (bbrout) wrote :

I found a fix. It deals with the drivers for various wireless hardware. I found this site very useful:
Go to the #2 answer on this thread:
http://askubuntu.com/questions/377454/wifi-dropping-every-20-mins
I went to this link:
https://help.ubuntu.com/community/WifiDocs/WirelessCardsSupported
Then to here to find I have a RealTek
https://help.ubuntu.com/community/WifiDocs/WirelessCardsSupported
then to here:
https://help.ubuntu.com/community/HardwareSupportComponentsWirelessNetworkCardsRealTek#PCI
Then here:
http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=1&PFid=1&Level=6&Conn=5&DownTypeID=3&GetDown=false&Downloads=true
got the new driver and instructions here:
http://www.realtek.com.tw/downloads/RedirectFTPSite.aspx?SiteID=2&DownTypeID=3&DownID=1030&PFid=1&Conn=5&FTPPath=ftp%3a%2f%2f58.211.24.153%2fcn%2fwlan%2frtl8187L_linux_1041%5b1%5d.0209.2012.tar.gz

I downloaded the OEM driver, installed an rebooted. It dropped once and after re-rebooting, it seems to work fine. It appears the problem is that the computer supplied driver for wifi and the OEM driver differ and that may possibly be the problem. This is a difficult bug to find and fix. I really hope that helps.

Bruce Rout, as this report is about an Atheros card, not a Realtek, this report has nothing to do with you. However, if you are having a problem in Ubuntu, and so your hardware and problem may be tracked, please file a new report with Ubuntu by executing the following in a terminal while booted into a Ubuntu repository kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.