Suspend fails due to tpm_tis: error -62 with kernel 2.6.38-4 (2.6.38-3 works)

Bug #722310 reported by Jean-Baptiste Lallement on 2011-02-20
34
This bug affects 8 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Canonical Kernel Team
Natty
High
Canonical Kernel Team

Bug Description

Suspend to RAM fails with 2.6.38-4 but worked with 2.6.38-3

The trace of the failure from dmesg is:
[ 136.224054] tpm_tis 00:0b: Operation Timed out
[ 136.224061] legacy_suspend(): pnp_bus_suspend+0x0/0x90 returns -62
[ 136.224064] PM: Device 00:0b failed to suspend: error -62
[ 136.244039] PM: suspend of drv:usb dev:2-3.4.1 complete after 111.792 msecs
[ 136.343654] sd 2:0:0:0: [sda] Stopping disk
[ 136.836606] PM: suspend of drv:sd dev:2:0:0:0 complete after 704.049 msecs
[ 136.836641] PM: Some devices failed to suspend

tpm_tis is to blame here.

It's very likely another instance of bug 602049 and bug 705845 but I'm filing a new report because it is a regression from the previous kernel version.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: linux-image-2.6.38-4-generic 2.6.38-4.31
Regression: Yes
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.38-4.31-generic 2.6.38-rc5
Uname: Linux 2.6.38-4-generic i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: j-lallement 2214 F.... pulseaudio
 /dev/snd/pcmC0D0p: j-lallement 2214 F...m pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xfeaf8000 irq 50'
   Mixer name : 'Realtek ALC660-VD'
   Components : 'HDA:10ec0660,10431613,00100001 HDA:10573055,10431316,00100700'
   Controls : 23
   Simple ctrls : 14
Date: Sun Feb 20 21:25:16 2011
EcryptfsInUse: Yes
HibernationDevice: RESUME=UUID=dab2fada-829b-4dab-a6c0-f2b27cd3d668
MachineType: ASUSTeK Computer Inc. U3SG
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.utf8
 LC_MESSAGES=en_US.utf8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-4-generic root=UUID=75f23f17-3ace-4485-af57-a7318eb6c2ff ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-2.6.38-4-generic N/A
 linux-backports-modules-2.6.38-4-generic N/A
 linux-firmware 1.47
SourcePackage: linux
WpaSupplicantLog:

dmi.bios.date: 01/28/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 305
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: U3SG
dmi.board.vendor: ASUSTeK Computer Inc.
dmi.board.version: 1.0
dmi.chassis.asset.tag: ATN12345678901234567
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer Inc.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr305:bd01/28/2008:svnASUSTeKComputerInc.:pnU3SG:pvr1.0:rvnASUSTeKComputerInc.:rnU3SG:rvr1.0:cvnASUSTeKComputerInc.:ct10:cvr1.0:
dmi.product.name: U3SG
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK Computer Inc.

Jean-Baptiste Lallement (jibel) wrote :
Changed in linux (Ubuntu Natty):
importance: Undecided → High
assignee: nobody → Canonical Kernel Team (canonical-kernel-team)
description: updated
Herton R. Krzesinski (herton) wrote :

This is probably same issue already discussed at bug 719620

Reverting commit 9b29050 ("tpm_tis: Use timeouts returned from TPM") should avoid it. Please test the kernel at http://people.canonical.com/~herton/lp722310/ to check if it's the case.

If it is the same problem, may be this could be a duplicate of 719620, though there we have two problems.

Changed in linux (Ubuntu Natty):
status: New → Incomplete
Jean-Baptiste Lallement (jibel) wrote :

With kernel 2.6.38-5-generic #32~1lp719620, suspend and resume works as expected. You can mark it as dup of 719620 if you think that it is the same cause, but note that in my case the last working version was 2.6.38-3 and in 719630 it was 2.6.38-2.

Changed in linux (Ubuntu Natty):
status: Incomplete → Triaged
Herton R. Krzesinski (herton) wrote :

Ok, so it's same problem, reverting the commit works. The most recent update on upstream thread about this problem asks for input about the regression: https://lkml.org/lkml/2011/2/18/230

So may be soon we will have a fix for it.

The explanation for 2.6.38-2 being last version working on 719620 is that after it the video broke on resume on that case, and also tpm_tis broke later. I think it's ok keeping both reports opened.

Herton R. Krzesinski (herton) wrote :

Ok, Linus reverted this commit on his tree yesterday (see commit e587137), so this will be solved on next rebase and upload.

Changed in linux (Ubuntu Natty):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.38-5.32

---------------
linux (2.6.38-5.32) natty; urgency=low

  [ Andy Whitcroft ]

  * rebase to mainline 6f576d57f1fa0d6026b495d8746d56d949989161
  * [Config] updateconfigs following rebase to v2.6.38-rc6
  * [Config] enable CONFIG_DMAR
    - LP: #552311

  [ Upstream Kernel Changes ]

  * drm/i915: skip FDI & PCH enabling for DP_A
    - LP: #561802, #600453, #681877

  [ Major Kernel Changes ]

  * rebase from v2.6.38-rc5 to v2.6.38-rc6
    - LP: #718402
    - LP: #719524
    - LP: #721126
    - LP: #719691
    - LP: #722689
    - LP: #722310
 -- Andy Whitcroft <email address hidden> Tue, 22 Feb 2011 13:28:39 +0000

Changed in linux (Ubuntu Natty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers