computer freezes on suspend/hibernate

Bug #660405 reported by David Riley on 2010-10-14
122
This bug affects 29 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xorg

I saw a similar bug reported relating to xorg, so I'm assuming this is where mine is coming from but I'm not sure. On hibernating my computer I get this error:

[38011.273623] [drm: init_ring_common] *ERROR* render ring head not reset to zero ctl 00000000 head 02001000 tail 00000000 start 02001000
[38011.273623] [drm: init_ring_common] *ERROR* render ring head forced to zero ctl 00000000 head 02001000 tail 00000000 start 02001000

Reproducible on every hibernate, computer usually locks afterwards, sometimes successfully hibernates. On Suspend it is hit or miss whether it will happen or not, but usually has the same results as hibernate.

Computer always hibernated fine in 10.04, this didn't start happening until I did a clean install of 10.10.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: xorg 1:7.5+6ubuntu3
ProcVersionSignature: Ubuntu 2.6.35-22.34-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic x86_64
Architecture: amd64
DRM.card0.DisplayPort.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.DisplayPort.2:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.HDMI_Type_A.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1366x768
 edid-base64: AP///////wAlzAcAAAAAAAATAQOAIhN4CsiFnldUmyYSUFQAAAABAQEBAQEBAQEBAQEBAQEBEhtWZlAAEzAZETMAWMIQAAAZAAAAAAAAAAAAAAAAAAAAAAAAAAAA/gBJTkxEaXNwbGF5CiAgAAAA/ABCVDE1NkdXMDEAVi4zAKI=
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
Date: Thu Oct 14 04:27:11 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
MachineType: Hewlett-Packard HP G62 Notebook PC
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-22-generic root=UUID=bd620bb2-b643-4449-b8d8-68d8d84f2570 ro quiet splash
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: xorg
Symptom: display
Title: Xorg freeze
dmi.bios.date: 03/23/2010
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.11
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 1484
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 77.15
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.11:bd03/23/2010:svnHewlett-Packard:pnHPG62NotebookPC:pvr0499110003202710000020000:rvnHewlett-Packard:rn1484:rvr77.15:cvnHewlett-Packard:ct10:cvrN/A:
dmi.product.name: HP G62 Notebook PC
dmi.product.version: 0499110003202710000020000
dmi.sys.vendor: Hewlett-Packard
glxinfo: Error: [Errno 2] No such file or directory
system:
 distro: Ubuntu
 codename: maverick
 architecture: x86_64
 kernel: 2.6.35-22-generic

David Riley (dmfnr1) wrote :
David Riley (dmfnr1) wrote :

You can see the actual error in the CurrentDmesg.txt file, my last suspend is documented in there. None of the information in there is useful to me, hopefully it is to you :)

geoff (geoff-wong) wrote :

Same problem on my Intel based HP-dm3 (using a 32 bit desktop dist-upgrade from 10.04). Previously worked perfectly in 10.04. Completely broken now in 10.10.

Andrew Turner (tekn0t) wrote :

Same for my Intel based Inspiron 15 laptop (64bit). Worked prior to 10.10, also worked in 10.10 Beta.

Michał J. Gajda (mgajda) wrote :

Same problem on Lenovo X301.

dirkhartzer (dirkhartzer) wrote :

The kernel update on Friday fixed this issue for me.

David Riley (dmfnr1) wrote :

Excellent! My suspicions after doing some reading was a regression in the kernel due to some other bug reports I've read related to the kernel and other distros.

Hopefully some of the other people who have been having this problem reports back, and the Ubuntu devs can get off easy on this one.

Andrew Turner (tekn0t) wrote :

I have successfully come back from 3 or 4 suspends this morning, so looking hopeful.

geoff (geoff-wong) wrote :

Suspend is working for me now. Hibernate is still broken.

Andrew Turner (tekn0t) wrote :

I don't usually use hibernate, but I just tried it three times without issue. (Dell Inspiron 15, 64 bit, Intel chipset)

Jon Leighton (jonleighton) wrote :

I have had this problem also on my girlfriend's laptop. The latest kernel (as of today) didn't help. Have worked around for now by configuring grub to boot an older kernel.

Andrew Turner (tekn0t) wrote :

Looks like I spoke too soon - just experienced a freeze after suspending.

Bryce Harrington (bryce) on 2010-11-04
affects: xorg (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
Mateo Matachana (mat30-mail) wrote :

I have the same problem on a Toshiba Satellite U400 with an Intel chipset. After suspending, the systems looks like freezed.

It isn't freezed. The system is perfectly working and you can type your password and your session will be resumed as usual (but anything will be shown). The network is up and working and you have full SSH access. I could log in in my system through SSH in one of those freezes and I saw the problem is the resolution of the screen: too low.

xrandr -display :0 returns on my laptop

Screen 0: minimum 320 x 200, current 320 x 200, maximum 8192 x 8192
VGA1 disconnected (normal left inverted right x axis y axis)
LVDS1 connected 1280x800+0+0 (normal left inverted right x axis y axis) 286mm x 179mm
   1280x800 59.9*+
   1024x768 60.0
   800x600 60.3 56.2
   640x480 59.9
HDMI1 connected 1920x1080+1280+0 (normal left inverted right x axis y axis) 510mm x 290mm
   1920x1080 59.9*+ 60.0 60.0
   1680x1050 60.0
   1280x1024 75.0 60.0
   1152x864 75.0
   1280x720 60.0
   1024x768 75.1 60.0
   832x624 74.6
   800x600 75.0 60.3 56.2
   720x480 59.9
   640x480 75.0 60.0
   720x400 70.1
DP1 disconnected (normal left inverted right x axis y axis)
DP2 disconnected (normal left inverted right x axis y axis)
TV1 disconnected (normal left inverted right x axis y axis)

The wake-up resolution (320x200) isn't supported by any of my screens and because of that the image isn't shown. Executing

xrandr -display :0 --output HDMI1 --off
xrandr -display :0 --screen 0 --size 640x480

allows me to set a proper screen resolution and continue working with the session as if anything would happened.

Quinn Ebert (quinnebert) wrote :

Seeing this as well on my HP CQ60 (GMA 9 Graphics). Specifically, it's suspend that's hampered on this machine; haven't seen any issues with hibernate (other than initially the swap being too small to allow hibernate -- which was rather-easily fixed). ;)

geoff (geoff-wong) wrote :
Mateo Matachana (mat30-mail) wrote :

@geoff I think is a similar problem, but different. My laptop never freezes, is reachable through SSH and the Sysrq + REISUB combination reboots the system as expected.

Quinn Ebert (quinnebert) wrote :

Regarding https://bugzilla.kernel.org/show_bug.cgi?id=16396

I will personally be trying 2.6.36/later, and will report back any changes in my situation here.

Cheers!

geoff (geoff-wong) wrote :

I've switched back to the 2.6.32-25 kernel which seems to have no such suspend/hibernate problems for me (although a friend using an eeepc901 reports similar problems).

bugbot (bugbot) on 2010-11-23
tags: added: resume
MNLipp (mnl) wrote :

I can confirm this for a HP 6730b with 2.6.35-23-generic-pae. Sometimes the system freezes, sometimes it takes a long time to suspend or resume.

MartinSt (martinstingl) wrote :

The problem that the system sometimes hangs when trying to hibernate/suspend and waking up afterwards does also exist on my HP 6930p.

Tybion (db-collins) wrote :

I also get the "render ring head not reset to zero" when booting up.
Using a failover mode to get the system working, but the GUI is unstable.
lspci
00:00.0 Host bridge: Intel Corporation 82945G/GZ/P/PL Memory Controller Hub (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02)
  : :
Ubuntu 10.10
david@thich:~$ uname -a
Linux thich 2.6.35-23-generic #41-Ubuntu SMP Wed Nov 24 10:18:49 UTC 2010 i686 GNU/Linux

MNLipp (mnl) wrote :

I'm running the "proposed" kernel 2.6.35-24-generic-pae for about 2 week now. It seems to fix the hibernate/suspend problem. I still had one or two failures, but things have improved significantly.

Tybion (db-collins) wrote :

I have installed the 'proposed' kernel 2.6.35.-24, but for me, this does not fix the problem. I still get the same error at boot up.

Vladislav Rovda (filincrew) wrote :

Have the same problem on my HP ProBook 4510s which is based on Intel hardware
It is disgusting to hard reboot laptop several times per day because it doesn't respond on any manipulations.
I have only [drm:init_ring_common] *ERROR* render ring head not reset to zero ctl ...

Can anybody provide some help?

Same problem here with 2.6.35-24-generic on Extensa 5235 (Intel GMA 4500M).

monochromec (monochromec) wrote :

Can confirm that 2.6.35-24 generic on a Dell Vostro 1320 doesn't fix the problem (Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller).

MNLipp (mnl) wrote :

I withdraw that 2.6.35-24-generic-pa fixes the problem on my HP 6730b. My observation by now is that hibernate/suspend works well, sometimes for more than a week, then it fails several times in a row and then it works again for some time. And it seems to work better if I select stand by from the menu instead of closing the lid.

@ MNLipp:

Did you mean 2.6.35-24-generic-pae?
If not, how to get and install 2.6.35-24-generic-pa, which sources, packages?

Thank you!

MNLipp (mnl) wrote :

@free-ubuntu:

I meant 2.6.35-24-generic-pae, of course. I copied/pasted the string from `uname -a` and missed the last letter. Sorry for causing confusion.

Tybion (db-collins) wrote :

If anyone is after a get-around while waiting for a fix, this works for me ...

In /etc/X11/, copy xorg.conf.failsafe to xorg.conf
I understand that this causes Ubuntu to use a old lower-functionality 'vesa' driver.

Some of the xorg.conf file ..
Section "Device"
 Identifier "Configured Video Device"
 Driver "vesa"
EndSection
  : :

(This may not be necessary ? ..)
I also modified a line in /etc/default/grub, adding the 'nomodeset' option ..
GRUB_CMDLINE_LINUX_DEFAULT="quiet nosplash nomodeset"
and ran
sudo update-grub

My system is stable using this driver, but I can't use Google Earth because this driver gives too low performance.

Vladislav Rovda (filincrew) wrote :

Thanks all. But I have updated to 2.6.37-11 kernel from https://launchpad.net/~abogani/+archive/ppa.

MNLipp (mnl) wrote :

@Vladislav Rovda:

Did the update to 2.6.37-11 help? Reliably?

Mobile (todd-seits) wrote :

Same for me on an Acer laptop, but happens from Hibernate, allows me to get back in and work, just have spam on the screen

Bryce Harrington (bryce) wrote :

Hi,

Thanks for reporting this X gpu lockup bug in Ubuntu maverick.

In my opinion GPU lockups are one of the most frustrating kinds of bugs, both as a user and a developer. I want take a few moments of your time to explain the situation with these types of bugs.

For some reason, -intel has been plagued with these freeze bugs for a long time. In the past -intel has had options to switch to legacy memory or rendering technologies as workarounds, but Intel tends to drop obsolete code pretty aggressively and unfortunately in maverick these workarounds are not available.

As a policy, Intel engineers look only at bugs that are seen in the most recent release of their drivers. With older versions of their drivers, such as the version in maverick, we're on our own.

On the plus side, they provide good tools for gathering debug data about the bugs, such as the intel_gpu_dump too. Unfortunately, the version of Apport in maverick doesn't capture the dmesg or X logs correctly (it collects the files at the time of freeze, but then overwrites them with clean, unhelpful versions when it goes to file the report for you.)

The version of these diagnostic tools in natty has been fixed up, and is allowing us to analyze GPU lockups a lot easier. This has helped us solve several of the bugs, and given us a handle on some of the more challenging ones.

Backporting these fixes may not be feasible though; by their nature the fixes for these type of bugs tend to be very low level, esoteric, and risky of causing something else to regress. Because the freezes are often hard to reproduce, it's not always possible to verify fixes anyway. It may be that our best bet is to focus on natty.

But for now, since these freezes typically require kernel patches to solve, I'm moving your bug report to the kernel package. They may be able to point you to a newer kernel likely to help with this issue.

affects: xserver-xorg-video-intel (Ubuntu) → linux (Ubuntu)
MNLipp (mnl) wrote :

Natty is still two and a half months away. But I can confirm that using the 2.6.37 kernel does help. I compiled the sources from kernel.org with the maverick configuration http://kernel.ubuntu.com/~kernel-ppa/configs/maverick/i386-generic-pae (following the instructions from https://help.ubuntu.com/6.10/ubuntu/installation-guide/i386/kernel-baking.html). The result has failed only twice in the last three weeks (with about 3 stand-by cycles a day).

Jeremy Foshee (jeremyfoshee) wrote :

Hi David,

If you could also please test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kernel-suspend
tags: added: kernel-hibernate
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Tybion (db-collins) wrote :

FYI ..

I tested my PC on a fully-patched Natty Ubuntu install about 3 days ago - kernel 2.6.38 ? - and the machine seems to run OK with the Intel driver.

Youtube videos run smoothly - whereas on Maverick on my eeePC (with Intel card) Youtube videos are jerky

BUT, when I run Google Earth and say 'Yes' to use DirectX rather than 'OpenGL Mode', Google Earth is so slow as to be unusable (ie. much the same as if you use 'OpenGL Mode')

lspci
00:00.0 Host bridge: Intel Corporation 82945G/GZ/P/PL Memory Controller Hub (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02)

broe (erich-rupp) wrote :

i tried 2.6.38-999-generic #201103060905 SMP Sun Mar 6 10:21:37 UTC 2011 i686 GNU/Linux and it didn't work out for me.

the errors with "render ring" disappeared and there was another error like "swap size 0", don't remeber exactly. despite this message it worked several times of hibernation and standby but as i just wanted to come back from hibernate i got the following behavior:

- the X-screen (alt-f7) stayed black, moving the mouse made the mouse pointer blink and jump around
- switching to alt-f1, f2, ... was possible
- pressing enter there gave another prompt for the long-name
- entering anything in the login-name frooze that login-process without asking for the password, login wasn't possible.

hibernate and standby worked nearly perfectly with 10.04

using:
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)

will try 2.6.37 now

broe (erich-rupp) wrote :

after 2.6.38-999-generic didn't work for me i installed 2.6.37.2 as described in #35 and i didn't have a single failure in about 20 switches to standby and hibernation.

David Riley (dmfnr1) wrote :

Can anyone running more recent Ubuntu versions who had this problem report on the status of this issue in the new releases? Just curious, it's been about a year, and I'm itching to get my laptop upgraded, but I can't really mess around much with my laptop due to it being used for work, and it's the only box I've had this problem with. Thanks in advance to anyone who has a chance to get back to me.

MNLipp (mnl) wrote :

Having no problems with HP6730b/Oneiric. Distro version even provided the fastest suspend/resume I've ever seen (almost instant resume). After the latest updates, it takes 10-20 seconds again, but it works reliably.

Quinn Ebert (quinnebert) wrote :

David,

I'd also like to confirm that running the latest Ubuntu 11 release on my HP/Compaq CQ60-420US has no more lingering issues. Probably worth an upgrade at this point if it won't break any of your applications.

Cheers!
--David Quinn Ebert

David Riley (dmfnr1) wrote :

Running 11.10 myself now and everything is working fine. Really nice having an up to date system, although I will say 10.04 is rock solid stable at this point, it's just a bit out of date with some of the new compiler features, and it's really nice not having a hacked together system with everything in /usr/local having to waste time recompiling everything when new updates come out.

Thanks a lot Ubuntu devs for the quality work.

buchs (buchsk) wrote :

I have been on 11.10 since it was released and for me the problem persists. It has morphed into a freeze of the screen - no input does anything.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.