Comment 12 for bug 565543

With xorg-edger's lastest packages of Xorg things get worse, as even 3rd button emulation is lost.

$ cat /var/log/Xorg.0.log | grep -i mouse
[ 26.144] (==) intel(0): Silken mouse enabled
[ 27.028] (II) config/udev: Adding input device ImPS/2 Generic Wheel Mouse (/dev/input/event6)
[ 27.028] (**) ImPS/2 Generic Wheel Mouse: Applying InputClass "evdev pointer catchall"
[ 27.029] (**) ImPS/2 Generic Wheel Mouse: always reports core events
[ 27.029] (**) ImPS/2 Generic Wheel Mouse: Device: "/dev/input/event6"
[ 27.044] (--) ImPS/2 Generic Wheel Mouse: Found 3 mouse buttons
[ 27.044] (--) ImPS/2 Generic Wheel Mouse: Found scroll wheel(s)
[ 27.044] (--) ImPS/2 Generic Wheel Mouse: Found relative axes
[ 27.044] (--) ImPS/2 Generic Wheel Mouse: Found x and y relative axes
[ 27.044] (II) ImPS/2 Generic Wheel Mouse: Configuring as mouse
[ 27.044] (**) ImPS/2 Generic Wheel Mouse: YAxisMapping: buttons 4 and 5
[ 27.044] (**) ImPS/2 Generic Wheel Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[ 27.044] (II) XINPUT: Adding extended input device "ImPS/2 Generic Wheel Mouse" (type: MOUSE)
[ 27.044] (**) ImPS/2 Generic Wheel Mouse: (accel) keeping acceleration scheme 1
[ 27.044] (**) ImPS/2 Generic Wheel Mouse: (accel) acceleration profile 0
[ 27.044] (**) ImPS/2 Generic Wheel Mouse: (accel) acceleration factor: 2.000
[ 27.044] (**) ImPS/2 Generic Wheel Mouse: (accel) acceleration threshold: 4
[ 27.044] (II) ImPS/2 Generic Wheel Mouse: initialized for relative axes.
[ 27.044] (II) config/udev: Adding input device ImPS/2 Generic Wheel Mouse (/dev/input/mouse1)
[ 27.048] (II) config/udev: Adding input device Sony Vaio Jogdial (/dev/input/mouse0)

It detected a Jogdial even my laptop does have one!, ALPS seems to be gone :'(