ALPS device (E7: 73 02 64) needs new model entry in alps.c

Bug #545307 reported by Mary on 2010-03-23
54
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Linux
Invalid
Medium
Fedora
Unknown
Unknown
Gentoo Linux
Fix Released
Medium
linux (Ubuntu)
Wishlist
Chase Douglas

Bug Description

When going to System, preference, mouse in Ubuntu 9.10 the touchpad does not show up and can't be configured to eliminate the tap-to-click feature. I am told that this is a problem in the kernel.

ProblemType: Bug
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: SB [HDA ATI SB], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 2/2
   Subdevice #0: subdevice #0
   Subdevice #1: subdevice #1
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: mary 1474 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'SB'/'HDA ATI SB at 0xf2300000 irq 16'
   Mixer name : 'IDT 92HD81B1C5'
   Components : 'HDA:111d76d5,103c3656,00100402'
   Controls : 26
   Simple ctrls : 16
Card1.Amixer.info:
 Card hw:1 'HDMI'/'HDA ATI HDMI at 0xf2210000 irq 19'
   Mixer name : 'ATI RS690/780 HDMI'
   Components : 'HDA:1002791a,00791a00,00100000'
   Controls : 4
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined
   Playback channels: Mono
   Mono: Playback [off]
Date: Tue Mar 23 14:20:08 2010
DistroRelease: Ubuntu 9.10
HibernationDevice: RESUME=UUID=b0827668-53f3-48e2-ac2a-b2733626cf41
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
MachineType: Hewlett-Packard HP Pavilion dm3 Notebook PC
Package: linux-image-2.6.31-20-generic 2.6.31-20.58
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-20-generic root=UUID=f1e2e19e-a0f8-407d-9533-c5ba95a8be50 ro quiet splash
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-20.58-generic
RelatedPackageVersions:
 linux-backports-modules-2.6.31-20-generic N/A
 linux-firmware 1.26
SourcePackage: linux
Uname: Linux 2.6.31-20-generic i686
dmi.bios.date: 12/04/2009
dmi.bios.vendor: Insyde Corp.
dmi.bios.version: F.22
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 3656
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 44.1D
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnInsydeCorp.:bvrF.22:bd12/04/2009:svnHewlett-Packard:pnHPPaviliondm3NotebookPC:pvr0486110000241F00110320000:rvnHewlett-Packard:rn3656:rvr44.1D:cvnHewlett-Packard:ct10:cvrN/A:
dmi.product.name: HP Pavilion dm3 Notebook PC
dmi.product.version: 0486110000241F00110320000
dmi.sys.vendor: Hewlett-Packard

Mary (mtaussig44) wrote :
tags: added: karmic lucid
Changed in linux (Ubuntu):
status: New → Triaged
importance: Undecided → Wishlist
Filex (filip-brinkmann) wrote :

I have the same issue on a Toshiba Satellite U500-115. Dmesg attached.

Filex (filip-brinkmann) wrote :

Chase, I hope you can have a look at this issue as you did with bug 505474. The Toshiba U500 series is quite popular and the bug renders the touchpad nearly unusable. The problem is that without having it recognized as a touchpad, one cannot set the turn-off feature when typing (e.g. via gsynaptics).

Additional information: in random periods (several times per day - once per week), the mousepointer wanders around randomly. Only a
modprobe -r psmouse ; modprobe psmouse

solves the problem in most cases.

Chase Douglas (chasedouglas) wrote :

I've uploaded a kernel for folks to test. Hopefully it will enable proper synaptics support for these alps devices, but there are a few options. If any of them fail to work, we'll have to try a different option. The kernel can be found at: http://people.canonical.com/~cndougla/545307/lp545307_1/

Thanks

Download full text (4.4 KiB)

On the first and the last one I got a warning saying there is an error in
the architecture amd64. should I install them anyway?

 The first error message read:
Linux kernel headers for version 2.6.31 on x86/x86_64
This package provides kernel header files for version 2.6.31 on x86/x86_64.
This is for sites that want the latest kernel headers.
Please read /usr/share/doc/linux-headers-2.6.31-21/debian.README.gz for
details.

the error message for the third one read:
Linux kernel image for version 2.6.31 on x86/x86_64
This package contains the Linux kernel image for version 2.6.31 on
x86/x86_64.
Also includes the corresponding System.map file, the modules built by the
packager, and scripts that try to ensure that the system is not left in an
unbootable state after an update.
Supports Generic processors.
Geared toward desktop systems.
You likely do not want to install this package directly. Instead, install
the linux-generic meta-package, which will ensure that upgrades work
correctly, and that supporting packages are also installed.

On Wed, Mar 24, 2010 at 3:52 PM, Chase Douglas
<email address hidden>wrote:

> I've uploaded a kernel for folks to test. Hopefully it will enable
> proper synaptics support for these alps devices, but there are a few
> options. If any of them fail to work, we'll have to try a different
> option. The kernel can be found at:
> http://people.canonical.com/~cndougla/545307/lp545307_1/<http://people.canonical.com/%7Ecndougla/545307/lp545307_1/>
>
> Thanks
>
> --
> ALPS device (E7: 73 02 64) needs new model entry in alps.c
> https://bugs.launchpad.net/bugs/545307
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “linux” package in Ubuntu: Triaged
>
> Bug description:
> When going to System, preference, mouse in Ubuntu 9.10 the touchpad does
> not show up and can't be configured to eliminate the tap-to-click feature. I
> am told that this is a problem in the kernel.
>
> ProblemType: Bug
> Architecture: i386
> ArecordDevices:
> **** List of CAPTURE Hardware Devices ****
> card 0: SB [HDA ATI SB], device 0: STAC92xx Analog [STAC92xx Analog]
> Subdevices: 2/2
> Subdevice #0: subdevice #0
> Subdevice #1: subdevice #1
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC0: mary 1474 F.... pulseaudio
> CRDA: Error: [Errno 2] No such file or directory
> Card0.Amixer.info:
> Card hw:0 'SB'/'HDA ATI SB at 0xf2300000 irq 16'
> Mixer name : 'IDT 92HD81B1C5'
> Components : 'HDA:111d76d5,103c3656,00100402'
> Controls : 26
> Simple ctrls : 16
> Card1.Amixer.info:
> Card hw:1 'HDMI'/'HDA ATI HDMI at 0xf2210000 irq 19'
> Mixer name : 'ATI RS690/780 HDMI'
> Components : 'HDA:1002791a,00791a00,00100000'
> Controls : 4
> Simple ctrls : 1
> Card1.Amixer.values:
> Simple mixer control 'IEC958',0
> Capabilities: pswitch pswitch-joined
> Playback channels: Mono
> Mono: Playback [off]
> Date: Tue Mar 23 14:20:08 2010
> DistroRelease: Ubuntu 9.10
> HibernationDevice: RESUME=UUID=b0827668-53f3-48e2-ac2a-b2733626cf41
> InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
> MachineType: Hewl...

Read more...

Chase Douglas (chasedouglas) wrote :

OOPS! I built the wrong type of kernel for you. I'll upload a new version in a bit.

Mary (mtaussig44) wrote :
Download full text (3.1 KiB)

You must be working too hard! I hope it is not a problem that I installed
the middle one.

On Wed, Mar 24, 2010 at 5:55 PM, Chase Douglas
<email address hidden>wrote:

> OOPS! I built the wrong type of kernel for you. I'll upload a new
> version in a bit.
>
> --
> ALPS device (E7: 73 02 64) needs new model entry in alps.c
> https://bugs.launchpad.net/bugs/545307
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “linux” package in Ubuntu: Triaged
>
> Bug description:
> When going to System, preference, mouse in Ubuntu 9.10 the touchpad does
> not show up and can't be configured to eliminate the tap-to-click feature. I
> am told that this is a problem in the kernel.
>
> ProblemType: Bug
> Architecture: i386
> ArecordDevices:
> **** List of CAPTURE Hardware Devices ****
> card 0: SB [HDA ATI SB], device 0: STAC92xx Analog [STAC92xx Analog]
> Subdevices: 2/2
> Subdevice #0: subdevice #0
> Subdevice #1: subdevice #1
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC0: mary 1474 F.... pulseaudio
> CRDA: Error: [Errno 2] No such file or directory
> Card0.Amixer.info:
> Card hw:0 'SB'/'HDA ATI SB at 0xf2300000 irq 16'
> Mixer name : 'IDT 92HD81B1C5'
> Components : 'HDA:111d76d5,103c3656,00100402'
> Controls : 26
> Simple ctrls : 16
> Card1.Amixer.info:
> Card hw:1 'HDMI'/'HDA ATI HDMI at 0xf2210000 irq 19'
> Mixer name : 'ATI RS690/780 HDMI'
> Components : 'HDA:1002791a,00791a00,00100000'
> Controls : 4
> Simple ctrls : 1
> Card1.Amixer.values:
> Simple mixer control 'IEC958',0
> Capabilities: pswitch pswitch-joined
> Playback channels: Mono
> Mono: Playback [off]
> Date: Tue Mar 23 14:20:08 2010
> DistroRelease: Ubuntu 9.10
> HibernationDevice: RESUME=UUID=b0827668-53f3-48e2-ac2a-b2733626cf41
> InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
> MachineType: Hewlett-Packard HP Pavilion dm3 Notebook PC
> Package: linux-image-2.6.31-20-generic 2.6.31-20.58
> ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-20-generic
> root=UUID=f1e2e19e-a0f8-407d-9533-c5ba95a8be50 ro quiet splash
> ProcEnviron:
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.31-20.58-generic
> RelatedPackageVersions:
> linux-backports-modules-2.6.31-20-generic N/A
> linux-firmware 1.26
> SourcePackage: linux
> Uname: Linux 2.6.31-20-generic i686
> dmi.bios.date: 12/04/2009
> dmi.bios.vendor: Insyde Corp.
> dmi.bios.version: F.22
> dmi.board.asset.tag: Base Board Asset Tag
> dmi.board.name: 3656
> dmi.board.vendor: Hewlett-Packard
> dmi.board.version: 44.1D
> dmi.chassis.type: 10
> dmi.chassis.vendor: Hewlett-Packard
> dmi.chassis.version: N/A
> dmi.modalias:
> dmi:bvnInsydeCorp.:bvrF.22:bd12/04/2009:svnHewlett-Packard:pnHPPaviliondm3NotebookPC:pvr0486110000241F00110320000:rvnHewlett-Packard:rn3656:rvr44.1D:cvnHewlett-Packard:ct10:cvrN/A:
> dmi.product.name: HP Pavilion dm3 Notebook PC
> dmi.product.version: 0486110000241F00110320000
> dmi.sys.vendor: Hewlett-Packard
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/545307/+subscribe
>

--
Mary Hen...

Read more...

Changed in linux (Ubuntu):
assignee: nobody → Chase Douglas (chasedouglas)
Chase Douglas (chasedouglas) wrote :

I've uploaded a new set of packages for i386. Please test them out.

Thanks

Mary (mtaussig44) wrote :
Download full text (3.3 KiB)

You have made headway but aren't quite there. The touchpad tab shows up in
both the mouse and in gsynaptics, but even though I check the disable
touchpad when typing and try to disable the tap to click, it doesn't
disable. Also, I seem to have lost the scrolling on the edge.

On Wed, Mar 24, 2010 at 7:25 PM, Chase Douglas
<email address hidden>wrote:

> I've uploaded a new set of packages for i386. Please test them out.
>
> Thanks
>
> --
> ALPS device (E7: 73 02 64) needs new model entry in alps.c
> https://bugs.launchpad.net/bugs/545307
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “linux” package in Ubuntu: Triaged
>
> Bug description:
> When going to System, preference, mouse in Ubuntu 9.10 the touchpad does
> not show up and can't be configured to eliminate the tap-to-click feature. I
> am told that this is a problem in the kernel.
>
> ProblemType: Bug
> Architecture: i386
> ArecordDevices:
> **** List of CAPTURE Hardware Devices ****
> card 0: SB [HDA ATI SB], device 0: STAC92xx Analog [STAC92xx Analog]
> Subdevices: 2/2
> Subdevice #0: subdevice #0
> Subdevice #1: subdevice #1
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC0: mary 1474 F.... pulseaudio
> CRDA: Error: [Errno 2] No such file or directory
> Card0.Amixer.info:
> Card hw:0 'SB'/'HDA ATI SB at 0xf2300000 irq 16'
> Mixer name : 'IDT 92HD81B1C5'
> Components : 'HDA:111d76d5,103c3656,00100402'
> Controls : 26
> Simple ctrls : 16
> Card1.Amixer.info:
> Card hw:1 'HDMI'/'HDA ATI HDMI at 0xf2210000 irq 19'
> Mixer name : 'ATI RS690/780 HDMI'
> Components : 'HDA:1002791a,00791a00,00100000'
> Controls : 4
> Simple ctrls : 1
> Card1.Amixer.values:
> Simple mixer control 'IEC958',0
> Capabilities: pswitch pswitch-joined
> Playback channels: Mono
> Mono: Playback [off]
> Date: Tue Mar 23 14:20:08 2010
> DistroRelease: Ubuntu 9.10
> HibernationDevice: RESUME=UUID=b0827668-53f3-48e2-ac2a-b2733626cf41
> InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
> MachineType: Hewlett-Packard HP Pavilion dm3 Notebook PC
> Package: linux-image-2.6.31-20-generic 2.6.31-20.58
> ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-20-generic
> root=UUID=f1e2e19e-a0f8-407d-9533-c5ba95a8be50 ro quiet splash
> ProcEnviron:
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.31-20.58-generic
> RelatedPackageVersions:
> linux-backports-modules-2.6.31-20-generic N/A
> linux-firmware 1.26
> SourcePackage: linux
> Uname: Linux 2.6.31-20-generic i686
> dmi.bios.date: 12/04/2009
> dmi.bios.vendor: Insyde Corp.
> dmi.bios.version: F.22
> dmi.board.asset.tag: Base Board Asset Tag
> dmi.board.name: 3656
> dmi.board.vendor: Hewlett-Packard
> dmi.board.version: 44.1D
> dmi.chassis.type: 10
> dmi.chassis.vendor: Hewlett-Packard
> dmi.chassis.version: N/A
> dmi.modalias:
> dmi:bvnInsydeCorp.:bvrF.22:bd12/04/2009:svnHewlett-Packard:pnHPPaviliondm3NotebookPC:pvr0486110000241F00110320000:rvnHewlett-Packard:rn3656:rvr44.1D:cvnHewlett-Packard:ct10:cvrN/A:
> dmi.product.name: HP Pavilion dm3 Notebook PC
> dmi.product.version: 048611000024...

Read more...

Chase Douglas (chasedouglas) wrote :

@Mary:

If I had to guess, I think these are issues with the mouse preferences. I just confirmed with a colleague that Karmic's mouse preferences are broken in this regard (I'm running Lucid now, and it works for me here). That functionality is also above the kernel. There's probably another launchpad bug about it somewhere :).

For now, I just need to confirm that all the buttons and touchpad work properly, and that the synaptics driver is being used. If you can control settings using gsynaptics, then I think we're all set.

Chase Douglas (chasedouglas) wrote :

@Filex:

Can you confirm Mary's results?

Thanks

Mary (mtaussig44) wrote :
Download full text (4.0 KiB)

I wish I could say it's all set. I'd be delighted if gsynaptics were
working. Unfortunately in gsynaptics, even though I unclick "enable
touchpad" and unclick "enable tapping," the tap-to-click still works. So I
still can't get rid of the problem that if I touch the touch pad by mistake
I am suddenly typing somewhere else on the page....Sorry, I know how much
work you have done...Is the kernel for this Alps touchpad fixed in Lucid?
(It wasn't when I tried on March 16th). If it is easier for you to have me
switch to that, let me know.

On Thu, Mar 25, 2010 at 4:21 PM, Chase Douglas
<email address hidden>wrote:

> @Mary:
>
> If I had to guess, I think these are issues with the mouse preferences.
> I just confirmed with a colleague that Karmic's mouse preferences are
> broken in this regard (I'm running Lucid now, and it works for me here).
> That functionality is also above the kernel. There's probably another
> launchpad bug about it somewhere :).
>
> For now, I just need to confirm that all the buttons and touchpad work
> properly, and that the synaptics driver is being used. If you can
> control settings using gsynaptics, then I think we're all set.
>
> --
> ALPS device (E7: 73 02 64) needs new model entry in alps.c
> https://bugs.launchpad.net/bugs/545307
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “linux” package in Ubuntu: Triaged
>
> Bug description:
> When going to System, preference, mouse in Ubuntu 9.10 the touchpad does
> not show up and can't be configured to eliminate the tap-to-click feature. I
> am told that this is a problem in the kernel.
>
> ProblemType: Bug
> Architecture: i386
> ArecordDevices:
> **** List of CAPTURE Hardware Devices ****
> card 0: SB [HDA ATI SB], device 0: STAC92xx Analog [STAC92xx Analog]
> Subdevices: 2/2
> Subdevice #0: subdevice #0
> Subdevice #1: subdevice #1
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC0: mary 1474 F.... pulseaudio
> CRDA: Error: [Errno 2] No such file or directory
> Card0.Amixer.info:
> Card hw:0 'SB'/'HDA ATI SB at 0xf2300000 irq 16'
> Mixer name : 'IDT 92HD81B1C5'
> Components : 'HDA:111d76d5,103c3656,00100402'
> Controls : 26
> Simple ctrls : 16
> Card1.Amixer.info:
> Card hw:1 'HDMI'/'HDA ATI HDMI at 0xf2210000 irq 19'
> Mixer name : 'ATI RS690/780 HDMI'
> Components : 'HDA:1002791a,00791a00,00100000'
> Controls : 4
> Simple ctrls : 1
> Card1.Amixer.values:
> Simple mixer control 'IEC958',0
> Capabilities: pswitch pswitch-joined
> Playback channels: Mono
> Mono: Playback [off]
> Date: Tue Mar 23 14:20:08 2010
> DistroRelease: Ubuntu 9.10
> HibernationDevice: RESUME=UUID=b0827668-53f3-48e2-ac2a-b2733626cf41
> InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
> MachineType: Hewlett-Packard HP Pavilion dm3 Notebook PC
> Package: linux-image-2.6.31-20-generic 2.6.31-20.58
> ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-20-generic
> root=UUID=f1e2e19e-a0f8-407d-9533-c5ba95a8be50 ro quiet splash
> ProcEnviron:
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.31-20.58-generic
> Related...

Read more...

Filex (filip-brinkmann) wrote :

I can confirm Mary's result with the new kernel.
The touchpad is recognized as AlpsPS/2 GlidePoint
i can use gsynaptics now - but changing preferences don't affect the touchpad's behavior.

Chase Douglas (chasedouglas) wrote :

I've uploaded a new kernel to http://people.canonical.com/~cndougla/545307/lp545307_2/. This kernel is the same as before, except that it outputs debugging information from the alps driver. Please test it out by installing it and then trying to use the touchpad, buttons, and synaptics features. Afterwards, collect the dmesg by running "dmesg > dmesg.txt" and attach it here. If there are any issues, they should appear in the dmesg.

Secondarily, please try the gpointing-device-settings package in lieu of gsynaptics. It is a newer package that deprecates gsynaptics. Details can be found at http://live.gnome.org/GPointingDeviceSettings.

Thanks

Mary (mtaussig44) wrote :
  • dmesg.txt Edit (45.3 KiB, text/plain; charset=US-ASCII; name="dmesg.txt")
Download full text (4.4 KiB)

I installed the kernel, but have the same result-- gsynaptics doesn't
disable the tapping. (nor does system, preferences, mouse). I tried loading
gpointing device using synaptics package manager and it looked like it was
installing, but then nothing shows up in system preferences or system
administration, so either I don't know how to work the program or something
didn't work on the install. I also tried downloading the
gpointing-device-settings-1.5.1.tar.gz<http://sourceforge.jp/projects/gsynaptics/downloads/45812/gpointing-device-settings-1.5.1.tar.gz/>at
the website and using that, but I don't know how to install it. I also
still don't have the edge scrolling back.

On Fri, Mar 26, 2010 at 11:15 AM, Chase Douglas <<email address hidden>
> wrote:

> I've uploaded a new kernel to
> http://people.canonical.com/~cndougla/545307/lp545307_2/<http://people.canonical.com/%7Ecndougla/545307/lp545307_2/>.
> This kernel is
> the same as before, except that it outputs debugging information from
> the alps driver. Please test it out by installing it and then trying to
> use the touchpad, buttons, and synaptics features. Afterwards, collect
> the dmesg by running "dmesg > dmesg.txt" and attach it here. If there
> are any issues, they should appear in the dmesg.
>
> Secondarily, please try the gpointing-device-settings package in lieu of
> gsynaptics. It is a newer package that deprecates gsynaptics. Details
> can be found at http://live.gnome.org/GPointingDeviceSettings.
>
> Thanks
>
> --
> ALPS device (E7: 73 02 64) needs new model entry in alps.c
> https://bugs.launchpad.net/bugs/545307
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in The Linux Kernel: Unknown
> Status in “linux” package in Ubuntu: Triaged
>
> Bug description:
> When going to System, preference, mouse in Ubuntu 9.10 the touchpad does
> not show up and can't be configured to eliminate the tap-to-click feature. I
> am told that this is a problem in the kernel.
>
> ProblemType: Bug
> Architecture: i386
> ArecordDevices:
> **** List of CAPTURE Hardware Devices ****
> card 0: SB [HDA ATI SB], device 0: STAC92xx Analog [STAC92xx Analog]
> Subdevices: 2/2
> Subdevice #0: subdevice #0
> Subdevice #1: subdevice #1
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC0: mary 1474 F.... pulseaudio
> CRDA: Error: [Errno 2] No such file or directory
> Card0.Amixer.info:
> Card hw:0 'SB'/'HDA ATI SB at 0xf2300000 irq 16'
> Mixer name : 'IDT 92HD81B1C5'
> Components : 'HDA:111d76d5,103c3656,00100402'
> Controls : 26
> Simple ctrls : 16
> Card1.Amixer.info:
> Card hw:1 'HDMI'/'HDA ATI HDMI at 0xf2210000 irq 19'
> Mixer name : 'ATI RS690/780 HDMI'
> Components : 'HDA:1002791a,00791a00,00100000'
> Controls : 4
> Simple ctrls : 1
> Card1.Amixer.values:
> Simple mixer control 'IEC958',0
> Capabilities: pswitch pswitch-joined
> Playback channels: Mono
> Mono: Playback [off]
> Date: Tue Mar 23 14:20:08 2010
> DistroRelease: Ubuntu 9.10
> HibernationDevice: RESUME=UUID=b0827668-53f3-48e2-ac2a-b2733626cf41
> InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (2...

Read more...

Chase Douglas (chasedouglas) wrote :

@Mary:

Your dmesg doesn't show any errors, so from what I've read that's the sign that everything is right at the driver level. I will submit the patch upstream to the driver maintainer so it can be included in the kernel.

Run "gpointing-device-settings &" in a terminal to try it out. You may see some stuff printed out in the terminal, but you can ignore it.

Also, can you run lshal with the test kernel and attach the output here?

Thanks

Mary (mtaussig44) wrote :
  • lshal2.txt Edit (25.4 KiB, text/plain; charset=US-ASCII; name="lshal2.txt")
Download full text (3.7 KiB)

The gpointing device ran and showed the Alps touchpad, but still didn't work
to change the tapping and scrolling.
So if everything is right at the driver level, what do you think could be
wrong? What's the best next step to fix this?

On Fri, Mar 26, 2010 at 3:34 PM, Chase Douglas
<email address hidden>wrote:

> @Mary:
>
> Your dmesg doesn't show any errors, so from what I've read that's the
> sign that everything is right at the driver level. I will submit the
> patch upstream to the driver maintainer so it can be included in the
> kernel.
>
> Run "gpointing-device-settings &" in a terminal to try it out. You may
> see some stuff printed out in the terminal, but you can ignore it.
>
> Also, can you run lshal with the test kernel and attach the output here?
>
> Thanks
>
> --
> ALPS device (E7: 73 02 64) needs new model entry in alps.c
> https://bugs.launchpad.net/bugs/545307
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in The Linux Kernel: Unknown
> Status in “linux” package in Ubuntu: Triaged
>
> Bug description:
> When going to System, preference, mouse in Ubuntu 9.10 the touchpad does
> not show up and can't be configured to eliminate the tap-to-click feature. I
> am told that this is a problem in the kernel.
>
> ProblemType: Bug
> Architecture: i386
> ArecordDevices:
> **** List of CAPTURE Hardware Devices ****
> card 0: SB [HDA ATI SB], device 0: STAC92xx Analog [STAC92xx Analog]
> Subdevices: 2/2
> Subdevice #0: subdevice #0
> Subdevice #1: subdevice #1
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC0: mary 1474 F.... pulseaudio
> CRDA: Error: [Errno 2] No such file or directory
> Card0.Amixer.info:
> Card hw:0 'SB'/'HDA ATI SB at 0xf2300000 irq 16'
> Mixer name : 'IDT 92HD81B1C5'
> Components : 'HDA:111d76d5,103c3656,00100402'
> Controls : 26
> Simple ctrls : 16
> Card1.Amixer.info:
> Card hw:1 'HDMI'/'HDA ATI HDMI at 0xf2210000 irq 19'
> Mixer name : 'ATI RS690/780 HDMI'
> Components : 'HDA:1002791a,00791a00,00100000'
> Controls : 4
> Simple ctrls : 1
> Card1.Amixer.values:
> Simple mixer control 'IEC958',0
> Capabilities: pswitch pswitch-joined
> Playback channels: Mono
> Mono: Playback [off]
> Date: Tue Mar 23 14:20:08 2010
> DistroRelease: Ubuntu 9.10
> HibernationDevice: RESUME=UUID=b0827668-53f3-48e2-ac2a-b2733626cf41
> InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
> MachineType: Hewlett-Packard HP Pavilion dm3 Notebook PC
> Package: linux-image-2.6.31-20-generic 2.6.31-20.58
> ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-20-generic
> root=UUID=f1e2e19e-a0f8-407d-9533-c5ba95a8be50 ro quiet splash
> ProcEnviron:
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.31-20.58-generic
> RelatedPackageVersions:
> linux-backports-modules-2.6.31-20-generic N/A
> linux-firmware 1.26
> SourcePackage: linux
> Uname: Linux 2.6.31-20-generic i686
> dmi.bios.date: 12/04/2009
> dmi.bios.vendor: Insyde Corp.
> dmi.bios.version: F.22
> dmi.board.asset.tag: Base Board Asset Tag
> dmi.board.name: 3656
> dmi.board.vendor: Hewlett-Packard
> dmi.board.vers...

Read more...

Chase Douglas (chasedouglas) wrote :

@Mary:

I'm not real sure why things are working quite right yet. I'll keep thinking about it.

Unfortunately, your lshal2.txt is mostly empty, as if most of the output was cut off. Can you try attaching again?

Thanks

Mary (mtaussig44) wrote :
  • lshal.txt Edit (23.1 KiB, text/plain; charset=US-ASCII; name="lshal.txt")
Download full text (3.3 KiB)

Sorry about that. Here it is again.

On Fri, Mar 26, 2010 at 4:46 PM, Chase Douglas
<email address hidden>wrote:

> @Mary:
>
> I'm not real sure why things are working quite right yet. I'll keep
> thinking about it.
>
> Unfortunately, your lshal2.txt is mostly empty, as if most of the output
> was cut off. Can you try attaching again?
>
> Thanks
>
> --
> ALPS device (E7: 73 02 64) needs new model entry in alps.c
> https://bugs.launchpad.net/bugs/545307
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in The Linux Kernel: Unknown
> Status in “linux” package in Ubuntu: Triaged
>
> Bug description:
> When going to System, preference, mouse in Ubuntu 9.10 the touchpad does
> not show up and can't be configured to eliminate the tap-to-click feature. I
> am told that this is a problem in the kernel.
>
> ProblemType: Bug
> Architecture: i386
> ArecordDevices:
> **** List of CAPTURE Hardware Devices ****
> card 0: SB [HDA ATI SB], device 0: STAC92xx Analog [STAC92xx Analog]
> Subdevices: 2/2
> Subdevice #0: subdevice #0
> Subdevice #1: subdevice #1
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC0: mary 1474 F.... pulseaudio
> CRDA: Error: [Errno 2] No such file or directory
> Card0.Amixer.info:
> Card hw:0 'SB'/'HDA ATI SB at 0xf2300000 irq 16'
> Mixer name : 'IDT 92HD81B1C5'
> Components : 'HDA:111d76d5,103c3656,00100402'
> Controls : 26
> Simple ctrls : 16
> Card1.Amixer.info:
> Card hw:1 'HDMI'/'HDA ATI HDMI at 0xf2210000 irq 19'
> Mixer name : 'ATI RS690/780 HDMI'
> Components : 'HDA:1002791a,00791a00,00100000'
> Controls : 4
> Simple ctrls : 1
> Card1.Amixer.values:
> Simple mixer control 'IEC958',0
> Capabilities: pswitch pswitch-joined
> Playback channels: Mono
> Mono: Playback [off]
> Date: Tue Mar 23 14:20:08 2010
> DistroRelease: Ubuntu 9.10
> HibernationDevice: RESUME=UUID=b0827668-53f3-48e2-ac2a-b2733626cf41
> InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
> MachineType: Hewlett-Packard HP Pavilion dm3 Notebook PC
> Package: linux-image-2.6.31-20-generic 2.6.31-20.58
> ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-20-generic
> root=UUID=f1e2e19e-a0f8-407d-9533-c5ba95a8be50 ro quiet splash
> ProcEnviron:
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.31-20.58-generic
> RelatedPackageVersions:
> linux-backports-modules-2.6.31-20-generic N/A
> linux-firmware 1.26
> SourcePackage: linux
> Uname: Linux 2.6.31-20-generic i686
> dmi.bios.date: 12/04/2009
> dmi.bios.vendor: Insyde Corp.
> dmi.bios.version: F.22
> dmi.board.asset.tag: Base Board Asset Tag
> dmi.board.name: 3656
> dmi.board.vendor: Hewlett-Packard
> dmi.board.version: 44.1D
> dmi.chassis.type: 10
> dmi.chassis.vendor: Hewlett-Packard
> dmi.chassis.version: N/A
> dmi.modalias:
> dmi:bvnInsydeCorp.:bvrF.22:bd12/04/2009:svnHewlett-Packard:pnHPPaviliondm3NotebookPC:pvr0486110000241F00110320000:rvnHewlett-Packard:rn3656:rvr44.1D:cvnHewlett-Packard:ct10:cvrN/A:
> dmi.product.name: HP Pavilion dm3 Notebook PC
> dmi.product.version: 0486110000241F00110320000
> dmi.sys.vendor: Hewlett-Packard
>
...

Read more...

Chase Douglas (chasedouglas) wrote :

@Mary:

Unfortunately, it's still cut off. In case you are trying to hard :), the easiest way to get the output is to run "lshal > lshal.txt". If you've got the full file, but it's not attaching right in launchpad, I would try attaching it using the form here at the bug report instead of through email. Maybe the attachment is getting cut off somewhere?

If you need some other way to transfer, feel free to email me personally and we can set something up.

Thanks for your effort though! It's much appreciated.

Mary (mtaussig44) wrote :

I'll try attaching it through the bug page.

Chase Douglas (chasedouglas) wrote :

@Mary:

Awesome! I found what I needed:

udi = '/org/freedesktop/Hal/devices/platform_i8042_i8042_AUX_port_logicaldev_input'
  info.callouts.add = {'hal-probe-vmmouse'} (string list)
  info.capabilities = {'input', 'input.mouse', 'input.touchpad'} (string list)
  info.category = 'input' (string)
  info.parent = '/org/freedesktop/Hal/devices/platform_i8042_i8042_AUX_port' (string)
  info.product = 'AlpsPS/2 ALPS GlidePoint' (string)
  info.subsystem = 'input' (string)
  info.udi = '/org/freedesktop/Hal/devices/platform_i8042_i8042_AUX_port_logicaldev_input' (string)
  input.device = '/dev/input/event10' (string)
  input.originating_device = '/org/freedesktop/Hal/devices/platform_i8042_i8042_AUX_port' (string)
  input.product = 'AlpsPS/2 ALPS GlidePoint' (string)
  input.x11_driver = 'synaptics' (string)
  linux.device_file = '/dev/input/event10' (string)
  linux.hotplug_type = 2 (0x2) (int)
  linux.subsystem = 'input' (string)
  linux.sysfs_path = '/sys/devices/platform/i8042/serio1/input/input10/event10' (string)

This is a description of your mouse. So, your touchpad has been recognized properly (input.product looks good) and is using the synaptics driver (input.x11_driver). So, I think the issues you have are more at the synaptics X driver level than the kernel level. So, keeping with the idea of one bug per issue, I suggest opening a bug against the xserver-xorg-input-synaptics package:

ubuntu-bug xserver-xorg-input-synaptics

Hopefully someone with more experience and knowledge in that driver can help you sort out these issues.

Changed in linux (Ubuntu):
status: Triaged → In Progress
Mary (mtaussig44) wrote :
Download full text (4.8 KiB)

Well, it is great that at least the touchpad is recognized! Thank you for
all your work on this. Hopefully there is a fix for the driver problem. I'll
see what I come up with....

On Sat, Mar 27, 2010 at 12:06 PM, Chase Douglas <<email address hidden>
> wrote:

> @Mary:
>
> Awesome! I found what I needed:
>
> udi =
> '/org/freedesktop/Hal/devices/platform_i8042_i8042_AUX_port_logicaldev_input'
> info.callouts.add = {'hal-probe-vmmouse'} (string list)
> info.capabilities = {'input', 'input.mouse', 'input.touchpad'} (string
> list)
> info.category = 'input' (string)
> info.parent = '/org/freedesktop/Hal/devices/platform_i8042_i8042_AUX_port'
> (string)
> info.product = 'AlpsPS/2 ALPS GlidePoint' (string)
> info.subsystem = 'input' (string)
> info.udi =
> '/org/freedesktop/Hal/devices/platform_i8042_i8042_AUX_port_logicaldev_input'
> (string)
> input.device = '/dev/input/event10' (string)
> input.originating_device =
> '/org/freedesktop/Hal/devices/platform_i8042_i8042_AUX_port' (string)
> input.product = 'AlpsPS/2 ALPS GlidePoint' (string)
> input.x11_driver = 'synaptics' (string)
> linux.device_file = '/dev/input/event10' (string)
> linux.hotplug_type = 2 (0x2) (int)
> linux.subsystem = 'input' (string)
> linux.sysfs_path =
> '/sys/devices/platform/i8042/serio1/input/input10/event10' (string)
>
> This is a description of your mouse. So, your touchpad has been
> recognized properly (input.product looks good) and is using the
> synaptics driver (input.x11_driver). So, I think the issues you have are
> more at the synaptics X driver level than the kernel level. So, keeping
> with the idea of one bug per issue, I suggest opening a bug against the
> xserver-xorg-input-synaptics package:
>
> ubuntu-bug xserver-xorg-input-synaptics
>
> Hopefully someone with more experience and knowledge in that driver can
> help you sort out these issues.
>
> --
> ALPS device (E7: 73 02 64) needs new model entry in alps.c
> https://bugs.launchpad.net/bugs/545307
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in The Linux Kernel: Unknown
> Status in “linux” package in Ubuntu: In Progress
>
> Bug description:
> When going to System, preference, mouse in Ubuntu 9.10 the touchpad does
> not show up and can't be configured to eliminate the tap-to-click feature. I
> am told that this is a problem in the kernel.
>
> ProblemType: Bug
> Architecture: i386
> ArecordDevices:
> **** List of CAPTURE Hardware Devices ****
> card 0: SB [HDA ATI SB], device 0: STAC92xx Analog [STAC92xx Analog]
> Subdevices: 2/2
> Subdevice #0: subdevice #0
> Subdevice #1: subdevice #1
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC0: mary 1474 F.... pulseaudio
> CRDA: Error: [Errno 2] No such file or directory
> Card0.Amixer.info:
> Card hw:0 'SB'/'HDA ATI SB at 0xf2300000 irq 16'
> Mixer name : 'IDT 92HD81B1C5'
> Components : 'HDA:111d76d5,103c3656,00100402'
> Controls : 26
> Simple ctrls : 16
> Card1.Amixer.info:
> Card hw:1 'HDMI'/'HDA ATI HDMI at 0xf2210000 irq 19'
> Mixer name : 'ATI RS690/780 HDMI'
> Components : 'HDA:1002791a,00791a00,00...

Read more...

Chase Douglas (chasedouglas) wrote :

I've submitted the patch upstream. If/when it's accepted into the linux kernel we will probably pull it into Lucid, but I wouldn't count on it being before the Ubuntu 10.04 LTS release unless things go very fast. It will likely appear in a kernel update post-release.

I'll try to keep this bug updated when things occur upstream.

Thanks for testing!

Andy Whitcroft (apw) on 2010-03-31
Changed in linux (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (3.3 KiB)

This bug was fixed in the package linux - 2.6.32-19.28

---------------
linux (2.6.32-19.28) lucid; urgency=low

  [ Andy Whitcroft ]

  * [Config] enable various multitouch devices
    - LP: #541453

  [ Chase Douglas ]

  * (pre-stable): input: ALPS - Add signature for HP Pavilion dm3 laptops
    - LP: #545307
  * SAUCE: Disable function tracing after hitting __schedule_bug
  * SAUCE: Reduce ACPI resource conflict message to KERN_INFO, printf
    cleanup
    - LP: #440470

  [ Jesse Barnes ]

  * SAUCE: drm/i915: don't change DRM configuration when releasing load
    detect pipe
    - LP: #488328

  [ John Johansen ]

  * SAUCE: AppArmor: Remove null_profile's use of PFLAG_NO_LIST_REF
    - LP: #539437
  * SAUCE: AppArmor: Stop page allocation warnings that can occur on policy
    load
    - LP: #458299
  * SAUCE: AppArmor: Return string len rather than the allocation size
    - LP: #551844
  * SAUCE: AppArmor: Fix oops in profile verification if profile unpack
    fails.

  [ Luke Yelavich ]

  * [Config] Enable Nouveau DRM module on powerpc

  [ Stefan Bader ]

  * SAUCE: Pull in thinkpad-acpi from v2.6.34-rc1
    - LP: #357673
  * [Config] Enable thinkpad-acpi ALSA volume control
    - LP: #357673

  [ Steve Conklin ]

  * SAUCE: drm/i915: Disable FBC on 915GM and 945GM
    - LP: #492392, #539609

  [ Upstream Kernel Changes ]

  * Revert "(pre-stable) drm/i915: blacklist lid status: Sony VGN-BX196VP,
    Dell Inspiron 700m"
    - LP: #515246
  * (pre-stable) softlockup: Stop spurious softlockup messages due to
    overflow
    - LP: #551068
  * backlight: mbp_nvidia_bl - add five more MacBook variants
    - LP: #511965
  * drm/nv04-nv40: Fix up the programmed horizontal sync pulse delay.
    - LP: #529130
  * drm/nouveau: Fix fbcon corruption with font width not divisible by 8
    - LP: #544739
  * (pre-stable) USB: fix usbfs regression
  * drm/radeon/bo: add some fallback placements for VRAM only objects.
    - LP: #507148
  * drm/radeon/kms: don't print error on -ERESTARTSYS.
    - LP: #507148
  * Input: add the ABS_MT_PRESSURE event
    - LP: #541453
  * HID: Support for 3M multitouch panel
    - LP: #541453
  * HID: make 3M PCT touchscreen driver standalone config option
    - LP: #541453
  * HID: add support for Stantum multitouch panel
    - LP: #541453
  * HID: make Stantum driver standalone config option
    - LP: #541453
  * HID: add support for Acer T230H multitouch
    - LP: #541453
  * HID: add support for Pixart Imaging Optical Touch Screen
    - LP: #541453
  * HID: fixed bug in single-touch emulation on the stantum panel
    - LP: #541453
  * HID: add pressure support for the Stantum multitouch panel
    - LP: #541453
  * HID: Support for MosArt multitouch panel
    - LP: #541453
  * HID: hid-ntrig add multi input quirk and clean up
    - LP: #541453
  * HID: n-trig: remove unnecessary tool switching
    - LP: #541453
  * HID: hid-ntrig: multitouch cleanup and fix
    - LP: #541453
  * HID: hid-ntrig: Single touch mode tap
    - LP: #541453
  * hid: ntrig touch events
    - LP: #541453
  * (pre-stable) x86-32, resume: do a global tlb flush in S4 resume
    - LP: #531309
  * drm/i915: Part of: Add initial bits for VGA mode...

Read more...

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released

That's my lshal part for touchpad:

udi = '/org/freedesktop/Hal/devices/platform_i8042_i8042_AUX1_port_logicaldev_input'
  info.capabilities = {'input', 'input.mouse', 'input.touchpad'} (string list)
  info.category = 'input' (string)
  info.parent = '/org/freedesktop/Hal/devices/platform_i8042_i8042_AUX1_port' (string)
  info.product = 'AlpsPS/2 ALPS GlidePoint' (string)
  info.subsystem = 'input' (string)
  info.udi = '/org/freedesktop/Hal/devices/platform_i8042_i8042_AUX1_port_logicaldev_input' (string)
  input.device = '/dev/input/event10' (string)
  input.originating_device = '/org/freedesktop/Hal/devices/platform_i8042_i8042_AUX1_port' (string)
  input.product = 'AlpsPS/2 ALPS GlidePoint' (string)
  linux.device_file = '/dev/input/event10' (string)
  linux.hotplug_type = 2 (0x2) (int)
  linux.subsystem = 'input' (string)
  linux.sysfs_path = '/sys/devices/platform/i8042/serio2/input/input10/event10' (string)

As you can see the line:

input.x11_driver = 'synaptics' (string)

is missing. Why?

I'm using Ubuntu Lucid on Sony VAIO VPCF11C5E

Chase Douglas (chasedouglas) wrote :

@Paolo:

I am not sure why the synaptics X driver isn't picking this up. Please open a new bug against the xserver-xorg-input-synaptics package. You can do this through launchpad or by running 'ubuntu-bug xserver-xorg-input-synaptics'.

Thanks

alabamas (a-huqi) wrote :

I think that is something related to driver,

Maybe Absolute mode is not working the way it should.
The Scrolling on Alps is managed by the absolute mode.
So if someone is able to debug the absolute mode please help!!!!

Thanks.

Chase Douglas (chasedouglas) wrote :

There's some follow up in bug 550625 for this issue. Unfortunately, this particular hardware is not responding the same as older hardware. Adding the device id does not make it work properly, and also removes the scroll support. A new protocol will need to be determined for this device.

Changed in linux (Ubuntu):
status: Fix Released → Won't Fix
Chase Douglas (chasedouglas) wrote :

I marked this bug as won't fix, not because we won't fix it if we can find a solution, but because leaving the state as Fix Released is somewhat misleading. New comments should be directed to bug 550625.

In , Tg42 (tg42) wrote :

The ALPS touchpad in Dell Latitude E6510 notebooks is not recognized by kernel 2.6.33 (and earlier). I think, this is already reported upstream, but it would be nice, if you could include the attached patch to the collection of Gentoo-Sources patches.

Reproducible: Always

In , Tg42 (tg42) wrote :

Created attachment 230417
Add the signature of the new ALPS touchpad to the alps driver

In , Tg42 (tg42) wrote :

The patch abv is against gentoo-sources-2.6.33-r1.

Can you tell me where you submitted this?

This patch was reverted Linus' upstream tree in the link in comment #4

This is actually also a problem in E6410, it is recognized as a standard PS/2 device (therefore, no scrolling, no double touch, etc)

From dmesg:
[ 1.150223] PNP: PS/2 Controller [PNP0303:PS2K,PNP0f13:PS2M] at 0x60,0x64 irq 1,12
[ 1.151001] i8042.c: Warning: Keylock active.
[ 1.152480] serio: i8042 KBD port at 0x60,0x64 irq 1
[ 1.152768] serio: i8042 AUX port at 0x60,0x64 irq 12
[ 1.153111] mice: PS/2 mouse device common for all mice

From:
$ hal-device | grep -B 15 input.x11_driver

26: udi = '/org/freedesktop/Hal/devices/platform_i8042_i8042_AUX_port_logicaldev_input'
  info.subsystem = 'input' (string)
  linux.hotplug_type = 2 (0x2) (int)
  linux.subsystem = 'input' (string)
  input.originating_device = '/org/freedesktop/Hal/devices/platform_i8042_i8042_AUX_port' (string)
  input.device = '/dev/input/event10' (string)
  info.product = 'PS/2 Generic Mouse' (string)
  linux.sysfs_path = '/sys/devices/platform/i8042/serio1/input/input10/event10' (string)
  info.parent = '/org/freedesktop/Hal/devices/platform_i8042_i8042_AUX_port' (string)
  info.udi = '/org/freedesktop/Hal/devices/platform_i8042_i8042_AUX_port_logicaldev_input' (string)
  info.category = 'input' (string)
  info.capabilities = { 'input', 'input.mouse' } (string list)
  input.x11_driver = 'evdev' (string)

Oh BTW: still true with kernel 2.6.34

raboof (arnouten) wrote :

The signature that was added to the kernel (as noted above) has been removed again since: http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=6d327cb03fbc64cac36571c9bc8a1576d2b3ea00

Changed in gentoo:
status: Unknown → Confirmed

We'll follow the upstream bug and backport any accepted patches

Changed in gentoo:
status: Confirmed → Fix Released
Changed in gentoo:
status: Fix Released → Won't Fix
Changed in linux:
importance: Unknown → Medium
Changed in gentoo:
importance: Unknown → Medium

(In reply to comment #10)
> FYI: Upstream kernel.org bug: https://bugzilla.kernel.org/show_bug.cgi?id=14660
>

I have tried the patch mentioned in comment #50 there, and it works on my Dell Latitude E6410. The Touchpad isn't recognized as such, so not usable via xf86-input-synaptics. It is recognized as an IMPS Mouse, supporting tapping and vertical scrolling. Suspend/Resume finally works, too. (With the previous patch by Dell, the mouse went haywire after a resume.

Link: https://patchwork.kernel.org/patch/350841/

Ah! My kernel is gentoo-sources-2.6.37

Changed in linux:
status: Unknown → Invalid

Just wanted to note that said patch works well with gentoo-sources-3.0.1

hello, there is some betaversion of the alps/synaptics driver v3, provided by Seth Forshee <email address hidden>

http://people.canonical.com/~sforshee/alps-touchpad/psmouse-alps-0.1/psmouse-alps-dkms_0.1_all.deb

I unpacked the deb file and used source to compile kernel modules. After that I can see two devices and everythings working just fine.(horizontal/vertical scrolling, turning touchpad on/off)

System uname:
Linux-3.0.3-gentoo-x86_64-Intel-R-_Core-TM-_i3_CPU_M_380_@_2.53GHz-with-gentoo-2.0.3

I: Bus=0011 Vendor=0002 Product=0008 Version=7326
N: Name="AlpsPS/2 ALPS DualPoint TouchPad"
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input16
U: Uniq=
H: Handlers=mouse1 event16
B: PROP=8
B: EV=b
B: KEY=e420 70000 0 0 0 0
B: ABS=260800001000003

I: Bus=0011 Vendor=0002 Product=0008 Version=0000
N: Name="DualPoint Stick"
P: Phys=isa0060/serio1/input1
S: Sysfs=/devices/platform/i8042/serio1/input/input15
U: Uniq=
H: Handlers=mouse0 event15
B: PROP=0
B: EV=7
B: KEY=70000 0 0 0 0
B: REL=3

Would have been nice if they wrote which kernel version they took the code from, so that we could get a patch to integrate... trying to find that out.

(Looks like a 3.0.4)...

The patch is provided here [1], and applies cleanly to 3.0.4 (and 3.0.3), so I think we can add it to genpatches.

[1] http://people.canonical.com/~sforshee/alps-touchpad/psmouse-alps-0.1/alps-v3-protocol-support-v1.patch

Reopening then. I'm going to test this today.

Confirmed it works by using a slightly different patch...

(In reply to comment #18)
> Confirmed it works by using a slightly different patch...

What do you mean by different?

Changed in gentoo:
status: Won't Fix → Unknown

Any chance we could get this patch applied to gentoo-sources?

Which one?

(In reply to comment #21)
> Which one?

sys-kernel/gentoo-sources that is

(In reply to comment #22)
> (In reply to comment #21)
> > Which one?
>
> sys-kernel/gentoo-sources that is

Works fine with =sys-kernel/gentoo-sources-3.0.4

I meant which patch. :)

I see Diego has modified the patch. Has this been submitted upstream? I'd like to see it submitted and accepted. Are standard procedure is not to add patches which are not vetted through upstream.

http://dev.gentoo.org/~mpagano/genpatches/faq.htm

(In reply to comment #24)
> I meant which patch. :)

This is the patch I used against gentoo sources to get my touchpad to be recognized properly and allow scrolling with it:

http://people.canonical.com/~sforshee/alps-touchpad/psmouse-alps-0.1/alps-v3-protocol-support-v1.patch

This is awesome!

The mentioned new patch does not only apply cleanly to gentoo-sources-3.0.4, AND xinput now reports a "AlpsPS/2 ALPS DualPoint TouchPad", no.

Furthermore the "touchpad" tab in KDE systemsettings (4.7.1 here) no longer says that no touchpad is recognized, but no states that a AlpsPS/2 Touchpad is recognized and configurable.

I _really_ hope this patch is accepted upstream!

There have been several releases since the original (the most recent being v0.7 [1]). Anyone willing to test and report if it works ok, or if there are any regressions/problems?

Thanks.

[1] http://people.canonical.com/~sforshee/alps-touchpad/psmouse-alps-0.7/

Created attachment 288059
Stripped Patches + shell script to batch patch (Version 0.7)

Startos, I have downloaded the patches and stripped them from "git cruft" to make them work.

They apply cleanly to getnoo-sources-3.0.4. I can not see any big difference, although the touchpad *feels* a bit less sensitive.

KDE-SystemSettings recognize the touchpad and (of course) synclient works with it now.

The archive attached are the "stripped" patches that I applied. The output of the (tiny) shell script was:

------------
sed-notebook /usr/src/linux # ./ALPS.patch.sh
Applying patch ALPS.patches/0001-Input-ALPS-Move-protocol-information-to-Documentatio.patch ...
patching file Documentation/input/alps.txt
patching file drivers/input/mouse/alps.c
Applying patch ALPS.patches/0002-Input-psmouse-Add-PSMOUSE_CMD_RESET_WRAP.patch ...
patching file drivers/input/mouse/psmouse.h
Applying patch ALPS.patches/0003-Input-ALPS-Add-protocol-version-field-in-alps_model_.patch ...
patching file drivers/input/mouse/alps.c
patching file drivers/input/mouse/alps.h
Applying patch ALPS.patches/0004-Input-ALPS-Remove-assumptions-about-packet-size.patch ...
patching file drivers/input/mouse/alps.c
Applying patch ALPS.patches/0005-Input-ALPS-Add-support-for-protocol-versions-3-and-4.patch ...
patching file drivers/input/mouse/alps.c
patching file drivers/input/mouse/alps.h
Applying patch ALPS.patches/0006-Input-ALPS-Add-documentation-for-protocol-versions-3.patch ...
patching file Documentation/input/alps.txt
patching file drivers/input/mouse/alps.c
Applying patch ALPS.patches/0007-Input-ALPS-Add-semi-MT-support-for-v3-protocol.patch ...
patching file drivers/input/mouse/alps.c
patching file drivers/input/mouse/alps.h
Applying patch ALPS.patches/0008-Input-ALPS-dump-raw-packet-data.patch ...
patching file drivers/input/mouse/alps.c
------------

Created attachment 288061
(Corr) Stripped Patches + shell script to batch patch (Version 0.7)

Damn... I was too quick with my fingers and messed up the archive. Here is a working one.

In SVN for next release, 3.0.4-gentoo-r1 which is forthcoming

Please proceed to enjoy your touchpads in gentoo-sources-3.0.4-r1 that was just released.

(In reply to comment #31)
> Please proceed to enjoy your touchpads in gentoo-sources-3.0.4-r1 that was just
> released.

Thanks for adding the patch! :-)

Wow! Great job!

But there are two issues I have now. First of all synaptiks (the KDE client for touchpads, I use it to disable the touchpad when an external mouse is plugged in) works, but I had a crash after resuming from suspend. I guess this is because of synaptiks not knowing anything about ALPS and simply assumes a Synaptics touchpad. I had it once, and if it happens again I'll send the Backtrace to bugs.kde.org.

The second is irritating: My middle mouse button no longer works. I have a Dell Latitude E6410, which has two rows of mouse buttons. Two below the touchpad, and three (they belong to the DualPoint Stick in the keyboard) above it. The middle button of those three no longer works. As Three-Finger-Tapping is functioning now, I can live with that, but have to get used to it. I've used the middle mouse button quite frequently.

Finally users should add a configuration to /etc/X11/xorg.conf to set the correct edge values. The ones I have come up so far are:

------------
Section "InputClass"
        Identifier "touchpad catchall"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Driver "synaptics"
        Option "LeftEdge" "100"
        Option "RightEdge" "1775"
        Option "TopEdge" "100"
        Option "BottomEdge" "1275"
(... snip ...)
------------

The default values sped up the pointer movement too far and resulted in too wide scrolling edges. Everyone should check their values with "synclient -m 1"

And now we see the reason we don't like to add out-of-tree patches that have not been accepted upstream. :)

If a new version comes out, I will update the patches.

Created attachment 288555
Stripped Patches + shell script to batch patch (Version 0.9)

Man, this guy is a genius!

I have updated to version 0.9 of the patch (the archive now has a versioned patch directory, versioned shell script to apply and one to remove the patches) and my middle mouse button is back.

xinput output now looks like this:

------------
AlpsPS/2 ALPS DualPoint TouchPad id=13 [slave pointer (2)]
        Reporting 3 classes:
                Class originated from: 13
                Buttons supported: 12
                Button labels: Button Left Button Middle Button Right Button Wheel Up Button Wheel Down Button Horiz Wheel Left Button Horiz Wheel Right None None None None None
                Button state:
                Class originated from: 13
                Detail for Valuator 0:
                  Label: Rel X
                  Range: 0.000000 - 2000.000000
                  Resolution: 0 units/m
                  Mode: relative
                Class originated from: 13
                Detail for Valuator 1:
                  Label: Rel Y
                  Range: 0.000000 - 1400.000000
                  Resolution: 0 units/m
                  Mode: relative
------------

See? "Button Middle" is back! :)

(In reply to comment #34)
> And now we see the reason we don't like to add out-of-tree patches that have
> not been accepted upstream. :)

Ah! It is a very good idea to have this patch in the tree. Personally I see three reasons:

1.: Without this patch you have to manually apply the old patch (but kernel.org is down!) to have the touchpad at least to be recognized as an IMPS/2 Mouse, meaning the whole system is unaware that this is a touchpad at all.
2.: Without this patch, starting synaptiks makes no sense whatsoever, as neither synclient nor synaptics can *see* the touchpad.
3.: With this patch in the tree, and maybe some advertisement, we could get more users to test it. Maybe it makes us being able to help Seth Forshee <email address hidden>, the author of the patch, to further improve it?

Just wanted to report that with the 0.9 patch set, synaptiks is stable for me. Several reboots, suspends and hibernations bot with and without AC plugged in did not trigger another crash. Whatever caused it, Seth fixed it.

Included in gentoo-sources-3.0.4-r2

Although everything is working well, I can still make synaptiks crash exactly once after each reboot of my laptop:

Boot -> Suspend -> Wakeup -> Crash.

When I then restart synaptiks, I can suspend and resume at will and the program is dead never crashing again until the next reboot.

As I think this is really weird, I have opened an issue at github for synaptiks here:
https://github.com/lunaryorn/synaptiks/issues/23

Anybody witnessing the same strange crashes might contribute there.

Sebastian Wiesner wrote to me saying that the crashing issue has been fixed in version 0.8 of synaptiks, which is not in the tree, yet.

v10 ALPS patches included in gentoo-sources-3.0.7.

I think we're going keep this bug open, until the patches are pushed upstream.

Yay! Patch version 10? great!

A note: Synaptiks 0.8.0 is fixed and no longer crashes. This is quite some progress for just a few weeks compared to the many month before, eh? ;-)

We'll keep carrying this in genpatches. If a new version is released, please reopen this.

If it makes the upstream kernel, we'll remove from genpatches, of course.

Changed in gentoo:
status: Unknown → Fix Released

Dmitry Torokhov has taken the patches, they're currently in linux-next so expect to see them in 3.3. The patches there are marginally different from the version 10 patches, shouldn't result in any noticible differences but if you'd like to update you can grab them from Dmitry's tree.

http://git.kernel.org/?p=linux/kernel/git/dtor/input.git

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.