[karmic] no sound on toshiba nb205

Bug #438318 reported by Joey Stanford
292
This bug affects 53 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Manoj Iyer
Jaunty
Medium
Leann Ogasawara
Karmic
Medium
Manoj Iyer
Lucid
Medium
Manoj Iyer

Bug Description

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)

ProblemType: Bug
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC272 Analog [ALC272 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC272 Analog [ALC272 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: joey 1731 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf0440000 irq 22'
   Mixer name : 'Realtek ALC272'
   Components : 'HDA:10ec0272,1179ff6e,00100001'
   Controls : 17
   Simple ctrls : 11
CheckboxCommand: alsa_record_playback
CheckboxSubmission: 217e57b4cdbebbc07e3f486b282ce94d
CheckboxSystem: b1865df84255b8716d3bcc269ff410d1
CheckboxTest: alsa_record_playback_alternates
Date: Mon Sep 28 12:36:18 2009
DistroRelease: Ubuntu 9.10
Package: alsa-base 1.0.20+dfsg-1ubuntu4
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-11.36-generic
SourcePackage: alsa-driver
Tags: ubuntu-unr checkbox-bug
Uname: Linux 2.6.31-11-generic i686

Revision history for this message
Joey Stanford (joey) wrote :
Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

Hi Joey,

I'm reassigning this to the linux kernel for now. I believe Manoj sent a patch upstream for this:

http://patchwork.kernel.org/patch/49477/

affects: alsa-driver (Ubuntu) → ubuntu
Changed in ubuntu:
importance: Undecided → Medium
status: New → Triaged
Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

Also adding a note that I had found patches in Hardy and forward ported them for testing in bug 389040. However, Manoj's patch referenced above is much cleaner and simpler.

https://bugs.edge.launchpad.net/ubuntu/+source/linux/+bug/389040

affects: ubuntu → linux (Ubuntu)
Revision history for this message
Joey Stanford (joey) wrote :

Tested the patch. We have sound! Built-in speakers don't turn off when the headset is plugged nor when selecting the headset as the output stream. There is sound though and that's a great step in the right direction. Mic-in remains unchanged...working perfectly.

Revision history for this message
Manoj Iyer (manjo) wrote :

Submitted patch upstream and to ukml

Changed in linux (Ubuntu):
assignee: nobody → Manoj Iyer (manjo)
status: Triaged → Incomplete
Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

I've gone ahead and marked bug 389040 as a duplicate of this bug as well.

Manoj, if you don't mind, I'm also going to submit this for a Jaunty SRU as the reporter/subscribers in bug 3890404 need this fixed for Jaunty as well.

Joey, Manoj, since you guys have access to the actual hardware, care to open a new bug (using ubuntu-bug linux) to specifically track the issue for muting the speakers when headphones are plugged in. That way the new bug will have the appropriate hw info attached. Please let us know the new bug # here. Thanks!

Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

For those of you who are running Jaunty, please test the following kernel and confirm it enables sound through the speakers. Thanks!

http://people.canonical.com/~ogasawara/lp438318/

Changed in linux (Ubuntu Jaunty):
assignee: nobody → Leann Ogasawara (leannogasawara)
importance: Undecided → Medium
status: New → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.31-11.38

---------------
linux (2.6.31-11.38) karmic; urgency=low

  [ Stefan Bader ]

  * [Upstream] acerhdf: Limit modalias matching to supported boards
    - LP: #435958

  [ Tim Gardner ]

  * [Config] Added sata_via to d-i/modules/sata-modules
    - LP: #434827
  * SAUCE: (drop after 2.6.31) Disable iwl-1000 series wireless adapters
    - LP: #439285
  * [Upstream] i915: Fix i2c init message
    - LP: #409361
  * [Config] Add sym53c8xx.ko to virtual sub-flavour
    - LP: #439415

  [ Upstream Kernel Changes ]

  * sched: Disable NEW_FAIR_SLEEPERS for now
    - LP: #436342

  * ACPI video: ignore buggy _BQC
  * ACPI video: work-around BIOS AML bug in _BQC
    - LP: #428910
  * ALSA: hda - Added quirk to enable sound on Toshiba NB200
    - LP: #438318

 -- Tim Gardner <email address hidden> Thu, 01 Oct 2009 13:52:09 -0600

Changed in linux (Ubuntu Karmic):
status: Incomplete → Fix Released
Revision history for this message
Pietro (pietro) wrote : Re: [Bug 438318] Re: [karmic] no sound on toshiba nb205

Hi, noob question. I have one of the Toshiba NB205s. I clicked the link,
saw that there are four files at the webpage. I downloaded them all, but
I just clicked on the biggest file (image) and it installed. Is that all
I needed to do? Or was I supposed to somehow include the Toshiba
NB20.patch? If so, how do I include it/incorporate it/rebuild the kernel
with it?

On Thu, 2009-10-01 at 21:34 +0000, Leann Ogasawara wrote:
> For those of you who are running Jaunty, please test the following
> kernel and confirm it enables sound through the speakers. Thanks!
>
> http://people.canonical.com/~ogasawara/lp438318/
>
> ** Changed in: linux (Ubuntu Jaunty)
> Importance: Undecided => Medium
>
> ** Changed in: linux (Ubuntu Jaunty)
> Status: New => In Progress
>
> ** Changed in: linux (Ubuntu Jaunty)
> Assignee: (unassigned) => Leann Ogasawara (leannogasawara)
>

Revision history for this message
Antonio Sánchez (antoniosanchez) wrote :

Hi Leann,

We have just test linux-image-2.6.28-15-generic_2.6.28-15.53~lp438318v1_i386.deb in Jaunty and sounds works throw headphones but don't work throw speakers.

Let us know if any other test is needed.

Revision history for this message
Pietro (pietro) wrote :

Current results:
No built-in speaker out
Consistent earphone out
Sporadic built-in mic in (worked once on Skype test call, not
Gnome-sound-recorder)
No ext mic input: cht-cht-t-t-cht-ch-ch-cht-t-t static sound.
Still don't know if I mis-installed, because I could not figure out any
steps that would incorporate the .patch file you posted.

Revision history for this message
Rainer Oliveira (raineroliveira) wrote :

I have the same test results as Antonio and Pietro: speaker sound doesnt work, while headphone does.

Hum... I dont know much about how to aply patches, but the patched kernel sugested here https://bugs.launchpad.net/ubuntu/+source/linux/+bug/389040/comments/117 works for me. This one made the speaker sound work, the headphones (including muting the sound when the phones are plugged), but i didnt test mic.

As I said, I didnt know about patches, but if that one worked, i think it's best to include it upstream.

Thanks.

Revision history for this message
Jeff Utter (jeffutter) wrote :

I am running a current Karmic (updated this morning) with nothing special in my modprobe.d and i get no sound from my speakers on my NB205 still.

$ uname -rv
2.6.31-11-generic #38-Ubuntu SMP Fri Oct 2 11:55:55 UTC 2009

Revision history for this message
Bertel King (kmetamorphosis) wrote :

I am using this laptop and my sound is also not working through the speakers. The headphone jack works, though. As does the mic. I am currently running Karmic and just finished installing updates.

Revision history for this message
Manoj Iyer (manjo) wrote :

This bugs regressed with the upstream, patch came from sound-2.6 merged by linus. I tested the patch that caused sound to break again even with the quirk applied and reported to alsa maintainer. I believe this breakage is caused by SHA 02d3332285377c9de395c2b5b792805d43923fd0

Changed in linux (Ubuntu Karmic):
status: Fix Released → In Progress
tags: added: regression-potential
Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

Hey Manjo,

I'm not convinced this would be the most appropriate fix for this but in bug 389040 I'd found some patches for this sound card and codec that were from way back in Hardy (not sure why they were never merged upstream).

http://mailman.alsa-project.org/pipermail/alsa-devel/2009-May/016917.html

And it seemed to reference a patch to enable audio:

http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-hardy-lum.git;a=commitdiff;h=7662834bb9a78d244c6d7ee43358c14c94d249c9

There also seemed to be a series of patches which followed to mute the speakers when the headphones are plugged in:

http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-hardy-lum.git;a=commitdiff;h=d47775d68efa5d80552839231fcb4f54dc254c08

And then enable the microphone:

http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-hardy-lum.git;a=commitdiff;h=cc28eee26d33fac60d598fb2269e673ba83570e9

I'd forward ported the above patches to Jaunty and had positive feedback from testers:

http://people.canonical.com/~ogasawara/lp389040/jaunty/

Unfortunately trying to forward port once more to Karmic resulted in the built in mic not functioning any longer, so they're not perfect but may help.

Revision history for this message
Rainer Oliveira (raineroliveira) wrote :

I agree with Leann.

I tested his patched kernel for karmic and, except for the internal mic that doesnt work (but an external one does), everything else worked.

I think that having sound from speakers (and from headphones) is way better than having no sound at all.

Thanks.

Revision history for this message
Joey Stanford (joey) wrote :

I don't know how relevant this is but I'll include it.

1) I did a fresh install on the nb205 using UNR Karmic. No sound.

2) netbook-launcher kept crashing after an update so I switched to desktop mode.

3) I tested Manoj's quirk patch on his custom kernel and I had sound
(as noted above)

4) Manoj's patch landed in the kernel with an alsa patch from Takashi
(alsa) and it doesn't work now (and I suspect it's the alsa patch
which fixes the HP Mini's sound).

5) Today I have sound on the headset jack but not the built-in
speakers. My built-in mic also works.

Revision history for this message
Blue (vali-dragnuta) wrote :

It seems that the sound works on speakers in ubuntu hardy.

Andy Whitcroft (apw)
Changed in linux (Ubuntu Karmic):
status: In Progress → Fix Committed
Andy Whitcroft (apw)
Changed in linux (Ubuntu Karmic):
status: Fix Committed → Fix Released
Revision history for this message
Joey Stanford (joey) wrote :

<apw> joey, so if you find its still broke move that bug back to In-Progress and just mention you talked to me and i agreed ...

Reset to in-progress.

Tested on NB-205. No change. Sound panels appear correct. There is sound on the headset jack. PA Volume Control confirms sound input. Alsamixer shows all un-muted. Tested against both output connectors. Still no audio on external speakers.

Changed in linux (Ubuntu Karmic):
status: Fix Released → In Progress
Revision history for this message
Joey Stanford (joey) wrote :

for 2.6.31-14 in Karmic

Revision history for this message
Pete Graner (pgraner) wrote :

@Joey,

We've backported 2.6.32's alsa can you install linux-backports-modules-alsa and try testing and report back here if it fixes the problem.

Thanks

~pete

Revision history for this message
Joey Stanford (joey) wrote :

@PeteG

Thanks for the new things to try!

I updated to the latest pushed karmic kernel. I enabled karmic backports and installed the alsa modules. I rebooted.

No joy. Headset jack audio is great (very loud and clear in fact) but nothing from the main speakers. External speaker sound worked on Manoj's kernel patch (alsa quirk) before applying the upstream alsa patch for the hp mini sound. When Tim sucked in upstream's changes it stopped working.

Joey Stanford (joey)
Changed in linux (Ubuntu Karmic):
status: In Progress → Fix Released
Revision history for this message
Joey Stanford (joey) wrote :

I reimaged the NB205 using the Karmic beta 386 (not UNR) and there is now sound after processing updates (which includes the kernel patches above). My old image was Alpha 6 UNR that was upgraded. I'm marking the Karmic bugtask as fix released with out prejudice in case QA or Kernel want to investigate further and reset the status. Thanks to everyone for the assistance!

Revision history for this message
Glenn Moloney (g-moloney) wrote :

Are they rolling out the fixes on UNR because my NB200 with Karmic UNR & all the updates still have no speaker sound. Headphone socket works fine. Tried starting from beta & using daily build (16/10) but still same results.

Revision history for this message
Joey Stanford (joey) wrote :

On Mon, Oct 19, 2009 at 02:25, Glenn Moloney <email address hidden> wrote:
> Are they rolling out the fixes on UNR because my NB200 with Karmic UNR &
> all the updates still have no speaker sound. Headphone socket works
> fine. Tried starting from beta & using daily build (16/10) but still
> same results.

I had some other (non-kernel) updates land and my speaker sound is now
no longer working. I'm thinking this may be a userspace issue now and
not a kernel issue...or there might be some mods clashing. I just
can't find any visible issues with it. I need to learn how to do a
more technical troubleshooting with alsa.

Revision history for this message
Glenn Moloney (g-moloney) wrote :

Thanks Joey. Hopefully it will be resolved without being too much of a headache.
Cheers

Revision history for this message
Joey Stanford (joey) wrote :

On Tue, Oct 20, 2009 at 04:21, Glenn Moloney <email address hidden> wrote:
> Thanks Joey. Hopefully it will be resolved without being too much of a headache.

I know that sound in the Kernel is currently in a sad state and that
between Karmic and Lucid it will probably be sorted out.

Revision history for this message
jeroenimo (jeroenimo) wrote :

Here on my nb200 also I have not had sound from internal speaker working (it does work with OSS4) the headphonejack an internal speaker work (tested with skype)

I tested:
2.6.31-6-generic
2.6.31-10-generic
2.6.31-14-generic
2.6.32-020632rc5-generic

And they all have the same "non working" internal speaker failing..

grtz J.

Revision history for this message
Rainer Oliveira (raineroliveira) wrote :

Using the linux-image-2.6.31-10-generic_2.6.31-10.30~lp389040oga1_i386.deb from http://people.canonical.com/~ogasawara/lp389040/karmic/ as in bug #389040 (https://bugs.launchpad.net/ubuntu/+source/linux/+bug/389040?comments=all) made the internal speaker sound work for me (Karmic as in october 15th). So, I dont think it's a userspace issue... I think.

Anyway, with Lean's kernel internal speaker works, the headphones work, but the internal mic doesn't (although using a external mic work).

I guess it could be a good idea to use Lean's kernel patch in upstream (at least untill another solution is found), as Karmic release is on the way and no sound from the speakers will be a show-stopper to many users of this beautiful netbook (and this bug seems to affect the nb200 model as well).

Revision history for this message
jdblair (jdb) wrote :

I can confirm that using Lean's kernel the internal speaker works, but the microphone no longer works.

Revision history for this message
Jeffrey Evans (kingofahyon) wrote :

I tried Lean's kernel on a nb205-n310/bn and can confirm that the external speakers work and the internal microphone works as well.

Revision history for this message
Jeffrey Evans (kingofahyon) wrote :

Scratch that last comment, after another reboot the internal microphone does not work.

Revision history for this message
Joey Stanford (joey) wrote :

based on the comments above, I've reset the karmic portion back to confirmed. Leann et al can over-ride this and set it back to fix released. With the Karmic RC updates, my ext speaker sound is gone. I think Manoj was going to do some testing but I know the team has been busy trying to get the other 500 items out of the door for karmic.

Changed in linux (Ubuntu Karmic):
status: Fix Released → Confirmed
Revision history for this message
Rainer Oliveira (raineroliveira) wrote :

I guess it's ok.
Surely, it will be fixed in a post-release upgrade, but I guess it would be better if it could be mentioned in the 9.10 release notes (known issues) for the users to know it's a known problem that will be fixed soon (if they have time to write it, of course) =)

I'm really excited with the 9.10 release! As a brazilian friend of mine says: "Go Koala!"

Thanks.

Revision history for this message
Mark Cariaga (mzc) wrote :

This also affects Acer Aspire One D250. My internal microphone does not work properly

Stefan Bader (smb)
Changed in linux (Ubuntu Jaunty):
status: In Progress → Fix Committed
Revision history for this message
Mark Cariaga (mzc) wrote :

this also affects MSI Wind U100 and AAO 110 8gb. just configure this two netbooks. same issue as my D250

Revision history for this message
Martin Pitt (pitti) wrote : Please test proposed package

Accepted linux into jaunty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Revision history for this message
Simon Jagoe (azriphale) wrote :

I just wiped Karmic from my NB200 in favour of Jaunty, and I can confirm that everything seems good with the proposed update.

* Sound from speakers: Works (although a bit soft for system sounds, Skype was good)
* Sound from headphones: Works
* Plugging in headphones disables the speaker
* Internal mic: Works (I just had to enable capture, which I did through alsamixer)
* I do not have an external mic to test.

Revision history for this message
Mark Cariaga (mzc) wrote :

I also seen backport drivers for karmic in proposed. please advise if it's for the same bug. i want to test it as well.

Martin Pitt (pitti)
tags: added: verification-done
removed: verification-needed
Changed in linux (Ubuntu Jaunty):
status: Fix Committed → Fix Released
Changed in linux (Ubuntu):
status: Confirmed → Fix Released
status: Fix Released → Fix Committed
status: Fix Committed → New
status: New → Fix Released
status: Fix Released → Confirmed
tags: added: regression-release
removed: regression-potential
tags: added: karmic
goto (gotolaunchpad)
description: updated
26 comments hidden view all 106 comments
Revision history for this message
Jeremy Foshee (jeremyfoshee) wrote :

Joey,
     Thanks for the verification. I'll set the bug to Fix Committed.

Busen,
      I doubt this will get a backport as it does not meet SRU requirements.

-JFo

Changed in linux (Ubuntu):
status: Confirmed → Fix Committed
status: Fix Committed → Confirmed
Changed in linux (Ubuntu Lucid):
status: Confirmed → Fix Committed
Revision history for this message
Jeremy Foshee (jeremyfoshee) wrote :

actually, that should have been Fix Released. Adjusting.

-JFo

Changed in linux (Ubuntu Lucid):
status: Fix Committed → Fix Released
Revision history for this message
Jeremy Foshee (jeremyfoshee) wrote :

Setting Karmic task as Won't Fix unless Manoj plans to submit an SRU.

-JFo

Changed in linux (Ubuntu Karmic):
status: Confirmed → Won't Fix
Revision history for this message
Joey Stanford (joey) wrote : Re: [Bug 438318] Re: [karmic] no sound on toshiba nb205

An updated landed a few weeks ago which clobbered this. It's now no
longer working in the current Lucid build.

Revision history for this message
Mark Cariaga (mzc) wrote :

Hi joey

Does this mean a regression? The bug is back on the current build?

On Feb 22, 2010, at 1:18 PM, Joey Stanford <email address hidden> wrote:

> An updated landed a few weeks ago which clobbered this. It's now no
> longer working in the current Lucid build.
>
> --
> [karmic] no sound on toshiba nb205
> https://bugs.launchpad.net/bugs/438318
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in “linux” package in Ubuntu: Fix Released
> Status in “linux” source package in Lucid: Fix Released
> Status in “linux” source package in Jaunty: Fix Released
> Status in “linux” source package in Karmic: Won't Fix
>
> Bug description:
> 00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High
> Definition Audio Controller (rev 02)
>
> ProblemType: Bug
> AplayDevices:
> **** List of PLAYBACK Hardware Devices ****
> card 0: Intel [HDA Intel], device 0: ALC272 Analog [ALC272 Analog]
> Subdevices: 1/1
> Subdevice #0: subdevice #0
> Architecture: i386
> ArecordDevices:
> **** List of CAPTURE Hardware Devices ****
> card 0: Intel [HDA Intel], device 0: ALC272 Analog [ALC272 Analog]
> Subdevices: 1/1
> Subdevice #0: subdevice #0
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC0: joey 1731 F.... pulseaudio
> Card0.Amixer.info:
> Card hw:0 'Intel'/'HDA Intel at 0xf0440000 irq 22'
> Mixer name : 'Realtek ALC272'
> Components : 'HDA:10ec0272,1179ff6e,00100001'
> Controls : 17
> Simple ctrls : 11
> CheckboxCommand: alsa_record_playback
> CheckboxSubmission: 217e57b4cdbebbc07e3f486b282ce94d
> CheckboxSystem: b1865df84255b8716d3bcc269ff410d1
> CheckboxTest: alsa_record_playback_alternates
> Date: Mon Sep 28 12:36:18 2009
> DistroRelease: Ubuntu 9.10
> Package: alsa-base 1.0.20+dfsg-1ubuntu4
> PackageArchitecture: all
> ProcEnviron:
> SHELL=/bin/bash
> LANG=en_US.UTF-8
> ProcVersionSignature: Ubuntu 2.6.31-11.36-generic
> SourcePackage: alsa-driver
> Tags: ubuntu-unr checkbox-bug
> Uname: Linux 2.6.31-11-generic i686
>
>
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/438318/+subscribe

Revision history for this message
Joey Stanford (joey) wrote :

Yes, that's my opinion mzc. I've alerted JJ about it. nxvl also
reports this is the case.

Revision history for this message
Jeremy Foshee (jeremyfoshee) wrote :

Joey,
     I'm looking into this as well. I'll follow up with JJ.

-JFo

tags: added: regression-update
Revision history for this message
Jeremy Foshee (jeremyfoshee) wrote :

changing back to Confirmed so it will show up in my view.

Changed in linux (Ubuntu Lucid):
status: Fix Released → Confirmed
Revision history for this message
Stephen (sc3fan) wrote :

Running Lucid on 2.6.32-16-generic and adding the fix to "the end of /etc/modprobe.d/alsa-base.conf." from post #53 worked. After going into pavucontrol (Pulse Audio Volume Control), the Output Devices tab and changing the Internal Audio Analog Stereo Port to "Analog Speakers" from "Analog Output" or "Analog Headphones."

Revision history for this message
Joey Stanford (joey) wrote :

The instructions in comment #75 worked for me!

Revision history for this message
Sean Fidler (seantlfidler) wrote :

This is working for me now too with the above fix on kernel 2.6.32-16. It appears to have also corrected the wonky volume settings for headphone output as well which is a nice perk. I used to only get reasonable volume levels at about 7% output but not the volume slider has a much more useful range.

Thanks!

Revision history for this message
John Logan (john-loganfamily) wrote :

The above didn't work for me. I upgraded to lucid but I don't have "Analogue Speakers" as an option. I am running on a Toshiba nb200-10g, lucid 2.6.32-16-generic.

Revision history for this message
Maxi Belino (maxi-belino) wrote :

I have a toshiba NB200 and sounds works from headphones but without them there's no sound, internal speaker is not working
My system:
Ubuntu Netbook remix
Linux ubuntu 2.6.31-20-generic #58-Ubuntu SMP Fri Mar 12 05:23:09 UTC 2010 i686 GNU/Linux

should i wait for patches /upgrades or i just follow the tips to fix this ?
thanks

Revision history for this message
John Logan (john-loganfamily) wrote :

Maxi Belino, I have a nb200 and none of the tips have worked for me on 9.04 or lucid. I too have my fingers crossed that this issue will disappear too since apart from this small issue the netbook is virtually perfect for ubuntu.

Revision history for this message
John Logan (john-loganfamily) wrote :

I finally got the external speaker working on my nb200-10g. I had to do this on lucid (ubuntu 10.4)

gksudo gedit /etc/modprobe.d/alsa-base.conf

When the file is open, please add the following 3 lines to the end of the file after "options snd-pcsp index=-2"

alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel model=toshiba-nb200

Then open a terminal and do the following:

wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.34-rc1/linux-headers-2.6.34-020634rc1-generic_2.6.34-020634rc1_i386.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.34-rc1/linux-headers-2.6.34-020634rc1_2.6.34-020634rc1_all.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.34-rc1/linux-image-2.6.34-020634rc1-generic_2.6.34-020634rc1_i386.deb

sudo dpkg -i linux-headers-2.6.34-020634rc1_2.6.34-020634rc1_all.deb
sudo dpkg -i linux-headers-2.6.34-020634rc1-generic_2.6.34-020634rc1_i386.deb
sudo dpkg -i linux-image-2.6.34-020634rc1-generic_2.6.34-020634rc1_i386.deb

if grub2-update doesn't automatically run after the last command then do sudo update-grub

reboot and you should have sound (if you like me have been messing with the outputs in the volume control you might need to open it up and select Speakers [ i only had headphones and output before doing this])

I am currently listening to "Yazoo - Only You" through the external speakers (probably shouldn't have botherd ;)

Revision history for this message
John Logan (john-loganfamily) wrote :

Sorry, I meant internal speaker where I said external speaker above.

Revision history for this message
Pietro (pietro) wrote :

Hi this is Pietro, still semi-noob wanting to know:
If I follow Kristoffer's suggestion, and install Kernel 2.6.32 the noob way (via gdebi), will this cause a problem when updating to Lucid? 2.6.32 is not in the standard repos of Karmic (checked via Synaptic), and gdebi warns that I probably should not install a new kernel via gdebi.
If this will NOT cause problems, Kristoffer, can you please advise about the most kosher way to install this newer kernel? I.e., post a sequence of shell commands, or a quick step-through via gdebi, or an adjustment to the repos for Synaptic (under Karmic) to make the system package manager aware of this minor detour from a standard install.
If this WILL cause problems in updating to Lucid later this month, can you please suggest a quick way to 'undo the deviance' so that we can resume with standard system updates?

Sorry if this seems off-topic, but a number of posts confirm Kristoffer's fix in post #53. And if I read them correctly, posts #70 and later suggest that we will still need this fix after Lucid is released. Thanks.

Revision history for this message
Kate Henriksson (khenriksson) wrote :

Pietro,

What I've taken to doing is using the official Lucid kernel, currently found here <http://packages.ubuntu.com/lucid/linux-image-2.6.32-19-generic> and downloadable from any of the mirrors here <http://packages.ubuntu.com/lucid/i386/linux-image-2.6.32-19-generic/download>.

I don't know of any reason that this kernel should cause a problem on upgrade, since it is in fact the proper Lucid kernel. My recommendation is to just download the deb file, double click on it, and click through any warnings to just install it via GDebi (I don't remember the exact sequence off the top of my head, but it should be straightforward). If you're worried about it you can always uninstall it via Synaptic and then restart before upgrading to Lucid.

This unfortunately isn't something you can get by changing the repositories because then all of the Lucid packages would come along with it, but the package manager is still aware of the package and can uninstall it cleanly the same as any other.

Revision history for this message
Maxi Belino (maxi-belino) wrote :

Hi John Logan,

Thank you very much for your tips.
Now it's working fine.

Now my system (Ubuntu Netbook Remix, on Toshiba NB200) reports:

# uname -a

Linux ubuntu 2.6.34-020634rc1-generic #020634rc1 SMP Tue Mar 9 10:59:29 UTC 2010 i686 GNU/Linux

Hope it helps to many more people.

I wonder if this will cause mess with updates, etc...?

thanks again!

Maxi

Revision history for this message
Heather L. Glahn (hlglahn) wrote :

I'm sorry, but I am very new to anything this in-depth with ubuntu. I am currently working on my friend's Toshiba NB 205 and cannot get the sound to work. What is the fix and how do I get it to work? I do not understand the information in this post.

Thanks.

Revision history for this message
John Logan (john-loganfamily) wrote :

Hi Heather,
I know how you feel, the good news is that it looks like whatever issue it is will be fixed in later versions/updates of Ubuntu since all my fix does it move the kernel (the heart of any Linux system) onto a later version (still under development). So you can if you want you can just use earphones and wait (it might be a long wait - probably after the roll out of Ubuntu 10.4).

However if you feel like being brave try to follow my instructions in post 81, please note that moving the kernel on like this can introduce new quirks which you may like even less than having no sound.

But don't let that put you off because thanks to the way Linux works you can select exactly which kernel you want to use by holding down the shift key when the computer starts.

Revision history for this message
bushnoh (bushnoh) wrote :

Sound works perfectly in beta 2 by adding

options snd-hda-intel index=0 model=auto

to the end of /etc/modprobe.d/alsa-base.conf

Revision history for this message
Pietro (pietro) wrote :

Hi, this is Pietro checking back in to confirm that Kristofer's fix worked for me in 9.10, and works (and is still necessary) in 10.04. At least for my Toshiba Netbook NB205. So if you have installed or just updated to 10.04 Lucid, here are instructions to get sound working the noob way:
Go to: Applications > Accessories > Terminal.
This will open what is called a "shell" window, and in the new window it will display [your-username]@[your-computer-name] followed by a prompt.
Here you can type in the following text:

sudo gedit /etc/modprobe.d/alsa-base.conf

Hit <ENTER>, and this command starts the text editor "Gedit," and directs it to open the file "alsa-base.conf" within the directories "/etc/modprobe.d". Once Gedit opens the file, scroll down to the bottom of the file and paste (or type) in the following text:

options snd-hda-intel index=0 model=auto

Save, quit Gedit, type "exit" in the Terminal window, close other apps, and reboot. Later you can change the Preferences in the Terminal program so that you can cut-and-paste shell commands from web pages like this, But I figure you want to get up-and-running right now, and will tinker with other configurations as needed later. Cheers!

Revision history for this message
carlomejia (carlomejia) wrote :

Thaks Pietro and Kristofer,

Im Carlos from Colombia southamerica, lucid lynx and toshiba nb205 user, the get along now, I missed the sound but now this is perfect.

Revision history for this message
Daniel Arndt (danielarndt) wrote :

Adding

"options snd-hda-intel index=0 model=auto"

to the end of my toshiba nb200 fixed sound. Different notebook model but same sound card. Headphone jack works correctly and mutes speakers when headphone are in. Internal microphone works (not sure if that is related at all but obviously couldn't test it before).

Thanks!

Revision history for this message
i_surf_the_turf (lefteris-loukisas) wrote :

Hello

I followed the instructions on post 81 and now ubuntu won't start!

How can I reverse it?

Thanks!

Revision history for this message
i_surf_the_turf (lefteris-loukisas) wrote :

I fixed it on my own. I ran the second (older) version in GRUB and it booted. I immediately changed the alsa configuration file, leaving the last line only, and changing the ending to "auto" as dictated by the other posts.

Afterwards, I found the 3 extra packages through the synaptic package manager and removed them completely. Now I'll restart and hopefully all will be well.

Revision history for this message
Nicolás Pereyra Molinas (pereyra) wrote :

I have a NB205-N312/BL. I'm use LinuxMint Isadora. I have written

options snd-hda-intel index=0 model=auto

to the end of /etc/modprobe.d/alsa-base.conf.

And then I rebooted the netbook

uname -a
Linux npereyra-netbook 2.6.32-22-generic #33-Ubuntu SMP Wed Apr 28 13:27:30 UTC 2010 i686 GNU/Linux

Revision history for this message
Russell Fields (r-russellfields) wrote :

i WAS ABLE TO OPEN THE FILE \etc\modprobe.d\alsa-base.conf but was unable to save in this directory is there a way to edit the file so I can try the patches. Thanks R

its a toshiba nb205-330wh, I am new to ubuntu but this is netbook remix 10.04
.

Revision history for this message
i_surf_the_turf (lefteris-loukisas) wrote :

Hey russellfields!

I know that it's frustrating but what you need to do is open a terminal and type sudo gedit \etc\modprobe.d\alsa-base.conf

What that does is to give you administrator privilages so after editing you can actually save the file. You can see that indicated with an asterisk in the title of the window.

If you want my opinion, it is a shame that there is no graphic UI function around that.

Revision history for this message
Tetsuo6995 (tetsuo6995) wrote :

Hi !

Am i the only one to think that this never ending bug is wrong ?
The fix is well known since a long time. Even before lucid was released we already knew how to fix that bug.

And it's still not working if you don't patch modprobe.d manually...
Maybe the bug is not important, maybe it's the bug correction procedure that is defective :/
I don't really know what the SRU is so i won't insist more. But bugs that can be fixed by ading one single line in a conf file shoudn't be that long to fix.

Anyway concerning the actual fix #89:
When you want to sudo a graphical app like gedit it's better to use "gksudo" which is exactly made for this purpose:

"gksu is a frontend to su and gksudo is a frontend to sudo. Their primary purpose is to run graphical commands that need root without the need to run an X terminal emulator and using su directly."

so it's more :

gksudo gedit /etc/modprobe.d/alsa-base.conf

i know it works perfectly with sudo but it's better to use the correct tool anyway :)

Revision history for this message
Daniel Dräs (g-kar) wrote :

Hi everyone,
got a pre-owned Toshiba NB205 and installed lucid on it. No sound from the speakers. I tried quite a lot, included the modprode-settings, still no sound.
Will this issue be moved forward? I can see that the bug is open since long months already without a generally available solution.
Thanks!
Figg

Revision history for this message
Daniel Dräs (g-kar) wrote :

huuups. Figg should be Fogg which is my username typically :)

Revision history for this message
Daniel Dräs (g-kar) wrote :

hi all,
found a solution that works for me. Don't know why I did not see this in the first place. in the audio control panel output tab i can choose from 'audio stereo', 'audio speakers' and 'audio headphones'. it was defaulted to audio stereo. I switched to audio speakers and now everything works as it should.
Cheers,
Fogg

Revision history for this message
Daniel Dräs (g-kar) wrote :

Some more info, sound works out of the box in maverick! Great job!

Revision history for this message
Brad Figg (brad-figg) wrote :

From the comments it seems that people have found the root of their problem to be with the default configuration and that the speakers on this model of toshiba do in fact work. If one of these solutions does not work for you please change the status back to confirmed. (or better yet, is to open a new bug)

Changed in linux (Ubuntu Lucid):
status: Confirmed → Incomplete
Brad Figg (brad-figg)
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
Brad Figg (brad-figg) wrote : Unsupported series, setting status to "Won't Fix".

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Incomplete → Won't Fix
2 comments hidden view all 106 comments
Revision history for this message
Rolf Leggewie (r0lf) wrote :

lucid has seen the end of its life and is no longer receiving any updates. Marking the lucid task for this ticket as "Won't Fix".

Changed in linux (Ubuntu Lucid):
status: Incomplete → Won't Fix
Displaying first 40 and last 40 comments. View all 106 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions